欢迎使用H3C CAS CVM虚拟化管理系统帮助中心

新华三技术有限公司

http://www.h3c.com

产品版本：E0710

Copyright © 2012-2020 新华三技术有限公司及其许可者 版权所有，保留一切权利。


前言

读者对象

本手册主要适用于如下工程师：

  • 网络规划人员

  • 现场技术支持与维护人员

  • 负责网络配置和维护的网络管理员

本书约定

1. 图形界面格式约定

格 式 | 意 义
< > | 带尖括号“< >”表示按钮名，如“单击<确定>按钮”。
[ ] | 带方括号“[ ]”表示窗口名、菜单名和数据表，如“弹出[新建用户]窗口”。
/ | 多级菜单用“/”隔开。如[文件/新建/文件夹]多级菜单表示[文件]菜单下的[新建]子菜单下的[文件夹]菜单项。

2. 各类标志

本书还采用各种醒目标志来表示在操作过程中应该特别注意的地方，这些标志的意义如下：

该标志后的注释需给予格外关注，不当的操作可能会对人身造成伤害。

提醒操作中应注意的事项，不当的操作可能会导致数据丢失或者设备损坏。

为确保设备配置成功或者正常工作而需要特别关注的操作或信息。

对操作内容的描述进行必要的补充和说明。

配置、操作、或使用设备的技巧、小窍门。

3. 示例约定

由于版本、配置不同、版本升级等原因，可能造成本手册中的内容与用户使用的版本显示信息不一致。实际使用中请以版本显示的内容为准。


H3C CAS 介绍

H3C CAS云计算管理平台（Cloud Automation System，简称CAS）是构建云计算基础架构的管理软件，它为数据中心云计算基础架构提供完善的虚拟化和云业务运营管理解决方案，用于实现数据中心云计算环境的中央管理控制。通过云计算管理平台简洁的管理界面，操作员可以轻松地统一管理数据中心的所有物理资源和虚拟资源，不仅能提高操作员的管控能力、简化日常例行工作，还可以降低IT环境的复杂度和运维成本。


平台架构

H3C CAS云计算管理平台的架构如下图所示：


组件介绍

CAS由四个组件构成：CVK、CVM、CIC、SSV。

CIC和SSV组件暂不支持在ARM架构的主机上安装。

  • CVK（Cloud Virtualization Kernel，虚拟化内核平台）

运行在基础设施层和上层客户操作系统之间的虚拟化内核软件。针对上层客户操作系统对底层硬件资源的访问，CVK用于屏蔽底层异构硬件之间的差异性，消除上层客户操作系统对硬件设备以及驱动的依赖，同时增强了虚拟化运行环境中的硬件兼容性、高可靠性、高可用性、可扩展性、性能优化等功能。

  • CVM（Cloud Virtualization Manager，虚拟化管理系统）

主要实现对数据中心内的计算、网络和存储等硬件资源的软件虚拟化管理，对上层应用提供自动化服务。其业务范围包括：虚拟计算、虚拟网络、虚拟存储、高可用性（HA）、动态资源调度（DRS）、虚拟机容灾与备份、虚拟机模板管理、集群文件系统、虚拟交换机策略等。

  • CIC（Cloud Intelligence Center，云业务管理中心）

由一系列云基础业务模块组成，通过将基础架构资源（包括计算、存储和网络）及其相关策略整合成虚拟数据中心资源池，并允许用户按需消费这些资源，从而构建安全的多租户混合云。其业务范围包括：组织（虚拟数据中心）、多租户数据和业务安全、云业务工作流、自助式服务门户、兼容OpenStack的REST API接口等。

  • SSV（User Self-Service Portal，用户自助服务门户）

通过云业务电子流的方式申请用户所需的云资源，构建以业务为中心的“IT即服务”模型。借助自助服务门户，用户可以便捷地按需申请云主机、云硬盘、云网络等资源，并通过远程连接协议（RDP或VNC）访问自己专属的云主机。

本联机帮助仅介绍CAS CVM虚拟化管理系统的内容。


界面布局

CVM界面布局如下：

  • 管理链接：用于显示登录信息、配置界面皮肤、显示告警信息、查看任务台、查看帮助、访问技术论坛、下载资料、查看版本信息、以及注销用户。

  • 搜索栏：实现了对主机和虚拟机的模糊查询功能。

  • 一键操作管理：提供健康巡检、资源分析、存储清理、资源导出、虚拟机还原和僵尸虚机管理功能。

  • 导航树：包含了系统所有功能的菜单项，选择不同的菜单项后，右侧面板视图区出现相应的操作页面。导航树可以根据实际需要收缩成菜单形式，以增加右侧视图区的可见大小，方便管理和监控相关数据。

  • 快速工具栏：提供常用的功能链接。在导航树中选择不同的菜单项，快捷工具栏中显示相应的功能链接。

  • 功能页签：选择不同的功能页签，进入相应的功能页面。

  • 面板视图区：显示当前的操作信息，并提供相应的功能链接。


典型应用

场景描述

某企业在内部私有数据中心实行虚拟化建设，采用服务器虚拟化技术整合内部服务器资源，希望通过服务器虚拟化技术，提高现有数据中心服务器硬件资源的利用率，有效抑制IT资源的不断膨胀的问题，降低客户的采购成本和维护成本，同时节省IT机房的占地空间以及供电和冷却等运营开支。

场景分析

根据公司的要求，需要对部署在数据中心内部的服务器进行统一集中的管理，并将业务应用系统全部部署在虚拟化环境中，其多个分散的分支机构、办事处和合作伙伴单位能像未虚拟化一样便捷地访问这些业务应用系统。为实现这一目的，利用虚拟化管理平台的服务器管理能力和虚拟化能力，通过管理界面对所有的服务器硬件资源进行集中管理，并将公司的业务系统逐一部署到虚拟化环境中。

组网

‌

业务规划

1. 网络规划

在系统中，服务器涉及管理网络、业务网络、存储网络、备份网络和迁移网络的规划，并且各网络需要相互独立。至少需要规划管理网络、业务网络和存储网络。

2. 存储规划

  • 本地磁盘规划

如果服务器使用了两块本地磁盘，建议对这两块本地磁盘做RAID 1。如果服务器使用了两块以上的本地磁盘，则建议对本地磁盘做RAID 5。

  • 外接存储规划

系统支持IP SAN和FC SAN的存储设备，建议对存储设备做RAID 5或者RAID 6。

系统最大支持64TB的共享文件系统，因此在规划存储设备时最大可以规划64TB的存储卷，推荐分配10TB~64TB的存储卷。

3. 主机池、集群、主机和共享文件系统规划

  • 一个主机池不建议超过4个HA集群；

  • 每个HA集群下不建议超过32台主机；

  • 每个集群不建议超过10个共享文件系统；

  • 共享文件系统存储卷不建议超过64TB；

  • 一个共享文件系统仅在一个集群下使用。

配置流程


操作流程

本快速入门是为了引导初次使用CAS的操作员快速的实现数据中心的基础设施的管理。

操作 | 描述
安装部署 | 云计算管理平台的安装与部署方式，请参见《H3C CAS安装指导》手册。
操作员权限设置 | 可选。 为确保管理安全性，强烈建议系统管理员在首次登录系统后，首先修改默认的admin操作员的密码，然后根据实际情况创建拥有不同权限的操作员，具体请参见操作员管理。
搭建双机热备 | 可选。 双机热备功能是对管理节点进行双机热备配置；当主管理节点发生故障时，通过主备管理节点的切换，管理节点可以对外正常提供服务。通过配置双机热备可以提高管理平台的可靠性。详细操作请参见双机热备配置指导。
License注册 | 未注册的云计算管理平台可以试用180天，试用版在功能上与正式版完全相同，用户可以通过获取授权并注册，解除试用时间限制。 详细操作请参见《H3C CAS软件注册指导》手册。
配置云资源 | 将数据数据中心内的硬件基础设施，包括服务器系统、网络和存储设备等，添加到系统中，作为云资源进行统一管理，提进给上层虚拟机使用，并进行时间服务器等初始配置。
配置虚拟机 | 根据业务需求创建符合规格的虚拟机，并配置虚拟机。
配置管理平台备份 | 配置系统备份，将系统中的数据和配置文件备份到远端服务器。


配置计算资源

配置NTP服务器

云计算管理平台中，虚拟化管理系统（CVM）主机和虚拟化内核平台（CVK）主机之间的系统时间必须保持一致，可以通过配置NTP服务器实现。

安装完管理平台后，系统默认开启了NTP服务，建议将虚拟化管理系统主机作为NTP的服务端，其他虚拟化内核平台主机作为NTP的客户端，与管理系统的主机时间保持一致（双机热备环境时使用虚IP）。

  1. 单击[云资源>更多操作>NTP时间服务器]菜单项。

  2. 在弹出的[设置NTP时间服务器]对话框中，输入虚拟化管理系统主机的IP地址（管理系统双机热备环境时使用虚IP），点击<确定>按钮即完成NTP配置。

配置主机池

主机池是一个逻辑概念，用于管理数据中心内的集群与主机。主机可以存在于主机池中，也可以加入集群。未加入集群的主机全部在主机池中，通过主机池对其进行管理。默认情况下，管理系统中没有任何主机池，需要手工在云资源中增加主机池。

  1. 单击[云资源>增加主机池]，在弹出的[增加主机池]对话框中输入主机池名“HostPool”，然后点击<确定>按钮。

配置集群

集群是由物理主机和虚拟机组成的计算资源集合，其目的是使管理员可以像管理单个实体一样轻松地管理多个主机和虚拟机，从而降低管理的复杂度，同时对集群内的主机和虚拟机状态进行监测。当集群启用了HA后，如果一台服务器主机出现故障，运行于这台主机上的所有虚拟机都可以在集群中的其它主机上重新启动。

默认情况下，管理系统中没有任何集群，需要手工增加集群到主机池中。

  1. 在主机池“HostPool”页面，点击<增加集群>按钮。

  2. 配置基本信息。输入集群名“Cluster”，选择“启用HA”功能，然后点击<下一步>按钮。如不开启集群HA，可直接点击<完成>按钮直接增加集群。

  3. 设置HA策略。

  • 生效最小节点数：配置集群中高可靠性正常运行所需的最小主机数。如果集群内正常运行的主机数量小于该参数时，虚拟机将无法进行HA故障迁移。

  • HA资源预留：为HA保留一定的资源（CPU、内存）。当集群剩余的资源低于设置的比例时，则不能进行如下操作：继续启动集群内虚拟机、将虚拟机还原到运行状态、将运行状态虚拟机迁入集群。

  4. 设置是否开启计算DRS和存储DRS功能。DRS功能可以自动管理虚拟机到主机/存储的分配，为平衡负载和执行资源分配策略而自动进行虚拟机或存储的迁移。设置完成后点击<完成>按钮，增加集群。

配置主机

主机指运行了虚拟化软件的实体物理服务器。主机的作用是给虚拟机提供物理硬件环境，有时也称为“宿主”。完成主机池或集群的添加后，管理员需要手工将指定的物理主机添加到主机池或集群。

为了确保运行在主机上的虚拟机的性能与可靠性，管理系统对主机的硬件有如下要求：

要求主机的CPU支持Intel-VT或AMD-V等硬件辅助虚拟化技术（管理服务器的CPU无此要求）；对于ARM架构的主机，CPU要求为ARM 8.1及其以上CPU，且支持虚拟化主机扩展VHE。内存不少于16GB，本地磁盘容量不少于300GB，物理网卡不少于4个千兆以太网卡，DVD光驱不少于1个。

  1. 在集群[Cluster]页面，单击<增加主机>按钮，弹出增加主机对话框。

  2. 在弹出的增加主机对话框中输入虚拟化内核平台主机的“IP地址”和“密码”。

  3. 增加主机完成后，在集群[Cluster]下显示新增加的主机，在主机的“概要”页面显示主机运行的管理平台版本等信息。


配置网络

虚拟交换机是构成虚拟化管理平台网络的关键角色，是指通过软件模拟的、具有实体交换机系统功能的网络平台。虚拟交换机的运行方式与物理以太网交换机十分相似。它检测与其虚拟端口逻辑连接的虚拟机信息，并通过此信息向正确的虚拟机转发流量。虚拟交换机通过绑定主机上的物理网卡，可以实现主机、虚拟机与外部物理网络的连接。

将主机添加到主机池或集群后，需要配置主机的虚拟交换机。管理平台网络中包括了管理网、存储网和业务网，分别对应管理虚拟交换机、存储虚拟交换机和业务虚拟交换机。安装完管理平台软件后，默认配置了管理网虚拟交换机“vswitch0”，存储虚拟交换机和业务虚拟交换机需要根据规划手动配置。

  1. 在集群[cluster]页面，选择[虚拟交换机]页签，单击<增加虚拟交换机>按钮，弹出增加虚拟交换机对话框。

  2. 配置基本信息。在“名称”栏输入规划的存储虚拟交换机名称“stor”，“转发模式”栏选择“VEB”时，“VLAN ID”栏根据实际规划配置，然后单击<下一步>按钮。

  3. 配置主机网络。勾选需要增加虚拟交换机的主机，然后单击<确定>返回配置主机网络对话框。

  4. 配置物理接口。单击右侧操作列的配置物理接口图标 [image] ，在弹出的配置物理接口对话框中，选择规划的存储虚拟交换机的网口，在“IP地址”栏和“子网掩码”栏输入规划的IP地址和子网掩码信息。需要为所有主机都配置物理接口。

一个主机只能配置一个网关。如果配置多个网关，将有可能导致不可预知的问题。

  1. 如不需要设置物理接口的链路聚合则直接单击<完成>按钮。

  2. 也可以根据规划选择多网卡进行链路聚合模式及负载分担模式设置（可选）。

  • 根据规划选择多个物理接口后，单击<下一步>按钮。

  • 根据需要设置物理接口的配置模式，单击<完成>按钮，完成物理接口配置。

· 与虚拟交换机连接的物理交换机上需要配置相应的链路聚合，否则将有可能导致虚拟化内核平台不可用。

· 如果虚拟交换机配置了“动态链路聚合”，则连接的物理交换机上必须配置动态聚合。

· 如果虚机交换机配置了“静态链路聚合”，且负载分担模式为“基本负载分担”或者“高级负载分担”，则物理交换机上应配置静态聚合；负载分担模式为“主备负载分担”，则物理交换机上不应该配置聚合。

· 推荐使用“主备负载分担”或“基本负载分担”，不建议使用“高级负载分担。


配置存储池

管理平台安装完成后，默认已存在两个“本地文件目录”类型的“isopool”和“defaultpool” 存储池。“isopool”存储池主要存放操作系统的ISO安装文件，“defaultpool”存储池主要存放虚拟机磁盘文件。

虚拟化管理系统支持“LVM本地存储卷”、“iSCSI网络存储”、“FC网络存储”、“本地文件目录”、“NFS网络文件系统”、“共享文件系统”和“Windows系统共享目录”等类型的存储池，推荐使用“共享文件系统”类型。

虚拟化管理系统的HA功能依赖于共享存储，虚拟机的磁盘文件存放在“共享文件系统”类型的存储池中。系统支持IP SAN和FC SAN共享存储，因此共享文件系统也被分为 “iSCSI共享文件系统”和“FC共享文件系统”两种类型。

· 一个共享文件系统限制在一个集群中使用。

· 如果虚拟机对磁盘IO有较高要求，可以使用“iSCSI网络存储”、“FC网络存储”的存储池，虚拟机通过块设备方式使用该存储池，比如医院的HIS系统。

本小节以“iSCSI共享文件系统”、“FC共享文件系统”、“iSCSI网络存储”和“FC网络存储”为例介绍存储池的配置。

存储侧创建存储卷

在管理平台中添加存储池前，需要在存储设备侧根据规划创建存储卷并分配给虚拟化内核平台主机。此处以P5000为例介绍iSCSI共享文件系统的配置。

· 创建存储卷时推荐使用“厚配置”模式（即“完全模式”）。

· P5000共享存储创建存储卷时不允许使用“网络RAID5”，因为“网络RAID5”模式使用“精简”模式。首先会以“网络RAID10”的方式存放数据，然后在转换为“网络RAID5”方式，会影响共享存储的性能。

  1. 根据规划，在P5000共享存储设备上创建500GB的卷“sharefile”。

  2. 将创建的卷分配给虚拟化内核平台主机。

iSCSI共享文件系统配置

服务器虚拟化内核平台主机和IP SAN共享存储使用iSCSI协议连接，因此需要为主机和IP SAN共享存储分别配置Initiator和Target信息。

为了提高存储数据的读写效率，建议使用单独的物理交换机连接主机和IP SAN共享存储。

  1. 修改服务器Initiator信息。在主机的“存储适配器”页面，选择“Open-iSCSI”，然后单击<修改>按钮。

主机安装完云计算管理平台软件后，默认存在一个Initiator，但是该Initiator复杂，可以根据规划进行修改。

  2. 在弹出的设置标识符对话框输入规划的Initiator信息，然后单击<确定>按钮。

  3. 主机池下增加共享文件系统配置信息。在主机池[pool]页面，单击<共享文件系统心跳网络>按钮。

· 系统中的共享文件系统以主机池为边界，主机池下的所有主机均可以挂载同一个共享文件系统，因此在主机池页面需要配置统一的共享文件系统信息。

· 默认情况下共享文件系统的心跳网络是使用管理网的，现场可以根据实际情况调整共享文件系统的心跳网络。

· iSCSI共享文件系统的多路径需要IP SAN存储支持，并在“增加共享文件系统”页面中的“IP地址”栏配置多个IP地址信息。

  4. 在弹出的“共享文件系统心跳网络”对话框中输入规划的存储网络地址信息“192.168.12.0”，然后单击<确定>按钮。

  5. 在主机池“pool”下的“共享文件系统”页面，单击<增加共享文件系统>按钮，弹出增加共享文件系统对话框。设置基本信息和LUN信息相应的参数，设置完毕后，单击<确定>按钮。

  6. 集群增加共享文件系统类型存储池。在集“cluster”的“存储”页面，单击<增加>按钮，弹出增加共享存储对话框。

  7. 选择之前添加的共享文件系统后，单击<选择主机>按钮，勾选使用该共享存储的主机，<确定>按钮。

  8. 返回增加共享存储对话框，单击<确定>按钮。

  9. 完成增加共享文件系统后，提示对文件系统进行格式化。单击<确定>按钮。

首次增加的存储卷需要进行格式化操作，如果系统中增加的存储卷已经做过格式化，那么不会再提醒格式化。

  10. 在格式化共享文件系统对话框，输入最大访问节点数，即该共享文件系统最大可以被多少个主机同时挂载，单击<确定>按钮。“锁类型”有两个选项：分布式锁、硬件辅助锁。硬件辅助锁对存储有要求，需要存储服务器支持CAW特性。

FC共享文件系统配置

  1. 在主机的“存储适配器”页面，查看FC HBA卡的信息。

  2. 单击[云资源]>[主机池]>[共享文件系统]页面，单击<增加共享文件系统>按钮，弹出增加共享文件系统对话框。在“ 基本信息”和“2 LUN信息”页面设置FC共享存储相关的信息，设置完毕后，单击<确定>按钮。

  3. 在[云资源]>[主机池]>[集群]>[存储]页面，单击<增加>按钮，弹出增加存储池对话框。

  4. 在增加共享存储对话框中选择对应的FC类型的存储，并单击<确定>按钮返回。

  5. 在增加共享存储对话框中单击<选择主机>按钮，在弹出的选择主机对话框中选择对应的主机，并单击<确定>按钮。

  6. 在“NAA信息”中的“HBA卡”栏务必选择“Multipath”配置FC多路径。

  7. 在增加共享存储对话框中单击<确定>按钮，在弹出的操作确认对话框中单击<确定>按钮。

iSCSI网络存储配置

  1. 主机增加存储池，在“类型”栏选择“iSCSI网络存储”，然后单击<下一步>按钮。

  2. 在“IP地址”栏输入IP SAN的地址信息，然后在“Target”栏搜索并选择Target信息，最后单击<确定>按钮。

  3. 增加存储池完成后，在“存储池”页面可显示新增加的“iSCSI网络存储”类型的存储池。

  4. 主机通过iSCSI方式挂载存储资源后，虚拟机可以以块设备方式使用存储资源，在“磁盘类型”栏选择“块设备”，并在“磁盘”栏通过搜索按钮选择块设备。

FC网络存储配置

  1. 在主机的“存储”页面，单击<增加>按钮。

  2. 弹出增加存储池对话框中，在“基本信息”页面的“类型”栏选择“FC网络存储”，“名称”和“显示名称”根据规划输入，然后单击<下一步>按钮。

  3. 在“其他信息”页面的NAA栏单击搜索按钮。在搜索到的NAA信息后单击<增加>按钮，然后单击<确定>按钮。

  4. 增加存储池完成后，在“存储池”页面可显示新增加的“FC网络存储”类型的存储池。

  5. 主机通过FC方式挂载存储资源后，虚拟机可以以块设备方式使用存储资源，在“磁盘类型”栏选择“块设备”。


虚拟机创建方式

系统支持多种部署虚拟机的方式，用户根据基础架构规划及不同的使用场景，选择适用的部署方式。

创建方式

描述

使用场景

创建单个虚拟机

新增单个虚拟机，可以对虚拟硬件（CPU、内存、磁盘、网卡等）进行配置。

虚拟机创建后，需要为其安装操作系统和CAStools。安装方法与在物理主机上安装操作系统的方法相同。

  • 系统初次部署，第一次创建虚拟机。

  • 系统中没有适合的模板或虚拟机（操作系统或硬件配置）时。

使用模板创建虚拟机

虚拟机模板是由一台虚拟机克隆或转换而来，是虚拟机的一个副本，包含虚拟机的系统配置、操作系统和应用程序。因此通过模板部署的虚拟机与模板具有相同的操作系统和应用程序。

  • 系统中有适合的模板，可以通过虚拟机模板便捷地创建和部署多台虚拟机。

  • 从其他虚拟化管理平台中导出开放虚拟化格式模板，通过部署OVF模板来创建虚拟机。

  • 适用于大规模部署虚拟机或通过自助服务流程申请虚拟机的场景。

克隆已有虚拟机

通过复制系统中已有的虚拟机来创建一个相似的虚拟机。

克隆后新虚拟机的硬件配置、操作系统、应用程序和数据与源虚拟机相同，但拥有新的虚拟网卡MAC地址和UUID地址。

需要部署多个类似的虚拟机时，可在单个虚拟机上配置安装不同的软件，然后将该虚拟机克隆多次，而不用分别创建和配置每个虚拟机。


新增单个虚拟机

上传虚拟机操作系统文件

虚拟机控制台支持“虚拟光驱”功能，可以通过本地镜像文件为虚拟机安装操作系统。本地镜像可以通过系统本地上传的方式，也可以通过第三方的软件上传到系统中。

  1. 在主机的“存储”页面，选中存储池“isopool”，然后单击<上传文件>按钮。

  2. 在弹出的文件上传对话框中，单击“请选择文件 把文件拖拽到这里”区域，弹出“打开”对话框。

  3. 在本地电脑选择需要上传的操作系统的ISO文件。

ISO文件名不支持中文、空格和括号等特殊字符，建议使用简单的命名方式。

  4. 回到文件上传对话框中，显示了选择的操作系统ISO文件，然后单击<开始上传>按钮。

  5. 文件上传对话框显示文件上传的进度信息。

  6. 上传成功后在存储池“isopool”下可显示上传的文件。

增加虚拟机

  1. 在主机页面，单击<增加虚拟机>按钮，弹出增加虚拟机对话框。

  2. 在[基本信息]页面的“虚拟机名称”和“显示名称”栏输入虚拟机的名称信息；“操作系统”栏根据实际操作系统类型选择“Windows”或者“Linux”；“版本”栏选择实际的操作系统版本信息。然后单击<下一步>按钮。

  3. 在[硬件信息]页面显示了虚拟机的硬件资源设置，可按照缺省数据申请，也可按照业务需求修改配置信息。

  4. 在“光驱”栏单击右边的搜索按钮，弹出选择存储对话框，在“显示名称”列选择存储池“isopool”，“文件名称”列选择操作系统的ISO文件，然后单击<确定>按钮。回到“增加虚拟机”的硬件信息页面。最后单击<确定>按钮。

  5. 增加虚拟机完成后，在主机下显示新增加的虚拟机，状态为关闭。

为虚拟机安装操作系统（Windows系统）

本节以Windows Server 2008版操作系统为例，说明Windows系统安装过程。

1. 挂载光驱并启动安装

  1. 选中虚拟机，单击[修改虚拟机]>[光驱]>[源路径]>[连接]>[选择文件]，从存储池中选择已经上传到系统中的镜像，单击<确定>，为虚拟机挂载操作系统ISO镜像。

  2. 在虚拟机页面，单击<启动>按钮启动虚拟机。

  3. 虚拟机启动后，单击<控制台>按钮，打开虚拟机的控制台对话框，显示的虚拟机已启动系统安装。

2. 加载硬盘驱动

  1. 在安装Windows操作系统时无法发现磁盘信息（因为选择了高速硬盘，Windows安装盘中没有对应的驱动），此时单击<加载驱动程序(L)>按钮（前提为“允许自动加载Virtio驱动”已经勾选），弹出“加载驱动程序”对话框。

  2. 选择“SCSI controller”进行安装高速硬盘的驱动。

  3. 高速硬盘驱动完成后，安装界面显示高速硬盘信息。

3. 安装系统后卸载光驱和软驱

  1. 在虚拟机控制台中安装虚拟机操作系统，安装完成后通过“控制台”登录虚拟机。

  2. 虚拟机安装完成后，需要将虚拟光驱中挂载的ISO文件断开连接。在“修改虚拟机”对话框的“光驱页面，单击<断开连接>按钮。光驱断开连接后，“源路径”栏显示为空。

  3. 虚拟机使用高速硬盘时会自动为虚拟机创建软驱设备，用于虚拟机操作系统安装Virtio驱动。当虚拟机操作系统安装完后，需要删除该软驱设备。

为虚拟机安装CAStools

虚拟机安装后，管理平台和虚拟机之间相互独立，管理平台无法获取虚拟机CPU、内存利用率等信息，若需要获取准确的监控数据，必须在虚拟机中安装CAStools虚拟机代理工具。

虚拟机代理工具支持Windows和Linux操作系统，详细的兼容性可参考《云计算管理平台软硬件兼容性列表》。

1. Windows系统安装虚拟机代理工具

  1. 虚拟机光驱连接ISO安装文件。在“修改虚拟机”对话框中，选择“光驱”，单击<选择>按钮。在弹出的“选择文件”对话框中的“类型”栏选择“安装CAStools”，然后单击<确定>按钮，源路径即显示虚拟机已经挂载系统中的虚拟机代理镜像。

  2. 安装代理工具。通过控制台登录虚拟机，虚拟机的虚拟光驱挂载了代理工具，双击虚拟光驱，弹出安装对话框。单击<下一步>按钮。按照安装向导逐步安装，直至安装完成。

虚拟机代理工具安装完成后，如果是Windows VISTA 32位、Windows VISTA 64位、Windows Server 2008 32位、Windows Server 2008 64位系统，需要重启才能使用Virtio驱动。

  3. 虚拟机安装代理工具后，在虚拟机的“概要”页面可以查看到代理工具的运行状态和版本信息。系统可以准确监控到虚拟机的资源利用率。比如“性能监控”页面的“内存利用率”和“分区占用率”信息。

  4. 代理工具安装完成后，在“修改虚拟机”对话框中的“光驱”中单击<断开连接>按钮。

2. Linux系统安装CAStools

  1. 虚拟机光驱连接ISO安装文件。在“修改虚拟机”对话框中，选择“光驱”，单击<选择>按钮。在弹出的“选择文件”对话框的“类型”栏选择“安装CAStools”，然后单击<确定>按钮。

  2. mount光驱。在Linux虚拟机中执行mount命令，挂载光驱设备，并进入到代理工具的Linux目录下。

  3. 然后执行安装命令“./CAS_tools_install.sh”。

  4. 安装完成后，在虚拟机的“概要”页面显示代理工具运行正常。

为虚拟机分配IP地址

虚拟机安装完成后，默认不存在IP地址，在虚拟机的“概要”页面，IP地址信息显示为空。系统可以通过虚拟机代理工具为虚拟机分配IP地址。

  1. 虚拟机的“修改虚拟机”对话框中，在“设置网络”栏勾选“IP/MAC绑定”或者“CAStools配置”。

  2. 以代理工具配置为例。勾选“CAStools配置”，在IP地址相关栏，输入虚拟机的IP地址信息，如下图所示。然后单击<应用>按钮。

  3. 虚拟机IP地址配置成功后，在“网络信息”页面显示刚配置的IP地址信息。在虚拟机的操作系统中，通过“ipconfig”命令，确认为虚拟机配置了对应的IP地址信息。


使用模板部署虚拟机

虚拟机模板由一台虚拟机“转换”或“克隆”而来，用于便捷地创建和配置多台新的虚拟机，一个虚拟机模板由虚拟机操作系统镜像和配置文件两部分组成。

克隆为模板与转换为模板的区别：

  • 克隆为模板：操作完成后原虚拟机继续保留。

  • 转换为模板：操作完成后原虚拟机转为了模板，不再继续保留。

模板存储

虚拟机模板是存放在虚拟化管理系统（CVM）主机上的，建议在共享存储设备单独规划一个存储空间用于存储虚拟机的模板。在增加模板存储之前确认在共享存储中已经完成存储卷的划分和相关配置。

  1. 在[云资源]>[虚拟机模板】页面，单击<模板存储>按钮。

  2. 在弹出的增加模板存储对话框中的“目标路径”栏输入规划的模板存放路径“/templet”；“类型”栏选择“iSCIS共享存储”；“IP地址”栏根据规划输入“192.168.12.100”，然后单击LUN右边的搜索按钮。

  3. 搜索IP地址对应的LUN信息，搜索完成后，单击<确定>按钮。增加模板存储完成后，在“模板存储”页面显示新增的模板存储信息。

制作虚拟机模板

系统内的虚拟机模板可通过如下三种方式获得：

在制作虚拟机模板前，请务必确认虚拟机的光驱和软驱已经断开连接，操作系统的地址信息已经设置为自动获取（否则会出现网络地址冲突问题）。

  • 将已有虚拟机克隆出一个虚拟机模板

  • 将已有虚拟机转换为模板

  • 将虚拟机导出为OVF模板

1. 将虚拟机克隆出模板

  1. 安全关闭虚拟机，将虚拟光驱和虚拟软驱中的文件卸载（如没有光驱和软驱没有挂载文件，请忽略）。

  2. 在虚拟机关闭的状态下，右键单击虚拟机，选择“克隆为模板”。

  3. 在弹出的“克隆为模板”对话框中的“模板名称”栏根据规划输入模板名称，并选择“模板存储”，然后单击<确定>按钮。“模板名称”不允许和虚拟机名称一致。

  4. 虚拟机模板制作完成后，进入“虚拟机模板”页面，可显示新增的虚拟机模板。

2. 将虚拟机转换为模板

  1. 安全关闭虚拟机，将虚拟光驱和虚拟软驱中的文件卸载。（如没有光驱和软驱没有挂载文件，请忽略）

  2. 选中虚拟机，单击[更多操作】>[转换为模板】菜单项，弹出克隆为模板或转换为模板对话框。输入虚拟机模板名称和模板描述信息，选择模板存放位置，点击<确定>。

  3. 在导航树中[云资源】>[虚拟机模板】菜单项中，进入虚拟机模板列表页面，即可看到转换出的虚拟机模板。同时，主机上已经移除了该虚拟机。

3. 导出为OVF模板

将从CVM中下载到本地的虚拟机模板的压缩包（.tar.gz格式）导入到CVM中。适用于跨平台部署虚拟机时使用。

  1. 在导航树中[云资源】>[虚拟机模板】菜单项中，进入虚拟机模板列表页面，选中要下载的虚拟机模板，单击下载图标，将虚拟机模板压缩包保存到本地。

  2. 在需要导入模板的CVM中，点击[云资源】>[虚拟机模板】菜单项，点击<导出OVF模板>，将模板导入。

用模板部署虚拟机

可通过配置数量为多个，实现虚拟机的批量部署。通过系统内的模板部署虚拟机一次最多可以批量部署100台虚拟机。当批量部署多台虚拟机时，不支持配置虚拟机的系统信息。

  1. 在导航树中[云资源】>[虚拟机模板】菜单项中，进入虚拟机模板列表页面。选择待部署虚拟机的模板，单击 [image] 图标，开始部署虚拟机。

  2. 在弹出的部署虚拟机配置对话框中，根据需要配置虚拟机的基本信息、部署的主机集群、存储信息、网络信息及系统信息。可以批量部署多个虚拟机。

  3. 在任务台显示虚拟机部署成功后，可在虚拟机部署的节点主机上看到部署的虚拟机。

  4. 启动虚拟机，打开控制台，可以看到虚拟机的系统已经存在，与虚拟机模板操作系统一致。输入在系统信息处配置的登录账号与密码后，可以进入虚拟机使用或进行其他配置。


克隆已有虚拟机

通过克隆系统中已有的虚拟机，创建一个现有虚拟机的副本虚拟机。新的虚拟机的硬件配置、操作系统、应用程序和数据与源虚拟机相同，但拥有新的虚拟网卡MAC地址和UUID地址。无论是在线还是离线的虚拟机都可以被克隆，在线克隆虚拟机，克隆的虚拟机业务不会被中断。

虚拟机克隆有三种方式：

  • 普通克隆：对于关闭状态的虚拟机，克隆后的虚拟机与原虚拟机磁盘数据完全相同，如果原虚拟机磁盘为三级镜像，则克隆后的虚拟机与原虚拟机共用基础磁盘镜像；对于运行状态的虚拟机，克隆后的虚拟机磁盘为一级镜像，不与原虚拟机共用基础磁盘镜像，其效果与完全克隆相同。

  • 快速克隆：基于增量文件的方式生成新的虚拟机，克隆后的虚拟机和原虚拟机共用磁盘基础镜像，不拥有原虚拟机增量存储的磁盘内容，克隆后的虚拟机磁盘为三级镜像。快速克隆可大大提高创建虚拟机的速度，节省服务器的存储空间。只有磁盘预分配方式为精简的虚拟机才支持快速克隆。

  • 完全克隆：克隆后的虚拟机与原虚拟机磁盘数据完全相同，且新虚拟机的磁盘为一级镜像，不与原虚拟机共用磁盘镜像。在需要部署大量虚拟机的场合，完全克隆所需的存储空间将是原虚拟机的整数倍。

  1. 选择待克隆的虚拟机，点击<克隆>按钮，弹出克隆虚拟机窗口，启动克隆任务。

  2. 配置通过克隆创建的虚拟机的基本信息、存储信息及网络信息。


虚拟机资源QoS

根据业务场景需求，可以灵活地选择最适合的虚拟机资源配置。当业务负载发生变化，也可以快速地调整虚拟机资源配置，保障业务稳定运行，提升资源效能。

通过设定虚拟机资源的使用上限，防止非关键应用和恶意用户抢占共享资源。根据业务的重要程度，分配不同的资源优先级及保障策略，优先保障重要业务的虚拟机资源供给，满足重要业务SLA（Service-Level-Agreement，服务等级协议）需求。确保高优先级的虚拟机具有更良好的计算、网络和存储性能，避免虚拟机之间的“临位干扰”效应。

虚拟机资源QoS相关参数也可以在创建虚拟机时进行配置。


CPU

虚拟机的CPU QoS用于报纸虚拟机的CPU资源分配，避免虚拟机间由于业务不同而导致的计算能力相互影响，满足不同业务对虚拟机计算性能的要求，最大程度复用资源，降低成本。

根据虚拟机配置的CPU参数，按分时复用原理对CPU进行调度，来控制虚拟机获得物理计算资源的比例，提供服务质量保障。

  1. 选择需要调整CPU资源的虚拟机，单击<修改虚拟机>按钮，进入修改虚拟机窗口。选择“CPU”选项，展开高级设置。

下图中，表示该虚拟机优先使用物理CPU资源，系统为该虚拟机预留1000MHz，且最多允许使用2000MHz。

图-1 CPU修改

CPU调度优先级

配置在多个虚拟机竞争物理CPU资源时，虚拟机获得CPU资源的优先级。CPU调度优先级定义了虚拟机的相对优先级或重要性。在资源紧张时，优先级高的虚拟机优先使用物理CPU资源。

优先级分为高、中、低，在抢占物理CPU时，分配的比例为4:2:1。例如在一台主频为2.8GHz的单核主机上运行三台虚拟机A、B、C，CPU调度优先级分别为高、中、低，当三台虚拟机CPU满负载运行时，分配到的计算能力分别为：1600MHz，800MHz，400MHz。

CPU调度优先级只在虚拟机竞争计算资源时发挥作用，在不存在竞争的情景下，有需求的虚拟机可以独占物理CPU资源。例如当虚拟机B和C处于关闭状态，虚拟机A可获得整个物理核即2.8GHz的计算能力。

在CPU高级设置处，将“CPU调度优先级”设置为“高”，则虚拟机优先使用物理CPU资源。

CPU预留（MHz）

配置虚拟机获得的最低计算能力。例如，当CPU个数为1时，预留配置为1000MHz，则该虚拟机可获得的计算能力不低于1000MHz。

在CPU高级设置处，调整CPU<预留>参数，预留一定量的CPU资源仅供该虚拟机使用。

限制（MHz）

配置虚拟机获得的最大计算能力。例如，当CPU个数为1时，限制配置为2000MHz，则该虚拟机可获得的最大计算能力为2000MHz。

在CPU高级设置处，调整CPU<限制>参数，配置虚拟机CPU单核允许使用主机CPU的最大频率。

CPU限制和CPU预留有关，最小值是CPU预留值。

如果开启整机限制，则只限制虚拟机整机使用的频率，不对单核做限制。


内存

内存虚拟化，即把主机的物理内存进行统一管理，包装成多个虚拟内存给若干虚拟机使用。内存QoS，即通过虚拟化技术，允许在同一主机上运行的虚拟机内存规格总和大于主机内存规格，从而在不增加物理内存的情况下，提高虚拟机密度，降低单台虚拟机成本。针对不同业务，提供质量保证。

虚拟机创建时，为其配置了一个内存容量（例如4GB），实际虚拟机在运行时，主机会根据虚拟机业务负载去配置虚拟机内存。

  1. 选择需要调整内存资源的虚拟机，单击<修改虚拟机>按钮，进入修改虚拟机窗口。选择“内存”选项。

下图中，表示该虚拟机的最大分配为4*16=64GB（创建时分配内存为4GB），修改虚拟机分配内存为8GB，系统为该虚拟机预留8GB内存，该虚拟机优先申请内存资源。

图-1 内存修改

内存分配

为虚拟机分配的内存，表示该虚拟机的最大内存使用量。虚拟机的内存分配可以根据业务需要进行调整，内存可调整的上限，即最大分配值，默认为创建时分配内存的16倍，如果此值大于虚拟机运行的主机内存，则取主机内存。

虚拟机关闭时，“最大分配内存”显示的是主机内存。

内存预留

配置在多个虚拟机竞争内存资源时，虚拟机分配内存的下限，预留的内存不再参与交换和抢占，以便保证在主机内存紧张时，虚拟机依旧可以使用一定的内存资源。预留的内存会被虚拟机独占，即使虚拟机实际使用量低于预留量，其他虚拟机也无法抢占该虚拟机空闲的内存资源。

此值为虚拟机分配内存的百分比，0表示系统仅保证虚拟机可使用的最少必要内存量，100表示为虚拟机预留分配的全部内存仅供该虚拟机使用。

资源优先级

配置在资源处于竞争的情况下，虚拟机获得内存资源的优先级。资源优先级定义了虚拟机的相对优先级或重要性。在虚拟机申请内存资源，或主机释放空闲内存（虚拟机迁移或关闭）时，优先级高的虚拟机优先分配内存资源。例如，虚拟机内存预留为0时，在主机内存资源紧张时，虚拟机会参与主机资源的抢占，如果此时虚拟机内存的资源优先级为高，虚拟机就会优先抢占内存资源。

优先级分为高、中、低，在抢占物理内存时，分配的比例为4:2:1。

内存资源优先级仅在各虚拟机竞争内存资源时发挥作用，在不存在竞争的情景下，有需求的虚拟机可以最大限度地获得内存资源。


磁盘

设置非重要虚拟机磁盘的I/O上限及IOPS（每秒处理I/O请求个数），保证在这些虚拟机业务量大时，不会影响到其他重要的虚拟机业务。

I/O速率与IOPS

IOPS是指单位时间内系统能处理的I/O请求数量，一般以每秒处理的I/O请求数量为单位，是衡量磁盘随机访问性能的关键指标。

如果同时限制IOPS和I/O速率，以最先达到的配置为准，因为虚拟机磁盘IOPS和I/O速率之间是有关联的。IOPS表示磁盘每秒传输I/O的次数，I/O速率表示每秒数据的传输总量（也称之为吞吐量）。IOPS和I/O速率之间存在线性的变化关系，当被传输的I/O（也称之为数据块或block）较小时，每个I/O传输所需耗费的时间就少，单位时间内传输的I/O数量就多，反之，当被传输的数据块较大时，传输每个数据块的时间增大，IOPS数量明显下降。

I/O速率与IOPS的关系可以按照公式计算：I/O速率（MiBps）=IOPS*块大小/1024。

图-1 数据块大小对IOPS于I/O速率的影响

· 虚拟机磁盘IOPS和I/O速率限制功能配置之后，必须重新启动虚拟机才能生效。

· 在配置时，IOPS和I/O速率不要设置过低，过低的配置将导致虚拟机启动速度非常缓慢。最大I/O字节数建议为8000KB/s，最大IOPS个数建议为300，如果低于此值，会影响虚拟机的运行速度。

  1. 选择需要限制磁盘I/O的虚拟机，单击<修改虚拟机>按钮，进入修改虚拟机窗口。选择“磁盘”选项，展开高级设置。

通过配置“限制I/O速率”，可以限制磁盘的最大读、写速率；配置“限制IOPS”，可以限制磁盘每秒处理读、写请求的最大个数。

图-2 限制磁盘I/O速率

IO优先级

配置在资源处于竞争的情况下，虚拟机进程对主机物理磁盘读写的优先权，包括高、中、低。主机上磁盘数据读写速度有限，当多个虚拟机同时进行大量数据读写时，I/O优先级高的虚拟机可以优先对磁盘进行数据读写操作。

优先级分为高、中、低，在抢占读写资源时，对应的比例为5:3:2。

  1. 选择需要调整磁盘IO优先级的虚拟机，单击<修改虚拟机>按钮，进入修改虚拟机窗口。选择“概要”选项，展开高级设置。

图-3 调整虚拟机IO优先级


网络

网络QoS功能通过网络策略模板实现。网络策略模板是一组网络控制功能的集合，如ACL、VLAN、QoS等。虚拟机网卡使用网络的优先级由网络策略模板所决定。通过为虚拟机配置网络策略模板，对虚拟机网络进行带宽控制，确保各个平面的流量拥塞不影响其他平面，使用相同网络策略的每台虚拟机提供流量整形、带宽优先级的控制能力。

如果想要精确控制虚拟机与特定站点之间的网络流量带宽，还可以针对特定网段定义网络限速策略。

  1. 选择需要调整网络策略的虚拟机，单击<修改虚拟机>按钮，进入修改虚拟机窗口。选择“网络”选项，单击“网络策略模板”右侧的选择按钮，进入选择网络策略模板窗口。

如果网络策略已经制定好，也可以在创建虚拟机时就选择定义好的网络策略模板。

图-1 选择网络策略模板

  2. 在选择网络策略模板窗口，单击<增加>按钮，为虚拟机定制一个网络策略模板。

如系统中已经有定义好的网络策略模板，直接选择适用的网络策略模板即可。

图-2 增加网络策略模板

出入流量

虚拟机网卡发送和接收流量的速率限制由网络策略模板中定义的入方向和出方向流量限制决定。

  1. 在增加网络策略模板窗口，输入策略名称，单击<下一步>按钮，配置出入流量。

图-3 输入网络策略名称

  2. 启用入方向和出方向流量限制，对虚拟机入方向（即虚拟机交换机至虚拟机方向）和出方向（即虚拟机至虚拟交换机方向）的流量做限制。

图-4 流量限制

网络优先级

当主机网络流量过大时，按照虚拟机使用的网络策略模板中的网络优先级为虚拟机网卡分配带宽。优先级分为低、中、高，在抢占网络带宽时，对应的比例为1:3:6。例如一台主机上运行三台虚拟机A、B、C，网络优先级分别为低，中，高，当主机网络流量过大，带宽不能满足这三台虚拟机的带宽要求时，就按照这个1:3:6的比例分配可用的流量。

  1. 在出入流量设置页签，调整网络优先级。

图-5 配置网络优先级

网络限速

网络限速策略是一条或多条规则的集合。规则用于识别网络报文流，对于识别出的特定网络报文流，限制其平均带宽和突发缓冲。网络限速策略用于虚拟机与特定站点之间网络流量带宽的精确控制。

网络限速策略通过网络策略模板作用到虚拟机上，与网络策略模板中入方向和出方向的流量限制相比，具有更精细的控制粒度。

如配置了网络限速策略，就不再需要为网络策略模板设置出入流量限制了。

  1. 在增加网络策略模板窗口，开启网络限速策略，单击<下一步>按钮。

图-6 启用网络限速策略

  2. 选择网络限速策略，如无合适的网络限速策略，可单击<增加>按钮，增加适用的网络限速策略。

图-7 增加网络限速策略

  3. 输入策略名称后，单击<增加规则>按钮，增加限速规则。

图-8 增加限速规则

  4. 定义限速策略限制的网段及应用的流量方向，单击<下一步>按钮。

图-9 设置限速网络

  5. 定义允许的平均带宽及突发缓冲区大小，单击<完成>按钮。

图-10 限速配置

  6. 选中新增加的限速规则，单击<确定>按钮。

图-11 选中限速规则

  7. 选中新增加的限速策略，单击<确定>按钮。

图-12 选中网络限速策略

  8. 在网络策略模板中单击<完成>按钮，确认将网络限速策略加入到网络策略模板中。

图-13 确认增加网络限速策略

  9. 选中网络策略模板，单击<确定>按钮，为虚拟机选择网络策略模板。

图-14 选择网络策略模板


管理系统备份

系统配置完成后，推荐配置虚拟化管理系统备份。当虚拟化管理系统发生故障时，可以通过备份的数据库、版本信息、配置文件等内容，对虚拟化管理系统进行恢复。

  1. 选择[云安全>>[CVM备份配置】页面完成系统的备份配置。推荐启用定时备份功能，并且备份到远端服务器。


双机热备配置指导

实际生产环境中服务器故障是不可避免的。服务器故障可能由各种原因引起，如设备故障、操作系统故障、软件系统故障等等。通常服务器产生故障正常的恢复的时间可能需要几分钟，甚至几小时。而对于一些重要系统而言，用户是很难忍受这样长时间的服务中断的。因此，就需要通过双机热备，来避免长时间的服务中断，保证系统长期、可靠的服务。

双机热备使用两台服务器部署管理平台，同时两台服务器互相备份，共同提供服务。当一台服务器出现故障时，可由另一台服务器承担服务，从而在不需要人工干预的情况下，自动保证管理平台能持续提供服务。双机热备由备用的服务器解决了在主服务器故障时管理平台中断的问题。

管理平台可以通过双机热备技术来实现管理平台的高可靠性，与管理平台配置备份相比，双机热备是一种实时的高可靠性方案。

  • 通过分析系统的重要性以及对服务中断的容忍程度，以此决定是否使用双机热备。即业务能否容忍中断，可容忍多长的时间恢复，或者业务不能恢复会造成多大的影响。

  • 双机热备会有一个短暂的切换过程。在切换过程中，管理平台服务有可能出现短暂的时间中断。当切换完成后，服务将正常恢复。

原理介绍

双机热备功能是基于数据同步复制的方式来实现的。主备服务器之间数据的同步采用DRBD（Distributed Replicated Block Device，分布式镜像块设备内容的存储复制）存储复制解决方案来实现，当主服务器数据发生变化时，该数据变化会实时同步到备用服务器，这样就保证了主备服务器之间数据的一致性。

双机热备优化后，新双机热备的主备切换是通过CMSD（CVM Master Slave Daemon，热备服务管理程序）来实现的。

CMSD主程序完成以下功能：

  • 老双机热备corosync+pacemaker+glue的集群通信功能。

  • 热备服务的启动、关闭、切换等功能。

  • 网络故障或主机故障时，热备服务能够自动进行切换。

· 在E0523及之后版本的双机热备为新双机热备。

· 在E0523之前版本的双机热备为老双机热备。

组网

新双机热备系统由三个实体组成：主节点、备节点和仲裁节点。

  • 主备节点是安装了CMSD主程序的两个节点。

  • 仲裁节点分为高级仲裁节点和简易ping仲裁节点。

  • 高级仲裁节点可以是同管理平台CVK或安装了CMSD程序的节点。

  • 简易ping仲裁节点可以是主备节点可ping通的交换机、路由器。

双机热备的组网拓扑图如下所示。

图-1 组网拓扑图

node1和node2是构成双机热备的两台CVM主机。

  • 多台CVK主机和node1、node2主备CVM管理平台组成CAS云服务平台。

  • CVK主机与主备CVM管理平台之间的交换网络要求至少是千兆网络。

  • 双机热备的两台主机（node1、node2）可以再作为CVK主机加入到热备主机自己管理的主机池中使用，但不能再分离成单独的CVM管理平台使用。

注意事项

  • 仅支持新部署的CAS，CVM虚拟化管理系统采用双机热备配置。不支持在原有在线使用的CAS中的CVM虚拟化管理系统升级成双机热备，因为原有数据无法保留。

  • 双机热备主机因为网络异常出现脑裂，等网络恢复正常后，会自动协商出主服务器，若脑裂时业务主机的性能数据发送的是现在的备服务器，脑裂恢复后，业务主机的性能数据仍向现在的备服务器发送性能数据，导致主管理平台性能数据丢失，此时在主管理平台上需执行连接主机操作，保证业务主机性能数据发送正确。

  • 双机热备部署或增加本地同步分区盘的过程中，要保证服务器健壮性，不能重启和关闭服务器。若出现故障服务器重启或断电，需要重新部署搭建。

缩略语

缩略语Abbreviations | 中文解释Chinese explanation | 英文全名Full spelling
CVM | 虚拟化管理系统 | Cloud Virtualization Manager
CVK | 虚拟化内核平台 | Cloud Virtualization Kernel
DRBD | 分布式镜像块设备内容的存储复制解决方案 | Distributed Replicated Block Device
CMSD | 热备服务管理程序 | CVM Master Slave Daemon


配置流程

配置前提

表-1 配置前提

操作 | 说明
搭建双机热备的主机的要求 | 搭建双机热备时对主机的详细要求说明。
同步模板数据的方式 | 数据模板的详细同步方式。
热备主机作为业务主机的使用说明 | 当热备主机同时作为业务主机时的详细说明。

配置步骤

表-2 配置步骤

操作 | 说明
系统安装要求 | 双机热备主备节点的系统安装要求。
双机热备配置 | 双机热备的搭建步骤。
双机热备产品注册 | 双机热备产品的注册方式、步骤。

双机热备常用操作

表-3 常用操作

操作 | 说明
单机故障后的恢复指导 | 在出现单机故障时的恢复方法。
双机热备服务启动/关闭控制 | 启动/关闭双机热备服务的方法、步骤。
常用命令 | 其他双机热备常用命令。


搭建双机热备的主机的要求

搭建双机热备的两台管理主机需同时满足以下条件：

  • 由于双机热备的数据库分区创建在/vms分区下，并且/vms分区自身需要一定量的空间，因此安装管理主机进行手动分区时，至少要为/vms分区分配30G的空间。/vms分区最小空间估算方法为：数据库分区（预估主机个数*10M+预估虚拟机个数*15M）*15/1024M+10G。建议在保证其他分区空间充足的前提下，为/vms分区分配尽量大的空间。

  • 为了缩短双机热备的搭建时间，当设置数据库分区大小超过200G时，建议两台CVM之间的管理网使用万兆光纤。

  • 全新安装的系统，没有作为业务主机使用过，管理平台中无纳管的业务主机。

  • 主机上的存储池必须保持系统默认配置，即只有isopool和defaultpool两个存储池。

  • 安装的CAS软件版本号必须相同，且安装的CAS组件（CVM、CIC、SSV）必须相同。

  • 安装系统时，主机的系统引导方式必须相同。

  • 两台主机之间的管理网络必须相通。

搭建双机热备的仲裁节点需满足以下条件：

  • 高级仲裁节点的系统需要和搭建双机的两台主机一致。

  • 推荐用同一云平台中的CVK作为高级仲裁。


同步模板数据的方式

双机热备推荐两种方式同步虚拟机模板数据：

  • FC或iSCSI共享模板存储方式。建议使用FC或iSCSI共享模板存储方式同步虚拟机模板数据。

  • 本地同步分区方式。

· 若有FC或iSCSI类型的共享存储，优先推荐使用共享存储。

· 若既要使用同步分区又要使用FC/iSCSI类型的共享存储，请先增加本地同步分区类型的模板存储，再挂载FC/iSCSI存储设备上的LUN。

当双机热备的两台主机无法使用共享存储LUN时，可以使用本地同步分区，用于同步主备管理平台之间的虚拟机模板数据。比如使用虚拟机作为CVM双机节点，主备管理平台无法使用FC存储设备上的LUN，又无法添加iSCSI存储设备上的LUN时，可以配置本地同步分区。

双机热备搭建成功后，在管理平台中，进入[云资源/虚拟机模板/模板存储]页面单击<增加模板存储>按钮或者进入[系统管理/双机热备配置/模板存储]页面单击<增加>按钮，可增加一个本地同步分区类型的模板存储。

只能增加一个本地同步分区类型的模板存储。

由于涉及到格式化，须使用本地磁盘作为新的同步分区。创建本地同步分区类型的模板存储时，主备节点存在如下限制条件，只有满足如下所有条件，才能成功创建本地同步分区类型的模板存储。

  • 主、备节点不能作为业务主机加入到管理平台中。

  • 主、备节点上不能添加除默认存储池外的其他存储池。

  • 主、备节点不能作为零存储（Vstor）的计算节点。

  • 主、备节点不能作为ONEStor的计算节点。

  • 主、备节点上不能发现和挂载FC和iSCSI存储设备上的LUN（此种情况下建议拔除cable线后再重新操作）。

  • 主、备节点的本地磁盘要求大小一致，其识别的设备名称相同(即都为/dev/sd*)。


热备主机作为业务主机的使用说明

  • 新双机热备（CMSD）的主备两台主机可以作为业务主机，允许加入到热备主机自己管理的主机池中使用；老双机热备（Corosync）不能作为业务主机使用。

· 在E0523及之后版本的双机热备为新双机热备。

· 在E0523之前版本的双机热备为老双机热备。

  • 双机热备的主备两台主机不能作为业务主机加入到另外一个管理平台中。

  • 新双机热备（CMSD）创建本地同步分区后，双机热备主机不能再作为业务主机使用。老双机热备搭建时默认创建本地同步分区，故不可作为业务主机使用、升级到新双机热备也不可作为业务主机使用。

  • 双机热备主机作为业务主机使用后不能再增加本地同步分区，需要在管理平台中删除作为业务主机的热备主机后，才可以添加。


系统安装要求

  • 两台服务器安装的CAS软件版本号必须相同，且安装的CAS组件（CVM、CIC、SSV）必须相同。

  • 两台服务器采用相同的引导方式进行系统安装：即都为BIOS方式或者都为UEFI方式，二者不可混用。

  • 两台服务器必须采用自动分区方式安装CVM系统，即采用Guided – use entire disk方式，如下图所示。

图-1 自动分区方式图

  • 要求主备两台服务器的时间保持一致。如果不一致请手动同步服务器时间。比如可以使用date –s ‘2013-6-14 8:30:00’命令手动配置时间，也可以配置NTP服务器来同步时间。

请注意在系统时间修改后，需要执行命令hwclock –w命令将时间信息写入BIOS保存，以免主机重启后时间发生变化。

  • 系统安装完成后，可以通过主机Xsconsole控制台来修改主机hostname和IP地址。

启用双机热备功能后，请不要再修改主机名称和IP地址，否则会出现严重问题。

  • 两台服务器系统盘分区编号和挂载点需保持一致，可通过lsblk命令查看系统盘分区信息。


双机热备配置

只需在一个管理平台中进行部署，即可实现双机备份功能。搭建过程中，因为需要初始化本地及对端硬盘分区，花费时间会比较长，请耐心等待，具体花费时间长短与实际环境中的硬盘大小及网络速度有关。一般来讲，千兆网络环境下，每100G硬盘大约花费20分钟，而在万兆网络环境中，花费时间会适当减少。

搭建场景组合

  • 服务器+高级仲裁

  • 服务器+简易Ping方式

  • 虚拟机+高级仲裁

  • 虚拟机+简易Ping方式

按照推荐优先级从高到低排列。

当主备两节点网络出现故障，但两节点对外通信正常，仲裁机制介入。

  • 高级仲裁主机：安装了CMSD程序且担任仲裁角色的节点。通常为指定一台已安装CVK组件的主机作为仲裁主机，当主备管理平台之间通信异常时，主备节点同时向仲裁主机发送本机状态信息，仲裁主机根据接收到的信息进行仲裁，将重新确定的主备角色信息回送给两节点。

  • 简易ping方式：两个正在使用且比较稳定可达的IP地址，一般为网关或其他能够常态可达的IP地址，用于ping测试。若仅有一个满足要求的常态可达的IP，则两个IP地址可以重复输入。

双机热备配置步骤

  1. 单击导航树中[系统管理/双机热备配置]菜单项，进入热备主机列表页面。

  2. 单击<热备搭建>按钮，弹出热备搭建对话框。

图-1 热备搭建对话框

  3. 输入虚IP地址、子网掩码、备机IP地址、备机root密码、选择仲裁方式并根据选择输入仲裁主机IP地址、仲裁主机root密码或者仲裁IP地址1、仲裁IP地址2、输入预估主机个数、预估虚拟机个数、数据库分区大小，单击<确定>按钮。

为了缩短双机热备的搭建时间，当设置数据库分区大小超过200G时，建议两台CVM之间的管理网使用万兆光纤。

  4. 在弹出的热备搭建确认对话框中输入参数CONFIRM，单击<确定>按钮。

图-2 热备搭建确认对话框

若预检查出错，会提示相应的错误信息，修改配置重新搭建即可。详细的错误信息将保存在/var/log/cvm_master_slave.log日志文件中。

  5. 开始搭建双机热备环境时，管理平台将跳转到双机热备配置页面，展示搭建进度。

图-3 双机热备配置

  6. 双机热备搭建成功，跳转到登录页面。

如果双机热备搭建失败，搭建页面中途会中止，并且页面下方提示“配置失败，请尝试重新登录并配置”，详细的错误信息将保存在/var/log/cvm_master.log和/var/log/cvm_master_slave.log日志文件中。根据失败所在的阶段和日志可以找到对应的原因，修改配置，重新搭建。

图-4 搭建失败

  7. 增加模板存储。热备搭建成功后，第一次登录管理平台时，会自动跳转到模板存储配置界面。如果要正常使用双机热备功能，需要配置模板存储。

图-5 首次登录提示创建本地同步分区或共享目录

  • 单击<现在创建>按钮，创建模板存储。推荐使用FC共享目录或iSCSI共享目录类型的模板存储。

图-6 增加模板存储

  • 若单击“暂不创建”，后续需要增加模板存储，可以在[系统管理/双机热备配置/模板存储]中增加。

  8. 配置VNC代理服务器（可选）。如果虚拟机登录时需要使用VNC代理，则需要登录管理平台，在[系统管理]中配置VNC代理服务器的信息。

图-7 VNC代理服务器参数配置

  • 如果提供CVM服务的主机本身配置了VNC代理服务器，则要求主备两台CVM主机必须都配置VNC代理服务器，且其IP参数必须设置为CVM管理系统的虚拟IP地址。

  • 主备CVM后台root密码需要一致，避免切换备节点后虚拟机无法正常连接VNC控制台。


双机热备产品注册

双机热备产品的注册，需要获取主备两台主机的主机信息文件，注册License。

  • 如采用本地授权方式，需要获取主、备两台CVM的主机信息文件完成注册。

版本 | 注册步骤
E0703之前的版本 | 1. 在主CVM上搜集主机信息文件后、需要进行主备切换再次搜集原备CVM主机信息文件。 2. 注册时需要分别使用主、备CVM的License文件，主备切换分别进行注册。
E0703（包含）~E0706（不包含） | 1. 主CVM上搜集主机信息文件后、需要进行主备切换再次搜集原备CVM主机信息文件。 2. 只需在当前主CVM上注册授权，无需切换设备分别注册。
E0706及以后的版本 | 1. 在主CVM上同时收集主、备两台CVM的主机信息文件。无需切换设备分别收集。 2. 只需在当前主CVM上注册授权，无需切换设备分别注册。

  • 如采取License Server授权方式，在CAS侧申请授权时，只需要在主CVM上申请即可。

关于双机热备场景下的具体注册步骤，请参考安装指导。若使用E0703之前的版本，获取主备两台主机的主机信息文件并进行注册的方法参考如下。

  1. 成功搭建双机热备环境后，通过设置的虚拟IP地址登录管理系统，获取管理主机的主机信息文件，此信息文件为Master主机的信息文件，下载并保存该文件。

  2. 单击导航树中的[系统管理/双机热备配置]菜单项，进入双机热备配置页面，单击<热备切换>按钮，进行热备切换。

  3. 主备管理平台成功切换后，通过虚拟IP地址登录管理系统，再次获取管理主机的主机信息文件，此信息文件为切换前的Slave主机（切换后的Master主机）的信息文件，下载并保存该文件。

  4. 根据生成的两份主机信息文件，在License管理平台中获取License注册文件。激活时，选择双机热备，并上传收集到的两份主机的信息文件，进行License首次激活申请，成功后获得License注册文件。

  5. 根据获得的License注册文件进行产品注册。注册时需要在两台管理主机中分别注册。即通过虚拟IP地址登录管理系统，先在Master管理平台中注册。进行主备切换，再次登录管理系统，进行产品注册。


单机故障后的恢复指导

适用范围

已经部署双机热备的云平台，其中一台热备服务器发生硬件故障，需重新安装系统或更换服务器时，必须手动进行双机热备功能的恢复。

其他诸如网络不可达、断电等未重装系统的故障，不需要手动进行恢复，故障解决后双机热备功能将自动恢复。

系统要求

  • 热备服务器单机故障时，用于恢复的服务器安装的云计算管理平台软件的版本必须与原版本一致。

  • 用于恢复的服务器如果是新更换的服务器或原热备服务器更换硬盘，则要求新服务器的硬盘或更换后的硬盘与原服务器的硬盘大小相同。如果为原服务器，只需重新安装原云计算管理平台系统。

  • 进行单机故障恢复时，主服务器（原双机备份的两台服务器中只剩下主服务器状态正常）必须对外提供CVM服务，这样恢复时才能进行原始数据的同步。

系统安装

  1. 新装服务器须采用与对端服务器（即现热备Master主机）相同的引导方式进行安装。对端服务器的引导方式可通过查看挂载点是否有/boot/efi来判断，有该挂载点的为UEFI方式，否则为BIOS方式。

图-1 UEFI方式

图-2 BIOS方式

  2. 新装服务器安装过程中设置的主机名称和IP地址必须与原主机（双机热备中故障主机）相同，如果设置不相同，则双机热备功能无法恢复。系统安装完成后，也可以通过主机Xsconsole控制台来修改主机名称和IP地址。

  3. 新装服务器建议采用Manual分区方式安装系统。手动分区是为了避免不同软件版本之间分区大小不一致导致无法成功恢复的问题。配置方法详见安装指导。

图-3 手动分区方式图

  • 新双机热备进行单机恢复，采用自动分区即可，要求/VMS分区大于主服务器的数据库分区大小。若主服务器有本地同步分区盘，则需要新安装服务器添加与主服务器相同大小和设备名称的磁盘。

  • 老双机热备升级的进行单机恢复，新安装服务器的最后一个分区（即/VMS分区，如图-4 所示）必须通过手动配置方式来保证大于对端服务器（即现热备Master主机，如图-5 所示）的最后两个分区之和，至少相差200M。

图-4 新安装服务器的分区图

图-5 热备Master服务器分区图

  4. 系统安装完成后，请使用date命令查看服务器时间，要求与主备双机的系统时间保持一致，如果不一致请手动同步服务器时间。可以使用date –s ‘2013-6-14 8:30:00’命令手动配置时间，也可以配置NTP服务器来同步时间。

系统时间修改后需要执行命令hwclock –w命令将时间信息写入BIOS保存，以免主机重启后时间发生变化。

故障恢复实现

注意事项

如果双机环境增加了iSCSI共享存储类型的模板存储，在执行故障恢复前，需要先登录备机的管理平台界面，修改存储适配器的标识符与之前的标识符一致（若采用新的备机，请修改存储适配器的标识符与故障主机存储适配器的标识符一致）。

若之前没有记录存储适配器的标识符，请咨询技术支持进行找回。

操作步骤

  1. 使用root用户登录主服务器，执行ms_recovery.sh脚本，根据提示输入yes。

运行脚本ms_recovery.sh示例。

root@node1:~# ms_recovery.sh 172.16.60.51 123456 123456

Please confirm to recovery 172.16.60.51 and format peer's /vms partition [yes/no]:

yes

------------------------Ip address Check------------------

运行脚本的过程中，因为需要初始化对端硬盘分区以及同步对端数据，花费时间会比较长，请耐心等待，具体花费时间长短与实际环境中的硬盘大小及网络速度有关。一般来讲，千兆网络环境下，每100G硬盘大约花费20分钟，而在万兆网络环境中，花费时间会适当减少。

· 在脚本执行过程中，不能中断程序执行。

· 执行单机恢复脚本，恢复完成后再次登录管理系统，热备管理的非双机热备主机的业务主机状态显示为不正常，重新连接业务主机即可。

该脚本共3个参数，说明如下。

表-1 脚本参数说明表

参数序号 | 参数名称 | 说明
$1 | peer-node-ip | 对端主机管理网络的IP地址，即新装服务器中作为Slave主机的IP地址。
$2 | peer-node-root-password | 对端主机root用户密码。
$3 | controller-root-password | 仲裁主机root用户密码，仲裁方式是简易Ping方式时，不需要设置该参数。

  2. 执行结果说明。

  • 执行成功

脚本执行完毕后，出现以下字样，则表示双机热备单机故障恢复成功。

“--------------Master/Slave Restore Success--------------”

  • 执行失败

如果执行失败，则在执行脚本过程中，会出现“ERROR….”失败提示信息，且程序将会自动中止执行。

详细的错误信息保存在/var/log/cvm_master.log和/var/log/cvm_master_slave.log日志文件中。

恢复完成后再次登录管理平台，如果热备管理的非双机热备主机的业务主机状态显示为不正常，重新连接业务主机即可。

重新注册

双机热备单机故障恢复后，产品可能需要重新注册。

  • 如果是硬盘故障，更换硬盘恢复成功后，采用原先申请的License注册文件在已恢复主机中重新注册即可。即故障恢复成功后，已恢复主机是作为Slave主机运行，此时需要进行主备切换，切换后，已恢复主机作为Master主机提供服务，此时通过虚拟IP地址登录管理系统进行注册即可。

  • 如果是新更换服务器，需要重新申请License注册文件，并重新注册，具体请参考双机热备产品注册。

  • 其他诸如断电、网络等故障，不必重新进行产品注册。


双机热备服务启动/关闭控制

ms_resource_stop.sh和ms_resource_start.sh两个脚本的主要作用是临时中止业务，进行主机维护。

· 老双机热备是为了切换，现在主要用于研发定位和处理问题使用。

· 通过ms_resource_stop.sh命令关闭双机热备服务后，两台热备主机并未分离，不能单独把其中一台主机再作为管理主机或业务主机使用。

脚本实现

  • ms_resource_stop.sh

关闭双机热备功能。命令执行过程中，命令不能中断（Ctrl+C中断）；执行命令时，主机不能关机或重启。该脚本没有调用参数。

  • ms_resource_start.sh

开启双机热备功能。当使用ms_resource_stop.sh关闭双机热备功能后，可以使用ms_resource_start.sh重新启用双机热备功能。命令执行过程中，命令不能中断（Ctrl+C中断），执行命令时，主机不能关机或重启。该脚本有一个可选参数。

脚本执行举例

在两台主机中任意一台执行即可。

以root用户登录主机，执行ms_resource_stop.sh脚本或ms_resource_start.sh脚本。

root@node01:/#ms_resource_stop.sh

或者

root@node01:/#ms_resource_start.sh


常用命令

查询双机热备主机状态

双机热备功能安装后，可以通过crm status命令查询双机热备主机中各服务的启动状态。

  • 双机热备启用成功，双机都正常的状态，如下所示。

root@node1:~# crm status

master : node1 (Online)

slave : node2 (Online)

quorum : [controller] node3 (Online)

-------------------------------------------

webip : [172.16.60.55] Started node1

Master/Slave Set: [/var/lib/mysql-share]

Master: [node1]

Slave : [node2]

mysql : Started node1

tomcat: Started node1

-------------------------------------------

  • 双机热备启用成功，node1主机故障，主备切换后的状态，如下所示。

root@node2:~# crm status

master : node2 (Online)

slave : node1 (Offline)

quorum : [controller] node3 (Online)

-------------------------------------------

webip : [172.16.60.55] Started node2

Master/Slave Set: [/var/lib/mysql-share]

Master: [node2]

Slave : [Unknown]

mysql : Started node2

tomcat: Started node2

-------------------------------------------

  • 双机热备安装或启用失败，主机状态，如下所示。

root@node1:~# crm status

cmsadm: failed to connect to cmsd

drbd脑裂判断

双机热备环境中，可以通过drbd-overview命令查看是否出现drbd脑裂。

若有StandAlone，表示已出现drbd脑裂。

已出现drbd脑裂：

root@node1:~# drbd-overview

0:r0/0 StandAlone Secondary/Unknow UpToDate/DUnknown r-----

0:r1/0 Connected Secondary/Primary UpToDate/UpToDate C r-----

删除本地同步分区

同步分区不支持界面删除，也不建议后台删除。但若增加的同步分区因为某些原因必须要删除时，可以在后台主服务器上执行ms_rm_sync_partion.sh r1命令，确定要删除时输入yes。请慎用。

  1. 删除本地同步分区。

root@node1:~# ms_rm_sync_partition.sh r1

Please confirm to delete r1 sync partition [yes/no]:

yes

Success to delete sync r1.

  2. 后台查看drbd-overview输出只有r0/0行，说明删除成功。

root@node2:~# drbd-overview

0:r0/0 Connected Primary/Secondary UpToDate/UpToDate C r----- /var/lib/mysql-share ext4 19G 91M 18G 1%


动态资源扩展

功能简介

企业或行业的某些业务系统访问量会出现周期性或随机性的波动，峰值访问量甚至可能超出正常访问量的几十倍或上百倍，典型的应用包括节假日期间的火车购票系统、开学期间的高校选课系统等。

如果按照峰值访问量部署业务系统，则会对IT硬件资源造成极大的浪费，因为这些硬件资源只在相对较短的时间段内提供服务，其余大部分时间都处于闲置状态；如果按照平均访问量部署业务系统，则无法满足访问峰值时的性能要求。

图-1 业务系统访问量模型

CAS提供了独创的面向应用的云资源动态扩展技术（DRX），实时监控承载了特定应用的虚拟服务器组的CPU、内存、TCP连接数、网络吞吐量、磁盘I/O吞吐量和IOPS性能等负载状况，在业务突发时自动扩展业务虚拟机进行流量负载分担，峰值过去后自动回收资源再利用，提高资源利用率，增加业务的灵活性，降低管理难度。

原理简介

下面从业务流程角度，阐述动态资源扩展与回收的实现原理。

图-2 DRX解决方案业务流程示意图

  • 在负载均衡模块（如F5负载均衡设备或软件负载均衡）上配置虚服务和实服务组，实服务组中的每一个实服务对应一个虚拟服务器，实服务中的IP地址就是虚拟服务器的IP地址，同时为实服务组配置调度算法和健康检测算法。

  • 在管理平台上配置虚拟资源动态扩展策略和动态回收策略，这些策略指定了资源扩展和回收的触发条件，可以是CPU利用率、内存利用率或TCP连接数上下限阈值，也可以是这些指标的任何组合。

  • 管理平台中的业务负载监控模块对虚拟服务器的负载状况进行实时监测，当业务访问量激增的时候，虚拟服务器的负载会上升到超出设定的上限阈值，此时，管理平台会根据虚拟机模板克隆一个或多个完全一样的业务系统。

  • 负载均衡模块检测到新的虚拟服务器上线，根据调度算法将新的连接请求分发到新的虚拟服务器上，最终使得整个业务系统的负载重新趋于平稳。

  • 当访问量下降之后，虚拟服务器上的负载也会随之下降，管理平台中的业务负载监控模块检测到虚拟服务器组内的负载低于设定的回收策略阈值时，关闭或删除资源占用率最低的虚拟服务器，从而将虚拟资源进行有效回收，腾出更多的资源给物理主机上的其它虚拟服务器使用。

  • 当访问量持续下降之后，管理平台中的业务资源调度模块继续关闭或删除资源占用率最低的虚拟服务器，直到最终只剩下原始的虚拟服务器为止。


配置流程

图-1 动态资源扩展的配置流程

表-1 流程说明

操作 | 说明
增加动态资源扩展业务 | 动态资源扩展业务是将集群内多个实现同一业务的虚拟机添加到一个业务虚拟机组中，通过定时检查业务虚拟机组中虚拟机的连接数、CPU和内存的平均利用率，并根据设置的资源扩展监控策略及注入模式、资源回收监控策略及回收模式，自动调整业务虚拟机组中虚拟机的数量。
配置监控参数和调度策略 | 可选。 在动态资源扩展业务对应的业务虚拟机组中，如果虚拟机的CPU、内存平均利用率以及连接数、网络流量、磁盘I/O、磁盘请求连续符合或者超过扩展监控策略中阈值的时间达到设置的持续时间，系统将自动为业务虚拟机组创建虚拟机；如果虚拟机的CPU、内存平均利用率以及连接数、网络流量、磁盘I/O、磁盘请求连续低于回收监控策略中阈值的时间达到设置的持续时间，系统将自动回收业务虚拟机组中的虚拟机。
配置定时扩展策略 | 可选。 定时扩展策略用于在指定时间周期内强制扩展虚拟机。某些应用系统的业务峰值是可以预知的，例如学校的选课系统。在每学期末的选课时间段里，系统总是异常繁忙，其他时间段则相对空闲。当选课系统应用定时扩展策略后，到达该时间段时，云计算管理平台会对选课系统所在的虚拟机进行自动扩展，而不管实际业务负载的大小，提升学生在选课时的访问体验。
配置纵向扩展策略 | 可选。 纵向扩展策略可以在指定条件下扩展业务虚拟机组内虚拟机的CPU和内存。当虚拟机的CPU、内存利用率超过纵向扩展策略中设置的阈值时，系统将自动为业务虚拟机组内的虚拟机增加相应的CPU或者内存。
配置LB联动资源 | 可选。 负载均衡设备与动态资源扩展业务联动，对外提供弹性伸缩的业务资源池。


增加动态资源扩展业务

  1. 单击导航树中[云业务/动态资源扩展]菜单项，进入动态资源扩展业务列表页面。

  2. 单击<增加动态资源扩展>按钮，弹出增加动态资源扩展对话框。

图-1 设置基本信息

  3. 设置业务名称等参数，LB设备可以选择后续再绑定，本节以先不绑定LB设备为例进行介绍。

表-1 配置基本信息

说明

说明

集群

动态资源扩展业务所运行的集群。

存储

指定存储池后，动态扩展的虚拟机只会使用此处指定的共享存储池。

虚拟机个数

动态资源扩展业务支持的虚拟机最大个数，即对应的业务虚拟机组允许存在虚拟机的最大个数。只能输入整数，默认为20。

生效类型

动态资源扩展业务是否生效，包括立即生效、时间段内生效、不生效，默认为立即生效。

  • 立即生效：指动态资源扩展业务在创建完成后立即生效。

  • 时间段内生效：指动态资源扩展业务在设置的时间段内生效。

  • 不生效：指动态资源扩展业务不生效。

生效开始时间

动态资源扩展业务生效的开始时间。当生效类型选择“时间段内生效”时需设置此参数。只设置起始时间，表示在该时间之后，动态资源扩展业务将一直生效。

生效结束时间

动态资源扩展业务生效的结束时间。当生效类型选择“时间段内生效”时需设置此参数。只设置结束时间时，表示动态资源扩展业务从当前时间到结束时间一直生效。

绑定LB联动资源

动态资源扩展业务虚拟机组是否绑定LB负载均衡设备。选择“是”时，需要设置“LB配置”的相关参数。此处也可以先不绑定LB设备，后续再通过“LB联动资源配置”功能进行配置。此处以先不绑定LB设备为例进行介绍。

  4. 单击<下一步>按钮，设置持续时间和检查时间间隔。

图-2 轮询周期配置

表-2 轮询周期配置

说明 | 说明
持续时间 | 允许业务虚拟机组中虚拟机的CPU、内存的平均利用率以及连接数连续超过扩展监控策略中阈值或者连续低于回收监控策略中阈值的时间。只能输入整数，默认为30秒。
检查时间间隔 | 检查业务虚拟机组中虚拟机的CPU、内存利用率以及连接数的时间间隔。只能输入整数，默认为30秒。

  5. 单击资源注入配置，根据实际需要单击 [image] 图标，修改资源扩展的监控策略。选择资源注入模式和每次扩展的虚拟机个数。

图-3 资源注入配置

表-3 资源注入配置

说明

说明

资源注入配置

单击搜索图标，选择资源注入监控策略。可选择系统预置的“资源扩展监控策略”，或对预置的监控策略进行修改。也可以单击<增加>按钮定制监控策略。有关监控策略的修改与新增，请参见监控策略。

当业务虚拟机组中虚拟机的CPU利用率、内存利用率、连接数、磁盘I/O、网络流量、磁盘请求在持续时间内连续符合扩展监控策略设置的阈值时，动态资源扩展业务将启动资源扩展，即在业务虚拟机组中自动创建虚拟机。

资源注入模式

在业务虚拟机组中创建虚拟机的模式，包括快速部署、快速克隆，默认为快速部署。

  • 快速部署：通过选择的虚拟机模板，在业务虚拟机组中进行快速部署来创建新的虚拟机。

  • 快速克隆：通过选择被克隆的虚拟机，在业务虚拟机组中进行快速克隆来创建新的虚拟机。

每次扩展的个数

当动态资源扩展业务进行资源扩展时，每次创建的虚拟机个数。只能输入整数，默认为1。

  6. 单击资源回收配置，根据实际需要单击 [image] 图标，修改资源回收的监控策略。设置资源回收类型等参数。

图-4 资源回收配置

表-4 资源回收配置

说明

说明

资源回收配置

单击搜索图标，选择资源回收监控策略。可选择系统预置的“资源回收监控策略”，或对预置的监控策略进行修改。也可以单击<增加>按钮定制监控策略。有关监控策略的修改与新增，请参见监控策略。

当业务虚拟机组中虚拟机的CPU利用率、内存利用率、连接数、磁盘I/O、网络流量、磁盘请求在持续时间内连续符合回收监控策略设置的阈值时，动态资源扩展业务将启动资源回收，即自动回收业务虚拟机组中的虚拟机。

资源回收类型

回收业务虚拟机组中虚拟机的策略，包括立即回收、温暖下线，默认为温暖下线。

  • 立即回收：当虚拟机达到回收条件时，立即对虚拟机执行回收动作。

  • 温暖下线：当虚拟机达到回收条件时，立即阻断虚拟机接收TCP报文，并每隔10秒钟查询一次虚拟机的发送报文数是否低于“回收阈值”。若低于“回收阈值”，则立即对虚拟机执行回收动作；若不低于“回收阈值”，则继续等待直到虚拟机的发送报文数低于“回收阈值”或者等待时间达到预置的“超时时间”，立即对虚拟机执行回收动作。

回收阈值

温暖下线回收虚拟机时，虚拟机发送报文数的最大值，默认为50。当资源回收模式选择“温暖下线”时，才需配置此参数。

超时时间

等待温暖下线回收虚拟机的超时时间，默认为10分钟。当资源回收模式选择“温暖下线”时，才需配置此参数。

资源回收模式

回收业务虚拟机组中虚拟机的模式，包括关闭虚拟机、删除虚拟机、休眠虚拟机，默认为关闭虚拟机。

  • 关闭虚拟机：指回收虚拟机时，直接关闭该虚拟机电源。

  • 删除虚拟机：指回收虚拟机时，直接删除该虚拟机。

  • 休眠虚拟机：指回收虚拟机时，直接将该虚拟机休眠。

保留运行的个数

动态资源扩展业务进行资源回收时，至少需要保留处于“运行”状态的虚拟机个数，默认为1。

  7. 单击<下一步>按钮，将运行同一个业务的若干虚拟机增加到一个业务虚拟机组中。

图-5 选择虚拟机加入业务虚拟机组

  8. 单击<下一步>按钮，设置扩展信息，单击<完成>按钮完成设置。

图-6 扩展信息设置

表-5 扩展信息设置

说明

说明

虚拟机模板

选择部署虚拟机所使用的虚拟机模板。当资源注入模式为“快速部署”时，需要配置此参数。

虚拟机克隆对象

选择虚拟机克隆的对象。当资源注入模式为“快速克隆”时，需要配置此参数。

这里的虚拟机克隆对象只能从被选定的虚拟机组中选择，且需要符合如下条件：

  • 磁盘镜像位于共享存储池上；

  • 虚拟机上不存在USB、PCI、SR-IOV、TPM设备；

  • 虚拟机未绑定NUMA节点或物理CPU；

  • 虚拟机磁盘的存储格式为智能。

虚拟机前缀名称

动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的名称前缀。

起始编号

动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的起始编号，将会显示在虚拟机名称前缀的后面。创建虚拟机时，虚拟机名称前缀后面的编号会一直不断的累加。

起始IP

动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的起始IP地址。

终止IP

动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的终止IP地址。在设置起始IP和终止IP时，需要预留足够的可分配IP地址。


配置监控参数和调度策略

  1. 单击导航树中的[云业务/动态资源扩展/<动态资源扩展业务名称>]，进入动态资源扩展业务的概要信息页面。

  2. 单击<业务监控>按钮，可以根据实际需要修改动态资源扩展业务的负载监控参数和扩展监控策略以及回收监控策略。

图-1 业务监控配置


配置定时扩展策略

  1. 单击导航树中的[云业务/动态资源扩展/<动态资源扩展业务名称>]，进入动态资源扩展业务的概要信息页面。

  2. 单击<定时扩展策略设置>按钮，弹出定时扩展策略对话框。

  3. 单击<增加>按钮，在弹出的对话框中设置定时扩展的信息，单击<确定>按钮完成操作。

图-1 增加定时扩展策略

  • 定时扩展频率为“每天”时，如果时间段的起始时间设置早于当前云计算管理平台的时间，则该定时扩展从第二天开始生效。

  • 定时扩展的轮询周期默认为10分钟，在定时扩展的时间段内，即使满足回收条件，动态资源扩展业务也不会回收虚拟机。

  • 在定时扩展的时间段外，如果业务虚拟机组内的虚拟机符合资源回收策略，扩展的虚拟机将会被自动回收。


配置纵向扩展策略

  1. 单击导航树中的[云业务/动态资源扩展/<动态资源扩展业务名称>]，进入动态资源扩展业务的概要信息页面。

  2. 单击<纵向扩展策略设置>按钮，弹出纵向扩展策略对话框。根据实际需要配置参数，单击<确定>按钮完成操作。

图-1 设置纵向扩展策略

表-1 设置纵向扩展策略

参数 | 说明
启用CPU设置 | 用于启用纵向扩展业务CPU策略。
CPU利用率 | 虚拟机的CPU利用率的纵向扩展阈值，超过该值就会给对应虚拟机增加CPU，默认为空。
每次扩展CPU | 系统每次给虚拟机增加的CPU个数，默认为空。
最大限制（CPU） | 虚拟机CPU扩展的最大限制，即业务虚拟机组内的虚拟机CPU核数的最大值，默认为空。
启用内存设置 | 用于启动纵向扩展业务内存策略。
内存利用率 | 虚拟机的内存利用率的纵向扩展阈值，默认为空。
每次扩展内存 | 系统每次给虚拟机增加的内存大小，默认为空。
最大限制（内存） | 虚拟机内存扩展的最大限制，即业务虚拟机组内的虚拟机内存的最大值，默认为空。


配置LB联动资源

  1. 单击导航树中的[云业务/动态资源扩展/<动态资源扩展业务名称>]，进入动态资源扩展业务的概要信息页面。

  2. 单击<LB联动资源配置>按钮，弹出LB联动资源配置对话框。根据实际需要配置参数，单击<确定>按钮完成操作。

图-1 LB联动资源配置

图-2 LB联动资源配置

参数 | 说明
起始IP | 动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的起始IP地址。
终止IP | 动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的终止IP地址。在设置起始IP和终止IP时，需要预留足够的可分配IP地址。
LB设备 | 动态资源扩展业务虚拟机组使用的负载均衡设备。负载均衡设备负责将流量根据设置的策略分发到后端各真正提供业务的虚拟机上。
虚服务器 | 虚拟服务器拥有一个虚拟IP，负责接收用户的访问请求，然后由负载均衡设备选择一个业务虚拟机进行响应。
实服务组 | 实服务组内是真实提供业务的虚拟机。
虚拟机业务端口 | 虚拟机提供业务的端口，不同的端口对应不同的服务。
实服务组调度算法 | LB设备根据调度算法来选择实服务组内提供服务的业务虚拟机。
实服务组健康检测方法 | LB设备会对实服务组内的业务虚拟机进行健康检测，当发现某个虚拟机不能提供服务后，后续的请求均不会发往该虚拟机。虚拟机恢复后，LB设备会恢复对该虚拟机的使用，这一过程对用户来说是透明的。


智能资源调度

智能资源调度支持将同一集群内的不同主机上的物理GPU资源添加到一个GPU资源池中，将多个实现同一类业务的虚拟机加入到一个业务虚拟机组中；当业务虚拟机组中的虚拟机启动或者重启时，系统根据虚拟机使用GPU资源的策略自动分配和释放GPU资源。

目前支持GPU、vGPU两种类型的资源池。

  • GPU类型的资源池用于GPU直通，GPU直通是通过VT-d技术，将物理GPU透传给某一个虚拟机，使虚拟机能够完全拥有物理GPU的资源与性能，满足行业用户对应用系统的性能要求。

  • vGPU类型的资源池，是将虚拟vGPU资源分配给虚拟机使用。

基于GPU资源池虚拟化技术的集群具有如下特点：

  • 当业务虚拟机需要进行非编任务时，从GPU资源池中动态选择一个空闲的GPU资源给该虚拟机；当业务虚拟机所在宿主机中没有可用的GPU资源，而其他主机存在闲置的GPU资源时，虚拟机自动迁移到其他主机，并使用该主机上的GPU显卡资源。

  • 当业务虚拟机完成非编任务时，关闭虚拟机，则虚拟机自动将GPU资源释放到GPU资源池中，供其他虚拟机使用。

整个过程实现了完全自动化的管理，是一种按需分配与回收、自动弹性扩展的云服务。

图-1 GPU资源池动态调度


配置流程

配置GPU直通。其操作流程如下：

流程说明如下：

操作 | 说明
主机启用IOMMU功能 | 必选。 配置GPU直通前，主机必须启用IOMMU功能。配置IOMMU后，需要重启主机生效。
配置GPU资源池 | 必选。 将同一集群内的不同主机上的用于GPU直通的物理GPU资源添加到一个GPU资源池中，将需要使用GPU直通的业务虚拟机加入业务虚拟机组中。 当业务虚拟机组中的虚拟机启动或者重启时，系统会根据GPU资源池内的资源情况以及虚拟机使用GPU资源的优先级为虚拟机分配GPU资源。
虚拟机安装显卡驱动 | 必选。 虚拟机分配到GPU资源后，需要在虚拟机操作系统内安装相应的显卡驱动，才能正确识别GPU显卡。


主机启用IOMMU功能

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，选择存在GPU显卡的主机，进入主机概要信息页面。

  2. 单击“高级选项”页签，进入启动项配置页面。将IOMMU配置状态设置为启用，单击<保存>按钮。

  3. 重启主机使配置生效。在主机概要信息页面单击<进入维护模式>按钮，使主机进入维护模式，单击<更多操作>按钮，选择[重启主机]菜单项重启主机。重启主机完成后退出维护模式。


配置GPU资源池

  1. 单击导航树中[云业务/智能调度资源]菜单项，进入智能调度业务列表页面。

  2. 单击<增加智能调度资源>按钮，弹出增加智能调度资源对话框。

  3. 设置业务名称为GPU直通，选择资源类型为GPU，单击<下一步>按钮，进入资源信息设置页面。

  4. 勾选加入资源池的GPU，单击<下一步>按钮，进入业务虚拟机组设置页面。

  5. 单击<增加>按钮，弹出增加智能调度业务虚拟机对话框。选择使用GPU设备的业务虚拟机，选择业务虚拟机所使用的业务模板，驱动类型为VFIO，设置是否独占GPU资源和虚拟机使用GPU资源的个数，单击<确定>按钮。

参数名称

参数说明

虚拟机

选择需要使用GPU资源且处于关闭状态的虚拟机，可以多选。所选虚拟机都会加入业务虚拟机组。

业务模板

  • 业务模板定义了在资源紧缺时，虚拟机使用资源的优先级以及应用低优先级业务模板的所有虚拟机占用资源的最高比例。每一个虚拟机都会应用一个业务模板。

  • 当虚拟机使用GPU资源的优先级较高时，请为其选择一个高优先级的业务模板。

  • 虚拟机抢占GPU资源的策略为：

  • 业务虚拟机组中的虚拟机应用相同优先级的业务模板时，先启动的虚拟机先获取GPU资源。

  • 资源池中的空闲GPU数量少于业务虚拟机组中即将启动的虚拟机数量时，高优先级虚拟机将优先获得GPU资源。

  • 当业务资源组中空闲的GPU数量少于业务虚拟机组中即将启动的高优先级的虚拟机数量，并且应用相同低优先级业务模板的虚拟机使用的资源比例总和超过该业务模板的分配比例时，系统将释放部份低优先级虚拟机已使用的GPU资源，以保障高优先级虚拟机的资源使用需求。

驱动类型

虚拟机GPU设备的驱动类型，仅支持VFIO。

资源独占

虚拟机是否独享GPU/vGPU资源。选择“否”，表示虚拟机在关闭状态下不会绑定GPU/vGPU资源。选择“是”，无论虚拟机处于何种状态，虚拟机会一直绑定GPU/vGPU资源，该GPU/vGPU资源为虚拟机独享，不能被其他虚拟机使用。只有当宿主机存在空闲GPU/vGPU资源，且该空闲资源已加入所选GPU资源池时，才允许开启资源独占。开启资源独占后，当集群内其他主机有满足条件的GPU/vGPU资源时，虚拟机在关机状态下允许迁移至该主机上，否则不允许迁移虚拟机。

资源个数

设置虚拟机使用GPU/vGPU资源的数量。选择vGPU类型的资源池时，资源个数最大值为1。选择GPU类型的资源池，且未开启资源独占，资源个数最大值为该资源池内单个主机的最大GPU数量，例如在该资源池中A主机有3个GPU，B主机有2个，C主机有2个，则最大值为3；若开启了资源独占，则资源个数最大值为该资源池内宿主机的空闲GPU数量。

  6. 在业务虚拟机组页面，单击<完成>按钮完成操作。

  7. 单击刚刚创建的智能资源调度业务，进入任务列表，启动虚拟机。

  8. 打开虚拟机控制台，在虚拟机操作系统内打开“设备管理器”，[其他设备]处新增“3D视频控制器”，或[显示适配器]处新增“标准VGA图形适配器”（设备图标上有告警标志），表示虚拟机已挂载GPU设备。


虚拟机安装显卡驱动

  1. 将配套的显卡驱动程序上传至虚拟机内。

  2. 安装显卡驱动程序。

  3. 显卡驱动程序安装完成后，打开“设备管理器”，[显示适配器]选项已正确显示显卡型号，GPU直通配置完成。


使用限制

  • 物理显卡必须支持NVIDIA GRID vGPU解决方案。

  • NVIDIA vGPU是许可产品，vGPU没有获得License授权时，其功能会受到限制。用户可以部署NVIDIA License Server来对vGPU进行授权。

  • 每个虚拟机只能绑定一个vGPU设备。

  • 每个物理GPU只能创建同一种类型的vGPU设备，但一块显卡上的不同物理GPU可以创建不同类型的vGPU设备。

  • 已经创建vGPU设备的物理GPU不能再用于直通，正在以直通方式使用的物理GPU不能再用来创建vGPU设备。

  • 显卡需要工作在图形模式。如果用户的显卡工作在计算模式，则必须使用gpumodeswitch工具将GPU的模式更改为图形模式。请参见NVIDIA的《gpumodeswitch User Guide》手册。


配置流程

vGPU资源池主要用于虚拟机配置vGPU设备。其操作流程如下：

流程说明如下：

操作 | 说明
创建vGPU设备 | 必选。 CAS集成了NVIDIA GRID vGPU技术，实现了GPU硬件虚拟化的解决方案。 创建vGPU设备前，主机上必须已经正确安装支持NVIDIA GRID vGPU技术的GPU显卡。
配置vGPU资源池 | 必选。 将集群内不同主机上虚拟化后的vGPU资源加入一个vGPU资源池，需要使用vGPU的虚拟机加入一个业务虚拟机组中，当业务虚拟机组中的虚拟机启动、重启时，系统会自动根据vGPU资源池中vGPU资源的空闲情况，以及虚拟机使用vGPU资源的优先级来动态的为虚拟机分配vGPU资源。
虚拟机安装vGPU显卡驱动 | 必选。 虚拟机分配到vGPU资源后，需要在虚拟机操作系统内安装相应的显卡驱动，才能正确识别vGPU。


创建vGPU设备

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，选择存在GPU设备的主机，进入主机概要信息页面。

  2. 选择“硬件配置”页签，单击<GPU设备>菜单项，进入主机GPU设备列表界面。

  3. 选择目标GPU设备，单击 [image] 图标，弹出增加vGPU对话框。

  4. 在vGPU类型下拉框中选择要虚拟的vGPU类型，单击<确定>按钮。


配置vGPU资源池

  1. 单击导航树中[云业务/智能调度资源]菜单项，进入智能调度业务列表页面。

  2. 单击<增加智能资源调度>按钮，弹出增加智能资源调度对话框。输入业务名称、描述，选择资源类型为vGPU。

  3. 单击<下一步>按钮，进入智能资源调度资源信息设置页面，在vGPU名称对应的下拉框中选择本次添加的vGPU资源池的类型，然后勾选加入资源池的vGPU。

一个资源池只能选择一种类型的vGPU。

  4. 单击<下一步>按钮，进入设置业务虚拟机组页面。单击<增加>按钮，弹出增加智能资源调度业务虚拟机对话框。

参数名称

参数说明

虚拟机

选择需要使用vGPU资源且处于关闭状态的虚拟机，可以多选。所选虚拟机都会加入业务虚拟机组。

业务模板

  • 所有的业务模板资源分配比例之和不能超过100%。

  • 系统会默认创建两个业务模板：非编业务和转码合成业务。这两个模板的资源分配比例之和为100%。所以如果需要新增业务模板，首先需要调整系统默认生成的两个模板的资源分配比例。使得所有业务模板的资源分配比例之和不超过100%。

  • 业务模板定义了在资源紧缺时，虚拟机使用资源的优先级以及应用低优先级业务模板的所有虚拟机占用资源的最高比例。每一个虚拟机都会应用一个业务模板。

  • 当虚拟机使用vGPU资源的优先级较高时，请为其选择一个高优先级的业务模板。

  • 虚拟机抢占vGPU资源的策略为：

  • 业务虚拟机组中的虚拟机应用相同优先级的业务模板时，先启动的虚拟机先获取vGPU资源。

  • 资源池中的空闲vGPU数量少于业务虚拟机组中即将启动的虚拟机数量时，高优先级虚拟机将优先获得vGPU资源。

  • 当业务资源组中空闲的vGPU数量少于业务虚拟机组中即将启动的高优先级的虚拟机数量，并且应用相同低优先级业务模板的虚拟机使用的资源比例总和超过该业务模板的分配比例时，系统将释放部份低优先级虚拟机已使用的vGPU资源，以保障高优先级虚拟机的资源使用需求。

驱动类型

虚拟机GPU设备的驱动类型，仅支持VFIO。

资源独占

虚拟机是否独享GPU/vGPU资源。选择“否”，表示虚拟机在关闭状态下不会绑定GPU/vGPU资源。选择“是”，无论虚拟机处于何种状态，虚拟机会一直绑定GPU/vGPU资源，该GPU/vGPU资源为虚拟机独享，不能被其他虚拟机使用。只有当宿主机存在空闲GPU/vGPU资源，且该空闲资源已加入所选GPU资源池时，才允许开启资源独占。开启资源独占后，当集群内其他主机有满足条件的GPU/vGPU资源时，虚拟机在关机状态下允许迁移至该主机上，否则不允许迁移虚拟机。

资源个数

设置虚拟机使用GPU/vGPU资源的数量。选择vGPU类型的资源池时，资源个数最大值为1。选择GPU类型的资源池，且未开启资源独占，资源个数最大值为该资源池内单个主机的最大GPU数量，例如在该资源池中A主机有3个GPU，B主机有2个，C主机有2个，则最大值为3；若开启了资源独占，则资源个数最大值为该资源池内宿主机的空闲GPU数量。

  5. 单击<完成>按钮。

  6. 单击刚刚创建的智能资源调度业务，进入任务列表，启动虚拟机。

  7. 打开虚拟机控制台，在虚拟机操作系统内打开“设备管理器”，[其他设备]处新增“3D视频控制器”，或[显示适配器]处新增“标准VGA图形适配器”（设备图标上有告警标志），表示虚拟机已挂载GPU设备。


虚拟机安装vGPU显卡驱动

  1. 将从NVIDIA官网获取的驱动程序通过共享的方式上传至虚拟机。

  2. 双击安装程序，进入安装界面，根据安装向导，完成驱动程序的安装。

  3. 驱动安装完成后，重启虚拟机。

虚拟机安装NVIDIA显卡驱动后，VNC控制台不可用，请使用远程桌面协议连接虚拟机，例如RGS、Mstsc。

  4. 使用远程桌面连接虚拟机，打开设备管理器，[显示适配器]选项已正确显示vGPU的型号，表示虚拟机已正确配置vGPU。


云彩虹

云彩虹就是在两个数据中心之间构建虚拟资源共享的桥梁。当某个虚拟化资源池的计算或存储资源不足时，可以将其中一些虚拟机的计算和存储资源在线迁移到另一个虚拟化资源池，业务不中断，实现跨物理边界的虚拟资源共享。

图-1 云彩虹解决方案

云彩虹解决方案对于同城异地数据中心之间的资源共享具有较大的意义，例如，当数据中心机房 #1资源不足、机房改造或硬件更新升级时，可以将其中一些虚拟机在线迁移到同城裸光纤连接的数据中心机房 #2，且业务不中断。


使用限制

  • 两个虚拟化管理系统所在的数据中心机房地理距离建议不要超过30公里，长距离网络传输的时延与抖动可能导致虚拟机数据迁移失败。

  • 两个虚拟化管理系统之间的网络带宽建议为万兆链路聚合或裸光纤直连，两个超融合管理平台之间三层网络互通。

  • 两个虚拟化管理系统之间的软件版本相同。


注意事项

  • 在线迁移虚拟机时，除了通过网络链路复制虚拟机磁盘镜像文件之外，还需要反复同步虚拟机内存，因此，建议选择内存变化不频繁的时间段进行迁移。

  • 源资源池和目的资源池必须具有相同名称的网络策略模板和虚拟交换机，否则，虚拟机云彩虹将失败。

  • 如果虚拟机挂载了光驱、软驱、PCI、USB或块设备，则不允许在线迁移此虚拟机。

  • 虚拟机在线迁移的最后阶段，可能会导致短暂的业务中断，例如，通过持续Ping被迁移虚拟机IP地址时，丢包数在0~2个，视被迁移虚拟机当时的内存压力与内存变化频繁程度而定。

  • 虚拟机在线迁移到目的虚拟化管理平台之后，连接该虚拟机的控制台会中断，属于正常现象，原因是迁移后的业务主机IP地址及VNC端口号都发生了变化。

  • 虚拟机在线迁移之后，无论IP地址为静态IP地址或者DHCP动态分配，迁移前后的IP地址都保持不变。

  • 待迁移虚拟机所在主机加入集群的IP地址类型必须和迁移目的主机加入集群的IP地址类型一致。

  • 若待迁移虚拟机的磁盘在NFS类型的存储池上，且磁盘缓存方式为一级虚拟缓存(None)或者直接读写(Directsync)，请先关闭虚拟机后再迁移，否则虚拟机将迁移失败。

  • 在CVM间迁移虚拟机时，不允许在两个CVM上对主机执行连接主机操作。


配置流程

云彩虹实现了当前数据中心与其他数据中心资源的共享，是构建云间资源共享的桥梁，提供了虚拟机在不同数据中心云计算管理平台之间在线迁移且业务不中断的功能。

云彩虹配置流程如下：

流程说明如下：

操作 | 说明
配置本地和远端数据中心 | 必选。 配置本地和远端云计算管理平台的访问IP、登录方式、用户名和密码等信息。
在线迁移虚拟机 | 必选。 在两个数据中心间在线迁移虚拟机。


创建虚拟机

  1. 系统管理员登录本地数据中心的CVM虚拟化管理系统，创建1个新的虚拟机（VM），虚拟机配置如下表所示。

表-1 虚拟机配置表

资源 | 大小
虚拟CPU个数 | 1路2核
虚拟内存大小 | 4GB
虚拟磁盘大小 | 80GB（本地磁盘）
虚拟磁盘类型 | 默认（1 * Virtio，高速）
虚拟磁盘格式 | 默认（智能，QCOW2）
虚拟磁盘缓存模式 | 默认（直接读写，directsync）
虚拟网卡类型 | 默认（1 * Virtio）
虚拟交换机 | 默认（vSwitch0）
网络策略模板 | 默认（Default）
IP地址/掩码 | 192.168.20.125/24

上述虚拟机资源配置仅为测试环境下的配置，不作为生产环境中业务虚拟机的推荐配置。生产环境中的虚拟机配置应该根据业务系统本身对CPU、内存、磁盘和网卡等资源的实际需求进行评估和测试后最终确定。

  2. 通过控制台（VNC）为虚拟机挂载Windows Server 2008 R2数据中心版64位操作系统光盘镜像之后，启动虚拟机，安装虚拟机操作系统。

图-1 为虚拟机安装操作系统

操作系统的安装与自定义配置（例如，磁盘分区、管理员账号设置、组件安装等）应根据实际生产业务系统自身的需求设置。

  3. 在CVM虚拟化管理系统上为虚拟机挂载CAStools工具，并在虚拟机操作系统内安装CAStools工具软件。

  4. 虚拟机操作系统安装成功之后，为虚拟网卡配置静态或动态IP地址。IP地址可以在操作系统内部手工配置，也可以通过CAStools工具下发配置。

图-2 通过CAStools配置虚拟网卡IP地址

  5. 为了验证云彩虹对虚拟机业务的影响，我们在云彩虹之前，首先在虚拟机操作系统内安装一个FTP客户端工具软件，并从一个预先架设好的FTP服务器上下载文件，验证迁移过程中FTP业务的中断情况。

图-3 通过FTP服务验证云彩虹对虚拟机业务的影响


配置本地和远端数据中心

  1. 登录本地数据中心CAS云计算管理平台，在导航栏中依次选择[云业务/云彩虹]，进入云彩虹配置页面。

  2. 单击本地数据中心图标，在弹出的“本地数据中心”信息卡中单击<配置数据中心>按钮。

  3. 在弹出的“配置本地数据中心”对话框中，输入本地数据中心名称和当前CAS云计算管理平台的管理IP地址，单击<确定>按钮。

  4. 单击云彩虹主界面右侧的 [image] 图标，增加远端数据中心CAS云计算管理平台。在弹出的“增加数据中心”对话框中设置远端CAS云计算管理平台的各项参数，单击<确定>按钮。

参数 | 说明
名称 | 必选项。用于标识数据中心的名称，最大支持36个中文或英文字符。
描述 | 可选项。用于描述数据中心，最大支持120个中文或英文字符。
IP地址 | 必选项。数据中心中部署的CAS云计算管理平台的管理IP地址。
登录方式 | 必选项。登录数据中心CAS云计算管理平台的应用层协议，默认为HTTP。
端口 | 必选项。通过HTTP访问数据中心时，默认端口号为8080；如需通过保密模式访问数据中心则选择HTTPS，默认端口号为8443。
用户名 | 必选项。访问远端数据中心CAS云计算管理平台的系统管理员账户，可以填写admin账户。
密码 | 必选项。访问远端数据中心CAS云计算管理平台的管理帐号对应的密码。

  5. 成功连接新增加的CAS云计算管理平台之后，界面显示如下图所示。左侧为本地数据中心拓扑，右侧为远端数据中心拓扑。


在线迁移虚拟机

  1. 鼠标点击左侧拓扑中的主机，查找到需要在线迁移的虚拟机，或者在左侧拓扑右上角的搜索框中键入需要在线迁移的虚拟机名称，回车。按住鼠标左键，将需要在线迁移的虚拟机拖拽到右侧拓扑的目的地主机上。

  2. 在弹出的“迁移配置”配置向导中，配置好相关参数，单击<下一步>按钮。

配置参数 | 含义
迁移超时时长 | 迁移处于运行状态的虚拟机的超时时间。默认值为20分钟。 例如：当迁移超时时长设置为20分钟，若虚拟机在20分钟内未完成迁移，系统将暂停该虚拟机，以便其可以快速完成迁移，待迁移完成后，再将该虚拟机恢复为运行状态。 当该参数设置为0时，系统将不会暂停虚拟机，虚拟机在迁移过程中始终处于运行状态。
压缩 | 表示是否将需要传输的内存数据进行压缩，减少数据传输的总量。默认为不压缩。

  3. 选择虚拟机迁移的目标存储位置，单击<完成>按钮，开始迁移虚拟机。

  4. 打开任务台，可以查看虚拟机在线迁移的进度。

  5. 在与被迁移虚拟机三层互通的PC机或虚拟机上，打开命令行终端，持续Ping被迁移虚拟机的IP地址，观察在线迁移过程中的业务中断情况。


验证迁移结果

  1. 在任务台中，可以看到云彩虹迁移的进度为100%。登录远端数据中心的管理平台，可以看到被迁移的虚拟机已成功运行，且IP地址保持不变。

  2. 在管理平台的操作日志中，可以看到云彩虹迁移日志。

  3. 通过控制台打开被迁移虚拟机，发现虚拟机操作系统界面维持在FTP下载界面，且FTP业务仍在正常继续。

图-1 通过FTP服务查看被迁移虚拟机运行状态


异构平台迁移配置指导

功能简介

通过异构平台迁移功能，可以将X86服务器，包括传统硬件架构、CVM虚拟机、异构云平台虚拟机，迁移到CVM虚拟化管理系统。该功能将安装了迁移客户端的物理服务器或虚拟机，作为待迁移的源设备，将CVM中的虚拟机作为迁移的目的虚拟机，通过迁移源设备的磁盘数据，实现P2V及V2V迁移。

使用限制

  • 磁盘增量迁移/增量备份时，有如下限制：

项

限制

单卷/单盘容量

  • 最大容量<=128TB

  • 32TB以下有较好的热迁移效果

增量大小

增量间隔时间内，允许数据变化范围<=1TB

  • EXT2/EXT3/EXT4文件系统执行精简迁移/备份容灾时，单文件系统容量需小于4TB。

  • 更多使用限制请参见对应版本的版本使用指导书，或者联系技术支持。

配置流程

异构平台迁移过程分如下几个步骤：

表-1 配置流程

操作 |  | 说明
源设备迁移准备 | 安装客户端 | 从CVM管理系统下载迁移客户端。
 | 查看源设备 | 在源设备安装客户端，源设备与CVM连接，并上报设备状态，CVM获取源设备信息。
目标虚拟机准备 | 获取PE镜像 | 目标虚拟机挂载PE镜像。
 | 创建虚拟机
 | 安装并配置TargetClient | 目标虚拟机通过PE镜像引导，配置TargetClient，通过Target_Client与CVM连接，并上报目标虚拟机设备状态，CVM获取目标虚拟机信息。
迁移源设备 | 创建迁移任务 | 用户创建并启动迁移任务，客户端获取迁移指令。
 | 驱动配置 | 迁移系统盘和数据盘。
 | 登录目标虚拟机

图-1 异构平台迁移流程

配置环境

将VMware vSphere中的虚拟机Win2012r2_64，迁移到CAS CVM中命名为Windows2012的虚拟机中。

图-2 配置需求


安装客户端

下载并上传客户端

  1. 单击导航树中[云业务/异构迁移平台]菜单项，进入异构迁移平台概要界面。点击“客户端下载”页签。客户端代理的服务器IP地址默认为CVM管理网IP地址。

· 当CVM管理网IP地址变化后，可以通过“客户端下载”页签中的<更新客户端代理IP地址>功能，来更新服务器IP，将客户端代理的服务器IP地址更新为变化后的CVM管理网IP地址。该功能只有在迁移License激活后才能使用。

· 对于CentOS版本，如果在安装的时候没有配置网络参数，会导致CAS侧无法识别到安装了Agent的虚拟机，若要使用异构平台迁移功能，需要安装过程中配置好管理网IP。

  2. 选择所需的客户端，点击对应操作系统的下载链接进行下载。该操作有两种可用方式。

  • 选择对应的客户端安装包下载。下载的安装包为zip压缩包，名字通常以Clone_Client开头（如Clone_Client_Redhat5x86_64.zip）。解压缩后使用FTP工具将已经解压缩的客户端安装包安装传输到客户机。

  • 选择匹配的应急客户端安装包。点击 [image] 图标，生成URL下载链接，复制下载链接至远程登录界面（提前连接客户端），下载客户端安装包。

图-1 下载迁移客户端

安装客户端

建议安装客户端前关闭源设备防火墙及相关安全策略。如源设备为云平台虚拟机，请确认安全组策略是否已开放迁移工具端口。

  1. 进入源设备控制台

图-2 进入控制台

  2. 双击客户端安装程序Clone_Client_Win.exe，弹出选择安装语言窗口，如下图所示。选择安装时要使用的语言，点击<确定>。

图-3 选择安装语言

  3. 同意许可协议，选择安装路径，开始安装。当弹出如下图所示的窗口时，选择安装CDP驱动程序。

图-4 安装CDP驱动

  4. 安装完成后需要重启源设备，完成安装。

对于Windows系统的源设备，重启会导致业务中断，请合理安排重启时间。

图-5 安装完成


查看源设备

单击[云业务/异构迁移平台]菜单项，查看安装了迁移客户端的设备已经出现在“源设备”列表中，等待配置迁移任务。

源设备名称默认取操作系统的计算机名。

图-1 查看源设备


获取PE镜像

产品提供了Win10PE、Centos7PE两种PE的iso，分别用于Windows系统迁移和Linux系统迁移。

  • Win10PE：如果迁移源设备的系统是Windows，则需要在目标设备运行Win10PE。

  • Centos7PE：如果迁移源设备系统是Linux，则需要在目标设备运行Centos7PE。


创建虚拟机

在虚拟化管理系统的主机上，单击<增加虚拟机>按钮，创建虚拟机，作为迁移的目标虚拟机。创建的虚拟机的磁盘容量和大小，都不能小于源设备的磁盘。

图-1 创新虚拟机


安装并配置TargetClient

  1. 在目标虚拟机上运行挂载PE镜像。单击<修改虚拟机>/<光驱>，为虚拟机挂载PE镜像。

图-1 挂载PE镜像

  2. 启动虚拟机，PE镜像引导自动运行TargetClient程序，进入云迁移平台。

  3. 单击左下角<网络配置>，为目标虚拟机添加网络，用于目标虚拟机与管理平台通信。配置好后，单击<确定>按钮，完成添加网络。

此处添加的网络，是一个临时的IP地址，仅用于虚拟机与管理平台间的通信，当虚拟机重启后，IP地址消失。迁移完成后可根据网络规划重新配置虚拟机的IP地址。

图-2 配置虚拟机临时IP

  4. 在云迁移平台中，输入CVM虚拟化管理系统IP地址，输入本机名（限定30字符）用于在管理平台标识本机。还可以根据需要，指定本虚拟机IP，与CVM建立连接。配置好后，点击右侧箭头图标登录。

指定本机IP为可选项，在多IP、浮动IP、公网IP等场景下，通过指定本机IP为公网IP或浮动IP，使源设备连接到目标虚拟机。

图-3 配置TargetClient参数

  5. TargetClient与管理平台连接，显示TargetClient已经登录管理平台，目标虚拟机已登录，等待配置任务。

图-4 目标虚拟机登录

  6. 单击[云业务/异构迁移平台]菜单项，查看虚拟机已经出现在“目标虚拟机”列表中，作为迁移的目标虚拟机。设备状态为在线，只有在线状态的虚拟机，才能作为迁移任务的目标虚拟机。

此处的设备状态，指TargetClient是否与管理平台正确连接，如连接正常，仍无法配置迁移任务，请查看是否存在网络地址冲突等问题。

图-5 目标虚拟机添加成功


创建迁移任务

  1. 创建迁移任务。单击导航树[云业务/异构平台迁移]/<创建迁移任务>按钮，弹出创建迁移任务对话框，进行目标匹配。选择待迁移的源设备、目标虚拟机。

图-1 选择源设备与目标虚拟机

  2. 选择迁移的磁盘，并匹配目标磁盘，单击<确定>。系统缺省会为每一个源设备磁盘匹配一个目标磁盘。所有被勾选的源设备磁盘，都必须匹配相同或更大容量的目标磁盘。如果源设备磁盘是动态盘，目标磁盘和源设备磁盘大小必须相同。

· 仅系统盘和数据盘是可选状态

· 目标磁盘的数据，包括分区表会被擦除，迁移后讲被完全还原成与源设备磁盘一致的数据。

· LVM没有对应的物理磁盘，是一个逻辑盘，它存在于物理盘之上，所以无需为LVM选择目标磁盘。

图-2 匹配磁盘

  3. 进行任务配置，配置自动增量迁移周期、迁移限速、迁移方式、通道压缩。单击<立即启动>，开始迁移。也可单击<保存任务>，暂时不启动，待需要时，从迁移任务列表启动迁移。

· 迁移任务一旦创建，即将迁移授权下发给源设备。一个源设备占用一个授权点数。源设备获取授权后，可以针对一个迁移任务多次执行迁移，也可以创建多个迁移任务。

· 授权一旦下发，不能取消。如因网络等原因，导致迁移任务未成功创建，授权也不会回收，此时请排查原因，重新创建迁移任务。

图-3 迁移任务配置

  4. 查看迁移任务列表。单击导航树[迁移任务]页签，进入迁移任务列表，查看迁移任务已经成功创建。迁移任务列表每隔30秒自动刷新。

迁移任务默认以源设备名称命名。

图-4 迁移任务列表。

  5. 查看迁移任务详情。直接在迁移任务列表单击源设备名，进入迁移任详情页面，可以查看任务进度、设备信息、日志。

迁移任务的进度，是通过定时采样计算的，当一个迁移任务中有较多磁盘时，有可能出现整体进度没有及时刷新的情况，此时请耐心等待进度刷新，并不影响迁移任务。也可以通过查看设备信息中具体每个磁盘的迁移状态，了解迁移进度。

图-5 查看迁移任务详情

  6. 结束任务。迁移任务完成后，需要手动执行结束，否则迁移任务会按照配置的自动增量迁移周期，自动周期性地进行迁移。请先将源设备相应服务停止，防止新数据产生，再点击结束。在迁移任务详情界面，单击<结束>按钮，结束迁移任务。

· 在配置任务的时候，也配置了自动增量迁移周期，用于在迁移任务执行过程中，对源设备已迁移的数据变化进行增量迁移的周期。自动增量迁移会在手动结束任务前，一直周期性进行。

· 未手动结束迁移任务前，可以通过<立即增量迁移>功能，手动执行多次增量迁移，将源设备新增数据同步到目标虚拟机。

· 手动结束任务时，也会自动执行一次增量迁移，但是一旦任务结束了，即不能对同一个源设备新增的数据进行迁移了，只能通过<还原配置>重新配置任务，进行完全的迁移。

图-6 结束任务


驱动配置

  1. 当系统检测到源设备和目标虚拟机存在驱动兼容风险时，会在迁移详情页面提示该风险。待迁移结束后，需要手动导入所需的驱动，避免因为驱动不兼容，导致目标虚拟机无法启动。

  2. 在任务详情界面，单击<驱动配置>按钮，弹出驱动配置对话框。

图-1 驱动配置

  3. 点击<导出硬件信息>按钮，目标设备的磁盘的硬件信息将会以.txt文件的形式被导出。（如果没有自动弹出下载，请至浏览器下载目录下找到此txt文件，名字为“目标虚拟机名称驱动硬件信息.txt”，打开文件，查看所需驱动信息，即适配的系统信息。

图-2 导出硬件信息

  4. 制作驱动程序文件。用待导入的驱动文件（通常Windows驱动为.sys或.inf文件，Linux驱动为.ko文件）生成ZIP压缩包（包内不要有多层目录），并命名为mptspi.zip。

  5. 将压缩包mptspi.zip导入管理平台。点击<导入驱动文件>按钮，在弹出对话框将驱动程序导入管理平台。

图-3 导入驱动

  6. 完成驱动导入后，TargetClient提示手动注入驱动程序，单击<驱动注入>，将驱动安装到目标虚拟机中。

图-4 注入驱动


登录目标虚拟机

  1. 进入目标虚拟机控制台，关闭云迁移平台。

  2. 在弹出的提示框中，单击<确认>，重启目标虚拟机。

重启虚拟机时，如果出现无法进入系统，提示找不到分区或磁盘等情况，需要关闭电源，重新启动，并在重启过程中选择CAS引导启动。

图-1 重启目标虚拟机

  3. 输入登录用户名和密码，进入目标虚拟机，查看目标虚拟机已经完全迁移了源设备的数据。

目标虚拟机用户名和密码默认和源设备一致。

图-2 登录目标虚拟机


迁移兼容性

操作系统兼容性

云迁移平台系统客户端所支持如下操作系统：

表-1 操作系统兼容性

类别

OS列表

备注

Windows系统

  • Windows Server 2003

  • Windows Server 2003 SP2 x86/x64

  • Windows Server 2003 R2 SP2 x86/x64

  • Windows Server 2008

  • Windows Server 2008 SP1 x64

  • Windows Server 2008 SP2 x86

  • Windows Server 2008 R2 SP1 x64

  • Windows Server 2012

  • Windows Server 2012 x64

  • Windows Server 2012 R2 x64

  • Windows Server 2016

  • Windows Server 2016 x64

1. 属于大类别，但未在详细版本列表中的版本，也兼容。

2. 不兼容Windows桌面版本。

Linux系统

Redhat 4/5/6 32bit

Redhat 4/5/6/7 64bit

Centos 6 32 bit

Centos 6/7 64 bit

Ubuntu 10/12/14 32bit

Ubuntu 16 64bit

中标麒麟（X86） 5.0/6.0/6.5/6.7/V7 64bit

银河麒麟（X86） 3.2/6.7 64bit

RedFlag 5.0 32bit

RedFlag 6.2/6.3/7.0 64bit

RedFlag axws3-64

Suse 10/11 32bit

Suse 10/11/12 64bit

1. Linux系统兼容性还需参考内核兼容性：2.6.18≤内核版本≤4.14.0。

2. 未在列表中列出的其他定制化系统，比如，基于Redhat/CentOS/Ubuntu核心管理套件定制的系统，一般都支持。

3. Linux系统不区分桌面版和服务器版，均可支持。

源设备磁盘及文件系统兼容性

云迁移平台支持的磁盘及文件系统兼容性如下：

表-2 源设备磁盘兼容性

类别 | 可否迁移/备份容灾
本地磁盘 | 是
iSCSI/FC LUN | 是
多路径逻辑卷 | 是
LVM/LVM2 逻辑卷 | 是
跨区卷动态盘 | 是
网络共享目录NFS/CIFS/Samba | 否

表-3 文件系统兼容性

类别 | 可否迁移/备份容灾 | 可否精简迁移/备份容灾
EXT2/EXT3/EXT4 | 是 | 是
XFS | 是 | 是
FAT/FAT32 | 是 | 是
NTFS | 是 | 是
Reiserfs | 是 | 是
无文件系统，裸磁盘使用 | 是 | 否

平台兼容性

支持物理机、常见虚拟化平台（VMware，Xen等）虚拟机迁移到CAS平台。

  • Linux源机内核版本若低于2.6.25（不含2.6.25）的老旧Linux源系统迁移/灾备后将无法兼容virtio，建议修改目标虚机/灾备机的磁盘控制器类型为IDE或者SATA。

  • Windows2012因为其驱动和内核管理的特性限制，建议目标灾备机磁盘控制器选择为IDE；迁移不受影响，可支持virtio。


在Linux系统安装客户端

  1. 使用FTP工具登录到客户端，进入/root/Clone_Client_Linux_64目录（如未解压请先解压缩）。执行安装命令运行脚本进行安装，根据客户端内核版本选择匹配的驱动，某些客户端需要手动按提示输入“Y”。当存在多个支持的驱动时，请选择与系统内核版本相近的驱动。

./install.sh

图-1 安装客户端

  2. 出现“install/start xxx succeeded!”，说明安装客户端成功，如下图所示。

图-2 安装成功


容灾管理配置指导

系统提供的容灾管理功能，基于存储远程复制技术与CDP持续数据保护两种数据复制技术，支持“基于存储复制的容灾”和“基于磁盘备份的容灾”两种容灾方式。可根据实际场景及业务需要，选择不同的容灾类型，构建容灾系统。两种容灾方式都融合在容灾管理功能中，过在配置保护组处区分“存储复制容灾”与“磁盘备份容灾”。容灾功能配置好后，支持一键容灾演练，针对各种使用场景进行容灾切换。

本文将从适用场景、实现机制等方面，分别介绍“基于存储复制的容灾”和“基于磁盘备份的容灾”这两种容灾方式及容灾配置流程。

主要功能

  • 容灾简介

  • 存储复制容灾配置


容灾简介

随着信息时代的发展，无论是企业，还是学校、医院等单位，越来越多的关键业务系统上线，对信息系统的依赖程度越来越高。当自然灾害或其他意外灾害发生时，如何保证业务数据的完整性，以及业务的连续性，对各单位来说至关重要。

容灾，又称灾难恢复（Disaster Recovery），指将信息系统从灾难（火灾、洪水、地震、或人为破坏等）造成的故障或瘫痪状态，恢复到可正常运行的状态，并将其支撑的业务功能，从不正常状态，恢复到可接受状态。容灾系统（Disaster Recovery System）的建设，一般在相隔较远的异地，建立两套或多套功能相同的业务系统，这些系统间，可进行状态监控及业务切换，当一处系统因人为或自然原因，造成严重故障或瘫痪，支持的业务功能不能正常运行时，整个业务系统可以切换到另一处，使得业务功能可以继续正常工作。

主要功能

  • 容灾系统关键性能指标

  • 容灾系统的分类


容灾系统关键性能指标

容灾系统的建设目标，是保证灾难发生时，数据不丢失，业务不中断。针对这两个目标，衡量容灾系统的关键指标有RPO和RTO两种。

  • RPO（Recovery Point Objective，恢复点目标），又称为业务系统所能容忍的最大数据丢失量目标，是指当灾难发生后，用户要求把数据恢复到灾难发生前的某个时间点。RPO是衡量企业在灾难发生后会丢失多少数据的指标，衡量容灾系统的数据冗余备份能力。

RPO一般由采用的数据复制方式决定。同步复制方式可以做到RPO为0，异步复制方式的RPO取决于复制的周期。

图-1 RPO

  • RTO（Recovery Time Objective，恢复时间目标），又称为用户能容忍的恢复时间目标，是指信息系统从灾难状态，恢复到可运行状态所需的时间，用来衡量容灾系统的业务恢复能力。RTO水平一般由容灾业务恢复流程决定，自动化程度越高，RTO越小。

图-2 RTO


容灾系统的分类

根据对系统的保护程度，可以将容灾系统分为如下两级：数据级、应用级。

  • 数据级容灾：通过建立异地容灾中心，做数据的远程备份。在灾难发生之后，确保原有的数据不会丢失或遭到破坏。在数据级容灾方式下，所建立的异地容灾中心可以简单地理解为一个远程的数据备份中心。

  • 应用级容灾：在数据级容灾基础上，在备份站点同样构建一套相同的应用系统，这样可以保证关键应用在允许的时间范围内恢复运行，尽可能减少灾难带来的损失，让用户基本感受不到灾难的发生，这样就使系统所提供的服务是完整的、可靠的和安全的。

图-1 容灾系统分类


关键技术

对数据的保护是容灾的基础，一般通过备份来保护数据。备份指为防止系统操作失误或故障导致的数据丢失，而将全部或部分数据集合从应用主机的硬盘或阵列复制到其他存储介质的过程。下面介绍与容灾管理功能相关的数据备份技术。

存储远程复制技术

存储阵列的复制技术一般分为同步复制和异步复制两种。

同步复制

同步复制能够保证具有复制关系的数据卷之间数据的一致性。同步复制的原理是，每个I/O写操作，都会等具有复制关系的主卷和远程卷都返回写完成才释放。因此同步复制方式有最高级别的数据完整性，但是性能会因为在阵列之间传送数据延迟而降低，而且同步复制方式复制阵列之间的距离要满足RTT（Round-Trip Time，往返时延）的要求。一般应用于较短距离间（10KM~100KM同城），且对数据一致性要求极高，对数据丢失几乎不可容忍的场景，如银行系统等。

图-1 同步远程复制

异步复制

异步复制方式一般都是周期性进行的，不能保证具有复制关系的数据卷之间的数据一致。异步复制的原理是本地主卷完成写操作后，给此数据卷创建一个快照，然后将快照复制到远程卷。异步复制方法提供了比较高的应用性能，但如果灾难发生，在远程卷上还未更新的数据就会有丢失风险，即时间窗口。

异步复制对带宽和距离要求相对较低，适用于业务系统性能要求较高，写压力小，对阵列IOPS和时延要求不是太高，如数据库、文件系统等场景。

图-2 异步远程复制

CDP技术

CDP（Continuous Data Protect，持续数据保护）技术，即在不影响主要数据运行前提下，通过捕获或跟踪数据的变化，并将其独立存放在生产数据之外，以确保数据可以恢复到过去的任意时间点的方法。理论上，任意一次的文件数据变化都会被自动记录，因此称为持续数据保护。

CDP技术能确定RPO指标，恢复到指定的任意时间点，以满足不同场景下的需求。SNIA（全球网络存储工业协会）在2011年的一份技术文档中，指出了CDP的三大标准：

  • 可以捕获源数据任意的数据变化

  • 至少可以备份到另外一个地方（异地容灾）

  • 可以恢复到任意时间点

从技术实现上，很多CDP方案需要安装代理软件，获取IO的变化。


存储复制容灾配置

基于存储复制的容灾可以针对两种场景：

  • 存储阵列支持SRA（Storage Replication Adapter，存储复制适配器）接口的场景。

  • 存储阵列不支持SRA接口的场景。

SRA是存储系统与SRM通信的桥梁。它为SRM提供的功能包括存储系统发现、复制LUN卷、故障切换演练、灾难恢复等。当SRM进行计划演练、计划恢复、故障恢复时，SRA可以为SRM提供相应资源，配合SRM自动完成虚拟化环境自动化容灾流程。

基于存储复制的容灾，支持对同构云场景的容灾。通过存储阵列的远程复制功能，在生产站点和恢复站点之间进行异步远程数据复制，当生产站点出现故障时，将业务切换到容灾站点。

适用场景

  • 基于存储复制的容灾适用于同构云（H3C CAS CVM）容灾场景，指生产站点与灾备站点是相同版本的CVM管理平台，要保护的生产机为CVM上的虚拟机。

  • 适用于数据中心级的容灾。

灾备等级

  • RPO为分钟级

  • RTO为分钟级

软硬件要求

  • 软件版本：E0536及以后版本，企业增强版，需包含SRM组件License。

  • 存储要求：

  • 存储自动化支持：红杉存储、HPE 3PAR存储、HPE Primera存储（E0709及以后版本）、ONEStor存储（E0709及以后版本）。

  • 3PAR版本：最低版本为#default：3.2.2.709，支持远程复制（remote copy）和双活（需Peer Persistence License支持），主备存储服务器版本一致。

  • HP存储阵列：需支持远端复制功能。

实现机制

在存储阵列层，通过存储远程复制，完成对业务虚拟机数据的备份。业务层通过配置保护组，将保护站点受保护的虚拟机配置同步到灾备站点。灾难发生时，利用备份的存储数据及同步的配置，在灾备站点拉起虚拟机，将业务切换到灾备站点。

存储复制容灾，依赖于存储阵列的复制功能，因此要求保护站点和恢复站点的存储复制技术要一致，且存储阵列上必须有存储复制功能和快照功能的授权。

图-1 存储复制容灾实现机制

功能特色

  • 利用存储阵列复制技术，在存储阵列层完成受保护虚拟机数据的复制，减少容灾业务对生产服务器的性能影响。存储阵列支持同步/异步复制模式，可根据客户RPO、RTO需求及场景，选择不同的复制模式。

  • 一键式快速恢复业务：通过管理系统，事先将故障恢复的流程进行演练，可以做到一键式的故障恢复切换，降低故障恢复的RTO。

  • 便捷的管理维护：一站式管理本地站点和远端站点，在某个管理系统进行容灾相关的配置，配置信息会同步到具有容灾关系的管理系统，不需要在多个管理系统之间来回切换即可完成配置。

  • 针对不同存储阵列的卷实现一对多的异地容灾，一个保护站点可以在多个恢复站点进行故障恢复。

  • 实现故障演练：在不影响现有业务正常运行的情况下，可以多次进行无中断的故障演练测试，确保实现可预测的恢复过程及恢复目标。

  • 存储阵列不局限于存储厂家，只需要保护站点和恢复站点的两台存储之间可以实现数据的复制功能和快照功能即可。对于不支持SRA的存储阵列，在进行故障切换的过程中需要通过手工的辅助工作来完成存储环境的准备。

  • 可以进行反向恢复，并可通过反向恢复方式将业务自动恢复到原来受保护的站点。


注意事项

为了能够实现基于存储复制的异地容灾，在部署的过程中需要注意：

  • 保护站点和恢复站点的存储阵列具有复制和快照功能许可，可以实现数据的复制功能。

  • 需要受保护虚拟机的数据存放在配置了复制关系的共享存储上。

  • 管理平台对SRM特性注册授权许可。如果是E0536版之前的版本升级的企业版，需要重新注册企业增强版License。

  • 容灾环境配置完毕后，必须先完成一次数据的同步，同步完毕后再进行恢复计划的相关操作。

  • 使用3PAR/Primera存储，创建remote copy组时，要保证使用RCFC协议，而不是RCIP协议。

  • 对于支持SRA功能的存储阵列，SRM容灾流程可以做到虚拟机恢复过程的全部自动化；对于不支持SRA功能的存储阵列，SRM流程需要事先通过手工方式准备好存储环境，然后再进行虚拟机恢复过程。

  • 如果要将软件从E0708之前版本升级到E0708及以后版本，需要在升级前将保护组及恢复计划删除，软件升级后，再重新添加保护组，配置容灾。


组网

保护站点和恢复站点为同版本管理系统，通过两站点存储阵列的复制技术，在存储层完成容灾数据的复制，实现异地备份机恢复功能。

图-1 组网图


配置流程

基于存储复制的容灾配置，分为配置准备、配置容灾任务、容灾切换功能三大步骤。在配置容灾任务时，选择存储复制容灾保护组。

存储复制容灾配置流程如下图所示。

图-1 存储复制容灾配置流程

容灾准备

需要先在存储侧配置好存储复制环境以及卷映射，进行存储的远程复制。然后在CAS侧，将存储挂载给主机使用。

配置容灾任务

1. 增加站点

站点包括本地站点和远端站点。站点的配置可以在保护端或灾备端中任意一端配置。对于存储阵列支持SRA适配器的场景，在增加站点的同时，需要增加存储适配器，以此来获取站点所使用的存储阵列信息。

2. 增加保护组

保护组是一组需要受保护的虚拟机或裸金属服务器的集合。保护组创建好后，系统自动进行一次虚拟机配置同步。在同构场景下，还可以在容灾切换前进行手动同步。

将属于同一个存储池（对应存储阵列中的一个或多个LUN）的虚拟机划分到一个保护组中，统一制定保护策略对虚拟机进行保护。通过存储阵列的复制功能，将本地存储阵列中LUN的数据复制到远端的LUN中，从而保护在该LUN中放置的虚拟机数据。

创建存储复制容灾类型的保护组时，需要指定保护站点和恢复站点、保护站点的主机池和恢复站点的主机池以及站点之间的资源映射关系。资源映射关系是用于将保护站点受保护的虚拟机使用的资源和恢复站点的资源建立对应关系，虚拟机在恢复站点恢复时，自动进行资源配置同步。可以建立的资源映射关系包括虚拟交换机映射、网络策略模板映射和存储（两个存储池所使用的存储LUN具有复制关系）映射。

3. 增加恢复计划

恢复计划就是针对不同保护组而设置的不同恢复策略，恢复计划执行后，在灾备端，根据恢复策略，自动创建容灾机，接替生产端业务。

容灾使用场景

容灾演练

容灾演练由开始演练和结束演练两个阶段组成。演练过程主要检查恢复计划实施的有效性，为提高灾难恢复能力进行预演，因此演练需要模拟保护站点故障发生后，在恢复站点能够恢复业务的全流程。演练测试过程不会影响生产业务。当演练过程完毕后，通过结束演练来完成测试后的环境清理工作，结束演练成功后，恢复计划的状态会成为就绪状态。

演练测试通过挂载恢复站点的LUN，并将其作为恢复站点的数据存储来实现。

图-2 存储复制容灾演练

计划恢复

计划恢复一般是在对保护站点进行维护的情况下，人为地将保护站点的虚拟机业务停止后，根据恢复计划将这些虚拟机业务在恢复站点恢复起来。

启动计划恢复后，保护站点的虚拟机将被关闭。计划恢复会触发一次数据的复制，当受保护的数据完全复制到恢复站点后，再依次恢复虚拟机业务。

图-3 计划恢复

故障恢复

故障恢复用于真实场景中保护站点发生故障，虚拟机业务不能工作的情况下，根据恢复计划在恢复站点恢复虚拟机业务。在这种情况下，受保护虚拟机是由于发生故障而异常中断的。

  • 对于异步复制的存储阵列，恢复站点存储的数据就是前一个复制周期完成后的数据信息，因此在恢复站点进行虚拟机业务恢复操作时，RPO不为0。

  • 对于同步复制的存储阵列，恢复站点存储的数据与保护站点的数据保持一致，因此在恢复站点进行虚拟机业务恢复操作时，RPO可以为0。

图-4 故障恢复

反向恢复

反向恢复是在保护站点发生故障时将虚拟机业务切换到恢复站点后，待故障的保护站点恢复正常工作的情况下，将运行在恢复站点的受保护虚拟机又恢复到保护站点。直接执行反向恢复功能，数据的反向恢复及虚拟机业务的切换自动完成。

图-5 反向恢复


准备存储环境

注意事项

  • 在3PAR上创建remote copy组时，保证组内有映射关系的LUN的wwn一致。

  • 在给主机增加3PAR上的LUN作为共享文件系统或者块设备时，请保证该LUN未加入remote copy组，或者即使加入了remote copy组，该LUN所在remote copy组的角色是Primary。

  • 当存储厂商类型为3PAR时，请保证在CAS上同步存储复制关系前所有CAS使用的remote copy组的角色不要出现Primary-Rev、Secondary-Rev。

  • 使用容灾功能时，若在同步完存储复制关系后需要再次添加新的存储复制关系供CVM使用，则在存储服务器上配置完毕后需要再次同步存储复制关系，并且同步前保证所有的恢复计划已经处于初始化状态，以避免已经存储在的存储复制关系在同步前后不一致。

  • 使用容灾功能时，当存储厂商为3PAR时，请勿在存储服务器上对加入了保护组的remote copy组执行switchover、restore、start、stop等会影响remote copy组的状态及角色的操作，以避免相关的恢复或演练执行失败。

  • 使用存储复制容灾功能时，当存储厂商为3PAR时，创建remote copy组时，需要保证使用的是RCFC协议，而不是RCIP协议。（目前3PAR只对接了FC没有对接iSCSI的，RCFC协议就是对应的FC，RCIP对应的是iSCSI）

  • 使用3PAR或Primera的双活实现SRA容灾功能时，请关闭“双活自动恢复和多路径管理”功能。

配置步骤

  1. 搭建好3PAR存储复制环境（同步/异步），3PAR存储搭建双活过程，及RCFC配置过程，请参见：3PAR存储服务器安装及双活环境搭建操作指导书。

  2. 通过HP 3PAR Management Console登录存储。在IP Address or Name地址栏中输入两台3PAR存储服务器的管理IP地址、用户名和密码，同时登录两个存储。

图-1 登录3PAR存储

  3. 登录成功以后，下图2013Store_1、2013Store_2分别为双活的两个存储。2013Store_1为主存储，2013Store_2为备存储，主存储映射给保护站点上的主机，备存储映射给灾备站点上的主机。

图-2 登录成功

  4. 在导航树选择<Provisioning>，在主存储2013Store_1上，单击<Create Vitual Volume>，创建存储卷。卷名称命名为cs_hxq_sra002，然后依次单击<Next>/<Finish>，完成存储卷cs_hxq_sra002的创建。

图-3 在存储2013Store_1上创建卷

  5. 存储卷创建成功后，单击左下角的按钮<Create and management HP 3PAR Remote copy configurations on HP 3PAR storage systems>，开始创建Remote Copy组。

图-4 创建Remote Copy组

  6. 在左侧导航树，单击<Create Remote Copy Group>，开始配置Remote Copy组信息。

图-5 开始配置Remote Copy组

  7. System选择主站点，输入Group名hxq002。单击<Next>。

图-6 配置Remote Copy组信息

  8. 左侧Source Volume选择刚才在2013Store_1上创建的cs_hxq_sra002存储卷，右侧Backup Volume选择“Create new volume”，选择CPG，建议保持CPG一致。

选择“Create new volume”以保证主备存储上的卷WWN一致，如果选择“Use existing volume”会导致卷的WWN不一致，可能会出现未知问题。

图-7 创建同步卷

  9. 单击<Add>按钮，在2013Store_2上创建同步卷。创建完成后，依次单击<Next>/<Finish>，完成同步卷创建。

图-8 增加同步卷

  10. 查看创建的同步卷。

图-9 创建同步存储卷

  11. 在导航树Groups可以查看创建好的Remote Copy的角色状态和卷信息。

图-10 查看Remote Copy角色和卷信息

  12. 也可以在2013Store_2上查看生成的同步存储卷。

图-11 查看同步存储卷

  13. 分别在存储2013Store_1和2013Store_2上，选择存储卷cs_hxq_sra002，右键选择<Export>，把存储卷映射给主站点主机和从站点主机。

图-12 将存储卷映射给主机

  14. 2013Store_1上的存储卷cs_hxq_sra002映射给主机host31。

图-13 查看主存储卷映射

  15. 2013Store_2上的存储卷cs_hxq_sra002映射给主机host20。

图-14 查看备存储卷映射


挂载存储

3PAR/Primera SRM支持FC共享文件系统和FC网络存储。

将准备存储环境章节准备的存储数据卷作为共享文件系统或者块设备挂载到CAS中。生产站点添加主存储上的存储卷，并作为集群下的FC共享文件系统挂载给主机使用。灾备站点的共享文件系统随着保护组的创建而自动添加，无需手动挂载。

  1. 单击导航树中[云资源/<主机池>]菜单项，选择“共享文件系统”页签，单击<增加共享文件系统>按钮，弹出增加共享文件系统对话框。将准备存储环境章节中配置好的存储LUN添加为共享文件系统（如果作为网络存储则挂载到主机上）。

图-1 增加共享文件系统-基本信息

图-2 增加共享文件系统-LUN信息

  2. 单击导航树中[云资源/主机池/<集群>]菜单项，选择“存储”页签，单击<增加>按钮，弹出增加共享存储对话框。将配置好的共享文件系统添加到主机上。

图-3 增加共享存储

  3. 单击导航树中[云资源/主机池/集群/<主机>]菜单项，单击<增加虚拟机>按钮，弹出增加虚拟机对话框。在主机上创建虚拟机，并且使用 2 添加的存储池作为虚拟机的存储。

图-4 增加虚拟机-基本信息

图-5 增加虚拟机-硬件信息

· 共享文件系统只能使用一个数据卷（LUN）。

· 数据存储挂载后，在执行恢复之前请确保存储至少同步过两次（两次同步才能生成一个public类型的时间点，用于故障演练操作），否则数据可能因为未完全同步而造成丢失的情况。


配置容灾任务

主要功能

  • 配置容灾站点

  • 配置容灾保护组


配置容灾站点

站点的配置可以在保护端或灾备端，任意一端配置。

  1. 添加本地站点。在保护站点，单击导航树[云业务/容灾管理/站点管理]/<增加站点>按钮，弹出增加站点对话框，添加站点信息。第一个增加的站点为本地站点（即生产端），IP地址为当前管理平台的IP地址。单击<下一步>按钮。

图-1 增加站点

  2. 增加存储阵列管理器（前提：使用的存储阵列支持SRA）并输入存储阵列管理器的相关信息，单击<完成>按钮。

图-2 增加存储阵列管理器

  3. 本地站点添加后，在存储阵列管理器配置列表的操作列，单击 [image] 按钮，进行连通性测试。存储连通测试成功后，本地站点添加完成。

图-3 连通性测试

  4. 本地站点添加完成后，后续增加的站点都为远端站点，重复步骤 1~步骤 3，完成远端站点的添加。本地和远端站点都添加完成后，容灾站点配置完成。

图-4 站点增加完成

  5. 站点增加完成后，单击存储阵列管理器配置列表右侧的<同步设备复制关系>按钮。

站点和存储阵列管理器增加完成后，必须执行此步骤。

图-5 同步设备复制关系

  6. 同步完成后单击存储阵列对应的 [image] 图标，可以查看存储复制关系。

图-6 查看设备复制关系


配置容灾保护组

  1. 单击导航树[云业务/容灾管理/保护组管理]/<增加保护组>按钮，弹出增加保护组对话框。容灾类型选择<存储复制容灾>，配置保护组的相关信息，选择保护站点和恢复站点，并从对应的站点中选择源主机池和目的主机池。单击<下一步>按钮。

· 自动保护虚拟机：自动保护符合条件的虚拟机。若该参数设置为“是”，则符合条件（虚拟机使用的存储、虚拟交换机、网络策略模板都为映射关系配置中的资源，并且名称和恢复站点中的虚拟机没有重复、未使用主机的软驱等本地设备）的虚拟机将自动加入到保护组中，后续添加的虚拟机如果满足条件也会自动加入。

· 对于保护组内的虚拟机，其备份文件和快照不受保护，即虚拟机恢复到备份站点后，其备份文件和快照将丢失。

图-1 创建保护组基本信息

  2. 配置资源映射关系。分别单击并拖动 [image] 、 [image] 、 [image] ，来配置保护组的存储、虚拟交换机、网络策略模板映射关系。存储选择挂载存储配置好的存储阵列。虚拟交换机，可以使用管理网或业务网虚拟交换机，本例使用管理网。网络策略模板，使用Default即可。单击<完成>按钮。

· 对于存储资源的映射，需要选择存储池的类型（包括共享文件系统和块设备）及存储类型（支持SRA和不支持SRA）。对于不支持SRA的存储阵列，只支持共享文件系统存储池。

· 映射关系中的虚拟交换机、网络策略模板可以自行定义，不一定要按照示例中使用默认的虚拟交换机和网络策略模板。

图-2 配置存储映射-选择存储

图-3 配置存储映射-选择设备

  3. 保护组资源映射配置完成，单击<完成>按钮。

图-4 保护组资源映射配置完成

  4. 为保护组添加虚拟机。单击受保护的虚拟机列表上方的<添加虚拟机>按钮，弹出选择虚拟机对话框。把需要保护的虚拟机增加到保护组中。

若勾选了自动保护符合条件的虚拟机，那么符合条件的虚拟机会显示在保护组的虚拟机列表中。

图-5 添加虚拟机


创建恢复计划

  1. 单击导航树中[云业务/站点容灾/恢复计划管理]菜单项，单击<增加>按钮，弹出增加恢复计划对话框。配置恢复计划的相关信息，并选择保护组和恢复集群信息。

· 保护组：选择一个加入恢复计划的保护组，新建的恢复计划将用来恢复该保护组的虚拟机。一个保护组只能用于一个恢复计划中。

· 恢复集群：选择一个恢复站点的集群，恢复时，保护组内的虚拟机将恢复到该集群的主机上。

图-1 创建恢复计划

  2. 恢复计划创建完成。恢复计划初次创建完的状态显示为“初始化”。

图-2 保护组创建完成


容灾切换场景

容灾任务配置完成后，可根据场景，执行容灾任务，进行容灾切换。

  • 定期进行容灾演练，以确保容灾任务配置正常。

  • 进行计划恢复，以维护保护站点。

  • 保护站点发生故障时，进行故障恢复。

  • 保护站点恢复后，进行反向恢复。

· 请确保恢复计划执行过程中具有存储映射关系的存储挂载状态正常，并且恢复集群的资源能够满足需要恢复虚拟机的资源需求，以免出现资源不够导致虚拟机无法部署启动的情况。

· 请确保恢复计划执行过程中保护站点和恢复站点都正常，并且站点之间网络连接正常，具有映射关系的存储挂载的主机状态正常。


容灾演练

恢复计划演练是一种检验配置的非破坏性测试，测试过程不会影响生产业务。恢复计划演练分为开始演练和结束演练两步，开始演练后，恢复计划将把虚拟机恢复到恢复站点。

演练测试通过挂载恢复站点存储卷的快照，并将其作为恢复站点的数据存储来实现，因此。当演练过程完毕后，通过结束演练来完成测试后的环境清理工作，结束演练成功后，恢复计划的状态会成为就绪状态。

针对基于SRA存储的容灾，容灾演练时，通过对存储卷创建快照，并挂给主机这种方式进行演练，所以限制容灾保护组存储映射不能超过128个。

开始演练

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<开始演练>按钮。

执行方式有两种，如果存储已经同步，可以选择跳过存储同步，直接执行计划演练，从而节省演练的时间；也可直接执行计划演练，其中包含了对存储进行同步的过程。

图-1 开始演练

  2. 提示生产环境和演练环境需要网络隔离，为不影响生产环境，需要返回保护组映射管理处，修改恢复端的虚拟交换机或网络策略模板，然后开始演练。

  3. 选择“恢复任务”页签，可以查看当前执行的任务状态。

图-2 恢复任务执行状态

  4. 单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-3 查看恢复详情

  5. 验证演练结果。切换到恢复站点，查看保护组中的虚拟机，已经根据保护组配置资源映射，被恢复到恢复站点中。选择挂载了映射存储的主机，然后在主机中均衡创建容灾机。

图-4 查看恢复结果

结束演练

  1. 演练成功后，通过单击<结束演练>按钮结束该恢复计划的演练，清理容灾数据，并使恢复计划处于就绪状态。

  2. 选择“恢复任务”页签，可以查看当前执行的任务状态。单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-5 查任务状态

  3. 单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-6 查看演练结束详情

  4. 验证结束演练结果。切换到恢复站点，容灾演练创建的虚拟机，已经被删掉，数据存储池也已经被清理。

图-7 验证结束演练结果

  5. 结束演练后，查看恢复计划，已经恢复到“就绪”状态。

图-8 查看恢复计划状态


计划恢复

计划恢复将会关闭保护组内的虚拟机，并暂停存储池。计划恢复的执行方式分为执行计划和直接恢复虚拟机两种。执行计划将按照恢复步骤执行；直接恢复虚拟机将跳过前面所有步骤，直接进行恢复虚拟机操作，这种情况主要用于恢复虚拟机之前的过程已经准备就绪，可以直接恢复虚拟机，节省恢复的时间。

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<计划恢复>按钮，执行计划恢复操作。

图-1 计划恢复

  2. 选择“恢复任务”页签，可以查看当前执行的任务状态。

图-2 查看计划恢复任务状态

  3. 也可以单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-3 查看计划恢复详情


反向恢复

当执行了计划恢复或者故障恢复后，受保护的虚拟机会在恢复站点启动运行。当原来的受保护站点具备了业务运行的状态后，可以通过反向恢复的方式将受保护的虚拟机恢复到最初的保护站点。

反向恢复执行时，请确保保护站点和恢复站点都正常，且之间网络连接正常，映射关系中存储挂载的主机状态正常。

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<反向恢复>按钮，执行反向恢复操作。

  2. 选择“恢复任务”页签，可以查看当前执行的任务状态。单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-1 查看反向恢复状态

图-2 查看反向恢复详细信息


故障恢复

故障恢复的执行方式分为执行计划和直接恢复虚拟机两种。执行计划将按照恢复步骤执行；直接恢复虚拟机将跳过前面所有步骤，直接进行恢复虚拟机操作，这种情况主要用于恢复虚拟机之前的过程已经准备就绪，以直接恢复虚拟机，节省恢复的时间。

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<故障恢复>按钮，执行故障恢复操作。

图-1 故障恢复

  2. 选择“恢复任务”页签，可以查看当前执行的任务状态。

图-2 查看任务状态

  3. 单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-3 查看反向恢复详情


准备存储环境

以配置HP存储阵列为例，准备好两台存储阵列，在SRM的站点部署HP存储阵列，并且存储阵列之间可以进行数据卷的复制功能（存储阵列需要具备复制功能和快照功能授权）。配置步骤如下。

  1. 登录HP存储阵列管理台。

图-1 存储阵列

  2. 右键单击导航树中[卷和快照]，选择[新建卷]菜单项，配置新建卷参数。配置卷相关的信息后，将新建的卷分配给需要使用该卷的主机。

图-2 新建卷

  3. 右键单击 2 中创建的卷lun_srm，选择[新建对卷的远程快照计划]菜单项，设置该卷的远程复制相关信息。

图-3 选择新建对卷的远程快照计划

  4. 打开“新建对卷进行远程快照计划”对话框，设置开始时间、重复周期、快照保留方案等信息，“远程卷的名称”需要选择恢复站点存储存储阵列的卷，如果对端存储还没有可用的卷匹配，可单击<新建远程卷>按钮进行新建。

图-4 新建对卷进行远程快照计划

  5. 完成数据同步后，右键单击恢复站点存储阵列的远程卷，选择[编辑卷]菜单项，编辑远程卷lun_srm_hp4530。在高级选项中将改卷的类型由远程改为主卷，并将该卷分配给恢复站点需要使用该卷的主机。

图-5 编辑卷

恢复站点存储阵列上的远程卷在正常使用时始终保持远程状态，这样保护站点存储阵列的主卷才会按照快照计划设置的策略，将数据同步存储到恢复站点存储阵列的远程卷。


挂载存储

将准备存储环境章节准备的存储数据卷作为共享文件系统或者块设备挂载到CAS中。

保护站点配置

  1. 在管理系统中部署主机池、集群、添加业务主机等相关资源。

  2. 单击导航树中[云资源/<主机池>]菜单项，选择“共享文件系统”页签，单击<增加共享文件系统>按钮，弹出增加共享文件系统对话框。将准备存储环境章节中配置好的存储LUN添加为共享文件系统（如果作为网络存储则挂载到主机上）。

图-1 增加共享文件系统-基本信息

图-2 增加共享文件系统-LUN信息

  3. 单击导航树中[云资源/主机池/<集群>]菜单项，选择“存储”页签，单击<增加>按钮，弹出增加共享存储对话框。将配置好的共享文件系统添加到集群的业务主机上。

图-3 增加共享存储

  4. 单击导航树中[云资源/主机池/集群/<主机>]菜单项，单击<增加虚拟机>按钮，弹出增加虚拟机对话框。在主机上创建虚拟机，并使用 3 中已配置好具有复制关系的数据卷（LUN）作为虚拟机的数据存储。

图-4 增加虚拟机-基本信息

图-5 增加虚拟机-硬件信息

恢复站点配置

  1. 在管理系统中部署主机池、集群、添加业务主机等相关资源。

  2. 单击导航树中[云资源/<主机池>]菜单项，选择“共享文件系统”页签，单击<增加共享文件系统>按钮，弹出增加共享文件系统对话框。将在准备存储环境章节中配置好的存储LUN添加为共享文件系统。

此时恢复站点的卷类型已经是主卷模式。

只需要在主机池添加共享文件系统即可，不需要到主机节点添加共享存储。

图-6 增加共享文件系统-基本信息

图-7 增加共享文件系统-LUN信息

  3. 登录存储阵列的管理台，将恢复站点的远程卷（lun_srm_hp4530）类型由“主卷”修改为“远程卷”，实现从主卷到远程卷的复制功能和快照功能。

恢复站点使用的存储卷，将卷的类型由主卷修改为远程卷，是为了让主站点使用的存储卷（主卷）同步到恢复站点的存储卷（远程卷）。当恢复站点存储卷是远程状态时，快照计划才能正常运行。

图-8 更改恢复站点的远程卷（lun_srm_hp4530）类型

共享文件系统只能使用一个数据卷（LUN）。

存储卷挂载后，在执行恢复之前请确保主站点存储卷（主卷）的数据已经同步到恢复站点的存储卷（远程卷）。


配置容灾任务

不支持SRA功能与支持SRA功能时的配置过程基本一样，不同的地方如下：

  • 配置容灾站点时不需要添加“存储阵列管理器”。

  • 配置容灾保护组的存储资源映射时，存储类型选择“非SRA存储”。

主要功能

  • 配置容灾站点

  • 配置容灾保护组


配置容灾站点

  1. 单击导航树[云业务/站点容灾/站点管理]菜单项，单击<增加站点>按钮，弹出增加站点对话框。缺省第一个增加的站点为本地站点类型，在IP地址信息中输入当前管理系统的IP地址。依次单击<下一步>按钮，单击<完成>按钮完成操作。

图-1 增加站点-站点信息

  2. 重复 1，增加远端站点。

图-2 增加远端站点

图-3 站点增加完成


配置容灾保护组

  1. 单击导航树中[云业务/站点容灾/保护组管理]菜单项，单击<增加保护组>按钮，弹出增加保护组对话框。配置保护组的相关信息，从配置的站点列表中选择保护站点和恢复站点，并从对应的站点中选择源主机池和目的主机池。

图-1 增加保护组-基本信息

  • 自动保护虚拟机：自动保护符合条件的虚拟机。若该参数设置为“是”，则符合条件（虚拟机使用的存储、虚拟交换机、网络策略模板都为映射关系配置中的资源，并且名称和恢复站点中的虚拟机没有重复、未使用主机的软驱等本地设备）的虚拟机将自动加入到保护组中，后续添加的虚拟机如果满足条件也会自动加入。

  • 对于保护组内的虚拟机，其备份文件和快照不受保护，即虚拟机恢复到备份站点后，其备份文件和快照将丢失。

  2. 单击<下一步>按钮，配置资源映射关系。分别单击图标 [image] 、 [image] 、 [image] 并拖动来增加存储映射、虚拟交换机映射、网络策略模板映射关系。对于存储资源的映射，需要选择存储池的类型（包括共享文件系统和块设备）及存储类型（支持SRA和不支持SRA）。对于不支持SRA的存储阵列，只支持共享文件系统存储池。

图-2 增加存储映射关系-选择存储

图-3 增加存储映射关系-选择设备

图-4 增加虚拟交换机映射关系

图-5 增加网络策略模板映射关系

图-6 增加保护组-映射关系

  • 映射关系中虚拟交换机和网络策略模板可以自行定义。示例中为系统默认的虚拟交换机和网络策略模板。

  • 增加存储映射关系时，存储类型选择“非SRA存储”。

  3. 在保护组列表中选择 1 增加的保护组，单击受保护的虚拟机列表上方的<添加虚拟机>按钮，弹出选择虚拟机对话框。在满足条件的虚拟机列中，选择要保护的虚拟机添加到保护组。

图-7 为保护组添加虚拟机

图-8 为保护组添加虚拟机完成


创建恢复计划

  1. 单击导航树中[云业务/站点容灾/恢复计划管理]菜单项，单击<增加>按钮，弹出增加恢复计划对话框。配置恢复计划的相关信息，并选择保护组和恢复集群信息，恢复计划初次创建完毕后的状态显示为“初始化”。

图-1 增加恢复计划

· 保护组：选择一个保护组，新建的恢复计划将用来恢复该保护组的虚拟机。

· 恢复集群：选择一个恢复站点的集群，恢复时，保护组内的虚拟机将恢复到该集群中的主机上。

图-2 恢复计划概要信息


容灾切换场景

主要功能

  • 容灾演练

  • 计划恢复

  • 故障恢复

  • 反向恢复


容灾演练

容灾演练是一种检验配置能否达到预期的恢复目的的非破坏性测试，演练分为开始演练和结束演练两步，开始演练结束后，进行演练的恢复计划会按照预先的配置把受保护虚拟机恢复到指定的恢复站点。

开始演练过程成功后，请及时结束演练，恢复计划将变为就绪状态，同时需要在存储管理台上配置回滚远程卷。

同步存储阵列数据

  1. 执行“开始演练”之前，请先同步一次存储阵列的数据。登录存储管理台，选择主卷（lun_srm），单击右键后选择“新建远程快照”，同步数据到远程卷（lun_srm_4530）。

图-1 新建远程快照

  2. 数据同步过程完成后，对远程卷（lun_srm_4530）进行编辑，将远程卷的类型由远程修改为主卷。

图-2 编辑卷

开始演练

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<开始演练>按钮开始演练，针对所选的恢复计划执行开始演练。

图-3 开始演练操作确认

图-4 开始演练

执行方式有两种：如果存储已经同步，可以选择跳过存储同步，直接执行计划演练，从而节省演练的时间；也可直接执行计划演练，其中包含了对存储进行同步的过程。

  2. 选择“恢复任务”页签，可以查看当前执行的任务状态。单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-5 查看开始演练执行结果

图-6 查看开始演练详细信息

结束演练

  1. 演练成功后，可以进行结束演练。单击<结束演练>按钮结束该恢复计划的演练，使恢复计划处于就绪状态。

  2. 选择“恢复任务”页签，可以查看当前执行的任务状态。单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-7 查看结束演练执行结果

图-8 查看结束演练详细信息

结束演练完成后，恢复计划的状态更改为就绪，后续可以进行计划恢复和故障恢复等操作。

回滚存储阵列数据

  1. 登录存储阵列的管理台，在远程卷lun_srm_hp4530的快照列表中选择最新的一个快照，右击选择Roll Back卷，使得当前的卷为最新的数据状态。

图-9 选择Roll Back卷

  2. roll back完成后，修改远程卷lun_srm_hp4530，将卷的类型由“主卷”改为“远程”。

图-10 编辑卷


计划恢复

计划恢复的执行方式分为执行计划恢复和直接恢复虚拟机两种，执行计划将按照恢复步骤执行；直接恢复虚拟机将跳过前面所有步骤，直接进行恢复虚拟机操作，常用于恢复虚拟机过程失败，或者已经通过手动操作准备好环境，则可选择直接恢复虚拟机。

计划恢复执行时，请确保存储映射关系中存储挂载的主机状态正常，并且恢复集群中的主机资源能够满足需要恢复虚拟机的资源需求。

同步存储阵列数据

  1. 手动同步数据，登录存储阵列管理台，选择主卷（lun_srm），右键单击，选择[创建远程快照]菜单项，创建远程快照到远程卷lun_srm_hp4530。

图-1 新建远程快照

  2. 登录虚拟化管理系统，关闭需要进行计划恢复的虚拟机，然后登录存储管理台，对主卷（lun_srm）创建远程快照到远程卷（lun_srm_hp4530）实现对数据再次同步，保证数据不丢失。

  3. 同步数据过程完毕后，将远程卷（lun_srm_hp4530）的类型由“远程”修改为“主卷”。

图-2 编辑卷

执行计划恢复

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<计划恢复>按钮，执行计划恢复操作。

图-3 计划恢复操作确认

图-4 计划恢复

图-5 确认计划恢复

  2. 选择“恢复任务”页签，可以查看当前执行的任务状态。单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-6 查看计划恢复执行结果

图-7 查看计划恢复详细信息


故障恢复

故障恢复的执行方式分为执行故障恢复和直接恢复虚拟机两种，执行故障恢复将按照恢复步骤执行；直接恢复虚拟机将跳过前面所有步骤，直接进行恢复虚拟机操作，常用于恢复虚拟机过程失败，或者手动操作准备好环境，则可以选择直接恢复虚拟机。

· 故障恢复执行前，如果主站点存储还能正常使用，建议先手动同步一次存储。

· 故障恢复执行时，请确保存储映射关系中存储挂载的主机状态正常，并且恢复集群中主机资源能够满足需要恢复虚拟机的资源需求。

  1. 登录存储管理台，将远程卷（lun_srm_hp4530）的类型由“远程”改为“主卷”。

图-1 编辑卷

  2. 登录虚拟化管理系统，单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<故障恢复>按钮，执行故障恢复操作。

图-2 故障恢复操作确认

图-3 确认故障恢复

  3. 选择“恢复任务”页签，可以查看当前执行的任务状态。单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-4 查看故障恢复执行结果

图-5 查看故障恢复详细信息


反向恢复

当执行了计划恢复或者故障恢复后，受保护的虚拟机会在恢复站点启动运行，当原来的受保护站点具备了业务运行的状态后，可以通过反向恢复的方式将受保护的虚拟机恢复到最初的保护站点。

请确保反向恢复执行过程中保护站点和恢复站点都正常，并且站点之间网络连接正常，映射关系中存储挂载的主机状态正常。

  1. 登录存储管理台，将原来的主卷（lun_srm）类型由“主卷”修改为“远程”。

图-1 编辑卷

  2. 上述卷的类型更改后，则具有远程复制关系的卷（lun_srm_hp4530）成为主卷，卷（lun_srm）成为远程卷，然后通过创建卷（lun_srm_hp4530）的远程快照到卷（lun_srm）来完成数据的反向同步。

图-2 新建远程快照

  3. 同步数据过程完毕后，登录恢复站点管理平台，关闭需要反向恢复的虚拟机，然后再登录存储管理台，通过对卷（lun_srm_hp4530）创建远程快照到卷（lun_srm）来实现再次同步数据。

  4. 同步数据过程完毕后，将卷（lun_srm）的类型由“远程”改为“主卷”。

图-3 编辑卷

  5. 登录虚拟化管理系统，单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<反向恢复>按钮，执行反向恢复操作。

图-4 反向恢复操作确认

图-5 确认反向恢复

  6. 选择“恢复任务”页签，可以查看当前执行的任务状态。单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-6 查看反向恢复执行结果

图-7 查看反向恢复详细信息

  7. 反向恢复成功后，登录存储管理台，将卷（lun_srm_hp4530）的类型由“主卷”改为“远程”。


磁盘备份容灾配置

基于磁盘备份的容灾，基于CDP操作系统数据复制技术实现容灾。通过安装在生产端主机中的Agent服务来获取生产端主机的信息，捕获数据块的变化，并将增量数据传输给存储节点，备份到灾备端的存储中。

基于多级快照链机制和实时同步机制，支持秒级数据同步，满足高性能RPO数据恢复需求。支持对异构平台（异构虚拟化、云平台、裸金属服务器等）的容灾，可以同时对多个异构平台的业务在一个灾备站点进行容灾。

磁盘备份容灾将安装了容灾客户端的虚拟机或裸金属服务器作为保护对象，将本地站点作为灾备站点，基于容灾客户端软件的磁盘实时复制功能，实现对生产端的虚拟机/裸金属数据的应急保护。基于多级快照链机制和实时同步机制，实现数据备份，支持秒级数据同步，满足高性能RPO数据恢复需求。

适用场景

适用场景：基于磁盘备份的容灾适合混合架构、异构云、同构云、裸金属、虚拟机容灾。还可用于生产机的关键业务的容灾。本配置指导主要介绍同构场景。

  • 同构场景：指生产站点与灾备站点是相同版本的CVM管理平台，保护对象为生产站点上的虚拟机。

  • 异构场景：指保护对象为他其他异构云平台的虚拟机、低版本CVM管理平台的虚拟机，或裸金属服务器，恢复站点为本CVM管理平台。

  • 混合架构：指保护保护对象基于虚拟机又有裸金属服务器，恢复站点为本CVM管理平台。

灾备等级

  • RPO为分钟级

  • RTO为分钟级

软硬件要求

  • 存储：无限制。

  • 生产端：支持X86架构云平台，或物理机。

  • 灾备端：支持E0536及以后版本，企业增强版，需要磁盘备份容灾License。

  • 操作系统：Windows Server版，Linux系统。磁盘备份容灾客户端所支持的操作系统如下表所示（可支持的操作系统仍在增加中，最新支持列表可参阅《Windows/Linux兼容性列表》）。

Linux系统以内核为准，Redhat5系列通用一个驱动，Redhat6系列大多数内核也是通用一个驱动。如果内核没出现在列表中，请选择最接近的内核的cdp驱动来安装，比如Redhat4.5 x32的内核是2.6.9-55.EL，可以使用Redhat4.7 x32的cdp_2.6.9-78.EL.ko驱动。

表-1 兼容性列表

兼容性列表
Windows | Windows Server 2003 X86/X64
 | Windows Server 2008 X86/X64
 | Windows Server 2008 R2 X64
 | Windows Server 2012 X64
 | Windows Server 2012 R2 X64
 | Windows Server 2016
Redhat | Redhat 4.2 i386（2.6.9-22ELsmp）
 | Redhat 4.2 i386（2.6.9-22.EL.ko）
 | Redhat 4.3 i386（2.6.9-34.21AXsmp.ko）
 | Redhat 4.6 x64（2.6.9-67.ELlargesmp_x64.ko）
 | Redhat 4.7 x32（2.6.9-78.EL.ko）
 | Redhat 4.7 x32（2.6.9-78.ELsmp.ko）
 | Redhat 4.7 x64（cdp_2.6.9-78.EL_x64.ko）
 | Redhat 4.7 x64（2.6.9-78.ELsmp_x64）
 | Redhat 5 x32系列（2.6.18-8.el5.ko）
 | Redhat 5 x64系列（2.6.18-8.el5_x64.ko）
 | Redhat 6.0 x32系列（2.6.32-71.el6.i686）
 | Redhat 6.0 x64系列（2.6.32-71.el6.x86_64）
 | Redhat 6.2 x32（2.6.32-220.el6.i686.ko）
 | Redhat 6.2 x64（2.6.32-220.el6.x86_x64.ko）
 | Redhat 7.0 x64（3.10.0-123.el7.x86_64）
 | Redhat 7.1 x64（3.10.0-229.el7.x86_64）
 | Redhat 7.2 x64（3.10.0-327.el7.x86_64）
Centos | Centos 6 x32系列（2.6.32-71.el6.i686）
 | Centos 6 x64系列（2.6.32-71.el6.x86_64）
 | Centos 7.0 x64（3.10.0-123.el7.x86_64）
 | Centos 7.1 x64（3.10.0-229.el7.x86_64）
 | Centos 7.2 x64（3.10.0-327.el7.x86_64）
Oracle Linux | OracleLinux-R6-U3-x64（2.6.39-200.24.1.el6uek.x86_64.ko）
Kylin | Kylin-4.0-1E-desktop_20160401-final-x86_64（3.16.0-23-generic）
 | NeoKylin-Linux-Advanced-Server-6.7（2.6.32-573.el6.x86_64）
 | NeoKylin-sws-3.2(64)（2.6.32-220.2.1.2.ky3.2.x86_64）
 | YHKylin-4.2-5-x86_64-server（2.6.32-431.29.2.3.ky3.1.x86_64）
Suse | SUSE Linux Enterprise Server 10 SP2 x86 （2.6.16.60-0.21-bigsmp）
 | SUSE Linux Enterprise Server 10 SP2 x86 （2.6.16.60-0.21-default）
 | SUSE Linux Enterprise Server 10 SP2 x64 （2.6.16.60-0.21-default）
 | SUSE Linux Enterprise Server 10 SP2 x64 （2.6.16.60-0.21-smp）
 | SUSE Linux Enterprise Server 10 sp3 x64 （2.6.16.60-0.54.5-smp_x64）
 | SUSE Linux Enterprise Server 11 SP2 x64 （3.0.13-0.27-default）
 | Suse Linux Enterprise Server 11 sp3 x86 （3.0.76-0.11-pae）
 | Suse Linux Enterprise Server 11 sp3 x64 （3.0.76-0.11-default）
 | Suse Linux Enterprise Server 11 sp3 x64 （3.0.101-0.31-default_x64）
 | Suse Linux Enterprise Server 12 sp2 x64 （4.4.21-69-default_x64）
Ubuntu | Ubuntu-12.04 x64（3.13.0-117-generic）
 | Ubuntu-14.10 x64（3.16.0-23-generic）

实现机制

将安装了容灾客户端的虚拟机（VM）或裸金属服务器（BM）作为保护对象，以操作系统为单位，将本地站点作为灾备站点，基于容灾客户端软件的磁盘实时复制功能，将生产机的数据复制到灾备站点管理平台，并在灾备站点的存储节点上创建虚拟机，来运行业务，实现业务的灾备。

对于CentOS版本，如果在安装的时候没有配置网络参数，会导致系统无法识别到安装了Agent的虚拟机，若要使用磁盘备份容灾功能，需要安装过程中配置好管理网IP。

图-1 磁盘备份容灾实现机制


组网

图-1 组网图


配置流程

基于磁盘备份的容灾配置，分为配置准备、配置容灾任务、容灾切换功能三大步骤。在配置容灾任务时，选择磁盘备份容灾保护组。

磁盘备份容灾配置流程如下图所示。

图-1 磁盘备份容灾配置流程

容灾准备

在生产端，为受保护的虚拟机或裸金属服务器安装客户端，以便获取生产端数据变化并备份到灾备端。在本地灾备端，设置容灾存储节点、容灾存储介质，用于存放容灾备份数据。设置容灾备份网络，用于传输容灾业务的备份数据。

配置容灾任务

1. 增加站点

站点包括本地站点和远端站点。站点的配置可以在保护端或灾备端，任意一端配置。对于磁盘备份容灾的异构场景，无需增加远端站点。

2. 增加保护组

保护组是一组需要受保护的虚拟机或裸金属服务器的集合。磁盘备份类型的保护组创建好后，系统自动进行一次虚拟机配置同步。对于同构场景，还可以在容灾切换前进行手动同步。

将安装了容灾客户端的虚拟机或生产机加入到一个保护组，通过制定合适的容灾策略，对虚拟机/生产机的数据自动进行持续同步，达到对虚拟机/生产机的保护目的。根据所保护的虚拟机/生产机的业务运行方式，分为普通业务、双机业务和集群业务。普通业务里的虚拟机/生产机单独运行，互不制约；双机和集群业务里的虚拟机/生产机需要有共享存储存放需要共同访问的数据。磁盘备份保护组支持同构及异构平台的容灾任务。

  • 同构场景：指保护站点与恢复站点是相同版本的CVM管理平台，要保护的生产机为CVM上的虚拟机。同构场景下，创建保护组时，需指定保护站点与恢复站点，以保护站点内安装了容灾客户端的虚拟机作为备选的保护对象，选择合适的容灾策略后，配置站点间网络资源映射关系。

  • 异构场景：指保护对象为他其他异构云平台的虚拟机、CVM低版本平台的虚拟机，或裸金属服务器，恢复站点为本CVM平台。异构场景下，创建保护组时，不配置保护站点，以安装了容灾客户端的虚拟机或生产机作为备选的保护对象，以本地站点为恢复站点，选择合适的容灾策略后，再配置恢复站点的生产机网络资源。

3. 增加恢复计划

恢复计划就是针对不同保护组而设置的不同恢复策略，恢复计划执行后，在灾备端，根据恢复策略，自动创建容灾机，接替生产端业务。

容灾使用场景

容灾演练

容灾演练由开始演练和结束演练两个阶段组成。演练过程主要检查恢复计划实施的有效性，为提高灾难恢复能力进行预演，因此演练需要模拟保护站点故障发生后，在恢复站点能够恢复业务的全流程。演练测试过程不会影响生产业务。当演练过程完毕后，通过结束演练来完成测试后的环境清理工作，结束演练成功后，恢复计划的状态会成为就绪状态。

磁盘备份容灾演练测试通过挂载恢复站点存储卷的快照，并将其作为恢复站点的数据存储来实现。

图-2 磁盘备份容灾演练

计划恢复

计划恢复一般是在对保护站点进行维护的情况下，人为地将保护站点的虚拟机业务停止后，根据恢复计划将这些虚拟机业务在恢复站点恢复起来。

启动计划恢复后，保护站点的虚拟机将被关闭（异构场景下不会自动关闭，如需关闭，需人为操作）。计划恢复会触发一次数据的复制，当受保护的数据完全复制到恢复站点后，再依次恢复虚拟机业务。

图-3 计划恢复

故障恢复

故障恢复用于真实场景中保护站点发生故障，虚拟机业务不能工作的情况下，根据恢复计划在恢复站点恢复虚拟机业务。在这种情况下，受保护虚拟机是由于发生故障而异常中断的。

对于磁盘备份容灾，恢复站点存储的数据为前一个复制周期完成后的数据，因此在恢复站点恢复业务时，RPO不为0。

图-4 故障恢复

反向恢复

反向恢复是在保护站点发生故障时将虚拟机业务切换到恢复站点后，待故障的保护站点恢复正常工作的情况下，将运行在恢复站点的受保护虚拟机又恢复到保护站点。对于磁盘备份容灾，需在生产环境运行PE反向恢复工具将容灾数据恢复到生产环境，体操作参见 反向恢复 。

图-5 反向恢复

清理备份数据

针对磁盘备份容灾，当执行过计划恢复或故障恢复后，可通过在生产环境运行PE反向恢复工具将容灾数据恢复到生产环境，恢复后执行清理备份数据，在恢复站点删除容灾机及临时数据。


生产端准备

1. 下载并上传备份客户端

  1. 进入恢复站点（即灾备端），单击导航树中[云业务/容灾管理/下载客户端]菜单项，进入客户端下载界面。

  2. 选择“客户端下载”页签。客户端代理的备份服务器IP地址默认为CVM管理网IP地址。

· 针对同构场景，被保护的虚拟机安装的客户端，要从恢复站点下载，这样虚拟机安装客户端后，才会自动根据服务器IP，连接到备份服务器。

· 可以设置一个备用的备份服务器IP，当首选IP出现异常时，系统自动切换备选IP来与恢复站点的管理系统进行通信。该功能只有在迁移License激活后才能使用。

  3. 选择所需的客户端，单击对应操作系统的下载链接进行下载。该操作有两种可用方式。

  • 选择对应的客户端安装包下载。下载的安装包为zip压缩包，名字通常以Clone_Client开头（如Clone_Client_Redhat5x86_64.zip）。解压缩后使用FTP工具将已经解压缩的客户端安装包传输到被保护的生产机。

  • 选择匹配的应急客户端安装包。单击 [image] 图标，生成URL下载链接，复制下载链接至远程登录界面（提前连接生产机），下载客户端安装包。

图-1 下载备份客户端

2. 安装客户端

建议安装客户端前关闭源设备防火墙及相关安全策略。如源设备为云平台虚拟机，请确认安全组策略是否已开放迁移工具端口。

  1. 进入生产机设备控制台。

图-2 进入控制台

  2. 双击客户端安装程序Clone_Client_Win.exe，弹出选择安装语言窗口，如下图所示。选择安装时要使用的语言，单击<确定>按钮。

图-3 选择安装语言

  3. 同意许可协议，选择安装路径，开始安装。当弹出如下图所示的窗口时，选择安装CDP驱动程序。

图-4 安装CDP驱动

  4. 安装完成后需要重启源设备，完成安装。

对于Windows系统的源设备，重启会导致业务中断，请合理安排重启时间。

图-5 安装完成


灾备端准备

1. 设置容灾存储节点

容灾存储节点，指在容灾业务中，在业务保护、数据传输过程中，提供数据的分发处理功能的主机，可以提供更多的存储空间和存储能力。只有设置为容灾存储节点的主机，才能作为容灾目的主机使用。生产端被保护的虚拟机或裸金属服务器，只能在容灾存储节点进行恢复。

  1. 进入灾备端CMV管理平台。

  2. 单击导航树中[云资源/主机池]，选择待作为容灾存储节点的主机。

  3. 单击<更多操作>/<设为容灾存储节点>，将所选主机设置为容灾存储节点。

图-1 设置容灾存储节点

2. 设置容灾存储介质

容灾存储介质，指在容灾存储节点内，存放容灾备份数据的存储池。只有作为容灾存储介质的存储池，才能作为磁盘备份容灾业务的目的存储池。容灾存储介质添加完成后，存储节点会短暂离线。

  1. 单击[云资源/主机池]，选择主机，单击“存储”页签，进入主机存储池列表。

  2. 选择作为容灾存储介质的存储池，单击 [image] 按钮，将该存储池设置为容灾介质。

图-2 设置容灾存储介质

3. 设置容灾备份网络

为数据传输量较大时，为了避免影响业务，可以为容灾业务专门的容灾备份网络。只有网络类型为“备份网络”的虚拟交换机，可以作为容灾备份网络。如果不设置容灾备份网络，备份数据也可以通过管理网络vswtich0进行传输。

图-3 设置容灾备份网络


配置容灾任务

主要功能

  • 添加站点

  • 创建保护组


添加站点

  1. 在保护站点，单击导航树[云业务/容灾管理/站点管理]/<增加站点>按钮，弹出增加站点对话框，添加站点信息。第一个增加的站点为本地站点（即生产端），IP地址为当前管理平台的IP地址。本地站点添加后，再增加远端（即恢复端）站点。

磁盘备份容灾，不需要配置存储阵列信息。

图-1 增加站点


创建保护组

  1. 单击导航树[云业务/容灾管理/保护组管理]/<增加保护组>按钮，弹出增加保护组对话框。容灾类型选择<磁盘备份容灾>，配置保护组的基本信息。单击<下一步>按钮。

· 同构场景，需要指定保护站点与恢复站点。

· 异构场景，不需要配置保护站点。

图-1 配置保护组基本信息

  2. 单击“容灾策略”，根据实际业务情况配置容灾策略。容灾策略包含同步策略及快照策略，容灾策略中的各项参数解释请参考联机帮助。

请根据实际业务数据量配置合适的同步时间间隔（0表示不自动同步），避免因没有配置自动同步导致灾难发生时数据丢失量过大。

图-2 修改容灾策略

  3. 配置资源映射关系，分别单击并拖动 [image] 、 [image] ，来配置保护组的虚拟交换机、网络策略模板映射关系。虚拟交换机，使用容灾备份网络或vswitch0（管理网），本例使用管理网。网络策略模板，使用Default即可。单击<完成>按钮。

异构场景，通过指定容灾网络及网络策略模板，来配置网络映射。

图-3 配置保护组资源映射

  4. 为保护组增加虚拟机。在创建的保护组下发，单击<添加虚拟机>按钮，弹出“选择虚拟机”窗口。所有安装了容灾客户端，且正确配置了网络的虚拟机都是备选虚拟机，选中需要保护的虚拟机增加到保护组中，单击<确定>按钮。

图-4 添加受保护的虚拟机

  5. 保护组配置完成。

图-5 保护组配置完成


创建恢复计划

  1. 单击导航树[云业务/容灾管理/恢复计划管理]/<增加恢复计划>按钮，弹出增加恢复计划对话框。容灾类型选择<磁盘备份容灾>，配置保护组的基本信息。单击<下一步>。配置恢复计划的相关信息，选择保护组及受保护的虚拟机，单击<确定>按钮。

可以为一个保护组配置多个恢复计划，按不同的恢复计划，恢复不同的虚拟机。本例将所有受保护的虚拟机都添加到一个恢复计划。

图-1 增加恢复计划

  2. 恢复创建完成。恢复计划初次创建完的状态显示为“初始化”。

图-2 恢复计划创建完成。


容灾切换场景

主要功能

  • 容灾演练

  • 计划恢复

  • 清理备份数据

  • 故障恢复


容灾演练

开始演练

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<开始演练>按钮，开始演练。

  2. 提示生产环境和演练环境需要网络隔离，为不影响生产环境，需要返回保护组映射管理处，修改恢复端的虚拟交换机或网络策略模板，然后再开始演练。

图-1 网络隔离确认

  3. 选择“恢复任务”页签，可以查看当前执行的任务状态。

图-2 恢复任务执行状态

  4. 单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-3 查看恢复详情

  5. 演练过程中，查看本地站点被保护的虚拟机，仍然处于运行状态，业务并未受影响。

图-4 本地站点虚拟机运行状态

  6. 验证演练结果。切换到恢复站点，查看保护组中的虚拟机，已经根据保护组配置资源映射，被恢复到恢复站点中。

容灾机将在符合条件主机中（在目的存储池上的主机），选择最优的主机上创建。

图-5 查看演练结果

结束演练

  1. 演练成功后，通过单击<结束演练>按钮结束该恢复计划的演练，清理容灾数据，并使恢复计划处于就绪状态。

图-6 结束演练

  2. 选择“恢复任务”页签，可以查看当前执行的任务状态。单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-7 查任务状态

  3. 单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-8 查看演练结束详情

  4. 验证结束演练结果。切换到恢复站点，容灾演练创建的虚拟机，已经被删掉，数据存储池也已经被清理。

图-9 验证结束演练结果

  5. 结束演练后，查看恢复计划，已经恢复到“就绪”状态。

演练结束后，需要把保护组映射关系中的网络策略模板，修改回正常的网络配置，避免故障或计划恢复后网络不通。

图-10 查看恢复计划状态


计划恢复

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<计划恢复>按钮，执行计划恢复操作。

如果是异构场景，会提示计划恢复前先关闭生产机，以免造成数据错误。

  2. 选择“恢复任务”页签，可以查看当前执行的任务状态。

图-1 查看计划恢复任务状态

  3. 单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-2 查看计划恢复详情

  4. 计划恢复成功后，本地站点虚拟机关机。

图-3 本地站点受保护的虚拟机关机

  5. 切换到恢复站点，查看保护组中的虚拟机，已经根据保护组配置资源映射，在恢复站点恢复，且已经接管业务，处于运行状态。

图-4 查看计划恢复结果


清理备份数据

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<清理备份数据>按钮，进行数据清理。

  2. 提示删除备份数据前进行PE镜像恢复，以免数据丢失。确认并清理数据。

图-1 清理备份数据确认

  3. 选择“恢复任务”页签，可以查看当前执行的任务状态。

图-2 查看清理任务

  4. 单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-3 查看清理任务过程

  5. 清理备份数据结束后，切换到恢复站点，容灾演练创建的虚拟机，已经被删掉，数据存储池也已经被清理。

图-4 备份数据被清理


故障恢复

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划管理名称>]菜单项，进入该恢复计划的概要信息页面。单击<故障恢复>按钮，执行计划恢复操作。

  2. 选择“恢复任务”页签，可以查看当前执行的任务状态。

图-1 查看故障恢复任务状态

  3. 单击恢复任务列表中执行日期对应的链接，查看详细执行过程。

图-2 查看故障恢复详情

  4. 故障恢复成功后，本地站点虚拟机关机。

图-3 本地站点受保护的虚拟机关机

  5. 切换到恢复站点，查看保护组中的虚拟机，已经根据保护组配置资源映射，在恢复站点恢复，且运行。

图-4 查看故障恢复结果


反向恢复

当保护站点恢复正常后，需要将业务切换回保护站点。本系统提供完善的反向恢复流程，保障业务、数据在生产端和灾备端间同步，完成业务反向切换。

alert

计划恢复或故障恢复后，容灾机和生产机的MAC地址是一致的，在进行反向恢复，将业务恢复到生产端的原虚拟机上（非新建虚拟机）时，为避免网络冲突导致无法恢复，容灾机和生产机不能在同一物理交换机下，如在同一物理交换机下，需要在修改容灾机MAC地址，避免网络问题导致无法连接Server端，无法反向恢复。

1. 准备PE镜像

提供Windows和Centos两种PE镜像，根据生产端的系统选择对应的PE镜像。

CAS-SRM-Recovery-centos_xxx.iso

CAS-SRM-Recovery-win10_xxx.iso

2. 新增虚拟机

  1. 单击导航树中[云资源/主机池/集群/主机]，进入主机的概要信息页面。单击<增加虚拟机>按钮，创建新的虚拟机，用于反向恢复虚拟机。

图-1 新建虚拟机

3. 挂载PE镜像配置虚拟机网络

  1. 挂载PE镜像，并重启虚拟机，引导进入容灾应急工具。

图-2 挂载PE镜像

  2. 进入虚拟机控制台。

图-3 PE引导进入容灾应急工具

  3. 在容灾应急工具下方，单击<网络配置>按钮，为虚拟机配置网络，单击<应用>按钮。

图-4 配置网络

4. 进行反向恢复

  1. 输入登录灾备端CVM地址，单击右侧<登录>按钮，登录容灾站点。

图-5 登录容灾端

  2. 选择待反向恢复的保护组，并双击，更新设备列表。保护组中的三台虚拟机出现在设备列表内。

图-6 选择保护组

  3. 选择一台待反向恢复的虚拟机，单击<下一步>按钮。进入应急恢复页签。

图-7 选择反向恢复的虚拟机

  4. 选择快照接管演练点，选择恢复模式。单击<恢复>按钮，开始反向恢复。

PE恢复有三种模式：

· 普通该模式：一次性恢复快照点以及在恢复完成前接管演练点写入的数据（接管前的数据）。

· 无缝模式：先恢复该快照点及快照点之前的所有数据，再恢复虚拟机中新生产的数据（接管前和接管后的数据）。

· 只恢复临时数据：只恢复容灾机中新生成的数据（接管后的数据）。

图-8 配置恢复策略

  5. 根据恢复策略，进行数据恢复的过程。

图-9 反向恢复过程

  6. 恢复成功。单击<确定>按钮，关闭容灾应急工具，并重启虚拟机。

图-10 反向恢复成功

  7. 虚拟机启动后，查看虚拟机恢复成功。

图-11 虚拟机启动成功

  8. 依次恢复另外两台虚拟机，将容灾站点的虚拟机反向恢复到保证站点中。


云资源概览

该功能通过图表查看云资源中主机与虚拟机实时状态信息。内容包括系统健康度、主机健康度、可回收资源、CPU分配比、内存分配比、共享存储分配比、系统告警信息，Top5主机的CPU和内存利用率、主机数量与状态、Top5虚拟机的CPU和内存利用率、虚拟机数量与状态，不健康主机信息，不健康虚拟机信息。

操作步骤

  1. 单击导航树中[概览]菜单项，进入概览信息页面。

  2. 单击 按钮，进入概览信息全屏显示页面；按ESC键，可以退出概览信息全屏显示页面。

参数说明

  • 系统健康度：显示CVM健康度，即CVM各主机健康度的平均值。

  • 主机健康度：显示CVK的健康度散点图，散点图横轴表示主机CPU健康度，散点图纵轴表示主机内存健康度，每个散点包括主机CPU健康度、内存健康度、存储健康度、网络健康度、主机健康度。通过左侧的滑动轴可以选择显示某一区间的散点。健康度具体计算方法如下：

  • CPU健康度：主机CPU利用率大于80%，CPU健康度为0~50分；主机CPU利用率为60%~80%（含60%和80%），CPU健康度为51~80分；主机CPU利用率小于60%，CPU健康度为81~100分。

  • 内存健康度：主机内存利用率大于80%，内存健康度为0~50分；主机内存利用率为60%~80%（含60%和80%），内存健康度为51~80分；主机内存利用率小于60%，内存健康度为81~100分。

  • 存储健康度：主机存储利用率大于80%，存储健康度为0~50分；主机存储利用率为60%~80%（含60%和80%），存储健康度为51~80分；主机存储利用率小于60%，存储健康度为81~100分。

  • 网络健康度：主机网络吞吐量大于1024Mbps，网络健康度为0~50分；主机网络吞吐量为500~1024Mbps（含500和1024），网络健康度为51~80分；主机网络吞吐量小于500Mbps，网络健康度为81~100分。

  • 主机健康度：主机健康度=CPU健康度*30%+内存健康度*40%+存储健康度*15%+网络健康度*15%。

  • 可回收资源：

  • vCPU：云资源中处于关闭状态的虚拟机CPU总核数。

  • 内存：云资源中处于关闭状态的虚拟机内存总数。

  • 存储：云资源中处于关闭状态的虚拟机磁盘容量大小总数。

  • CPU分配比：

  • 主机CPU总核数：云资源中各主机CPU核数数量总和。

  • 虚拟机CPU总核数：云资源中各虚拟机CPU核数数量总和。

  • CPU分配比例：云资源中主机CPU的利用率（即虚拟机CPU总核数占主机CPU总核数的百分比）。

  • 内存分配比：

  • 主机内存总数：云资源中各主机内存容量总和。

  • 虚拟机内存总数：云资源中各虚拟机内存容量总和。

  • 内存分配比例：云资源中主机内存的利用率（即虚拟机内存总数占主机内存总数的百分比）。

  • 共享存储分配比：

  • 存储总数：云资源中集群共享存储容量总和。

  • 可用总数：云资源中集群共享存储可用容量总和。

  • 存储分配比例：云资源中集群共享存储使用率（即共享存储已使用容量占共享存储总容量的百分比）。

  • 系统告警：显示告警管理中每个级别（包括：紧急、重要、次要、提示）的告警数量，单击告警级别标签，进入实时告警页面，并显示该告警级别的所有告警信息。

  • Top5主机CPU利用率：显示云资源中利用率最高的五个主机的CPU利用率趋势图。趋势图中显示最近20分钟的利用率趋势。趋势图中横轴表示时间，纵轴表示利用率。操作员可以通过单击主机对应的图例来选择显示该主机利用率的趋势。

  • Top5主机内存利用率：显示云资源中利用率最高的五个主机的内存利用率趋势图。趋势图中显示最近20分钟的利用率趋势。趋势图横轴表示时间，纵轴表示利用率。操作员可以通过单击主机对应的图例来选择显示该主机利用率的趋势。

  • 主机状态统计：显示当前云资源中主机总数与不同状态（包括：正常、异常、维护）的主机数量。

  • Top5主机CPU利用率：显示云资源中CPU利用率（即百分比）最高的五个主机的名称和CPU利用率环形图表。操作员可以通过单击主机名对应的环查看主机的概要信息页面。

  • Top5主机内存利用率：显示云资源中内存利用率（即百分比）最高的五个主机的名称和内存利用率柱形图表。柱形图中横轴表示主机名称；纵轴表示利用率。操作员可以通过单击主机名对应的柱形图查看主机的概要信息页面。

  • Top5虚拟机CPU利用率：显示云资源中利用率最高的五个虚拟机的CPU利用率趋势图。趋势图中显示最近20分钟的利用率趋势。趋势图中横轴表示时间，纵轴表示利用率。操作员可以通过单击虚拟机对应的图例来选择显示的虚拟机利用率趋势。

  • Top5虚拟机内存利用率：显示云资源中利用率最高的五个虚拟机的内存利用率趋势图。趋势图中显示最近20分钟的利用率趋势。趋势图横轴表示时间，纵轴表示利用率。操作员可以通过单击虚拟机对应的图例来选择显示的虚拟机利用率趋势。

  • 虚拟机状态统计：显示当前云资源中虚拟机总数与不同状态（包括：正常、关闭、异常）的虚拟机数量。

  • Top5虚拟机CPU利用率：显示云资源中CPU利用率（即百分比）最高的五个虚拟机的显示名称和CPU利用率环形图表。操作员可以通过单击虚拟机名对应的环查看虚拟机的概要信息页面。

  • Top5虚拟机内存利用率：显示云资源中内存利用率（即百分比）最高的五个虚拟机的显示名称和内存利用率柱形图表。柱形图中横轴表示虚拟机显示名称；纵轴表示利用率。操作员可以通过单击虚拟机名对应的柱形图查看虚拟机的概要信息页面。

  • 不健康主机：云资源中CPU利用率或内存利用率超过80%的主机。

  • CPU利用率：主机CPU利用率趋势图。趋势图中显示最近10分钟的利用率趋势。趋势图中横轴表示时间，纵轴表示利用率。

  • 内存利用率：主机内存利用率趋势图。趋势图中显示最近10分钟的利用率趋势。趋势图中横轴表示时间，纵轴表示利用率。

  • I/O吞吐量：主机I/O吞吐量趋势图。趋势图中显示最近10分钟的I/O吞吐量趋势。趋势图中横轴表示时间，纵轴表示I/O吞吐量。

  • 网络吞吐量：主机网络吞吐量趋势图。趋势图中显示最近10分钟的网络吞吐量趋势。趋势图中横轴表示时间，纵轴表示网络吞吐量。

  • 不健康虚拟机：云资源中CPU利用率或内存利用率超过80%的虚拟机。

  • CPU利用率：虚拟机CPU利用率趋势图。趋势图中显示最近10分钟的利用率趋势。趋势图中横轴表示时间，纵轴表示利用率。

  • 内存利用率：虚拟机内存利用率趋势图。趋势图中显示最近10分钟的利用率趋势。趋势图中横轴表示时间，纵轴表示利用率。

  • I/O吞吐量：虚拟机I/O吞吐量趋势图。趋势图中显示最近10分钟的I/O吞吐量趋势。趋势图中横轴表示时间，纵轴表示I/O吞吐量。

  • 网络吞吐量：虚拟机网络吞吐量趋势图。趋势图中显示最近10分钟的网络吞吐量趋势。趋势图中横轴表示时间，纵轴表示网络吞吐量。


云资源管理

云资源是云计算管理平台分层管理模型的核心节点之一。通过对云资源进行管理，可以统一管理数据中心内所有复杂的硬件基础设施，其中不仅包括基本的IT基础设施（如硬件服务器系统），还包括与之配套的其它设备（如网络和存储系统）。默认情况下，CVM出厂配置中已经添加了一个名为“云资源”的根节点，准备使用系统进行管理的所有物理资源都需要手工逐一添加到该节点下进行统一的管理。

云资源中被管理对象之间的关系可以用下图描述：

  • 主机池是一个管理窗口，主机只有被增加到主机池之后，才能被系统管理。

  • 集群是主机池中的一个管理窗口，是多个主机的集合，可以为其管理的对象提供高可靠性设置。当集群开启高可靠性功能后，系统会持续对集群中所有主机和虚拟机的运行状况进行监测。一旦发现主机或者虚拟机故障，系统将立即响应并在集群中其它可用的主机上重启所有受影响的虚拟机。

  • 主机是运行了虚拟化软件的实体物理服务器，为虚拟机提供硬件环境。

  • 虚拟机是由软件模拟的、具有完整硬件系统功能的、运行在一个完全隔离环境中的完整计算机系统。

在云资源中，操作员还可以设置系统策略，如备份策略、快照策略等，虚拟机可以应用上述策略，根据策略指定的时间，对虚拟机进行备份或者快照。

云资源管理主要包括：

  • 查看云资源概要信息

  • 查看云资源中的主机信息

  • 查看云资源中的虚拟机信息

  • 查看云资源中的操作日志

  • 主机池管理

  • 主机管理

  • 集群管理

  • 虚拟机管理

  • 虚拟机模板管理

  • 虚拟机视图管理

  • 虚拟机回收站管理

  • 备份策略管理

  • 快照策略管理

  • 监控策略管理

  • 开关机策略管理

  • NTP时间服务器设置

  • 网络策略模板管理

  • 主机驱动规则管理


查看云资源概要信息

该功能用于查看整个云资源的详细配置信息，云资源中Top5主机的CPU和内存利用率信息、主机状态统计，以及Top5虚拟机的CPU和内存利用率信息。

操作步骤

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

参数说明

  • 基本属性：显示整个云资源的详细配置信息。

  • 主机池：云资源中主机池个数。

  • 主机：云资源中主机个数。

  • CPU总核数：云资源中各主机CPU核数数量总和。

  • 总内存：云资源中各主机内存容量总和。

  • 本地总存储：云资源中各主机本地存储容量总和。

  • 本地总可用存储：云资源中各主机剩余可用的本地存储容量总和。

  • 虚拟机：云资源中虚拟机的数量总和，以及处于“运行”和“关闭”状态的虚拟机数量统计。

  • 虚拟机密度：云资源中平均每个主机中虚拟机的数量。

  • Top5主机CPU利用率：显示云资源中CPU利用率（即百分比）最高的五个主机的名称和CPU利用率环形图表。

  • Top5主机内存利用率：显示云资源中内存利用率（即百分比）最高的五个主机的名称和内存利用率柱形图表。

  • 主机状态统计：显示当前云资源中主机总数与不同状态（包括：正常、异常、维护）的主机数量。

  • Top5虚拟机CPU利用率：显示云资源中CPU利用率（即百分比）最高的五个虚拟机的显示名称和CPU利用率环形图表。

  • Top5虚拟机内存利用率：显示云资源中内存利用率（即百分比）最高的五个虚拟机的显示名称和内存利用率柱形图表。


查看云资源中的主机

该功能用于查看整个云资源中的所有主机信息。

操作步骤

  1. 单击导航树中[云资源]菜单项，进入云资源的概要信息页面。

  2. 选择“主机”页签，进入云资源主机信息页面。

参数说明

  • 名称：主机的名称。

  • 状态：主机当前的状态，包括正常、不正常、维护模式、主机不在集群HA内。

  • 虚拟机概要：主机上虚拟机的数量，以及处于“运行”和“关闭”状态的虚拟机数量。

  • CPU：主机当前的CPU总核数（即CPU个数与每个CPU核数的乘积）。

  • 内存：主机当前的内存容量。

  • CPU利用率：主机CPU一小时内的平均利用率。

  • 内存利用率：主机内存一小时内的平均利用率。

  • 磁盘容量：主机本地磁盘的空间大小。

  • 平台：主机使用的虚拟化平台。目前仅支持CVK。

  • 操作：以图标方式显示操作员可以对主机执行的管理操作。 表示修改主机。


查看云资源中的虚拟机

该功能用于查看云资源中的所有虚拟机信息。

操作步骤

  1. 单击导航树中[云资源]菜单项，进入云资源的概要信息页面。

  2. 选择“虚拟机”页签，进入云资源的虚拟机信息页面。

  3. 单击<界面定制>按钮，可以调整显示列表的内容和顺序。

参数说明

  • 显示名称：虚拟机的显示名称。

  • 描述：虚拟机的描述信息。

  • 主机：虚拟机所属主机的名称。

  • 状态：虚拟机当前的状态，包括运行、暂停、关闭、未知、HA异常。

  • CPU利用率：虚拟机CPU一小时内的平均利用率。

  • 内存利用率：虚拟机内存一小时内的平均利用率。

  • CPU：虚拟机当前的CPU总核数（即CPU个数与每个CPU核数的乘积）。

  • 内存：虚拟机当前的内存容量。

  • 操作系统：虚拟机的操作系统，目前支持Windows、Linux和银河麒麟类型的操作系统。其中ARM架构主机仅支持银河麒麟类型的操作系统，X86架构主机支持Windows和Linux操作系统。

  • 名称：虚拟机的名称。

  • IPv4/IPv6属性：虚拟机系统网卡对应的IPv4/IPv6属性。单击IP地址对应的超链接，可以查看IPv4/IPv6属性详细信息。对于IPv4属性，若虚拟机未安装CAStools，则无法采集子网掩码。

  • CAStools版本：CAStools版本信息。只有安装了CAStools的虚拟机才会显示CAStools版本。

  • CAStools状态：CAStools的运行状态，包括运行中、未运行。若虚拟机安装了CAStools且在虚拟机上已运行，则会显示“运行中”，否则会显示“未运行”。当虚拟机关机时显示“--”。

  • 连续运行时长：虚拟机已经连续运行的时间。

  • 创建时间：创建虚拟机的时间。

  • 最后关机时间：虚拟机的最后关机时间。

  • 时间同步：显示虚拟机是否配置时间同步。

  • 磁盘容量：显示虚拟机的磁盘容量大小。

  • 可用容量：显示虚拟机磁盘的可用容量。

  • 已用容量：显示虚拟机磁盘的已用容量。

  • 防病毒配置：虚拟机是否启用防病毒，包括启用、不启用。ARM架构主机暂不支持防病毒配置。


查看云资源中的操作日志

该功能用于查看所有操作员在管理平台中所做的操作信息。

操作步骤

  1. 单击导航树中[云资源]菜单项，进入云资源的概要信息页面。

  2. 选择“任务”页签，进入该主机池的任务列表页面。

参数说明

  • 登录名：操作员登录管理平台所使用的登录名。

  • 操作员姓名：操作员的姓名。

  • 完成时间：操作员完成操作的时间。

  • 登录地址：操作员登录管理平台所使用计算机的IP地址。

  • 操作分类：所执行操作的分类。

  • 操作对象：操作所执行的对象。

  • 操作描述：所执行操作的详细描述。

  • 执行结果：操作的执行结果。

  • 成功：表示操作执行成功。

  • 部分成功：表示操作执行部分成功。

  • 失败：表示操作执行失败。

  • 失败原因：操作失败的详细原因。

  • 风险级别：操作执行对应的风险级别，包括高、中、低。

  • 事件类型：操作员所操作事件的类型。


主机池

在CVM中，主机池是一系列主机和集群的集合体。必须先创建主机池，然后通过主机池或主机池中的集群来管理主机。

在系统中增加主机池后，操作员可以在主机池中增加集群或主机；可以在主机池中增加共享文件系统，为共享文件系统设置心跳网络；还可以将主机池内的系统资源授权给其他操作员分组进行管理。

主要功能

  • 增加主机池

  • 删除主机池

  • 查看主机池概要信息

  • 查看主机池中的主机信息

  • 查看主机池中的虚拟机信息

  • 查看主机池的操作日志

  • 连接主机池中的所有主机

  • 共享文件系统管理

  • RBD网络存储管理

  • 设置共享文件系统的心跳网络


增加主机池

该功能用于在云资源中增加一个主机池。

主机池增加完成后，需要在主机池中增加集群或者增加主机。

操作步骤

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<增加主机池>按钮，弹出增加主机池对话框。

  3. 输入主机池名称。

  4. 单击<确定>按钮完成操作。


删除主机池

该功能用于删除主机池。删除主机池将不会影响下属主机或者集群中虚拟机的运行，但该主机池下所有的主机和虚拟机都将脱离CVM的管理。

配置前提

在删除主机池前，请确保对主机池中集群、主机和虚拟机的全部操作已完成。

注意事项

  • 如果主机池中配置了集群，集群中包含主机并且启用了HA功能，则不允许删除该主机池。

  • 如果主机池中的主机配置了共享文件系统存储池，则不允许删除该主机池。

操作步骤

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 单击<更多操作>按钮，选择[删除主机池]菜单项，弹出删除主机池确认对话框。

  3. 单击<确定>按钮完成操作。


查看主机池概要信息

该功能用于查看主机池的详细配置信息，主机池中主机的状态统计信息、Top5主机的CPU和内存利用率信息，以及Top5虚拟机的CPU和内存利用率信息。

操作步骤

  1. 单击导航树[云资源/<主机池>]菜单项，进入主机池概要信息页面。

参数说明

  • 基本属性：显示指定主机池的详细配置信息。

  • 主机：主机池中主机个数。

  • CPU总核数：主机池中各主机CPU核数数量总和。

  • 总内存：主机池中各主机内存容量总和。

  • 本地总存储：主机池中各主机本地存储容量总和。

  • 本地总可用存储：主机池中各主机剩余可用的本地存储容量总和。

  • 虚拟机：主机池中虚拟机的数量，包括虚拟机总数，以及处于“运行”和“关闭”状态的虚拟机数量。

  • 虚拟机密度：主机池中平均每个主机上的虚拟机数量。

  • Top5主机CPU利用率：显示主机池中CPU利用率（即百分比）最高的五个主机的名称和CPU利用率环形图表。

  • Top5主机内存利用率：显示主机池中内存利用率（即百分比）最高的五个主机的名称和内存利用率柱形图表。

  • 主机状态统计：显示当前主机池中主机总数与不同状态，包括正常、异常、维护）的主机数量。

  • Top5虚拟机CPU利用率：显示主机池中CPU利用率（即百分比）最高的五个虚拟机的显示名称和CPU利用率环形图表。

  • Top5虚拟机内存利用率：显示主机池中内存利用率（即百分比）最高的五个虚拟机的显示名称和内存利用率柱形图表。


查看主机池中的主机

该功能用于查看指定主机池中的所有主机信息。

操作步骤

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“主机”页签，进入主机池下的主机信息页面。

参数说明

  • 名称：主机的名称。

  • 状态：主机当前的状态，包括正常、不正常、维护模式、主机不在集群HA内。

  • 虚拟机概要：主机上虚拟机的总数量，以及处于“运行”和“关闭”状态的虚拟机数量。

  • CPU：主机当前的CPU总核数（即CPU个数与每个CPU核数的乘积）。

  • 内存：主机当前的内存容量。

  • CPU利用率：主机的实时CPU利用率。

  • 内存利用率：主机的实时内存利用率。

  • 磁盘容量：主机本地磁盘的空间大小。

  • 平台：主机使用的虚拟化平台。目前仅支持CVK。

  • 操作：以图标方式显示操作员可以对主机执行的管理操作。 表示修改主机。


查看主机池中的虚拟机

该功能用于查看指定主机池中的所有虚拟机信息。

操作步骤

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“虚拟机”页签，进入主机池下的虚拟机信息页面。

  3. 单击<界面定制>按钮，可以调整显示列表的内容和顺序。

参数说明

  • 显示名称：虚拟机的显示名称。

  • 描述：虚拟机的描述信息。

  • 主机：虚拟机所属主机的名称。

  • 状态：虚拟机当前的状态，包括运行、暂停、关闭、未知、HA异常。

  • CPU利用率：虚拟机的实时CPU利用率。

  • 内存利用率：虚拟机的实时内存利用率。

  • CPU：虚拟机当前的CPU总核数（即CPU个数与每个CPU核数的乘积）。

  • 内存：虚拟机当前的内存容量。

  • 操作系统：虚拟机上的操作系统，目前支持Windows、Linux和银河麒麟类型的操作系统。其中ARM架构的主机仅支持银河麒麟类型的操作系统，X86架构主机支持Windows和Linux操作系统。

  • 名称：虚拟机的名称。

  • IPv4/IPv6属性：虚拟机系统网卡对应的IPv4/IPv6属性。单击IP地址对应的超链接，可以查看IPv4/IPv6属性详细信息。对于IPv4属性，若虚拟机未安装CAStools，则无法采集子网掩码。

  • CAStools版本：CAStools版本信息。只有安装了CAStools的虚拟机才会显示CAStools版本。

  • CAStools状态：CAStools的运行状态，包括运行中、未运行。若虚拟机安装了CAStools且在虚拟机上已运行，则会显示“运行中”，否则会显示“未运行”。当虚拟机关机时显示“--”。

  • 连续运行时长：虚拟机已经连续运行的时间。

  • 创建时间：创建虚拟机的时间。

  • 最后关机时间：虚拟机的最后关机时间。

  • 时间同步：显示虚拟机是否配置时间同步。

  • 磁盘容量：显示虚拟机的磁盘容量大小。

  • 可用容量：显示虚拟机磁盘的可用容量。

  • 已用容量：显示虚拟机磁盘的已用容量。

  • 防病毒配置：虚拟机是否启用防病毒，包括启用、不启用。ARM架构主机暂不支持防病毒配置。


查看主机池的操作日志

该功能用于查看所有操作员对指定主机池所做的操作信息。

操作步骤

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“任务”页签，进入该主机池的任务列表页面。

参数说明

  • 登录名：操作员登录管理平台所使用的登录名。

  • 操作员姓名：操作员的姓名。

  • 完成时间：操作员完成操作的时间。

  • 登录地址：操作员登录管理平台所使用计算机的IP地址。

  • 操作分类：所执行操作的分类。

  • 操作对象：操作所执行的对象。

  • 操作描述：所执行操作的详细描述。

  • 执行结果：操作的执行结果。

  • 成功：表示操作执行成功。

  • 部分成功：表示操作执行部分成功。

  • 失败：表示操作执行失败。

  • 失败原因：操作失败的详细原因。

  • 风险级别：操作执行对应的风险级别，包括高、中、低。

  • 事件类型：操作员所操作事件的类型。


连接主机池中的所有主机

通过该功能，管理平台可以与主机池中的所有主机建立连接。如果已经连接到该主机，将会重新建立连接。

操作步骤

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 单击<更多操作>按钮，选择[连接所有主机]菜单项，弹出连接所有主机确认对话框。

  3. 单击<确定>按钮完成操作。


共享文件系统管理

在传统环境中，SAN存储的LUN资源一般都是被一台主机直接挂载。在主机的操作系统中执行文件系统格式化操作，如格式化为FAT32、NTFS、EXT2/3/4等文件系统后，主机就可以以文件的方式使用该SAN存储的LUN资源。

但在虚拟化环境中，SAN存储的LUN资源需要被多台主机同时挂载，为了避免多台主机并行读写产生资源冲突的问题，因此需要将SAN存储的LUN资源格式化为共享文件系统，如OCFS2。

系统根据SAN存储的类型，支持两种类型的共享文件系统：iSCSI共享文件系统和FC共享文件系统。

共享文件系统是以主机池为边界，即共享文件系统不允许跨主机池使用。

共享文件系统管理主要包括在主机池中增加共享文件系统、修改共享文件系统、格式化共享文件系统、删除共享文件系统、查看共享文件系统中的存储文件详细信息等。

配置前提

  • 在主机池中增加共享文件系统前，请先确保主机已正确连接SAN存储，且存储端已做好LUN的划分和映射等相关配置。

  • 在格式化共享文件系统前，请先确保共享文件系统被主机的存储池引用且该存储池处于“不活动”状态。

  • 扩容共享文件系统前，请确保符合以下条件：

  • 至少有一个主机使用了该共享文件系统作为存储池。

  • 所有使用了该共享文件系统作为存储池的主机都处于正常状态，同时这些存储池也都处于活动状态。

注意事项

  • 如果共享文件系统正在被主机的存储池使用，则不允许删除。需要先删除使用该共享文件系统的存储池，然后才能删除共享文件系统。删除操作将导致共享文件系统中原始数据丢失。

  • 格式化文件系统时如果选择锁类型为硬件辅助锁，则要求存储服务器必须支持CAW。如果存储设备是ONEStor时，锁类型不能为硬件辅助锁。

  • 若分布式存储中的数据池已经配置为RBD网络存储，则该数据池中的存储卷不允许再配置为共享文件系统。

增加共享文件系统

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“共享文件系统”页签，进入该主机池的共享文件系统信息列表页面。

  3. 单击<增加共享文件系统>按钮，弹出增加共享文件系统对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 单击<完成>按钮完成操作。

修改共享文件系统

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“共享文件系统”页签，进入该主机池的共享文件系统信息列表页面。

  3. 选择要修改的共享文件系统，单击 [image] 图标，弹出修改共享文件系统对话框。

  4. 根据实际需要修改相关参数。当共享文件系统被主机的存储池使用时，只能修改显示名称、描述和是否作为业务存储。关于参数的详细介绍，请参见 参数说明 。

  5. 单击<完成>按钮完成操作。

格式化共享文件系统

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“共享文件系统”页签，进入该主机池的共享文件系统信息列表页面。

  3. 选择要格式化的共享文件系统，单击 [image] 图标，弹出磁盘格式化确认对话框。单击<确定>按钮，弹出格式化共享文件系统确认对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 单击<确定>按钮完成操作。

删除共享文件系统

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“共享文件系统”页签，进入该主机池的共享文件系统信息列表页面。

  3. 选择要删除的共享文件系统，单击 [image] 图标，弹出删除共享文件系统确认对话框。

  4. 单击<确定>按钮完成操作。

扩容共享文件系统

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“共享文件系统”页签，进入该主机池的共享文件系统信息列表页面。

  3. 选择要扩容的共享文件系统，单击 [image] 图标，弹出删除共享文件系统确认对话框。

  4. 单击<确定>按钮完成操作。

查看共享文件系统的存储文件详细信息

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“共享文件系统”页签，进入该主机池的共享文件系统信息列表页面。

  3. 选择要查看的共享文件系统，单击 [image] 图标，查看存储文件的详细信息。

参数说明

增加或修改共享文件系统：

  • 类型：共享文件系统的格式，包括：iSCSI共享文件系统、FC共享文件系统，默认为iSCSI共享文件系统。根据当前已有存储服务器的类型，确定共享文件系统选择iSCSI类型或FC类型。

  • 目标路径：共享文件系统在主机上的挂载点。

  • IP地址：IP SAN存储服务器的IP地址。当共享文件系统的类型设置为iSCSI时，需设置此参数。

  • LUN：选择共享文件系统所使用的LUN。当共享文件系统的类型设置为iSCSI时，需设置此参数。

  • NAA：存储服务器上LUN的唯一标识符。当共享文件系统的类型设置为iSCSI时，此参数由所选择的LUN确定。当共享文件系统的类型设置为FC时，此处需要选择一个LUN。

  • 业务存储：开启时表示系统自动向集群部署虚拟机时，可使用该共享文件系统。

格式化共享文件系统：

  • 最大访问节点数：允许使用共享文件系统的存储池数量，默认为32。

  • 簇大小（KB）：文件占用磁盘空间的最小单位，默认为1024KB。如果一个文件的容量大于单个簇大小，那么它会存储到多个簇中；如果一个文件的容量小于单个簇大小，那么它会独占一个簇。共享文件系统存放的文件多为虚拟机镜像文件，建议将簇大小设置的尽可能大，可以增强磁盘读取数据的性能，同时也不会浪费太多磁盘空间。

  • 锁类型：支持选择分布式锁和硬件辅助锁。

  • 分布式锁：分布式锁是一种基于网络的锁管理器，通过网络提供节点间互斥，当主机之间的网络中断可能会影响存储的正常使用。

  • 硬件辅助锁：硬件辅助锁是一种基于磁盘的锁管理器，锁的信息存储在磁盘上各自的锁区域中，集群间通过磁盘进行节点间互斥，即使主机间管理网络异常，只要存储链路可用，整个存储集群就可用。

共享文件系统列表：

  • 总容量：共享文件系统的总容量。

  • 已分配容量：已分配给虚拟机磁盘的虚拟容量总和。

  • 实际可用容量：共享存储剩余的实际可用容量。


RBD网络存储管理

RBD即RADOS Block Device的简称，是CEPH提供的块存储。RBD块设备可以直接挂载给虚拟机使用。RBD网络存储管理包括RBD网络存储池管理和RBD Client管理。

1. RBD网络存储池管理

RBD网络存储池用于维护与分布式存储的对应关系。虚拟机要使用分布式存储中的RBD块时，需先增加RBD网络存储池并关联分布式存储，再为主机挂载存储池。RBD网络存储池以主机池为边界，即RBD网络存储池不允许跨主机池使用。

RBD网络存储池管理包括增加RBD网络存储池、修改RBD网络存储池和删除RBD网络存储池。

2. RBD Client管理

RBD Client是主机对接分布式存储所需的客户端工具，主机必须安装RBD Client才能使用RBD网络存储资源，RBD Client的类型需要和分布式存储的类型保持一致。当分布式存储版本进行升级并明确要求RBD Client升级时，需要对RBD Client进行升级操作。RBD Client的安装包或升级包由分布式存储厂商提供，随分布式存储的版本一并提供。

RBD Client管理包括安装RBD Client和升级RBD Client。

注意事项

  • 不允许删除正在被虚拟机使用的RBD网络存储池。

  • 安装或升级RBD Client的时候主机会进入维护模式，处于运行状态的虚拟机会自动迁移至其他主机，虚拟机上的业务不受影响。待安装或升级完成后需手动将虚拟机迁回至原主机。

  • 若分布式存储的数据池中已经存在存储卷配置为共享文件系统、iSCSI网络存储的LUN或模板存储，则不允许再将该数据池配置为RBD网络存储。

  • ONEStor同一硬盘池中的数据池只能同时被一个管理平台增加为RBD网络存储。只能选择配置方式为精简配置的数据池作为RBD网络存储。

增加RBD网络存储池

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“RBD网络存储”页签，进入RBD网络存储池列表页面。

  3. 单击<增加RBD池>按钮，弹出增加RBD网络存储池对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 单击<确定>按钮完成操作。

修改RBD网络存储池

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“RBD网络存储”页签，进入RBD网络存储池列表页面。

  3. 选择目标存储池，单击 [image] 图标，弹出修改RBD网络存储池对话框。

  4. 根据实际需要修改相关参数，单击<确定>按钮完成操作。

删除RBD网络存储池

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“RBD网络存储”页签，进入RBD网络存储池列表页面。

  3. 选择目标存储池，单击 [image] 图标，弹出确认对话框。

  4. 单击<确定>按钮完成操作。

安装RBD Client

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“RBD网络存储”页签，进入RBD网络存储池列表页面。

  3. 单击<RBD Client管理>按钮，弹出RBD Client管理对话框。

  4. 勾选目标主机，单击 [image] 图标，为目标主机安装RBD Client。

  5. 单击<确定>按钮完成操作。

升级RBD Client

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 选择“RBD网络存储”页签，进入RBD网络存储池列表页面。

  3. 单击<RBD Client管理>按钮，弹出RBD Client管理对话框。

  4. 勾选目标主机，单击 [image] 图标，为目标主机升级已安装的RBD Client。

  5. 单击<确定>按钮完成操作。

参数说明

RBD网络存储池管理：

  • 分布式存储：选择提供RBD存储服务的分布式存储资源。

  • 数据池：选择分布式存储中的块存储数据池作为RBD网络存储。

RBD Client管理：

  • 资源类型：主机池对接的分布式存储的类型，包括ONEStor、柏科存储和Xsky存储三种。

  • 重新检测：重新检测主机的RBD Client安装情况。

  • 安装状态：主机上RBD Client的安装状态。

  • 进度：主机RBD Client安装情况的检测进度。

  • 版本：主机上安装的RBD Client的版本。


设置共享文件系统的心跳网络

共享文件系统的心跳网络主要用于使用了共享文件系统的主机之间的报文交互。该功能用于设置主机池下的共享文件系统心跳网络所在的网段。默认使用主机的管理网络同时作为共享文件系统的心跳网络。

用户可根据主机使用存储类型，网卡剩余情况及管理网、存储网带宽压力等选择不同类型网络来作为共享文件系统的心跳网络。

  • 主机使用FC SAN存储：

  • 管理网带宽压力较大，主机有多余网卡，可将共享文件系统的心跳网络配置为单独的网络。

  • 管理网带宽压力不大时，可将管理网络同时设置为共享文件系统的心跳网络。

  • 主机使用IP SAN存储：

  • 管理网带宽压力大，存储网带宽压力小，可将存储网络同时设置为共享文件系统的心跳网络。

  • 管理网带宽压力小，存储网带宽压力大，可将管理网络同时设置为共享文件系统的心跳网络。

注意事项

必须在挂载共享文件系统之前设置共享文件系统的心跳网络。

操作步骤

  1. 单击导航树中[云资源/主机池]菜单项，进入主机池概要信息页面。

  2. 单击<更多操作>按钮，选择[共享文件系统心跳网络]菜单项，弹出共享文件系统心跳网络设置对话框。

  3. 输入IP地址、子网掩码/前缀，单击<确定>按钮完成操作。

参数说明

  • IP地址：主机池中共享文件系统的心跳网络所在网段的任意IP地址。例如，主机规划了三个网络，管理网络192.168.10.0/24，业务网络192.168.20.0/24，存储网络192.168.30.0/24。若需要将存储网络同时作为共享文件系统的心跳网络，则此处IP可设置为192.168.30.0/24中的任意IP地址，如192.168.30.8。若不填，则默认使用管理网络作为共享文件系统的心跳网络。

  • 子网掩码/前缀：设置共享文件系统的心跳网络的网段。


资源授权管理

资源授权管理用于将主机池内的所有系统资源（包括主机池、集群、主机、虚拟机等）授权给其他的操作员分组进行管理。

授权给其他操作员分组后，只有属于该分组的操作员才能查看和操作该主机池内的系统资源。admin超级管理员默认可以管理所有主机池的资源。

操作步骤

  1. 单击导航树中[云资源/主机池]菜单项，进入主机池概要信息页面。

  2. 单击<更多操作>按钮，选择[资源授权管理]菜单项，弹出资源授权管理对话框。

  3. 选择将授权的操作员分组，单击<确定>按钮完成操作。

参数说明

授权管理分组：被授权的操作员分组。


主机

主机是运行了虚拟化软件的实体物理服务器。主机的作用是给虚拟机提供硬件环境，有时也称为“宿主”。通过主机和虚拟机的配合，一台主机上可以安装多个操作系统（主机上的操作系统和虚拟机中的操作系统），并且几个操作系统间还可以实现通信，就像是真实物理机一样。

在CVM中增加主机后，操作员可以根据实际需要配置相应的虚拟交换机，为虚拟机、主机、外部网络提供网络连接；为主机增加相应的存储池用于存放虚拟机磁盘镜像文件；为主机开启相关高级功能，如大页内存、IOMMU、CPU隔离、DPDK、中断亲和性和英特尔AEP配置等。

主要功能

ARM架构的主机暂不支持“GPU设备管理”、“容灾存储节点管理”以及“查看主机硬件监控信息”功能。

  • 增加主机

  • 修改主机

  • 删除主机

  • 主机存储管理

  • 主机虚拟交换机管理

  • 物理网卡管理

  • GPU设备管理

  • 存储适配器管理

  • 高级设置

  • 进入和退出维护模式

  • 主机唤醒管理

  • 主机维护操作管理

  • 容灾存储节点管理

  • 查看主机概要信息

  • 查看主机硬件监控信息

  • 查看主机性能监控信息

  • 查看主机上的虚拟机信息


增加主机

默认情况下，主机没有加入到管理平台中，需要手工将指定的主机添加到主机池或集群中。

该功能用于为主机池或者集群增加一个主机或着批量增加多个主机。

配置前提

所有待增加的主机已安装与CVM相同版本的CVK。

注意事项

  • 批量增加主机时，IP地址池中的地址个数应小于512，且起始IP必须小于结束IP。

  • 若待增加的主机正在运行共享文件系统，请通过增加单个主机的方式向主机池或集群中增加主机，以便初始化主机的共享文件系统。

  • 若待增加的主机上已挂载了NFS网络文件系统或Windows系统共享目录类型的存储池，则必须使用与该存储池同地址类型（IPv4或IPv6）的主机IP进行增加。

操作步骤

  1. 单击导航树中[云资源/<主机池>]或者[云资源/主机池/<集群>]菜单项，进入主机池或者集群概要信息页面。

  2. 单击<增加主机>按钮，弹出增加主机对话框。

  3. 选择是否批量增加主机，并设置相关参数后，单击<确定>按钮完成操作。

  • 增加单个主机时，需输入待增加主机IP地址、密码。

  • 批量增加主机时，需输入待增加主机所在IP地址池的起始IP、结束IP和密码。

参数说明

  • 起始IP：批量增加主机时，所有待增加主机所在IP地址池的起始IP。

  • 结束IP：批量增加主机时，所有待增加主机所在IP地址池的结束IP。

  • IP地址：增加单个主机时，待增加主机的IP地址。

  • 用户名：通过SSH协议访问主机时使用的用户帐号。目前仅支持root用户。

  • 密码：通过SSH协议访问主机时使用的用户帐号对应的密码。批量增加主机时，所有主机的密码必须相同。


修改主机

该功能用于修改主机上与管理平台连接的用户帐户对应的密码。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 单击<更多操作>按钮，选择[修改主机]菜单项，弹出修改主机对话框。

  3. 输入连接主机的密码和确认密码。

  4. 单击<确定>按钮完成操作。

参数说明

  • 主机名称：主机的名称。

  • 用户名：通过SSH协议访问主机时使用的用户帐号。目前仅支持root用户。

  • 密码：通过SSH协议访问主机时使用的用户帐号对应的密码。

  • 确认密码：用户账号确认密码。


删除主机

该功能用于删除主机池或者集群中指定的主机。

注意事项

  • 删除主机后，该主机及其主机上的虚拟机都将脱离管理平台的管理，但不影响该主机及其虚拟机的正常运行，且删除主机后，该主机上被移入回收站的虚拟机都会被彻底删除。

  • 在启用HA功能的集群中，删除主机需要慎重。确认不再使用主机或者主机故障不可修复时，再执行删除操作。对于从集群中删除的主机，为了确保其再次加入集群后可以正常运行，操作员必须先为主机重装CVK，再将其加入集群。

  • 如果删除主机失败并提示主机连接异常，需要重新连接主机后，再执行删除主机操作。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 单击<更多操作>按钮，选择[删除主机]菜单项，弹出删除主机确认对话框。

  3. 单击<确定>按钮完成操作。


主机存储

CAS中的存储用于保存虚拟机的操作系统、应用程序文件以及与活动相关的其它数据，是虚拟机正常工作的基本前提条件。

系统支持多种类型的存储资源，包括本地存储和外接存储。

  • 本地存储：可以是位于物理主机内部的内部硬盘，也可以包括位于主机之外并通过SAS或SATA等协议直接连接主机的外部存储系统。

  • 外接存储：物理主机通过高速的网络访问存储系统。外接存储可以实现共享，其数据存储可以同时被多个主机访问。CAS支持多种类型的外接存储，包括IP SAN、FC SAN以及NAS（网络附加存储）。

  • IP SAN：在iSCSI存储上存储虚拟机文件。通过iSCSI连接，主机可以充当启动器（Initiator），与位于远程iSCSI存储系统的目标（Target）进行通信。主机使用系统提供的iSCSI软件适配器连接到存储，通过这种连接，主机只需要一个标准的网络适配器来进行网络连接。

  • FC SAN：在FC存储上存储虚拟机文件。FC SAN是一种将主机连接到高性能存储设备的专用高速网络。主机需要配置光纤通道总线适配器(HBA)。如果主机包含FCoE（以太网光纤通道）适配器，则可以使用以太网网络与存储设备进行连接。

  • NAS（网络附加存储）：主机通过标准的TCP/IP网络访问远程文件服务器，并将虚拟机文件存储在远程文件服务器上。系统支持NFS网络文件系统和Windows系统共享目录。

主要功能

  • 存储池管理

  • 存储卷管理


存储池

ARM架构的主机暂不支持“本地文件目录（高速）”类型存储池。

在系统中，存储池是用来存放存储卷文件的目录。一个主机可以增加多个存储池。

当主机加入到管理平台后，默认存在两个“本地文件目录”类型的“defaultpool”和“isopool”存储池。其中“defaultpool”存储池用于存放虚拟机磁盘镜像文件，“isopool”存储池默认存放了castools.iso以及各操作系统的virtio驱动文件。操作员可以根据实际需要为主机增加不同类型的存储池。

存储池类型

对于不同类型的存储，系统支持增加存储池的类型为：

  • 本地存储：本地文件目录、本地文件目录（高速）、LVM逻辑存储卷；本地文件目录（高速）类型的存储池是使用数据中心持久化内存模块（DCPMM）来构建的存储池，相对于其他介质（HDD或SSD）构建的本地文件目录存储池，有着更高的性能。

  • 分布式存储：RBD网络存储。

  • 外接存储：

  • IP SAN：iSCSI网络存储、iSCSI共享文件系统；

  • FC SAN：FC网络存储、FC共享文件系统；

  • NAS（网络附加存储）：NFS网络文件系统、Windows系统共享目录。

虚拟机使用存储资源的方式

虚拟机使用其存储资源的方式有两种：

  • 块设备：块设备也称作裸设备，磁盘上没有文件系统，虚拟机可以直接访问和使用存储上的卷资源。常用于搭建数据库服务器等对磁盘空间要求比较高的场景，如医院的HIS系统。

  • 文件：文件是构建在文件系统之上的磁盘文件。虚拟机挂载磁盘文件后，实际看到的是一个的物理磁盘。文件的磁盘挂接方式更便于管理。

对于LVM逻辑存储卷、iSCSI网络存储、FC网络存储和RBD网络存储类型的存储池，虚拟机以“块设备”的方式使用其存储资源；对于本地文件目录、共享文件系统和NFS网络文件系统类型的存储池，虚拟机以“文件”的方式使用其存储资源。对于Windows系统共享目录类型的存储池，系统限制了对它的写操作，只能读取其中的数据。建议该类型的存储池用来存放操作系统的安装镜像文件。虚拟机可以直接挂载存储池中的ISO安装文件进行操作系统的安装，而不用将安装文件拷贝到本地。

图-1 主机-虚拟机使用存储资源示意

容灾存储介质

容灾存储介质指存放容灾备份数据的路径。只有作为容灾存储介质的存储池，才能作为磁盘备份容灾业务中的目的存储池。容灾存储介质添加完成后，存储节点会短暂离线。

注意事项

  • iSCSI网络存储类型和iSCSI共享文件系统类型的存储池，不能共用一个iSCSI存储服务器的同一个LUN。

  • NFS服务器的用户映射方式需要配置为no_root_squash，并授予root访问权限，否则将会导致存储池不可用。

  • 部分存储厂商的FC存储服务器，不支持自动扫描出对应LUN信息。因此在主机上增加FC SAN共享文件系统类型的存储池时，若找不到LUN信息，则需要重启主机才能正常发现LUN信息。

  • 当暂停FC网络存储或本地文件目录类型的存储池时，使用该存储池的虚拟机仍然可以正常启动；当暂停本地文件目录（高速）类型的存储池时，使用该存储池的虚拟机无法正常启动。

  • 在主机增加存储池时，若该存储需要支持虚拟机自动迁移，须满足以下条件：

  • 选择NFS网络文件系统，需要保证NFS所在源服务器的路径、NFS存储池的名称与集群内其他主机上的NFS存储池相同。

  • 选择iSCSI网络存储，需要保证该存储与集群内其他主机上的iSCSI网络存储有相同的存储名称和Target。

  • 选择FC网络存储，需要自动迁移的虚拟机使用的LUN与其他主机FC网络存储的LUN相同，还需要保证FC网络存储的名称相同。

  • 增加共享文件系统类型的存储池时，不允许安全区域的主机或集群和非安全区域的主机或集群使用同一个共享存储。

  • 查看路径详情时，I/O吞吐量统计、磁盘请求和磁盘I/O延迟图表内只展示首选路径信息。如果多条路径都为首选路径，则这几条路径的信息都会展示。

  • 只有共享文件系统类型的存储池才能作为容灾存储介质。

  • 若分布式存储的数据池已经配置为RBD网络存储池，则该数据池中的存储卷不允许再配置iSCSI网络存储的LUN。

  • 本地文件目录（高速）类型的存储池需要硬件支持，目前仅支持使用英特尔傲腾内存（AEP）来构建。在英特尔AEP配置菜单项下若存在有效数据或者在增加本地文件目录存储池时内存高速存储开关可操作，则表示主机支持该类型的存储池。

增加存储池

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 单击<增加>按钮，弹出增加存储池对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  5. 单击<完成>按钮完成操作。

修改存储池显示名称

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 在存储池列表中选择待修改的存储池，单击 [image] 图标，弹出修改存储池显示名称对话框。

  4. 输入显示名称，单击<确定>按钮完成操作。

启动存储池

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择待启动的存储池，单击 [image] 图标，弹出启动存储池确认对话框。

  4. 单击<确定>按钮完成操作。

暂停存储池

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择待暂停的存储池，单击 [image] 图标，弹出暂停使用存储池确认对话框。

  4. 单击<确定>按钮完成操作。

设为容灾存储介质

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择待设置的存储池，单击 [image] 图标，弹出设置容灾存储介质确认对话框。

  4. 单击<确定>按钮完成操作。

取消容灾存储介质

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择待取消的存储池，单击 [image] 图标，弹出取消容灾存储介质确认对话框。

  4. 单击<确定>按钮完成操作。

刷新存储池

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择待刷新的存储池，单击 [image] 图标，刷新存储池的信息。

查看存储池详细信息

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择待查看的存储池，单击 [image] 图标，查看存储池详细信息。

删除存储池

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择待删除的存储池，单击 [image] 图标，弹出删除存储池确认对话框。

  4. 单击<确定>按钮完成操作。

查看路径详情

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择待查看的共享文件系统类型的存储池，点击 [image] 图标，查看路径详情。

参数说明

增加“LVM逻辑存储卷”类型的存储池：

  • 源路径：需要选择VG作为源路径。如果管理员在主机上配置了VG，并为其增加了系统目录（如swap、home、var等）的挂载点，则不能选择这样的VG作为源路径。因为LVM存储卷作为虚拟机的磁盘，将会破坏主机系统目录下的数据。

增加“iSCSI网络存储”类型的存储池：

  • 目标路径：存储池使用的本地目录挂载点，默认为/dev/disk/by-id。

  • IP地址：iSCSI存储服务器的IP地址。

  • Target：iSCSI存储服务器的标识。

  • 设置标识符：设置CVK主机的iqn标识符，标示符必须全局唯一。

  • NAA：存储服务器上物理LUN的标识符，一个NAA对应一个LUN。如果存储配置了多路径，则可选NAA为所有Target包含的LUN的交集，需至少选择其中一个LUN。

增加“FC网络存储”类型的存储池：

  • 目标路径：存储池使用的本地目录挂载点，默认为/dev/disk/by-id。

  • NAA：存储服务器上物理LUN的标识符，一个NAA对应一个LUN，此处需要选择一个LUN。

增加“本地文件目录”类型的存储池：

  • 内存高速存储：是否使用内存高速存储构建本地文件目录（高速）类型的存储池。当主机不支持内存高速存储时，该选项无法进行选择。当选择使用内存高速存储时，需要选择内存区域。内存高速存储是将数据中心持久化内存模块（DCPMM）映射成本地存储，主要用于保存虚拟机的基础镜像。在对虚拟机进行新建、克隆以及部署等操作时，使用该介质构建的存储池，可以大幅提高虚拟机基础镜像的加载及访问效率，目前仅支持英特尔傲腾内存（AEP）。

  • 目标路径：存储池使用的本地目录，例如：存储池的名称为test，目标路径默认为/vms/test。该参数支持自定义。

  • 内存区域：挂载至存储池中的存储块设备对应的内存区域。

增加“NFS网络文件系统”类型的存储池：

  • 目标路径：存储池使用的本地目录挂载点。

  • 源主机IP：共享目录所在主机的IP地址

  • 源路径：共享目录的路径，如共享的目录为/opt/nfsshare，则需要填写：/opt/nfsshare。

增加“共享文件系统”类型的存储池：

  • 共享文件系统：选择要挂载的共享文件系统。在增加共享文件系统类型的存储池前，请先在主机池中增加共享文件系统，具体请参见共享文件系统管理。

  • 设置标识符：设置主机的iqn标识符，标示符必须全局唯一。

  • 设置网络：当主机无法访问iSCSI存储服务器时，通过设置网络可以快捷地增加或修改虚拟交换机的配置以便完成网络的互通。

  • 目标路径：存储池使用的本地目录挂载点。例如共享文件系统的显示名称为test，则目标路径默认为/vms/test，不能修改。

  • NAA：LUN的唯一标识符。

  • 设备型号：FC SAN存储设备的型号。

  • HBA卡：若主机与FC SAN存储设备之间配置了多路径，请选择Multipath，设置FC的多路径，增强可靠性。

增加“Windows系统共享目录”类型的存储池：

  • 目标路径：存储池使用的本地目录挂载点。

  • 源主机IP：Windows系统共享目录所在主机的IP地址。

  • 源路径：共享目录的路径，如共享的目录为X盘的share文件夹，则需填写：/share。目前只支持单级目录，不支持如/test/share1类似的多级目录。

  • 用户名：登录Windows系统所使用的用户名。

  • 密码：登录Windows系统所使用的用户名对应的密码。

存储池列表&查看存储池详细信息：

  • 总容量：存储池的总容量。

  • 对于iSCSI网络存储类型的存储池，若其Target下有多个LUN，则总容量为该Target下所有LUN容量的总和，包括被添加为共享文件系统、模板存储的LUN容量。

  • 对于RBD网络存储类型的存储池，假设其对应分布式存储的块存储数据池Pool A：

  • 若Pool A的冗余策略为副本，则总容量＝Pool A裸容量/副本数。

  • 若Pool A的冗余策略为纠删码，则总容量＝Pool A裸容量×数据块个数/（数据块个数+校验块个数）。

裸容量是指Pool A中正常硬盘容量的总和。由于分布式存储中存在元数据等开销，所以RBD网络存储池实际可用总容量会略小于此参数。如果分布式存储是元数据池、数据池分离的情况，那么Pool A裸容量应为其元数据池的裸容量。以ONEStor为例，Pool A裸容量为其硬盘池的裸容量（ONEStor的硬盘池即为元数据池）。

  • 已分配容量：已分配给虚拟机磁盘的虚拟容量总和。对于类型为iSCSI网络存储或FC网络存储的存储池，此参数表示存储池中块设备的总容量。

  • 实际可用容量：存储池剩余的实际可用容量。

路径详情：

  • NAA：存储服务器上物理LUN的标识符。

  • 所配置存储设备的多路径策略，包括：--、最近使用、固定、循环、最优，默认为“--”。

  • 路径详情：共享存储池的路径信息。

  • 名称：路径名称。

  • 状态：路径状态，包括：active、unable。

  • IP地址：生成多路径映射盘符对应的IP地址。

  • 首选：多路径磁盘I/O读写时可能选择的路径。如果首选显示为一个“*”，则表示此路径为活动路径；如果首选显示为两个或多个“*”，则表示在这些路径之间磁盘I/O负载均衡。

  • I/O吞吐量统计：统计并显示一定时间范围内主机某个磁盘I/O吞吐量。

  • 磁盘请求：统计并显示一定时间范围内主机某个磁盘的IOPS。

  • 磁盘I/O延迟：统计并显示一定时间范围内主机某个磁盘的I/O延迟。


存储卷

对于本地文件目录、共享文件系统、NFS网络文件系统类型的存储池，存储卷表示在存储池中创建的文件，系统支持两种类型的存储卷磁盘格式。

  • 高速：格式为raw，该格式的存储卷优点是结构简单，I/O效率高，缺点是不支持快照、在线备份、在线克隆等功能。

  • 智能：格式为qcow2，该格式的存储卷支持快照、在线克隆、在线备份等功能。新建存储卷时，系统默认使用此格式。

对于LVM逻辑存储卷类型的存储池，存储卷表示在VG中划分的LV，虚拟机以块设备的方式增加LV作为虚拟机的磁盘。

对于iSCSI网络存储和FC网络存储类型的存储池，存储卷表示在存储服务器上划分的属于该存储池的LUN，虚拟机以块设备的方式增加LUN作为虚拟机的磁盘。

对于RBD网络存储类型的存储池，存储卷表示在分布式存储上创建的RBD块。RBD块作为虚拟机磁盘，其磁盘格式是raw，但与raw格式的文件不同，RBD块支持快照和在线克隆。

存储卷管理主要包括为指定的存储池新建存储卷、上传文件，批量迁移存储卷，删除存储卷和下载存储卷等操作。

注意事项

  • 对于iSCSI网络存储类型的存储池，若其Target下有多个LUN，则其存储卷列表中只显示该Target下可以被虚拟机以块设备方式使用的LUN。

  • 若在新建存储卷时主机因故障发生重启，请在主机启动完成后，将已创建出来的存储卷删除，再重新创建该存储卷。

  • 批量迁移存储卷的过程中，请不要对使用该存储卷的虚拟机执行启动、关闭、迁移、克隆、快照、备份等操作，否则将可能导致虚拟机数据丢失。

  • 对于存储卷格式为高速（raw）且正在被虚拟机使用的存储卷，禁止执行批量迁移操作。

  • 暂不支持上传、下载以及批量迁移RBD网络存储池中的RBD块。

  • 在使用ONEStor同一元数据池的所有RBD网络存储池内，不允许创建同名的存储卷。

新建存储卷

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择存储池，在页面下方的存储卷列表中显示该存储池中所有存储卷的信息。

  4. 单击<新建存储卷>按钮，弹出新建存储卷对话框。

  5. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  6. 单击<确定>按钮完成操作。

增加LUN

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择一个iSCSI网络存储池或FC网络存储池，在页面下方的存储卷列表中显示该存储池中所有存储卷的信息。

  4. 单击<增加LUN>按钮，弹出增加LUN信息对话框。

  5. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  6. 单击<确定>按钮完成操作。

上传文件

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择存储池，在页面的下方会显示此存储池中所有存储卷和文件信息。

  4. 单击<上传文件>按钮，弹出文件上传对话框，在对话框中单击虚线框区域，选择本地要上传的文件，单击<开始上传>按钮完成文件的上传。

批量迁移存储卷

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择存储池，在页面的下方会显示此存储池中的存储卷。

  4. 在存储卷列表中选择待迁移的存储卷，单击<批量迁移>按钮，弹出操作确认对话框。

  5. 单击<确定>按钮确认迁移，选择目的存储池。

  6. 单击<确定>按钮完成操作。

删除存储卷

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择存储池，在页面的下方会显示此存储池中的存储卷。

  4. 在存储卷列表中选择待删除的存储卷，单击 [image] 图标。

  5. 单击<确定>按钮，再次弹出删除确认对话框，根据提示在输入框中输入“DELETE”。

  6. 单击<确定>按钮完成操作。

下载存储卷

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择存储池，在页面的下方会显示此存储池中的存储卷。

  4. 在存储卷列表中选择待下载的存储卷，单击 [image] 图标，弹出下载存储卷确认对话框。

  5. 单击<确定>按钮完成操作。

参数说明

新建存储卷：

  • 最大容量：存储卷的最大存储空间，不能超过存储池可用容量。

  • 格式：存储卷的格式，包括高速、智能，默认为智能。在RBD网络存储池中新建的存储卷是高速格式。在本地文件目录、共享文件系统、NFS网络文件系统类型的存储池中新建的存储卷，默认是智能格式。

  • 基础镜像文件：即安装完操作系统及应用软件的存储卷，可以提供给多台虚拟机共同使用，以节省服务器存储空间。此处需要选择“qcow2”或者“raw”类型的文件。

  • 预分配：存储卷的分配方式，包括：精简、延迟置零和置零，默认为精简。

  • 精简：创建存储卷时，只为该存储卷分配最初所需要的数据存储空间的容量。如果之后存储卷需要更多的存储空间，则它可以增加到创建存储卷时设置的最大容量。

  • 延迟置零：创建存储卷时就为存储卷分配最大容量的存储空间。创建时不会擦除物理设备上保留的任何数据，在虚拟机首次执行写操作时，将其置零。NFS网络文件系统类型的存储池不支持创建预分配方式为延迟置零的存储卷。

  • 置零：创建存储卷时就为存储卷分配最大容量的存储空间，在创建过程中会将物理设备上保留的数据置零，创建存储卷所需时间较长。

  • 簇大小：文件占用磁盘空间的最小单位，默认为256KB。如果一个文件的容量大于单个簇大小，该文件将存储到多个簇中；如果一个文件的容量小于单个簇大小，该文件将独占一个簇。共享文件系统存放的文件多为虚拟机镜像文件，建议将簇大小设置的尽可能大，以增强磁盘读取数据的性能，又节约磁盘空间。当新建智能格式的存储卷时，需设置此参数。

  • NAA：存储服务器上物理LUN的标识符，一个NAA对应一个LUN。


FC网络存储的LUN

主机上增加“FC网络存储”类型的存储池时，是以NAA为单位进行扫描添加，一个NAA对应一个LUN。一个“FC网络存储”类型的存储池可以管理多个LUN，可以根据实际需要为其增加LUN或者删除不需要的LUN。

FC网络存储的LUN管理主要包括为“FC网络存储”类型的存储池增加LUN、删除LUN等操作。

增加LUN

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择FC网络存储类型的存储池，在页面下方的存储卷列表中显示该存储池中所有LUN的信息。

  4. 单击<增加LUN>按钮，弹出增加LUN信息对话框，单击 [image] 图标，搜索并选择一个LUN；当搜索到多个LUN时，可单击NAA对应的输入框选择LUN。

  5. 单击<确定>按钮完成操作。

删除LUN

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面。

  2. 选择“存储”页签，进入该主机的存储池列表页面。

  3. 选择FC网络存储类型的存储池，在页面下方的存储卷列表中显示该存储池中所有LUN的信息。

  4. 在存储卷列表中选择要删除的LUN，单击 [image] 图标，弹出删除LUN信息确认对话框。

  5. 单击<确定>按钮完成操作。

参数说明

  • NAA：存储服务器上物理LUN的标识符，一个NAA对应一个LUN。


主机虚拟交换机

虚拟交换机是通过软件模拟的，具有实体交换机功能的网络平台，为虚拟机、主机、外部网络提供网络连接。

虚拟交换机主要提供三种类型的端口：

  • 虚拟机端口：连接虚拟机的虚拟网卡。

  • Local口：连接主机协议栈的端口。

  • 上行端口：连接主机的物理网卡。

如果虚拟交换机设置了VLAN，那么物理交换机上对应的物理端口需要设置相应的VLAN通过，否则主机或者虚拟机无法与外部网络通信。

系统支持五种网络类型的虚拟交换机，包括管理网络、业务网络、存储网络、备份网络和迁移网络。

  • 管理网络：此类型的虚拟交换机用于传输管理平台与各主机之间控制层数据。

  • 业务网络：此类型的虚拟交换机用于传输虚拟机业务数据。

  • 存储网络：此类型的虚拟交换机用于传输主机到IP SAN存储服务器或者主机到分布式存储之间的报文，且不允许虚拟机连接使用。

  • 备份网络：此类型的虚拟交换机用于传输虚拟机备份到远端服务器时的备份数据，且不允许虚拟机连接使用。一个主机上只允许存在一个备份网络类型虚拟交换机或此类型的子网。备份网络还可以用于传输容灾业务产生的备份数据，如果不设置备份网络，备份数据默认走管理网进行传输。

  • 迁移网络：此类型的虚拟交换机用于传输虚拟机迁移时的内存和磁盘镜像数据，且不允许虚拟机连接使用。一个主机上只允许存在一个此类型的虚拟交换机或此类型的子网。

在管理平台中增加主机后，系统会在主机上自动创建一个默认的虚拟交换机“vswitch0”，用于管理网络。如果没有单独设置备份网络和迁移网络，那么虚拟机的备份数据和迁移数据默认都通过管理网络vswitch0传输。

主机的虚拟交换机管理包括增加虚拟交换机、修改虚拟交换机、启用虚拟交换机、删除虚拟交换机和虚拟交换机的高级设置功能，如端口镜像管理、DHCP服务配置、NetFlow配置以及子网管理功能。

注意事项

  • ARM架构的主机暂不支持NetFlow配置。

  • 增加虚拟交换机时，不能增加两个相同网段的虚拟交换机。

  • 管理平台不允许删除正在被虚拟机使用的虚拟交换机。

  • 当虚拟交换机中只存在vswitch0时，删除虚拟交换机会导致管理平台无法访问。

增加虚拟交换机

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 单击<增加>按钮，弹出增加虚拟交换机对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见参数说明。

修改虚拟交换机

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待修改的虚拟交换机，单击 [image] 图标，弹出修改虚拟交换机对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  5. 单击<完成>按钮完成操作。

启用虚拟交换机

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待启用的虚拟交换机，单击 [image] 图标，弹出启用虚拟交换机确认对话框。

  4. 单击<确定>按钮完成操作。

删除虚拟交换机

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待删除的虚拟交换机，单击 [image] 图标，弹出删除虚拟交换机确认对话框。

  4. 单击<确定>按钮完成操作。

设为容灾备份网络

注意事项

ARM架构主机暂不支持容灾备份。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择一个备份网络类型的虚拟交换机，或名称为vswitch0的虚拟交换机（vswitch0默认可作为备份网络），单击 [image] 图标，弹出确认对话框。

  4. 单击<确定>按钮完成操作。

参数说明

  • 网络类型：虚拟交换机的网络类型，默认为业务网络。

  • 管理网络：此类型的虚拟交换机用于传输管理平台与各主机之间控制层数据。

  • 业务网络：此类型的虚拟交换机用于传输虚拟机业务数据。

  • 存储网络：此类型的虚拟交换机用于传输主机到IP SAN存储服务器或者主机到分布式存储之间的报文，且不允许虚拟机连接使用。

  • 备份网络：此类型的虚拟交换机用于传输虚拟机备份到远端服务器时的备份数据，且不允许虚拟机连接使用。一个主机上只允许存在一个此类型虚拟交换机或此类型的子网。

  • 迁移网络：此类型的虚拟交换机用于传输虚拟机迁移时的内存和磁盘镜像数据，且不允许虚拟机连接使用。一个主机上只允许存在一个此类型的虚拟交换机或此类型的子网。

  • 其他网络：此类型的虚拟交换机用于传输上述未提及的其他类型的数据。

  • 转发模式：虚拟机流量的转发模式，包括：VEB、VXLAN(SDN)，默认为VEB。

  • VEB：Virtual Ethernet Bridge，虚拟以太网桥。在这种模式下，虚拟机与虚拟机之间的流量通过纯软件的方式进行转发。

  • VXLAN(SDN)：部署了SDN控制器和云计算管理平台的VXLAN解决方案对应的虚拟交换机转发模式。

  • VLAN ID：虚拟交换机Local口的VLAN ID，单独划分VLAN后，可将主机的网络流量与虚拟机的网络流量进行二层隔离。

  • 启用DPDK：设置DPDK功能，开启后可以提升虚拟机的网络性能。

  • MTU：设置虚拟交换机允许通过最大数据包的大小，单位为Byte。默认vswitch0不允许修改MTU的值。

  • 启用组播：设置虚拟交换机的组播功能，开启后虚拟交换机可以实现组播流量的正常转发。默认vswitch0不允许启用组播。

  • 物理接口：选择虚拟交换机所使用的主机物理网卡的接口。一个物理接口只能被一个虚拟交换机使用。当主机的物理接口都被其他虚拟交换机使用时，物理接口选项不可填。若一个虚拟交换机没有使用物理接口，则连接该虚拟交换机的虚拟机只能彼此进行通信，而无法与外部网络进行通信。选择多个物理接口时，需要配置链路聚合模式和负载分担模式。

  • IPv4地址：配置虚拟交换机的IPv4地址。

  • 子网掩码：配置对应IPv4地址的子网掩码。

  • IPv4网关：配置主机的IPv4网关地址，一台主机只能配置一个IPv4网关。

  • IPv6地址：配置虚拟交换机的IPv6地址。

  • 子网前缀长度：配置对应IPv6地址的子网前缀长度。

  • IPv6网关：配置主机的IPv6网关地址，一台主机只能配置一个IPv6网关。

  • 链路聚合模式：虚拟交换机使用的物理网卡之间的链路聚合方式，包括静态、动态，默认为静态。当此参数设置为动态时，物理交换机上需要开启LACP功能。当选择多个物理接口时，才允许设置此参数。

  • 负载分担模式：虚拟交换机使用的物理网卡之间的负载分担模式，包括高级、基本、主备，默认为高级。当选择多个物理接口时，才允许设置此参数。

  • 高级：根据转发报文的以太网类型、IP报文协议、源IP地址、目的IP地址、应用层源端口和目的端口进行负载分担。

  • 基本：根据转发报文的源MAC地址和VLAN Tag进行负载分担。

  • 主备：根据物理网卡主备进行负载分担。当主网卡出现故障，自动使用备网卡进行网络流量的处理。

  • 故障恢复切换：若启用故障恢复切换，当主网卡恢复正常，自动切换回主网卡；若不启用故障恢复切换，当主网卡恢复正常，依然使用备网卡处理，不会自动切换回主网卡。当负载分担模式为“主备”时，需要设置此选项。

  • 主链路选择方式：当负载分担模式为“主备”时，需要设置主链路的选择方式。

  • 速率优先：根据网卡的速率选择主网卡，速率高的作为主网卡。当网卡速率相同时，系统随机选择一个网卡作为主网卡。

  • 手动配置：通过指定网卡的分担优先级选择主网卡，优先级高的作为主网卡。需要设置网卡的分担优先级。

  • 分担优先级：从上往下进行优先级排序，最上面的优先级最高，即作为主网卡。


端口镜像

端口镜像是指将源端口的数据报文复制到与数据监测设备相连的目的端口上，从而实现在目的端口上监测源端口的数据报文信息的目的。端口镜像常用于数据分析和网络问题诊断。

端口镜像管理主要包括增加端口镜像、修改端口镜像以及删除端口镜像等操作。

注意事项

  • 源端口虚拟机所属VLAN不能为1。

  • 端口镜像源端口可选择多个与同一虚拟交换机相连的虚拟机网卡。

  • 端口镜像目的端口最多可选择两个与同一虚拟交换机相连的虚拟机网卡。当未指定端口镜像的目的端口时，镜像报文会从主机的Uplink口发出。

增加端口镜像

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待增加端口镜像的虚拟交换机，单击 [image] 图标，弹出虚拟交换机高级设置对话框。

  4. 选择“端口镜像”页签，进入端口镜像列表页面。

  5. 单击<增加>按钮，弹出增加端口镜像对话框。

  6. 设置相关参数，关于参数的详细介绍，请参见参数说明。

  7. 单击<完成>按钮完成操作。

修改端口镜像

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待修改端口镜像的虚拟交换机，单击 [image] 图标，弹出虚拟交换机高级设置对话框。

  4. 选择“端口镜像”页签，进入端口镜像列表页面。

  5. 选择待修改的端口镜像，单击 [image] 图标，弹出修改端口镜像对话框。

  6. 修改相关参数，关于参数的详细介绍，请参见参数说明。

  7. 单击<完成>按钮完成操作。

删除端口镜像

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待删除端口镜像的虚拟交换机，单击 [image] 图标，弹出虚拟交换机高级设置对话框。

  4. 选择“端口镜像”页签，进入端口镜像列表页面。

  5. 选择待删除的端口镜像，单击 [image] 图标，弹出确认删除端口镜像对话框。

  6. 单击<确定>按钮完成操作。

参数说明

  • 镜像VLAN ID：镜像VLAN ID是为此镜像预留的专用VLAN ID。

  • 方向：源端口可复制的报文的方向。

  • 入方向：虚拟机指定端口发送到虚拟交换机的报文。

  • 出方向：虚拟交换机发送到虚拟机指定端口的报文。

  • 双向：虚拟交换机收到和发出的报文。


DHCP服务配置

DHCP（Dynamic Host Configuration Protocol，动态主机配置协议）主要作用是集中的管理、分配IP地址，使网络环境中的主机动态的获得IP地址、网关地址、DNS服务器地址等信息，并能够提升地址的使用率。

在中、大型网络，特别是大型网络中，往往有超过100台的虚拟机，必须引入一种高效的IP地址分配方法，DHCP服务可以满足这一需求。DHCP服务可以简化用户增加虚拟机的操作，使得增加的虚拟机可以自动获得符合要求的IP地址。

在同一虚拟交换机上可以配置多个DHCP服务，以VLAN作为区分。每个DHCP服务的作用范围根据VLAN进行区分，作用于设置了相应虚拟交换机及VLAN的虚拟机。

DHCP服务配置主要包括为指定的虚拟交换机增加DHCP服务、修改DHCP服务配置以及删除DHCP服务等操作。

注意事项

  • DHCP服务器本身会占用DHCP服务中配置的起始地址，配置成功后DHCP地址池中会缺少一个配置的起始地址。

  • 设置的多个DHCP服务，DHCP范围不能重叠。

  • 删除DHCP服务将会导致已从DHCP服务获得IP地址的虚拟机在一段时间之后失去已分配的地址，新加入对应虚拟交换机和对应VLAN的虚拟机将获取不到IP地址。

增加DHCP服务

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待增加DHCP服务的虚拟交换机，单击 [image] 图标，弹出的高级设置对话框。

  4. 选择“DHCP服务”页签，进入DHCP服务列表页面。

  5. 单击<增加>按钮，弹出增加DHCP服务页面。

  6. 设置相关参数，关于参数的详细介绍，请参见参数说明。

  7. 单击<确定>按钮完成操作。

修改DHCP服务配置

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待修改DHCP服务的虚拟交换机，单击 [image] 图标，弹出的高级设置对话框。

  4. 选择“DHCP服务”页签，进入DHCP服务列表页面。

  5. 选择待修改的DHCP服务配置，单击 [image] 图标，弹出修改DHCP配置对话框。

  6. 修改相关参数，关于参数的详细介绍，请参见参数说明。

  7. 单击<确定>按钮完成操作。

删除DHCP服务

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待删除DHCP服务的虚拟交换机，单击 [image] 图标，弹出的高级设置对话框。

  4. 选择“DHCP服务”页签，进入DHCP服务列表页面。

  5. 选择待删除的DHCP服务配置，单击 [image] 图标，弹出删除DHCP服务确认对话框。

  6. 单击<确定>按钮完成操作。

参数说明

  • VLAN ID：配置DHCP服务对应的VLAN的ID。在同一虚拟交换机中，VLAN ID可以区分不同的DHCP服务，必须唯一。配置了对应VLAN和虚拟交换机的虚拟机可以自动获得IP地址。

  • IP类型：选择DHCP服务分配的IP地址的类型，包括IPv4和IPv6。

  • 起始地址：DHCP服务的地址池起始IP地址。此地址作为DHCP服务器的地址。组播地址和回环地址不能作为DHCP地址段。起始地址不允许输入127.*.*.*。

  • 结束地址：DHCP服务的地址池结束IP地址。结束地址必须大于起始地址。地址池容量最大支持5000个地址。组播地址和回环地址不能作为DHCP地址段。结束地址不允许输入127.*.*.*。

  • DNS地址：DHCP服务使用的DNS服务器地址。

  • 租约时间：DHCP服务的租约时间，单位小时，不填代表无限制。

  • 地址池使用情况：描述地址的使用情况，包括已经使用的地址数和可以使用的地址总数。每个方格对应可以分配的地址，其中绿色表示该地址已分配，灰色表示该地址未分配。鼠标移动至方格并停留时，将显示相关信息。


NetFlow配置

ARM架构的主机暂不支持NetFlow配置。

通过配置NetFlow策略，对流经虚拟交换机的网络流量进行采集，并定时发送到NetFlow收集器，网络管理员可以在NetFlow收集器上对虚拟交换机发送的流量进行分析，从而实现对虚拟交换机上所有端口的流量进行实时监控。

NetFlow配置主要包括增加NetFlow收集器、删除NetFlow收集器以及配置活动流导出超时时间等操作。

增加NetFlow收集器

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待增加NetFlow收集器的虚拟交换机，单击 [image] 图标，弹出的高级设置对话框。

  4. 选择“NetFlow”页签，进入NetFlow列表页面。

  5. 单击<增加>按钮，弹出增加收集器对话框。

  6. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  7. 单击<确定>按钮完成操作。

删除NetFlow收集器

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待删除NetFlow收集器的虚拟交换机，单击 [image] 图标，弹出的高级设置对话框。

  4. 选择“NetFlow”页签，进入NetFlow列表页面。

  5. 选择待删除的NetFlow收集器，单击 [image] 图标，弹出删除收集器确认对话框。

  6. 单击<确定>按钮完成操作。

配置活动流导出超时时间

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 选择待配置的虚拟交换机，单击 [image] 图标，弹出的高级设置对话框。

  4. 选择“NetFlow”页签，进入NetFlow列表页面。

  5. 单击<配置>按钮，弹出配置NetFlow对话框。

  6. 输入活动流导出超时时间。关于参数的详细介绍，请参见参数说明。

  7. 单击<确定>按钮完成操作。

参数说明

  • IP地址：收集器的IP地址。

  • 端口：收集器的端口。

  • 活动流导出超时：向收集器发送数据的最长间隔时间。


子网管理

主机物理网卡的接口数量有限，无法为不同类型的网络流量分配独立的接口时，可通过在主机的虚拟交换机上创建不同类型的子网并配置带宽占比，以达到不同网络流量共用虚拟交换机绑定的物理接口的目的，从而提高网络带宽的利用率。

例如，一台服务器仅配置了一张2端口的万兆网卡和一张2端口的千兆网卡，此时可以按照如下方法规划管理网、业务网和存储网，以保证网络带宽又提高网络的高可靠性：

  • 配置两个虚拟交换机，网络类型分别为管理网和业务网。其中，管理网虚拟交换机可用系统默认的vswitch0。

  • 将千兆网卡上的2个端口与管理网虚拟交换机vswitch0绑定，并配置链路聚合。

  • 将万兆网卡的2个端口与业务网虚拟交换机绑定，并配置链路聚合。

  • 在业务网虚拟交换机上，创建存储网作为子网，并根据网络实际情况配置存储网络的带宽占比。

子网管理主要包括增加子网、修改子网以及删除子网等操作。

配置前提

创建子网前，请确保虚拟交换机已绑定至少一个处于活动状态的物理接口。

注意事项

子网仅供主机使用，不转发虚拟机的业务流量。

增加子网

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入主机的虚拟交换机列表页面。

  3. 单击虚拟交换机对应的操作列 [image] 图标，弹出增加子网对话框。

  4. 设置相关参数，关于参数的详细介绍，请参见参数说明。

  5. 单击<确认>按钮完成操作。

修改子网

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入该主机的虚拟交换机列表页面。

  3. 单击子网对应的操作列 [image] 图标，弹出修改子网对话框。

  4. 修改相关参数，关于参数的详细介绍，请参见参数说明。

  5. 单击<确认>按钮完成操作。

删除子网

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟交换机”页签，进入虚拟交换机页面。

  3. 单击子网对应的操作列 [image] 图标，弹出删除子网确认对话框。

  4. 单击<确定>按钮完成操作。

参数说明

  • 网络类型：子网的网络类型。

  • 管理网络：此类型的子网用于传输管理平台与各主机之间控制层数据。

  • 存储网络：此类型的子网用于传输主机到IP SAN存储服务器或者主机到分布式存储之间的报文。

  • 备份网络：此类型的子网用于传输虚拟机备份到远端服务器时的备份数据。一个主机上只允许存在一个此类型的子网或此类型的虚拟交换机。

  • 迁移网络：此类型的子网用于传输虚拟机迁移时的内存和磁盘镜像数据。一个主机上只允许存在一个此类型的子网或此类型的虚拟交换机。

  • 其他网络：此类型的子网用于传输上述未提及的其他类型的数据。

  • IPv4地址：子网使用的IPv4地址。

  • 子网掩码：子网IP地址对应的掩码。

  • IPv6地址：配置虚拟交换机的IPv6地址。

  • 子网前缀长度：配置对应IPv6地址的子网前缀长度。

  • VLAN ID：子网连接主机协议栈端口的VLAN ID。

  • 带宽占比：为复用网卡物理接口的子网设置最大带宽。同一虚拟交换机上所有子网的带宽占比之和不能超过99%。


物理网卡

物理网卡管理包括启用物理网卡，暂停物理网卡，修改物理网卡使用的驱动、MTU值，设置物理网卡的LLDP、SR-IOV以及网络限速等。

主机加入到管理平台后，默认启用所有的物理网卡。通过主机的“物理网卡”页签可以查看主机所有物理网卡的详细信息。

注意事项

  • ARM架构主机暂不支持SR-IOV。

  • 若虚拟机以增加PCI设备的方式将物理网卡作为虚拟机直通网卡使用时，则该物理网卡的速率、状态、MTU、载波和工作模式显示为“--”，启动 [image] 、暂停 [image] 按钮隐藏，不可对其配置LLDP、SR-IOV、网络限速功能。

启用物理网卡

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“物理网卡”页签，进入该主机的物理网卡列表页面。

  3. 选择待启动的物理网卡，单击 [image] 图标，启动物理网卡。

暂停物理网卡

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“物理网卡”页签，进入该主机的物理网卡列表页面。

  3. 选择待暂停的物理网卡，单击 [image] 图标，暂停物理网卡。

修改物理网卡的驱动、MTU值

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“物理网卡”页签，进入该主机的物理网卡列表页面。

  3. 选择待修改的物理网卡，单击 [image] 图标，在弹出的修改物理网卡对话框中修改驱动、MTU参数。关于参数的详细介绍，请参见参数说明。

  4. 单击<确定>按钮完成操作。

设置物理网卡的LLDP

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“物理网卡”页签，进入该主机的物理网卡列表页面。

  3. 选择待修改的物理网卡，选择“LLDP”页签，进入LLDP管理页面。

  4. 单击启用LLDP对应的开关项启用/停用LLDP功能。关于参数的详细介绍，请参见参数说明。

  5. 单击<保存>按钮完成操作。

设置物理网卡的SR-IOV

ARM架构的主机暂不支持网卡设置SR-IOV。

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“物理网卡”页签，进入该主机的物理网卡列表页面。

  3. 选择指定的物理网卡，选择“SR-IOV”页签，进入SR-IOV管理页面。

  4. 单击启用SR-IOV对应的开关项启用/停用SR-IOV，设置虚拟网卡个数。关于参数的详细介绍，请参见参数说明。

  5. 单击<保存>按钮完成操作。

设置物理网卡的网络限速

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“物理网卡”页签，进入该主机的物理网卡列表页面。

  3. 选择待修改的物理网卡，选择“网络限速”页签，进入网络限速信息页面。

  4. 输入限制速率。关于参数的详细介绍，请参见参数说明。

  5. 单击<保存>按钮完成操作。

参数说明

物理网卡列表：

  • NUMA：网卡所在的NUMA节点。

  • 速率：主机物理网卡的速率。主机若是由安装了CAS软件的虚拟机模拟的，则网卡速率会显示为-1。因为虚拟机的高速网卡使用的是virtio_net驱动，系统无法获取它的实际速率，但此现象不会影响主机物理网卡的使用。

  • 设备地址：显示网卡设备的PCI地址，用于区分PCI总线上的不同PCI设备。例如“0000:04:10.5”，其中“0000”是PCI域，每一个PCI域可以包含256个PCI总线；“04”是总线号，表示设备所在的PCI总线序号；“10”是槽位号，表示设备所在插槽的槽位序号；“.5”是功能号，表示设备在系统中的逻辑设备的序号。

  • 载波：网线是否连接网络设备，on表示连接，off表示未连接。

  • 工作模式：主机物理网卡的工作模式，Ful表示全双工、Half表示半双工。

修改物理网卡的驱动和MTU值：

  • 内核驱动：传统的系统网卡驱动。

  • VFIO驱动：将PCI设备映射到用户态时所需要的驱动，用于PCI设备直通或者对应虚拟交换机启用DPDK时。只有当主机启用IOMMU时，才能为网卡设置VFIO驱动。

  • MTU：与虚拟交换机端连接网口的最大传输单元。当驱动为“内核驱动”时，才允许修改此参数。对于已经加入虚拟交换机的物理网卡，只能通过虚拟交换机间接修改物理网卡的MTU值，不能通过直接对物理网卡的MTU值进行修改。

设置物理网卡的LLDP：

  • 对端设备信息：如果对端设备支持LLDP，对端设备会以报文的形式把自己的设备信息发送给物理网卡，展示在这里。主要信息包括发送设备的桥MAC地址、本设备信息在邻居设备上的存活时间等。根据不同厂商提供的不同设备，可能会有管理IP、系统描述、端口描述等信息。如果对端设备不支持LLDP，将接收不到LLDP报文，提示获取不到对端设备信息。

设置物理网卡的SR-IOV：

  • SR-IOV：将单一的物理网卡虚拟成多个VF接口，每个VF接口都有单独的虚拟PCIe通道，这些虚拟的PCIe通道共用物理网卡的PCIe通道。每个虚拟机可占用一个或多个VF接口，虚拟机通过自身的VF驱动程序直接访问VF接口，而不需要Hypervisor的协调干预，从而大幅提升网络吞吐性能。SR-IOV需要物理网卡硬件支持。

  • 虚拟网卡个数：物理网卡虚拟成虚拟网卡（即VF）的个数。若虚拟网卡个数显示为-1，可能是主机BIOS或者网卡的固件版本过低导致的，此时无法修改虚拟网卡个数。

设置物理网卡的网络限速：

  • 限制：网卡出方向速率限制值，默认为该网卡最大传输速率。启用SR-IOV的物理网卡不支持配置网络限速。


GPU设备

ARM架构的主机暂不支持“GPU设备管理”功能。

CAS集成了NVIDIA Virtual GPU技术，提供GPU虚拟化能力，为虚拟机用户在WIN10、3D图形设计、多媒体等复杂的图像数字场景下带来极致流畅的体验。GPU虚拟化使多个虚拟机共享同一个物理GPU资源，提高了GPU的资源利用率。

vGPU应用的主要流程为：

主机上增加vGPUà增加资源类型为vGPU的智能资源调度业务à为虚拟机增加GPU设备（选择资源类型为vGPU的资源池）à虚拟机内安装NVIDIA驱动并连接vGPU License Server。

GPU设备管理主要包括查看主机的物理GPU和vGPU信息、增加vGPU、回收vGPU、启用ECC和关闭ECC等操作。

注意事项

  • 物理GPU虚拟化时，其ECC（Error Correcting Code）功能必须处于关闭状态。修改ECC状态后，必须重启主机才能生效。

  • 每个物理GPU只能创建同一种类型的vGPU设备。

  • 已经创建vGPU设备的物理GPU不能再用于直通，正在以直通方式使用的物理GPU不能再用来创建vGPU设备。

查看主机的物理GPU和vGPU信息

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“GPU设备”页签，进入主机的GPU设备列表页面。

  3. 单击GPU设备列表中的物理GPU，可查看该物理GPU虚拟的vGPU的信息。

增加vGPU

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“GPU设备”页签，进入主机的GPU设备列表页面。

  3. 选择目标GPU设备，单击 [image] 图标，弹出增加vGPU对话框。

  4. 选择vGPU名称，单击<确定>按钮完成操作。

回收vGPU

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“GPU设备”页签，进入主机的GPU设备列表页面。

  3. 选择目标GPU设备，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮完成操作。

启用ECC

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“GPU设备”页签，进入主机的GPU设备列表页面。

  3. 选择目标GPU设备，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮完成操作。

关闭ECC

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“GPU设备”页签，进入主机的GPU设备列表页面。

  3. 选择目标GPU设备，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮完成操作。

参数说明

GPU设备：

  • 槽号：物理GPU的槽位号。

  • 设备厂商：物理GPU的生产厂商。

  • 类型：物理GPU的型号。

  • ECC：Error Correcting Code，是一种纠错码技术。此处显示物理GPU的ECC功能的启用状态。

vGPU：

  • UUID：vGPU的UUID，即虚拟化时生成的唯一标识符。

  • 名称：vGPU的类型名称。

  • 类型：vGPU的类型。

  • 显示器接口数：vGPU支持的最大显示器接口数。

  • 缓存：vGPU支持的帧缓冲区大小。

  • 分辨率：vGPU支持的最大分辨率。


存储适配器

主机使用存储适配器来访问不同的存储设备。CAS支持不同类型的存储适配器，包括SCSI、iSCSI、FC HBA、FCoE HBA。

安装完CAS软件的主机默认存在一个SCSI类型的Local-SCSI存储适配器和一个iSCSI类型的Open-iSCSI的存储适配器。Local-SCSI存储适配器用于连接服务器本地硬盘。Open-iSCSI存储适配器用于连接iSCSI存储。Open-iSCSI存储适配器默认存在一个iqn标识符信息（即Initiator信息），该标识符信息较复杂，为方便后期管理与维护，建议修改。

若主机配置了硬件FC HBA卡或者FCoE HBA（如CNA）连接FC存储时，在存储适配器列表中也会显示FC HBA或FCoE HBA的详细信息。

CAS还支持软件FCoE适配器。软件FCoE需要主机的FCoE协议堆栈进行协议处理，由网卡完成FCoE报文的转发工作。软件FCoE适配器需与提供数据中心桥接(DCB)和I/O卸载功能的网卡配合使用。

当主机与SAN存储之间存在多路径连接时，SAN网络中的任何元素（如适配器、交换机或电缆）发生故障，数据流量可切换到另一条可行的物理路径上进行传输。除路径故障切换外，多路径还提供负载均衡。负载均衡是在多个物理路径中分配I/O负载的过程。负载均衡可以减少或消除潜在的瓶颈。

CAS支持多路径策略的配置，依据不同存储厂商存储设备自己设定的多路径策略，支持最近使用、固定、循环、最优四种多路径策略。前提条件是存储设备开启了多路径并支持配置相应的多路径策略。

在主机上增加不同类型的存储池，其多路径的设置如下：

  • iSCSI共享文件系统：在主机池上增加iSCSI共享文件系统时，在IP地址输入框中输入IP SAN的多个业务IP地址。当只填写一个IP地址时，也默认启用多路径。具体请参见共享文件系统管理。

  • FC共享文件系统：在主机上增加FC共享文件系统的存储池时，在HBA输入框中选择Multipath启用多路径。具体请参见存储池管理。

  • iSCSI网络存储：默认不启用多路径，不能修改。

  • FC网络存储：默认启用多路径，不能修改。

当管理员在存储服务器上配置了LUN的划分和映射后，可以在管理平台中执行扫描存储适配器操作，用于发现主机可以使用的所有LUN信息。iSCSI存储分配给主机的LUN需要先在主机上增加相应存储池后才能扫描出对应的信息。对于部分FC存储，若无法扫描出对应的LUN信息，则需要重启主机才能正常发现。

存储适配器管理包括设置主机的iqn标识符、增加软件FCoE适配器、删除软件FCoE适配器、配置存储设备的多路径策略和扫描存储适配器等操作。

配置前提

配置软件FCoE适配器之前，交换机侧已做好FCoE的相关配置。

注意事项

  • ARM架构主机暂不支持软件FCoE适配器。

  • 增加软件FCoE适配器不成功时，可以通过如下4个方法进行排查：检查线路连接是否正确；在存储适配器界面单击<刷新>按钮；检查FCF交换机的配置是否正确；尝试在FCF交换机连接主机网卡的端口下执行shutdown/undo shutdown。

  • 当网卡的速率为10Gbps时，创建的软件FCoE适配器速率显示为Unknown，实际为8Gbps。

  • 当软件FCoE适配器下的存储设备已经挂载存储池时，不能删除该软件FCoE适配器，必须先删除该适配器下的存储池后，才能进行删除操作。

设置主机的iqn标识符

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“存储适配器”页签，进入该主机的存储适配器列表页面。

  3. 在存储适配器列表中，选择Open-iSCSI适配器，单击 [image] 图标，弹出设置标识符对话框。

  4. 输入标识符信息，单击<确定>按钮完成操作。

增加软件FCoE适配器

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“存储适配器”页签，进入该主机的存储适配器列表页面。

  3. 单击<增加>按钮，弹出添加软件FCoE适配器对话框。

  4. 单击 [image] 图标，弹出选择物理接口对话框，选择一个可以创建FCoE适配器的以太网物理接口。关于参数的详细介绍，请参见参数说明。

  5. 单击<确定>按钮完成操作。

删除软件FCoE适配器

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“存储适配器”页签，进入该主机的存储适配器列表页面。

  3. 在存储适配器列表中，选择待删除的FCoE存储适配器，单击 [image] 图标，弹出删除存储适配器确认对话框。

  4. 单击<确定>按钮完成操作。

配置存储设备的多路径策略

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“存储适配器”页签，进入该主机的存储适配器列表页面。

  3. 在存储设备列表中，选择要设置多路径策略的存储LUN，单击 [image] 图标，弹出管理路径对话框。

  4. 选择多路径策略。关于参数的详细介绍，请参见参数说明。

  5. 单击<确定>按钮完成操作。

扫描存储适配器

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“存储适配器”页签，进入该主机的存储适配器列表页面。

  3. 在存储适配器列表中，选择要扫描的存储适配器，单击 [image] 图标；或者单击<全部扫描>按钮，扫描全部的存储适配器。

  4. 在设备扫描对话框中选择扫描模式。关于参数的详细介绍，请参见参数说明。

  5. 单击<确定>按钮执行扫描操作。

参数说明

增加软件FCoE适配器：

  • 物理接口：选择一个物理网卡，网卡需支持数据中心桥接（DCB）和I/O卸载功能。

配置存储设备的多路径策略：

  • NAA：存储服务器上物理LUN的标识符。

  • 多路径策略：配置存储设备的多路径策略，包括：--、最近使用、固定、循环、最优，默认为“--”。

  • --：默认的多路径策略，若系统包含设备默认支持列表，则自动匹配对应的策略，若系统不支持采用“--”，则为最优。

  • 最近使用：使用一条默认路径，其他所有路径作为备用路径。当发生故障后，从备用路径随机选用一条路径进行I/O。在故障路径恢复之后，不能自动恢复到原有路径上，需要手动切换路径。该策略不能提供负载均衡。

  • 固定：选择第一条首选路径，当通往磁盘的首选路径可用时，主机将始终使用此路径。如果主机无法通过首选路径访问磁盘，它会尝试替代路径。一旦首选路径恢复可用，主机便会恢复到首选路径。该策略不能提供负载均衡。

  • 循环：所有路径均为活动路径，使用路径选择算法轮流选择所有可用的活动路径，在所有可用路径上平均分配I/O实现负载均衡。

  • 最优：在ALUA（Asymmetric Logical Unit Access，异步逻辑单元访问）模式下的推荐配置。按存储端SP分组。优先值高的SP路径为首选路径组（速度相对快）。在首选路径组中所有活动路径上平均I/O，实现负载均衡。当所有首选路径组路径故障后，会切换至备用路径组。在备用路径组上实现I/O负载均衡。当故障恢复后自动切换回首选路径组的路径。

  • 状态：路径状态，包括：active、unable。

  • IP地址：指生成多路径映射盘符对应的IP地址，仅在IP SAN存储启动多路径后显示。FC SAN存储设备的IP地址始终显示为空。

  • 首选：多路径磁盘I/O读写时可能选择的路径。如果首选显示为一个“*”，则表示此路径为活动路径；如果首选显示为两个或多个“*”，则表示在这些路径之间磁盘I/O负载均衡。

扫描存储适配器：

  • 正常扫描：按照正常规则扫描，不会重置HBA端口。

  • 强制扫描：强制执行扫描操作。一些HBA卡在存储分配完成后，需要通过强制扫描（存储链路重置）才能发现新增加设备。这是一种破坏性操作，可能导致IO操作超时。


高级设置

主机的高级设置功能包括主机的启动项配置、查看主机的NUMA/CPU信息、为主机配置静态路由、DPDK配置、中断亲和性配置以及英特尔AEP配置。

主要功能

ARM架构的主机暂不支持“启动项配置”、“查看主机的NUMA/CPU信息”、“DPDK配置”、“中断亲和性配置”以及“英特尔AEP配置”功能。

  • 启动项配置

  • 查看主机的NUMA/CPU信息

  • 路由配置

  • DPDK配置

  • 中断亲和性配置


启动项配置

ARM架构的主机暂不支持“启动项配置”功能。

主机的启动项配置包括大页内存的配置、IOMMU配置、CPU隔离。

  • 大页内存管理方式（HugePage），与传统的4KB普通页管理方式相比，大页管理大内存（8GB以上）更为有效，大大提高了CPU cache中存放page table所覆盖的内存大小，从而提高了TLB命中率。

  • IOMMU（Input/Output Memory Management Unit，内存输入/输出管理单元）允许系统设备在虚拟内存中进行寻址，也就是将虚拟内存地址映射为物理内存地址，让实体设备可以在虚拟的内存环境中工作，这样可以帮助虚拟机提升内存访问的性能。

  • CPU隔离是把指定的CPU从主机的多核平衡调度策略中移除。CPU被隔离后，系统不会自动把任务放到隔离的CPU上运行。隔离的CPU专用于虚拟机CPU绑定的物理CPU、DPDK绑定的物理CPU。以防出现主机CPU一直处于忙碌状态，一些重要业务的虚拟机或者主机启用DPDK功能时获取主机CPU资源过慢的情况，影响业务的处理速度。

注意事项

  • 修改大页、IOMMU配置、CPU配置后，必须重启主机才能生效。

  • 若主机开启了DPDK配置，则无法禁用大页配置。

  • 若主机网卡的驱动为VFIO，则无法禁用IOMMU。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“高级设置”页签，进入主机的启动项配置页面。

  3. 修改大页配置，在大页配置状态选择框中选择启用或禁用大页，若选择启用大页，则根据需要选择页大小，输入页数。

  4. 修改IOMMU配置，在IOMMU配置状态选择框中选择启用或禁用IOMMU。

  5. 修改CPU隔离，在CPU隔离配置状态选择框中选择启用或禁用CPU隔离。若选择启用CPU隔离，则至少选择一个NUMA节点，单击NUMA节点 [image] 图标，弹出隔离CPU对话框，选择要隔离的CPU，单击<确定>按钮。

  6. 单击<保存>按钮完成操作。

参数说明

大页配置：

  • 大页当前状态：主机当前的大页状态，包括：启用、禁用，默认为禁用。

  • 大页配置状态：主机大页配置的状态，包括：启用、禁用，默认为禁用。

  • 页大小：主机大页配置的页大小。

  • 页数：主机大页配置的页数。

IOMMU配置：

  • IOMMU当前状态：主机当前的IOMMU状态，包括：启用、禁用，默认为禁用。

  • IOMMU配置状态：主机IOMMU配置的状态，包括：启用、禁用，默认为禁用。

CPU配置：

  • CPU隔离当前状态：主机当前的CPU隔离状态，包括：启用、禁用，默认为禁用。

  • CPU隔离配置状态：主机CPU隔离配置的状态，包括：启用、禁用，默认为禁用。

  • NUMA节点：系统中NUMA节点数对应主机物理CPU数，单个CPU物理核数（如CPU支持超标量则还需乘超标量数值）即为NUMA节点内的CPU数量，NUMA节点编号从0开始。每个NUMA节点包含CPU，IO总线及内存资源。

  • 隔离CPU：NUMA节点中被隔离的CPU。

  • 操作：以图标的方式显示操作员可以对CPU隔离执行的管理操作。 表示修改NUMA节点上被隔离的CPU。


查看主机的NUMA/CPU信息

ARM架构的主机暂不支持“查看主机的NUMA/CPU信息”功能。

该功能用于查看主机下虚拟机绑定主机物理CPU的信息。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机的概要信息页面。

  2. 选择“高级设置”页签，进入主机的启动项配置页面。

  3. 选择[NUMA/CPU信息]菜单项，进入主机的CPU信息页面。

参数说明

  • CPU：显示NUMA节点的信息。

  • 状态：NUMA节点中的物理CPU的绑定状态，包括：空闲、已使用。

  • 空闲：表示该CPU未被虚拟CPU绑定。

  • 已使用：表示该CPU已被虚拟CPU绑定。

  • 绑定数量：绑定此物理CPU的虚拟CPU的数量。

  • 用途：显示此物理CPU的用途，包括虚拟机绑定、DPDK绑定、中断亲和性绑定等。


路由配置

路由配置用于配置主机的静态路由，主要功能包括增加静态路由、修改静态路由和删除静态路由。

注意事项

  • 网关必须和某个虚拟交换机属于同一网段，如果网关无效，则无法配置路由信息。

  • 路由信息将通过网关所在的虚拟交换机生效。

增加静态路由

  1. 单击导航树中[云资源/主机池/集群/<主机名>]或者[云资源/主机池/<主机名>]进入主机概要信息页面。

  2. 选择“高级设置”页签，进入主机的启动项配置页面。

  3. 选择[路由配置]菜单项，进入路由配置信息页面。

  4. 单击<增加路由>按钮，弹出增加路由对话框。

  5. 设置相关参数，单击<确定>按钮完成操作。关于参数的详细介绍，请参见参数说明。

编辑静态路由

  1. 单击导航树中[云资源/主机池/集群/<主机名>]或者[云资源/主机池/<主机名>]进入主机概要信息页面。

  2. 选择“高级设置”页签，进入主机的启动项配置页面。

  3. 选择[路由配置]菜单项，进入路由配置信息页面。

  4. 选择待修改的静态路由，单击 [image] 图标，修改相关参数。关于参数的详细介绍，请参见参数说明。

  5. 单击<确定>按钮完成操作。

删除静态路由

  1. 单击导航树中[云资源/主机池/集群/<主机名>]或者[云资源/主机池/<主机名>]进入主机概要信息页面。

  2. 选择“高级设置”页签，进入主机的启动项配置页面。

  3. 选择[路由配置]菜单项，进入路由配置信息页面。

  4. 选择待删除的静态路由，单击 [image] 图标，弹出操作确认对话框。

  5. 单击<确定>按钮完成操作。

参数说明

  • 目的IP网段：输入目的IP所属的网段。

  • 目的子网掩码/前缀：输入目的IP的子网掩码/前缀。

  • 网关：输入主机的网关IP。


DPDK配置

ARM架构的主机暂不支持“DPDK配置”功能。

该功能用于主机DPDK的配置。DPDK是一个开源的数据平面开发工具集，提供了一个用户空间下的高效数据包处理函数库，它通过环境抽象层旁路内核协议栈、轮询模式的报文无中断收发、无锁环形内存管理、优化内存/缓冲区/队列管理、基于网卡多队列和流识别的负载均衡、内存大页、NUMA、CPU隔离和绑定等多项技术，实现了在x86处理器架构下的高性能报文转发能力。

主机启用DPDK后，可以提升虚拟机网络报文的处理性能。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“高级设置”页签，进入主机的启动项配置页面。

  3. 选择[DPDK配置]菜单项，进入主机的DPDK配置页面。

  4. 选择是否启用DPDK。若选择启用DPDK，则至少选择一个NUMA节点，单击NUMA [image] 图标，弹出绑定CPU/大页内存对话框，输入大页内存容量、选择内存单位，选择绑定的CPU，单击<确定>按钮。

  5. 单击<保存>按钮完成操作。

参数说明

  • DPDK状态：主机当前的DPDK状态，包括：启用、禁用，默认为禁用。

  • 绑定CPU：NUMA节点绑定的CPU。

  • 绑定大页内存：NUMA节点绑定的大页内存。


中断亲和性配置

ARM架构的主机暂不支持“中断亲和性配置”功能。

系统的中断亲和性配置是把所有可以设置亲和性的中断都设置到指定的CPU上。设置成功后，这些中断的处理程序都会运行在指定的CPU上。通常把中断亲和性设置到非隔离的CPU上，以免这些中断的处理影响那些被隔离的CPU上运行的任务的实时性。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“高级设置”页签，进入主机的启动项配置页面。

  3. 选择[中断亲和性配置]菜单项，进入主机的中断亲和性配置页面。

  4. 选择启用或禁用中断亲和性状态。若启用中断亲和性，则至少选择一个NUMA节点，单击NUMA [image] 图标，弹出中断亲和性绑定页面，选择绑定的CPU，单击<确定>按钮。

  5. 单击<保存>按钮完成操作。

参数说明

  • 中断亲和性状态：主机当前的中断亲和性状态，包括：启用、禁用，默认为禁用。

  • 中断亲和性绑定CPU：绑定中断亲和性的CPU。


英特尔AEP配置

ARM架构的主机暂不支持“英特尔AEP配置”功能。

在主机安装了英特尔傲腾内存后，可以在本页面查看相关信息，并对其进行初始化。完成初始化后，系统可将英特尔傲腾内存配置为存储块设备进行挂载，作为本地文件目录（高速）类型的存储池使用。使用方式请参见存储池管理。

注意事项

  • 不允许初始化已经挂载到存储池上使用的Socket。

  • 初始化Socket后，需要重启主机以生效。

  • 在所有物理设备都生效的条件下，由于对齐等原因，Socket的容量与region下每个物理设备的容量和存在5%以内的偏差，属于正常现象。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“高级设置”页签，进入主机的启动项配置页面。

  3. 选择[英特尔AEP配置]菜单项，进入主机的英特尔AEP配置页面。

  4. 选择需要进行初始化的一个或多个Socket，单击<初始化>按钮，弹出确认对话框，单击<确定>按钮。


进入和退出维护模式

主机进入维护模式后，操作员可执行关闭主机、重启主机和远程唤醒主机等操作。执行上述操作后，主机仍处于维护模式。为了使主机能正常被使用，需要先退出维护模式。

本节主要介绍主机进入维护模式和退出维护模式的操作。

配置前提

待进入维护模式的主机上不存在处于“运行”或“暂停”状态的虚拟机。

进入维护模式

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/主机]菜单项，进入主机概要信息页面。

  2. 单击<进入维护模式>按钮，弹出进入维护模式对话框。选择“自动迁移处于运行或暂停状态的虚拟机”或者“自动迁移处于关闭状态的虚拟机”。

  3. 单击<确定>按钮完成操作。

退出维护模式

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/主机]菜单项，进入主机概要信息页面。

  2. 单击<退出维护模式>按钮，弹出退出维护模式确认对话框。

  3. 单击<确定>按钮完成操作。


主机唤醒管理

远程唤醒主机用于启动处于维护模式下“关闭”的主机。远程唤醒主机之前需要先设置唤醒参数，即唤醒主机的方式。

为主机设置的唤醒方式也适用于在“主机唤醒监控策略”影响下主机的自动唤醒。

主机唤醒管理包括唤醒参数设置、远程唤醒主机等操作。

唤醒参数设置

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 单击<更多操作>按钮，选择[唤醒参数设置]菜单项，弹出唤醒参数设置对话框。

  3. 选择唤醒方式、设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 单击<确定>按钮完成操作。

远程唤醒主机

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 单击<更多操作>按钮，选择[远程唤醒]菜单项，弹出远程唤醒主机确认对话框。

  3. 单击<确定>按钮完成操作。

参数说明

唤醒参数设置：

  • 唤醒方式：唤醒主机使用的方式，包括网络唤醒、IPMI唤醒，默认为网络唤醒。

  • 网络唤醒：指由一台正常运行的主机向待唤醒主机的网卡发送一段数据报文，使待唤醒的主机从休眠或关闭状态转为正常运行状态。使用网络唤醒方式的主机需要ATX电源和主板软硬件的支持，唤醒操作才能生效。

选择此唤醒方式时，请确保CVM与CVK主机的二层网络连通。

  • IPMI唤醒：指由IPMI（Intelligent Platform Management Interface，智能平台管理接口）向待唤醒主机上的BMC（Baseboard Management Controller，基板管理控制器）发送命令，使待唤醒的主机从休眠或关闭状态转为正常运行状态。BMC是安装在服务器主板上的独立板卡，服务器上存在单独的网络接口卡与BMC通信。使用IPMI唤醒方式的主机需要IPMI和BMC固件的支持，唤醒操作才能生效。

选择此唤醒方式时，请确保CVM与CVK主机的BMC网络连通。

  • BMC IP地址：主机的BMC IP地址。与BMC关联的网卡的IP地址，不同于主机的IP地址。该IP地址应是具有无限租期的静态或DHCP地址。

  • 用户名：主机的BMC帐号。

  • 密码：主机的BMC帐号对应的密码。BMC帐户的用户名和密码必须能够远程打开主机电源。


主机维护操作

主机维护操作管理包括连接主机、关闭主机和重启主机。

  • 连接主机：用于CVM与指定的主机建立连接。如果系统已经连接到该主机，将会重新与主机建立连接。系统会定时轮询所管理的全部主机，如果某主机因为网络故障或自身运行故障而不能被正常连接，主机图标将由“ [image] ”变成“ [image] ”，同时该主机上的所有虚拟机也都将变成未知状态“ [image] ”。

  • 关闭主机：用于关闭处于维护模式的主机。只有在维护模式下才能执行关闭主机操作。

  • 重启主机：用于重启维护模式的主机，只有在维护模式下才能执行重启主机操作。

连接主机

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/主机]菜单项，进入主机概要信息页面。

  2. 单击<更多操作>按钮，选择[连接主机]菜单项，弹出连接主机确认对话框。

  3. 单击<确定>按钮完成操作。

关闭主机

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/主机]菜单项，进入主机概要信息页面。

  2. 单击<更多操作>按钮，选择[关闭主机]菜单项，弹出关闭主机确认对话框。

  3. 单击<确定>按钮完成操作。

重启主机

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/主机]菜单项，进入主机概要信息页面。

  2. 单击<更多操作>按钮，选择[重启主机]菜单项，弹出重启主机确认对话框。

  3. 单击<确定>按钮完成操作。


容灾存储节点

ARM架构的主机暂不支持“容灾存储节点管理”功能。

容灾存储节点指在容灾业务中，在业务保护、数据传输过程中提供数据的分发处理功能的主机，可以提供更多的存储空间和存储能力。只有设置为容灾存储节点的主机，才能作为容灾目的主机使用。

注意事项

已经加入到保护组的主机，不能取消容灾存储节点。

设为存储节点

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项。

  2. 选择“更多操作”页签。

  3. 选择[设为容灾存储节点]菜单项，弹出设置存储节点确认对话框。

  4. 单击<确定>按钮完成操作。

取消存储节点

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项。

  2. 选择“更多操作”页签。

  3. 选择[取消容灾存储节点]菜单项，弹出取消存储节点确认对话框。

  4. 单击<确定>按钮完成操作。


查看主机概要信息

该功能用于查看指定主机的详细配置信息、主机上虚拟机的CPU和内存利用率的Top5信息、以及主机的CPU利用率、内存利用率和网络吞吐量的实时监控信息。

注意事项

  • 当主机更改内存或CPU硬件资源后，操作员需要重新连接主机，才能在主机概要中显示更改后的内存或CPU信息。

  • 当主机仅配置了IPv6地址时，主机概要信息中不会显示iLO参数项。当主机同时配置了IPv4和IPv6地址时，主机概要信息iLO参数项仅会显示IPv4地址。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

参数说明

  • 基本属性：显示指定主机的详细配置信息。

  • IP地址：主机的IP地址。

  • 状态：主机当前的状态，包括正常、不正常、维护模式、主机不在集群HA内。

  • iLO：访问iLO管理平台的IP地址。

  • 主机型号：主机的设备型号。

  • CPU数量：主机CPU核数数量总和（即CPU个数与每个CPU核数的乘积）。

  • CPU型号：主机CPU的型号。

  • CPU主频：主机CPU的频率。

  • 内存：主机内存的容量。

  • 空闲内存：主机剩余的可用内存容量。

  • 版本：主机安装的CVK版本。

  • 虚拟机：主机上虚拟机的总数，以及处于“运行”和“关闭”状态的虚拟机数量。

  • 本地存储：主机磁盘的容量。

  • 本地空闲存储：主机剩余可用的本地磁盘容量。

  • 主机时间：主机系统内部时间。

  • 运行时间：主机系统持续运行的时间。

  • 存储使用率：主机本地存储的使用率百分比（本地已用存储/本地存储总量）。

  • CPU分配比：主机CPU的利用情况（即虚拟机CPU总核数占主机CPU总核数的百分比）。

  • 内存分配比：主机内存的利用情况（即虚拟机内存总数占主机内存总数的百分比）。

  • Top5虚拟机CPU利用率：显示主机中CPU利用率（即百分比）最高的五个虚拟机的显示名称和CPU利用率环形图表。

  • Top5虚拟机内存利用率：显示主机中内存利用率（即百分比）最高的五个虚拟机的显示名称和内存利用率柱形图表。

  • 计算资源监控信息：显示主机的CPU利用率、内存利用率。

  • CPU利用率：以仪表盘形式显示主机的CPU利用率。仪表盘中指针指向的刻度默认显示最近30秒内当前主机的CPU利用率，以4%为单位。

  • 内存利用率：以仪表盘形式显示主机的内存利用率。仪表盘中指针指向的刻度默认显示最近30秒内当前主机的内存利用率，以4%为单位。

  • 网络吞吐量统计：以趋势图形式显示主机近5分钟的网络吞吐量。趋势图横轴为时间，纵轴为网络吞吐量，以Mbps为单位。


查看主机硬件监控信息

ARM架构的主机暂不支持“查看主机硬件监控信息”功能。

该功能用于查看主机硬件监控相关信息，主要包括主机的摘要信息、处理器信息、内存信息、温度信息、电源信息和风扇信息。

操作步骤

  1. 单击导航树[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“硬件监控”页签，进入主机摘要信息页面，可查看设备状态信息、系统信息和BIOS信息。单击<导出>按钮，可导出摘要信息。

  3. 选择左侧“处理器”页签，进入主机硬件监控的处理器信息页面，可查看主机的处理器的型号、状态、结构等信息。

  4. 选择左侧“内存”页签，进入主机硬件监控的内存信息页面，可查看主机的内存摘要信息和详细信息。

  5. 选择左侧“温度”页签，进入主机硬件监控的温度信息页面，可查看主机的温度图和传感器数据。

  6. 选择左侧“电源”页签，进入主机硬件监控的电源信息页面，可查看主机的电源名称、功率和状态信息。

  7. 选择左侧“风扇”页签，进入主机硬件监控的风扇信息页面，可查看主机的风扇的名称、位置、状态、转速信息。


查看主机性能监控信息

该功能用于查看指定主机的CPU利用率、内存利用率、磁盘I/O吞吐量统计、网络吞吐量统计、网络总包数、网络丢包数、磁盘请求（IOPS）、磁盘I/O延迟、磁盘利用率和分区占用率信息。

操作步骤

  1. 单击导航树[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“性能监控”页签，进入该主机性能监控页面。

参数说明

  • CPU利用率：横轴为时间，纵轴为主机CPU利用率。CPU利用率图表表示在图中时间范围内主机CPU利用率。

  • 内存利用率：横轴为时间，纵轴为主机内存利用率。内存利用率图表表示在图中时间范围内主机内存利用率。

  • I/O吞吐量统计：横轴为时间，纵轴为主机硬盘吞吐量，以KBps为单位。I/O吞吐量统计图表表示在图中时间范围内主机各个硬盘吞吐量情况。

  • 网络吞吐量统计：横轴为时间，纵轴为主机网卡的吞吐量，以Mbps为单位。网络吞吐量统计图表表示在图中时间范围内主机网卡的流量情况。可以选择不同网卡查看详情。

  • 网络总包数：横轴为时间，纵轴为网络数据包的数值。网络总包数统计图表表示在图中时间范围内主机网卡发送和接收网络数据包的总数。可以选择不同网卡查看详情。

  • 网络丢包数：横轴为时间，纵轴为网络丢包数的数值。网络丢包数统计图表表示在图中时间范围内主机网卡发送和接收网络数据包时丢包的数量统计。可以选择不同网卡查看网络丢包情况。

  • 磁盘请求：横轴为时间，纵轴为主机磁盘每秒读写次数。磁盘请求图表表示在图中时间范围内主机选中磁盘读写情况。

  • 磁盘I/O延迟：横轴为时间，纵轴为主机磁盘的I/O延迟，以毫秒为单位。磁盘I/O延迟图表示在图中时间范围内主机选中磁盘I/O延迟情况。

  • 磁盘利用率：横轴为时间，纵轴为主机磁盘利用率。磁盘利用率图表表示在图中时间范围内主机磁盘使用情况。

  • 分区占用率：显示指定主机的各个分区信息。

  • 系统分区：分区的名称。

  • 分区类型：分区的磁盘格式。

  • 分区挂载：挂载分区的目录。

  • 容量：该分区的总容量。单位为GB。

  • 已使用容量：该分区当前已使用的容量。单位为GB。

  • 占用率：该分区当前已使用容量与总容量的百分比。


查看主机上的虚拟机信息

该功能用于查看指定主机上的虚拟机信息。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“虚拟机”页签，进入该主机的虚拟机信息列表页面。

  3. 单击<界面定制>按钮，可以调整显示列表的内容和顺序。

参数说明

  • 显示名称：虚拟机的显示名称。

  • 描述：虚拟机的描述信息。

  • 状态：虚拟机运行状态，包括运行、暂停、关闭、未知、HA异常。

  • CPU利用率：虚拟机的实时CPU利用率。

  • 内存利用率：虚拟机的实时内存利用率。

  • CPU：虚拟机当前的CPU总核数（即CPU个数与每个CPU核数的乘积）。

  • 内存：虚拟机当前的内存容量。

  • 操作系统：虚拟机上运行的操作系统，目前支持Windows、Linux和银河麒麟类型的操作系统。其中ARM架构主机仅支持银河麒麟类型的操作系统，X86架构主机支持Windows和Linux操作系统。

  • 名称：虚拟机的名称。

  • IPv4/IPv6属性：虚拟机系统网卡对应的IPv4/IPv6属性。单击IP地址对应的超链接，可以查看IPv4/IPv6属性详细信息。对于IPv4属性，若虚拟机未安装CAStools，则无法采集子网掩码。

  • CAStools版本：CAStools版本信息。只有安装了CAStools的虚拟机才会显示CAStools版本。

  • CAStools状态：CAStools的运行状态，包括运行中、未运行。若虚拟机安装了CAStools且在虚拟机上已运行，则会显示“运行中”，否则会显示“未运行”。当虚拟机关机时显示“--”。

  • 连续运行时长：虚拟机已经连续运行的时间。

  • 创建时间：创建虚拟机的时间。

  • 最后关机时间：虚拟机的最后关机时间。

  • 时间同步：显示虚拟机是否配置时间同步。

  • 磁盘容量：显示虚拟机的磁盘容量大小。

  • 可用容量：显示虚拟机磁盘的可用容量。

  • 已用容量：显示虚拟机磁盘的已用容量。

  • 防病毒配置：虚拟机是否启用防病毒，包括启用、不启用。ARM架构主机暂不支持防病毒配置。


查看主机的操作日志

该功能用于查看所有操作员对指定主机所做的操作信息。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 选择“任务”页签，进入该主机的任务列表页面。

参数说明

  • 登录名：操作员登录管理平台所使用的登录名。

  • 完成时间：操作员完成操作的时间。

  • 登录地址：操作员登录管理平台所使用计算机的IP地址。

  • 操作分类：所执行操作的分类。

  • 操作对象：操作所执行的对象。

  • 操作描述：所执行操作的详细描述。

  • 执行结果：操作的执行结果。

  • 成功：表示操作执行成功。

  • 部分成功：表示操作执行部分成功。

  • 失败：表示操作执行失败。

  • 失败原因：操作失败的详细原因。

  • 风险级别：操作执行对应的风险级别，包括高、中、低。

  • 事件类型：操作员所操作事件的类型。


集群

集群是物理主机和虚拟机组成的计算资源集合，用来提供虚拟化环境下的高可靠性和高可用性。通过集群，操作员可以像管理单个实体一样轻松地管理多个主机和虚拟机，从而降低管理的复杂度。

主要功能

ARM架构主机暂不支持配置网络USB资源池。

  • 增加集群

  • 设置集群的高可靠性

  • 设置集群动态资源调度

  • 应用HA

  • 电源智能管理

  • 路由管理

  • 虚拟机/主机组

  • 虚拟机/主机规则

  • 网络USB资源池

  • 集群虚拟交换机

  • 集群存储

  • 重命名集群

  • 删除集群

  • 查看集群概要信息

  • 查看集群性能监控

  • 查看集群中的主机

  • 查看集群中的虚拟机

  • 查看集群的操作日志

注意事项

当增加或删除集群中主机的操作未完成时，对该集群的其他操作都将处于等待状态，直至增加或者删除主机操作完成。


增加集群

该功能用于为主机池增加集群。增加集群时，可设置是否开启集群HA功能和动态资源调度功能。

  • HA功能：开启集群HA功能后，管理平台会持续监测集群内所有主机和虚拟机的运行状况。若发现某台主机故障，管理平台将立即响应并在集群内其它可用的主机上重启所有受影响的虚拟机；若发现虚拟机故障，则会重启虚拟机。有关高可靠性的详细介绍，请参见 设置集群的高可靠性 。

  • 动态资源调度：动态资源调度功能将主机资源聚合到集群中，持续不断地监控集群内计算资源和存储资源的利用率，并根据数据中心的实际需要，为虚拟机智能地分配所需的资源。动态资源调度包括计算资源DRS和存储资源DRS。有关动态资源调度的详细介绍，请参见 设置集群动态资源调度 。

操作步骤

  1. 单击导航树中[云资源/<主机池>]菜单项，进入主机池概要信息页面。

  2. 单击<增加集群>按钮，弹出增加集群对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  4. 参数设置完成后，单击<完成>按钮。

参数说明

基本信息设置：

  • 启用HA：是否开启集群的HA功能，默认为是。开启HA功能后，管理平台会持续对集群内所有主机与虚拟机的运行状况进行监测。若发现某台主机发生故障，管理平台将立即响应并在集群内其它可用的主机上重启所有受影响的虚拟机。若发现虚拟机故障，则会重启虚拟机。

HA策略设置：

  • 启用业务网HA：是否开启业务网HA功能，默认为否。当虚拟机对应的业务网出现故障或者连接不通时，虚拟机可以迁移到其他主机上，恢复虚拟机业务。对于未绑定物理网卡、使用管理网或使用VXLAN转发模式的虚拟交换机将不支持HA故障检测。

  • 开启HA接入控制：是否开启HA接入控制，默认为否。若开启HA接入控制，则需要配置生效最小节点数或HA资源预留。

  • 生效最小节点数：用于设置集群中高可靠性正常运行所需的最小主机数。如果集群内正常运行的主机数量小于该参数时，虚拟机将无法进行HA故障迁移。生效最小节点数默认为1。配置此参数时，请确保集群内所有主机的CPU个数和内存大小保持一致，否则有可能会因为资源容量计算不准确而导致虚拟机无法进行故障迁移。

  • HA资源预留：为集群的HA保留一定的CPU和内存资源。当集群剩余资源所占比例小于预留值时，则不能继续启动集群内虚拟机，将虚拟机还原到运行/暂停状态，或将运行状态虚拟机迁入集群。

  • 触发动作：集群开启HA后，共享存储故障时，系统对受影响的虚拟机进行故障迁移或冻结，默认为故障迁移。当系统参数设置页面中的“共享存储故障隔离”参数设置为“不重启主机”且HA状态由关闭到开启时，此参数才允许修改。

  • 故障迁移：当共享存储故障时，全部数据存放在共享存储的虚拟机将被迁移到集群中的其他主机上。

  • 虚拟机冻结：当共享存储故障时，部分或全部数据存放在共享存储的虚拟机将被冻结，并显示为暂停。待共享存储恢复正常后，被冻结的虚拟机将自动恢复为运行状态。

计算DRS设置：

  • 开启计算资源DRS：是否开启计算资源DRS，默认为否。开启计算资源DRS功能后，系统可以自动管理虚拟机到主机的分配，为平衡负载和执行资源分配策略而自动进行虚拟机的在线迁移。

  • 持续时间：允许主机的CPU以及内存利用率持续超过监控策略中阈值的最长时间，默认为5分钟。例如，持续时间设置为5分钟，当主机的CPU或者内存利用率持续5分钟超过阈值时，动态资源调度功能将会启动。

  • 时间间隔：检查集群中主机状态的时间间隔，默认为10分钟。

  • 监控策略：用于计算资源DRS的监控策略，可配置CPU利用率、内存利用率和网络流量作为预置条件。

存储DRS设置：

  • 开启存储资源DRS：是否开启存储资源DRS，默认为否。开启存储资源DRS功能后，系统可以自动管理虚拟机到存储的分配，为平衡负载和执行资源分配策略而自动进行虚拟机的存储迁移。

  • 持续时间：允许主机的存储利用率、磁盘I/O或磁盘请求持续超过监控策略中阈值的最长时间，默认为5分钟。例如，持续时间设置为5分钟，当主机的存储利用率、磁盘I/O或磁盘请求持续5分钟超过阈值时，动态资源调度功能将会启动。

  • 时间间隔：检查集群中主机状态的时间间隔，默认为10分钟。

  • 监控策略：用于存储资源DRS的监控策略，可配置磁盘I/O、存储容量利用率和磁盘请求作为预置条件。


设置集群的高可靠性

集群的高可靠性（High Availability，简称HA）依赖于共享存储和动态迁移技术，为集群中所有虚拟机上运行的应用程序提供简单易用、经济高效的高可用性，最大程度减少因硬件故障造成的服务器宕机和服务中断时间。集群的高可靠性适用于业务运行连续性要求较高的场合。

高可靠性原理概述

管理平台将一组服务器主机合并为一个具有共享资源池的集群。开启集群HA功能之后，管理平台会持续监测集群内所有的服务器主机与虚拟机运行状况。

  • 当主机故障时，管理平台自动将故障主机上的虚拟机迁移到其他可用主机上。

  • 当虚拟机故障时，管理平台尝试将故障虚拟机在其原主机上重启。若故障虚拟机重启成功，则虚拟机继续在原主机上运行；若故障虚拟机重启失败，则虚拟机将自动迁移到空闲主机上重启。

  • 当主机与共享存储间网络故障时，管理平台自动将主机上的虚拟机迁移到其他可用主机上。

高可靠性的技术特点

  • 自动监测主机和虚拟机：管理平台会自动监测主机和虚拟机的运行状态。若管理平台发现主机或虚拟机故障，则会在其他主机上重启所有受影响的虚拟机，这个过程无需任何人为干预。

  • 资源预留：管理平台会保证资源池中具有足够的资源提供给虚拟机。当主机宕机后，预留资源可以保证虚拟机能够顺利地重启。

  • 虚拟机自动重新启动：通过在其他主机上重启虚拟机，可以保护任何应用程序不会因为硬件失效而中断服务。

  • 智能选择主机：当同时开启集群高可靠性与动态资源调度功能时，管理平台可以根据资源的使用情况，为失效主机上的虚拟机选择能获得最佳运行效果的主机。

注意事项

  • 在启用HA功能的集群中，每台主机上虚拟交换机的配置（即虚拟交换机的个数、名称、转发模式等）必须一致。

  • 在启用HA功能的集群中，为确保虚拟机在集群中各主机间顺利迁移，所有虚拟机的镜像文件都必须保存在共享存储中。若虚拟机必须使用本地存储，则不建议启用HA或者动态资源调整功能。

  • 在启用HA功能的集群中，各主机的CPU厂商必须一致。例如，CPU厂商均为Intel或AMD的CPU。另外，采用同一厂商、同一型号CPU的主机组成的集群，可以获得最好的迁移兼容能力。

  • 在关闭集群HA功能前，请确保集群中没有处于关闭或者重启等异常状态的主机，否则可能会导致集群中的虚拟机重名。如果出现虚拟机重名的问题，可以通过重新开启集群HA功能解决。

  • 在启用或者禁用集群HA功能的过程中，请勿对集群中的虚拟机执行启用、部署、迁移等操作，也不要对集群中的主机执行重启、关机等操作，以免造成不可预知的错误。

  • 在启用HA功能的集群中，如果重新安装主机上的CVK组件，需要先从集群中删除该主机。待CVK组件重新安装完成，再将其加入集群。这样可以避免集群中出现主机状态不一致的情况。

  • 在集群启用HA功能之前，需要确保集群下的所有主机已预留出足够的系统资源（内存等），当集群内有主机发生故障时，故障主机上的虚拟机能够迁移到同集群正常运行的主机中。

  • 如果虚拟机开启了Intel RDT防吵闹功能，但集群内故障迁移目的主机不支持该功能，故障迁移时会将虚拟机的Intel RDT防吵闹功能关闭。

操作步骤

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<高可靠性>按钮，弹出修改集群高可靠性对话框。

  3. 根据需要启用集群的HA。如果启用集群的HA，则需要为集群中的虚拟机选择缺省的启动优先级。

  4. 根据需要开启业务网HA和HA接入控制。如果开启HA接入控制，则需要输入生效最小节点数、选择故障切换主机或设置HA资源预留百分比。

  5. 单击<确定>按钮。

参数说明

  • 启动优先级：用于设置集群中虚拟机的缺省启动优先级，包括低级、中级和高级，默认为中级。虚拟机的启动优先级在增加虚拟机或修改虚拟机的过程中设置。主机故障后，虚拟机启动的相对优先顺序。这些虚拟机在新主机上按顺序重新启动，首先启动优先级最高的虚拟机，然后是中级优先级的虚拟机，最后是低级优先级的虚拟机，直到重新启动所有虚拟机或者没有更多的可用集群资源为止。

  • 业务网HA:当虚拟机对应的业务网出现故障或者连接不通时，虚拟机可以迁移到其他主机上，恢复虚拟机业务。对于未绑定物理网卡、使用管理网或使用VXLAN转发模式的虚拟交换机将不支持HA故障检测。

  • 开启HA接入控制：是否启用HA接入控制。若开启HA接入控制，则需要配置生效最小节点数、故障切换主机或HA资源预留。

  • 生效最小节点数：用于设置集群中高可靠性正常运行所需的最小主机数。如果集群内正常运行的主机数量小于该参数时，HA将会失效。生效最小节点数默认为1。配置此参数时，请确保集群内所有主机的CPU个数和内存大小保持一致，否则有可能会因为资源容量计算不准确而导致虚拟机无法进行故障迁移。

  • 故障切换主机：当集群HA内出现故障虚拟机需要自动迁移时，优先从指定的主机组内选择迁移目的主机，指定的主机仅用于故障迁移，不能作为增加、迁移虚拟机的目的主机。故障切换主机必须挂载与业务主机相同的共享存储，并且主机中不能存在运行状态的虚拟机。

  • HA资源预留：为集群的HA保留一定的CPU和内存资源。当集群剩余资源所占比例小于预留值时，则不能继续启动集群内虚拟机，将虚拟机还原到运行/暂停状态，或将运行状态虚拟机迁入集群。

  • 触发动作：集群开启HA后，共享存储故障时，系统对受影响的虚拟机进行故障迁移或冻结，默认为故障迁移。当系统参数设置页面中的“共享存储故障隔离”参数设置为“不重启主机”且HA状态由关闭到开启时，此参数才允许修改。

  • 故障迁移：当共享存储故障时，全部数据存放在共享存储的虚拟机将被迁移到集群中的其他主机上。

  • 虚拟机冻结：当共享存储故障时，部分或全部数据存放在共享存储的虚拟机将被冻结，并显示为暂停。待共享存储恢复正常后，被冻结的虚拟机将自动恢复为运行状态。


设置集群动态资源调度

开启集群动态资源调度功能后，系统可以持续不断地监控集群内计算资源池和存储资源池的利用率，并根据数据中心的实际需要，为虚拟机智能地分配所需的资源。

当操作员将虚拟机整合到资源较少的物理主机上，虚拟机的资源需求往往会限制主机上虚拟机的数量，全部资源需求很有可能超过主机的可用资源。管理平台提供的动态资源调度特性则提供了一个自动化机制，通过持续地平衡容量，将虚拟机迁移到有更多可用资源的主机上，确保每个虚拟机在任何节点都能及时地调用相应的资源。即便是大量运行SQL Server的虚拟机，只要开启了动态资源调度功能，就不必再对CPU和内存利用率进行一一监测。全自动化的资源分配和负载平衡功能，也可以显著地降低数据中心的成本与运营费用。

动态资源调度功能包括计算资源DRS和存储资源DRS。

  • 计算资源DRS功能通过心跳机制，定时监测集群内主机的CPU和内存利用率，并根据用户自定义的规则来判断是否需要为该主机在集群内寻找有更多可用资源的主机，以将该主机上的虚拟机迁移到另外一台具有更多合适资源的主机上。如果该主机资源利用率仍超过规则设定值，则将该主机上其它的虚拟机逐个迁移出去，直到主机的资源利用率低于阈值为止。

  • 存储资源DRS功能主要是为了平衡集群内存储的压力，通过监测主机共享存储池的磁盘I/O吞吐量、IOPS和磁盘利用率中的一项，当该项指标超出临界值时，就会将存储池中部分虚拟机的镜像文件迁移到主机中的另一个有更多可用资源的共享存储池上，以达到存储的负载均衡。

动态资源调度功能适用于可能存在持续性突发业务负载的场合。通过动态分配和平衡计算资源、存储资源，动态资源调度特性能够：

  • 整合服务器，降低IT成本，增强灵活性。

  • 减少停机时间，保持业务的持续性和稳定性。

  • 减少需要运行服务器的数量，提高能源的利用率。

注意事项

磁盘为RBD块的虚拟机不受存储资源DRS的调度。

操作步骤

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<动态资源调度>按钮，弹出动态资源调度对话框。

  3. 根据需要开启计算资源DRS和存储资源DRS。如果开启计算资源DRS或者开启存储资源DRS，则需要输入对应项的持续时间、时间间隔，并选择监控策略。

  4. 单击<确定>按钮。

参数说明

  • 开启计算资源DRS：是否开启计算资源DRS，默认为否。当开启计算资源DRS功能时，系统可以自动管理虚拟机到主机的分配，为平衡负载和执行资源分配策略而自动进行虚拟机的在线迁移。开启计算资源DRS后，需配置如下参数：

  • 持续时间：允许主机的CPU利用率、内存利用率或网络流量持续达到或者超过监控策略中阈值的最长时间，默认为5分钟。例如，若持续时间设置为5分钟，当主机的CPU利用率、内存利用率或网络流量连续达到或者超过监控策略中阈值的时间超过5分钟时，动态资源调度功能将会启动。

  • 时间间隔：检查主机计算资源利用率的时间间隔，默认为10分钟。

  • 监控策略：用于计算资源DRS的监控策略，可配置CPU利用率、内存利用率和网络流量作为预置条件。

  • 功能生效时间段：配置集群动态资源调度生效时间范围。开始时间小于截止时间，表示功能生效时间为当天的“开始时间”到“截止时间”；开始时间等于截止时间，表示功能全天生效；开始时间大于截止时间，表示功能生效时间从开始“开始时间”到次日的“截止时间”。

  • 开始时间：功能生效开始时间。

  • 截止时间：功能生效截止时间。

  • 开启存储资源DRS：是否开启存储资源DRS，默认为否。当开启存储资源DRS功能时，系统可以自动管理虚拟机到存储的分配，为平衡负载和执行资源分配策略而自动进行虚拟机的存储迁移。主机必须挂载集群中的所有共享存储，才能支持存储资源DRS。否则，当该主机连接的共享存储达到监控策略设置的阈值时，存储资源DRS将不会生效。开启存储资源DRS后，需配置如下参数：

  • 持续时间：允许主机的磁盘I/O、存储容量利用率或磁盘请求持续达到或者超过监控策略中阈值的最长时间，默认为5分钟。例如，若持续时间设置为5分钟，则当主机的磁盘I/O、存储容量利用率或磁盘请求连续达到或者超过监控策略中阈值的时间超过5分钟时，动态资源调度功能将会启动。

  • 时间间隔：检查主机存储资源利用率的时间间隔，默认为10分钟。

  • 监控策略：用于存储资源DRS的监控策略，可配置磁盘I/O、存储容量利用率和磁盘请求作为预置条件。


应用HA

应用HA是指运行于虚拟机操作系统内的应用进程的高可靠性，当应用进程由于自身原因导致无法对外正常提供服务时，可以依赖应用HA功能，以最短的时间自动恢复业务。

应用HA功能依赖于集群的高可靠性。开启集群HA功能之后，系统会持续监测集群内所有主机和虚拟机运行状况。通过安装于虚拟机操作系统的CASTools工具来获取应用进程的状态，以判定业务的存活状态。应用HA可实现如下功能：

  • 实时显示应用进程的可用性状态。

  • 当应用进程不可用时，触发告警通知用户，并执行用户自定义的修复策略，包括重启服务和重启虚拟机，最小化业务宕机时间。

主要功能

  • 应用监控策略管理


应用监控策略

应用监控策略用于设置应用进程故障后，系统对故障进程和进程所在虚拟机采取的处理方式。

注意事项

应用监控策略生效需同时满足如下条件：

  • 开启集群的高可靠性。

  • 集群中的虚拟机需安装CASTools工具，并开启高可靠性。

  • 将应用监控策略应用于集群的虚拟机上，即对虚拟机配置应用监控任务。

查看应用监控策略信息

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控列表页面。

  3. 单击<应用监控配置>按钮，弹出监控策略配置对话框，显示系统中所有的应用监控策略信息。

  4. 在应用监控策略列表中选择待查看的策略，单击 [image] 图标，弹出查看应用监控策略对话框。

增加应用监控策略

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控列表页面。

  3. 单击<应用监控配置>按钮，进入监控策略配置对话框。

  4. 单击<增加>按钮，弹出增加应用监控策略对话框。

  5. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  6. 参数设置完成后，单击<完成>按钮。

修改应用监控策略

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控列表页面。

  3. 选择待修改的策略，单击 [image] 图标，弹出修改应用监控策略对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 单击<确定>按钮。

删除应用监控策略

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控列表页面。

  3. 选择待删除的策略，单击 [image] 图标，弹出删除应用监控策略确认对话框。

  4. 单击<确定>按钮。

参数说明

  • 适用操作系统：应用监控策略所适用的操作系统。

  • 服务名称：需监控的服务名称。

  • 安装路径：需监控服务的安装路径。

  • HA策略：连续三次检测到服务故障后所采取的虚拟机处理方式，包括重启虚拟机和不重启虚拟机。

  • 用户自定义命令行：设置用户是否需要自定义配置启动命令行和状态监控命令行，默认是不设置。对于用户自定义的命令行，若服务名称是由多个单词组成，则对服务名称需加双引号。例如Windows下启用名称为iNode DAM Agent的服务时，则自定义启动命令行应为：sc start "iNode DAM Agent"；自定义状态监控命令行应为：sc query "iNode DAM Agent"。

  • 启动命令行：服务故障后重启服务的命令行。该命令可以启动一个应用程序或者服务，也可以是启动某个TCP的连接，也可以是一个多个命令组成的命令行脚本。若监控的应用或者服务异常时，可以使用该命令成功恢复应用或者服务。当命令执行成功时，其返回值必须为0。当用户自定义命令行选择为“是”时，需要配置此参数。

  • 状态监控命令行：监控服务状态的命令行。该命令可以查询一个应用程序或者服务的运行状态，也可以是查询一个TCP的连接状态，也可以是一个由多个命令组成的命令行脚本。若查询的应用或者服务正常运行时，则输出应用或者服务为“running”或者“active”的状态，其返回值为0。若查询的应用或者服务异常时，返回其他值。当用户自定义命令行选择为“是”时，需要配置此参数。


应用监控任务

应用监控任务管理用于对集群中的虚拟机配置应用监控策略。

注意事项

  • 单个虚拟机最大可以支持同时启用16个应用HA监控任务，单个主机最大可以支持同时启用256个应用HA监控任务，单个集群最大可以支持同时启用1024个应用HA监控任务。

  • 虚拟机需安装CASTools才能监控虚拟机中的应用状态。

  • 若关闭集群的高可靠性，则集群下所有的应用HA监控任务都将暂停；若关闭虚拟机的高可靠性或虚拟机被移入回收站，则该虚拟机的应用HA监控任务都将暂停。

查看应用监控任务列表

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控列表页面。

增加应用监控任务

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控任务列表页面。

  3. 单击<增加应用监控>按钮，弹出增加应用监控对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 参数设置完成后，单击<完成>按钮。

修改应用监控任务

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控任务列表页面。

  3. 选择待修改的任务，单击 [image] 图标，弹出修改应用监控对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 修改完成后，单击<确定>按钮。

删除应用监控任务

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控任务列表页面。

  3. 选择待删除的任务，单击 [image] 图标，弹出操作提示确认框。

  4. 单击<确定>按钮。

启动应用监控任务

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控任务列表页面。

  3. 在应用监控任务列表中选择待启动的任务，单击 [image] 图标，弹出操作提示确认框。

  4. 单击<确定>按钮。

暂停应用监控任务

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控任务列表页面。

  3. 在应用监控任务列表中选择待暂停的任务，单击 [image] 图标，弹出操作提示确认框。

  4. 单击<确定>按钮。

批量启动应用监控任务

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控任务列表页面。

  3. 在应用HA监控任务列表中，选择一个或多个应用HA监控任务，单击<批量操作>按钮，选择[启动应用监控]菜单项，弹出操作提示确认对话框。

  4. 单击<确定>按钮。

批量暂停应用监控任务

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控任务列表页面。

  3. 在应用HA监控任务列表中选择一个或多个应用HA监控任务，单击<批量操作>按钮，选择[暂停应用监控]菜单项，弹出操作提示确认对话框。

  4. 单击<确定>按钮。

批量删除应用监控任务

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“应用HA”页签，进入该集群的应用HA监控任务列表页面。

  3. 在应用HA监控任务列表中选择一个或多个应用HA监控任务，单击<批量操作>按钮，选择[删除应用监控]菜单项，弹出操作提示确认对话框。

  4. 单击<确定>按钮。

参数说明

  • 任务名称：应用HA监控的任务名称。

  • 服务名称：任务所监控的服务的名称。

  • 主机：虚拟机所属主机的名称。

  • 服务状态：任务所监控的服务的运行状态，包括未知、正常、故障和无法恢复。

  • 任务状态：任务的运行状态，包括运行和暂停。

  • 虚拟机：任务需要监控的虚拟机。

  • 监控策略：任务所采用的监控策略。

  • 立即生效：应用HA监控是否在创建完成后立即生效，默认为否。


电源智能管理

电源智能管理（Dynamic Power Management，DPM）是指系统持续不断的监控集群中物理主机的资源利用率。当集群的负载降低时，系统将资源利用率较低的主机上的虚拟机迁移到其他主机上，并关闭闲置主机的电源来降低数据中心的能耗；当集群的负载上升时，系统将自动唤醒先前关闭的闲置主机，通过动态资源调度均衡集群内主机上的负载。

  • 电源智能管理功能中，系统可监控的主机资源利用率包括CPU利用率和内存利用率。系统默认提供两个用于电源智能管理的监控策略，分别是主机回收监控策略和主机唤醒监控策略。策略中CPU利用率和内存利用率为“逻辑与”关系。用户可单独配置CPU利用率或内存利用率的监控策略，也可配置CPU利用率与内存利用率为“逻辑或”关系的监控策略。通过设置监控策略，实现集群中主机的智能回收和智能唤醒。有关监控策略的配置，请参见 监控策略 。

  • 主机智能回收：当集群中所有正常状态的主机的负载在一段时间内持续低于指定监控策略的阈值时，系统自动将集群中一台主机上的虚拟机全部迁移到集群中的其它主机上，并自动关闭该主机。当集群中正常运行的主机小于或等于两台时，不再触发主机回收。

  • 主机智能唤醒：当集群中所有正常状态的主机的负载在一段时间内持续高于指定监控策略的阈值，并且存在处于关闭状态的主机时，系统将自动启动处于关闭状态的主机，再根据动态资源调度功能设定策略将高负载主机上的部分虚拟机迁移到该主机上。

注意事项

  • 如果开启电源智能管理功能，集群中的所有主机和虚拟机都必须使用相同的共享存储，并允许虚拟机自动迁移。

  • 为了达到最佳节能效果，设置主机回收策略和主机唤醒策略的阈值时，建议保留一定的差值。例如：主机回收策略中设置CPU及内存利用率小于10%，主机唤醒策略中设置CPU及内存利用率大于80%。

  • 电源智能管理功能中，主机回收策略和主机唤醒策略仅支持CPU利用率和内存利用率作为预置条件的监控策略。

操作步骤

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[电源智能管理]菜单项，弹出电源智能管理对话框。

  3. 根据需要开启电源智能管理。如果开启电源智能管理，则需要输入持续时间、时间间隔，选择主机回收策略和主机唤醒策略。

  4. 单击<确定>按钮。

参数说明

  • 开启电源智能管理：是否开启电源智能管理功能，默认为否。开启电源智能管理功能可实现集群中主机的智能回收和智能唤醒。

  • 持续时间：允许主机的CPU及内存利用率超过监控策略中设置阈值的最长持续时间，默认为2分钟。

  • 检查时间间隔：检查主机CPU以及内存利用率的时间间隔，默认为10分钟。

  • 主机回收策略：当主机的负载在设置持续时间内连续小于监控策略设置的阈值时，将该主机下的虚拟机全部迁移到同一集群下内存利用率最小的主机上，并自动关闭该主机。

  • 主机唤醒策略：当集群中存在处于关闭状态的主机，且其它主机的负载在设置的持续时间内连续超过监控策略设置的阈值时，系统将自动启动处于关闭状态的主机，根据动态资源调度功能设定策略将高负载主机上的部分虚拟机迁移到该主机上。

  • 功能生效时间段：配置电源智能管理功能的生效时间范围。开始时间小于截止时间，表示功能生效时间为当天的“开始时间”到“截止时间”；开始时间等于截止时间，表示功能全天生效；开始时间大于截止时间，表示功能生效时间从开始“开始时间”到次日的“截止时间”。

  • 开始时间：功能生效开始时间。

  • 截止时间：功能生效截止时间。


路由管理

路由管理用于批量为主机配置静态路由，主要功能包括增加静态路由、修改静态路由、增加使用主机和删除静态路由。

注意事项

  • 网关必须和某个虚拟交换机属于同一网段，如果网关无效，则无法配置路由信息。

  • 路由信息将通过网关所在的虚拟交换机生效。

增加静态路由

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[路由管理]菜单项，进入路由管理页面。

  3. 单击<增加路由>按钮，弹出增加路由对话框。

  4. 在基本信息页签设置参数，单击<下一步>，进入选择主机页签。关于参数的详细介绍，请参见 参数说明 。

  5. 在选择主机页签中，单击<选择主机>按钮，弹出选择主机对话框，勾选所需的主机，单击<确定>按钮，返回增加路由对话框。

  6. 单击<完成>按钮完成操作。

编辑静态路由

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[路由管理]菜单项，进入路由管理页面。

  3. 选择待编辑的静态路由信息，单击 [image] 图标，弹出编辑路由对话框。

  4. 在基本信息页签编辑参数，单击<下一步>，进入选择主机页签。关于参数的详细介绍，请参见 参数说明 。

  5. 在选择主机页签中，单击<选择主机>按钮，弹出选择主机对话框，勾选所需的主机，单击<确定>按钮，返回编辑路由对话框；或者单击 [image] 图标，删除已选择的主机。

  6. 单击<完成>按钮完成操作。

增加使用的主机

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[路由管理]菜单项，进入路由管理页面。

  3. 选择需要增加使用主机的路由信息，单击<增加使用的主机>按钮，弹出选择主机对话框。

  4. 在选择主机页签中，单击<选择主机>按钮，弹出选择主机对话框，勾选所需的主机。

  5. 单击<确定>按钮完成操作。

删除静态路由

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[路由管理]菜单项，进入路由管理页面。

  3. 选择待删除的静态路由信息，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮完成操作。

参数说明

  • 目的IP网段：输入目的IP所属的网段。

  • 目的子网掩码/前缀：输入目的IP的子网掩码/前缀。

  • 网关：输入主机的网关IP。


虚拟机/主机组

虚拟机/主机组用于管理集群中的组信息。操作员可以通过虚拟机/主机组，创建虚拟机与主机间的关联性规则，从而建立关联性或反关联性关系。

注意事项

已配置虚拟机/主机规则的虚拟机/主机组，不允许被删除。

增加虚拟机/主机组

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[虚拟机/主机组]菜单项，进入虚拟机/主机组列表页面。

  3. 单击<增加>按钮，弹出增加虚拟机/主机组对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 参数设置完成后，单击<完成>按钮。

修改虚拟机/主机组

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[虚拟机/主机组]菜单项，进入虚拟机/主机组列表页面。

  3. 选择待修改的虚拟机/主机组，单击 [image] 图标，弹出修改虚拟机/主机组对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 修改完成后，单击<确定>按钮。

删除虚拟机/主机组

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[虚拟机/主机组]菜单项，进入虚拟机/主机组列表页面。

  3. 选择待删除的虚拟机/主机组，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

参数说明

增加虚拟机/主机组：

  • 类型：分组的类型，包括虚拟机组和主机组。

  • 虚拟机列表：加入虚拟机组的虚拟机。

  • 主机列表：加入主机组的主机。


虚拟机/主机规则

虚拟机/主机规则管理用于设置虚拟机之间、虚拟机组与主机组之间的关联与反关联关系。

虚拟机之间的关联关系为聚集，即规则中的虚拟机需聚集在同一台主机上运行；虚拟机间的反关联关系为分开，即规则中的虚拟机需分布在不同主机上运行。管理平台支持设置虚拟机之间的关联动作，主要包括无、启动、关闭、启动/关闭。

  • 无：虚拟机之间没有关联动作，只根据关联性规则聚集在同一台主机或分布在不同主机上。

  • 启动：规则中的虚拟机同时启动。

  • 关闭：规则中的虚拟机同时关闭。

  • 启动/关闭：规则中的虚拟机同时启动或同时关闭。

虚拟机组与主机组之间的关联关系分为必须在组中主机上运行和应在组中的主机上运行。

  • 必须在组中主机上运行：虚拟机组中的虚拟机必须在主机组中的主机上运行。

  • 应在组中的主机上运行：虚拟机组中的虚拟机应当（但非必须）在主机组中的主机上运行。

虚拟机组与主机组之间的反关联关系分为不得在组中的主机上运行和不应在组中的主机上运行。

  • 不得在组中的主机上运行：虚拟机组中的虚拟机不能在主机组中的主机上运行。

  • 不应在组中的主机上运行：虚拟机组中的虚拟机不应当（但可以）在主机组中的主机上运行。

虚拟机/主机规则的应用场景如下：

  • 关联关系：适用于频繁交互数据的业务系统中。通过配置关联关系，保证虚拟机在同一主机上运行。

  • 反关联关系：适用于对主机资源（如CPU和内存资源）消耗较大的业务场景下。通过配置反关联关系，使不同业务始终分布在不同主机上，从而保证集群的负载均衡。

注意事项

  • 虚拟机/主机规则可能导致集群的故障切换功能和DRS的算法更加复杂，请谨慎使用。

  • 当规则类型为分开虚拟机时，规则中可设置的虚拟机数遵循如下规律：

  • 若集群未启用HA，当集群下的主机总数大于二时，规则中可设置的虚拟机数最大为集群下的主机总数。

  • 若集群未启用HA，当集群下的主机总数小于等于二时，规则中可设置的虚拟机数最大为二。

  • 若集群启用HA、开启HA接入控制并设置故障切换主机，当集群下主机总数减去故障迁移主机数大于二时，规则中可设置的虚拟机数最大为集群下主机总数减去故障迁移主机数。

  • 若集群启用HA、开启HA接入控制并设置故障切换主机，当集群下的主机总数减去故障迁移主机数小于等于二时，规则中可设置的虚拟机数最大为二。

  • 若集群未启用HA，或启用HA后未设置故障切换主机，当集群下的主机总数大于二时，规则中可设置的虚拟机数最大为集群下的主机总数。

  • 若集群未启用HA，或启用HA后未设置故障切换主机，当集群下的主机总数小于等于二时，规则中可设置的虚拟机数最大为二。

  • 当规则类型为聚集虚拟机或分开虚拟机时，受规则约束的虚拟机的所有磁盘需使用共享存储。

  • 一个虚拟机可以同时受两类互不冲突的虚拟机规则约束，但不能既受虚拟机规则约束，又受虚拟机到主机规则约束。例如：当虚拟机A与虚拟机B必须聚集在同一台主机上，虚拟机A与虚拟机C必须分布在不同主机上时，虚拟机A就不能在虚拟机到主机类型规则的虚拟机组中。

增加虚拟机/主机规则

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[虚拟机规则]菜单项，进入虚拟机规则列表页面。

  3. 单击<增加>按钮，弹出增加虚拟机规则对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 参数设置完成后，单击<完成>按钮。

修改虚拟机/主机规则

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[虚拟机规则]菜单项，进入虚拟机规则列表页面。

  3. 选择待修改的规则，单击 [image] 图标，弹出修改虚拟机规则对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 修改完成后，单击<确定>按钮。

删除虚拟机/主机规则

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[虚拟机规则]菜单项，进入虚拟机规则列表页面。

  3. 选择待删除的规则，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

参数说明

  • 类型：虚拟机/主机规则的类型，包括聚集虚拟机、分开虚拟机和虚拟机到主机。聚集虚拟机是指受规则约束的虚拟机需聚集在同一主机上；分开虚拟机是指受规则约束的虚拟机需分布在不同主机上。虚拟机到主机是虚拟机组中的虚拟机在主机组中主机上的分布规则。分布规则可通过关联关系进行设置。

当规则类型为聚集虚拟机或分开虚拟机时，需配置如下参数：

  • 关联动作：虚拟机之间的关联动作，包括无、启动、关闭和启动/关闭。默认为无，表示虚拟机之间无关联动作，只聚集在同一主机上或分布在不同主机上。启动、关闭、启动/关闭分别表示应用规则的虚拟机将同时启动、同时关闭、同时启动或关闭。

  • 虚拟机列表：受聚集或分开虚拟机规则约束的虚拟机。

当规则类型为虚拟机到主机时，需配置如下参数：

  • 虚拟机组：与主机组关联的虚拟机组。

  • 关联关系：虚拟机组中的虚拟机在主机组中的主机上的分布规则，包括必须在组中的主机上运行，应在组中的主机上运行，不得在组中的主机上运行和不应在组中的主机上运行。

  • 主机组：与虚拟机组关联的主机组。


网络USB资源池

ARM架构的主机暂不支持“网络USB资源池管理”功能。

网络USB资源池用于管理集群中所有主机的网络USB设备。挂载网络USB设备的虚拟机迁移到集群中其他主机后，可继续使用其网络USB设备，从而实现了虚拟机跨集群中的物理主机使用USB设备的功能。

注意事项

  • 只有处于活动状态的网络USB设备，才可挂载到虚拟机。

  • 一个网络USB设备可挂载到多个虚拟机上。

  • 若网络USB设备已挂载到在线状态（运行或暂停）的虚拟机上，则该网络USB设备禁止挂载到其它在线状态的虚拟机上。

  • 已挂载到在线状态（运行或暂停）虚拟机的网络USB设备，不允许执行暂停网络USB服务操作。

  • 当主机上同时配置了IPv4和IPv6地址时，该主机可以选择以这两种地址中的一个加入集群。该主机的网络USB设备挂载到集群中的某一个虚拟机上时，则必须要求此虚拟机能够ping通该主机加入集群的IP地址，网络USB设备才能正常使用。

启动网络USB服务

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 单击<更多操作>按钮，选择[网络USB资源池]菜单项，网络USB资源池列表页面。

  3. 单击<刷新>按钮，更新集群中网络USB资源。

  4. 在网络USB设备列表中选择待启动的网络USB设备，单击 [image] 图标，弹出操作确认对话框。

  5. 单击<确定>按钮。

暂停网络USB服务

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 单击<更多操作>按钮，选择[网络USB资源池]菜单项，网络USB资源池列表页面。

  3. 单击<刷新>按钮，更新集群中网络USB资源。

  4. 在网络USB设备列表中选择待暂停的网络USB设备，单击 [image] 图标，弹出操作确认对话框。

  5. 单击<确定>按钮。

为虚拟机挂载网络USB设备

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 单击<更多操作>按钮，选择[网络USB资源池]菜单项，网络USB资源池列表页面。

  3. 单击<刷新>按钮，更新集群中网络USB资源。

  4. 在网络USB设备列表中选择网络USB设备，单击 [image] 图标，弹出虚拟机列表对话框。

  5. 选择USB控制器类型和待挂载网络USB设备的虚拟机，单击<确定>按钮。

卸载虚拟机的网络USB设备

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 单击<更多操作>按钮，选择[网络USB资源池]菜单项，网络USB资源池列表页面。

  3. 单击<刷新>按钮，更新集群中网络USB资源。

  4. 在网络USB设备列表中选择网络USB设备，单击 [image] 图标，弹出虚拟机列表对话框。

  5. 选择待卸载网络USB设备的虚拟机，单击<确定>按钮。


集群虚拟交换机

虚拟交换机是通过软件模拟的、具有实体交换机功能的网络平台，为虚拟机、主机和外部网络提供网络连接。虚拟交换机主要提供三种类型的端口：

  • 虚拟机端口：用于连接虚拟机的虚拟网卡，以实现虚拟机与其他虚拟机或外部网络的通信。

  • Local口：连接主机协议栈的端口。

  • 上行端口：连接主机的物理网卡。每个上行端口对应一个物理适配器。多对上行端口和物理适配器可做聚合，以达到链路冗余。

在系统中增加主机后，系统会在主机上自动创建一个默认的虚拟交换机“vswitch0”，用于管理网络。如果没有单独设置备份网络和迁移网络，那么虚拟机的备份数据和迁移数据默认都通过管理网络vswitch0传输。

注意事项

不允许删除正在被虚拟机使用的虚拟交换机。

增加虚拟交换机

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“虚拟交换机”页签，进入该集群的虚拟交换机列表页面。

  3. 单击<增加虚拟交换机>按钮，弹出增加虚拟交换机对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 参数设置完成后，单击<完成>按钮。

修改虚拟交换机

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“虚拟交换机”页签，进入该集群的虚拟交换机列表页面。

  3. 选择待修改的虚拟交换机，单击 [image] 图标，弹出修改虚拟交换机对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 修改完成后，单击<完成>按钮。

删除虚拟交换机

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“虚拟交换机”页签，进入该集群的虚拟交换机列表页面。

  3. 选择待删除的虚拟交换机，单击 [image] 图标，弹出提示对话框。

  4. 单击<确定>按钮。

查看虚拟交换机拓扑

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“虚拟交换机”页签，进入该集群的虚拟交换机列表页面。

  3. 选择待查看的虚拟交换机，单击 [image] 图标，可查看集群中虚拟交换机拓扑。

删除使用虚拟交换机的主机

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群的概要信息页面。

  2. 选择“虚拟交换机”页签，进入该集群的虚拟交换机列表页面。

  3. 在使用虚拟交换机的主机列表中选择待删除的主机，单击 [image] 图标，弹出提示对话框。

  4. 单击<确定>按钮。

参数说明

  • 操作：以图标的方式显示操作员可以对虚拟交换机执行的管理操作，单击图标后相应的操作会生效。

  • 表示修改虚拟交换机。

  • 表示删除虚拟交换机。

  • 表示查看虚拟交换机拓扑。

  • 网络类型：虚拟交换机的网络类型，默认值为业务网络。

  • 管理网络：此类型的虚拟交换机用于传输管理平台与各主机之间控制层数据。

  • 业务网络：此类型的虚拟交换机用于传输虚拟机业务数据。

  • 存储网络：此类型的虚拟交换机用于传输主机到IP SAN存储服务器或者主机到分布式存储之间的报文，且不允许虚拟机连接使用。

  • 备份网络：此类型的虚拟交换机用于传输虚拟机备份到远端服务器时的备份数据，且不允许虚拟机连接使用。一个主机上只允许存在一个此类型的虚拟交换机或此类型的子网。

  • 迁移网络：此类型的虚拟交换机用于传输虚拟机迁移时的内存和磁盘镜像数据，且不允许虚拟机连接使用。一个主机上只允许存在一个此类型的虚拟交换机或此类型的子网。

  • 其他网络：此类型的虚拟交换机用于传输上述未提及的其他类型的数据。

  • 转发模式：虚拟交换机的转发模式，包括VEB和VXLAN(SDN)，默认为VEB。

  • VEB：Virtual Ethernet Bridge，虚拟以太网桥。在该模式下，虚拟机与虚拟机之间的流量通过纯软件的方式进行转发。

  • VXLAN(SDN)：部署了SDN控制器和云计算管理平台的VXLAN解决方案对应的虚拟交换机转发模式。

  • VLAN ID：虚拟交换机连接主机协议栈端口的VLAN ID。

  • 启用DPDK：设置DPDK功能，开启后可以提升虚拟机的网络性能。

  • MTU：设置虚拟交换机允许通过最大数据包的大小，单位为Byte。默认vswitch0不允许修改MTU的值。

  • 启用组播：设置虚拟交换机的组播功能，开启后虚拟交换机可以实现组播流量的正常转发。默认vswitch0不允许启用组播。

  • 物理接口：虚拟交换机所使用的主机物理网卡的接口。一个物理接口只能被一个虚拟交换机使用。当主机的物理接口都被其他虚拟交换机使用时，物理接口选项不可填。若一个虚拟交换机没有使用物理接口，则连接该虚拟交换机的虚拟机只能彼此进行通信，而无法与外部网络进行通信。选择多个物理接口时，需要配置链路聚合模式和负载分担模式。

  • IPv4地址：虚拟交换机的IPv4地址。

  • 子网掩码：虚拟交换机IPv4地址对应的子网掩码。

  • 网关：配置主机的IPv4网关地址，一台主机只能配置一个IPv4网关。

  • IPv6地址：配置虚拟交换机的IPv6地址。

  • 子网前缀长度：配置对应IPv6地址的子网前缀长度。

  • IPv6网关：配置主机的IPv6网关地址，一台主机只能配置一个IPv6网关。

  • 链路聚合模式：虚拟交换机使用的物理网卡之间的链路聚合方式，包括静态链路聚合和动态链路聚合，默认为静态链路聚合。当此参数设置为动态时，物理交换机上需要开启LACP功能。当选择多个物理接口时，才允许设置此参数。

  • 负载分担模式：虚拟交换机使用的物理网卡之间的负载分担模式，包括高级负载分担、基本负载分担和主备负载分担，默认为主备负载分担。当选择多个物理接口时，才允许设置此参数。

  • 高级：根据转发报文的以太网类型、IP报文协议、源IP地址、目的IP地址、应用层源端口和目的端口进行负载分担。

  • 基本：根据转发报文的源MAC地址和VLAN Tag进行负载分担。

  • 主备：根据物理网卡主备进行负载分担。当主网卡出现故障，自动使用备网卡进行网络流量的处理。

  • 故障恢复切换：若启用故障恢复切换，当主网卡恢复正常，自动切换回主网卡；若不启用故障恢复切换，当主网卡恢复正常，依然使用备网卡处理，不会自动切换回主网卡。当负载分担模式为“主备”时，需要设置此选项。

  • 主链路选择方式：当负载分担模式为“主备”时，需要设置主链路的选择方式。

  • 速率优先：根据网卡的速率选择主网卡，速率高的作为主网卡。当网卡速率相同时，系统随机选择一个网卡作为主网卡。

  • 手动配置：通过指定网卡的分担优先级选择主网卡，优先级高的作为主网卡。需要设置网卡的分担优先级。

  • 分担优先级：从上往下进行优先级排序，最上面的优先级最高，即作为主网卡。


集群存储

集群中的共享存储是指共享文件系统类型或RBD网络存储的存储池，可以被集群内的主机同时挂载。集群HA功能的HA、DRS、DPM等涉及到虚拟机在线迁移的功能都依赖于共享存储。使用共享存储可以保证虚拟机在迁移过程中只涉及计算资源的切换，而不涉及存储资源的迁移，从而节省了迁移所需时间。

集群下的共享存储管理主要用于为主机批量增加、删除、暂停、启动共享存储池。

增加共享存储

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“存储”页签，进入该集群的共享存储列表页面。

  3. 单击<增加>按钮，弹出增加共享存储对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 参数设置完成后，单击<完成>按钮。

启动共享存储

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“存储”页签，进入该集群的共享存储列表页面。

  3. 选择待启动的共享存储，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

暂停共享存储

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“存储”页签，进入该集群的共享存储列表页面。

  3. 选择待暂停的共享存储，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

删除共享存储

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“存储”页签，进入该集群的共享存储列表页面。

  3. 选择待删除的共享存储，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

增加使用共享存储的主机

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“存储”页签，进入该集群的共享存储列表页面。

  3. 单击<增加使用的主机>按钮，弹出增加使用的主机对话框。

  4. 单击<选择主机>按钮，弹出选择主机对话框。

  5. 选择主机后单击<确定>按钮，返回增加使用的主机对话框。

  6. 单击<确定>按钮。

批量启动选中主机的存储池

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“存储”页签，进入该集群的共享存储列表页面。

  3. 在使用共享存储的主机列表中，选择一个或多个主机，单击<批量操作>按钮，选择[启动选择主机的存储池]菜单项，弹出操作确认对话框。

  4. 单击<确定>按钮。

批量暂停选中主机的存储池

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“存储”页签，进入该集群的共享存储列表页面。

  3. 在使用共享存储的主机列表中选择一个或多个主机，单击<批量操作>按钮，选择[暂停选择主机的存储池]菜单项，弹出操作确认对话框。

  4. 单击<确定>按钮。

批量删除选中主机的存储池

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“存储”页签，进入该集群的共享存储列表页面。

  3. 在使用共享存储的主机列表中选择一个或多个主机，单击<批量操作>按钮，选择[删除选择主机的存储池]菜单项，弹出操作确认对话框。

  4. 单击<确定>按钮。

参数说明

共享存储列表：

  • 类型：增加的共享存储的类型，包括共享文件系统和RBD网络存储。

  • 目标路径：共享存储在物理主机上的挂载点。

  • 总容量：共享存储池的总容量。

对于RBD网络存储类型的存储池，假设其对应分布式存储的块存储数据池Pool A：

  • 若Pool A的冗余策略为副本，则总容量＝Pool A裸容量/副本数。

  • 若Pool A的冗余策略为纠删码，则总容量＝Pool A裸容量×数据块个数/（数据块个数+校验块个数）。

裸容量是指Pool A中正常硬盘容量的总和。由于分布式存储中存在元数据等开销，所以RBD网络存储池实际可用总容量会略小于此参数。如果分布式存储是元数据池、数据池分离的情况，那么Pool A裸容量应为其元数据池的裸容量。以ONEStor为例，Pool A裸容量为其硬盘池的裸容量（ONEStor的硬盘池即为元数据池）。

  • 已分配容量：已分配给虚拟机磁盘的虚拟容量总和。

  • 实际可用容量：共享存储剩余的实际可用容量。

  • 操作：以图标的方式显示操作员可以对共享存储执行的管理操作，单击图标后相应的操作会生效。

  • 表示启动共享存储。

  • 表示刷新共享存储。

  • 表示暂停共享存储。

  • 表示删除存储池。

  • 共享文件系统：集群所属的主机池中的共享文件系统。


重命名集群

该功能用于修改集群的名称。

操作步骤

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[重命名]菜单项，弹出重命名集群对话框。

  3. 输入集群名称，单击<确定>按钮。


删除集群

该功能用于删除指定的集群。删除集群后，该集群中的主机和虚拟机都将脱离管理平台的管理，但不影响主机和虚拟机的正常运行。

操作步骤

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 单击<更多操作>按钮，选择[删除集群]菜单项，弹出删除集群确认对话框。

  3. 单击<确定>按钮。


查看集群概要信息

该功能用于查看集群的详细配置信息，集群中主机的CPU和内存利用率信息，以及虚拟机的CPU和内存利用率信息。

操作步骤

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

参数说明

  • 基本属性：显示指定集群的详细配置信息。

  • 主机：集群包含的主机数量。

  • CPU总核数：集群中各主机的CPU核数总和。

  • 总内存：集群中各主机的内存容量总和。

  • 本地总存储：集群中各主机的本地存储容量总和。

  • 本地总可用存储：集群中各主机剩余可用的本地存储容量总和。

  • 虚拟机：集群中虚拟机的总数，以及处于“运行”和“关闭”状态的虚拟机数量。

  • 虚拟机密度：集群中平均每个主机中虚拟机的数量。

  • 高可靠性：集群是否启用高可靠性功能。

  • 计算DRS：集群是否启用计算资源动态资源调度功能。

  • 存储DRS：集群是否启用存储资源动态资源调度功能。

  • 电源智能管理：集群是否启用电源智能管理功能。

  • CPU利用率：集群中所有主机CPU半小时的平均使用率。

  • 内存利用率：集群中所有主机内存半小时的平均使用率。

  • 存储利用率：集群中所有主机存储半小时的平均使用率。

  • CPU分配比：集群中主机CPU的利用情况（即虚拟机CPU总核数占主机CPU总核数的百分比）。

  • 内存分配比：集群中主机内存的利用情况（即虚拟机内存总数占主机内存总数的百分比）。

  • 共享存储分配比：集群中主机共享存储的利用情况（即虚拟机共享存储总容量占主机共享存储总容量的百分比）。

  • Top5主机CPU利用率：显示集群中CPU利用率（即百分比）最高的五个主机的名称和CPU利用率环形图表。

  • Top5主机内存利用率：显示集群中内存利用率（即百分比）最高的五个主机的名称和内存利用率柱形图表。

  • Top5虚拟机CPU利用率：显示集群中CPU利用率（即百分比）最高的五个虚拟机的显示名称和CPU利用率环形图表。

  • Top5虚拟机内存利用率：显示集群中内存利用率（即百分比）最高的五个虚拟机的显示名称和内存利用率柱形图表。


查看集群性能监控

该功能用于查看集群下主机的CPU平均利用率、内存平均利用率、I/O吞吐量统计、磁盘请求和共享文件系统占用率。

操作步骤

  1. 单击导航树中[云资源/<主机池>/<集群>]菜单项，进入该集群的概要信息页面。

  2. 选择“性能监控”页签，进入该集群的性能监控页面。

参数说明

  • CPU利用率：横轴为CPU运行时间，纵轴为集群主机CPU平均利用率。CPU利用率图表表示在图中时间范围内集群下所有主机的平均CPU利用率。

  • 内存利用率：横轴为内存运行时间，纵轴为集群主机内存平均利用率。内存利用率图表表示在图中时间范围内集群下所有主机内存的平均利用率。

  • I/O吞吐量统计：横轴为共享存储运行时间，纵轴为集群共享存储I/O吞吐量。I/O吞吐量统计图表表示在图中时间范围内集群指定共享存储的I/O吞吐量。

  • 磁盘请求：横轴为共享存储运行时间，纵轴为共享存储每秒读写操作的次数。磁盘请求图表表示在图中时间范围内主机磁盘读写情况。

  • 共享文件系统占用率：显示集群下共享文件系统使用情况。

  • 类型：共享文件系统的类型，包括iSCSI和FC。

  • 目标路径：共享文件系统在主机上的挂载路径。

  • 总容量：共享存储池的总容量。

  • 实际可用容量：共享存储剩余的实际可用容量。

  • 存储利用率（%）：共享文件系统使用率。


查看集群中的主机

该功能用于查看指定集群中的所有主机信息。

操作步骤

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“主机”页签，进入该集群的主机信息页面。

参数说明

  • 状态：主机当前的状态，包括正常、不正常、维护模式和主机不在集群HA内。

  • 虚拟机概要：主机上虚拟机的总数量，以及处于“运行”和“关闭”状态的虚拟机数量。

  • CPU：主机当前的CPU总核数。

  • 内存：主机当前的内存容量。

  • CPU利用率：主机的实时CPU利用率。

  • 内存利用率：主机的实时内存利用率。

  • 磁盘容量：主机本地磁盘的空间大小。

  • 平台：主机使用的虚拟化平台。目前仅支持CVK。

  • 操作：以图标的方式显示操作员可以对主机执行的管理操作，单击图标后相应的操作会生效。 表示修改主机。


查看集群中的虚拟机

该功能用于查看指定集群中的所有虚拟机信息。

操作步骤

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“虚拟机”页签，进入该集群的虚拟机信息页面。

  3. 单击<界面定制>按钮，可以调整显示列表的内容和顺序。

参数说明

  • 显示名称：虚拟机的显示名称。

  • 描述：虚拟机的描述信息。

  • 主机：虚拟机所属主机的名称。

  • 状态：虚拟机当前的状态，包括运行、暂停、关闭、未知和HA异常。

  • CPU利用率：虚拟机的实时CPU利用率。

  • 内存利用率：虚拟机的实时内存利用率。

  • CPU：虚拟机当前的CPU总核数（即CPU个数与每个CPU核数的乘积）。

  • 内存：虚拟机当前的内存容量。

  • 操作系统：虚拟机的操作系统类型，目前支持Windows、Linux以及银河麒麟类型的操作系统。其中ARM架构主机仅支持银河麒麟类型的操作系统，X86架构主机支持Windows和Linux操作系统。

  • 名称：虚拟机的名称。

  • IPv4/IPv6属性：虚拟机系统网卡对应的IPv4/IPv6属性。单击IP地址对应的超链接，可以查看IPv4/IPv6属性详细信息。对于IPv4属性，若虚拟机未安装CAStools，则无法采集子网掩码。

  • CAStools版本：CAStools版本信息。只有安装了CAStools的虚拟机才会显示CAStools版本。

  • CAStools状态：CAStools的运行状态，包括运行中和未运行。若虚拟机安装了CAStools且在虚拟机上已运行，则会显示“运行中”，否则会显示“未运行”。当虚拟机关机时显示“--”。

  • 连续运行时长：虚拟机已经连续运行的时间。

  • 创建时间：创建虚拟机的时间。

  • 最后关机时间：虚拟机的最后关机时间。

  • 时间同步：显示虚拟机是否配置时间同步。

  • 磁盘容量：显示虚拟机的磁盘容量大小。

  • 可用容量：显示虚拟机磁盘的可用容量。

  • 已用容量：显示虚拟机磁盘的已用容量。

  • 防病毒配置：虚拟机是否启用防病毒，包括启用和不启用。ARM架构主机暂不支持防病毒配置。


查看集群的操作日志

该功能用于查看所有操作员对指定集群执行的操作信息。

操作步骤

  1. 单击导航树中[云资源/主机池/<集群>]菜单项，进入集群概要信息页面。

  2. 选择“任务”页签，进入该集群的任务列表页面。

参数说明

  • 登录名：操作员登录管理平台所使用的登录名。

  • 完成时间：操作员完成操作的时间。

  • 登录地址：操作员登录管理平台所使用计算机的IP地址。

  • 操作分类：操作的分类。

  • 操作分类：所执行操作的分类。

  • 操作对象：操作所执行的对象。

  • 操作描述：所执行操作的详细描述。

  • 执行结果：操作的执行结果。

  • 成功：表示操作执行成功。

  • 部分成功：表示操作执行部分成功。

  • 失败：表示操作执行失败。

  • 失败原因：操作失败的详细原因。

  • 风险级别：操作执行对应的风险级别，包括高、中和低。

  • 事件类型：操作员所操作事件的类型。


虚拟机

虚拟机与主机类似，它们主要的区别在于虚拟机并不是由电子元器件组成的，而是由一组文件构成的。每台虚拟机都是一个完整的系统，它具有CPU、内存、网络设备、存储设备和BIOS，因此操作系统和应用程序在虚拟机中的运行方式与它们在普通物理机上的运行方式没有任何区别。

虚拟机创建后，可以根据实际需要对虚拟机的系统配置进行修改，如调整虚拟机的CPU数量，内存大小，增加或删除网卡、磁盘、显卡等；可以对虚拟机进行迁移，以达到系统运行最优化的目的；还可以对虚拟机进行快照或备份，保证数据的安全。

主要功能

  • 虚拟机创建管理

  • 修改虚拟机

  • 迁移虚拟机

  • 删除虚拟机

  • 虚拟机状态管理

  • 虚拟机快照管理

  • 虚拟机备份与还原管理

  • 合并虚拟机磁盘镜像

  • 查看虚拟机概要信息

  • 虚拟机CAStools管理

  • 查看虚拟机的性能监控信息

  • 查看虚拟机进程服务监控信息

  • 查看虚拟机的备份历史信息

  • 查看虚拟机的控制台信息

  • 查看虚拟机的迁移历史信息


虚拟机创建

系统支持多种创建虚拟机的方式：

  • 增加虚拟机：增加虚拟机时，可自定义虚拟机的CPU、内存、磁盘、网卡以及操作系统等。常用于系统初次部署。

  • 使用模板创建虚拟机：模板是虚拟机的一个副本，包含虚拟机的系统配置、操作系统和应用程序。使用模板创建虚拟机能够大幅节省配置新虚拟机和安装操作系统的工作量。

  • 通过虚拟机模板部署虚拟机：使用系统中的虚拟机模板部署虚拟机。在部署虚拟机之前，需要先制作虚拟机模板，具体操作请参见创建虚拟机模板。

  • 通过OVF模板部署虚拟机：使用第三方平台导出的OVF模板部署虚拟机。

  • 克隆虚拟机：使用系统中的虚拟机克隆出与源虚拟机相似的新虚拟机。在需要部署多个类似的虚拟机时，可在单个虚拟机上配置安装不同的软件，然后将该虚拟机克隆多次，而不用分别创建和配置每个虚拟机。

主要功能

  • 增加虚拟机

  • 通过虚拟机模板部署虚拟机

  • 通过OVF模板部署虚拟机


增加虚拟机

该功能用于在主机或集群上创建一个虚拟机。在集群中增加虚拟机时，系统在集群中资源最优（即虚拟机数量最少，内存利用率最低，CPU利用率最低）的主机上创建虚拟机。创建完成后，需要为虚拟机安装操作系统才能正常使用。

操作步骤

增加虚拟机

  1. 单击导航树中[云资源/主机池/<主机>]或者[云资源/主机池/集群/<主机>]菜单项，进入主机概要信息页面；或者单击[云资源/主机池/<集群>]菜单项进入集群概要信息页面。

  2. 单击<增加虚拟机>按钮，弹出增加虚拟机对话框。

  3. 根据配置向导完成虚拟机的创建。

2. 为虚拟机安装操作系统

  1. 从导航树中选择新增加的虚拟机，进入虚拟机概要信息页面。

  2. 选择“控制台”页签，进入控制台页面。单击“Java”或者“网页”链接，打开虚拟桌面窗口。

  3. 在虚拟桌面窗口中，单击<虚拟光驱>按钮，挂载本地镜像文件，为虚拟机安装虚拟机操作系统。

参数说明

在ARM架构的主机上增加虚拟机，暂不支持SR-IOV直通网卡。

X86架构服务器

1. 基本信息设置

  • 操作系统：选择虚拟机的操作系统，注意所选操作系统必须与实际安装的操作系统类型一致，否则可能会影响驱动运行，导致无法正常安装系统。

  • 自动迁移：集群动态资源调度和电源智能管理策略生效后是否允许虚拟机在集群内自动迁移。

  • CAStools自动升级：当虚拟机操作系统安装的虚拟机代理工具版本低于当前管理平台提供的版本时，会自动升级虚拟机代理工具，不开启则不会自动升级。

2. CPU选项

  • CPU：设置虚拟机CPU的个数，其不能超过当前主机的CPU总个数。Windows 7操作系统由于自身系统特性的原因，最多只能有效使用2个CPU，为了提升处理性能，可以为每个CPU设置多个核。

  • CPU核数：设置虚拟机CPU的核数，默认为1，虚拟机配置CPU核数不超过物理主机CPU核数，CPU个数与CPU核数之间可以组合。

  • 最大CPU：设置虚机可分配的最大CPU个数。虚拟机最大CPU值为：最大CPU个数*当前CPU核数。

  • 绑定物理CPU：将虚拟机的虚拟CPU绑定到主机的一个或多个物理CPU上，绑定后的虚拟机不会使用主机的其它物理CPU。虚拟机绑定物理CPU后，不要关闭主机超线程，否则可能会导致vCPU和NUMA节点对应关系错乱，引起虚拟机启动异常。

  • NUMA节点：系统中NUMA节点数对应主机物理CPU数，单个CPU物理核数（如CPU支持超标量则还需乘超标量数值）即为NUMA节点内的CPU数量，NUMA节点编号从0开始。每个NUMA节点包含CPU，IO总线及内存资源。

  • CPU工作模式：设置CPU的工作模式，包括兼容模式，主机匹配模式，直通模式，默认为兼容模式。

  • 兼容模式：将不同的型号物理CPU虚拟成相同型号的vCPU，迁移兼容性好。

  • 主机匹配模式：将不同的物理CPU虚拟成不同型号的vCPU，迁移兼容性差，相对于兼容模式可以给虚拟机操作系统提供更优的性能。

  • 直通模式：直接将物理CPU暴露给虚拟机使用，迁移兼容性差，相对于兼容模式和主机匹配模式可以给虚拟机操作系统提供更优的性能。如果CPU工作模式设置为直通模式，则该虚拟机在迁移时，要求目的主机的与源主机的CPU型号必须保持一致。

  • 体系结构：设置虚拟机CPU架构，包括64位、32位，默认为64位。对于32位操作系统，CPU架构可选择32位，也可选择64位，通常选择64位；对于64位操作系统，CPU架构必须选择64位，否则虚拟机将无法启动。

  • CPU调度优先级：设置虚拟机进程对物理CPU资源的抢占优先级，包括高、中、低，默认为中。

  • CPU预留：设置预留一定量的CPU资源仅供该虚拟机使用。

  • CPU限制：设置虚拟机CPU单核允许使用主机CPU的最大频率。

  • 整机限制：选择是否启用整机限制。例：某虚拟机CPU共有4核，虚拟机CPU单核允许使用的频率限制为2GHz，开启整机限制后，则虚拟机整机允许使用主机CPU的最大频率为8GHz，此时单核可使用的频率可超过2GHz。

  • 在线缩容：选择是否允许在线减小CPU的个数。CPU在线缩容需要虚拟机操作系统的支持。

  • I/O优先级：设置虚拟机进程对硬盘读写的优先权，包括低、中、高，默认为中。

3. 内存选项

  • 内存：设置虚拟机的内存容量。为虚拟机分配的内存大小是虚拟机操作系统的内存大小。内存的最大值取决于当前主机物理内存大小。

  • 内存预留：设置为虚拟机预留内存百分比。为了使内存有效使用，主机会按虚拟机实际内存使用量为其分配内存，上限为虚拟机配置的内存值。为了避免主机内存耗尽时，未达到内存使用上限的虚拟机无法继续使用更多的内存，可以设置为虚拟机预留一部分内存。

  • 限制：设置虚拟机允许使用主机内存的最大值。

  • 内存资源优先级：设置虚拟机申请内存资源的优先级，包括高、中、低，默认为低。

  • 内存气球：开启后可在不关闭虚拟机情况下，通过Ballooning技术动态调整虚拟机内存，将主机内存按需分配。

  • 大页配置：设置虚拟机是否允许使用主机的大页内存，主机必须开启大页功能才能设置此项。大页功能与内存预留、内存限制、内存资源优先级和内存气球功能互斥。

4. 网络选项

  • 网络：设置虚拟机网卡将要连接的虚拟交换机。

  • 网络策略模板：设置虚拟机的网络策略。虚拟机所属VLAN、ACL访问控制、虚拟网卡的网络带宽限制均由所选网络策略模板而定。

  • 虚拟防火墙：用于设置虚拟机使用的虚拟防火墙。设置后，虚拟机的入方向和出方向数据报文将会根据防火墙的规则进行过滤。

  • 网络类型：设置虚拟机的网络适配器类型，包括普通网卡、高速网卡、Intel e1000网卡、SR-IOV直通网卡，默认为高速网卡。高速网卡是CVK软件驱动的网卡。当网卡类型为高速网卡时内核加速选项默认为开启，当网卡类型为SR-IOV直通网卡时需要选择网卡的驱动类型，并设置VLAN ID。

  • 驱动类型：SR-IOV直通网卡的驱动类型。

  • 网卡绑定IPv4/IPv6：与虚拟机网卡MAC地址绑定的IP地址。若虚拟机网卡设置的IP地址与绑定IP不一致，则该网卡无法正常通信。

  • MAC地址：设置虚拟机MAC地址的获取方式，包括手工设定和自动获取两种方式，默认为自动获取。

  • VLAN ID：设置虚拟机网卡所属的VLAN ID。当网络类型为“SR-IOV直通网卡”时，才可设置此参数。

  • 内核加速：设置内核加速功能，开启后高速类型网卡将以一个单独线程的形式在CVK内核中进行模拟，可以提升虚拟机网络性能。当设备型号选择为“高速网卡”时，需设置此参数。

  • 队列个数：设置虚拟网卡的队列个数，多队列可以提高虚拟网卡处理数据的性能，缺省值为1，最大值为vCPU的个数*核数。当设备型号选择为“高速网卡”并且开启内核加速时，需设置此参数。

  • MTU：设置虚拟机网卡的最大传输单元，默认为1500。当网络类型为“普通网卡”、“高速网卡”或“Intel e1000网卡”时，需要设置此参数。

5. 磁盘选项

  • 磁盘：设置作为虚拟机磁盘的存储卷及其所在的存储池。

  • 类型：设置虚拟机的磁盘类型，包括文件、新建RBD块和块设备，其中文件分为新建文件和已有文件。当主机上存在活动的RBD网络存储池时，默认为新建RBD块；反之，默认为新建文件。

  • 新建文件：文件是构建在文件系统之上的磁盘文件，虚拟机看到的是一个实际的磁盘，实际使用的是一个虚拟磁盘文件所表示的一个磁盘。文件方式的磁盘挂接方式更便于管理。新建文件是新建一个空的存储文件作为虚拟机的磁盘。

  • 新建RBD块：在RBD网络存储池中新建一个RBD块作为虚拟机的磁盘。

  • 已有文件：选择一个已经存在且未被其他虚拟机使用的存储文件作为虚拟机的磁盘。可选项包括本地文件目录、共享文件系统、NFS网络文件系统类型的存储池中的存储卷。

  • 块设备：块设备也称作裸设备，即磁盘上没有文件系统，如IP SAN或FC SAN上的存储LUN。块设备一般应用于性能要求较高的虚拟化环境，如数据库、高性能I/O计算等。该选项用于选择一个已经存在且未被其他虚拟机使用的存储卷作为虚拟机的磁盘。可选项包括RBD网络存储、iSCSI网络存储、FC网络存储和LVM逻辑存储卷类型的存储池中的存储卷。

  • 存储池：增加虚拟机时，创建的新磁盘所在的目标存储池。

  • 文件名：新建文件作为虚拟机的磁盘时，输入磁盘的文件名称，选择文件的磁盘格式，包括高速、智能，默认为智能。

  • 智能：虚拟机的磁盘格式为qcow2。

  • 高速：虚拟机的磁盘格式为raw。该格式结构简单，I/O效率高。

  • 预分配：存储卷的分配方式，包括精简、延迟置零和置零，默认为精简。当磁盘类型为新建文件时，需要设置此参数。

  • 精简：创建存储卷时，只为该存储卷分配最初所需要的数据存储空间的容量。如果之后存储卷需要更多的存储空间，则它可以增加到创建存储卷时设置的最大容量。

  • 延迟置零：创建存储卷时就为存储卷分配最大容量的存储空间。创建时不会擦除物理设备上保留的任何数据，在虚拟机首次执行写操作时，将其置零。

  • 置零：创建存储卷时就为存储卷分配最大容量的存储空间，在创建过程中会将物理设备上保留的数据置零，创建存储卷所需时间较长。

  • 簇大小：文件占用磁盘空间的最小单位，默认为256KB。如果一个文件的容量大于单个簇大小，该文件将存储到多个簇中；如果一个文件的容量小于单个簇大小，该文件将独占一个簇。共享文件系统存放的文件多为虚拟机镜像文件，建议将簇大小设置的尽可能大，以增强磁盘读取数据的性能，又节约磁盘空间。当新建智能格式的磁盘时，需设置此参数。

  • 总线类型：设置虚拟机磁盘的总线类型，包括IDE硬盘、SCSI硬盘、USB硬盘、高速硬盘、高速SCSI硬盘，默认为高速硬盘。

  • 缓存方式：设置虚拟机数据的缓存方式，包括直接读写、一级物理缓存、二级虚拟缓存、一级虚拟缓存。磁盘格式为“智能”（即qcow2格式）时，默认为直接读写（directsync），磁盘格式为raw、块设备（包括RBD）时，默认为一级虚拟缓存（none）。

  • 直接读写（directsync）：指数据直接从物理磁盘读写。

  • 一级物理缓存（writethrough）：指数据先写入主机缓存，再将主机缓存内的数据写入物理磁盘。

  • 二级虚拟缓存（writeback）：指数据先写入虚拟机缓存，再将虚拟机缓存内的数据写入主机缓存，最终写入物理磁盘。

  • 一级虚拟缓存（none）：指数据先写入虚拟机缓存，再将虚拟机缓存内的数据直接写入物理磁盘。

  • 磁盘模式：选择是否可以对磁盘进行外部快照。只有文件类型的磁盘才可以配置磁盘模式。

  • 从属：虚拟机创建外部快照时包含该从属磁盘，对其进行外部快照。还原时也对该磁盘还原。

  • 独立-持久：虚拟机创建外部快照时，不对该磁盘进行快照，还原时也不对该磁盘还原。

  • Serial号：磁盘的序列号。

6. 软驱选项

  • 软驱：设置虚拟机使用的软驱镜像，系统会自动加载与所选择的操作系统和版本相对应的高速驱动。

7. 光驱选项

  • 光驱：设置虚拟机使用的光驱或镜像。虚拟机使用完主机上的物理光驱后，请及时取消虚拟机与主机上物理光驱的挂接，以免虚拟机迁移时，因为目的主机没有物理光驱而导致迁移失败。

  • 连接方式：用于指定虚拟机光驱的连接方式，包括CD/DVD、镜像文件，默认为镜像文件。

8. 增加硬件选项

  • 增加硬件：用于为虚拟机增加相应的硬件资源，包括网卡、磁盘、光驱、软驱、GPU设备、USB设备、网络USB设备、PCI设备、看门狗。在给虚拟机增加PCI设备时，对于内存小于2G的虚拟机，其PCI设备的内存总和不建议超过2G；对于内存大于2G的虚拟机，其PCI设备的内存总和不建议超过1G，否则可能导致虚拟机无法正常启动。

  • GPU设备：GPU（Graphics Processing Unit）图形处理单元，它把CPU从图形处理任务中解放出来让CPU可以执行其他更多的系统任务。虚拟机挂载了GPU/vGPU设备后，无论虚拟机处于何种状态，都不允许云彩虹迁移；在运行状态下不允许休眠、克隆为模板、转换为模板、快照、克隆、迁移主机以及迁移主机和存储。

  • GPU资源池：选择虚拟机使用的GPU资源池。选择GPU类型的资源池时，虚拟机以直通方式使用主机的物理GPU资源；选择vGPU类型的资源池时，虚拟机使用主机的vGPU资源。

  • 业务模板：定义了虚拟机使用资源的优先级，当资源池中的资源紧张时，高优先级的虚拟机优先获取相关资源。

  • 驱动类型：虚拟机PCI设备或GPU设备的驱动类型。

  • 资源独占：虚拟机是否独享GPU/vGPU资源。选择“否”，表示虚拟机在关闭状态下不会绑定GPU/vGPU资源。选择“是”，无论虚拟机处于何种状态，虚拟机会一直绑定GPU/vGPU资源，该GPU/vGPU资源为虚拟机独享，不能被其他虚拟机使用。只有当宿主机存在空闲GPU/vGPU资源，且该空闲资源已加入所选GPU资源池时，才允许开启资源独占。开启资源独占后，当集群内其他主机有满足条件的GPU/vGPU资源时，虚拟机在关机状态下允许迁移至该主机上，否则不允许迁移虚拟机。

  • 资源个数：设置虚拟机使用GPU/vGPU资源的数量。选择vGPU类型的资源池时，资源个数最大值为1。选择GPU类型的资源池，且未开启资源独占，资源个数最大值为该资源池内单个主机的最大GPU数量，例如在该资源池中A主机有3个GPU，B主机有2个，C主机有2个，则最大值为3；若开启了资源独占，则资源个数最大值为该资源池内宿主机的空闲GPU数量。

  • 看门狗：中断响应处理虚拟机的方式，包括重启、关闭、迁移，默认值为重启。

ARM架构服务器

1. 基本信息设置

  • 操作系统：选择虚拟机的操作系统，注意所选操作系统必须与实际安装的操作系统类型一致，否则可能会影响驱动运行，导致无法正常安装系统。

  • 自动迁移：集群动态资源调度和电源智能管理策略生效后是否允许虚拟机在集群内自动迁移。

  • CAStools自动升级：当虚拟机操作系统安装的虚拟机代理工具版本低于当前管理平台提供的版本时，会自动升级代理工具，不开启则不会自动升级。

2. CPU选项

  • CPU：设置虚拟机CPU的个数，其不能超过当前主机的CPU总个数。

  • CPU核数：设置虚拟机CPU的核数，默认为1，虚拟机配置CPU核数不超过物理主机CPU核数，CPU个数与CPU核数之间可以组合。

  • 绑定物理CPU：将虚拟机的虚拟CPU绑定到主机的一个或多个物理CPU上，绑定后的虚拟机不会使用主机的其它物理CPU。虚拟机绑定物理CPU后，不要关闭主机超线程，否则可能会导致vCPU和NUMA节点对应关系错乱，引起虚拟机启动异常。

  • NUMA节点：系统中NUMA节点数对应主机物理CPU数，单个CPU物理核数（如CPU支持超标量则还需乘超标量数值）即为NUMA节点内的CPU数量，NUMA节点编号从0开始。每个NUMA节点包含CPU，IO总线及内存资源。

  • CPU工作模式：仅支持直通模式，直接将物理CPU暴露给虚拟机使用。虚拟机在迁移时，要求目的主机的与源主机的CPU型号必须保持一致。

  • CPU调度优先级：设置虚拟机进程对物理CPU资源的抢占优先级，包括高、中、低，默认为中。

  • CPU预留：设置预留一定量的CPU资源仅供该虚拟机使用。

  • CPU限制：设置虚拟机CPU单核允许使用主机CPU的最大频率。

  • 整机限制：选择是否启用整机限制。例：某虚拟机CPU共有4核，虚拟机CPU单核允许使用的频率限制为2GHz，开启整机限制后，则虚拟机整机允许使用主机CPU的最大频率为8GHz，此时单核可使用的频率可超过2GHz。

3. 内存选项

  • 内存：设置虚拟机的内存容量。为虚拟机分配的内存大小是虚拟机操作系统的内存大小。内存的最大值取决于当前主机物理内存大小。

  • 内存预留：设置为虚拟机预留内存百分比。为了使内存有效使用，主机会按虚拟机实际内存使用量为其分配内存，上限为虚拟机配置的内存值。为了避免主机内存耗尽时，未达到内存使用上限的虚拟机无法继续使用更多的内存，可以设置为虚拟机预留一部分内存。

  • 限制：设置虚拟机允许使用主机内存的最大值。

  • 内存资源优先级：设置虚拟机申请内存资源的优先级，包括高、中、低，默认为低。

  • 大页配置：设置虚拟机是否允许使用主机的大页内存，主机必须开启大页功能才能设置此项。大页功能与内存预留、内存限制、内存资源优先级和内存气球功能互斥。

4. 网络选项

  • 网络类型：设置虚拟机的网络适配器类型，包括普通网卡、高速网卡、Intel e1000网卡，默认为高速网卡。高速网卡是CVK软件驱动的网卡。

  • 网卡绑定IPv4/IPv6：与虚拟机网卡MAC地址绑定的IP地址。若虚拟机网卡设置的IP地址与绑定IP不一致，则该网卡无法正常通信。

  • MAC地址：设置虚拟机MAC地址的获取方式，包括手工设定和自动获取两种方式，默认为自动获取。

  • 内核加速：设置内核加速功能，开启后高速类型网卡将以一个单独线程的形式在CVK内核中进行模拟，可以提升虚拟机网络性能。当设备型号选择为“高速网卡”时，需设置此参数。

  • 队列个数：设置虚拟网卡的队列个数，多队列可以提高虚拟网卡处理数据的性能，缺省值为1，最大值为vCPU的个数*核数。当设备型号选择为“高速网卡”并且开启内核加速时，需设置此参数。

  • MTU：设置虚拟机网卡的最大传输单元，默认为1500。

5. 磁盘选项

  • 磁盘：设置作为虚拟机磁盘的存储卷及其所在的存储池。

  • 类型：设置虚拟机的磁盘类型，包括文件、新建RBD块和块设备，其中文件分为新建文件和已有文件。当主机上存在活动的RBD网络存储池时，默认为新建RBD块；反之，默认为新建文件。

  • 新建文件：文件是构建在文件系统之上的磁盘文件，虚拟机看到的是一个实际的磁盘，实际使用的是一个虚拟磁盘文件所表示的一个磁盘。文件方式的磁盘挂接方式更便于管理。新建文件是新建一个空的存储文件作为虚拟机的磁盘。

  • 新建RBD块：在RBD网络存储池中新建一个RBD块作为虚拟机的磁盘。

  • 已有文件：选择一个已经存在且未被其他虚拟机使用的存储文件作为虚拟机的磁盘。可选项包括本地文件目录、共享文件系统、NFS网络文件系统类型的存储池中的存储卷。

  • 块设备：块设备也称作裸设备，即磁盘上没有文件系统，如IP SAN或FC SAN上的存储LUN。块设备一般应用于性能要求较高的虚拟化环境，如数据库、高性能I/O计算等。该选项用于选择一个已经存在且未被其他虚拟机使用的存储卷作为虚拟机的磁盘。可选项包括RBD网络存储、iSCSI网络存储、FC网络存储和LVM逻辑存储卷类型的存储池中的存储卷。

  • 存储池：增加虚拟机时，创建的新磁盘所在的目标存储池。

  • 文件名：新建文件作为虚拟机的磁盘时，输入磁盘的文件名称，选择文件的磁盘格式，包括高速、智能，默认为智能。

  • 智能：虚拟机的磁盘格式为qcow2。

  • 高速：虚拟机的磁盘格式为raw。该格式结构简单，I/O效率高。

  • 预分配：存储卷的分配方式，包括精简、延迟置零和置零，默认为精简。当磁盘类型为新建文件时，需要设置此参数。

  • 精简：创建存储卷时，只为该存储卷分配最初所需要的数据存储空间的容量。如果之后存储卷需要更多的存储空间，则它可以增加到创建存储卷时设置的最大容量。

  • 延迟置零：创建存储卷时就为存储卷分配最大容量的存储空间。创建时不会擦除物理设备上保留的任何数据，在虚拟机首次执行写操作时，将其置零。

  • 置零：创建存储卷时就为存储卷分配最大容量的存储空间，在创建过程中会将物理设备上保留的数据置零，创建存储卷所需时间较长。

  • 簇大小：文件占用磁盘空间的最小单位，默认为256KB。如果一个文件的容量大于单个簇大小，该文件将存储到多个簇中；如果一个文件的容量小于单个簇大小，该文件将独占一个簇。共享文件系统存放的文件多为虚拟机镜像文件，建议将簇大小设置的尽可能大，以增强磁盘读取数据的性能，又节约磁盘空间。当新建智能格式的磁盘时，需设置此参数。

  • 总线类型：虚拟机磁盘的总线类型，ARM架构的主机只支持高速硬盘和高速SCSI硬盘，默认为高速SCSI硬盘。

  • 缓存方式：设置虚拟机数据的缓存方式，包括直接读写、一级物理缓存、二级虚拟缓存、一级虚拟缓存。磁盘格式为“智能”（即qcow2格式）时，默认为直接读写（directsync），磁盘格式为raw、块设备（包括RBD）时，默认为一级虚拟缓存（none）。

  • 直接读写（directsync）：指数据直接从物理磁盘读写。

  • 一级物理缓存（writethrough）：指数据先写入主机缓存，再将主机缓存内的数据写入物理磁盘。

  • 二级虚拟缓存（writeback）：指数据先写入虚拟机缓存，再将虚拟机缓存内的数据写入主机缓存，最终写入物理磁盘。

  • 一级虚拟缓存（none）：指数据先写入虚拟机缓存，再将虚拟机缓存内的数据直接写入物理磁盘。

  • 磁盘模式：选择是否可以对磁盘进行外部快照。只有文件类型的磁盘才可以配置磁盘模式。

  • 从属：虚拟机创建外部快照时包含该从属磁盘，对其进行外部快照。还原时也对该磁盘还原。

  • 独立-持久：虚拟机创建外部快照时，不对该磁盘进行快照，还原时也不对该磁盘还原。

  • Serial号：磁盘的序列号。

6. 软驱选项

  • 软驱：设置虚拟机使用的软驱镜像，系统会自动加载与所选择的操作系统和版本相对应的高速驱动。

7. 光驱选项

  • 光驱：设置虚拟机使用的光驱或镜像。虚拟机使用完主机上的物理光驱后，请及时取消虚拟机与主机上物理光驱的挂接，以免虚拟机迁移时，因为目的主机没有物理光驱而导致迁移失败。

  • 连接方式：用于指定虚拟机光驱的连接方式，包括CD/DVD、镜像文件，默认为镜像文件。

8. 增加硬件选项

  • 增加硬件：用于为虚拟机增加相应的硬件资源，包括网卡、磁盘、光驱、软驱。


通过虚拟机模板部署虚拟机

虚拟机模板是由一台虚拟机克隆或转换而来，用于便捷地创建和配置多台新虚拟机。通过虚拟机模板部署的虚拟机与模板具有相同的操作系统和应用程序。

在部署虚拟机之前，需要先制作虚拟机模板，具体请参见创建虚拟机模板。

注意事项

由ARM老版本通过模板部署、升级或备份恢复到新ARM版的虚拟机，不支持在线添加硬件设备。

操作步骤

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 在虚拟机模板列表中选择待部署虚拟机的模板，单击 [image] 图标，弹出部署虚拟机配置对话框。

  3. 根据配置向导完成虚拟机的部署。

参数说明

基本信息设置：

  • 数量：一次性部署虚拟机的个数，最小值为1，最大值为100。

  • 显示名称（前缀）：虚拟机显示名称，若部署虚拟机的数量大于1，则会显示为“显示名称前缀”。

  • 起始编号：批量部署虚拟机时的起始编号，当部署虚拟机的数量大于1时，才需配置此参数。

  • 密级级别：部署虚拟机设置密级级别，包括绝密、机密、秘密、内部公开，默认为内部公开。当密级级别为内部公开时，虚拟机只能部署到非安全区域，当密级级别设置为非内部公开时，虚拟机只允许部署到安全区域内。系统启用保密模式后才需要设置此项。

  • 快速部署：基于虚拟机模板的基础镜像文件部署虚拟机。若勾选“快速部署”选项，系统将会提高创建虚拟机的速度，节省服务器的存储空间。

  • 立即启动：虚拟机部署完成后，是否立即启动。

  • 配置操作系统：选择是否需要配置虚拟机的操作系统信息。

  • 快速初始化：通过CAStools对虚拟机的操作系统参数和用户账号信息进行初始化设置，不清除操作系统的SID（安全标识符）信息。快速初始化要求在虚拟机模板中安装虚拟机代理工具，适用于支持虚拟机代理工具的Windows和Linux操作系统。

  • 完全初始化：通过Sysprep（系统准备工具）对虚拟机的操作系统参数、用户账号信息进行初始化设置，并清除的操作系统的SID信息。完全初始化要求在虚拟机模板中配置Sysprep（系统准备工具），仅适用于Windows 7和Windows XP操作系统。（ARM架构的主机暂不支持此参数）。

存储信息设置：

  • 目的存储文件：为虚拟机指定存储文件名称。

  • 目的存储池：为虚拟机指定使用的存储池，单击“目的存储池”列表格，可以选择目的存储池位置。

  • 磁盘格式：当未勾选“快速部署”选项时，需设置此项参数，包括不变、智能、高速，默认为不变。

  • 不变：部署的虚拟机的磁盘格式与模板保持一致。

  • 智能：设置部署的虚拟机的磁盘格式为qcow2。

  • 高速：设置部署的虚拟机的磁盘格式为raw。该格式结构简单，I/O效率高。

网络信息设置：

  • 虚拟交换机：指定虚拟机使用的虚拟交换机。

  • 网络策略模板/端口组：指定虚拟机使用的网络策略模板以及端口组，新部署的虚拟机使用的是最新的网络策略模板，其配置的VLAN和QoS可能与虚拟机模板不一致。

  • 网络参数：指定虚拟机的IP地址分配方式，默认为DHCP方式。若手工分配方式，可以设置IP地址、子网掩码、默认网关、主DNS服务器、备DNS服务器和设置IP绑定等网络参数。

  • IP地址：指定虚拟机的IP地址。

  • 子网掩码：指定虚拟机的子网掩码。

  • 默认网关：指定虚拟机的默认网关。

  • 主DNS服务器：指定虚拟机的主DNS服务器。

  • 备DNS服务器：指定虚拟机的备DNS服务器。

  • 设置IP绑定：勾选表示将虚拟机的IP地址与MAC地址绑定。

  • 虚拟防护墙：设置虚拟机使用的虚拟防火墙。设置后，虚拟机的入方向和出方向数据报文将会根据防火墙的规则进行过滤。

系统信息设置-X86架构服务器：

  • 计算机名：操作系统中计算机的名称。

  • 隶属于：部署后的虚拟机属于的域或者工作组。当部署Windows系统模板的虚拟机时，才需设置此参数。

  • 域/工作组：域或工作组的名称，当部署Windows系统模板的虚拟机时，才需设置此参数。

  • 登录帐号：虚拟机操作系统的登录帐号。

  • 登录密码：虚拟机操作系统登录帐号对应的密码。

  • 密码确认：必须与登录密码完全一致。

  • 本地组：虚拟机操作系统登录帐号所属的本地组，包括Administrators、Power Users、Users，默认为Administrators。当部署Windows系统模板的虚拟机时，才需设置此参数。

  • 时区：操作系统的时区。当部署Windiwos系统模板的虚拟机时，才需设置此参数。

  • 默认用户密码：系统默认用户Administrator的密码，不填写则不设置密码。当部署Windows系统模板的虚拟机，并选择完全初始化时，才需设置此参数。

  • 激活序列号：虚拟机操作系统的激活序列号。当部署Windows系统模板的虚拟机，并勾选了配置虚拟机的操作系统信息和完全初始化时，需设置此参数。若不设置此参数，则在虚拟机启动时必须输入符合操作系统版本的激活序列号。

系统信息设置-ARM架构的主机：

  • 计算机名：操作系统中计算机的名称。

  • 登录帐号：虚拟机操作系统的登录帐号。

  • 登录密码：虚拟机操作系统登录帐号对应的密码。

  • 密码确认：必须与登录密码完全一致。


通过OVF模板部署虚拟机

OVF（Open Virtualization Format，开放虚拟化格式）定义了开源的虚拟机文件格式规范。OVF模板可以实现虚拟机在不同虚拟化管理平台之间相互兼容。目前系统支持由H3C CAS CVM、VMware vSphere、Oracle VM和中兴iECS等虚拟化平台导出的OVF模板。

注意事项

  • 由于上传OVF模板耗费的时间与虚拟机镜像文件实际占用的磁盘空间大小密切相关。建议在部署OVF模板之前，调整系统参数中的闲置超时时间（具体操作步骤请参见系统参数设置），使系统的闲置超时时间大于OVF模板文件的上传时间，确保OVF模板文件在上传过程中不会中断。

  • 系统暂不支持部署存在磁盘分片的OVF模板。

  • 系统暂不支持部署磁盘文件或其他文件名不规范的OVF模板。不规范的文件名即文件名中带特殊字符（除字母、数字、减号、下划线、点外的其他字符为特殊字符）；或首字母为减号和点；或全部为数字的文件名。

  • 在部署VMware vSphere平台虚拟机或VirtualBox虚拟机的OVF模板时，如果虚拟机的系统是Windows XP等较老的系统，可以通过修改注册表的方式，使操作系统支持ide（piix3/piix4），或直接选择硬件兼容性较好的虚拟机做为模板使用，来避免因硬件兼容性问题可能导致的部署后蓝屏问题。

  • ARM版本目前只支持部署通过CAS导出的OVF模板。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 单击<更多操作>按钮，选择[部署OVF模板]菜单项，弹出部署OVF模板对话框。

  3. 根据配置向导完成虚拟机的部署。

参数说明

基本信息设置：

  • 显示名称：虚拟机的显示名称，可支持中文字符。

  • CPU个数：虚拟机CPU的核数（即CPU个数与每个CPU核数的乘积）。

  • 内存：虚拟机内存的容量。

  • 立即启动：虚拟机部署完成后是否立即启动。

磁盘设置：

  • 目的存储文件：部署的虚拟机的存储卷名称。

  • 目的存储池：部署的虚拟机存储卷所属的存储池。

  • 总线类型：设置虚拟机磁盘的总线类型，包括IDE硬盘、SCSI硬盘、USB硬盘、高速硬盘、高速SCSI硬盘，默认为IDE硬盘。跨平台的OVF模板部署时，磁盘总线类型建议选择IDE硬盘。部署完成后，虚拟机先在线安装虚拟机代理工具（安装代理工具时会默认安装virtio驱动），再离线修改磁盘总线类型为高速硬盘，以最大程度发挥磁盘I/O性能。

网卡设置：

  • 网络：设置虚拟机网卡将要连接的虚拟交换机。

  • 网络策略模板：设置虚拟机交换接口的网络策略。

  • 虚拟防火墙：设置虚拟机使用的虚拟防火墙。设置后，虚拟机的入方向和出方向数据报文将会根据防火墙的规则进行过滤。

  • 网络类型：设置虚拟机的网络适配器类型，包括普通网卡、高速网卡、Intel e1000网卡，默认为高速网卡。高速网卡是CVK软件驱动的网卡。

  • 网卡绑定IPv4/IPv6：设置与虚拟机网卡MAC地址绑定的IP地址。若虚拟机网卡设置的IP地址与绑定IP不一致，则该网卡无法正常通信。

  • 内核加速：设置内核加速功能，开启后高速类型网卡将以一个单独线程的形式在CVK内核中进行模拟，可以提升虚拟机网络性能。设备型号选择为高速网卡，可以设置此参数，默认为开启。

  • 队列个数：设置虚拟网卡的队列个数，多队列可以提高虚拟网卡处理数据的性能，缺省值为1，最大值为vCPU的个数*核数。当设备型号选择为“高速网卡”并且开启内核加速时，需设置此参数。


克隆虚拟机

该功能用于通过复制虚拟机来创建一个新的虚拟机。克隆后新虚拟机的硬件配置、操作系统、应用程序和数据与源虚拟机相同，但拥有新的虚拟网卡MAC地址和UUID地址。

注意事项

  • 克隆虚拟机时，如果需要将目的虚拟机的镜像文件存放到其他存储池，则必须确保源虚拟机所在的存储池剩余空间大于虚拟机磁盘的空间。

  • 对于SUSE openSUSE和Ubuntu Linux操作系统的虚拟机，克隆前请先清空其网卡配置文件。否则，通过该虚拟机克隆出新虚拟机后，修改新虚拟机的网络配置参数将不生效。

  • 离线克隆挂载GPU设备（物理GPU/vGPU）的虚拟机，克隆后的新虚拟机不含GPU设备。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<克隆>按钮，弹出克隆虚拟机对话框。

  3. 根据配置向导完成虚拟机的克隆。

参数说明

基本信息设置：

  • 源虚拟机：被克隆的虚拟机显示名称。

  • 显示名称：克隆后新虚拟机的显示名称，缺省为“源虚拟机”+“_clone”。

  • 克隆方式：虚拟机克隆可选择的克隆类型，包括普通克隆、快速克隆、完全克隆，默认为完全克隆。

  • 普通克隆：对于关闭状态的虚拟机，克隆后的虚拟机与原虚拟机磁盘数据完全相同，如果原虚拟机磁盘为三级镜像，则克隆后的虚拟机与原虚拟机共用基础磁盘镜像；对于运行状态的虚拟机，克隆后的虚拟机磁盘为一级镜像，不与原虚拟机共用基础磁盘镜像，其效果与完全克隆相同。

  • 快速克隆：基于增量文件的方式生成新的虚拟机，克隆后的虚拟机和原虚拟机共用磁盘基础镜像，不拥有原虚拟机增量存储的磁盘内容，克隆后的虚拟机磁盘为三级镜像。快速克隆可大大提高创建虚拟机的速度，节省服务器的存储空间。只有磁盘预分配方式为精简的虚拟机才支持快速克隆。

  • 完全克隆：克隆后的虚拟机与原虚拟机磁盘数据完全相同，且新虚拟机的磁盘为一级镜像，不与原虚拟机共用磁盘镜像。在需要部署大量虚拟机的场合，完全克隆所需的存储空间将是原虚拟机的整数倍。

  • 克隆目的位置，包括主机内克隆、主机间克隆，默认为主机内克隆。

  • 主机内克隆：克隆后新虚拟机与被克隆的虚拟机在同一个主机上。

  • 主机间克隆：克隆后新虚拟机与被克隆的虚拟机在不同的主机上。

  • 立即启动：克隆完成后，是否立即启动新虚拟机。

存储信息设置：

  • 目的存储文件：为克隆后的新虚拟机指定存储文件名称。

  • 目的存储池：为克隆后的新虚拟机指定使用的存储池，单击“目的存储池”列表格，可以选择目的存储池位置。

  • 克隆方式为快速克隆和普通克隆时：若被克隆虚拟机的磁盘为文件类型，则只能选择本地文件目录、共享文件系统或NFS网络文件系统类型的存储池；若被克隆虚拟机的磁盘为RBD块，则只能选择来自同一分布式存储资源的RBD网络存储池。

  • 克隆方式为完全克隆时，目的存储池的选择不受限制。

  • 指定格式：选择克隆后新虚拟机的磁盘格式，当虚拟机进行完全克隆或对无多级镜像的虚拟机进行普通克隆时，才支持配置此项参数，包括不变、高速、智能，默认为不变。所选目的存储池的类型是本地文件目录、共享文件系统或NFS网络文件系统时，该参数的设置才会生效。

  • 不变：选择克隆后新虚拟机的磁盘格式是否与被克隆的虚拟机相同。

  • 智能：设置克隆后新虚拟机的磁盘格式为qcow2。

  • 高速：设置克隆后新虚拟机的磁盘格式为raw。该格式结构简单，I/O效率高。

网络信息设置：

  • 虚拟交换机：选择克隆后新虚拟机虚拟交换机。

  • 网络参数：设置克隆后新虚拟机的IPv4/IPv6网络参数，包括默认、DHCP、手工分配，默认为“默认”。选择“默认”，表示系统不对克隆后新虚拟机的网络参数进行配置；选择“DHCP”，表示采用DHCP方式配置克隆后新虚拟机的网络参数；选择“手工分配”，表示手工配置克隆后新虚拟机的网络参数，具体参数如下：

  • IP地址：克隆后新虚拟机的IP地址。

  • 子网掩码：克隆后新虚拟机的子网掩码。

  • 默认网关：克隆后新虚拟机的默认网关。

  • 主DNS服务器：克隆后新虚拟机的主DNS服务器。

  • 备DNS服务器：克隆后新虚拟机的备DNS服务器。

  • 设置IPv4/IPv6绑定：是否将克隆后新虚拟机的网卡MAC与IP地址绑定。绑定后，若虚拟机网卡设置的IP地址与绑定IP不一致，则该网卡无法正常通信。


修改虚拟机

该功能用于修改虚拟机的各类配置信息，以及为虚拟机增加和删除硬件。

注意事项

  • 如果选择高速硬盘作为虚拟机的普通硬盘，需要更新其驱动程序才能正常使用，具体方法请参见常见问题。

  • 对于处于运行状态的虚拟机，只有增加或者删除高速类型硬盘的操作会实时生效，增加或者删除其它类型硬盘的操作将会在虚拟机下次启动时生效。

  • 对于处于“运行”状态的虚拟机，删除其网卡的操作，只有当操作系统支持在线删除网卡时才会立即生效，否则将会在虚拟机下次启动时生效。

  • 处于运行状态且拥有可用USB设备的虚拟机，在主机上对应的USB设备被拔插后，该虚拟机将无法正常访问对应的USB设备。管理员需要重启该虚拟机，虚拟机才能正常访问对应的USB设备。

  • 虚拟光驱挂载镜像文件后，在虚拟机操作系统中打开光驱，可能会不显示内容，需要先在虚拟机操作系统中弹出光驱，然后通过虚拟机控制台中的虚拟光驱或修改虚拟机页面中的“光驱”选项重新挂载镜像文件。

  • 更改虚拟机磁盘的总线类型的推荐方法如下：1、关闭虚拟机，请勿直接关闭电源；2、在修改虚拟机页面删除需要更改总线类型的磁盘；3、为虚拟机增加一个目标总线类型的磁盘，并将已删除磁盘的磁盘文件（块设备）作为新增磁盘的磁盘文件（块设备）；4、启动虚拟机完成磁盘总线类型的更改。

  • 加入到磁盘备份容灾类型保护组中的虚拟机，在修改虚拟机网络信息后，需要重启虚拟机的容灾客户端。

  • 虚拟机进行外部快照后，不能修改其磁盘的磁盘模式。

  • 由ARM老版本通过模板部署、升级或备份恢复到新ARM版的虚拟机，不支持在线添加硬件设备。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<修改虚拟机>按钮，弹出修改虚拟机对话框。

  3. 根据需要单击选项框中菜单项，修改虚拟机的配置信息。每完成一类配置信息的修改，需要单击<应用>按钮保存设置。

  4. 根据需要单击<增加硬件>按钮，为虚拟机增加存储、网络、USB设备、PCI设备等，（ARM架构的主机仅支持增加：存储、网络、输入、控制台、声卡、PCI设备、显卡）；还可选择不需要的硬件，如磁盘、网卡、光驱等，单击<删除硬件>按钮，删除相应硬件。

参数说明

X86架构服务器

1. 概要选项

  • 显示名称：虚拟机的显示名称（支持中文）。

  • 自动迁移：当集群动态资源调度和电源智能管理策略生效后是否允许虚拟机在集群内自动迁移。

  • 高可靠性：针对单个虚拟机设置开启或禁用高可靠性，默认为开启。当开启集群HA时，界面才显示该配置项。禁用虚拟机高可靠性后，虚拟机将不能被集群HA管理。

  • 时间同步：如果虚拟机的时间和当前物理主机的时间不一致，自动调整虚拟机时间调为当前物理主机的时间，使虚拟机与物理主机能够提供基于统一时间的多种应用。

  • CAStools自动升级：开启表示，当虚拟机操作系统安装的虚拟机代理工具版本低于当前管理平台提供的版本时，会自动升级代理工具，不开启设置则不会自动升级。系统缺省在凌晨一点钟对启用了自动升级功能的虚拟机进行代理工具升级，升级开始时间以虚拟机时间为参考，如果希望在统一时间升级代理工具，则需要启用“时间同步”功能。

  • 时钟设置：设置虚拟机的时钟，包括本地时钟、世界时钟。本地时钟指系统设置时间，世界时钟指UTC时间。

  • I/O优先级：与主机上的其它虚拟机相比，该虚拟机进程对主机物理磁盘读写的优先权，包括高、中、低。主机上磁盘数据读写速度有限，当多个虚拟机同时进行大量数据读写时，I/O优先级高的虚拟机可以优先对磁盘进行数据读写操作。

  • 启动优先级：虚拟机所在物理主机发生故障时，如果该主机加入了集群，且集群启用了HA功能，运行于这台主机上的所有虚拟机可以在集群中的其它主机上重新启动。根据虚拟机上承载业务的重要性级别，为虚拟机设置启动优先级。该虚拟机的启动优先级，包括缺省默认、低、中、高。该选项只有在虚拟机所在的主机已经加入到集群，且集群启用了HA功能时才需要配置。

  • 蓝屏故障策略：当该虚拟机发生故障时执行动作，包括不处理、故障重启、故障迁移。必须启用HA，且安装虚拟机代理工具，系统故障策略才能生效。

  • 不处理：表示不执行任何动作。

  • 故障重启：表示将虚拟机重启。

  • 故障迁移：表示将虚拟机迁移到集群中的其它主机上。

  • CAStools类型：虚拟机代理工具的类型，包括Virtio串口、普通串口。

  • 硬件版本：虚拟机所使用的QEMU版本。数值越大，版本越新。管理平台升级后，虚拟机的硬件版本也随之升级，因此虚拟机的硬件信息和操作系统可能会出现兼容性问题。如果存在兼容性问题，虚拟机会出现蓝屏或无法启动，此时建议回退虚拟机的硬件版本。

  • 完整性校验：在虚拟机启动时对其磁盘进行完整性校验，校验通过才允许启动虚拟机。磁盘完整性校验耗时较长。

2. CPU选项

  • CPU个数：设置虚拟机CPU的个数，其不能超过当前主机最大的CPU个数。对于支持CPU热添加的虚拟机修改其CPU个数后，虚拟机的操作系统可能会出现3~5秒运行缓慢的现象，之后即可恢复正常。此外，Linux操作系统的虚拟机不能在启动过程中进行CPU热添加操作。Windows 7操作系统由于自身系统特性的原因，最多只能有效使用2个CPU，为了提升处理性能，可以为每个CPU设置多个核。

  • CPU核数：设置虚拟机CPU的核数。

  • 绑定物理CPU：将虚拟机的虚拟CPU绑定到主机的一个或多个物理CPU上，绑定后的虚拟机不会使用主机的其它物理CPU。虚拟机绑定物理CPU后，不要关闭主机超线程，否则可能会导致vCPU和NUMA节点对应关系错乱，引起虚拟机启动异常。

  • NUMA节点：系统中NUMA节点数对应主机物理CPU数，单个CPU物理核数（如CPU支持超标量则还需乘超标量数值）即为NUMA节点内的CPU数量，NUMA节点编号从0开始。每个NUMA节点包含CPU，IO总线及内存资源。

  • CPU工作模式：设置CPU的工作模式，包括兼容模式、主机匹配模式、直通模式，默认为兼容模式。

  • 兼容模式：将不同的型号物理CPU虚拟成相同型号的vCPU，迁移兼容性好。

  • 主机匹配模式：将不同的物理CPU虚拟成不同型号的vCPU，迁移兼容性差，相对于兼容模式可以给虚拟机操作系统提供更优的性能。

  • 直通模式：直接将物理CPU暴露给虚拟机使用，迁移兼容性差，相对于兼容模式和主机匹配模式可以给虚拟机操作系统提供更优的性能。如果CPU工作模式设置为直通模式，则该虚拟机在迁移时，要求目的主机的与源主机的CPU型号必须保持一致。

  • 最大CPU：设置虚机可分配的最大CPU个数。虚拟机最大CPU值为：最大CPU个数*当前CPU核数。

  • 体系结构：设置虚拟机CPU架构，包括64位、32位，默认为64位。当CPU工作模式选择为“兼容模式”时，才可设置此参数。32位体系架构的CPU仅支持32bit操作系统，通常选择64位。对于64位操作系统的虚拟机，此参数必须设置为64位，否则关闭虚拟机后，将无法启动。

  • CPU调度优先级：设置虚拟机进程抢占物理CPU资源的抢占优先级，包括低、中、高，默认为中），支持在线修改。

  • 预留：设置预留一定量的CPU资源仅供该虚拟机使用。

  • 限制：设置虚拟机CPU单核允许使用主机CPU的最大频率。

  • 整机限制：选择是否启用整机限制。例：某虚拟机CPU共有4核，虚拟机CPU单核允许使用的频率限制为200MHz，开启整机限制后，则虚拟机整机允许使用主机CPU的最大频率为800MHz，此时单核可使用的频率可超过200MHz。

  • 在线缩容：选择是否允许在线减小CPU的个数。CPU在线缩容需要虚拟机操作系统的支持，若操作系统不支持CPU在线缩容，则界面不会显示此配置项。

  • Intel RDT防吵闹：选择是否开启Intel RDT防吵闹功能。开启后可以防止单个虚拟机占用太多的CPU缓存（上限为20%）和内存带宽（单个vCPU上限为10%），影响其他的虚拟机的CPU缓存和内存带宽使用。开启Intel RDT防吵闹功能之前，请先在系统参数设置中启用该功能。该功能需要主机CPU支持，如果主机不支持该功能，则虚拟机无法开启防吵闹功能。

3. 内存选项

  • 改变分配：设置虚拟机的内存容量。最大值不能超过主机内存容量。如果操作系统支持内存热添加（部分Linux操作系统需要安装虚拟机代理工具），则虚拟机在线添加内存后不需要重启虚拟机即可生效，如果操作系统不支持内存热添加，则需要关闭虚拟机后再修改内存。目前不支持对初始内存小于4GB，且挂接了IDE硬盘的Linux虚拟机进行内存热添加操作。

  • 预留：设置为虚拟机预留内存百分比。为了使内存有效使用，主机会按虚拟机实际内存使用量为其分配内存，上限为虚拟机配置的内存值。为了避免主机内存耗尽时，未达到内存使用上限的虚拟机无法继续使用更多的内存，可以设置为虚拟机预留一部分内存。

  • 限制：设置虚拟机允许使用主机内存的最大值。

  • 资源优先级：设置虚拟机申请内存资源的优先级，包括低、中、高。

  • 内存气球：开启后可在不关闭虚拟机情况下，通过Ballooning技术动态调整虚拟机内存，将主机内存按需分配。虚拟机进行内存热添加之后，不能直接配置内存气球。需要先关闭虚拟机，然后修改内存，再将其启动。待虚拟机启动后，才能配置虚拟机的内存气球。

  • 大页配置：设置虚拟机是否允许使用主机的大页内存。

4. 磁盘选项

  • 存储格式：设置虚拟机磁盘的存储格式，包括高速（raw）、智能（qcow2）。当虚拟机处于运行状态、存在快照或磁盘存在多级镜像文件的情况下，不允许修改虚拟机的存储格式。

  • 存储：设置虚拟机磁盘的存储容量大小。存储容量单位可选择MB、GB或TB，根据虚拟机所在存储池的可用容量选择存储容量单位。当虚拟机存在快照、磁盘存在多级镜像文件的情况或者磁盘预分配方式为置零、延迟置零的情况下，不允许修改虚拟机的磁盘容量。对于处于运行状态的虚拟机，在增加高速类型的磁盘容量之前，请确认该虚拟机是否正在进行数据传输。如果虚拟机正在进行数据传输，对高速类型磁盘的扩容操作，将可能会导致数据传输失败。

  • 分配的存储空间是用户数据空间。虚拟机磁盘镜像文件还包含系统空间，即虚拟机磁盘镜像文件容量＝系统空间容量＋用户数据空间容量。已用空间即虚拟机磁盘镜像文件占用实际存储的空间，可能会大于分配的存储空间。

  • 当虚拟机存在快照、磁盘存在多级镜像文件的情况或者磁盘预分配方式为置零、延迟置零的情况下，不允许修改虚拟机的磁盘容量。

  • 对于处于运行状态的虚拟机，为高速类型的磁盘增加容量之前，请确认该虚拟机是否正在进行数据传输。如果虚拟机正在进行数据传输，对高速类型磁盘的扩容操作，将可能会导致数据传输失败。

  • 预分配：存储卷的分配方式，包括：精简、延迟置零和置零。当虚拟机处于运行状态、虚拟机存在快照或虚拟机磁盘存在多级镜像文件时，此参数不支持修改。虚拟机磁盘类型为块设备时，此参数不可见。

  • 簇大小：文件占用磁盘空间的最小单位，默认为256KB。如果一个文件的容量大于单个簇大小，该文件将存储到多个簇中；如果一个文件的容量小于单个簇大小，该文件将独占一个簇。共享文件系统存放的文件多为虚拟机镜像文件，建议将簇大小设置的尽可能大，以增强磁盘读取数据的性能，又节约磁盘空间。当虚拟机处于运行状态、虚拟机存在快照或虚拟机磁盘存在多级镜像文件时，此参数不支持修改。虚拟机磁盘类型为块设备时，此参数不可见。

  • 磁盘模式：选择是否可以对磁盘进行外部快照。只有文件类型的磁盘才可以配置磁盘模式。虚拟机执行过外部快照后，不能修改其磁盘的磁盘模式。

  • 从属：虚拟机创建外部快照时包含该从属磁盘，对其进行外部快照。还原时也对该磁盘还原。

  • 独立-持久：虚拟机创建外部快照时，不对该磁盘进行快照，还原时也不对该磁盘还原。

  • 限制I/O速率：限制磁盘的最大读速率、写速率，单位为KB/s，默认为空（空表示不限制）。

  • 限制IOPS：限制磁盘每秒读请求、写请求的最大个数，默认为空（空表示不限制）。

  • 缓存方式：设置虚拟机存储文件的磁盘缓存方式，包括：直接读写、一级物理缓存、二级虚拟缓存、一级虚拟缓存。磁盘格式为“智能”（即qcow2格式）时，默认为直接读写（directsync），磁盘格式为raw、块设备（包括RBD）时，默认为一级虚拟缓存（none）。

  • 直接读写(Directsync)：指数据直接从物理磁盘读写。

  • 一级物理缓存(Writethrough)：指数据先写入主机缓存，再将主机缓存内的数据写入物理磁盘。

  • 二级虚拟缓存(Writeback)：指数据先写入虚拟机缓存，再将虚拟机缓存内的数据写入主机缓存，最终写入物理磁盘。

  • 一级虚拟缓存(None)：指数据先写入虚拟机缓存，再将虚拟机缓存内的数据直接写入物理磁盘。

  • Serial号：磁盘的序列号。

5. 网络选项

  • 虚拟交换机：设置虚拟机网卡连接的虚拟交换机。

  • 网络策略模板：设置虚拟机应用的网络策略模板。

  • 虚拟防火墙：设置虚拟机使用的虚拟防火墙。设置完成后，虚拟机的入方向和出方向数据报文将会根据防火墙的规则进行过滤。

  • MAC地址：设置虚拟机的MAC地址。

  • IPv4信息/IPv6信息：设置虚拟机的网络参数，包括IP/MAC绑定、手工配置和DHCP。

  • IP/MAC绑定表示配置网卡的IP地址，若虚拟机网卡设置的IP地址与绑定IP不一致，则该网卡无法正常通信；

  • 手工配置表示手工指定虚拟机的IP地址、子网掩码、默认网关、首选DNS和备选DNS，手工配置的网络参数需通过虚拟机代理工具进行设置，请确保虚拟机已安装了CAStools。

  • DHCP表示通过虚拟机代理工具配置网卡的网络参数，请确保虚拟机已安装了CAStools，并检查其它服务与代理工具是否冲突，例如：Linux虚拟机在设置网络信息前，需关闭NetworkManager服务。

  • 设备型号：设置虚拟机的网络适配器类型。当虚拟机网卡为普通网卡、高速网卡或Intel e1000网卡时，此参数的选项包括普通网卡、高速网卡和Intel e1000网卡。当虚拟机网卡为SR-IOV直通网卡时，此参数无法修改。

  • 内核加速：设置内核加速功能，开启后高速类型网卡将以单独一个线程的形式在CVK内核中进行模拟，可以提升虚拟机网络性能。当设备型号选择为“高速网卡”时，需设置此参数。

  • MTU：设置虚拟机网卡的最大传输单元。

  • 驱动类型：SR-IOV直通类型网卡的驱动类型。

  • VLAN ID：SR-IOV直通类型网卡所属的VLAN ID。

6. 更多选项

控制台选项

  • 启用VNC代理：设置虚拟机是否启用VNC代理。单击右侧 [image] 图标，可设置VNC代理服务器的参数，即输入VNC代理服务器IP地址、登录用户名和登录密码。如果登录虚拟化管理系统的方式为HTTPS，则需将代理服务器设置为虚拟化管理系统的IP地址。如果配置的VNC代理服务器为已经被管理系统管理的主机，则配置的VNC代理登录用户名及密码不生效。

显卡选项

  • 设备型号：设置虚拟机显卡的型号，包括Cirrus、Vga、Qxl。当虚拟机安装了Fedora19或Fedora20操作系统时，请不要将设备型号设置为“Cirrus”，否则将可能导致显示异常。

串口选项

  • 串口监听：是否启用串口监听功能。

引导设备选项

  • 自动启动：设置虚拟机是否在所在主机启动时同时启动。

  • 引导固件：设置虚拟机的启动引导方式，包括BIOS、UEFI。BIOS是基本输入/输出系统；UEFI指统一的可扩展固件接口。若引导固件选择“UEFI”，且多个光驱分别挂载不同的Windows系统安装文件时，虚拟机可能无法按照优先级最高的引导设备进行引导。

  • 虚拟机引导设备：设置虚拟机的引导设备，包括磁盘、光驱、网络。

虚拟NUMA设置选项

  • 虚拟NUMA：设置是否启用虚拟NUMA。启用后，可使虚拟NUMA节点上的CPU和内存资源优先分配在一个物理NUMA上。

“高级设置”选项中可修改的参数：

  • 保密配置：

  • 密级级别：设置虚拟机密级级别，包括绝密、机密、秘密，默认为秘密。

  • 防病毒配置：

  • 启用防病毒：开启虚拟机防病毒配置可以降低虚拟机遭受病毒攻击的风险，实现对虚拟机的保护。若要禁用防病毒，请在虚拟机关闭状态下设置。

  • 虚拟机的防病毒配置依赖管理系统的防病毒配置，具体请参见防病毒配置。

  • USB重定向策略配置：

  • USB重定向：启用USB重定向功能，使客户机的USB设备可以在远程桌面会话中使用。

  • USB重定向个数：设置USB重定向的数量，输入范围为1~4。

  • SPICE客户端接入策略配置：

  • 启用SSL：开启设置表示当使用SPICE客户端时，启用SSL加密功能。

  • SSL加密通道名称：选择对一个或多个通道进行SSL加密。可选的SSL加密通道有：主通道（main）、输入（input）、显示（display）、光标（cursor）、回放（playback）、录制（record）、智能卡（smartcard）、USB重定向（usbredir）。

7. 增加硬件选项

  • 硬件类型：增加硬件时虚拟机可选择的硬件资源类型，包括存储、网络、输入、控制台、声卡、USB设备、网络USB设备、PCI设备、显卡、串口、TPM设备、看门狗、GPU设备。

  • 增加“存储”：

  • 总线类型：虚拟磁盘的总线类型，包括IDE硬盘、SCSI硬盘、USB硬盘、高速硬盘、IDE光驱、软驱、高速SCSI硬盘。增加USB硬盘时，系统默认支持USB3.0接口，若系统无法识别，则需手动安装相应的驱动。相较SCSI硬盘，高速SCSI硬盘性能更优。软驱用于.vfd格式的软盘映象文件。

  • 类型：虚拟磁盘类型，包括文件、RBD块、块设备、本地磁盘。

  • 文件路径：存储卷路径。

  • 块设备路径：磁盘块设备路径。

  • 本地磁盘路径：主机中本地磁盘的路径。

  • 大小：磁盘容量。

  • 缓存方式：虚拟磁盘缓存方式，包括直接读写（directsync）、一级物理缓存（writethrough）、二级虚拟缓存（writeback）、一级虚拟缓存（none）。磁盘格式为“智能”（即qcow2格式）时，默认为直接读写（directsync），磁盘格式为raw、块设备（包括RBD）时，默认为一级虚拟缓存（none）。

  • 磁盘模式：选择是否可以对磁盘进行外部快照。只有文件类型的磁盘才可以配置磁盘模式。

  • 从属：虚拟机创建外部快照时包含该从属磁盘，对其进行外部快照。还原时也对该磁盘还原。

  • 独立-持久：虚拟机创建外部快照时，不对该磁盘进行快照，还原时也不对该磁盘还原。

  • 限制I/O速率：限制磁盘的最大读写速率，单位为KB/s，取值范围16~2147483647，默认为空，空表示不限制。

  • 限制IOPS：限制磁盘每秒读写请求的最大个数，取值范围16~2147483647，默认为值空，空表示不限制。

  • Serial号：磁盘的序列号。

  • 增加“网络”：

  • 设备型号：虚拟网卡的类型，包括普通网卡、高速网卡、Intel e1000网卡、SR-IOV直通网卡。

  • 内核加速：开启后高速类型网卡将以一个单独线程的形式在CVK内核中进行模拟，可以提升虚拟机网络性能。当设备型号选择为“高速网卡”时，需设置此参数。

  • 队列个数：设置虚拟网卡的队列个数，多队列可以提高虚拟网卡处理数据的性能，缺省值为1，最大值为vCPU的个数*核数。当设备型号选择为“高速网卡”并且开启内核加速时，需设置此参数。

  • 虚拟交换机：设置虚拟机网卡连接的虚拟交换机。

  • 网络策略模板：设置虚拟机的网络策略。

  • 虚拟防火墙：设置虚拟机使用的虚拟防火墙。设置完成后，虚拟机的入方向和出方向数据报文将会根据防火墙的规则进行过滤。

  • MAC地址分配方式：设置虚拟机MAC地址的获取方式，包括自动分配、手工指定。

  • MAC地址：虚拟机网卡的MAC地址。当MAC地址分配方式选择“手工指定”时该参数可输入。

  • 网卡绑定IPv4/Ipv6：设置与虚拟机网卡MAC地址绑定的IPv4/Ipv6地址。若虚拟机网卡设置的IPv4/Ipv6地址与绑定IPv4/Ipv6不一致，则该网卡无法正常通信。

  • MTU：设置虚拟机网卡的最大传输单元。默认为1500。当网络类型为“普通网卡”、“高速网卡”或“Intel e1000网卡”时，才能设置此参数。

  • 驱动类型：SR-IOV直通类型网卡的驱动类型。

  • 物理网卡：SR-IOV直通类型网卡使用的主机物理网卡。

  • VLAN ID：SR-IOV直通类型网卡所属的VLAN ID。

  • 增加“输入”设备：

  • 类型：输入设备的类型，包括写字板、鼠标。

  • 总线：输入设备使用的总线。

  • 增加“控制台”：

  • 类型：虚拟机控制台的类型，包括VNC、SPICE。

  • 密码：控制台登录密码。

  • 启用VNC代理：是否启用VNC代理。

  • 端口分配方式：控制台端口号的分配方式，包括自动分配、手工指定。

  • 端口：控制台端口号。当端口分配方式为“手工指定”时该参数可配置。

  • 键盘映射与主机一致：控制台磁盘映射方式是否与主机保持一致。

  • 其它：键盘映射方式。

  • 增加“声卡”：

  • 类型：虚拟声卡类型，包括ac97、ich6，默认为ac97。

  • 增加“显卡”：

  • 类型：虚拟显卡类型，包括Qxl。当虚拟机存在多个显卡时，系统会将所有显卡的类型都设置为Qxl。

  • 增加“USB设备”（ARM架构的主机暂不支持）：

  • 控制器：USB设备控制器类型，包括USB 1.0、USB 2.0、USB 3.0，默认为USB 2.0。

  • 设备名称：USB设备名称。

  • 供应商：USB供应商名称。

  • 产品名称：USB产品名称。

  • 增加“网络USB设备”（ARM架构的主机暂不支持）：

  • 控制器：网络USB设备控制器类型，包括USB 1.0、USB 2.0、USB 3.0，默认为USB 2.0。

  • 网络USB视图：查看当前集群的网络USB被虚拟机使用的情况。

  • 设备名称：网络USB设备名称。

  • 供应商：网络USB设备的供应商名称。

  • 产品名称：网络USB设备的产品名称。

  • 状态：网络USB设备的状态

  • 操作：启动或者暂停网络USB设备

  • 增加“PCI设备”：在给虚拟机增加PCI设备时，对于内存小于2G的虚拟机，其PCI设备的内存总和不建议超过2G；对于内存大于2G的虚拟机，其PCI设备的内存总和不建议超过1G，否则可能导致虚拟机无法正常启动。

  • 驱动类型：虚拟机PCI设备的驱动类型。

  • 设备名称：PCI设备名称。

  • 供应商：PCI供应商名称。

  • 产品名称：PCI产品名称。

  • 物理接口：物理网卡。

  • 增加“串口”：

  • 类型：串口的类型，包括Physical host character device (dev)、Pseudo TTy(pty)，默认为Physical host character device (dev)。

  • 串口号：根据串口号来识别不同的串口。

  • 路径：主机串口路径。如果选择增加dev类型的串口，必须输入可用的路径（如：/dev/ttyS0），否则会导致虚拟机无法启动。

  • 增加“TPM设备”：

  • TPM设备：TPM（Trusted Platform Module）可信平台模块，可以有效的保护虚拟机，防止非法用户的访问。

  • 设备位置：TPM的设备位置。

  • 增加“看门狗”：

  • 处理方式：中断响应处理虚拟机方式，包括重启、关闭、迁移，默认为重启。

  • 增加“GPU设备”：

  • GPU设备：GPU（图形处理单元），它把CPU从图形处理任务中解放出来，让CPU可以执行其他更多的系统任务。

  • GPU资源池：选择虚拟机使用的GPU资源池。选择GPU类型的资源池时，虚拟机以直通方式使用主机的物理GPU资源；选择vGPU类型的资源池时，虚拟机使用主机的vGPU资源。

  • 业务模板：定义了虚拟机使用资源的优先级，当资源池中的资源紧张时，高优先级的虚拟机优先获取相关资源。

  • 驱动类型：虚拟机GPU设备的驱动类型。

  • 资源独占：虚拟机是否独享GPU/vGPU资源。选择“否”，表示虚拟机在关闭状态下不会绑定GPU/vGPU资源。选择“是”，无论虚拟机处于何种状态，虚拟机会一直绑定GPU/vGPU资源，该GPU/vGPU资源为虚拟机独享，不能被其他虚拟机使用。只有当宿主机存在空闲GPU/vGPU资源，且该空闲资源已加入所选GPU资源池时，才允许开启资源独占。开启资源独占后，当集群内其他主机有满足条件的GPU/vGPU资源时，虚拟机在关机状态下允许迁移至该主机上，否则不允许迁移虚拟机。

  • 资源个数：设置虚拟机使用GPU/vGPU资源的数量。选择vGPU类型的资源池时，资源个数最大值为1。选择GPU类型的资源池，且未开启资源独占，资源个数最大值为该资源池内单个主机的最大GPU数量，例如在该资源池中A主机有3个GPU，B主机有2个，C主机有2个，则最大值为3；若开启了资源独占，则资源个数最大值为该资源池内宿主机的空闲GPU数量。

ARM架构服务器

1. 概要选项

  • 显示名称：虚拟机的显示名称（支持中文）。

  • 自动迁移：当集群动态资源调度和电源智能管理策略生效后是否允许虚拟机在集群内自动迁移。

  • 高可靠性：针对单个虚拟机设置开启或禁用高可靠性，默认为开启。当开启集群HA时，界面才显示该配置项。禁用虚拟机高可靠性后，虚拟机将不能被集群HA管理。

  • 时间同步：如果虚拟机的时间和当前物理主机的时间不一致，自动调整虚拟机时间调为当前物理主机的时间，使虚拟机与物理主机能够提供基于统一时间的多种应用。

  • CAStools自动升级：开启表示，当虚拟机操作系统安装的代理工具版本低于当前管理平台提供的版本时，会自动升级代理工具，不开启设置则不会自动升级。系统缺省在凌晨一点钟对启用了自动升级功能的虚拟机进行代理工具升级，升级开始时间以虚拟机时间为参考，如果希望在统一时间升级代理工具，则需要启用“时间同步”功能。

  • 时钟设置：设置虚拟机的时钟，包括本地时钟、世界时钟。本地时钟指系统设置时间，世界时钟指UTC时间。

  • 启动优先级：虚拟机所在物理主机发生故障时，如果该主机加入了集群，且集群启用了HA功能，运行于这台主机上的所有虚拟机可以在集群中的其它主机上重新启动。根据虚拟机上承载业务的重要性级别，为虚拟机设置启动优先级。该虚拟机的启动优先级，包括缺省默认、低、中、高。该选项只有在虚拟机所在的主机已经加入到集群，且集群启用了HA功能时才需要配置。

  • CAStools类型：虚拟机代理工具的类型，ARM架构的主机仅支持Virtio串口。

  • 硬件版本：虚拟机所使用的QEMU版本。ARM架构的主机目前仅支持QEMU 2.12版本。

  • 完整性校验：在虚拟机启动时对其磁盘进行完整性校验，校验通过才允许启动虚拟机。磁盘完整性校验耗时较长。

2. CPU选项

  • CPU个数：设置虚拟机CPU的个数，其不能超过当前主机最大的CPU个数。

  • CPU核数：设置虚拟机CPU的核数。

  • 绑定物理CPU：将虚拟机的虚拟CPU绑定到主机的一个或多个物理CPU上，绑定后的虚拟机不会使用主机的其它物理CPU。虚拟机绑定物理CPU后，不要关闭主机超线程，否则可能会导致vCPU和NUMA节点对应关系错乱，引起虚拟机启动异常。

  • NUMA节点：系统中NUMA节点数对应主机物理CPU数，单个CPU物理核数（如CPU支持超标量则还需乘超标量数值）即为NUMA节点内的CPU数量，NUMA节点编号从0开始。每个NUMA节点包含CPU，IO总线及内存资源。

  • CPU工作模式：设置CPU的工作模式，仅支持直通模式，即直接将物理CPU暴露给虚拟机使用，可以给虚拟机操作系统提供更优的性能。虚拟机在迁移时，要求目的主机的与源主机的CPU型号必须保持一致。

  • CPU调度优先级：设置虚拟机进程对物理CPU资源的抢占优先级，包括高、中、低，默认为中。

  • CPU预留：设置预留一定量的CPU资源仅供该虚拟机使用。

  • CPU限制：设置虚拟机CPU单核允许使用主机CPU的最大频率。

  • 整机限制：选择是否启用整机限制。例：某虚拟机CPU共有4核，虚拟机CPU单核允许使用的频率限制为2GHz，开启整机限制后，则虚拟机整机允许使用主机CPU的最大频率为8GHz，此时单核可使用的频率可超过2GHz。

3. 内存选项

  • 改变分配：设置虚拟机的内存容量。最大值不能超过主机内存容量。如果操作系统支持内存热添加（部分Linux操作系统需要安装CAStools），则虚拟机在线添加内存后不需要重启虚拟机即可生效，如果操作系统不支持内存热添加，则需要关闭虚拟机后再修改内存。目前不支持对初始内存小于4GB，且挂接了IDE硬盘的Linux虚拟机进行内存热添加操作。

  • 预留：设置为虚拟机预留内存百分比。为了使内存有效使用，主机会按虚拟机实际内存使用量为其分配内存，上限为虚拟机配置的内存值。为了避免主机内存耗尽时，未达到内存使用上限的虚拟机无法继续使用更多的内存，可以设置为虚拟机预留一部分内存。

  • 限制：设置虚拟机允许使用主机内存的最大值。

  • 资源优先级：设置虚拟机申请内存资源的优先级，包括低、中、高。

  • 大页配置：设置虚拟机是否允许使用主机的大页内存。

4. 磁盘选项

  • 存储格式：设置虚拟机磁盘的存储格式，包括高速（raw）、智能（qcow2）。当虚拟机处于运行状态、存在快照或磁盘存在多级镜像文件的情况下，不允许修改虚拟机的存储格式。

  • 存储：设置虚拟机磁盘的存储容量大小。存储容量单位可选择MB、GB或TB，根据虚拟机所在存储池的可用容量选择存储容量单位。当虚拟机存在快照、磁盘存在多级镜像文件的情况或者磁盘预分配方式为置零、延迟置零的情况下，不允许修改虚拟机的磁盘容量。对于处于运行状态的虚拟机，在增加高速类型的磁盘容量之前，请确认该虚拟机是否正在进行数据传输。如果虚拟机正在进行数据传输，对高速类型磁盘的扩容操作，将可能会导致数据传输失败。

  • 分配的存储空间是用户数据空间。虚拟机磁盘镜像文件还包含系统空间，即虚拟机磁盘镜像文件容量＝系统空间容量＋用户数据空间容量。已用空间即虚拟机磁盘镜像文件占用实际存储的空间，可能会大于分配的存储空间。

  • 当虚拟机存在快照、磁盘存在多级镜像文件的情况或者磁盘预分配方式为置零、延迟置零的情况下，不允许修改虚拟机的磁盘容量。

  • 对于处于运行状态的虚拟机，为高速类型的磁盘增加容量之前，请确认该虚拟机是否正在进行数据传输。如果虚拟机正在进行数据传输，对高速类型磁盘的扩容操作，将可能会导致数据传输失败。

  • 预分配：存储卷的分配方式，包括：精简、延迟置零和置零。当虚拟机处于运行状态、虚拟机存在快照或虚拟机磁盘存在多级镜像文件时，此参数不支持修改。虚拟机磁盘类型为块设备时，此参数不可见。

  • 簇大小：文件占用磁盘空间的最小单位，默认为256KB。如果一个文件的容量大于单个簇大小，该文件将存储到多个簇中；如果一个文件的容量小于单个簇大小，该文件将独占一个簇。共享文件系统存放的文件多为虚拟机镜像文件，建议将簇大小设置的尽可能大，以增强磁盘读取数据的性能，又节约磁盘空间。当虚拟机处于运行状态、虚拟机存在快照或虚拟机磁盘存在多级镜像文件时，此参数不支持修改。虚拟机磁盘类型为块设备时，此参数不可见。

  • 磁盘模式：选择是否可以对磁盘进行外部快照。只有文件类型的磁盘才可以配置磁盘模式。

  • 从属：虚拟机创建外部快照时包含该从属磁盘，对其进行外部快照。还原时也对该磁盘还原。

  • 独立-持久：虚拟机创建外部快照时，不对该磁盘进行快照，还原时也不对该磁盘还原。

  • 限制I/O速率：限制磁盘的最大读速率、写速率，单位为KB/s，默认为空（空表示不限制）。

  • 限制IOPS：限制磁盘每秒读请求、写请求的最大个数，默认为空（空表示不限制）。

  • 缓存方式：设置虚拟机存储文件的磁盘缓存方式，包括：直接读写、一级物理缓存、二级虚拟缓存、一级虚拟缓存。磁盘格式为“智能”（即qcow2格式）时，默认为直接读写（directsync），磁盘格式为raw、块设备（包括RBD）时，默认为一级虚拟缓存（none）。

  • 直接读写(Directsync)：指数据直接从物理磁盘读写。

  • 一级物理缓存(Writethrough)：指数据先写入主机缓存，再将主机缓存内的数据写入物理磁盘。

  • 二级虚拟缓存(Writeback)：指数据先写入虚拟机缓存，再将虚拟机缓存内的数据写入主机缓存，最终写入物理磁盘。

  • 一级虚拟缓存(None)：指数据先写入虚拟机缓存，再将虚拟机缓存内的数据直接写入物理磁盘。

  • Serial号：磁盘的序列号。

5. 网络选项

  • 虚拟交换机：设置虚拟机网卡连接的虚拟交换机。

  • 网络策略模板：设置虚拟机应用的网络策略模板。

  • 虚拟防火墙：设置虚拟机使用的虚拟防火墙。设置完成后，虚拟机的入方向和出方向数据报文将会根据防火墙的规则进行过滤。

  • MAC地址：设置虚拟机的MAC地址。

  • IPv4信息/IPv6信息：设置虚拟机的网络参数，包括IP/MAC绑定、手工配置和DHCP。

  • IP/MAC绑定表示配置网卡的IP地址，若虚拟机网卡设置的IP地址与绑定IP不一致，则该网卡无法正常通信；

  • 手工配置表示手工指定虚拟机的IP地址、子网掩码、默认网关、首选DNS和备选DNS，手工配置的网络参数需通过虚拟机代理工具进行设置，请确保虚拟机已安装了虚拟机代理工具。

  • DHCP表示通过虚拟机代理工具配置网卡的网络参数，请确保虚拟机已安装了CAStools，并检查其它服务与代理工具是否冲突，例如：Linux虚拟机在设置网络信息前，需关闭NetworkManager服务。

  • 设备型号：设置虚拟机的网络适配器类型。当虚拟机网卡为普通网卡、高速网卡或Intel e1000网卡时，此参数的选项包括普通网卡、高速网卡和Intel e1000网卡。

  • 内核加速：设置内核加速功能，开启后高速类型网卡将以单独一个线程的形式在CVK内核中进行模拟，可以提升虚拟机网络性能。当设备型号选择为“高速网卡”时，需设置此参数。

  • MTU：设置虚拟机网卡的最大传输单元。

6. 更多选项

控制台选项

  • 启用VNC代理：设置虚拟机是否启用VNC代理。单击右侧 [image] 图标，可设置VNC代理服务器的参数，即输入VNC代理服务器IP地址、登录用户名和登录密码。如果登录虚拟化管理系统的方式为HTTPS，则需将代理服务器设置为管理系统的IP地址。如果配置的VNC代理服务器为已经被管理系统管理的主机，则配置的VNC代理登录用户名及密码不生效。

显卡选项

  • 设备型号：设置虚拟机显卡的型号，包括Vga、Qxl。

串口选项

  • 串口监听：是否启用串口监听功能。

引导设备选项

  • 自动启动：设置虚拟机是否在所在主机启动时同时启动。

  • 虚拟机引导设备：设置虚拟机的引导设备，包括磁盘、光驱、网络。

7. 增加硬件选项

  • 硬件类型：增加硬件时虚拟机可选择的硬件资源类型，包括存储、网络、输入、控制台、声卡、显卡、PCI设备。由ARM老版本通过模板部署、升级或备份恢复到新ARM版的虚拟机，不支持在线添加硬件设备。

  • 增加“存储”：

  • 总线类型：虚拟磁盘的总线类型，包括光驱、软驱、高速硬盘、高速SCSI硬盘。

  • 类型：虚拟磁盘类型，包括文件、RBD块、块设备、本地磁盘。

  • 文件路径：存储卷路径。

  • 块设备路径：磁盘块设备路径。

  • 本地磁盘路径：主机中本地磁盘的路径。

  • 大小：磁盘容量。

  • 缓存方式：虚拟磁盘缓存方式，包括直接读写（directsync）、一级物理缓存（writethrough）、二级虚拟缓存（writeback）、一级虚拟缓存（none）。磁盘格式为“智能”（即qcow2格式）时，默认为直接读写（directsync），磁盘格式为raw、块设备时，默认为一级虚拟缓存（none）。

  • 磁盘模式：选择是否可以对磁盘进行外部快照。只有文件类型的磁盘才可以配置磁盘模式。

  • 从属：虚拟机创建外部快照时包含该从属磁盘，对其进行外部快照。还原时也对该磁盘还原。

  • 独立-持久：虚拟机创建外部快照时，不对该磁盘进行快照，还原时也不对该磁盘还原。

  • 限制I/O速率：限制磁盘的最大读写速率，单位为KB/s，取值范围16~2147483647，默认为空，空表示不限制。

  • 限制IOPS：限制磁盘每秒读写请求的最大个数，取值范围16~2147483647，默认为值空，空表示不限制。

  • Serial号：磁盘的序列号。

  • 增加“网络”：

  • 设备型号：虚拟网卡的类型，包括普通网卡、高速网卡、Intel e1000网卡。

  • 内核加速：开启后高速类型网卡将以一个单独线程的形式在CVK内核中进行模拟，可以提升虚拟机网络性能。当设备型号选择为“高速网卡”时，需设置此参数。

  • 队列个数：设置虚拟网卡的队列个数，多队列可以提高虚拟网卡处理数据的性能，缺省值为1，最大值为vCPU的个数*核数。当设备型号选择为“高速网卡”并且开启内核加速时，需设置此参数。

  • 虚拟交换机：设置虚拟机网卡连接的虚拟交换机。

  • 网络策略模板：设置虚拟机的网络策略。

  • 虚拟防火墙：设置虚拟机使用的虚拟防火墙。设置完成后，虚拟机的入方向和出方向数据报文将会根据防火墙的规则进行过滤。

  • MAC地址分配方式：设置虚拟机MAC地址的获取方式，包括自动分配、手工指定。

  • MAC地址：虚拟机网卡的MAC地址。当MAC地址分配方式选择“手工指定”时该参数可输入。

  • 网卡绑定IPv4/Ipv6：设置与虚拟机网卡MAC地址绑定的IPv4/Ipv6地址。若虚拟机网卡设置的IPv4/Ipv6地址与绑定IPv4/Ipv6不一致，则该网卡无法正常通信。

  • MTU：设置虚拟机网卡的最大传输单元。默认为1500。当网络类型为“普通网卡”、“高速网卡”或“Intel e1000网卡”时，才能设置此参数。

  • 增加“输入”设备：

  • 类型：输入设备的类型，包括写字板、鼠标。

  • 总线：输入设备使用的总线。

  • 增加“控制台”：

  • 类型：虚拟机控制台的类型，包括VNC、SPICE。

  • 密码：控制台登录密码。

  • 启用VNC代理：是否启用VNC代理。

  • 端口分配方式：控制台端口号的分配方式，包括自动分配、手工指定。

  • 端口：控制台端口号。当端口分配方式为“手工指定”时该参数可配置。

  • 键盘映射与主机一致：控制台磁盘映射方式是否与主机保持一致。

  • 其它：键盘映射方式。

  • 增加“声卡”：

  • 类型：虚拟声卡类型，包括ac97、ich6，默认为ac97。

  • 增加“PCI设备”：在给虚拟机增加PCI设备时，对于内存小于2G的虚拟机，其PCI设备的内存总和不建议超过2G；对于内存大于2G的虚拟机，其PCI设备的内存总和不建议超过1G，否则可能导致虚拟机无法正常启动。

  • 驱动类型：虚拟机PCI设备的驱动类型。

  • 设备名称：PCI设备名称。

  • 供应商：PCI供应商名称。

  • 产品名称：PCI产品名称。

  • 物理接口：物理网卡。

  • 增加“显卡”：

  • 类型：虚拟显卡类型，包括Qxl。当虚拟机存在多个显卡时，系统会将所有显卡的类型都设置为Qxl。


迁移虚拟机

迁移虚拟机是指更改虚拟机的运行载体，包括计算资源和存储资源，如更改虚拟机运行的主机、更改虚拟机磁盘（镜像文件）所在的存储池等。

虚拟机迁移分类

根据虚拟机的状态可分为在线迁移和离线迁移两种方式：

  • 在线迁移是指迁移运行状态的虚拟机。在进行在线迁移虚拟机之前，请确保目的主机的内存充足，否则将会导致虚拟机迁移失败。

  • 离线迁移是指迁移关闭状态的虚拟机。

根据应用模式可分为动态迁移和手工迁移：

  • 动态迁移：集群内主机上的虚拟机在运行时的动态迁移。典型应用场景是集群内主机故障或资源分配严重不均衡，或者配置了电源管理策略；通过集群的HA、DRS和DPM功能可以实现虚拟机的动态迁移。

  • 手工迁移：人为控制的虚拟机迁移。典型应用场景是管理员在日常运维或者巡检时，手工对虚拟机的运行载体（主机或数据存储）进行变更，以达到系统运行最优化的目的。比如需要对主机进行硬件升级，可以利用手工迁移的方式，将该主机上的虚拟机全部迁移至其他正常工作的主机上，然后对主机进行关机和维护处理，硬件升级完成后，再将虚拟机手工迁移回来。

系统提供的三种手工迁移方式

  • 更改主机：将虚拟机迁移到另一台主机上。只有使用共享存储池的虚拟机，才允许以此方式迁移，且目的主机必须挂载该共享存储池。

  • 更改数据存储：将虚拟机的磁盘迁移到该虚拟机所在主机的其他存储池中。

  • 更改主机和数据存储：将虚拟机迁移到另一台主机上，并将其磁盘迁移到目的主机所挂载的存储池中。目的主机可以是云资源中的任意一台主机。

不同状态虚拟机迁移时使用的网络说明

迁移方式 | 更改主机 | 更改数据存储 | 更改主机和数据存储
在线迁移 | 迁移网络、管理网络 | 管理网络 | 迁移网络、管理网络
离线迁移 | 管理网络 | 管理网络 | 迁移网络、管理网络

  • 关于管理网络与迁移网络的详细介绍，请参见主机虚拟交换机。

以“更改主机和数据存储”的方式迁移虚拟机，或以“更改主机”的方式迁移在线虚拟机时：

  • 若源主机和目的主机的迁移网络可达，则优先使用迁移网络进行迁移，且迁移过程中源主机与目的主机的管理网络需能正常通信，以传输配置信息和控制命令。

  • 若源主机和目的主机的迁移网络不可达，则通过管理网络迁移虚拟机。

迁移超时时长

手工迁移运行状态的虚拟机时，需要设置迁移超时时长。若超时时长到期后虚拟机还未完成迁移，则系统将暂停该虚拟机，以便其可以快速完成迁移；迁移完成后，再将该虚拟机恢复为运行状态。

迁移超时时长的计时起点根据迁移方式的不同，存在如下区别：

  • 以“更改主机”和“更改主机和数据存储”方式在线迁移虚拟机时，迁移超时时长是从迁移虚拟机时开始计时。

  • 以“更改数据存储”方式在线迁移虚拟机时，迁移超时时长是从虚拟机所有待迁移磁盘均拷贝到对应目的存储池后，更新第一个磁盘的脏数据时开始计时。（脏数据：虚拟机迁移过程中产生的数据。）

本节主要介绍手工迁移虚拟机的配置方法。

注意事项

  • 不支持以“更改数据存储”、“更改主机和数据存储”的方式在线迁移磁盘为RBD块的虚拟机。

  • 在迁移虚拟机时，请确保目的存储池可用空间充足，目的主机的CPU和内存资源足够，否则可能导致迁移失败，或迁移后虚拟机启动失败或者启动缓慢。

  • 以“更改数据存储”或者“更改主机和数据存储”方式迁移虚拟机时，需确保源存储池的空闲容量，大于虚拟机存储卷的容量，才能成功迁移数据存储。当迁移后虚拟磁盘格式与源虚拟机不同时，还需确保目的存储池的可用空间至少是源虚拟机存储卷容量的两倍，否则可能导致迁移失败。

  • 以“更改主机”或“更改主机和数据存储”方式迁移虚拟机时，在虚拟机未完全迁移完成时，目的主机的虚拟机列表中可能会出现两条该虚拟机的记录，待迁移完成后，只保留一条记录。

  • 虚拟机存在快照时，迁移虚拟机的存储只能在同为文件系统类型的存储池之间或同分布式存储资源的RBD网络存储池之间进行。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<迁移>按钮，弹出迁移虚拟机对话框。

  3. 根据配置向导完成虚拟机的迁移。

参数说明

迁移类型设置：

  • 更改主机：将虚拟机迁移到另一台主机上。只有使用共享存储池的虚拟机，才允许以此方式迁移，且目的主机必须挂载该共享存储池。

  • 更改数据存储：将虚拟机的磁盘迁移到该虚拟机所在主机的其他存储池中。

  • 更改主机和数据存储：将虚拟机迁移到另一台主机上，并将其磁盘迁移到目的主机所挂载的存储池中。目的主机可以是云资源中的任意一台主机。

  • 迁移超时时长：手工迁移运行状态的虚拟机时，需要设置迁移超时时长。若超时时长到期后虚拟机还未完成迁移，则系统将暂停该虚拟机，以便其可以快速完成迁移；迁移完成后，再将该虚拟机恢复为运行状态。默认为5分钟。当该参数设置为0时，系统将不会暂停虚拟机，虚拟机在迁移过程中始终处于运行状态。迁移超时时长的计时起点根据迁移方式的不同，存在如下区别：

  • 以“更改主机”和“更改主机和数据存储”方式在线迁移虚拟机时，迁移超时时长是从迁移虚拟机的时刻起开始计时。

  • 以“更改数据存储”方式在线迁移虚拟机时，迁移超时时长是从虚拟机磁盘拷贝到目的存储池后，向磁盘更新脏数据的时刻起开始计时。（脏数据：虚拟机迁移过程中产生的数据。）

  • 压缩：迁移运行或暂停状态的虚拟机时，将需要传输的数据进行压缩，减少数据传输的总量。

目标存储设置：

  • 指定格式：选择迁移后虚拟机的磁盘格式，包括不变、智能、高速，默认为不变。所选目的存储池的类型是本地文件目录、共享文件系统或NFS网络文件系统时，该参数的设置才会生效。若迁移虚拟机的磁盘中存在基础镜像文件，则该虚拟机的磁盘格式无法改变。

  • 不变：虚拟机被迁移到目的主机或存储后的磁盘格式与迁移前保持一致。

  • 智能：虚拟机被迁移到目的主机或存储后的磁盘格式为qcow2。

  • 高速：虚拟机被迁移到目的主机或存储后的磁盘格式为raw。该格式结构简单，I/O效率高。


删除虚拟机

该功能用于删除指定的虚拟机。

注意事项

  • 无论虚拟机是否处于“运行”状态，删除操作都将会强制执行。因此误删除虚拟机时会导致数据丢失，请谨慎操作。

  • 若虚拟机存在块设备，当虚拟机删除后，将无法通过向主机导入虚拟机备份文件还原此虚拟机。

  • “低格并删除虚拟机的数据存储文件”方式删除虚拟机，会先将虚拟机的存储数据低级格式化，然后再删除文件，如果存储卷较大时，可能耗时较长，请谨慎使用该选项。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<删除>按钮，弹出删除虚拟机对话框。

  3. 选择删除虚拟机的方式，包括移入回收站、保留虚拟机的数据存储文件、删除虚拟机的数据存储文件。

  • 当虚拟机删除方式选择“移入回收站”或“保留虚拟机的数据存储文件”时，单击<确定>按钮，弹出删除确认对话框，单击<确定>按钮完成操作。

  • 当虚拟机删除方式选择“删除虚拟机的数据存储文件”或“低格并删除虚拟机的数据存储文件”时，单击<确定>按钮，弹出删除确认对话框，单击<确定>按钮，再次弹出删除确认对话框。在删除确认对话框的输入框中，根据提示输入“DELETE”，单击<确定>按钮完成操作。


虚拟机状态管理

虚拟机状态管理主要包括启动虚拟机、安全关闭虚拟机、关闭虚拟机电源、暂停虚拟机、恢复虚拟机、休眠虚拟机、重启虚拟机等操作。

  • 启动虚拟机：启动处于关闭状态的虚拟机，从而使虚拟机正常开始工作。

  • 安全关闭虚拟机：关闭虚拟机的电源。在关闭虚拟机之前，会首先保存虚拟机系统的数据。

  • 关闭虚拟机电源：将虚拟机强制断电，使其处于关闭状态。

  • 暂停虚拟机：暂停处于运行状态的虚拟机。虚拟机暂停时，内存中的数据仍保留在内存中，只是虚拟机处于停止运行状态。

  • 恢复虚拟机：将处于暂停状态的虚拟机恢复到运行状态。

  • 休眠虚拟机：将处于运行或者暂停状态的虚拟机休眠，使其处于关闭状态。执行虚拟机休眠操作后，系统先将内存中的数据暂时以文件的方式保存在硬盘中，然后切断虚拟机的电源，休眠虚拟机。

  • 重启虚拟机：重启处于运行或者暂停状态的虚拟机。当虚拟机出现故障停机，或虚拟机配置发生变更（如增减CPU个数、内存大小、磁盘大小等）时，需要重启虚拟机。

注意事项

  • 在关闭虚拟机电源时，虚拟机中未保存的数据会丢失，应尽量正常关闭虚拟机，避免直接关闭虚拟机电源导致数据丢失。

  • 安全关闭虚拟机是系统向虚拟机发出关机指令，虚拟机是否能够正常关闭，取决于虚拟机操作系统，即在系统中关闭虚拟机成功后，虚拟机的实际状态可能与系统中显示的不同。

启动虚拟机

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<启动>按钮，弹出启动虚拟机确认对话框。

  3. 单击<确定>按钮完成操作。

安全关闭虚拟机

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<安全关闭>按钮，弹出关闭虚拟机确认对话框。

  3. 单击<确定>按钮完成操作。

关闭虚拟机电源

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<关闭电源>按钮，弹出关闭虚拟机确认对话框。

  3. 单击<确定>按钮完成操作。

暂停虚拟机

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<更多操作>按钮，选择[暂停]菜单项，弹出暂停虚拟机确认对话框。

  3. 单击<确定>按钮完成操作。

恢复虚拟机

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<更多操作>按钮，选择[恢复]菜单项，弹出恢复虚拟机确认对话框。

  3. 单击<确定>按钮完成操作。

休眠虚拟机

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<更多操作>按钮，选择[休眠]菜单项，弹出休眠虚拟机确认对话框。

  3. 单击<确定>按钮完成操作。

重启虚拟机

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<更多操作>按钮，选择[重启]菜单项，弹出重启虚拟机确认对话框。

  3. 单击<确定>按钮完成操作。


虚拟机快照管理

虚拟机快照是某一时刻虚拟机状态的副本，可以保存虚拟机的设置和磁盘数据，用于虚拟机数据的还原和恢复。为虚拟机升级操作系统、安装新应用软件或升级应用软件之前，可以先为虚拟机创建快照。当虚拟机因为上述操作引起系统崩溃或者软件运行异常时，可以通过快照快速的恢复虚拟机。如需周期性的为虚拟机创建快照，请参见快照策略管理。

虚拟机的快照可以分为外部快照和内部快照两种，两种快照方式不能混用，当虚拟机已经创建了内部快照，再次快照只能选择继续内部快照，同理，虚拟机创建了外部快照后，再次快照也只能继续外部快照。

1. 内部快照

在创建快照时，会将当前磁盘中已分配的簇（cluster）置为只读，标记为已被快照引用，当有新的写IO请求，要修改某个簇时，将该簇中的数据复制出来，创建一个新的簇，后续对该簇的编辑将保存在这个新簇中。由于虚拟机的内部快照存储在其基础磁盘文件中，当虚拟机的磁盘文件遭到损坏或者误删除时，快照数据也会随之丢失。

删除内部快照时，会释放磁盘空间。为避免磁盘文件过大，建议控制快照个数，必要时通过删除虚拟机快照会释放磁盘空间。

2. 外部快照

创建快照时，当前磁盘被置为只读，系统在磁盘所在存储路径中创建增量镜像文件，后续对该磁盘数据的编辑保存在增量镜像文件中。对该磁盘再次创建快照时，原磁盘和当前增量镜像文件均被置为只读，系统会在数据存储中再创建一个增量镜像文件，形成一个具有数据依赖关系的镜像链。由于外部快照是通过创建增量镜像文件的方式存储增量数据的，因此对虚拟机业务影响较小，比较适合业务变化频繁的虚拟机。

删除外部快照不会更改虚拟机或其他快照。删除快照时，会进行镜像合并，将快照后的增量镜像文件的数据写入到上一级镜像文件中 。为避免快照过多，导致镜像链过长，影响虚拟机性能，建议控制快照个数，必要时通过删除快照，缩短镜像链，提高性能。

当虚拟机镜像经过多次外部快照、还原等操作后，可能存在冗余增量镜像文件，例如删除了外部快照，但其关联的增量镜像文件没有合并到上一级镜像时。冗余增量镜像文件过多会影响虚拟机性能，通过精简镜像链功能，对镜像链中的镜像进行合并，以减少镜像链层级，加快磁盘读取速度。精简镜像链时，在不影响数据依赖关系的前提下，增量镜像文件会被合并到其上一级镜像。

注意事项

  • 由于快照会导致虚拟机磁盘文件增大，需保证待创建快照的虚拟机的镜像文件所在存储池有足够的剩余容量。

  • 一个虚拟机可以创建多个快照，为避免磁盘文件过大，或镜像链过长，建议不要创建过多的快照，必要时通过删除虚拟机快照会释放磁盘空间，或提高虚拟机性能。

  • 内部快照只支持磁盘为智能（qcow2）格式或者RBD块的虚拟机。虚拟机磁盘为RBD块时，暂不支持在线的内存快照。

  • 虚拟机创建外部快照时，只对磁盘模式为“从属”的磁盘进行快照。

  • 在创建虚拟机快照和通过虚拟机快照还原虚拟机的过程中，请尽量避免修改虚拟机的配置信息，否则通过快照恢复虚拟机时，可能会出现恢复失败的情况。

  • 快照虚拟机时，将不会快照虚拟机的GPU配置信息。同理，虚拟机的GPU配置也不受快照还原的影响。

创建快照

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<快照管理>按钮，弹出虚拟机快照管理对话框。

  3. 单击<创建>按钮，弹出创建快照对话框。输入名称和描述，选择快照类型。当虚拟机处于运行、暂停状态时，可以选择是否快照内存，对于内部快照方式，还可设置超时时长。关于参数的详细介绍，请参见参数说明。

  4. 单击<确定>按钮完成操作。

修改快照

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<快照管理>按钮，弹出虚拟机快照管理对话框。

  3. 在虚拟机快照历史树中，选择要修改的快照，单击<修改>按钮，弹出修改虚拟机快照确认对话框。

  4. 修改虚拟及快照的名称和描述信息，单击<确定>按钮完成操作。

用快照还原虚拟机

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<快照管理>按钮，弹出虚拟机快照管理对话框。

  3. 在虚拟机快照历史树中，勾选要还原的快照，单击<还原>按钮，弹出还原虚拟机确认对话框。单击<确定>按钮完成操作。

删除快照

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<快照管理>按钮，弹出虚拟机快照管理对话框。

  3. 在虚拟机快照历史树中，选择要删除的快照，单击<删除>按钮，弹出删除虚拟机快照确认对话框。单击<确定>按钮完成操作。

精简镜像链

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<快照管理>按钮，弹出虚拟机快照管理对话框。

  3. 单击<精简镜像链>按钮，弹出操作确认对话框。单击<确定>按钮完成操作。

参数说明

  • 快照内存：设置是否对虚拟机内存进行快照，默认值为否。

  • 快照类型：支持内部快照和外部快照两种快照方式。内部快照存储在其磁盘文件中，外部快照通过创建增量磁盘存储增量数据。

  • 超时时长：针对内部快照，设置虚拟机快照内存的超时时间，默认值为5分钟。当快照内存所用时长达到超时时长时，系统将暂停虚拟机，待快照内存完成后再将虚拟机恢复为运行状态。


虚拟机备份与还原

备份是一种稳定的灾备方案。虚拟机执行备份后，生成的虚拟机备份文件是一个独立的文件，不会因为虚拟机镜像文件的损坏或误删除而丢失。

当服务器、存储等物理设备故障，或者软件BUG、病毒，或者误操作、非正常关机等人为操作导致虚拟机数据丢失时，可以使用虚拟机的备份文件来恢复虚拟机。

1. 虚拟机备份

虚拟机备份根据不同的维度可分为以下几种情况：

  • 根据执行备份时间的不同，可分为：

  • 周期性备份：通过备份策略的配置可以实现虚拟机的周期性备份。具体请参见备份策略管理。

  • 立即备份：手工实现实时备份虚拟机，具体请参见立即备份虚拟机。

  • 根据备份文件存放位置的不同，可分为：

  • 本地备份：备份文件存放于主机本地目录中。

  • 远端备份：备份文件存放于远端服务器的目录中。

  • 根据备份数据范围的不同，可分为：

  • 整机备份：备份整个虚拟机，包括所有磁盘数据和虚拟机配置文件。通过备份文件，可以还原整个虚拟机。

  • 磁盘备份：仅备份虚拟机的磁盘数据，不包括虚拟机配置文件。通过备份文件，只能还原虚拟机的磁盘数据。

  • 根据备份方式的不同，可分为：

  • 全量备份：对某一时间点之前的所有数据和应用进行完整拷贝。

  • 增量备份：在一次全量备份或增量备份后，每次只备份与前一次备份相比被修改的数据。

  • 差异备份：基于全量备份，每次只备份全量备份后所有更改的数据。

  • CBT备份：利用CBT（Changed Block Tracking）技术进行备份

  • 利用CBT（Changed Block Tracking）技术，快速获取增量数据信息，无需像原有备份那样逐块比较磁盘或磁盘快照，从而提高增量备份效率。

  • CBT备份是E0525版本开始提供的一种技术。通过为每块虚拟磁盘创建一个bitmap来记录虚拟磁盘的增量数据信息。由于bitmap保存在内存中且数据量较小，因此在做增量备份时，系统能够快速地解析bitmap来获取增量数据信息，然后根据这些信息对增量数据进行备份。

2. 虚拟机还原

虚拟机还原根据还原方式的不同，可分为：

  • 还原虚拟机：将处于关闭状态的虚拟机还原到某个历史备份时刻的状态。通过备份管理列表中的历史备份文件进行还原，请参见还原虚拟机；通过向主机导入虚拟机备份文件还原，请参见向主机导入虚拟机。

  • 导入虚拟机：对于已删除的虚拟机，通过导入整机备份文件的方式，还原整个虚拟机。具体请参见向主机导入虚拟机。

  • 一键还原虚拟机：可将虚拟机磁盘快速还原到创建虚拟机还原点时的状态，常用于快速还原虚拟机磁盘数据。一键还原虚拟机之前需要先创建虚拟机还原点。创建虚拟机还原点的具体操作，请参见创建还原点；一键还原虚拟机的具体操作，请参见虚机还原。


立即备份虚拟机

该功能用于实时备份虚拟机，根据实际需要可选择将虚拟机备份到主机本地目录或者远端服务器；可选择对虚拟机进行整机备份或磁盘备份；可选择对虚拟机进行全量备份、增量备份或差异备份。

如需周期性备份虚拟机，请参见备份策略管理。

注意事项

  • 备份虚拟机时，不会备份虚拟机的权限信息、启动优先级、自动迁移配置信息和GPU配置信息。

  • 对于磁盘类型为高速（raw）文件或块设备的虚拟机，不支持在线备份（即虚拟机处于运行状态时的备份）、增量备份和差异备份。

  • CBT备份不支持对快照进行备份，当对含有快照信息的虚拟机进行CBT备份时，通过备份文件还原虚拟机后，虚拟机的快照信息将会丢失。

  • 虚拟机执行CBT备份时，不允许改变其状态，否则会备份失败。

  • 目前仅支持CBT全量备份和CBT增量备份。

  • 只有磁盘为智能格式，且所有磁盘均是一级镜像的虚拟机，才支持CBT备份。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 在虚拟机概要信息页面中单击<更多操作>按钮，选择[立即备份]菜单项，弹出立即备份对话框。

  3. 备份参数有两种设置方式：

  • 方式一，从系统的全局备份策略中引用虚拟机的备份参数。单击<导入备份策略>按钮，选择备份策略。在导入备份策略之前，需要先增加备份策略，具体请参见备份策略管理。

  • 方式二，手工配置备份参数。

  4. 根据配置向导完成虚拟机的备份。

参数说明

基本信息设置：

  • 备份文件名：虚拟机备份文件的名称。

  • 保留个数：主机本地或远端服务器上保留虚拟机备份文件的个数。该参数设置为空时表示保留所有备份文件

  • 磁盘读速率限制：备份虚拟机时，读取待备份磁盘的最大速率。

  • 磁盘写速率限制：备份虚拟机时，将虚拟机备份文件写入目的存储卷的最大速率。

  • 临时目录：虚拟机备份过程中使用的临时目录。备份时，系统先将备份数据放于临时目录中，待备份完成后，再将该目录下的数据删除。默认为“/vms/vmbackuptmp”。若管理员指定的目录不存在，在执行备份策略时，系统将自动创建该目录。

  • 备份类型：虚拟机备份的类型，包括整机备份、磁盘备份，默认为整机备份。

  • 整机备份：备份整个虚拟机，包括所有磁盘数据和虚拟机配置文件。通过备份文件，可以还原整个虚拟机。

  • 磁盘备份：只备份单个或多个磁盘数据，不包括虚拟机配置文件。通过备份文件，只能还原虚拟机的磁盘数据。

  • 压缩：备份时是否对磁盘数据进行压缩，默认值为压缩。

  • CBT备份：是否启用CBT备份。基于CBT技术的备份可以追踪虚拟机磁盘在指定时间点后变化的数据，使得磁盘的增量备份变得简单高效，缩短了备份时间、减少了系统计算资源的消耗。

备份设置：

  • 虚拟机备份文件的存放位置，包括主机本地目录和远端服务器，默认为主机本地目录。

当备份到主机本地目录时，需配置如下参数：

  • 备份位置：虚拟机所在主机上存放虚拟机备份文件的路径。

当备份到远端服务器时，需配置如下参数：

  • IP地址：远端服务器的IP地址。

  • 用户名：远端服务器的用户帐号。该帐号要求有可读写远端服务器的权限。若连接远端服务器的方式为FTP，则该账号必须为远端服务器FTP Server上创建的帐号；若连接远端服务器的方式为SCP，则该账号必须为远端服务器操作系统上创建的帐号。

  • 密码：用户帐号对应的密码。

  • 备份位置：远端服务器上存放虚拟机备份文件的路径。

  • 连接方式：将虚拟机备份文件传输到远端服务器所使用的传输协议，包括FTP和SCP，默认为FTP。若选择FTP方式，则仅支持Server-U、VsFTP、IIS类型的FTP服务器。

  • 服务器端口：访问远端服务器所用的端口号。当连接方式为FTP时，服务器端口默认为21；当连接方式为SCP时，服务器端口默认为22。

  • 连接测试：对管理系统和远端服务器的连通性进行实时检查。

  • 备份模式：虚拟机备份的方式，包括全量备份、增量备份、差异备份，默认为全量备份。

  • 全量备份：全量备份是对某一时间点之前的所有数据和应用的一个完整拷贝，能够提供最好的数据保护。

  • 增量备份：在一次全量备份或增量备份后，每次只备份与前一次备份相比被修改的数据。第一次增量备份为全量备份。

  • 差异备份：基于全量备份，每次只备份前一次全量备份后所有修改的数据。第一次差异备份为全量备份。启用CBT备份后，暂不支持选择差异备份。


还原虚拟机

该功能是通过虚拟机的备份文件对虚拟机进行还原，把虚拟机恢复到某个历史备份时刻的状态。

配置前提

待还原的虚拟机处于关闭状态。

注意事项

  • 虚拟机还原所需时间与虚拟机备份文件大小有关。虚拟机备份文件越大，还原所需时间就越长。

  • 通过远端服务器的备份文件还原绑定了CPU的虚拟机，且主机的CPU核数小于虚拟机绑定的CPU核数时，虚拟机CPU绑定信息将会丢失。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 选择“备份管理”页签，进入虚拟机备份管理页面。

  3. 单击备份文件 [image] 图标，在弹出的对话框中输入临时目录，单击<确定>按钮可完成操作。

参数说明

  • 备份文件名：虚拟机备份文件的名称。

  • 创建时间：创建虚拟机备份文件的时间点。

  • 备份模式：虚拟机备份的类型，包括全量备份、增量备份、差异备份。

  • 备份位置：存储虚拟机备份文件的目录。

  • 文件大小：虚拟机备份文件的大小。

  • 备份类型：虚拟机备份的类型，包括整机备份、磁盘备份。

  • 存储路径：备份磁盘的存储路径。当备份类型为“磁盘备份”时，才会显示数据。

  • CBT备份：该备份是否为CBT备份。关于CBT备份，请参见CBT备份。

  • 临时目录：虚拟机还原过程中用到的临时目录。默认为“/vms/vmbackuptmp”，若管理员指定的目录不存在，当执行还原操作时，系统将自动创建该目录。


向主机导入虚拟机

该功能利用整机备份的虚拟机备份文件进行虚拟机的导入或还原。

配置前提

待导入或还原的虚拟机不在虚拟机回收站中。

注意事项

对于主机中关闭状态的虚拟机，向主机导入虚拟机备份文件会覆盖原有虚拟机，并删除快照，还原虚拟机到备份时刻的状态。

操作步骤

  1. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/<主机名>]菜单项，进入主机概要信息页面。

  2. 单击<导入虚拟机>按钮，进入虚拟机导入或还原对话框。

  3. 数据源参数有两种设置方式：

  • 方式一，引用管理系统的全局备份策略配置数据源参数，单击<参数引用>按钮，选择备份策略。

  • 方式二，手工配置数据源参数。

  4. 根据配置向导完成虚拟机导入或还原操作。

参数说明

数据源设置：

  • 恢复方式：导入或者还原虚拟机的方式，包括主机本地目录、FTP方式、SSH/SCP方式，默认为主机本地目录。

  • 主机本地目录：表示以主机本地文件的方式导入或还原虚拟机。

  • FTP方式：表示以FTP方式从远端服务器上导入或还原虚拟机。

  • SSH/SCP方式：表示以SSH/SCP方式从远端服务器上导入或还原虚拟机。

  • IP地址：远端服务器的IP地址。当恢复方式选择为FTP方式、SSH/SCP方式时，需要设置此参数。

  • 用户名：如果恢复方式选择为FTP方式，表示远端FTP服务器上创建的帐号。如果恢复方式选择为SSH/SCP方式，表示远端SSH/SCP服务器上创建的帐号。

  • 密码：连接远端服务器的用户帐号对应的密码。当恢复方式选择为FTP方式、SSH/SCP方式时，需要设置此参数。

  • 数据源位置：虚拟机备份文件所在的目录，例如：/vms/images。

  • 临时目录：虚拟机导入或还原的过程中使用的临时目录，默认为“/vms/vmbackuptmp”。若管理员指定的目录不存在，在执行导入或还原操作时，系统将自动创建该目录。

  • 新虚拟机显示名称：通过导入备份文件创建的新虚拟机的显示名称。此项不填表示不创建新虚拟机，只以原虚拟机名称导入或还原。

虚拟机设置：

  • 虚拟机名称：选择一个需要导入或还原的虚拟机名称。

备份时间设置：

  • 时间：虚拟机备份的时间。此处需选择一个时间，将该时间点对应的备份文件进行导入或还原。


导入虚拟机备份文件

该功能用于将不在虚拟机备份历史中的备份文件导入到备份历史。

导入虚拟机备份文件之后，可通过还原操作将虚拟机恢复到备份时刻的状态。具体请参见还原虚拟机。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 选择“备份管理”页签，进入虚拟机备份管理信息页面。

  3. 单击<导入>按钮，弹出备份文件导入对话框。

  4. 数据源参数有两种设置方式：

  • 方式一，引用管理系统的全局备份策略配置数据源参数，单击<参数引用>按钮，选择备份策略。

  • 方式二，手工配置数据源参数。

  5. 根据配置向导完成虚拟机备份文件的导入操作。

参数说明

  • 恢复方式：导入虚拟机备份文件的方式，包括主机本地目录、FTP方式、SSH/SCP方式，默认为主机本地目录。

  • 主机本地目录：表示以主机本地文件的方式导入虚拟机备份文件。

  • FTP方式：表示以FTP方式从远端服务器上导入虚拟机备份文件。

  • SSH/SCP方式：表示以SSH/SCP方式从远端服务器上导入虚拟机备份文件。

  • IP地址：远端服务器的IP地址。当恢复方式选择为FTP方式、SSH/SCP方式时，需要设置此参数。

  • 用户名：如果恢复方式选择为FTP方式，表示远端FTP服务器上创建的帐号。如果恢复方式选择为SSH/SCP方式，表示远端SSH/SCP服务器上创建的帐号。

  • 密码：连接远端服务器的用户帐号对应的密码。当恢复方式选择为FTP方式、SSH/SCP方式时，需要设置此参数。

  • 数据源位置：虚拟机备份文件所在的目录，例如：/vms/images。

  • 临时目录：导入虚拟机备份文件过程中使用的临时目录，默认为“/vms/vmbackuptmp”。若管理员指定的目录不存在，在执行导入操作时，系统将自动创建该目录。


创建还原点

该功能用于为关闭状态下的虚拟机创建还原点。创建还原点后，可通过一键操作，进行虚机还原，将虚拟机磁盘快速还原到还原点时的状态。一键还原虚拟机的操作请参见虚机还原。

配置前提

  • 待创建还原点的虚拟机处于关闭状态。

注意事项

  • 磁盘为RBD块的虚拟机不支持创建还原点。

  • 虚拟机还原点只有一个，创建新还原点会覆盖旧还原点。

  • 创建还原点时，将删除虚拟机所有快照。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<更多操作>按钮，选择[创建还原点]菜单项，弹出创建还原点确认对话框。

  3. 单击<确定>按钮完成操作。


合并虚拟机磁盘镜像

该功能用于将虚拟机的磁盘多级镜像文件合并为一个新的一级镜像文件。若虚拟机存在多个磁盘为多级镜像文件，执行合并镜像后，会分别将各磁盘的多级镜像文件合并为一级。

配置前提

待合并磁盘镜像的虚拟机处于关闭状态，不存在快照或还原点，且其镜像文件所在存储池有足够的剩余容量。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<更多操作>按钮，选择[合并镜像]菜单项，弹出合并镜像确认对话框。

  3. 单击<确定>按钮完成操作。


查看虚拟机概要信息

该功能用于查看虚拟机的基本属性、高级信息、硬件信息、CPU利用率和内存利用率。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

参数说明

  • 概要：显示指定虚拟机的详细配置信息。

  • 显示名称：虚拟机的显示名称，可通过单击显示名称对应的 [image] 图标修改虚拟机的显示名称。

  • 主机：虚拟机所属主机的名称，包括主机的IP地址。

  • 存储：虚拟机磁盘的容量。

  • CAStools版本：显示当前虚拟机安装的虚拟机代理工具的版本，当代理工具版本低于当前管理平台提供的版本时，显示代理工具升级按钮。单击<升级>按钮，代理工具将会自动升级为最新版本。

  • 控制台：登录虚拟机的控制台类型（目前仅支持VNC）。

  • VNC端口：远程登录虚拟机的VNC端口号。

  • 启用VNC代理：虚拟机是否启用了VNC代理。

  • 自动迁移：虚拟机是否启用了自动迁移。

  • 虚拟机类型：显示虚拟机的类型。

  • 普通虚拟机：表示虚拟机为非容灾恢复虚拟机；

  • 灾备机：表示虚拟机为依据存储复制容灾保护组创建的临时占位机（暂未执行网络与存储映射，无法对外提供业务）；

  • 容灾恢复机：表示虚拟机为存储复制容灾业务恢复出的完整虚拟机，网络和存储均已完成映射，可以接管业务；

  • “-”表示其他类型，虚拟机不是在CAS中创建的虚拟机，例如VDI下发的虚拟机。

  • 防病毒配置：显示虚拟机防病毒配置的状态。启用：虚拟机正常启用了防病毒功能；不启用：虚拟机没有启用防病毒功能；启用（操作系统不支持）：虚拟机启用了防病毒功能，但虚拟机操作系统不支持防病毒功能；启用（驱动未安装）：虚拟机启用了防病毒功能，但虚拟机未安装防病毒驱动；启用（驱动安装失败）：虚拟机启用了防病毒，但虚拟机防病毒驱动安装失败。

  • 保护模式：是否启用了保护模式，包括启用、不启用。

  • 高级信息：显示指定虚拟机的高级配置信息。

  • UUID：虚拟机的唯一标识。

  • 体系结构：虚拟机CPU的体系结构。

  • CPU调度优先级：虚拟机在集群中的CPU调度优先级。

  • 内存资源优先级：虚拟机内存的使用优先级。

  • I/O优先级：虚拟机在集群中的I/O优先级（ARM架构的主机暂不支持）。

  • 物理地址扩展（PAE）：虚拟机是否使用物理地址扩展。

  • 高级配置与电源管理接口（ACPI）：虚拟机是否使用高级配置ACPI。

  • 高级可编程中断控制器（APIC）：虚拟机是否使用APIC。

  • 密级级别：虚拟机的密级级别。

  • 硬件信息：显示虚拟机的硬件设备信息，包括CPU、内存、磁盘、网络、光驱、软驱信息。

  • CPU：显示虚拟机CPU配置（个数*核数），CPU近一小时的平均利用率。可通过单击 [image] 图标修改虚拟机CPU的个数与核数。

  • 内存：显示虚拟机内存配置，内存近一小时的平均利用率。可通过单击 [image] 标修改虚拟机内存大小。

  • 磁盘：显示虚拟机磁盘容量、总线类型、存储路径（如果虚拟机存在多级镜像，点击“更多”可以查看镜像链）、磁盘名称、磁盘类型、预分配方式、存储格式、缓存方式、磁盘基础镜像信息。若虚拟机镜像文件所在的目录在存储池中没有定义，则磁盘容量显示为0MB。以该镜像文件所在路径新增一个“本地文件目录”类型的存储池后，能够正确读出镜像容量的大小。某些异常情况下，可能出现虚拟机磁盘的存储路径显示与实际不符，或无法显示的情况，此时磁盘概要信息会出现三角形警告（ [image] ），点击该图标，可以进行虚拟机磁盘存储路径同步，以正确显示存储路径。

  • 网络：显示虚拟机MAC地址、IP地址、VLAN ID、连接的虚拟交换机、接口使用的网络策略模板、出方向平均带宽、出方向突发缓冲、入方向平均带宽、入方向突发缓冲配置信息。

  • 光驱：显示虚拟机光驱中光盘或挂载的光驱镜像的容量、光驱总线类型、光驱名称、存储格式、缓存方式、镜像文件存储路径信息。可单击 [image] 图标挂载/卸载光驱或镜像文件。

  • 软驱：显示虚拟机软驱中软盘或挂载的软驱镜像的容量、软驱总线类型、软驱名称、存储格式、缓存方式、镜像文件存储路径信息。可单击 [image] 图标挂载/卸载软驱或镜像文件。

  • CPU利用率：显示了图中时间范围内虚拟机CPU利用率趋势图。横轴表示时间，默认单位为30秒，纵轴表示利用率。

  • 内存利用率：显示了图中时间范围内虚拟机内存利用率趋势图。横轴表示时间，默认单位为30秒，纵轴表示利用率。


虚拟机CAStools管理

虚拟机代理工具管理包括安装CAStools和升级CAStools。

注意事项

  • 对于处于保护模式的虚拟机，推荐使用虚拟机启动时的代理工具自动升级功能，不建议登录到虚拟机内部手工升级代理工具。

  • 升级代理工具的版本后，请务必重启虚拟机，否则将其转换或者克隆成模板，通过该模板部署的虚拟机，将无法配置成功。

挂载CAStools

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<修改虚拟机>按钮，弹出修改虚拟机对话框。

  3. 选择“光驱”选项卡项，单击<连接>按钮，弹出“选择文件”对话框。

  4. 单击“类型”下拉框，选择“安装CAStools”，CAStools.iso将会自动挂载。

  5. 单击<确定>按钮完成操作。

升级CAStools

  1. 单击导航树中[云资源/主机池/<虚拟机>]或者[云资源/主机池/集群/<虚拟机>]菜单项，进入主机概要信息页面。

  2. 单击<更多操作>按钮，选择[升级CAStools]菜单项，弹出升级确认对话框。

  3. 单击<确定>按钮完成操作。


查看虚拟机的性能监控信息

该功能用于查看虚拟机的CPU利用率、内存利用率、I/O吞吐量统计、网络吞吐量统计、磁盘I/O延迟、磁盘请求、CPU使用情况、磁盘利用率、连接数和分区占用率信息（ARM架构的主机暂不显示该信息）。

注意事项

  • 为了准确的监控虚拟机CPU和内存的使用情况，建议管理员在虚拟机上安装虚拟机代理工具，虚拟化管理系统通过该工具可以准确的获取虚拟机CPU和内存的使用情况。

  • 当虚拟机关闭、暂停、未安装虚拟机代理工具时，系统将无法获取虚拟机的相关信息，磁盘利用率和分区占用率都会显示为空。

  • 在虚拟机在线迁移的过程中，虚拟机的CPU使用情况、内存使用情况、I/O吞吐量统计、网络吞吐量统计等性能监控信息可能不准确。

  • 以“更改主机”或“更改主机和数据存储”方式迁移虚拟机时，在虚拟机未完全迁移完成时，虚拟机性能监控信息可能出现两条记录，待迁移完成后，只保留一条正确记录。

  • 如果虚拟机磁盘类型是块设备，性能监控页面的磁盘利用率可能不准确，请以虚拟机内部实际利用率为准。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 选择“性能监控”页签，进入该虚拟机性能监控页面。

参数说明

  • CPU利用率：横轴为时间，纵轴为虚拟机CPU利用率。CPU利用率图表表示在图中时间范围内虚拟机CPU的利用率。

  • 内存利用率：横轴为时间，纵轴为虚拟机内存利用率。内存利用率图表表示在图中时间范围内虚拟机内存的利用率。

  • I/O吞吐量统计：横轴为时间，纵轴为虚拟机硬盘吞吐量，以KBps为单位。I/O吞吐量统计图表表示在图中时间范围内虚拟机各个硬盘吞吐量情况。

  • 网络吞吐量统计：横轴为时间，纵轴为虚拟机网卡的吞吐量，以Mbps为单位。网络吞吐量统计图表表示在图中时间范围内虚拟机各个网卡的流量情况。

  • 磁盘I/O延迟：横轴为时间，纵轴为虚拟机硬盘在30秒内每次请求的平均延迟时间，以ms为单位。磁盘I/O延迟统计图表表示在图中时间范围内虚拟机各个硬盘I/O延迟情况。

  • 磁盘请求：横轴为时间，纵轴为虚拟机硬盘在30秒内的平均请求数，以IOPS为单位。磁盘请求统计图表表示在图中时间范围内虚拟机各个硬盘I/O请求情况。

  • 连接数：横轴为时间，纵轴为虚拟机在30分钟内的TCP连接数。连接数趋势图表表示在图中时间范围内实时统计的虚拟机上处于活跃状态（即established状态）的TCP连接数，虚拟机安装代理工具后，系统才会显示此项统计值。

  • CPU使用情况：横轴为时间，纵轴为虚拟机使用所在主机的CPU频率，以MHz为单位。CPU使用情况图表表示在图中时间范围内虚拟机使用所在主机CPU的情况。

  • 磁盘利用率：横轴为时间，纵轴为虚拟机磁盘利用率，磁盘利用率=虚拟机磁盘已用容量/管理平台为虚拟机分配的磁盘总容量*100%。磁盘利用率图表表示在图中时间范围内虚拟机磁盘使用情况。

  • 分区占用率：显示虚拟机的各个分区信息。由于虚拟机系统内存会占用一定大小的存储空间，虚拟机系统分区已使用容量与修改虚拟机页面中的磁盘已用空间可能不符（ARM架构的主机暂不显示该信息）。


查看虚拟机进程服务监控信息

该功能用于查看虚拟机当前正在运行的程序、进程和服务，显示每个进程的用户名、进程ID、进程名、CPU利用率、内存利用率和内存使用量信息。

配置前提

  • 虚拟机处于运行状态。

  • 虚拟机已安装操作系统和虚拟机代理工具，且操作系统和代理工具兼容。

注意事项

在虚拟机在线迁移的过程中，虚拟机进程的CPU利用率、内存利用率等性能监控信息可能不准确。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 选择“进程服务监控”页签，进入该虚拟机进程服务监控页面。

  3. 单击<刷新>按钮，可以刷新显示最新进程服务信息。

参数说明

  • 用户名：运行进程的系统用户名。

  • PID：进程号，进程在系统中的唯一ID。

  • 进程名：程序、进程或服务的名称。

  • CPU利用率：进程使用虚拟机CPU的比例。

  • 内存利用率：进程使用虚拟机内存的比例。

  • 内存使用：进程在虚拟机操作系统内占用的内存大小。


查看虚拟机的备份历史

该功能用于查看虚拟机的历史备份文件信息。

注意事项

同一备份目录下，属于同一备份方式（CBT备份或普通备份）的最后一个备份链中的备份文件，其备份模式是增量/差异备份时，不允许删除。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 选择“备份管理”页签，进入虚拟机备份管理信息页面。

参数说明

  • 创建时间：创建虚拟机备份文件的时间点。

  • 备份模式：虚拟机备份的类型。

  • 备份位置：存储虚拟机备份文件的目录。

  • 文件大小：虚拟机备份文件的大小。

  • 备份类型：虚拟机备份的类型。

  • 存储路径：备份磁盘的存储路径。当备份类型为“磁盘备份”时，才会显示数据。

  • CBT备份：显示备份文件的备份方式是否为CBT备份。


查看虚拟机的控制台信息

该功能用于查看指定虚拟机的控制台信息，包括虚拟机UUID、VNC端口、MAC地址以及IP地址等信息。

配置前提

  • 打开虚拟机的网页控制台前：

  • 请先确认浏览器版本符合要求，推荐使用Chrome39、Firefox19.0及其以上版本的浏览器。

  • 若登录虚拟化管理系统的方式为HTTPS，则需先开启虚拟机的VNC代理，再将代理服务器设置为管理系统的IP地址。

  • 在保密模式下，通过Firefox浏览器使用https打开管理系统时，打开VNC控制台前，需要先手动在管理证书处将CVMIP:8081设置成例外，允许VNC代理服务器端口（8081），才能正常登录VNC控制台。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 选择“控制台”页签，进入该虚拟机的控制台页面。

  3. 单击“Java”链接，保存并打开提示保存的文件，弹出虚拟桌面窗口，或者单击“网页”链接，弹出虚拟桌面窗口。

参数说明

控制台：显示控制台的详细信息。

  • UUID：虚拟机的唯一标识。

  • 虚拟机状态：虚拟机的状态，包括运行、暂停、关闭、未知、HA异常。

  • 主机IP地址：虚拟机所属主机的IP地址。

  • VNC端口：远程登录虚拟机的VNC IPv4/Ipv6端口号。

  • 远程控制台：登录远程控制台的方式，包括通过Java以及通过网页两种方式。

远程桌面：显示远程桌面的信息。

  • MAC地址：虚拟机的MAC地址。

  • IPv4地址/IPv6地址：虚拟机的IPv4地址或IPv6地址。

  • 操作：以图标的方式显示可以对远程桌面执行的管理操作，单击图标后相应的操作会生效。 表示打开远程桌面。


查看虚拟机的迁移历史

该功能用于查看虚拟机历史迁移的详细信息，包括迁移前后虚拟机所在的CVK主机和存储池、迁移方式、迁移此虚拟机的操作员、迁移的开始时间、迁移耗时等信息。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 选择“迁移历史”页签，进入该虚拟机的迁移历史页面。

参数说明

  • 起始：产生当前虚拟机的CVK主机名称，该虚拟机的产生方式包括增加、部署、克隆、导入、本地化、云彩虹、OVF部署、NOVA部署等。

  • 当前：当前虚拟机目前所处的CVK主机名称。

  • 迁移方式：手动和自动。手动迁移方式包括迁移主机、迁移主机和存储；自动迁移是指由高可靠性、计算资源动态资源调度、电源智能管理、虚拟机规则、进入维护模式等引起的虚拟机迁移。

  • 操作员：迁移该虚拟机的执行者。

  • 源存储：在迁移主机和存储情况下，该虚拟机所在的源存储名称。

  • 目的存储：在迁移主机和存储情况下，该虚拟机迁入的目的存储名称。

  • 耗时：从迁移开始到迁移结束所用的时间。

  • 开始时间：迁移该虚拟机操作开始执行的时间。


查看虚拟机的操作日志

该功能用于查看虚拟机的操作日志。

操作步骤

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 选择“任务”页签，进入该虚拟机的任务列表页面。

参数说明

  • 登录名：操作员登录管理系统所使用的登录名。

  • 操作员姓名：操作员或者最终用户的姓名。

  • 完成时间：操作员或者最终用户完成操作的时间。

  • 登录地址：操作员登录管理系统所使用计算机的IP地址。

  • 操作分类：所执行操作的分类，此处为“虚拟机动作”。

  • 操作对象：操作所执行的对象，此处为虚拟机的名称。

  • 操作描述：所执行操作的详细描述。

  • 执行结果：操作的执行结果。

  • 成功：表示操作执行成功。

  • 部分成功：表示操作执行部分成功。

  • 失败：表示操作执行失败。

  • 失败原因：操作失败的详细原因。

  • 风险级别：操作执行对应的风险级别，包括高、中、低。

  • 事件类型：操作员所操作事件的类型。


虚拟机模板

虚拟机模板是虚拟机操作系统、应用软件和配置文件的集合。通过虚拟机模板，可批量创建多个软硬件规格相同的虚拟机，避免手工创建虚拟机过程中的繁琐配置和出错概率。虚拟机模板适用于大规模部署虚拟机或通过自助服务流程申请虚拟机的场景。

主要功能

  • 创建虚拟机模板

  • 虚拟机模板相关操作管理


创建虚拟机模板

在虚拟化管理系统中创建虚拟机模板的方式有如下三种：

  • 导入虚拟机模板：将虚拟机模板的压缩包（.tar.gz格式）导入到管理系统中。该功能只能导入通过管理系统下载的虚拟机模板压缩包。对于管理系统已经存在的虚拟机模板，不支持重复导入。

  • 克隆为模板：复制出与指定虚拟机完全一样的虚拟机作为模板。源虚拟机在克隆为模板后仍然可以使用。

  • 转换为模板：将“关闭”状态的虚拟机转换为模板。源虚拟机在转换为模板后只能作为模板使用，并将从导航树中移除。

还可以将 “关闭”状态的虚拟机导出为OVF（Open Virtualization Format，开放虚拟化格式）模板。OVF定义了开源的虚拟机文件格式规范，可以实现虚拟机在不同虚拟化管理平台之间相互兼容。

本章主要介绍将虚拟机克隆和转换为模板的操作，有关导出为OVF模板的具体操作，请参见导出OVF模板。

注意事项

  • 挂载软驱的虚拟机，不支持导出为OVF模板。

  • 不允许将安全区域内的虚拟机导出为OVF模板。

  • 挂载GPU设备（物理GPU/vGPU）的虚拟机，可以离线克隆为模板，但使用此模板部署出来的虚拟机不含GPU设备。

  • 将已安装Linux操作系统的虚拟机克隆或转换为模板前，请先进入Linux操作系统内，手工将/etc/udev/rules.d/70-persistent-net.rules文件删除，否则用该虚拟机模板部署的虚拟机上无eth0网卡。

  • 将已安装Linux系统的虚拟机克隆或转换为模板时，系统内的/usr目录不允许单独分区，否则通过此模板部署虚拟机时将无法正确配置新虚拟机操作系统的信息。

  • 将虚拟机克隆或转换为模板前，请将其IP地址的获取方式修改为自动获取，否则通过虚拟机模板部署的虚拟机其网卡会残留源虚拟机的静态IP信息。

  • 对于SUSE openSUSE和Ubuntu Linux操作系统的虚拟机，克隆为模板或转换为模板前，请先清空其网卡配置文件。否则，通过该虚拟机生成的模板部署新虚拟机后，修改新虚拟机的网络配置参数将不生效。

克隆为模板

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<更多操作>按钮，选择[克隆为模板]菜单项，弹出克隆为模板对话框。

  3. 输入虚拟机模板名称和模板描述信息，选择模板存放位置，模板所有者。

  4. 单击<确定>按钮。

转换为模板

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<更多操作>按钮，选择[转换为模板]菜单项，弹出转换为模板对话框。

  3. 输入虚拟机模板名称和模板描述信息，选择模板存放位置，模板所有者。

  4. 单击<确定>按钮。

导出OVF模板

  1. 单击导航树中[云资源/主机池/主机/<虚拟机>]或者[云资源/主机池/集群/主机/<虚拟机>]菜单项，进入虚拟机概要信息页面。

  2. 单击<更多操作>按钮，选择[导出OVF模板]菜单项，弹出导出OVF模板确认对话框。

  3. 单击<确定>按钮执行OVF模板的导出操作。

  4. 导出完成的OVF模板将自动下载到本地下载路径。

参数说明

  • 模板存储：虚拟机模板的存放位置。

  • 所有者：选择模板的所有者，公共模板指所有用户都可以进行模板相关操作，私有模板只有创建者所属用户组的用户才可以进行模板相关操作。


虚拟机模板相关操作

虚拟机模板的相关操作主要包括将模板部署为虚拟机、分发虚拟机模板、下载虚拟机模板、完整性校验和来源追溯、修改虚拟机模板、删除虚拟机模板和导入虚拟机模板。

  • 部署虚拟机：通过虚拟机模板来创建新的虚拟机。通过虚拟机模板部署的虚拟机与模板具有相同的操作系统和应用程序。

  • 分发虚拟机模板：将虚拟机模板拷贝到目的主机的目的存储池中。使用虚拟机模板部署虚拟机之前，建议先分发虚拟机模板，这样部署时可以直接使用目的存储池中的模板镜像，从而提高部署效率。

  • 下载虚拟机模板：将虚拟机模板下载到本地。下载的虚拟机模板其压缩包的文件格式为.tar.gz。

  • 完整性校验和来源追溯：完整性校验是指虚拟机模板文件的CRC校验，防止虚拟机模板在拷贝或传输过程中的篡改。来源追溯是指对虚拟机模板的来源和制作者进行记录，避免大量虚拟机模板带来的管理混乱问题。

  • 修改虚拟机模板：修改虚拟机模板的配置信息，包括CPU个数与核数、内存容量、存储卷名称和容量。若已基于虚拟机模板快速部署了虚拟机，则不允许修改虚拟机模板的名称与存储容量。

  • 开启镜像更新：通过虚拟机模板部署一台临时的虚拟机，用来更新模板的镜像。开启镜像更新后，虚拟机模板将进入维护模式。

  • 进入虚拟机控制台：进入开启了镜像更新后创建的临时虚拟机控制台，进行更新镜像的操作，例如安装或删除新的应用。

  • 关闭镜像更新：虚拟机模板的镜像更新完成后，通过关闭镜像更新功能，删除镜像更新功能创建的临时虚拟机，虚拟机模板恢复为正常状态。

  • 切换为公共/私有模板：将公共模板转换为私有，或将私有模板转换为公共模板。

  • 删除虚拟机模板：删除虚拟机模板。若已基于虚拟机模板快速部署了虚拟机，则删除虚拟机模板时，模板文件将不被删除，继续保留在存储中。

  • 导入虚拟机模板：将虚拟机模板的压缩包（.tar.gz格式）导入到管理系统中。该功能只能导入通过管理系统下载的虚拟机模板压缩包。对于系统中已经存在的虚拟机模板，不支持重复导入。

注意事项

  • 上传虚拟机模板的压缩包到管理系统的过程中，请勿关闭浏览器和导入虚拟机模板对话框，以免上传失败。

  • 导入虚拟机模板过程中，请勿长时间停留在配置网络策略模板页面。否则导入模板操作可能会因登录超时而失败。

过滤虚拟机模板

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 在“所有者”处，通过选择“全部”，“公共”，或“私有”，根据模板所有者过滤并查看系统中的所有虚拟机模板。

部署虚拟机

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 在虚拟机模板列表中，单击 [image] 图标，弹出部署虚拟机对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 参数设置完成后，单击<完成>按钮。

分发虚拟机模板

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 在虚拟机模板列表中，单击 [image] 图标，弹出分发虚拟机模板对话框。

  3. 设置相关参数。有关参数的详细介绍，请参见参数说明。

  4. 参数设置完成后，单击<完成>按钮。

下载虚拟机模板

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 选择待下载的模板，单击 [image] 图标，将虚拟机模板压缩包保存到本地。

完整性验证和来源追溯

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 选择待查看的模板，单击 [image] 图标，弹出完整性验证和来源追溯页面。

开启镜像更新

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 在虚拟机模板列表中，选择待更新镜像的模板，单击 [image] 图标，系统将根据该模板部署一台临时虚拟机，用来更新模板的镜像。

进入控制台

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 在虚拟机模板列表中，选择开启了镜像更新功能的模板，单击 [image] 图标，进入镜像更新功能创建的临时虚拟机。

  3. 根据需要更新模板的镜像，例如删除或安装应用程序。

关闭镜像更新

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 在虚拟机模板列表中，选择待关闭镜像更新功能的模板，单击 [image] 图标，删除临时虚拟机，并退出维护模式。

修改虚拟机模板

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 在虚拟机模板列表中，单击 [image] 图标，弹出修改虚拟机模板对话框。

  3. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  4. 修改完成后，单击<确定>按钮。

切换为公共/私有模板

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 在虚拟机模板列表中，单击 [image] 图标，进行模板所有者的公/私有转换。

删除虚拟机模板

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 选择待删除的模板，单击 [image] 图标，弹出删除虚拟机模板确认对话框。

  3. 单击<确定>按钮。

导入虚拟机模板

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 单击<导入虚拟机模板>按钮，弹出导入虚拟机模板对话框。

  3. 单击虚拟框区域，在弹出的对话框中选择需要导入的虚拟机模板压缩包，或者直接将“*.tar.gz”类型的模板文件拖拽到虚线框中，单击<开始上传>按钮上传虚拟机模板。

  4. 待上传完成后，单击网络策略模板输入框对应的 [image] 图标，为虚拟机模板选择网络策略模板。

  5. 选择模板所有者。

  6. 单击<完成>按钮。

参数说明

部署虚拟机

基本信息设置：

  • 数量：一次性部署虚拟机的个数，最小值为1，最大值为100。

  • 当部署虚拟机的个数为1时，需配置虚拟机的显示名称。

  • 当部署虚拟机的个数大于1时，需配置显示名称、显示名称前缀和起始编号。其中，显示名称是指虚拟机显示名称的配置方式，包括自动生成和手工配置。自动生成即按照指定的显示名称前缀和起始编号依次生成；手工配置即在详细信息设置中，以手工定义的方式或文件导入的方式进行配置。

  • 密级级别：部署虚拟机设置密级级别，包括绝密、机密、秘密和内部公开，默认为内部公开。当密级级别为内部公开时，虚拟机只能部署到非安全区域，当密级级别设置为非内部公开时，虚拟机只允许部署到安全区域内。系统启用保密模式后才需要设置此项。

  • 快速部署：基于虚拟机模板的基础镜像文件部署虚拟机。若勾选“快速部署”选项，系统将会提高创建虚拟机的速度，节省服务器的存储空间。

  • 立即启动：虚拟机部署完成后，是否立即启动。

  • 配置操作系统：选择是否需要配置虚拟机的操作系统信息。

  • 快速初始化：通过虚拟机代理工具对虚拟机的操作系统参数和用户账号信息进行初始化设置，不清除操作系统的SID（安全标识符）信息。快速初始化要求在虚拟机模板中安装代理工具，适用于支持虚拟机代理工具的Windows和Linux操作系统。

  • 完全初始化：通过Sysprep（系统准备工具）对虚拟机的操作系统参数、用户账号信息进行初始化设置，并清除操作系统的SID信息。完全初始化要求在虚拟机模板中配置Sysprep（系统准备工具），仅适用于Windows 7和Windows XP操作系统（ARM架构的主机暂不支持此参数）。

存储信息设置：

  • 目的存储文件：为虚拟机指定存储文件名称。

  • 目的存储池：为虚拟机指定使用的存储池，单击“目的存储池”列表格，可以选择目的存储池位置。

  • 磁盘格式：当未勾选“快速部署”选项时，需设置此项参数。磁盘格式包括不变、智能和高速，默认为不变。

  • 不变：部署的虚拟机的磁盘格式与模板保持一致。

  • 智能：设置部署的虚拟机的磁盘格式为qcow2。

  • 高速：设置部署的虚拟机的磁盘格式为raw。

网络信息设置（部署单个虚拟机时，才显示此项）：

  • 虚拟交换机：指定虚拟机使用的虚拟交换机。

  • 网络策略模板/端口组：指定虚拟机使用的网络策略模板，新部署的虚拟机使用的是最新的网络策略模板，其配置的VLAN和QoS可能与虚拟机模板不一致。

  • 网络参数：指定虚拟机的IPv4/IPv6网络参数，包括默认、DHCP、手工分配，默认值为默认。选择“默认”，表示虚拟机与虚拟机模板的网络参数一致；选择“DHCP”，表示采用DHCP方式配置虚拟机的网络参数；选择“手工分配”，表示手工配置虚拟机的网络参数，主要参数如下：

  • IP地址：指定虚拟机的IP地址。

  • 子网掩码：指定虚拟机的子网掩码。

  • 默认网关：指定虚拟机的默认网关。

  • 主DNS服务器：指定虚拟机的主DNS服务器。

  • 备DNS服务器：指定虚拟机的备DNS服务器。

  • 设置IPv4/IPv6绑定：是否将虚拟机的IP地址与MAC地址绑定。绑定后，若虚拟机网卡设置的IP地址与绑定IP不一致，则该网卡无法正常通信。

  • 虚拟防火墙：指定虚拟机使用的虚拟防火墙。设置后，虚拟机的入方向和出方向数据报文将会根据防火墙的规则进行过滤。

  • 所有者：选择模板的所有者，公共模板指所有用户都可以进行模板相关操作，私有模板只有创建者可以进行模板相关操作。

详细信息设置（批量部署多个虚拟机时，才显示此项）：

  • 手工定义：手工输入虚拟机的显示名称、操作系统、网络等参数。

  • 从文件导入：通过导入文件的方式设置虚拟机的显示名称、操作系统、网络等参数。操作员可自定义创建文件，可以通过单击“模板文件”链接下载虚拟机配置信息文件的模板，依据“模板文件”来定义虚拟机的配置信息。支持txt及csv格式的文件。选择从文件导入虚拟机的配置信息时，需确保文件内虚拟机的配置信息正确。

  • 分隔符：虚拟机配置信息文件中各列信息之间的分隔符号，包括：英文半角逗号（,）、英文半角分号（;）、Tab键、空格。选择分隔符时，需与虚拟机配置信息文件中使用的分隔符保持一致，否则文件将导入失败。

  • 导入起始行：从导入的虚拟机配置信息文件中指定导入数据的起始行数。

系统信息设置-X86架构服务器（部署单个虚拟机，且“配置操作系统”参数选择“是”时，才显示此项）：

  • 计算机名：虚拟机操作系统中的主机名称。

  • 隶属于：虚拟机部署后加入域或者工作组。当部署Windows操作系统的虚拟机时，才需设置此参数。

  • 域/工作组：虚拟机部署后加入的域/工作组名称。当部署Windows操作系统的虚拟机时，才需设置此参数。

  • 登录帐号：登录虚拟机操作系统的帐号。

  • 登录密码：登录虚拟机操作系统的密码。

  • 本地组：登录虚拟机操作系统的账号所属的本地组，包括：Administrators、Power Users、Users，默认值为Administrators。当部署Windows操作系统的虚拟机时，才需设置此参数。

  • 时区：操作系统的时区。当部署Windows系统模板的虚拟机，并选择完全初始化时，才需设置此参数。

  • 默认用户密码：系统默认用户Administrator的密码，不填写则不设置。当部署Windows系统模板的虚拟机，并选择完全初始化时，才需设置此参数。

  • 激活序列号：虚拟机操作系统安装激活时需要的序列号。当部署Windows操作系统的虚拟机时，并勾选了配置虚拟机的操作系统信息和完全初始化时，需设置此参数。若不设置此参数，在虚拟机启动时必须输入符合操作系统版本的激活序列号。

系统信息设置-ARM架构的主机：

  • 计算机名：操作系统中计算机的名称。

  • 登录帐号：虚拟机操作系统的登录帐号。

  • 登录密码：虚拟机操作系统登录帐号对应的密码。

  • 密码确认：必须与登录密码完全一致。

分发虚拟机模板

  • 覆盖同名存储卷：下发虚拟机模板时，是否覆盖目标主机的同名存储卷，默认为否。

修改虚拟机模板

  • 名称：虚拟机模板的名称。若已基于虚拟机模板快速部署了虚拟机，则不允许修改该虚拟机模板的名称。

  • CPU个数：通过虚拟机模板部署的虚拟机的CPU核数（即CPU个数与每个CPU核数的乘积）。

  • 内存：通过虚拟机模板部署的虚拟机的内存容量。

  • 存储卷名称：通过虚拟机模板部署的虚拟机的存储卷名称，默认与虚拟机模板名称一致，且不支持修改。

  • 存储容量：部署完成后虚拟机的磁盘容量。若已基于虚拟机模板快速部署了虚拟机，则不允许修改该虚拟机模板的存储容量。


模板存储

模板存储管理是指对虚拟机模板存储路径的管理，主要包括增加模板存储、启动模板存储、暂停模板存储、删除模板存储、搜索虚拟机模板、查看模板存储、CVM主机存储适配器管理以及CVM主机网络管理等功能。

  • 增加模板存储：增加虚拟机模板的存储路径。系统支持增加本地文件目录、iSCSI共享目录、FC共享目录、NFS网络文件系统、本地同步分区五种类型的存储路径。搭建双机热备环境时，建议使用主、备管理平台都可以访问的共享目录（例如iSCSI共享目录、FC共享目录、NFS网络文件系统）作为模板存储，优点是无需再占用管理网络带宽同步虚拟机模板数据；若无共享存储可用，则需创建一个本地同步分区作为模板存储，主管理平台会自动将本地同步分区中的数据通过管理网络同步到备管理平台。

  • 启动模板存储：用于启动处于“不活动”状态的虚拟机模板存储。

  • 暂停模板存储：用于暂停处于“活动”状态虚拟机模板存储。

  • 删除模板存储：删除虚拟机模板的存储路径。若模板存储为本地文件目录，且存储路径下存在虚拟机模板，则该路径不支持删除。

  • 搜索虚拟机模板：对于模板存储中已存在但未在系统中显示的虚拟机模板，可通过此功能将其导入到系统中。导入的虚拟机模板将在虚拟机模板列表中展示，并可下载到本地、分发到其他模板存储中、或通过该模板部署虚拟机等。

  • 查看模板存储：查看虚拟机模板存储路径的详细信息。

  • CVM主机存储适配器管理：双机热备环境中，当CVM主机未作为CVK主机加入到管理平台时，可以通过本功能，查看CVM主机所使用的存储适配器信息，设置主机iqn标识符、设备扫描等（ARM架构的主机暂不支持该功能）。

  • CVM主机网络管理：双机热备环境中，当CVM主机未作为CVK主机加入到管理平台时，可以通过本功能，管理CVM主机上的虚拟交换机，包括增加、修改、删除虚拟交换机（ARM架构的主机暂不支持该功能）。

注意事项

  • 若分布式存储的数据池已经配置为RBD网络存储池，则该数据池中的存储卷不允许再配置模板存储。

增加模板存储

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 单击<模板存储>按钮，进入模板存储列表页面。

  3. 单击<增加模板存储>按钮，弹出增加模板存储对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  5. 参数设置完成后，单击<完成>按钮。

启动模板存储

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 单击<模板存储>按钮，进入模板存储列表页面。

  3. 单击 [image] 图标，在弹出的操作确认对话框中，单击<确定>按钮。

暂停模板存储

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 单击<模板存储>按钮，进入模板存储列表页面。

  3. 单击 [image] 图标，在弹出的操作确认对话框中，单击<确定>按钮。

删除模板存储

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 单击<模板存储>按钮，进入模板存储列表页面。

  3. 选择待删除的模板存储，单击 [image] 图标，在弹出的删除确认对话框中，单击<确定>按钮。

搜索虚拟机模板

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 单击<模板存储>按钮，进入模板存储列表页面。

  3. 单击 [image] 图标，弹出搜索虚拟机模板对话框。

  4. 选中扫描出的虚拟机模板，单击<确定>按钮，可将虚拟机模板的信息同步到系统界面中。

查看模板存储

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 单击<模板存储>按钮，进入模板存储列表页面。

  3. 选择待查看的模板存储，单击 [image] 图标，进入查看模板存储对话框。

CVM存储适配器管理

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 单击<模板存储>按钮，进入模板存储列表页面。

  3. 单击<CVM存储适配器>按钮，弹出存储适配器对话框，查看管理系统主机所使用的存储适配器信息。

  • 单击Open-iSCSI存储适配器对应的操作列 [image] 图标，可以修改主机的iqn标识符信息。

  • 单击存储适配器对应的操作列 [image] 图标，可以执行设备扫描操作。

CVM主机网络管理

  1. 单击导航树中[云资源/虚拟机模板]菜单项，进入虚拟机模板列表页面。

  2. 单击<模板存储>按钮，进入模板存储列表页面。

  3. 单击<CVM网络>按钮，弹出网络对话框，可以查看管理系统主机上的虚拟交换机信息。

  • 单击<增加>按钮，可为管理系统主机增加虚拟交换机。

  • 单击虚拟交换机对应的操作列 [image] 图标，可以修改虚拟交换机。

  • 单击虚拟交换机对应的操作列 [image] 图标，可以删除虚拟交换机。

参数说明

  • 目标路径：模板存储在CVM主机上的本地目录挂载点。本地文件目录和本地同步分区类型必须以/vms/开头，其他类型不能以/vms开头。

  • 类型：模板存储的类型，包括本地文件目录、iSCSI共享目录、FC共享目录、NFS网络文件系统、本地同步分区（ARM架构的主机暂不支持NFS网络文件系统）。非双机热备环境中，才能创建本地文件目录类型的模板存储。同时满足以下条件时，才能创建本地同步分区类型的模板存储：

  • 双机热备环境。

  • CVM主机没有作为CVK主机加入到管理平台中。

  • 没有创建过本地同步分区。

  • 磁盘分区：主、备CVM主机中都存在的相同名称和容量的逻辑磁盘或分区才能作为本地同步分区。创建本地同步分区时会对磁盘/分区进行格式化。最多只允许创建一个本地同步分区。选择“本地同步分区”时，才需设置此参数，（ARM架构的主机暂不支持）。

  • IP地址：选择“iSCSI共享目录”时，需输入iSCSI存储服务器的IP地址。

  • LUN：请确保所选LUN未被其他共享文件系统、iSCSI网络存储、模板存储和其他CVM管理系统所使用。双机热备环境中，主备管理平台必须都能获取到此LUN。选择“iSCSI共享目录”时，才需设置此参数。

  • NAA：请确保所选LUN未被其他共享文件系统、FC网络存储、模板存储和其他CVM管理系统所使用。双机热备环境中，主备管理平台必须都能获取到此LUN。选择“FC共享目录”时，才需设置此参数。

  • 源主机IP：NFS网络文件系统的IP地址。双机热备环境中，主备管理平台必须都能连通该NFS网络文件系统。选择“NFS网络文件系统”时，才需设置此参数，（ARM架构的主机暂不支持）。

  • 源路径：NFS网络文件系统中的路径。选择“NFS网络文件系统”时，才需设置此参数，（ARM架构的主机暂不支持）。


共享存储

共享存储管理主要用于管理第三方存储服务器。当前仅支持管理第三方分布式存储系统。

主要功能

分布式存储


分布式存储

分布式存储系统是将大量的通过网络互联的普通服务器组成存储集群，对外作为一个整体提供存储服务。

目前系统支持三种类型的分布式存储：ONEStor、柏科存储和Xsky存储，但同时只能添加一种。

对于ONEStor分布式存储，提供监控功能，可以在管理系统中直接查询ONEStor的基本信息，存储节点的信息，存储集群的IOPS、带宽等性能数据以及硬盘的状态。

如果管理员在ONEStor存储系统中修改了用户的登录密码，则需要在管理系统中同步修改ONEStor资源的密码信息，便于管理系统与ONEStor存储系统重新建立连接。如果已被增加进管理系统的ONEStor存储系统修改了对应的IP地址、用户名等信息，那么在管理系统上需要删除该ONEStor存储系统，再重新增加。

注意事项

  • 如果管理员在分布式存储系统中修改了handy密码或CEPH密码，则需要在管理系统中同步修改分布式存储的密码信息，便于管理系统与分布式存储系统重新建立连接。

  • 如果已被增加进管理系统的分布式存储系统修改了对应的IP地址、用户名信息，那么在管理系统上需要删除该分布式资源，再重新增加。

增加分布式存储

  1. 单击导航树[云资源/共享存储/分布式存储]菜单项，进入分布式存储列表页面。

  2. 单击<增加分布式存储>按钮，弹出增加分布式存储对话框。

  3. 设置相关参数，关于参数的详细介绍，请参见参数说明。

  4. 单击<确定>按钮完成操作。

修改分布式存储

  1. 单击导航树[云资源/共享存储/分布式存储]菜单项，进入分布式存储列表页面。

  2. 选择目标分布式存储，单击 [image] 图标，弹出修改分布式存储对话框。

  3. 修改相关参数，关于参数的详细介绍，请参见参数说明。

  4. 单击<确定>按钮完成操作。

删除分布式存储

  1. 单击导航树[云资源/共享存储/分布式存储]菜单项，进入分布式存储列表页面。

  2. 选择目标分布式存储，单击 [image] 图标，弹出删除分布式存储确认对话框。

  3. 单击<确定>按钮完成操作。

查看ONEStor分布式存储概要信息

  1. 单击导航树中[云资源/共享存储/分布式存储]菜单项，进入分布式存储列表界面。

  2. 选择目标ONEStor分布式存储，单击 [image] 图标，或单击左侧导航树<ONEStor资源>菜单项，进入ONEStor概要信息界面。关于参数的详细介绍，请参见参数说明。

查看ONEStor分布式存储性能监控信息

  1. 单击导航树中[云资源/共享存储/分布式存储]菜单项，进入分布式存储列表界面。

  2. 选择目标ONEStor分布式存储，单击 [image] 图标，或单击左侧导航树<ONEStor资源>菜单项，进入ONEStor概要信息界面。

  3. 选择“性能监控”页签，进入ONEStor分布式存储性能监控信息页面。关于参数的详细介绍，请参见参数说明。

查看ONEStor分布式存储硬盘信息

  1. 单击导航树中[云资源/共享存储/分布式存储]菜单项，进入分布式存储列表界面。

  2. 选择目标ONEStor分布式存储，单击 [image] 图标，或单击左侧导航树<ONEStor资源>菜单项，进入ONEStor概要信息界面。

  3. 选择“硬盘”页签，进入ONEStor硬盘信息页面。关于参数的详细介绍，请参见参数说明。

参数说明

增加/修改分布式存储：

  • 资源类型：增加的分布式存储的类型，包括：ONEStor、柏科存储和Xsky存储。

  • handy IP：资源类型选择为ONEStor时需设置此参数，访问ONEStor资源的IP地址，即登录ONEStor管理平台的IP。

  • 端口号：资源类型选择为ONEStor时需设置该参数。访问ONEStor的端口号，默认值为80。

  • handy用户名：资源类型选择为ONEStor时需设置该参数。登录ONEStor管理平台的用户名。

  • 修改handy密码：修改ONEStor分布式存储时可设置此参数。若选择“是”，在“handy密码”填写新密码，可直接修改handy密码。

  • handy密码：资源类型选择为ONEStor时需设置该参数。登录ONEStor时登录用户名对应的密码。

  • 配置CEPH：资源类型选择为ONEStor时需设置此参数。若需要ONEStor提供RBD存储服务，请选择“是”；否则只能在管理系统中监控ONEStor的基本状态。

  • CEPH IP：分布式存储提供CEPH RBD存储服务的IP地址，即分布式存储环境中任意一台服务器的管理网IP或存储业务网IP。

  • CEPH用户名：访问分布式存储服务器的用户名。

  • 修改CEPH密码：修改ONEStor分布式存储时可设置此参数。若选择“是”，在“CEPH密码”填写新密码，可直接修改CEPH密码。

  • CEPH密码：访问分布式存储服务器的用户名对应的密码。

查看ONEStor资源概要信息-基本属性：

  • IP地址：ONEStor资源的IP地址。

  • 存储节点：ONEStor资源中存储节点的个数。

  • 总存储：ONEStor存储集群的总容量。

  • 总可用存储：ONEStor存储集群的总可用容量。

  • 存储集群利用率：显示ONEStor存储集群的已使用容量和空闲容量的比例。

  • 存储集群健康度：显示存储集群的健康度以及集群中正常、异常和警告的虚节点（即PG）的数量。

查看ONEStor资源概要信息-存储节点信息：

  • 名称：存储节点的主机名称。

  • 网络状态：存储节点的网络状态，包括：正常，异常。

  • 机架：放置该存储节点的机架的名称。

  • 存储业务IP地址：存储节点的业务网IP地址，CVK主机使用此IP可以访问ONEStor存储。

  • 分区：ONEStor集群中的存储区域单元；该参数表示存储节点所属的分区名称。

  • 硬盘状态：存储节点的硬盘状态，显示正常的硬盘数量和总硬盘数量。

  • 存储容量：存储节点的存储容量大小。

  • 存储利用率：存储节点的存储利用率百分比。

  • CPU利用率：存储节点的CPU利用率百分比。

  • 内存：存储节点的内存容量。

  • 内存利用率：存储节点的内存利用率百分比。

查看ONEStor资源性能监控信息：

  • 存储集群IOPS（Input/Output Operations Per Second）：指存储集群在过去一小时内每秒处理的读写访问次数。

  • 读：表示读访问次数。

  • 写：表示写访问次数。

  • 存储集群带宽：指存储集群在过去一小时内每秒传输数据的量，单位为KBps。

  • 读：表示磁盘读流量速率。

  • 写：表示磁盘写流量速率。

查看ONEStor资源硬盘信息：

  • 设备：以主机名/盘符名的形式标识硬盘。

  • 容量：该硬盘的总容量。

  • 已使用：该硬盘已使用的容量。

  • 硬盘利用率：该硬盘已使用容量占总容量的百分比。


虚拟机视图

操作员可以通过虚拟机视图管理功能自定义一些目录，并可以在每个目录下创建子目录。根据实际需要将同类型的虚拟机收藏到一个目录中进行统一管理，如根据部门或者业务类型等将虚拟机划分到不同的目录中。

虚拟机视图管理功能可以方便操作员分类管理虚拟机、快速查找虚拟机、快速查看虚拟机的详细信息等。

当虚拟机目录存在子目录或虚拟机时，支持设置虚拟机启动规则。

  • 设置启动规则后，在虚拟机视图页面中显示的子目录及虚拟机顺序就是批量启动虚拟机或批量关闭虚拟机的顺序。

  • 启动或关闭间隔是指上一子目录或虚拟机的启动或关闭完成时间与下一子目录或虚拟机的启动或关闭开始时间之间的间隔。

  • 典型应用场景是设置虚拟机按照指定的顺序依次启动。例如：3个虚拟机分别安装了数据库、应用和WebService软件，需要设置一定的启动顺序。首先将它们收藏到同一个虚拟机目录下，然后设置相应的启动规则，再执行批量启动操作。

注意事项

  • 系统默认提供“虚拟机视图”作为顶级目录。该目录不支持删除，也不支持将虚拟机收藏到该目录中。

  • 设置启动规则后，在虚拟机视图目录下批量启动或关闭虚拟机时，启动规则比虚拟机规则的优先级高，虚拟机规则中的关联动作失效。例如：虚拟机视图目录中存在VM1、VM2、VM3三台虚拟机，设置的启动规则为VM1－>VM2－>VM3，启动间隔为5分钟。其中VM2和VM3同属于一个虚拟机规则，关联动作为同时启动。若执行批量启动操作，则VM2、VM3将按启动规则中的顺序启动。

增加目录

  1. 单击导航树中[云资源/虚拟机视图]菜单项，进入虚拟机视图页面。

  2. 选择待增加子目录的父目录，单击<增加目录>按钮，弹出增加目录对话框。

  3. 输入目录名称，单击<确定>按钮，完成增加目录操作。

删除目录

  1. 单击导航树中[云资源/虚拟机视图]菜单项，进入虚拟机视图页面。

  2. 选择待删除的目录，单击<更多操作>按钮，选择[删除目录]选项，弹出操作确认框。

  3. 单击<确定>按钮。

收藏虚拟机

  1. 单击导航树中[云资源/虚拟机视图]菜单项，进入虚拟机视图页面。

  2. 选择待收藏虚拟机的目录，单击<收藏虚拟机>按钮，弹出选择虚拟机的对话框。

  3. 选择所需的一台或多台虚拟机，单击<确定>按钮。

移除虚拟机

  1. 单击导航树中[云资源/虚拟机视图]菜单项，进入虚拟机视图页面。

  2. 选择待移除虚拟机的目录，在该目录的虚拟机列表页面中选择虚拟机，单击<更多操作>按钮，选择[移除虚拟机]菜单项，弹出操作确认框。

  3. 单击<确定>按钮。

设置虚拟机启动规则

  1. 单击导航树中[云资源/虚拟机视图]菜单项，进入虚拟机视图页面。

  2. 选择待设置规则的目录，单击<设置启动规则>按钮，弹出设置启动规则对话框。

  3. 通过鼠标直接拖拽子目录或虚拟机的方式设置启动或者关闭优先级，也可以将指定的子目录或虚拟机，通过单击 [image] 或 [image] 图标，设置为最先启动或者关闭。

  4. 设置虚拟机启动或者关闭间隔。关于启动/关闭间隔的详细介绍，请参见参数说明。

  5. 单击<确定>按钮。

批量启动虚拟机

  1. 单击导航树中[云资源/虚拟机视图]菜单项，进入虚拟机视图页面。

  2. 选择待批量启动虚拟机的目录，单击<批量操作>按钮，选择[启动]菜单项，弹出启动虚拟机确认对话框。

  3. 单击<确定>按钮。

批量关闭虚拟机

  1. 单击导航树中[云资源/虚拟机视图]菜单项，进入虚拟机视图页面。

  2. 选择待批量关闭虚拟机的目录，单击<批量操作>按钮，选择[安全关闭]菜单项，弹出关闭虚拟机确认对话框。

  3. 单击<确定>按钮。

设置虚拟机视图显示样式

  1. 单击导航树中[云资源/虚拟机视图]菜单项，进入虚拟机视图页面。

  2. 选择虚拟机视图目录，单击<树形>按钮，或单击<详细信息>按钮，虚拟机视图将以树形或详细信息形式显示。

参数说明

启动/关闭间隔：上一子目录或虚拟机的启动或关闭完成时间与下一子目录或虚拟机的启动或关闭开始时间之间的间隔，默认为10秒。此间隔时间为最短的启动或者关闭间隔时间。若执行启动或关闭的任务较多，启动间隔时间可能会延长。未收藏虚拟机的子目录节点与下一虚拟机之间的启动间隔时间仍有效。


虚拟机回收站

虚拟机回收站类似于Windows操作系统中的“回收站”，用来存放操作员临时删除的虚拟机。移入回收站的虚拟机，其镜像文件和配置文件并未删除，但HA、DRS、DPM、关联/反关联等策略对其不再生效。系统支持将在线和离线状态的虚拟机移入回收站。若将在线状态的虚拟机移入回收站，系统将强制关闭该虚拟机的电源。

虚拟机回收站管理的主要功能包括在回收站中查询虚拟机、还原虚拟机、销毁虚拟机和查看虚拟机信息。

  • 查询虚拟机：根据查询条件查找回收站中的虚拟机。

  • 还原虚拟机：将回收站中的虚拟机还原到源主机。还原后的虚拟机其镜像文件与移入回收站之前保持一致，但原有的虚拟机规则与动态资源扩展的业务虚拟机组配置将不会还原。

  • 销毁虚拟机：彻底删除回收站中的虚拟机。销毁后的虚拟机无法还原。销毁虚拟机分手工销毁和自动销毁两种方式。

  • 手工销毁虚拟机：手工将回收站中的虚拟机删除。

  • 自动销毁虚拟机：用户可在系统参数设置中，设置虚拟机回收保存期，到期的虚拟机将被自动销毁，且无法还原。

  • 查看虚拟机信息：查看回收站中虚拟机的详细配置信息。

注意事项

如果回收站中的虚拟机所在的源主机不可连接或被手工删除，将同步销毁回收站中的虚拟机，但保留虚拟机的磁盘镜像文件。

查询虚拟机

  1. 单击导航树中[云资源/虚拟机回收站]菜单项，进入虚拟机回收站页面。

  2. 单击<高级查询>按钮，弹出高级查询对话框。

  3. 选择主机池、集群或主机作为查询条件，单击<确定>按钮，回收站中将显示出符合条件的虚拟机。

还原虚拟机

  1. 单击导航树中[云资源/虚拟机回收站]菜单项，进入虚拟机回收站页面。

  2. 在回收站的虚拟机列表中选择待还原的虚拟机，单击 [image] 图标，或者选择一台或多台虚拟机后单击<还原虚拟机>按钮。

销毁虚拟机

  1. 单击导航树中[云资源/虚拟机回收站]菜单项，进入虚拟机回收站页面。

  2. 在回收站的虚拟机列表中选择待销毁的虚拟机，单击 [image] 图标，或者选择一台或多台虚拟机后单击<销毁虚拟机>按钮，弹出删除虚拟机对话框。

  3. 选择删除虚拟机的方式。关于虚拟机删除方式的详细介绍，请参见参数说明。

  4. 单击<确定>按钮。

查看虚拟机信息

  1. 单击导航树中[云资源/虚拟机回收站]菜单项，进入虚拟机回收站页面。

  2. 在回收站的虚拟机列表中选择待查看的虚拟机，单击 [image] 图标，显示虚拟机详细信息对话框。

参数说明

  • 销毁时间：系统彻底删除虚拟机的时间。销毁时间到达前虚拟机可以被还原，到达销毁时间虚拟机将被自动删除。回收站中的虚拟机支持自动销毁（自动销毁类型最长保存时间为30天）和永久保留，缺省是永久保留在回收站中，可以通过修改系统参数“虚拟机回收保存期”进行调整。

  • 保留虚拟机的数据存储文件：删除虚拟机时，仅删除虚拟机配置文件，保留虚拟机数据。虚拟机镜像文件的存储位置保持不变。若需恢复该虚拟机，可以新建虚拟机，并挂载该镜像文件。

  • 删除虚拟机的数据存储文件：删除虚拟机时，虚拟机配置文件与虚拟机数据一并删除。选择删除虚拟机的数据存储文件后，还可设置是否彻底销毁数据。

  • 低格并删除虚拟机的数据存储文件：先将虚拟机的存储数据低级格式化，然后再删除文件，如果存储卷较大时，可能耗时较长，请谨慎使用该选项。


策略与规则

通过制定统一的策略和规则，管理系统中的云资源，包括配置NTP时间服务器、制定网络策略模板、设置主机驱动规则和端口规则（保密模式下），以及针对虚拟机制定备份策略、快照策略，开关机策略。

主要功能有：

  • 备份策略

  • 快照策略

  • 监控策略


备份策略

备份是一种稳定的灾备方案。虚拟机执行备份后，生成的虚拟机备份文件是一个独立的文件，不会因为虚拟机镜像文件的损坏或误删除而丢失。

当服务器、存储等物理设备故障，或者软件BUG、病毒，或者误操作、非正常关机等人为操作导致虚拟机数据丢失时，可以使用虚拟机的备份文件来恢复虚拟机。

根据执行备份时间的不同，可将虚拟机备份分为：

  • 立即备份：手工实现实时备份虚拟机，具体请参见立即备份虚拟机。

  • 周期性备份：将备份策略应用到一台或多台虚拟机，从而进行虚拟机的备份。备份策略是周期性地批量备份虚拟机或虚拟机磁盘的策略。当备份策略生效时，系统将在指定时间对应用了备份策略的虚拟机的整机或指定磁盘进行备份，并生成对应的备份文件。

注意事项

  • 备份虚拟机时，将不会备份虚拟机的权限信息、启动优先级、自动迁移配置信息和GPU配置信息。

  • 对于磁盘类型为高速（raw）或块设备的虚拟机，不支持在线备份（即虚拟机处于运行状态时的备份）、增量备份和差异备份。

  • CBT备份不支持对快照进行备份，当对含有快照信息的虚拟机进行CBT备份时，通过备份文件还原虚拟机后，虚拟机的快照信息将会丢失。

  • 虚拟机执行CBT备份时，不允许改变其状态，否则会备份失败。

增加备份策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<备份策略>按钮，进入备份策略配置页面。

  3. 单击<增加>按钮，弹出增加备份策略对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  5. 参数设置完成后，单击<完成>按钮。

修改备份策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<备份策略>按钮，进入备份策略配置页面。

  3. 在备份策略列表中选择待修改的备份策略，单击 [image] 图标，弹出修改备份策略对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  5. 修改完成后，单击<完成>按钮。

删除备份策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<备份策略>按钮，进入备份策略列表页面。

  3. 选择待删除的备份策略，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

开启备份策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<备份策略>按钮，进入备份策略列表页面。

  3. 选择待开启的备份策略，单击 [image] 图标，弹出开启备份策略对话框。

  4. 单击<确定>按钮。

关闭备份策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<备份策略>按钮，进入备份策略列表页面。

  3. 选择待关闭的备份策略，单击 [image] 图标，弹出关闭备份策略对话框。

  4. 单击<确定>按钮。

删除应用备份策略的虚拟机

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<备份策略>按钮，进入备份策略列表页面。

  3. 在应用备份策略的虚拟机列表中选择待删除的虚拟机，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

删除应用备份策略的磁盘

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<备份策略>按钮，进入备份策略列表页面。

  3. 单击“应用备份策略的磁盘”页签，在应用备份策略的磁盘列表中选择待删除的磁盘，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

参数说明

基本信息设置：

  • 磁盘I/O阈值：虚拟机磁盘I/O的最大吞吐量，默认为10MB。当备份开始时间到达时，系统会检测虚拟机的磁盘IO吞吐量。当虚拟机的实际磁盘I/O吞吐量小于等于阈值时，才对应用备份策略的虚拟机进行备份。否则，系统将放弃此次备份任务，等待下次备份开始时间到达。只有当待备份虚拟机处于运行状态，此参数才生效。

  • 备份目的地：虚拟机备份文件的存放位置，包括主机本地目录和远端服务器，默认为主机本地目录。

当备份到主机本地目录时，需配置如下参数：

  • 备份位置：虚拟机所在主机上存放虚拟机备份文件的路径。

当备份到远端服务器时，需配置如下参数：

  • IP地址：远端服务器的IP地址。

  • 用户名：远端服务器的用户帐号。该帐号要求有可读写远端服务器的权限。若连接远端服务器的方式为FTP，则该账号必须为远端服务器FTP Server上创建的帐号；若连接远端服务器的方式为SCP，则该账号必须为远端服务器操作系统上创建的帐号。

  • 密码：用户帐号对应的密码。

  • 连接方式：将虚拟机备份文件传输到远端服务器所使用的传输协议，包括FTP和SCP，默认为FTP。若选择FTP方式，则仅支持Server-U、VsFTP、IIS类型的FTP服务器。

  • 服务器端口：访问远端服务器所用的端口号。当连接方式为FTP时，服务器端口默认为21；当连接方式为SCP时，服务器端口默认为22。

  • 连接测试：对管理系统和远端服务器的连通性进行实时检查。

  • 备份位置：远端服务器上存放虚拟机备份文件的路径。

  • 备份类型：根据备份数据范围的不同，备份类型分为整机备份和磁盘备份，默认为进行整机备份。

  • 整机备份：备份整个虚拟机，包括所有磁盘数据和虚拟机配置文件，生成整机的备份文件。通过备份文件，可以还原整个虚拟机。

  • 磁盘备份：备份虚拟机的单个或多个磁盘数据，不包括虚拟机配置文件，生成指定磁盘的备份文件。通过备份文件，只能还原虚拟机的磁盘数据。

  • CBT备份：是否启用CBT备份。基于CBT技术的备份可以追踪虚拟机磁盘在指定时间点后变化的数据，使得磁盘的增量备份变得简单高效，缩短了备份时间、减少了系统计算资源的消耗。只有在 E0525及以上版本中创建的磁盘为单级镜像且为智能（qcow2）格式的虚拟机才支持CBT备份。

  • 立即生效：是否启用备份策略，默认为否。

全量备份设置：

  • 频率：执行全量备份的频率，默认为每月。

  • 开始时间：执行全量备份的开始时间。

  • 截止时间：执行全量备份的截止时间。当截止时间小于开始时间时，截止时间为第二天的时间。若截止时间到达时仍未完成本次备份任务，则待正在备份的虚拟机完成备份后，系统将放弃此次备份任务，等待下次备份开始时间到达。

  • 保留个数：主机本地或远端服务器上保留虚拟机备份文件的个数。该参数设置为空时表示保留所有备份文件。

  • 增量或差异备份：选择执行增量备份或者差异备份。

  • 增量备份：在一次全量备份或增量备份后，每次只备份与前一次备份相比被修改的数据。第一次增量备份为全量备份。

  • 差异备份：基于全量备份，每次只备份前一次全量备份后所有修改的数据。启用CBT备份后，暂不支持选择差异备份。

  • 磁盘读速率限制：备份虚拟机时，读取待备份磁盘的最大速率。

  • 磁盘写速率限制：备份虚拟机时，将虚拟机备份文件写入目的存储卷的最大速率。

  • 临时目录：虚拟机备份过程中使用的临时目录。备份时，系统先将备份数据放于临时目录中，待备份完成后，再将该目录下的数据删除。默认为“/vms/vmbackuptmp”。若管理员指定的目录不存在，在执行备份策略时，系统将自动创建该目录。

  • 压缩：备份时是否对磁盘数据进行压缩，默认为是。

增量或差异备份设置：

  • 频率：执行增量或者差异备份的频率，默认为每周备份。

  • 开始时间：执行增量或者差异备份的开始时间。

  • 截止时间：执行增量或者差异备份的截止时间。当截止时间小于开始时间时，截止时间为第二天的时间。若截止时间到达时仍未完成本次备份任务，则待正在备份的虚拟机完成备份后，系统将放弃此次备份任务，等待下次备份开始时间到达。


快照策略

虚拟机快照是某一时刻虚拟机状态的副本。

与备份相比，快照是一种临时性的灾备方案。当虚拟机的镜像文件损坏或者误删除时，快照数据也会随之丢失。

快照主要应用在如下场景（包括但不限于）：

  • 安装新应用软件。该应用软件与已有的其它软件冲突或者与操作系统本身不兼容，导致新的应用软件安装之后，虚拟机运行异常。

  • 升级操作系统。升级后，已有的某些应用软件在新的操作系统上不兼容。

  • 升级应用软件。升级后，新版本的应用软件与现有操作系统不兼容。

当虚拟机操作系统崩溃或者应用软件运行异常时，可使用快照还原功能来快速恢复虚拟机。

根据执行快照的时间不同，可将快照分为：

  • 快照管理：为某台虚拟机的手工创建实时快照，具体请参见虚拟机快照管理。

  • 快照策略：将快照策略应用到一台或多台虚拟机，从而进行虚拟机的快照。快照策略是周期性地批量创建虚拟机快照的策略。当快照策略生效时，系统将在指定时间对应用了快照策略的虚拟机进行快照，并生成对应的快照文件。

注意事项

  • 只有磁盘存储格式为“智能”的虚拟机，才支持创建快照。

  • 快照虚拟机时，将不会快照虚拟机的GPU配置信息。同理，虚拟机的GPU配置也不受快照还原的影响。

增加快照策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[快照策略]菜单项，进入虚拟机快照策略列表页面。

  3. 单击<增加>按钮，弹出增加快照策略对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  5. 参数设置完成后，单击<完成>按钮。

修改快照策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[快照策略]菜单项，进入虚拟机快照策略列表页面。

  3. 选择待修改的快照策略，单击 [image] 图标，弹出修改快照策略对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  5. 修改完成后，单击<完成>按钮。

删除快照策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[快照策略]菜单项，进入虚拟机快照策略列表页面。

  3. 选择待删除的快照策略，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

开启快照策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[快照策略]菜单项，进入虚拟机快照策略列表页面。

  3. 选择待开启的快照策略，单击 [image] 图标，弹出开启快照策略对话框。

  4. 单击<确定>按钮。

关闭快照策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[快照策略]菜单项，进入虚拟机快照策略列表页面。

  3. 选择待关闭的快照策略，单击 [image] 图标，弹出关闭快照策略对话框。

  4. 单击<确定>按钮。

删除应用快照策略的虚拟机

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[快照策略]菜单项，进入虚拟机快照策略列表页面。

  3. 选择待删除的虚拟机，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

参数说明

基本信息设置：

  • 最大快照个数：允许创建虚拟机快照的最大个数，默认为0。0表示对虚拟机快照的个数不作限制。

  • 快照内存：设置是否对虚拟机的内存进行快照，默认为否。当虚拟机内存利用率较高时，快照内存可能导致虚拟机上的业务暂停。

  • 立即生效：是否启用快照策略，默认为否。

执行时间设置：

  • 频率：执行快照策略的频率，包括每月、每周、每天，默认为每月。

  • 时间：执行快照策略的时间。


监控策略

监控策略是监控计算或存储资源的规则。配置监控策略后，系统可对集群、主机和虚拟机运行状态进行实时监控。监控的指标包括CPU利用率、内存利用率、连接数、网络流量、磁盘I/O、存储容量利用率和磁盘请求。

监控策略应用于集群的动态资源扩展、动态资源调度和电源智能管理功能。

  • 当监控策略应用于动态资源扩展时，可监控CPU利用率、内存利用率、连接数、网络流量、磁盘I/O和磁盘请求。

  • 当监控策略应用于计算资源动态调度时，可监控CPU利用率、内存利用率和网络流量；当监控策略应用于存储资源动态调度时，可监控磁盘I/O、存储容量利用率和磁盘请求。

  • 当监控策略应用于电源智能管理时，可监控CPU利用率、内存利用率。

增加监控策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[监控策略]菜单项，进入监控策略列表页面。

  3. 单击<增加>按钮，弹出增加监控策略对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  5. 参数设置完成后，单击<完成>按钮。

修改监控策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[监控策略]菜单项，进入监控策略列表页面。

  3. 选择待修改的监控策略，单击 [image] 图标，弹出修改监控策略对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  5. 修改完成后，单击<完成>按钮。

删除监控策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[监控策略]菜单项，进入监控策略列表页面。

  3. 选择待删除的监控策略，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

查看监控策略的详细信息

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[监控策略]菜单项，进入监控策略列表页面。

  3. 选择待查看的监控策略，单击 [image] 图标，弹出查看监控策略对话框。

参数说明

基本信息设置：

  • 条件关系：监控策略中多条预置条件之间的逻辑关系，包括与和或，默认为与。

条件设置：

  • 条件：监控策略中预置条件的条件类型，包括CPU利用率、内存利用率、连接数、网络流量、磁盘I/O、存储容量利用率和磁盘请求，默认为CPU利用率。

  • CPU利用率：主机CPU利用率或虚拟机CPU利用率。

  • 内存利用率：主机内存利用率或虚拟机内存利用率。

  • 连接数：虚拟机的socket连接数。

  • 网络流量：主机或者虚拟机的网络流量，单位为MBps。

  • 磁盘I/O：虚拟机或集群共享存储的磁盘I/O吞吐量，单位为KBps。

  • 存储容量利用率：集群共享存储的容量利用率。

  • 磁盘请求：虚拟机或集群共享存储的磁盘I/O请求次数，单位IOPS。

  • 运算符：监控策略中配置预置条件所用的运算符，包括>、>=、<、<=，默认为>。

  • 值：监控策略中预置条件的值。

  • 预置条件：监控策略的预置条件列表。


开关机策略

开关机策略用于设置虚拟机定时自动开关机。开关机策略作为一种自动化运维手段，适用于无需全时段运行的业务，既可以保证在指定时间段内虚拟机业务的可用性，也可以确保其它时间段内资源的及时释放。

增加开关机策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[开关机策略]菜单项，进入开关机策略列表页面。

  3. 单击<增加>按钮，弹出增加开关机策略对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  5. 参数设置完成后，单击<完成>按钮。

修改开关机策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[开关机策略]菜单项，进入开关机策略列表页面。

  3. 选择待修改的开关机策略，单击 [image] 图标，弹出修改开关机策略对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  5. 修改完成后，单击<完成>按钮。

删除开关机策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[开关机策略]菜单项，进入开关机策略列表页面。

  3. 选择待删除的开关机策略，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

查看开关机策略时间配置

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[开关机策略]菜单项，进入开关机策略列表页面。

  3. 选择待查看的开关机策略，单击 [image] 图标，弹出查看时间配置对话框。

开启开关机策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[开关机策略]菜单项，进入开关机策略列表页面。

  3. 选择待开启的开关机策略，单击 [image] 图标，弹出开启开关机策略对话框。

  4. 单击<确定>按钮。

关闭开关机策略

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[开关机策略]菜单项，进入开关机策略列表页面。

  3. 选择待关闭的开关机策略，单击 [image] 图标，弹出关闭开关机策略对话框。

  4. 单击<确定>按钮。

删除应用开关机策略的虚拟机

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[开关机策略]菜单项，进入开关机策略列表页面。

  3. 在应用开关机策略的虚拟机列表中选择待删除的虚拟机，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮。

参数说明

基本信息设置：

  • 立即生效：是否启用开关机策略，默认为否。

频率设置：

  • 频率：执行开关机策略的频率，包括每年、每月、每周、每天，默认为每天。

  • 启动时间：应用开关机策略的虚拟机的开机时间。

  • 关闭时间：应用开关机策略的虚拟机的关机时间。


NTP时间服务器设置

该功能用于设置NTP时间服务器。配置时间服务器后，CVM或CVM所管理的CVK主机将同步NTP时间服务器的时钟，使虚拟化环境中的所有物理主机和虚拟机时间保持一致，以便提供基于统一时间的多种应用。例如，确保虚拟化高可靠性集群中的心跳报文时间一致、确保日志记录中的时间一致以便准确定位故障等。

注意事项

  • 在NTP时间服务器配置完成后，请不要修改主机的系统时间，否则将影响系统的正常运行。建议将CVM管理服务器设置为NTP主服务器。

  • 双机热备的情况下，使用VIP作为NTP主服务器时，不需要配置备用NTP服务器。

操作步骤

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<更多操作>按钮，选择[NTP时间服务器]菜单项，弹出设置NTP时间服务器对话框。

  3. 输入NTP主/备用服务器的域名或IP地址，单击<确定>按钮。

参数说明

  • NTP主服务器：主用NTP时间服务器的域名或者IP地址。

  • NTP备用服务器：备用NTP时间服务器的域名或者IP地址。


网络策略模板

网络策略模板是一组网络控制功能的集合，如ACL、VLAN、QoS等。

将网络策略模板应用到虚拟机的网卡后：

  • 若网络策略模板引用了ACL策略，虚拟交换机匹配到相应ACL规则后，会按规则指定的方式去处理虚拟机的网络流量。

  • 虚拟机所属VLAN由网络策略模板中的VLAN ID决定。

  • 虚拟机网卡发送和接收流量的速率限制由网络策略模板引用的网络限速策略或网络策略模板中定义的入方向和出方向流量限制决定。

  • 虚拟机网卡使用网络的优先级由网络策略模板所决定。

网络策略模板管理包括增加网络策略模板、修改网络策略模板、删除网络策略模板和查看网络策略模板的信息等操作。

注意事项

  • 如果虚拟机正在使用网络策略模板，修改该网络策略模板完成后，将会在虚拟网卡所连接虚拟交换机的端口上立即生效。

  • 如果网络策略模板正在被虚拟机网卡使用，则不允许删除。

增加网络策略模板

  1. 单击导航树中[云资源/网络策略模板]菜单项，进入云资源概要信息页面。

  2. 选择“网络策略模板”页签，进入网络策略模板列表页面。

  3. 单击<增加网络策略模板>按钮，弹出增加网络策略模板配置对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  5. 单击<完成>按钮完成操作。

修改网络策略模板

  1. 单击导航树中[云资源/网络策略模板]菜单项，进入云资源概要信息页面。

  2. 选择“网络策略模板”页签，进入网络策略模板列表页面。

  3. 选择待修改的网络策略模板，单击 [image] 图标，弹出修改网络策略模板配置对话框。

  4. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  5. 单击<完成>按钮完成操作。

复制网络策略模板

  1. 单击导航树中[云资源/网络策略模板]菜单项，进入网络策略模板列表页面。

  2. 选择待复制的网络策略模板，单击 [image] 图标，弹出复制网络策略模板对话框。

  3. 填写或修改相关参数后，单击<确定>按钮完成操作。

切换为公共网络策略模板

  1. 单击导航树中[云资源/网络策略模板]菜单项，进入网络策略模板列表页面。

  2. 选择待切换的网络策略模板，单击 [image] 图标，弹出操作确认对话框。

  3. 单击<确定>按钮，将私有网络策略模板切换为公共模板。

过滤网络策略板

  1. 单击导航树中[云资源/网络策略模板]菜单项，进入网络策略模板列表页面。

  2. 在“所有者”处，通过选择“全部”，“公共”，或“私有”，根据网络策略模板所有者过滤并查看系统中的所有虚拟机模板。

删除网络策略模板

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“网络策略模板”页签，进入网络策略模板列表页面。

  3. 选择待删除的网络策略模板，单击 [image] 图标，弹出删除网络策略模板确认对话框。

  4. 单击<确定>按钮完成操作。

查看网络策略模板的信息

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“网络策略模板”页签，进入网络策略模板列表页面。

  3. 选择待查看的网络策略模板，单击 [image] 图标，弹出查看网络策略模板信息对话框。

参数说明

增加或修改网络策略模板：

  • ACL策略：网络策略模板引用的ACL策略。

  • VLAN ID：网络策略模板设置的VLAN的ID，虚拟机应用网络策略模板后，所属VLAN由此VLAN决定。

  • 启用网络限速策略：启用后，系统将按照网络限速策略中定义的规则对虚拟机网络流量进行带宽的精确控制。网络限速策略与网络策略模板中入方向流量限制、出方向流量限制、网络优先级互斥。若系统中不存在网络限速策略，请先增加网络限速策略，具体操作请参见网络限速策略管理。

  • 所有者：选择网络策略模板的所有者，公共模板指所有用户都可以查看并使用的模板，私有模板只有创建者所属用户组内的用户才可以查看并使用。

  • 启用入方向流量限制：是否对虚拟机入方向（即虚拟交换机至虚拟机方向）的流量做限制。

  • 平均带宽：入方向流量平均带宽，单位为Kbps。

  • 突发缓冲：为入方向突发流量预留的缓冲区大小，单位为KBytes。

  • 启用出方向流量限制：是否虚拟机出方向（即对虚拟机至虚拟交换机方向）的流量做限制。

  • 平均带宽：出方向流量平均带宽，单位为Kbps。

  • 突发缓冲：为出方向突发流量预留的缓冲区大小，单位为KBytes。

  • 网络优先级：当主机网络流量过大时，按照设置的优先级为虚拟机网卡分配带宽。


主机驱动规则

主机驱动规则用于同时启用或禁用CVM管理的所有主机上的相关驱动。主机驱动规则只有在保密模式下才支持。

出现以下操作时，CVM会自动将主机驱动规则下发给主机，从而启用或禁用主机上的驱动：

  • CVM主机的Tomcat服务重启时，系统会将所有规则下发给所有主机。

  • 增加主机、连接主机时，系统会将所有规则下发给相关的主机。

  • 新增、修改、启用和禁用主机驱动规则时，系统会将变化的规则下发给所有主机。

主机驱动规则管理包括增加主机驱动规则、修改主机驱动规则、启用主机驱动规则、禁用主机驱动规则、删除主机驱动规则、批量启用主机驱动规则、批量禁用主机驱动规则和批量删除主机驱动规则等功能。

注意事项

  • 禁止配置CVK主机正在使用的驱动。CVK主机使用的驱动列表请查看对应版本说明书。

  • 删除主机驱动规则后，主机上该驱动的状态会恢复到未添加规则之前的状态。

增加主机驱动规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机驱动”页签，进入主机驱动规则列表页面。

  3. 单击<增加主机驱动规则>按钮，弹出增加主机驱动规则对话框。

  4. 输入主机驱动名称，并选择启用或禁用驱动。

  5. 检查并确认配置，单击<确定>按钮完成操作。

修改主机驱动规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机驱动”页签，进入主机驱动规则列表页面。

  3. 选择待修改的主机驱动规则，单击 [image] 图标，弹出修改主机驱动规则对话框。

  4. 输入主机驱动名称，并选择启用或禁用驱动。

  5. 检查并确认配置，单击<确定>按钮完成操作。

启用主机驱动规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机驱动”页签，进入主机驱动规则列表页面。

  3. 选择待启用的主机驱动规则，单击 [image] 图标，弹出启用主机驱动确认对话框。

  4. 单击<确定>按钮完成操作。

禁用主机驱动规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机驱动”页签，进入主机驱动规则列表页面。

  3. 选择待禁用的主机驱动规则，单击 [image] 图标，弹出禁用主机驱动确认对话框。

  4. 单击<确定>按钮完成操作。

删除主机驱动规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机驱动”页签，进入主机驱动规则列表页面。

  3. 选择待删除的主机驱动规则，单击 [image] 图标，弹出删除主机驱动规则确认对话框。

  4. 单击<确定>按钮完成操作。

批量启用主机驱动规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机驱动”页签，进入主机驱动规则列表页面。

  3. 选择待批量启用的多个规则，单击<批量操作>按钮，选择[启用]菜单项，弹出启用驱动规则确认对话框。

  4. 单击<确定>按钮完成操作。

批量禁用主机驱动规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机驱动”页签，进入主机驱动规则列表页面。

  3. 选择待批量禁用的多个规则，单击<批量操作>按钮，选择[禁用]菜单项，弹出禁用驱动规则确认对话框。

  4. 单击<确定>按钮完成操作。

批量删除主机驱动规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机驱动”页签，进入主机驱动规则列表页面。

  3. 选择待批量删除的多个规则，单击<批量操作>按钮，选择[删除]菜单项，弹出删除驱动规则确认对话框。

  4. 单击<确定>按钮完成操作。


主机端口规则

主机端口规则用于同时启用或禁用虚拟化管理系统管理的所有主机上的相关端口。主机端口规则只有在保密模式下才支持。

出现以下操作时，CVM会自动将主机端口规则下发给主机，从而启用或禁用主机上的端口：

  • CVM主机的Tomcat服务重启时，系统会将所有规则下发给所有主机。

  • 增加主机、连接主机时，系统会将所有规则下发给相关的主机。

  • 新增、修改、启用和禁用主机端口规则时，系统会将变化的规则下发给所有主机。

主机端口规则管理包括增加主机端口规则、修改主机端口规则、启用主机端口规则、禁用主机端口规则、删除主机端口规则、批量启用主机端口规则、批量禁用主机端口规则和批量删除主机端口规则等功能。

注意事项

  • 禁止配置CVK主机正在使用的端口。CVK主机使用的端口列表请查看对应版本说明书。

  • 删除主机端口规则后，主机上该端口的状态会恢复到未添加规则之前的状态。

增加主机端口规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机端口”页签，进入主机端口规则列表页面。

  3. 单击<增加主机端口规则>按钮，弹出增加主机端口规则对话框。

  4. 输入起始端口、结束端口和端口说明，并选择端口的状态。

  5. 单击<确定>按钮完成操作。

修改主机端口规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机端口”页签，进入主机端口规则列表页面。

  3. 选择待修改的主机端口规则，单击 [image] 图标，弹出修改主机端口规则对话框。

  4. 输入起始端口、结束端口和端口说明，并选择端口的状态。

  5. 单击<确定>按钮完成操作。

启用主机端口规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机端口”页签，进入主机端口规则列表页面。

  3. 选择待启用的主机端口规则，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮完成操作。

禁用主机端口规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机端口”页签，进入主机端口规则列表页面。

  3. 选择待禁用的主机端口规则，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮完成操作。

删除主机端口规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机端口”页签，进入主机端口规则列表页面。

  3. 选择待删除的主机端口规则，单击 [image] 图标，弹出操作确认对话框。

  4. 单击<确定>按钮完成操作。

批量启用主机端口规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机端口”页签，进入主机端口规则列表页面。

  3. 选择待批量启用的多个规则，单击<批量操作>按钮，选择[启用]菜单项，弹出操作确认对话框。

  4. 单击<确定>按钮完成操作。

批量禁用主机端口规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机端口”页签，进入主机端口规则列表页面。

  3. 选择待批量禁用的多个规则，单击<批量操作>按钮，选择[禁用]菜单项，弹出操作确认对话框。

  4. 单击<确定>按钮完成操作。

批量删除主机端口规则

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 选择“主机端口”页签，进入主机端口规则列表页面。

  3. 选择待批量删除的多个规则，单击<批量操作>按钮，选择[删除]菜单项，弹出操作确认对话框。

  4. 单击<确定>按钮完成操作。


一键操作

一键操作管理包括对系统进行快速全方位的健康巡检以及查看相应的健康巡检结果，查看主机、虚拟机资源的使用情况，扫描和清理空闲的存储卷，导出系统中的主机或虚拟机资源列表，还原虚拟机和启动、删除僵尸虚拟机等功能。

主要功能

  • 健康巡检

  • 资源分析

  • 存储清理

  • 资源导出

  • 虚机还原


健康巡检

该功能用于快速检测系统的健康情况，计算检测项总体得分。该功能可提供系统检测、计算资源检测、存储资源检测、网络资源检测、高可靠性服务状态检测，可帮助管理员快速了解虚拟机环境的运行状态、性能以及可能存在的隐患。对于检测异常的指标项，系统会提供有效的改进建议，确保业务系统稳定可靠的运行。同时系统支持对检测结果的打印和导出。

操作步骤

  1. 鼠标指针指向管理平台首页顶部<一键>按钮，选择[健康巡检]菜单项，进入一键健康巡检页面。

  2. 选择需要的检测项。单击<勾选所有>按钮，可选择所有检测项。单击<开始检测>按钮，开始巡检。

  3. 巡检完成后，健康巡检页面的检测结果，将统计显示参与检测项总数，故障数与警告数。系统默认显示检测异常的异常汇总页面。单击<检测正常>或<检测汇总>按钮，切换到正常汇总页面或检测汇总页面。

  4. 在检测过程中，可单击<停止检测>按钮，停止巡检操作。

  5. 巡检完成后，可单击<重新检测>按钮，选择检测项，重新进行巡检。

  6. 单击<打印>按钮，可打印巡检结果。

  7. 单击<导出>按钮，导出巡检结果。

巡检结果说明

  • CPU资源超配状态：检测系统中各个计算节点上已分配的虚拟CPU个数与物理CPU总核数（含超线程）的比例关系，当已分配的虚拟CPU个数超过物理CPU总核数时，可能导致服务器本身工作不稳定，过量超配使用时，极有可能出现各种不可预知的异常结果。在虚拟化环境中，影响的对象包括该服务器上的所有虚拟机，轻者导致业务系统响应缓慢，影响用户体验，重者可能造成所有的业务系统异常。

CPU资源超配比建议在80%以下，最大不超过150%。

  • 内存资源超配状态：检测系统中各个计算节点上已分配的虚拟内存容量与可用物理内存容量的比例关系，当已分配的虚拟内存容量超过可用物理内存容量时，可能导致服务器本身工作不稳定，过量超配使用时，极有可能出现各种不可预知的异常结果。在虚拟化环境中，影响的对象包括该服务器上的所有虚拟机，轻者导致业务系统响应缓慢，影响用户体验，重者可能造成所有的业务系统异常。

内存资源超配比建议在80%以下，最大不超过150%。

  • 存储资源超配状态：检测系统中各个共享存储卷上已分配的虚拟磁盘容量与可用物理磁盘容量的比例关系，当已分配的虚拟磁盘容量超过可用物理磁盘容量的80%时，使用该共享存储卷的虚拟机将面临无法磁盘I/O读写，从而导致虚拟机业务暂停的风险。

存储资源超配比建议在80%以下，最大不超过150%。


资源分析

该功能用于查看主机、虚拟机的资源配置与近一个月的CPU、内存的使用情况。

操作步骤

  1. 鼠标指针指向管理平台首页顶部<一键>按钮，选择[资源分析]菜单项，进入一键资源分析页面。

  2. 在资源类型下拉框中选择集群、主机或虚拟机可查看相应的资源配置与近一个月内的CPU、内存使用情况。

  3. 单击<打印>按钮，可打印相应的信息。

  4. 单击<导出>按钮，弹出资源导出对话框，选择导出格式，单击<确定>按钮，导出相应的信息。

参数说明

集群资源：

  • 高可靠性：集群是否启用了高可靠性设置。

  • 主机数：集群内主机总数。

  • 虚拟机密度：集群中平均每个主机中虚拟机的数量。

  • 虚拟机概要：集群中虚拟机的总数，以及处于“运行”和“关闭”状态的虚拟机数量。

  • CPU总核数：集群中各主机的CPU核数总和。

  • 总内存：集群中各主机的内存容量总和。

  • 共享存储（可用/最大）：集群共享存储可用容量和最大容量。

  • CPU利用率均值（近一个月）：集群内主机近一个月CPU利用率均值。

  • 内存利用率均值（近一个月）：集群内主机近一个月内存利用率均值。

  • 存储利用率：集群中所有主机本地存储的利用率。

主机资源：

  • 状态：主机当前的状态，包括正常、不正常、维护模式、主机不在集群HA内。

  • 管理IP地址：主机管理网口的IP地址。

  • 本地磁盘容量：主机本地磁盘的空间大小。

  • 本地磁盘利用率：主机本地磁盘的利用率百分比。

  • 虚拟机概要：各主机上虚拟机总数以及处于“运行”和“关闭”状态的虚拟机数量。

  • CPU：主机CPU总核数。

  • 内存：主机的内存容量。

  • CPU利用率均值（近一个月）：主机近一个月CPU利用率均值。

  • CPU利用率峰值（近一个月）：主机近一个月CPU利用率峰值。

  • 内存利用率均值（近一个月）：主机近一个月内存利用率均值。

  • 内存利用率峰值（近一个月）：主机近一个月内存利用率峰值。

虚拟机资源：

  • 显示名称：虚拟机的显示名称。

  • 主机名称：虚拟机所在主机的名称。

  • 状态：虚拟机的状态，包括运行、暂停、关闭、未知、HA异常。

  • 操作系统：虚拟机的操作系统。

  • vCPUs：虚拟机当前的CPU总核数（即CPU个数与每个CPU核数的乘积）。

  • CPU利用率峰值（近一个月）：虚拟机近一个月CPU利用率峰值。

  • CPU利用率均值（近一个月）：虚拟机近一个月CPU利用率均值。

  • 内存：虚拟机当前的内存容量。

  • 内存利用率峰值（近一个月）：虚拟机近一个月内存利用率峰值。

  • 内存利用率均值（近一个月）：虚拟机近一个月内存利用率均值。

  • 分配容量：已分配给虚拟机磁盘的虚拟容量总和。

  • 已用容量：虚拟机已被使用的磁盘容量。

  • 剩余容量：虚拟机剩余可用的磁盘容量。

  • 创建时间：虚拟机的创建时间。


存储清理

该功能用于扫描和清理存储池中空闲的未被虚拟机使用的存储卷。

注意事项

操作员在清理存储卷时，请仔细核实存储卷的实际使用情况，谨慎删除。

操作步骤

  1. 鼠标指针指向管理平台首页顶部的<一键>按钮，选择[存储清理]菜单项进入一键存储清理页面。

  2. 单击<开始扫描>按钮，扫描出存储池中空闲的存储卷信息。

  3. 选择需要清理的存储卷，或者单击<全选>按钮选择全部空闲的存储卷。

  4. 单击<一键清理>按钮，清理选中的存储卷。


资源导出

该功能用于查询和导出系统内集群、主机或虚拟机的信息。

操作步骤

  1. 鼠标指针指向管理平台首页顶部<一键>按钮，选择[资源导出]菜单项，进入一键资源导出页面。

  2. 单击<打印>按钮可打印相应的信息。

  3. 单击<导出>按钮可导出相应的信息。

  • 当资源类型选择为集群或主机时，单击<导出>按钮，弹出资源导出对话框，选择导出格式，单击<确定>按钮，导出相应信息。

  • 当资源类型选择为虚拟机时，弹出资源导出对话框，选择导出格式、列名定制，单击<确定>按钮。若不开启列名定制，则直接完成导出操作。若开启列名定制，则弹出列名定制对话框，选择需要导出的列名，单击<确定>按钮，完成导出操作。


虚机还原

该功能用于还原虚拟机磁盘状态到创建虚拟机还原点时的状态。

  • 一键还原虚拟机之前需要先创建虚拟机还原点。创建虚拟机还原点的具体操作，请参见 创建还原点 。

注意事项

  • 执行还原时，虚拟机的磁盘会被还原到创建还原点时的状态。还原擦除的数据不可逆。

  • 执行还原时，虚拟机的配置（CPU、内存、网络等）不会被还原。

  • 执行还原后，该虚拟机所有的历史快照都将丢失。

虚机还原

  1. 鼠标指针指向管理平台界面顶部的<一键>按钮，选择[虚机还原]菜单项进入一键虚机还原页面。

  2. 选择要还原的虚拟机，单击<还原>按钮，弹出虚拟机还原确认对话框。

  3. 单击<确定>按钮完成操作。

删除还原点

  1. 鼠标指针指向管理平台界面顶部的<一键>按钮，选择[虚机还原]菜单项进入一键虚机还原页面。

  2. 选择要删除的还原点，单击<删除>按钮，弹出确认对话框。

  3. 单击<确定>按钮完成操作。


僵尸虚拟机管理

僵尸虚拟机是指长时间未使用且处于关闭状态的虚拟机。

僵尸虚拟机管理提供了启动、删除、批量启动和批量删除僵尸虚拟机的功能。

启动僵尸虚拟机

  1. 鼠标指针指向管理平台界面顶部的<一键>按钮，选择[僵尸虚机]菜单项，进入一键僵尸虚拟机页面。

  2. 选择待启动的僵尸虚拟机，单击对应操作列的 [image] 图标，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

批量启动僵尸虚拟机

  1. 鼠标指针指向管理平台界面顶部的<一键>按钮，选择[僵尸虚机]菜单项，进入一键僵尸虚拟机页面。

  2. 在列表中选中多个虚拟机，单击<批量操作>按钮，选择[启动]菜单项，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

删除僵尸虚拟机

  1. 鼠标指针指向管理平台界面顶部的<一键>按钮，选择[僵尸虚机]菜单项，进入一键僵尸虚拟机页面。

  2. 选择要删除的虚拟机，单击对应操作列的 [image] 图标，弹出删除虚拟机对话框。

  3. 选择删除虚拟机的方式。

  • 当虚拟机删除的方式选择移入回收站或保留虚拟机的数据存储文件时，单击<确定>按钮，弹出删除确认对话框，单击<确定>按钮完成操作。

  • 当虚拟机删除的方式选择删除虚拟机的数据存储文件时，单击<确定>按钮，弹出删除确认对话框，单击<确定>按钮，再次弹出删除确认对话框。在删除确认对话框的输入框中，根据提示输入“DELETE”，单击<确定>按钮完成操作。

批量删除僵尸虚拟机

  1. 鼠标指针指向管理平台界面顶部的<一键>按钮，选择[僵尸虚机]菜单项，进入一键僵尸虚拟机页面。

  2. 在列表中选中多个虚拟机，单击<批量操作>按钮，选择[删除]菜单项，弹出删除虚拟机对话框。

  3. 选择删除虚拟机的方式。

  • 当虚拟机删除的方式选择移入回收站或保留虚拟机的数据存储文件时，单击<确定>按钮，弹出删除确认对话框，单击<确定>按钮完成操作。

  • 当虚拟机删除的方式选择删除虚拟机的数据存储文件时，单击<确定>按钮，弹出删除确认对话框，单击<确定>按钮，再次弹出删除确认对话框。在删除确认对话框的输入框中，根据提示输入“DELETE”，单击<确定>按钮完成操作。


云业务管理

ARM架构主机暂不支持智能资源调度、异构平台迁移功能。

云业务是结合实际应用场景，提供资源的动态管理和分配、数据中心站点的异地备份及恢复、不同数据中心之间资源共享的服务。

主要功能

  • 动态资源扩展管理

  • 智能资源调度管理

  • 容灾管理

  • 云彩虹管理


动态资源扩展管理

动态资源扩展可以定时监控业务系统的资源利用率负载情况，根据业务负载的变化动态的增加或减少业务虚拟机运行的数量，为业务系统提供弹性可扩展、伸缩的资源池。

主要功能

  • 动态资源扩展业务管理

  • 业务监控配置

  • 定时扩展策略管理

  • 纵向扩展策略设置

  • LB联动资源配置

  • 查看动态资源扩展业务概要信息

  • 查看动态资源扩展业务的虚拟机信息

  • 查看动态资源扩展业务资源监控信息

  • 查看动态资源扩展业务LB联动资源


动态资源扩展业务管理

动态资源扩展业务是将集群内多个实现同一业务的虚拟机添加到一个业务虚拟机组中，通过定时检查业务虚拟机组中虚拟机的连接数、CPU和内存的平均利用率，并根据设置的资源扩展监控策略及注入模式、资源回收监控策略及回收模式，自动调整业务虚拟机组中虚拟机的数量。

通过动态资源扩展业务功能，能够实现单业务系统的资源负载分担。

动态资源扩展业务管理包括增加动态资源扩展业务、修改动态资源扩展业务、删除动态资源扩展业务、启动动态资源扩展业务，关闭动态资源扩展业务和重新发布虚拟机等功能。

注意事项

  • 当扩展监控策略和回收监控策略所设置的阈值条件被同时满足时，系统将自动扩展虚拟机，而回收监控策略将不生效。

  • 删除动态资源扩展业务时，由该动态资源扩展业务创建的虚拟机不会被删除。

  • 当动态资源扩展资源注入模式为快速克隆时，如需克隆虚拟机的全部数据，需要手动执行“重新发布”。重新发布后，作为快速克隆对象的虚拟机会先进行一次镜像合并，再进行快速克隆。

增加动态资源扩展业务

  1. 单击导航树中[云业务/动态资源扩展]菜单项，进入动态资源扩展业务列表页面。

  2. 单击<增加动态资源扩展>按钮，弹出增加动态资源扩展对话框。

  3. 设置相关参数，关于参数的详细介绍，请参见 参数说明 。

  4. 单击<完成>按钮完成操作。

修改动态资源扩展业务

  1. 单击导航树中[云业务/动态资源扩展]菜单项，进入动态资源扩展业务列表页面。

  2. 选择待修改的动态资源扩展业务，单击对应操作列的 [image] 图标，弹出修改动态资源扩展对话框。

  3. 修改相关参数，关于参数的详细介绍，请参见 参数说明 。

  4. 单击<完成>按钮完成操作。

删除动态资源扩展业务

  1. 单击导航树中[云业务/动态资源扩展]菜单项，进入动态资源扩展业务列表页面。

  2. 选择待删除的动态资源扩展业务，单击对应操作列的 [image] 图标，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

启动动态资源扩展业务

  1. 单击导航树中[云业务/动态资源扩展]菜单项，进入动态资源扩展业务列表页面；或者单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入动态资源扩展业务的概要页面。

  2. 在动态资源扩展业务列表页面中选择待启动的动态资源扩展业务，单击对应操作列的 [image] 图标；或者在动态资源扩展业务的概要页面中，单击<启动动态资源扩展>按钮。

  3. 在弹出的对话框中选择生效类型。

  4. 单击<确定>按钮完成操作。

关闭动态资源扩展业务

  1. 单击导航树中[云业务/动态资源扩展]菜单项，进入动态资源扩展业务列表页面；或者单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入动态资源扩展业务的概要页面。

  2. 在动态资源扩展业务列表页面中选择待关闭的动态资源扩展业务，单击对应操作列的 [image] 图标；或者在动态资源扩展业务的概要页面中，单击<关闭动态资源扩展>按钮。

  3. 在弹出的确认对话框中，单击<确定>按钮完成操作。

重新发布虚拟机

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入动态资源扩展业务的概要页面。

  2. 在动态资源扩展业务的概要页面-基本属性中，单击虚拟机参数对应的图标。

  3. 在弹出的对话框中，单击<确定>按钮完成操作。

参数说明

基本信息：

  • 集群：动态资源扩展业务所运行的集群。

  • 存储：指定存储池后，动态扩展的虚拟机只会使用指定的共享存储池。

  • 备用集群：动态资源扩展业务所运行的备用集群，主集群无法满足扩展条件时，虚拟机会向备用集群进行扩展。当资源注入模式选择为快速克隆时，主备集群必须使用相同的共享存储，虚拟机才会向备用集群扩展。

  • 存储：指定存储池后，向备用集群扩展的虚拟机只会使用指定的共享存储池。

  • 虚拟机个数：动态资源扩展业务支持的虚拟机最大个数，即对应的业务虚拟机组允许存在虚拟机的最大个数。只能输入整数，默认值为20。

  • 生效类型：动态资源扩展业务是否生效（包括：立即生效、时间段内生效、不生效，默认值为不生效）。

  • 立即生效：指动态资源扩展业务在创建完成后立即生效。

  • 时间段内生效：指动态资源扩展业务在设置的时间段内生效。

  • 不生效：指动态资源扩展业务不生效。

  • 生效开始时间：动态资源扩展业务生效的开始时间。当生效类型选择“时间段内生效”时需设置此参数。只设置起始时间，表示在该时间之后，动态资源扩展业务将一直生效。

  • 生效结束时间：动态资源扩展业务生效的结束时间。当生效类型选择“时间段内生效”时需设置此参数。只设置结束时间时，表示动态资源扩展业务从当前时间到结束时间一直生效。

  • 绑定LB联动资源：动态资源扩展业务虚拟机组是否绑定LB负载均衡设备。选择“是”时，需要设置“LB配置”的相关参数。

业务参数：

  • 持续时间：允许业务虚拟机组中虚拟机的CPU、内存的平均利用率以及连接数连续超过扩展监控策略中阈值或者连续低于回收监控策略中阈值的时间。只能输入整数，默认值为30秒。

  • 检查时间间隔：检查业务虚拟机组中虚拟机的CPU、内存利用率以及连接数的时间间隔。只能输入整数，默认值为30秒。

  • 资源注入配置：选择资源扩展的监控策略。当业务虚拟机组中虚拟机的CPU、内存利用率、连接数、网络流量、磁盘I/O、磁盘请求在持续时间内连续符合扩展监控策略设置的阈值时，动态资源扩展业务将启动资源扩展，即在业务虚拟机组中自动创建虚拟机。

  • 资源注入模式：在业务虚拟机组中创建虚拟机的模式（包括：快速部署、快速克隆，默认值为快速部署）。

  • 快速部署：通过选择的虚拟机模板，在业务虚拟机组中进行快速部署来创建新的虚拟机。

  • 快速克隆：通过选择被克隆的虚拟机，在业务虚拟机组中进行快速克隆来创建新的虚拟机。

  • 每次扩展的个数：当动态资源扩展业务进行资源扩展时，每次创建的虚拟机数量，最小值为1，最大值为100。此参数与“每次扩展百分比”只能同时设置一个。

  • 每次扩展百分比：当动态资源扩展业务进行资源扩展时，每次扩展虚拟机数量的百分比，最小值为1，最大值为100；在配置此参数后，每次扩展的虚拟机数量由当前运行的业务虚拟机数量乘以“每次扩展百分比”后，再向上取整得到。例如：当前运行的业务虚拟机是10个，扩展百分比设置为35，那么每次扩展的数量就是10*0.35=3.5个，再向上取整为4。此参数与“每次扩展的个数”只能同时设置一个。

  • 资源回收配置：选择资源回收的监控策略。当业务虚拟机组中虚拟机的CPU、内存利用率、连接数、网络流量、磁盘I/O、磁盘请求在持续时间内连续符合回收监控策略设置的阈值时，动态资源扩展业务将启动资源回收，即自动回收业务虚拟机组中的虚拟机。

  • 资源回收类型：业务虚拟机组中虚拟机的回收策略，包括立即回收、温暖下线，默认值为温暖下线。

  • 立即回收：当虚拟机达到回收条件时，立即对虚拟机执行回收动作。

  • 温暖下线：当虚拟机达到回收条件时，立即阻断虚拟机接收TCP报文，并每隔10秒钟查询一次虚拟机的发送报文数是否低于“回收阈值”。若低于“回收阈值”，则立即对虚拟机执行回收动作；若不低于“回收阈值”，则继续等待直到虚拟机的发送报文数低于“回收阈值”或者等待时间达到预置的“超时时间”，立即对虚拟机执行回收动作。

  • 回收阈值：温暖下线回收虚拟机时，虚拟机发送报文数的最大值，默认值为50。当资源回收模式选择“温暖下线”时，才需配置此参数。

  • 超时时间：等待温暖下线回收虚拟机的超时时间，默认值为10分钟。当资源回收模式选择“温暖下线”时，才需配置此参数。

  • 资源回收模式：业务虚拟机组中虚拟机的回收模式，包括关闭虚拟机、删除虚拟机、休眠虚拟机，默认值为关闭虚拟机。

  • 关闭虚拟机：指回收虚拟机时，直接关闭该虚拟机电源。

  • 删除虚拟机：指回收虚拟机时，直接删除该虚拟机。

  • 休眠虚拟机：指回收虚拟机时，直接将该虚拟机休眠。

  • 保留运行的个数：动态资源扩展业务进行资源回收时，至少需要保留处于“运行”状态的虚拟机个数，默认值为1。

虚拟机组：

  • 业务虚拟机：将运行同一个业务的若干虚拟机增加到一个业务虚拟机组中。

扩展信息：

  • 虚拟机模板：选择部署虚拟机所使用的虚拟机模板。当资源注入模式为“快速部署”时，需要配置此参数。

  • 虚拟机克隆对象：选择虚拟机克隆的对象。当资源注入模式为“快速克隆”时，需要配置此参数。在基本信息配置中，若将存储指定为共享文件系统类型的存储池，则虚拟机克隆对象只能是磁盘为文件的虚拟机；若指定为RBD网络存储类型的存储池，则虚拟机克隆对象只能是挂载了RBD块的虚拟机，且此RBD块与指定的RBD网络存储池属于同一分布式存储资源。同时虚拟机还需符合如下条件：（1）虚拟机上不存在USB、PCI、SR-IOV、TPM设备；（2）虚拟机未绑定NUMA节点或物理CPU；（4）虚拟机磁盘为文件时，其存储格式为智能且预分配为精简。

  • 虚拟机前缀名称：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的名称前缀。

  • 起始编号：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的起始编号，将会显示在虚拟机名称前缀的后面。创建虚拟机时，虚拟机名称前缀后面的编号会一直不断的累加。

  • IPv4配置：

  • 起始IP：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的起始IP地址。

  • 终止IP：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的终止IP地址。在设置起始IP和终止IP时，需要预留足够的可分配IP地址。

  • 子网掩码：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建的虚拟机的子网掩码。

  • 默认网关：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建的虚拟机的默认网关。

  • IPv6配置：

  • 起始IP：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的起始IPv6地址。

  • 终止IP：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的终止IPv6地址。在设置起始IP和终止IP时，需要预留足够的可分配IP地址。

  • 网络前缀：虚拟机IPv6地址对应的前缀长度。

  • 默认网关：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建的虚拟机的默认网关。

  • LB配置：

  • 绑定IP类型：动态资源扩展业务使用的负载均衡设备的IP地址类型。

  • LB设备：动态资源扩展业务虚拟机组使用的负载均衡设备。负载均衡设备负责将流量根据设置的策略分发到后端各真正提供业务的虚拟机上。

  • 虚服务器：虚拟服务器拥有一个虚拟IP，负责接收用户的访问请求，然后由负载均衡设备选择一个业务虚拟机进行响应。

  • 实服务组：实服务组内是真实提供业务的虚拟机。

  • 虚拟机业务端口：虚拟机提供业务的端口，不同的端口对应不同的服务。


业务监控配置

该功能用于配置动态资源扩展业务的负载监控策略。

在动态资源扩展业务对应的业务虚拟机组中，如果虚拟机的CPU、内存平均利用率以及连接数、网络流量、磁盘I/O、磁盘请求连续符合或者超过扩展监控策略中阈值的时间达到设置的持续时间，系统将自动为业务虚拟机组创建虚拟机；如果虚拟机的CPU、内存平均利用率以及连接数、网络流量、磁盘I/O、磁盘请求连续低于回收监控策略中阈值的时间达到设置的持续时间，系统将自动回收业务虚拟机组中的虚拟机。

操作步骤

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入该动态资源扩展业务的概要信息页面。

  2. 单击<业务监控>按钮，弹出业务监控配置对话框。

  3. 根据实际情况设置相关参数。

  4. 单击<确定>按钮完成操作。

参数说明

  • 持续时间：允许业务虚拟机组中虚拟机的CPU、内存的平均利用率以及连接数连续超过扩展监控策略中阈值或者连续低于回收监控策略中阈值的时间。只能输入整数，默认值为30秒。

  • 时间间隔：检查业务虚拟机组中虚拟机的CPU、内存利用率以及连接数的时间间隔。只能输入整数，默认值为30秒。

  • 扩展监控策略：选择资源扩展的监控策略。当业务虚拟机组中虚拟机的CPU、内存利用率、连接数、网络流量、磁盘I/O、磁盘请求在持续时间内连续超过监控策略设置的阈值时，动态资源扩展业务将启动资源扩展，即在业务虚拟机组中自动创建虚拟机。监控策略中的“条件”、“运算符”和“阈值”请根据实际情况进行选择，例如CPU利用率>=80%或内存利用率>=70%或连接数>=100。

  • 回收监控策略：选择资源回收的监控策略。当业务虚拟机组中虚拟机的CPU、内存利用率、连接数、网络流量、磁盘I/O、磁盘请求在持续时间内连续小于监控策略设置的阈值时，动态资源扩展业务将启动资源回收，即自动回收业务虚拟机组中的虚拟机。监控策略中的“条件”、“运算符”和“阈值”可以根据实际情况进行选择，例如CPU利用率<=30%或内存利用率<=20%或连接数<=10。


定时扩展策略管理

定时扩展策略用于在指定时间周期内强制扩展虚拟机。

某些应用系统的业务峰值是可以预知的，例如学校的选课系统。在每学期末的选课时间段里，系统总是异常繁忙，其他时间段则相对空闲。当选课系统应用定时扩展策略后，到达该时间段时，CVM会对选课系统所在的虚拟机进行自动扩展，而不管实际业务负载的大小，提升学生在选课时的访问体验。

注意事项

  • 定时扩展频率为“每天”时，如果时间段的起始时间设置早于当前CVM的时间，则该定时扩展从第二天开始生效。

  • 定时扩展的轮询周期默认值为10分钟，在定时扩展的时间段内，即使满足回收或者扩展条件，动态资源扩展业务也不会回收或者扩展虚拟机。

  • 在定时扩展的时间段外，如果业务虚拟机组内的虚拟机符合资源回收策略，扩展的虚拟机将会被自动回收。

增加定时扩展策略

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入该动态资源扩展业务的概要信息页面。

  2. 单击<定时扩展策略设置>按钮，弹出定时扩展策略对话框。

  3. 单击<增加>按钮，弹出增加定时扩展策略对话框。

  4. 设置相关参数，关于参数的详细介绍，请参见 参数说明 。

  5. 单击<确定>按钮，完成操作。

修改定时扩展策略

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入该动态资源扩展业务的概要信息页面。

  2. 单击<定时扩展策略设置>按钮，弹出定时扩展策略对话框。

  3. 选择待修改的定时扩展策略，单击对应操作列的 [image] 图标，弹出修改定时扩展策略对话框。

  4. 修改相关参数，关于参数的详细介绍，请参见 参数说明 。

  5. 单击<确定>按钮，完成操作。

删除定时扩展策略

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入该动态资源扩展业务的概要信息页面。

  2. 单击<定时扩展策略设置>按钮，弹出定时扩展策略对话框。

  3. 选择待删除的定时扩展策略，单击对应操作列的 [image] 图标，弹出确认提示对话框。

  4. 单击<确定>按钮，完成操作。

查看定时扩展策略信息

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入该动态资源扩展业务的概要信息页面。

  2. 单击<定时扩展策略设置>按钮，弹出定时扩展策略对话框。

  3. 选择要查看的定时扩展策略，单击对应操作列的 [image] 图标，弹出查看定时扩展策略对话框。

参数说明

增加或修改定时扩展策略：

  • 每次扩展的个数：每次定时扩展的虚拟机数量，最小值为1，最大值为100。

  • 频率：定时扩展虚拟机的周期。

  • 开始时间：执行定时扩展策略的时间段起点。

  • 截止时间：执行定时扩展策略的时间段终点。

  • 立即生效：定时扩展策略是否生效。

定时扩展策略列表：

  • 每次扩展数量：即每次扩展的虚拟机数量。

  • 生效时间段：定时扩展策略生效的时间段。

  • 状态：定时扩展策略的状态（包括：生效、不生效）。

  • 操作：在列可以编辑、删除，或查看定时扩展策略详细信息。


纵向扩展策略设置

纵向扩展策略可以在指定条件下扩展业务虚拟机组内虚拟机的CPU和内存。

当虚拟机的CPU、内存利用率超过纵向扩展策略中设置的阈值时，系统将自动为业务虚拟机组内的虚拟机增加相应的CPU或者内存。

该功能用于配置动态资源扩展业务的纵向扩展策略。

操作步骤

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入该动态资源扩展业务的概要信息页面。

  2. 单击<纵向扩展策略设置>按钮，弹出纵向扩展策略对话框。

  3. 根据需要启用CPU设置和内存设置。

  4. 启用CPU设置需要输入CPU利用率阈值、每次扩展CPU个数、最大限制（CPU）；启用内存设置需要输入内存利用率阈值、每次扩展内存大小、最大限制（内存）。

  5. 单击<确定>按钮完成操作。

参数说明

  • 启用CPU设置：用于启用纵向扩展业务CPU策略。

  • CPU利用率：虚拟机的CPU利用率的纵向扩展阈值，超过该值就会给对应虚拟机增加CPU，默认值为空。

  • 每次扩展CPU：系统每次给虚拟机增加的CPU个数，默认值为空。

  • 最大限制（CPU）：虚拟机CPU扩展的最大限制，即业务虚拟机组内的虚拟机CPU核数的最大值，默认值为空。

  • 启用内存设置：用于启动纵向扩展业务内存策略。

  • 内存利用率：虚拟机的内存利用率的纵向扩展阈值，默认值为空。

  • 每次扩展内存：系统每次给虚拟机增加的内存大小，默认值为空。

  • 最大限制（内存）：虚拟机内存扩展的最大限制，即业务虚拟机组内的虚拟机内存的最大值，默认值为空。


LB联动资源配置

该功能用于为动态资源扩展业务虚拟机组配置负载均衡设备。

配置前提

有可用的LB设备，且LB设备已做好了相关配置。

操作步骤

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入该动态资源扩展业务的概要信息页面。

  2. 单击<LB联动资源配置>按钮，弹出LB联动资源配置对话框。

  3. 根据实际情况设置相关参数。

  4. 单击<确定>按钮完成操作。

参数说明

  • 起始IP：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的起始IP地址。

  • 终止IP：动态资源扩展业务进行资源扩展时，在业务虚拟机组中创建虚拟机的终止IP地址。在设置起始IP和终止IP时，需要预留足够的可分配IP地址。

  • LB设备：动态资源扩展业务虚拟机组使用的负载均衡设备。负载均衡设备负责将流量根据设置的策略分发到后端各真正提供业务的虚拟机上。

  • 虚服务器：虚拟服务器拥有一个虚拟IP，负责接收用户的访问请求，然后由负载均衡设备选择一个业务虚拟机进行响应。

  • 实服务组：实服务组内是真实提供业务的虚拟机。

  • 虚拟机业务端口：虚拟机提供业务的端口，不同的端口对应不同的服务。

  • 实服务组调度算法：LB设备根据调度算法来选择实服务组内提供服务的业务虚拟机。

  • 实服务组健康检测方法：LB设备会对实服务组内的业务虚拟机进行健康检测，当发现某个虚拟机不能提供服务后，后续的请求均不会发往该虚拟机。虚拟机恢复后，LB设备会恢复对该虚拟机的使用，这一过程对用户来说是透明的。


查看动态资源扩展业务概要信息

该功能用于查看动态资源扩展业务的概要信息、资源使用情况的统计信息。

操作步骤

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入该动态资源扩展业务的概要信息页面。

参数说明

  • 基本属性：显示动态资源扩展业务的基本信息。

  • 业务名称：动态资源扩展业务的名称。

  • 集群：动态资源扩展业务运行的集群。

  • 虚拟机最大个数：动态资源扩展业务支持的虚拟机最大个数，即对应的业务虚拟机组允许存在虚拟机的最大个数。

  • 当前虚拟机个数：动态资源扩展业务对应的业务虚拟机组中当前的虚拟机个数。

  • 资源注入模式：在动态资源扩展业务对应的业务虚拟机组中创建虚拟机的模式，包括快速部署、快速克隆。

  • 虚拟机/模板：被克隆的虚拟机名称或者所使用的虚拟机模板名称。当资源注入模式为“快速部署”时，此处显示部署虚拟机所使用的虚拟机模板名称；当资源注入模式为“快速克隆”时，此处显示被克隆的虚拟机名称。

  • 每次扩展的个数：动态资源扩展业务进行资源扩展时，每次创建的虚拟机个数。

  • 每次扩展百分比：当动态资源扩展业务进行资源扩展时，每次扩展虚拟机数量的百分比；在配置此参数后，每次扩展的的虚拟机数量由当前运行的业务虚拟机数量乘以“每次扩展百分比”后，再向上取整得到。例如：当前运行的业务虚拟机是10个，扩展百分比设置为35，那么每次扩展的数量就是10*0.35=3.5个，再向上取整为4。

  • 回收类型：业务虚拟机组中虚拟机的回收策略，包括立即回收、温暖下线。

  • 回收模式：业务虚拟机组中虚拟机的回收方式，包括关闭、删除、休眠虚拟机。

  • 状态：动态资源扩展业务的状态，包括生效、不生效。

  • 扩展监控策略：当业务虚拟机组中虚拟机对应的参数在持续时间内连续符合扩展监控策略设置的阈值时，动态资源扩展业务将启动资源扩展，即在业务虚拟机组中自动创建虚拟机。

  • 回收监控策略：当业务虚拟机组中虚拟机对应的参数在持续时间内连续符合回收监控策略设置的阈值时，动态资源扩展业务将启动资源回收，即自动回收业务虚拟机组中的虚拟机。

  • 业务资源CPU使用情况：显示了业务虚拟机组中所有处于“运行”状态的虚拟机近30分钟的CPU利用率平均值趋势图，横轴表示时间，纵轴表示CPU利用率百分比。

  • 业务资源内存使用情况：显示了业务虚拟机组中所有处于“运行”状态的虚拟机近30分钟的内存利用率平均值趋势图，横轴表示时间，纵轴表示内存利用率百分比。

  • 业务资源连接数统计：显示了业务虚拟机组中所有处于“运行”状态的虚拟机近30分钟的连接数趋势图，横轴表示时间，纵轴表示连接数个数。

  • 业务资源网络流量统计：显示了业务虚拟机组中所有处于“运行”状态的虚拟机近30分钟的网络流量统计趋势图，横轴表示时间，纵轴表示网络流量平均值，单位为Mbps。


查看动态资源扩展业务的虚拟机信息

该功能用于查看动态资源扩展业务对应的业务虚拟机组内的虚拟机信息。

操作步骤

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入该动态资源扩展业务的概要信息页面。

  2. 选择“虚拟机”页签，进入动态资源扩展业务的虚拟机信息页面。

  3. 增加业务组虚拟机：在虚拟机信息页面，单击 [image] 图标，在弹出的对话框中选择目标虚拟机为业务虚拟机，单击<确定>按钮。

  4. 设置虚拟机是否根据资源回收策略被系统自动回收： 图标表示自动回收； [image] 图标表示不回收，单击 [image] 或者 [image] 图标，更改虚拟机的自动回收状态。

参数说明

  • CPU利用率：显示所选虚拟机近30分钟的CPU利用率趋势图，横轴表示时间，纵轴表示CPU利用率百分比。

  • 内存利用率：显示所选虚拟机近30分钟的内存利用率趋势图，横轴表示时间，纵轴表示内存利用率百分比。

  • 连接数：显示所选虚拟机近30分钟的连接数趋势图，横轴表示时间，纵轴表示连接数。

  • 网络吞吐量统计：显示所选虚拟机近30分钟的网络吞吐量趋势图，横轴表示时间，纵轴表示网络吞吐量，单位为Mbps。

  • I/O吞吐量统计：显示所选虚拟机近30分钟的I/O吞吐量趋势图，横轴表示时间，纵轴表示I/O吞吐量，单位为KBps。

  • 磁盘请求：显示所选虚拟机近30分钟的磁盘请求趋势图，横轴表示时间，纵轴表示选中虚拟机磁盘请求数，单位IOPS。


查看动态资源扩展业务资源监控信息

该功能用于查看动态资源扩展业务对应业务虚拟机组的虚拟机资源平均利用率。

操作步骤

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入动态资源扩展业务的概要信息页面。

  2. 选择“业务资源监控”页签，进入动态资源扩展业务的资源监控页面。

参数说明

  • 业务资源CPU使用情况：显示了动态资源扩展业务对应的业务虚拟机组近30分钟CPU利用率平均值趋势图，横轴表示时间，纵轴表示CPU利用率百分比。

  • 业务资源内存使用情况：显示了动态资源扩展业务对应的业务虚拟机组近30分钟内存利用率平均值趋势图，横轴表示时间，纵轴表示内存利用率百分比。

  • 业务资源连接数统计：显示了动态资源扩展业务对应的业务虚拟机组近30分钟连接数平均值趋势图，横轴表示时间，纵轴表示连接数。

  • 业务资源网络流量统计：显示了动态资源扩展业务对应的业务虚拟机组近30分钟网络吞吐量平均值趋势图，横轴表示时间，纵轴表示网络吞吐量，单位为Mbps。

  • 业务资源磁盘I/O使用情况：显示了动态资源扩展业务对应的业务虚拟机组近30分钟I/O吞吐量平均值趋势图，横轴表示时间，纵轴表示I/O吞吐量，单位为KBps。

  • 业务资源磁盘请求数统计：显示了动态资源扩展业务对应的业务虚拟机组近30分钟磁盘请求平均值趋势图，横轴表示时间，纵轴表示每秒钟磁盘请求数。


查看动态资源扩展业务LB联动资源

该功能用于查看动态资源扩展业务配置的LB联动资源。

操作步骤

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入动态资源扩展业务的概要信息页面。

  2. 选择“LB联动资源”页签，进入动态资源扩展业务LB联动资源页面。

参数说明

  • 基本属性：显示框显示了动态资源扩展业务LB联动资源概要信息。

  • 设备名称：动态资源扩展业务应用的LB设备名称。

  • 设备管理地址：动态资源扩展业务应用的LB设备管理IP地址。

  • 虚服务器名称：动态资源扩展业务应用的LB设备配置的虚服务器名称。

  • 虚服务器类型：虚服务器提供的服务类型。

  • 虚服务器IP地址：虚服务器对外提供服务的IP地址。

  • 虚服务器端口号：虚服务器对外提供服务的端口号。

  • 实服务器组名称：实服务器组名称，实服务器组内为真实提供业务的虚拟机。

  • 调度算法：LB设备根据调度算法来选择实服务组内提供服务的业务虚拟机。

  • 健康检测方法：LB设备会对实服务组内的业务虚拟机进行健康检测，当发现某个虚拟机不能提供服务后，后续的请求均不会发往该虚拟机。虚拟机恢复后，LB设备会恢复对该虚拟机的使用，这一过程对用户来说是透明的。

  • 虚服务器组连接数统计：显示了虚服务器连接数趋势图，横轴表示时间，默认单位为30秒，纵轴表示连接数。

  • 虚拟机负载均衡统计：显示了处于LB实服务组虚拟机的负载均衡状态统计。

  • 虚拟机名称：处于LB联动资源实服务组的虚拟机名称。

  • IP地址：处于LB联动资源实服务组的虚拟机IP地址。

  • 活动连接数：处于LB联动资源实服务组的虚拟机活动连接的数量。

  • 最大连接数：处于LB联动资源实服务组的虚拟机当前最大并发连接数。

  • 连接总数：处于LB联动资源实服务组的虚拟机连接的总数。

  • LB联动状态：虚拟机是否注册到LB设备的实服务组（包括：注册、未注册）。

  • 操作：以图标的方式显示操作员可以对虚拟机执行的操作。 表示为虚拟机绑定IP地址； [image] 表示注册虚拟机，当虚拟机注册后，才能被LB当作实服务器使用。


查看动态资源扩展任务操作日志

该功能用于查看动态资源扩展任务操作日志。

操作步骤

  1. 单击导航树中[云业务/动态资源扩展/<动态资源扩展业务名称>]菜单项，进入该动态资源扩展业务的概要信息页面。

  2. 选择“任务”页签，进入该动态资源扩展业务的操作日志页面。

参数说明

  • 登录名：操作员登录管理平台所使用的登录名。

  • 操作员姓名：操作员的姓名。

  • 完成时间：操作员完成操作的时间。

  • 登录地址：操作员登录管理平台所使用计算机的IP地址。

  • 操作对象：执行的动态资源扩展业务。

  • 执行结果：操作的执行结果。

  • 成功：表示操作执行成功。

  • 部分成功：表示操作执行部分成功。

  • 失败：表示操作执行失败。

  • 失败原因：操作失败的详细原因。

  • 风险级别：操作执行对应的风险级别，包括高、中、低。

  • 事件类型：操作员所操作事件的类型。


智能资源调度管理

ARM架构主机暂不支持智能资源调度功能。

智能资源调度功能是将同一集群下不同主机上的物理资源添加到一个业务资源组中。将多个实现同一类业务的虚拟机添加到一个业务虚拟机组中。每一个虚拟机都会应用一个业务模板。业务模板定义了在资源紧缺时,虚拟机使用资源的优先级以及应用低优先级业务模板的所有虚拟机占用资源的最高比例。

当业务虚拟机组中的虚拟机启动或重启时，CVM能够自动根据业务资源组中的资源空闲情况、虚拟机使用业务模板的优先级以及业务模板的分配比例来动态分配资源。

系统目前仅支持GPU、vGPU资源的智能调度。

配置该功能时，需要先根据实际情况创建业务模板。业务模板描述了虚拟机使用主机物理资源的优先级。业务模板创建完成后，再创建智能资源调度业务。

主要功能

  • 业务模板管理

  • 智能资源调度业务管理

  • 查看智能资源调度业务的虚拟机信息

  • 查看智能资源调度业务的资源明细信息


业务模板管理

业务模板定义了一种业务类型，描述了虚拟机使用主机物理资源的优先级。当参与智能调度的资源紧张时，系统会根据虚拟机使用的业务模板优先级为虚拟机分配相关资源，优先级高的虚拟机优先获取相关资源。

系统默认存在两种业务模板，包括非编业务与转码合成业务，可根据实际需求增加其他业务模板。

业务模板管理包括增加业务模板、修改业务模板、删除业务模板和查看业务模板详细信息等功能。

注意事项

不允许删除已经被虚拟机使用的业务模板。

增加业务模板

  1. 单击导航树中[云业务/智能资源调度]菜单项，进入智能资源调度业务列表页面。

  2. 单击<业务模板>按钮，进入业务模板设置页面。

  3. 单击<增加>按钮，弹出增加业务模板对话框。

  4. 设置相关参数，关于参数的详细介绍，请参见 参数说明 。

  5. 单击<完成>按钮完成操作。

修改业务模板

  1. 单击导航树中[云业务/智能资源调度]菜单项，进入智能资源调度业务列表页面。

  2. 单击<业务模板>按钮，进入业务模板设置页面。

  3. 选择待修改的业务模板，单击对应操作列的 [image] 图标，弹出修改业务模板对话框。

  4. 根据实际情况修改相关参数，关于参数的详细介绍，请参见 参数说明 。

  5. 单击<完成>按钮完成操作。

删除业务模板

  1. 单击导航树中[云业务/智能资源调度]菜单项，进入智能资源调度业务列表页面。

  2. 单击<业务模板>按钮，进入业务模板设置页面。

  3. 选择待删除的业务模板，单击对应操作列的 [image] 图标，弹出确认对话框。

  4. 单击<确定>按钮完成操作。

查看业务模板详细信息

  1. 单击导航树中[云业务/智能资源调度]菜单项，进入智能资源调度业务列表页面。

  2. 单击<业务模板>按钮，进入业务模板设置页面。

  3. 选择要查看的业务模板，单击对应操作列的 [image] 图标，弹出查看业务模板对话框。

参数说明

  • 优先级：当主机参与智能调度的资源紧张即虚拟机有资源需求而主机无资源可分配给虚拟机时，管理平台将根据业务模板优先级调整资源分配。高优先级的虚拟机优先获取资源，低优先级的虚拟机存在资源被抢占的风险，请根据实际需求设置业务模板。

  • 资源紧张启动模式：当GPU/vGPU资源池中的资源紧张时，可以设置未分配到资源的业务虚拟机的启动策略，包括不启动、不带资源启动、抢占，缺省为不启动。

  • 不启动：当资源池中无可用资源或者剩余资源数量不满足虚拟机的资源个数要求时，不启动虚拟机。

  • 不带资源启动：当资源池中无可用资源时，不为虚拟机分配资源，直接启动虚拟机。当资源池中剩余资源数量不满足虚拟机的资源个数要求时，为虚拟机分配剩余资源并启动虚拟机；例如，资源池中有2个GPU资源，但虚拟机的GPU资源个数需求是3，此时可以正常启动虚拟机，并为虚拟机分配2个GPU资源。

  • 抢占：高优先级虚拟机可以抢占低优先级虚拟机已使用的资源。

  • 分配比例：当低优先级业务模板的所有虚拟机使用资源超过此值时，高优先级的虚拟机会抢占低优先级虚拟机所使用的资源。例如：集群内有10个GPU参与智能调度，低优先级业务模板分配比例为20%，则对应2个GPU，当应用该业务模板的所有虚拟机使用了5个GPU资源（分配比例为50％），超出此分配比例20％；如果此时有高优先级虚拟机启动，但GPU资源池内已经没有空闲GPU资源了，那么高优先级的虚拟机会抢占应用该低优先级业务模板的虚拟机所使用的GPU资源。注意平台内所有业务模板的分配比例之和不能超过100%。当资源紧张启动模式为抢占时，需要设置此参数。

  • 停止业务命令：虚拟机操作系统可执行的命令，如shutdown，用于释放虚拟机已经占有的主机上参与智能调度的资源，释放后其他虚拟机才可以使用。只有正确配置了此命令，系统才会尝试去释放虚拟机已使用的GPU/vGPU资源。当资源紧张启动模式为抢占时，需要设置此参数。

  • 命令返回结果：用于系统判断停止业务命令是否执行成功，即判断虚拟机执行停止业务命令返回结果与本参数内容是否一致。若一致，则表示停止业务命令执行成功，虚拟机会释放相关资源；若不一致，则表示停止业务命令执行失败，系统将根据停止失败处理方式查找下一个虚拟机继续执行停止业务命令或关闭当前虚拟机。当资源紧张启动模式为抢占时，需要设置此参数。

  • 停止失败处理方式：选择停止业务失败即释放资源失败时的处理方式，包括查找下一个、关闭虚拟机。当资源紧张启动模式为抢占时，需要设置此参数。

  • 查找下一个：当停止业务命令执行失败时，系统将尝试停止其它虚拟机的业务以释放资源。

  • 关闭虚拟机电源：当停止业务命令执行失败时，直接关闭当前虚拟机的电源，以释放资源。


智能资源调度业务管理

智能资源调度业务能够根据资源池中资源的空闲情况、虚拟机使用业务模板的优先级以及业务模板的分配比例来动态分配资源。

以GPU资源为例：在智能资源调度业务中，虚拟机以直通的方式使用主机的GPU资源，一个GPU资源同时只能透传给一个虚拟机使用。当虚拟机所在主机没有可用GPU资源时，系统会自动将虚拟机以“更改主机”的方式迁移到集群内其他有空闲GPU资源的主机上。当集群内GPU资源紧张时，应用高优先级业务模板的虚拟机在启动时将会抢占应用低优先级业务模板的虚拟机已使用的资源。如果应用相同低优先级业务模板的虚拟机，其使用的资源比例没有超过该业务模板的分配比例，则低优先级虚拟机的资源不会被抢占。

智能资源调度业务管理包括增加智能资源调度业务、修改智能资源调度业务和删除智能资源调度业务等功能。

注意事项

  • 应用智能资源调度业务的虚拟机，其镜像文件需存储在共享存储上，且参与智能调度的资源所在的主机都挂在了该共享存储。如果虚拟机的镜像文件不在共享存储上，那么该虚拟机只能使用所在主机的物理资源。

  • 当资源类型是vGPU时，只能选择同一类型的vGPU资源加入业务资源组。

  • 物理GPU虚拟化后，不能再增加到资源类型为GPU的业务资源组中。

增加智能资源调度业务

  1. 单击导航树中[云业务/智能资源调度]菜单项，进入智能资源调度业务列表页面。

  2. 单击<增加智能资源调度业务>按钮，弹出增加智能资源调度业务对话框。

  3. 设置相关参数，关于参数的详细介绍，请参见 参数说明 。

  4. 单击<确定>按钮完成操作。

修改智能资源调度业务

  1. 单击导航树中[云业务/智能资源调度]菜单项，进入智能资源调度业务列表页面。

  2. 选择待修改的智能资源调度业务，单击对应操作列的 [image] 图标，弹出修改智能资源调度业务对话框。或者单击导航树中[云业务/智能资源调度/<智能资源调度业务名称>]菜单项，进入智能资源调度的虚拟机信息页面，单击<修改智能资源调度业务>按钮，弹出修改智能资源调度业务对话框。

  3. 根据实际情况修改相关参数。关于参数的详细介绍，请参见 参数说明 。

  4. 单击<确定>按钮完成操作。

删除智能资源调度业务

  1. 单击导航树中[云业务/智能资源调度]菜单项，进入智能资源调度业务列表页面。

  2. 选择待删除的智能资源调度业务，单击对应操作列的 [image] 图标，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

参数说明

基本信息：

  • 集群：智能资源调度业务所运行的集群。

  • 资源类型：智能资源调度业务中的资源类型，系统当前仅支持GPU、vGPU类型的资源。

业务资源信息：

  • UUID：vGPU的UUID，即虚拟化时生成的唯一标识符。当资源类型为vGPU时，才会显示此选项。

  • 名称：vGPU的类型的名称。当资源类型为vGPU时，才会显示此选项。

  • 显示器接口数：vGPU支持的最大显示器接口数。当资源类型为vGPU时，才会显示此选项。

  • 缓存：vGPU支持的帧缓冲区大小。当资源类型为vGPU时，才会显示此选项。

  • 分辨率：vGPU支持的最大分辨率。当资源类型为vGPU时，才会显示此选项。

  • 槽号：资源对应的槽号。

  • 设备厂商：资源的设备厂商。当资源类型为GPU时，才会显示此选项。

  • 主机：资源所在的主机。

业务虚拟机组－增加业务虚拟机：

  • 业务模板：选择虚拟机所使用的业务模板。

  • 主机：虚拟机所属的主机。

  • 驱动类型：虚拟机使用资源的驱动类型。

  • 资源独占：虚拟机是否独享GPU/vGPU资源。选择“否”，表示虚拟机在关闭状态下不会绑定GPU/vGPU资源。选择“是”，无论虚拟机处于何种状态，虚拟机会一直绑定GPU/vGPU资源，该GPU/vGPU资源为虚拟机独享，不能被其他虚拟机使用。只有当宿主机存在空闲GPU/vGPU资源，且该空闲资源已加入所选GPU资源池时，才允许开启资源独占。开启资源独占后，当集群内其他主机有满足条件的GPU/vGPU资源时，虚拟机在关机状态下允许迁移至该主机上，否则不允许迁移虚拟机。

  • 资源个数：设置虚拟机使用GPU/vGPU资源的数量。选择vGPU类型的资源池时，资源个数最大值为1。选择GPU类型的资源池，且未开启资源独占，资源个数最大值为该资源池内单个主机的最大GPU数量，例如在该资源池中A主机有3个GPU，B主机有2个，C主机有2个，则最大值为3；若开启了资源独占，则资源个数最大值为该资源池内宿主机的空闲GPU数量。


查看智能资源调度业务的虚拟机信息

该功能用于查看智能资源调度业务对应的虚拟机信息。

操作步骤

  1. 单击导航树中[云业务/智能资源调度/<智能资源调度业务名称>]菜单项，进入该智能资源调度业务的虚拟机信息页面。

参数说明

  • 显示名称：虚拟机的显示名称。

  • 状态：虚拟机运行状态，包括：运行、暂停、关闭、未知、HA异常。

  • CPU利用率：虚拟机CPU一小时内的平均利用率。

  • 内存利用率：虚拟机内存一小时内的平均利用率。

  • 操作系统：虚拟机上运行的操作系统。

  • 业务模板：虚拟机所使用的业务模板。

  • 驱动类型：虚拟机使用资源时所用的驱动类型。

  • 槽号：虚拟机正在使用的资源对应的槽号。

  • 主机：虚拟机所属的主机。

  • 独占：显示虚拟机是否独占GPU资源。“否”表示虚拟机运行状态下使用GPU/vGPU资源，关闭时释放资源，该资源可以被其他虚拟机使用。“是”表示虚拟机在关闭状态下仍会绑定GPU/vGPU资源。

  • 个数：显示虚拟机使用的GPU/vGPU资源的数量。


查看智能资源调度业务的资源明细信息

该功能用于查看指定智能资源调度业务的资源明细信息。

操作步骤

  1. 单击导航树中[云业务/智能资源调度/<智能资源调度业务名称>]菜单项，进入该智能资源调度业务的虚拟机信息页面。

  2. 选择“资源明细”页签，进入该智能资源调度业务的资源明细信息列表页面。

参数说明

  • UUID：vGPU的UUID，即虚拟化时生成的唯一标识符。当资源类型为vGPU时，才会显示此选项。

  • 名称：vGPU的类型的名称。当资源类型为vGPU时，才会显示此选项。

  • 类型：vGPU的类型。当资源类型为vGPU时，才会显示此选项。

  • 显示器接口数：vGPU支持的最大显示器接口数。当资源类型为vGPU时，才会显示此选项。

  • 缓存：vGPU支持的帧缓冲区大小。当资源类型为vGPU时，才会显示此选项。

  • 分辨率：vGPU支持的最大分辨率。当资源类型为vGPU时，才会显示此选项。

  • 槽号：资源对应的槽号。

  • 设备厂商：资源的设备厂商。当资源类型为GPU时，才会显示此选项。

  • 主机：资源所在的主机。

  • 状态：资源的使用状态，包括：空闲、使用中。

  • 虚拟机：正在使用资源的虚拟机，如果状态为“空闲”，则此项为空。


查看智能资源调度业务的资源使用历史信息

该功能用于查看智能资源调度业务的资源使用历史信息。

操作步骤

  1. 单击导航树中[云业务/智能资源调度/<智能资源调度业务名称>]菜单项，进入智能资源调度业务的虚拟机信息页面。

  2. 选择“资源使用历史”页签，进入智能资源调度业务的资源使用历史信息列表页面。

参数说明

  • UUID：vGPU的UUID，即虚拟化时生成的唯一标识符。当资源类型为vGPU时，才会显示此选项。

  • 名称：vGPU的类型的名称。当资源类型为vGPU时，才会显示此选项。

  • 类型：vGPU的类型。当资源类型为vGPU时，才会显示此选项。

  • 显示器接口数：vGPU支持的最大显示器接口数。当资源类型为vGPU时，才会显示此选项。

  • 缓存：vGPU支持的帧缓冲区大小。当资源类型为vGPU时，才会显示此选项。

  • 分辨率：vGPU支持的最大分辨率。当资源类型为vGPU时，才会显示此选项。

  • 槽号：资源对应的槽号。

  • 设备厂商：资源的设备厂商。当资源类型为GPU时，才会显示此选项。

  • 主机：资源所在的主机。

  • 虚拟机：正在使用资源的虚拟机，如果状态为“空闲”，则此项为空。

  • 开始时间：虚拟机使用此资源的开始时间。

  • 结束时间：虚拟机使用此资源的结束时间。


容灾管理

ARM架构主机暂不支持磁盘备份容灾功能。

容灾管理对容灾系统中的业务提供了异地恢复的功能。将一个CVM站点配置为保护站点，并为其配置一个恢复站点，若保护站点因意外(如火灾、洪水、地震、人为蓄意破坏等)停止工作时，可以由恢复站点接替业务并继续运行，保证业务不中断。

用户将生产端和容灾端添加到一个保护组中，再通过设置灾难恢复计划，当生产端不能正常工作时，执行恢复计划，在灾备端根据保护组设置的策略，自动创建容灾机，来接替生产端业务。根据不同的业务场景及数据保护方式，提供两种容灾类型：

  • 存储复制容灾

将一个CVM站点配置为保护站点，并为其配置一个恢复站点。通过两站点存储阵列的复制技术，在存储层完成容灾数据的复制，实现异地备份及恢复的功能。

存储复制容灾依赖于存储阵列的复制功能。当保护站点和恢复站点的存储阵列都支持SRA（Storage Replication Adapter，存储复制适配器）时，可以实现自动化的故障恢复。若存储阵列不支持SRA，需要手工将存储环境准备就绪后再进行容灾业务的切换。搭建容灾环境时，推荐使用支持SRA的存储阵列。

  • 磁盘备份容灾

将安装了容灾客户端软件的虚拟机或生产机（物理机）作为保护对象，将本地CVM站点作为恢复站点，基于容灾客户端软件的磁盘实时复制功能，实现对源端的虚拟机/生产机数据应急保护。基于多级快照链机制和实时同步机制实现数据备份，支持秒级数据同步，满足高性能RPO数据恢复需求。

注意事项

容灾管理功能不支持IP类型为IPv6地址的主机和虚拟机交换机。

主要功能

  • 站点管理

  • 保护组管理

  • 恢复计划管理


站点管理

异地容灾方式中，可以将数据中心称为站点。站点又分为本地站点和远端站点。通常情况下，本地站点是需要被保护的站点，管理生产资源的业务；远端站点是用来恢复业务的目标站点，管理灾备资源。如果发生灾难，本地的业务会恢复到远端站点的资源上。

在配置容灾系统时，需要增加本地站点和远端站点的信息。当本地站点和远端站点的存储阵列都支持SRA时，需要为站点增加对应的存储阵列管理器。当站点和存储阵列管理器增加完成后，需要同步存储设备的复制关系。容灾系统的配置可以在一个站点的管理台统一完成，两端的配置数据是同步的。

站点管理包括增加站点、修改站点、删除站点、增加存储阵列管理器、修改存储阵列管理器、删除存储阵列管理器、同步存储设备复制关系和查看存储设备复制关系等功能。

注意事项

  • 磁盘备份容灾无需配置存储阵列管理器。

  • 非系统管理员分组的用户不可以执行站点添加和配置站点等操作。

  • 若一个CVM已经配置了站点数据，则该CVM不能再被其它CVM添加为远端站点。

  • 若站点被保护组绑定，则不允许删除。

  • 当站点对应的存储阵列不支持SRA时，站点不需要添加存储阵列管理器。

  • 若CVM站点中的CVK主机不能访问被添加的存储阵列管理器，则连通测试失败。

  • 若存储阵列管理器下存在设备配置了映射关系，则该存储阵列管理器不允许被修改或删除。

增加站点

  1. 单击导航树[云业务/容灾管理/站点管理]菜单项，进入站点管理界面。

  2. 单击<增加站点>按钮，弹出增加站点对话框。

  3. 设置相关参数，关于参数的详细介绍，请参见 参数说明 。

  4. 单击<完成>按钮完成操作。

修改站点

  1. 单击导航树[云业务/容灾管理/站点管理]菜单项，进入站点管理界面。

  2. 选择待修改的站点，单击对应操作列的 [image] 图标，弹出修改站点对话框。

  3. 修改相关参数，关于参数的详细介绍，请参见 参数说明 。

  4. 单击<确定>按钮完成操作。

删除站点

  1. 单击导航树[云业务/容灾管理/站点管理]菜单项，进入站点管理界面。

  2. 选择待删除的站点，单击对应操作列的 [image] 图标，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

增加存储阵列管理器

  1. 单击导航树[云业务/容灾管理/站点管理]菜单项，进入站点管理界面。

  2. 选择待增加存储阵列管理器的站点，单击<增加存储阵列管理器>按钮，弹出增加存储阵列管理器对话框。

  3. 设置相关参数，关于参数的详细介绍，请参见 参数说明 。

  4. 单击<连通测试>按钮，测试存储阵列配置是否正确。

  5. 单击<确定>按钮完成操作。

修改存储阵列管理器

  1. 单击导航树[云业务/容灾管理/站点管理]菜单项，进入站点管理界面。

  2. 选择待修改的站点，选择其下待修改的存储阵列管理器，单击对应操作列的 [image] 图标，弹出修改存储阵列管理器对话框。

  3. 修改相关参数，关于参数的详细介绍，请参见 参数说明 。

  4. 单击<连通测试>按钮，测试存储阵列配置是否正确。

  5. 单击<确定>按钮完成操作。

删除存储阵列管理器

  1. 单击导航树[云业务/容灾管理/站点管理]菜单项，进入站点管理界面。

  2. 选择待修改的站点，选择其下待删除的存储阵列管理器，单击对应操作列的 [image] 图标，弹出确认框。

  3. 单击<确定>按钮完成操作。

同步存储设备复制关系

  1. 单击导航树[云业务/容灾管理/站点管理]菜单项，进入站点管理界面。

  2. 单击<同步设备复制关系>按钮，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

查看存储设备复制关系

  1. 单击导航树[云业务/容灾管理/站点管理]菜单项，进入站点管理界面。

  2. 选择一个站点，选择其下的一个存储阵列管理器，单击对应操作列的 [image] 图标，弹出查看设备复制关系对话框。

参数说明

站点信息：

  • 站点名称：容灾站点的名称。

  • 站点类型：包括本地和远端。本地指当前CVM；远端指其它CVM。第一个增加的站点类型缺省为本地站点，后续增加的站点类型都缺省为远端站点。

  • IP地址：站点的IP地址。

  • 用户名：连接站点所使用的web登录用户名。

  • 密码：连接站点所使用的web登录用户名对应的密码。增加本地类型的站点时不需要输入用户名和密码，默认使用登录用户的用户名和密码。

  • 厂商类型：站点所使用的存储阵列的生产厂商。

存储阵列信息：

  • 存储阵列名称：存储阵列管理器的名称。

  • 源端IP地址：站点所使用的存储阵列的IP地址。

  • 源端用户名：站点所连接的存储阵列管理器所使用的用户名。

  • 源端密码：站点所连接的存储阵列管理器所使用的用户名对应的密码。

  • 对端IP地址：与站点所使用的存储阵列有存储复制关系的存储阵列的IP地址。

  • 对端用户名：与站点所使用的存储阵列有存储复制关系的存储阵列管理器所使用的用户名。

  • 对端密码：与站点所使用的存储阵列有存储复制关系的存储阵列管理器所使用的用户名对应的密码。

查看存储设备复制关系：

  • 源端存储LUN名称：源端LUN设备的名称。

  • 复制方向：存储阵列管理器中LUN设备复制关系的方向。

  • 对端存储LUN名称：对端LUN设备的名称。

  • 对端存储名称：对端LUN设备所在存储阵列管理器的名称。


保护组管理

保护组是一组需要受保护的虚拟机或物理机的集合。根据容灾类型，可创建两种类型的保护组。

  • 存储复制类型保护组

将属于同一个存储池（对应存储阵列中的一个LUN）的虚拟机划分到一个保护组中，统一制定保护策略对虚拟机进行保护。通过存储阵列的复制功能，将本地存储阵列中LUN的数据复制到远端的LUN中，从而保护在该LUN中放置的虚拟机数据。

创建存储复制容灾类型的保护组时，需要指定保护站点和恢复站点、保护站点的主机池和恢复站点的主机池以及站点之间的资源映射关系。资源映射关系是用于将保护站点受保护的虚拟机使用的资源和恢复站点的资源建立对应关系，虚拟机在恢复站点恢复时，自动进行资源替换。可以建立的资源映射关系包括虚拟交换机映射、网络策略模板映射和存储（两个存储池所使用的存储LUN具有复制关系）映射。

  • 磁盘备份类型保护组

将安装了容灾客户端的虚拟机或生产机加入到一个保护组，通过制定合适的容灾策略，对虚拟机/生产机的数据自动进行持续同步，达到对虚拟机/生产机的保护目的。根据所保护的虚拟机/生产机的业务运行方式，分为普通业务、双机业务和集群业务。普通业务里的虚拟机/生产机单独运行，互不制约；双机和集群业务里的虚拟机/生产机需要有共享存储存放需要共同访问的数据。磁盘备份保护组支持同构及异构平台的容灾任务。

  • 同构场景：指保护站点与恢复站点是相同版本的CVM管理平台，要保护的生产机为系统上的虚拟机。同构场景下，创建保护组时，需指定保护站点与恢复站点，以保护站点内安装了容灾客户端的虚拟机作为备选的保护对象，选择合适的容灾策略后，配置站点间网络资源映射关系。

  • 异构场景：指保护对象为CVM管理平台低版本的平台的虚拟机，或其他其他平台的虚拟机或物理机，恢复站点为高版本的CVM管理平台。异构场景下，创建保护组时 ，不配置保护站点，以安装了容灾客户端的虚拟机或生产机作为备选的保护对象，以本地站点为恢复站点，选择合适的容灾策略后，再配置恢复站点的生产机网络资源。

配置前提

磁盘备份类型的保护组添加虚拟机/生产机时需要保证这些虚拟机/生产机已经安装了容灾客户端。

注意事项

  • 被添加到存储复制保护组的虚拟机，不再支持“更改数据存储”及“更改主机和数据存储”类型的迁移。

  • 虚拟机安装了容灾客户端后，如果要克隆虚拟机，或通过模板批量部署虚拟机，在克隆或转为为模板前，需要先从客户端安装路径下删除配置文件AentSystenmInfo.ini。

主要功能

  • 增加保护组

  • 修改保护组

  • 删除保护组

  • 修改资源映射关系

  • 增加虚拟机/生产机

  • 修改虚拟机/生产机的优先级

  • 删除虚拟机/生产机

  • 同步保护组

  • 同步保护组内虚拟机

  • 下发备份配置

  • 启动备份任务

  • 设置容灾机磁盘总线类型


增加保护组

用于新增一个存储复制类型或磁盘备份类型的保护组。

注意事项

  • 挂载了光驱或软驱的虚拟机，在保护组中会被过滤掉，如果想要保护这些虚拟机，请先卸载光驱或软驱。

  • 如需对已经加入保护组的生产机进行磁盘扩容或增加磁盘，需要先将生产机从保护组中删除，磁盘扩容或增加磁盘后再重新加入保护组，才能对新增的磁盘进行容灾备份。

  • 修改保护组中虚拟机的优先级时，只能在站点状态正常、虚拟机数量大于1时进行。若在修改过程中删除虚拟机，则会刷新虚拟机列表，重新加载虚拟机数据。

  • 存储复制类型的保护组中，存储、虚拟交换机、网络策略模板类型的资源映射关系每种至少需要配置一个。

  • 磁盘备份类型的保护组不关心保护端的存储情况，只需要配置恢复端的目的存储（仅适用于磁盘备份容灾）。

  • 磁盘备份类型的保护组，在未指定保护站点时（异构场景），只需要配置恢复站点虚拟机的虚拟交换机和网络策略模板；指定了保护站点时（同构场景），需要建立保护站点与恢复站点的虚拟机的网络映射关系（仅适用于磁盘备份容灾）。

  • 为磁盘备份类型的保护组添加虚拟机时，带有USB、PCI、SR_IOV、GPU、VGPU、TPM等设备的虚拟机及绑定了物理CPU的虚拟机会被过滤掉，如果需要保护带有这些设备的虚拟机，请先将设备删除或解绑定物理CPU再添加到保护组（仅适用于磁盘备份容灾）。

  • Windows系统的虚拟机/生产机，如果磁盘数量多于一个，需要先在操作系统内部对磁盘进行格式化挂载后，才能对磁盘进行磁盘备份容灾（仅适用于磁盘备份容灾）。

  • 容灾策略一旦被保护组使用，就不允许再修改，如果想要改变保护组的容灾策略，需要重新创建一个新的容灾策略给保护组使用（仅适用于磁盘备份容灾）。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 单击<增加保护组>按钮，弹出增加保护组对话框。

  3. 设置保护组基本信息相关参数，关于保护组基本信息相关参数的详细介绍，请参见 参数说明 。单击<下一步>按钮，为保护组配置资源映射关系。

  4. 增加存储映射关系：

  • 用鼠标拖动 [image] 至下方保护组显示框，弹出增加存储映射关系对话框。

  • 选择存储池类型、存储类型，单击<下一步>按钮。

  • 选择保护站点资源所在的存储卷，选择恢复站点资源所在的存储卷，单击<确定>按钮。

  5. 增加虚拟交换机映射关系：

  • 用鼠标拖动 [image] 至下方保护组显示框，弹出增加虚拟交换机映射关系对话框。

  • 选择保护站点虚拟交换机，选择恢复站点虚拟交换机，单击<确定>按钮。

  6. 增加网络策略模板映射关系：

  • 用鼠标拖动 [image] 至下方保护组显示框，弹出增加网络策略模板映射关系对话框。

  • 选择保护站点的网络策略模板，选择恢复站点的网络策略模板，单击<确定>按钮。

  7. 单击<确定>按钮完成操作。

参数说明

1. 存储复制容灾保护组

基本信息：

  • 容灾类型：保护组的容灾类型，选择“存储复制容灾”。

  • 名称：保护组的名称。该名称在系统中必须唯一。

  • 保护站点：设置保护组关联的保护站点。

  • 恢复站点：设置保护组关联的恢复站点。

  • 源主机池：设置保护站点的主机池，即受保护虚拟机所在的主机池。

  • 目的主机池：设置恢复站点的主机池，受保护虚拟机在该主机池中恢复。

  • 业务类型：选择保护组所保护的虚拟机的业务类型。

  • 虚拟化层容灾：仅对在CAS中管理的虚拟机进行容灾。

  • 云上容灾：与CloudOS配合，对CloudOS上纳管的虚拟机进行容灾。

  • 自动保护虚拟机：在存储复制容灾类型的保护组中，如开启此项设置，则符合下列条件的虚拟机（不包括由DRX快速部署、DRX快速克隆、浮动桌面池部署的虚拟机和固定桌面池保护模式的虚拟机）将自动加入到保护组：

  • 虚拟机使用的存储池、虚拟交换机、网络策略模板都为资源映射关系中配置的资源。

  • 虚拟机名称与恢复站点中的虚拟机名称不重复。

  • 虚拟机未使用主机的USB设备、PCI设备、直通网卡、TPM设备、光驱、软驱，未绑定主机物理CPU。

映射关系：

  • 存储资源映射：设置保护组存储资源映射关系。选择存储池的类型、存储类型及设备，建立保护站点和恢复站点的存储池映射关系。对于不支持SRA的存储阵列，只支持配置“共享文件系统”类型的存储池的映射。

  • 存储池类型：选择存储池类型。

  • 存储类型：选择存储类型。

  • 保护站点资源：选择保护站点的存储资源。

  • 恢复站点资源：选择恢复站点的存储资源。

  • 虚拟机交换机映射：设置保护组虚拟交换机资源映射关系。

  • 保护站点资源：选择保护站点的虚拟机交换机。

  • 恢复站点资源：选择恢复站点的虚拟交换机。

  • 网络策略模板映射：设置保护组网络策略模板映射关系。

  • 保护站点资源：选择保护站点的网络策略模板。

  • 恢复站点资源：选择恢复站点的网络策略模板。

2. 磁盘备份容灾保护组

基本信息：

  • 容灾类型：保护组的容灾类型，选择“磁盘备份容灾”。

  • 名称：保护组的名称。该名称在系统中必须唯一。

  • 保护站点：设置保护组关联的保护站点。

  • 恢复站点：设置保护组关联的恢复站点。

  • 源主机池：设置保护站点的主机池，即受保护虚拟机所在的主机池。

  • 目的主机池：设置恢复站点的主机池，受保护虚拟机在该主机池中恢复。

  • 业务类型：选择磁盘备份容灾类型保护组所保护的虚拟机/生产机的业务类型（仅适用于磁盘备份容灾保护组）。

  • 普通业务：表示保护组内虚拟机/生产机独立运行，互不制约。

  • 双机业务：表示保护组内虚拟机/生产机以双机方式运行。此业务类型要求一次加入两台虚拟机/生产机到保护组中。

  • 集群业务：表示保护组内虚拟机/生产机以集群方式运行。此业务类型要求一次加入至少三台虚拟机/生产机到保护组中。

  • 容灾策略：基于备份容灾的保护组持续备份虚拟机/生产机的策略。

容灾策略：

  • 同步间隔时间：设置两次数据同步之间的时间间隔。可以为不同的硬盘设置不同的同步时间间隔。

  • 同步时间段：设置只在某段时间内进行数据同步。如所备份的服务器在夜间不会产生数据变化，则可以设置只在白天进行数据同步。

  • 备份速度限制：设置备份速度的上限。在有多个客户端在进行备份操作时，用户可以为每一个客户端设置备份速度，来控制其备份进度从而减小对网络资源的使用但会延长备份过程所需时间。

  • 快照时间间隔：设置快照频率，默认为1小时。若所备份的客户端数据变化非常频繁则需要设置较短的间隔时间。

  • 快照时间段：设置只在某个时间段进行数据快照。如所备份的客户端在夜间不会产生数据变化，则可以设置只在白天进行快照，从而节省带宽和存储节点空间。

  • 快照保存：选择快照保存方式（包括：按快照数、按保留时限，默认为按快照数）。

  • 单数据集最大快照数：当快照数据达到单数据集最大快照数后，容灾应急系统会对选择的硬盘分区、卷进行重新完全镜像，生成新的数据集，所有策略参数和原来设置的一样。当选择“按快照数”保存快照时需要设置此参数。

  • 快照保留时限：设置在备份过程中保留最近几天内的所有快照。时限之前的快照将被合并为一个快照。如果每天有多个快照，这些快照会自动合并成一个快照，但最近24小时内的快照不进行合并操作，便于原机故障时可以在最近的时间内找到尽量多的快照点。使用了该设置后，设备可以一直快照下去。当选择“保留时限”保存快照时需要设置此参数。

  • 完整数据集：设置在容灾存储介质上保留的完整数据（一次完全镜像和其附带的快照称为一份完整备份）的个数。当完整数据集个数已经超过设定的值时，会删除最老的完整数据。注意：如果一个数据集里的某个快照已经被恢复计划使用，则该数据集不会被删除。

  • 备份模式：选择备份模式。

  • 精简备份：只备磁盘的有效数据。

  • 完全备份：备份整个磁盘，不论是否有数据。比较耗时耗存储空间，使用该功能时请确认。

  • 数据校验模式：选择数据校验模式。

  • 精简校验：只校验磁盘的有效数据。

  • 完全校验：校验整个磁盘，不论是否有数据。比较耗时耗带宽，使用该功能时请确认。

映射关系：

  • 目的集群：磁盘备份容灾类型的保护组在恢复站点所使用的集群。

  • 目的主机：磁盘备份容灾类型的保护组在恢复站点所使用的主机。只有设置为容灾存储节点的主机才能作为容灾目的主机，即要求主机必须已经下发过备份类型虚拟交换机配置。

  • 目的存储池：磁盘备份容灾类型的保护组在恢复站点所使用的存储池。所备份的信息都将放置于该存储池。只有设置为容灾存储介质的存储池才能作为容灾目的存储池，即要求存储池所在主机是一个存储节点，且该存储池已经下发过容灾存储介质配置。

  • 网络：磁盘备份容灾类型的保护组在恢复站点所用的虚拟机网络。包括虚拟交换机和网络策略模板。

  • 虚拟机交换机映射：设置保护组虚拟交换机资源映射关系。

  • 保护站点资源：选择保护站点的虚拟机交换机。

  • 恢复站点资源：选择恢复站点的虚拟交换机。

  • 网络策略模板映射：设置保护组网络策略模板映射关系。

  • 保护站点资源：选择保护站点的网络策略模板。

  • 恢复站点资源：选择恢复站点的网络策略模板。


修改保护组

用于修改容灾保护组。

注意事项

  • 存储复制类型的保护组，可修改保护组描述、容灾策略及资源映射关系。

  • 磁盘复制类型的保护组，可修改保护组描述、容灾策略及网络。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择待修改的保护组，单击对应操作列的 [image] 图标，弹出修改保护组对话框。

  3. 根据实际情况修改相关参数和资源映射关系。

  4. 单击<确定>按钮完成操作。


删除保护组

用于删除容灾保护组。

注意事项

只有当关联的恢复计划处于非运行状态的保护组才允许删除。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择待删除的保护组，单击对应操作列的 [image] 图标，弹出确认对话框。

  3. 单击<确定>按钮完成操作。


修改资源映射关系

修改保护组的资源映射关系。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择待修改的保护组，单击对应操作列的 [image] 图标，弹出资源映射管理对话框。

  3. 拖动 [image] 、 [image] 或 [image] 图标，增加对应资源映射关系。

  4. 选择待删除的资源映射关系，单击鼠标右键，选择[删除]菜单项，删除对应的资源映射关系。


增加虚拟机/生产机

用于为保护组增加受保护的虚拟机/生产机。

注意事项

对于磁盘备份容灾类型保护组：

  • 为双机业务类型保护组添加虚拟机/生产机时，必须添加两台，且将其中一台设置为Master。

  • 为或集群业务类型的保护组添加虚拟机/生产机时，必须至少添加三台，且将其中一台设置为Master。

  • 集群或双机业务的保护可以创建多个共享磁盘。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择待增加虚拟机/生产机的保护组，在受保护的虚拟机/生产机列表将显示该保护组中已经存在的虚拟机/生产机。

  3. 单击<添加虚拟机>/<添加生产机>按钮，弹出选择虚拟机/生产机对话框。

  4. 选择需要增加到保护组的虚拟机/生产机。

  5. 点击<设置Master>为双机/集群业务的虚拟机/生产机设置Master（仅适用于磁盘备份容灾，双机/集群业务保护组）。

  6. 点击<下一步>为双机/集群业务的虚拟机/生产机设置共享磁盘（仅适用于磁盘备份容灾，双机/集群业务保护组）。

  7. 单击<确定>按钮完成操作。

参数说明

选择虚拟机/生产机：

  • IP地址：虚拟机或生产机的IP地址。

  • 操作：设置Master或取消Master。为双机或集群业务保护组增加虚拟机/生产机时，将其中一台设置Master（仅适用于磁盘备份容灾保护组）。

设置共享磁盘（仅适用于磁盘备份容灾保护组）：

  • 磁盘信息：虚拟机/生产机的磁盘信息。双机或集群业务的虚拟机或生产机必须选择同类型的磁盘。

  • 分区大小：磁盘分区的大小。


修改虚拟机/生产机的优先级

用于修改保护组中受保护的虚拟机/生产机的优先级。优先级高的虚拟机/生产机，会先在恢复站点中恢复。

注意事项

  • 在站点状态正常、虚拟机数量大于1时才可以修改保护组中虚拟机的优先级。

  • 若在修改过程中删除虚拟机，则会刷新虚拟机列表，重新加载虚拟机数据。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择待修改的保护组，在受保护的虚拟机/生产机列表将显示该保护组中已经存在的虚拟机/生产机。

  3. 单击<修改优先级>按钮，通过拖拽修改虚拟机/生产机优先级。

  4. 单击<确定>按钮完成操作。


删除虚拟机/生产机

用于为保护组删除受保护的虚拟机/生产机。

注意事项

双机或者集群业务类型保护组不允许删除生产机。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择待修改的保护组，在受保护的虚拟机列表将显示该保护组中已经存在的虚拟机。

  3. 选择待删除的虚拟机，单击对应操作列的 [image] 图标，或者单击<删除组内虚拟机>按钮，弹出确认对话框。

  4. 单击<确定>按钮完成操作。


同步保护组

用于将保护组变化的信息同步到恢复站点。当保护组发生变化时，如增加或删除被保护的虚拟机、修改保护组描述后，将变化同步到恢复站点。

注意事项

  • 保护组信息变化时，系统会自动同步，只有当因为网络或其他问题导致自动同步不成功时，才需要手动同步保护组。

  • 当站点状态正常，且保护组的恢复计划处于就绪或初始化状态时，才允许同步保护组。

  • 同步保护组时，会将保护组内虚拟机也同步。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择目标保护组，单击对应操作列的 [image] 图标，弹出确认操作对话框。

  3. 单击<确定>按钮完成操作。


同步保护组内虚拟机

用于将保护组中生产端的虚拟机资源同步到恢复站点。当生产端虚拟机规格发生变化时，如增加或修改虚拟机的网卡后，需要同步虚拟机，将更新的资源同步到恢复站点。

注意事项

  • 当生产端虚拟机规格变化后，系统会自动进行同步组内虚拟机操作。只有当因网络或其他问题导致没有自动同步时，才需要手动执行同步保护组内虚拟机。

  • 当站点状态正常，且保护组的恢复计划处于就绪或初始化状态时，才允许同步虚拟机。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择目标保护组，在受保护的虚拟机列表将显示该保护组中已经存在的虚拟机。

  3. 选择待同步的虚拟机，单击对应操作列的 [image] 图标，或者单击<同步组内虚拟机>按钮，弹出同步虚拟机对话框。

  4. 单击<确定>按钮完成操作。


下发备份配置

该功能仅适用于磁盘备份容灾保护组。

当磁盘备份任务处于“未配置”状态时，通过下发备份配置功能，将生产机的备份配置（生产机所属保护组所配置的容灾策略、目的存储池等信息）重新下发，以便生产机能继续执行备份任务。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择目标保护组，在受保护的虚拟机列表将显示该保护组中已经存在的虚拟机。

  3. 选择受保护的虚拟机/生产机，单击对应操作列的 [image] 图标，弹出确认对话框。

  4. 点击<确认>按钮，开始下发配置。


启动备份任务

该功能仅适用于磁盘备份容灾保护组。

当磁盘备份任务处于“暂停”状态时，通过该功能启动备份任务。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择目标保护组，在受保护的虚拟机列表将显示该保护组中已经存在的虚拟机。

  3. 选择受保护的虚拟机/生产机，单击对应操作列的 [image] 图标，弹出启动确认对话框。

  4. 点击<确认>按钮，开始启动备份任务。


设置容灾机磁盘总线类型

该功能仅适用于磁盘备份容灾保护组。

用于为新生成的容灾虚拟机的手动设置磁盘总线类型。

注意事项

设置容灾机磁盘总线类型后，在容灾机启动后才能生效。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择目标保护组，在受保护的虚拟机列表将显示该保护组中已经存在的虚拟机。

  3. 选择受保护的虚拟机/生产机，单击对应操作列的 [image] 图标，弹出设置容灾机磁盘总线类型对话框。

  4. 为磁盘设置总线类型。


查看生产机/虚拟机磁盘备份详情

该功能仅适用于磁盘备份容灾保护组。

用于查看磁盘备份保护组内受保护的生产机/虚拟机根据容灾策略的进行磁盘备份的任务详情。

操作步骤

  1. 单击导航树中[云业务/容灾管理/保护组管理]菜单项，进入保护组列表页面。

  2. 选择目标保护组，在受保护的虚拟机列表将显示该保护组中已经存在的虚拟机。

  3. 单击待查看备份详情的虚拟机，弹出虚拟机备份详情页面。

参数说明

备份任务概况

  • 备份状态：容灾策略中制定的磁盘备份任务执行状态。

  • 未配置：磁盘备份任务因频繁操作导致备份配置未成功下发。

  • 运行：正在进行磁盘备份。备份任务运行过程包含：初始化、全盘镜像、同步、快照、数据校验、空闲，只有在运行（空闲）状态时，恢复计划才能执行成功。

  • 暂停：磁盘备份任务暂停。如因频繁的操作导致的备份中断。

  • 异常：磁盘备份任务异常。如因网络长时间中断导致的备份任务不能继续进行。

  • 描述：当前虚拟机/生产机的描述信息。

  • 保护组：当前虚拟机/生产机所在的保护组。

  • 业务类型：当前虚拟机/生产机的业务类型。

快照

  • 数据集：当前磁盘备份任务产生的完整数据集的个数。

  • 快照数：当前磁盘备份任务产生的快照个数。

  • 快照时间周期：当前虚拟机/生产机快照产生的时间周期。

磁盘

  • 磁盘信息：被保护的虚拟机/生产机的磁盘分区。

  • 分区大小：磁盘分区大小。

  • 运行状态：磁盘的备份状态。包括：空闲、镜像中、镜像完成、镜像错误、校验、校验错误、无状态。只有在“镜像完成”或暂无状态时，恢复计划才能成功执行。


恢复计划管理

恢复计划是针对不同保护组设定的不同故障恢复策略，使得保护组中虚拟机能按照指定的策略进行恢复。恢复计划执行后，在灾备端根据保护组设置的策略，会自动创建容灾机，接替生产端业务。

恢复计划管理包括增加、修改、删除恢复计划，修改恢复计划优先级，将容灾机切换为普通虚拟机（仅适用于磁盘备份容灾）、恢复计划实施，查看恢复计划概要信息和查看恢复任务详细信息等功能。

主要功能

  • 增加恢复计划

  • 修改恢复计划

  • 删除恢复计划

  • 修改恢复计划优先级

  • 将容灾机切换为普通虚拟机

  • 恢复计划实施

  • 查看恢复计划概要信息

  • 查看恢复任务详细信息

注意事项

  • 存储复制容灾恢复出的容灾机不支持：删除、迁移、迁移存储卷、转换为模板、增加/删除硬件设备。

  • 根据磁盘备份容灾恢复出来的容灾机的磁盘都是qcow2格式，且预分配方式、簇大小等和源机可能不一致。

  • 磁盘备份容灾恢复出的容灾机不支持：删除、迁移、迁移存储卷、制作模板（转换/导出/克隆模板）、快照、克隆、备份与还原、被集群HA管理、设置亲和性。

  • 恢复计划执行完一次后，如果想再次恢复生产机，需要先将容灾机切换为普通虚拟机；也可以在生产端使用PE反向恢复工具将容灾数据恢复到生产端，清理恢复端备份数据，然后继续使用原恢复计划。


增加恢复计划

该功能用于增加一个新的恢复计划。

注意事项

添加了虚拟机/生产机的保护组才可以加入恢复计划。

操作步骤

  1. 单击导航树中[云业务/容灾管理/恢复计划管理]菜单项，进入恢复计划管理页面。

  2. 单击<增加恢复计划>按钮，弹出增加恢复计划对话框。

  3. 输入名称、描述，选择保护组和恢复集群（存储复制保护组）或受保护的生产机（磁盘备份保护组）。

  4. 单击<确定>按钮完成操作。

参数说明

  • 保护组：恢复计划绑定的保护组。

  • 恢复集群：保护组虚拟机恢复到恢复站点的集群。

  • 共享存储信息：保护组主机池应用的共享文件系统，此处显示的是保护组存储资源映射关系中配置的本地站点的共享存储信息。

  • 受保护的生产机：磁盘备份容灾保护组中的生产机，此处可以选择需要恢复的生产机。


修改恢复计划

该功能用于修改指定恢复计划的信息。

注意事项

当恢复计划的状态为开始演练执行中、结束演练执行中、计划恢复执行中、故障恢复执行中或反向恢复执行中时，不允许修改该恢复计划。

操作步骤

  1. 单击导航树中[云业务/容灾管理/恢复计划管理]菜单项，进入恢复计划管理页面。

  2. 选择待修改的恢复计划，单击对应操作列的 [image] 图标，弹出修改恢复计划对话框。

  3. 修改描述，选择保护组、恢复集群、受保护的生产机。

  4. 单击<确定>按钮完成操作。

参数说明

  • 保护组：恢复计划绑定的保护组。

  • 恢复集群：保护组虚拟机恢复到恢复站点的集群。

  • 受保护的生产机：磁盘备份容灾保护组中的生产机，此处可以选择需要恢复的生产机。


删除恢复计划

该功能用于删除指定的恢复计划。

注意事项

当恢复计划的状态为开始演练执行中、结束演练执行中、计划恢复执行中、故障恢复执行中或反向恢复执行中时，不允许删除该恢复计划。

操作步骤

  1. 单击导航树中[云业务/容灾管理/恢复计划管理]菜单项，进入恢复计划管理页面。

  2. 选择待删除的恢复计划，单击对应操作列的 [image] 图标，弹出确认对话框。

  3. 单击<确定>按钮完成操作。


修改恢复计划优先级

该功能用于修改恢复计划的优先级。

注意事项

只有当恢复计划数量大于1时，才能修改优先级。

操作步骤

  1. 单击导航树中[云业务/容灾管理/恢复计划管理]菜单项，进入恢复计划管理页面。

  2. 单击<修改优先级>按钮，在弹出的对话框中，上下拖拽恢复计划的名称调整优先级。

  3. 单击<确定>按钮完成操作。


将容灾机切换为普通虚拟机

该功能仅适用于磁盘备份容灾保护组。

将根据恢复计划恢复出来的容灾机切换为普通虚拟机，切换完成后，虚拟机会使用独立的存储文件，并且反向恢复时也不会清理该虚拟机。

注意事项

  • 计划恢复和故障恢复出来的虚拟机可以切换为普通机，演练生成的虚拟机不支持切换为普通机。

  • 将容灾机切换为普通机会导致虚拟机MAC发生变化，切换后请重新配置该虚拟机的网络。

操作步骤

  1. 单击导航树中[云业务/容灾管理/恢复计划管理/恢复虚拟机列表]菜单项，进入恢复虚拟机列表页面。

  2. 选择虚拟机转化的容灾虚拟机，单击对应操作列的 [image] 图标，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

参数说明

  • 显示名称：虚拟机的显示名称。

  • 状态：虚拟机的状态，包括运行、暂停、关闭、未知、HA异常。

  • 主机：虚拟机所属主机的名称。

  • 恢复计划 ：恢复该虚拟机所使用的恢复计划名称。


恢复计划实施

系统支持四种恢复计划的执行方式，包括故障演练、计划恢复、故障恢复、反向恢复和清理备份数据，分别对应不同的使用场景。

  • 故障演练：是提高灾难恢复能力进行的预演，可以检验恢复计划的正确性。故障演练需要模拟保护站点发生故障，在恢复站点恢复业务的全流程。演练的过程不影响正常的生产业务。故障演练分为开始演练和结束演练两步。开始演练后，虚拟机会在恢复站点中进行恢复。确认配置没有问题后，需要及时结束演练，恢复计划将变为就绪状态，可以进行计划恢复和故障恢复操作。

  • 计划恢复：适用于站点都完好的情况，如站点维护。启动计划恢复后，保护站点中受保护的虚拟机将被关闭，存储会触发一次数据复制操作，当受保护的数据完全复制到恢复站点的存储后，再依次恢复虚拟机的业务，保证数据不丢失和业务系统的继续运行。

  • 故障恢复：适用于恢复因自然灾害，如地震、火灾而损坏的站点。启动灾难恢复，保护站点中受保护的虚拟机会根据恢复计划在恢复站点依次进行业务恢复，从而保证业务系统快速恢复。这种情况下，受保护的虚拟机是由于故障而异常中断，恢复站点中存储的数据是前一个复制周期完成后的数据信息，因此恢复的数据与灾难发生时的数据不完全相同。

  • 反向恢复：针对存储复制保护组，当执行过计划恢复或者故障恢复后，如果保护站点能够恢复且数据没有丢失，则可以进行反向恢复，将虚拟机重新切换回已恢复正常的保护站点中运行。此时恢复站点中恢复的虚拟机将会被删除，存储将会被解挂载。

  • 清理备份数据：针对磁盘备份保护组，当执行过计划恢复或故障恢复后，可通过在生产环境运行PE反向恢复工具将容灾数据恢复到生产环境，恢复后执行清理备份数据，在恢复站点删除容灾机及临时数据（该功能仅适用于磁盘备份容灾）。

注意事项

  • 恢复计划状态为就绪或者初始化时，才能执行故障演练、计划恢复、故障恢复和反向恢复等操作。

  • 如果非保护组存储下有活动的虚拟机引用了保护组存储中的光驱文件，执行计划恢复、反向恢复时，将导致该存储无法关闭，恢复失败。

  • 容灾演练和恢复需在数据备份相对稳定的时刻进行，因此只有在受保护的虚拟机/生产机的备份状态为“运行（空闲）”，且磁盘的运行状态为“镜像完成”或暂无状态（无数据）时演练和恢复才能成功。

故障演练

  1. 单击导航树中[云业务/站点容灾/恢复计划管理/<恢复计划名称>]菜单项，进入恢复计划概要页面。

  2. 单击<开始演练>按钮，弹出开始演练对话框。

  3. 选择执行方式。如果存储已经同步，可以选择跳过存储同步，直接执行计划演练。单击<确定>按钮完成操作。

  4. 查看演练的详细执行过程：选择“恢复任务”页签，在恢复任务列表中单击执行日期对应的链接，查看演练的详细信息。

  5. 开始演练成功后，需要及时结束演练：在恢复计划概要页面中，单击<结束演练>按钮，使恢复计划处于就绪状态。

计划恢复

  1. 单击导航树中[云业务/容灾管理/恢复计划管理/<恢复计划名称>]菜单项，进入恢复计划概要页面。

  2. 单击<计划恢复>按钮，弹出计划恢复对话框。

  3. 选择执行方式，关于参数的详细介绍，请参见 参数说明 。

  4. 单击<确定>按钮完成操作。

批量计划恢复

  1. 单击导航树中[云业务/容灾管理/恢复计划管理]菜单项，进入恢复计划管理页面。

  2. 选择多个恢复计划，单击<批量操作>按钮，选择[计划恢复]菜单项，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

故障恢复

  1. 单击导航树中[云业务/容灾管理/恢复计划管理/<恢复计划名称>]菜单项，进入恢复计划概要页面。

  2. 单击<故障恢复>按钮，弹出故障恢复对话框。

  3. 选择执行方式，关于参数的详细介绍，请参见 参数说明 。

  4. 单击<确定>按钮完成操作。

批量故障恢复

  1. 单击导航树中[云业务/容灾管理/恢复计划管理]菜单项，进入恢复计划管理页面。

  2. 选择多个恢复计划，单击<更多操作>按钮，选择[故障恢复]菜单项，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

反向恢复

  1. 单击导航树中[云业务/容灾管理/恢复计划管理/<恢复计划名称>]菜单项，进入恢复计划概要页面。

  2. 单击<反向恢复>按钮，弹出执行计划恢复对话框。

  3. 选择执行方式，关于参数的详细介绍，请参见 参数说明 。

  4. 单击<确定>按钮完成操作。

清理备份数据

  1. 单击导航树中[云业务/容灾管理/恢复计划管理/<恢复计划名称>]菜单项，进入恢复计划概要页面。

  2. 单击<清理备份数据复>按钮，弹出确认对话框。

  3. 确定容灾机的临时数据已经通过PE反向恢复工具被恢复到生产环境后，单击<确定>按钮完成操作。

批量反向恢复

  1. 单击导航树中[云业务/容灾管理/恢复计划管理]菜单项，进入恢复计划管理页面。

  2. 选择多个恢复计划，单击<更多操作>按钮，选择[反向恢复]菜单项，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

参数说明

  • 执行方式：存储复制保护组的恢复计划执行方式，包括执行计划和直接恢复虚拟机。

  • 执行恢复计划：按照恢复步骤执行恢复计划。

  • 直接恢复虚拟机：直接进行恢复虚拟机操作，跳过前面操作步骤，可以节省恢复时间。适用于恢复计划中恢复虚拟机之前过程已准备就绪。


查看恢复计划概要信息

该功能用于查看恢复计划的概要信息。

操作步骤

  1. 单击导航树中[云业务/容灾管理/恢复计划管理/<恢复计划名称>]菜单项，进入恢复计划概要页面。

参数说明

基本属性：

  • 保护组：恢复计划绑定的保护组。

  • 保护站点：保护组配置的保护站点名称。

  • 恢复站点：保护组配置的恢复站点名称。

  • 恢复集群：保护组虚拟机恢复到恢复站点的集群。

  • 状态：恢复计划的当前状态（包括就绪、演练中、初始化、开始演练、结束演练、计划恢复、故障恢复和反向恢复），及演练或恢复结果（包括成功、失败、执行中、等待执行和部分成功）。

受保护的虚拟机/生产机：

  • 显示名称：受保护的虚拟机的名称。

  • 恢复状态：受保护的虚拟机的初始状态或执行恢复操作后的状态。

存储信息：

  • 共享存储信息：存储复制类型保护组的存储资源映射关系中配置的本地站点的共享存储信息。

  • 存储路径：磁盘备份容灾类型保护组中配置的恢复站点的存储信息。


查看恢复任务详细信息

该功能用于查看恢复计划的恢复任务信息。

注意事项

  • 在恢复计划概要页面中，单击恢复计划状态的超链接，查看的是最近恢复任务的详细信息。

  • 最近恢复状态为失败的计划恢复或者故障恢复，可以单击虚拟机名称旁边的<恢复虚拟机>按钮，直接恢复虚拟机。

操作步骤

  1. 单击导航树中[云业务/容灾管理/恢复计划管理/<恢复计划名称>]菜单项，进入恢复计划概要页面。

  2. 选择“恢复任务”页签，进入恢复任务页面。

  3. 单击执行日期的超链接，进入恢复任务详细页面。

参数说明

  • 恢复步骤：恢复步骤的具体说明。

  • 状态：恢复步骤的执行状态。

  • 失败原因：恢复步骤的失败原因。


下载客户端

该功能仅适用于磁盘备份容灾。

磁盘备份容灾类型中，受保护的生产机/虚拟机需要安装客户端才能进行备份。请根据生产机操作系统下载相应的客户端并安装。备份服务器IP 地址可以根据生产机的网络情况进行重新配置。

操作步骤

  1. 单击导航树中[云业务/站点容灾/下载客户端]菜单项，进入下载客户端页面。

  2. 选择需要下载客户端，直接点击下载或者复制客户端地址进行下载。

参数说明

  • 首选IP：用于备份服务器与恢复站点的CVM进行通信。

  • 备选IP：当首选IP出现异常，系统自动切换备选IP来与恢复站点的CVM进行通信。


云彩虹管理

云彩虹实现了当前数据中心的CVM与其他数据中心的CVM资源的共享，是构建云间资源共享的桥梁。提供了虚拟机在不同数据中心CVM之间在线迁移且业务不中断的功能。

云彩虹管理包括增加CVM云资源、修改CVM云资源、删除CVM云资源和在CVM间迁移虚拟机等功能。

  • 云彩虹迁移网络限速功能可以通过为虚拟交换机增加网络类型为“迁移网络”的子网，并设置带宽占比来实现，具体方法请参见 子网管理 。

配置前提

  • 待增加的远端数据中心CVM，其版本与本地CVM版本相同。

  • 待迁移虚拟机所在主机加入集群的IP地址类型必须和迁移目的主机加入集群的IP地址类型一致。

  • 若待迁移虚拟机的磁盘在NFS类型的存储池上，且磁盘缓存方式为一级虚拟缓存(None)或者直接读写(Directsync)，请先关闭虚拟机后再迁移，否则虚拟机将迁移失败。

注意事项

在CVM间迁移虚拟机时，不允许在两个CVM上对主机执行连接主机操作。

增加CVM资源

  1. 单击导航树中[云业务/云彩虹]菜单项，进入云彩虹CVM资源列表页面。

  2. 首次增加CVM资源时，需要先配置本地数据中心：单击界面右侧 [image] 图标，弹出配置本地数据中心确认对话框。单击<确定>按钮，弹出配置本地数据中心对话框。

  3. 输入本地数据中心名称、IP地址，选择登录方式（包括：HTTP、HTTPS），输入端口号，单击<确定>按钮。

  4. 增加远端数据中心的CVM：单击界面右侧 [image] 图标，弹出增加数据中心对话框。

  5. 输入数据中心名称、描述、IP地址，选择CVM登录方式（包括：HTTP、HTTPS），默认端口设置，输入登录CVM的用户名、密码。

  6. 单击<确定>按钮完成操作。

修改CVM资源

  1. 单击导航树中[云业务/云彩虹]菜单项，进入云彩虹CVM资源列表页面。

  2. 单击CVM资源对应的 [image] 图标，弹出数据中心CVM概要显示框。

  3. 单击<配置数据中心>按钮，在弹出对话框中，根据已添加CVM资源的变化情况，修改相关参数。

  4. 单击<确定>按钮完成操作。

删除CVM资源

  1. 单击导航树中[云业务/云彩虹]菜单项，进入云彩虹CVM资源列表页面。

  2. 单击界面右侧CVM资源对应的 [image] 图标，弹出删除CVM资源操作确认对话框。

  3. 单击<确定>按钮完成操作。

在CVM间迁移虚拟机

  1. 单击导航树中[云业务/云彩虹]菜单项，进入云彩虹CVM资源列表页面。

  2. 在搜索框中输入虚拟机名称后按回车键或双击主机图标，弹出虚拟机集合显示框，显示框以缩略图的形式显示了主机中所有虚拟机。

  3. 用鼠标拖动显示框中虚拟机到目的主机图标上松开鼠标左键，弹出迁移配置对话框。

  4. 设置相关参数，关于参数的详细介绍，请参见 参数说明 。

  5. 单击<完成>按钮完成操作。

参数说明

  • 数据中心节点：单击拓扑图中的 [image] 图标可显示数据中心CVM概要信息。

  • 集群节点：单击拓扑图中 [image] 图标，可显示集群概要信息。

  • 主机节点：单击拓扑图中 [image] 图标，可显示主机概要信息。

  • 迁移超时时长：迁移处于运行状态的虚拟机的超时时间。例如：当迁移超时时长设置为20分钟，若虚拟机在20分钟内未完成迁移，系统将暂停该虚拟机，以便其可以快速完成迁移，待迁移完成后，再将该虚拟机恢复为运行状态。默认值为20分钟。当该参数设置为0时，系统将不会暂停虚拟机，虚拟机在迁移过程中始终处于运行状态。

  • 压缩：将需要传输的数据进行压缩，减少数据传输的总量。


异构平台迁移

ARM架构的服务器暂不支持异构平台迁移功能。

异构平台迁移提供了将X86物理服务器，或虚拟机迁移到CAS虚拟机的功能。将安装了迁移客户端的物理服务器或虚拟机，作为待迁移的源设备，将CAS中运行并配置好目标客户端的虚拟机作为迁移的目标虚拟机，通过迁移源设备的磁盘数据，实现P2V及V2V迁移。

异构平台迁移提供了迁移任务创建、源设备客户端代理程序下载，以及源设备、目标虚拟机、迁移任务和平台关键信息统计与查询的功能。

注意事项

异构平台迁移功能不支持IPv6网络。

主要功能

  • 迁移任务管理

  • 驱动配置

  • 查看异构平台迁移概要信息

  • 查看源设备

  • 查看目标设备


迁移任务管理

迁移任务管理包含创建迁移任务，以及迁移任务相关操作。支持创建单个任务或批量创建多个任务。任务创建完成后可直接启动迁移，也可以先保存任务，待需要时再启动迁移。任务创建好后，可根据需要，启动、暂停、结束，删除任务。

注意事项

  • 源设备只有获取授权后，才能配置迁移任务。源设备被授权后，可以针对一个迁移任务多次执行迁移，也可以创建多个迁移任务。

  • 迁移授权在保存任务或立即启动迁移任务时，即下发给源设备，授权一旦下发，不能取消。即使迁移任务未成功创建，迁移授权也不释放，此时请排查原因，重新创建迁移任务。

  • 迁移任务默认以源设备名称命名。

  • 迁移任务完成后，需要手动执行结束，否则迁移任务会按照配置的自动增量迁移周期，自动周期性地进行迁移。

  • 迁移任务的进度，是通过定时采样计算的，当一个迁移任务中有较多磁盘时，有可能出现整体进度没有及时刷新的情况，此时请耐心等待进度刷新，并不影响迁移任务。也可以通过查看设备信息中具体每个磁盘的迁移状态，了解迁移进度。

创建迁移任务

  1. 单击导航树中[云业务/异构平台迁移]菜单项，进入异构平台迁移概要信息页面。

  2. 单击<创建迁移任务>按钮，弹出的创建迁移任务对话框。

  3. 选择迁移的源设备、目标设备及磁盘、选择迁移的磁盘并匹配目标磁盘后，直接单击<下一步>或单击<增加迁移任务>按钮，创建新的迁移任务，进行批量配置后，单击<下一步>。

  4. 配置迁移任务，关于参数的详细介绍，请参见参数说明。

  5. 单击<立即启动>，完成迁移任务的创建并立即启动迁移任务，或单击<保存任务>按钮，将任务保存到迁移任务列表，待需要的时候再启动。

启动迁移任务

  1. 单击导航树中[云业务/异构迁移平台/迁移任务页签]，进入迁移任务列表；或单击[云业务/异构迁移平台/<迁移任务>]直接进入迁移任务详情页面。

  2. 选择待启动的迁移任务，单击对应操作列的 [image] ，在弹出对话框中确认；或单击<启动>按钮，启动迁移任务。

暂停迁移任务

  1. 单击导航树中[云业务/异构迁移平台/迁移任务页签]，进入迁移任务列表；或单击[云业务/异构迁移平台/<迁移任务>]直接进入迁移任务详情页面。

  2. 选择待暂停的迁移任务，单击对应操作列的 [image] ；或单击<暂停>按钮，暂停迁移任务。

结束迁移任务

  1. 单击导航树中[云业务/异构迁移平台/迁移任务页签]，进入迁移任务列表；或单击[云业务/异构迁移平台/<迁移任务>]直接进入迁移任务详情页面。

  2. 选择待结束的迁移任务，单击对应操作列的 [image] ；或单击<结束>按钮，结束迁移任务。

删除迁移任务

  1. 单击导航树中[云业务/异构迁移平台/迁移任务页签]，进入迁移任务列表；或单击[云业务/异构迁移平台/<迁移任务>]直接进入迁移任务详情页面。

  2. 选择待删除的迁移任务，单击对应操作列的 [image] ，弹出确认对话框。

  3. 单击<确定>按钮完成操作。

查看迁移任务详情

  1. 单击导航树中[云业务/异构平台迁移/<迁移任务>]，进入异构平台迁移任详情页面；或单击导航树中[云业务/异构迁移平台/迁移任务页签]，进入迁移任务列表页面，单击源设备名称，进入对应的迁移任务详情页面。

查看迁移任务列表

该功能用于查看所有迁移任务的列表，并可以启动、完成或还原任务。

操作步骤

  1. 单击导航树中[云业务/异构迁移平台]菜单项，进入异构平台迁移页面。

  2. 选择“迁移任务”页签，进入迁移任务列表页面。迁移任务列表每隔30秒自动刷新。

参数说明

1. 创建迁移任务

目标匹配：

  • 源设备：指待迁移数据的虚拟机或者裸金属服务器。待迁移的虚拟机或裸设备需要安装与其操作系统相匹配的迁移客户端后，才能作为迁移的源设备。

  • 目标虚拟机：指数据迁移的目的端虚拟机。CAS中配置好目标客户端的虚拟机，才可以作为迁移的目的虚拟机。

  • 磁盘选择和匹配：选择源设备磁盘和目标虚拟机磁盘。目标虚拟机磁盘的容量和数量均不得低于源设备。仅系统盘和数据盘是可迁移状态。

任务配置：

  • 自动增量迁移周期：设置迁移成功完成后，对源设备中发生变化（增加/减少）的数据，进行再次迁移的时间间隔。自动增量迁移在用户手动结束迁移任务前会一直周期性进行。时间间隔单位可选“秒、分、时、天”四种，默认时间间隔为30分钟。

  • 迁移速度限制：对迁移中使用的带宽进行限制，以减迁移对业务的影响，默认为50MBps，0表示不限制。

  • 迁移方式：选择进行全盘迁移或者精简迁移。全盘迁移即进行全盘整体迁移；精简迁移仅对磁盘有效数据块复制。

  • 通道压缩：选择是否对源设备数据压缩后再传输。开启通道压缩可以减少迁移带宽需求，但会增加源设备资源消耗，可能会影响源设备运行。

  • 不开启：不压缩，直接传输磁盘数据，需要占用较多网络资源。

  • 压缩率优先：对数据压缩50%后迁移（压缩率较高），需要占用较多CPU资源。

  • 性能优先： 优先保证源设备性能，对数据压缩30%后迁移（压缩率较低），占用较少的CPU资源。

2. 查看迁移任务详情

  • 任务进度：当前迁移任务执行的进度。

  • 创建任务：迁移任务建立完成。

  • 待迁移：迁移任务已近配置完成，等待启动。

  • 迁移中：迁移任务执行中，正在进行数据迁移。

  • 暂停：迁移任务暂停。

  • 待结束：迁移完成后，等待手动结束任务。

  • 迁移完成：迁移完成后，已经执行手动结束任务。

  • 迁移失败：迁移任务未成功完成。

  • 策略信息：该迁移任务使用的迁移策略，即创建迁移任务时配置的策略。

  • 设备信息：迁移设备的磁盘信息。

  • 源设备：源设备的磁盘名称。

  • 挂载点：源主机磁盘挂载点。

  • 文件系统：源主机磁盘文件系统。

  • 容量：源设备或目标虚拟机的磁盘容量。

  • 目标虚拟机：目标虚拟机的磁盘名称。

  • 状态：磁盘迁移进度状态。

3. 查看迁移任务列表

  • 源设备名称：默认采用源设备名称标识对应的迁移任务。

  • 源设备IP：显示迁移源设备的IP地址。

  • 迁移状态：当前任务的迁移情况。

  • 迁移进度：当前任务的迁移进度。

  • 预计剩余时间：预计迁移到待结束所需要的时间。

  • 目标虚拟机名称：显示迁移任务目标虚拟机的名称。

  • 目标虚拟机IP：显示迁移任务目标虚拟机的IP地址。


驱动配置

当检测到源设备和目标虚拟机有硬盘驱动兼容风险时，将存在驱动兼容风险的硬件筛选出来，并可以导出硬件信息，根据导出的硬件信息准备驱动，导入到目标虚拟机中，解决硬盘兼容问题。

注意事项

  • 导出硬件信息时，如果没有自动弹出下载窗口，请至浏览器下载目录下找到目标虚拟机名对应的硬件信息文本文件。

  • 一次只能导入一个驱动及其依赖，需要导入注入多个驱动时重复导入操作。

导出硬件信息

  1. 单击[云业务/异构平台迁移/<迁移任务>]，进入迁移任务详情页面。

  2. 单击<驱动配置>按钮，弹出驱动配置对话框。

  3. 单击<导出硬件信息>按钮，目标设备的硬盘信息将会以.txt文件的形式被导出。（如果没有自动弹出下载，请至浏览器下载目录下找到此txt文件）。

导入驱动

  1. 根据“导出目标虚拟机硬件信息”导出的硬件信息找到对应的驱动程序。

  2. 单击[云业务/异构平台迁移/<迁移任务>]，进入迁移任务详情页面。

  3. 单击<驱动配置>按钮，弹出驱动配置对话框。

  4. 在“需要配置驱动的硬件”列表中，选择需要导入驱动的硬件，单击对应操作列的 [image] 图标，导入对应的驱动程序文件。


查看异构平台迁移概要信息

该功能通过图表查看异构平台迁移的概要信息。包括任务统计、目标虚拟机统计、授权统计与扩容、当前任务。

操作步骤

  1. 单击导航树中[云业务/异构迁移平台]菜单项，进入异构平台迁移概要页面。

参数说明

任务统计：

  • 待迁移：任务已经配置，可以启动迁移的任务。

  • 迁移中：包含迁移进行中和暂停的任务。

  • 待结束：迁移任务完成之后，等待手动结束的任务。

  • 迁移完成：迁移成功的任务。

  • 迁移失败：迁移不成功的任务。

目标虚拟机：

  • 已配置：已配置迁移任务的目标虚拟机。

  • 未配置：未配置迁移任务的目标虚拟机。

授权统计：

  • 已用：已经使用的授权点数总和。

  • 剩余：剩余可用的授权点数总和。

  • 扩容：导入License文件，增加授权点数。授权点数为可进行迁移的源设备总数，每台新加的源设备在初次配置迁移任务时都会消耗一个授权点数。

  • 当前任务：显示全部迁移任务及状态。包括待迁移、迁移中、暂停和待结束的任务。


查看源设备

源设备是指待迁移数据的虚拟机或者裸金属服务器。需要迁移的物理服务器或虚拟机，安装与其操作系统相匹配的客户端后，即可作为待配置的源设备出现在列表中。点击设备名称可以跳转到设备对应的迁移任务的详情中去。

操作步骤

  1. 单击导航树中[云业务/异构迁移平台]菜单项，进入异构迁移平台概要界面。

  2. 点击“源设备”页签，查看源设备列表。

参数说明

  • 设备状态：当前源设备处于在线还是离线状态。只有在线状态的设备，才能创建迁移任务。

  • 迁移状态：指源设备对应的迁移任务状态。

  • 未配置：源设备还未配置迁移任务。

  • 待迁移：源设备已经配置了迁移任务，等待启动迁移操作。

  • 迁移中：迁移任务执行中，正在进行数据迁移。

  • 暂停：迁移任务暂停。

  • 待结束：迁移已经完成，等待手动结束任务。

  • 迁移完成：迁移已经完成，并已经结束任务。

  • 迁移失败：迁移任务未成功完成。

  • 授权状态：显示源设备是否已获取异构平台迁移授权。获取授权的源设备将占用一个授权点数。

  • 已授权：源设备已获取异构平台迁移授权。

  • 未授权：源设备未获取异构平台迁移授权。


查看目标设备

目标虚拟机是指数据迁移数据的目的地。CAS中挂载PE镜像并配置好目标客户端的虚拟机，可以作为迁移的目标虚拟机。

操作步骤

  1. 单击导航树中[云业务/异构迁移平台]菜单项，进入异构迁移平台概要界面。

  2. 点击“目标虚拟机”页签，查看目标虚拟机列表。

参数说明

  • 设备状态：当前目标虚拟机是否在线。只有在线的虚拟机，才能作为迁移的目的虚拟机。

  • 迁移状态：目标虚拟机是否配置了迁移任务，以及对应的迁移任务状态。

  • 未配置：目标虚拟机还未配置迁移任务。

  • 待迁移：目标虚拟机已经配置了迁移任务，等待启动迁移操作。

  • 迁移中：迁移任务执行中，正在进行数据迁移。

  • 暂停：迁移任务暂停。

  • 待结束：迁移任务已完成，等待手动结束任务。

  • 迁移完成：迁移任务已完成，并已经结束任务。

  • 迁移失败：迁移任务未成功完成。


客户端下载

该功能用于下载迁移客户端代理程序并配置代理的服务器IP地址。待迁移的源设备，需要根据操作系统下载相应的客户端并安装后，才能进行迁移。每个客户端代理都有一个服务器IP地址，用于与服务端，即CVM进行通信。客户端代理的服务器IP地址默认为CVM管理网IP地址，当CVM管理网IP地址变化后，可以通过更新代理IP，将客户端代理的服务器IP地址更新为变化后的CVM管理网IP地址。

更新客户端代理IP地址

  1. 单击导航树中[云业务/异构迁移平台]菜单项，进入异构迁移平台概要界面。单击“客户端下载”页签。

  2. 点击<更新客户端代理IP>按钮，将客户端代理的服务器IP地址更新为CVM管理网IP地址。

下载客户端

  1. 单击导航树中[云业务/异构迁移平台]菜单项，进入异构迁移平台概要界面。单击“客户端下载”页签。

  2. 点击对应操作系统的下载链接进行下载。


云安全管理

ARM架构的主机暂不支持：安全区域、保密策略、双因子认证、防病毒配置、保密业务电子流。

云安全用于管理CVM安全相关的配置，其中包括密码策略、安全区域、保密策略、访问策略、双因子认证、ACL策略、虚拟防火墙、网络限速策略、CVM备份策略、防病毒配置、保密业务电子流。

主要功能

  • 密码策略

  • 安全区域

  • 保密策略

  • 访问策略管理

  • 双因子认证

  • ACL策略管理

  • 虚拟防火墙管理

  • 网络限速策略管理

  • 管理平台备份配置管理

  • 防病毒配置


密码策略

该功能用于控制操作员的密码复杂度及密码有效期，密码策略全局有效，即只要使用该策略，就对所有操作员都生效。密码策略主要包括密码最小长度、密码复杂度要求、密码有效期三种控制策略。

注意事项

修改密码策略后，该策略会立即生效。新注册的操作员必须遵守该策略；已经注册的操作员仅受密码有效期的影响，当密码过期后，修改密码时必须遵守该策略。

操作步骤

  1. 单击导航树中[云安全/密码策略]菜单项，进入密码策略页面。

  2. 输入密码最小长度并选择密码复杂性要求，输入密码有效期。

  3. 单击<保存>按钮完成操作。

参数说明

  • 密码最小长度：操作员密码的最小长度。非保密模式下，取值范围为1~14，默认为8；保密模式下，取值范围为8～14，默认为8。

  • 密码复杂性要求：操作员密码的复杂度要求，包括无限制、必须混合使用字母和数字、必须包含特殊字符、必须为字母数字特殊字符组合、必须为大写字母小写字母数字特殊字符组合，默认为必须为字母数字特殊字符组合。特殊字符请参见“特殊字符表”。

  • 密码有效期：操作员密码有效期。非保密模式下，默认为0，0代表无限制。保密模式下，默认值为1。

特殊字符表（以下字符均为半角字符）：

字符 | 名称 | 字符 | 名称
~ | 波浪符号 | ` | 撇号
! | 叹号 | @ | At符号
# | 井号 | $ | 美元符号
% | 百分号 | ^ | 脱字符号
& | 与符号 | * | 星号
() | 括号 | = | 等号
+ | 加号 | | | 竖线
- | 减号 | _ | 下划线
[] | 中括号 | {} | 大括号
: | 冒号 | ; | 分号
\ | 反斜杠 | “ | 双引号
, | 逗号 | / | 斜杠
. | 点符号 | <> | 角括号
? | 问号 |  | 空格


安全区域

ARM架构的主机暂不支持“安全区域”功能。

安全区域是由一个或多个集群组成的安全隔离区域。安全区域内的虚拟机的密级级别必须为非内部公开，且只能在虚拟机所在集群进行迁移或克隆，禁止克隆或转换为模板；非安全区域内的虚拟机的密级级别必须为内部公开，且只能在非安全区域内进行迁移或克隆。

配置前提

当开启保密模式时，系统才显示安全区域功能。关于开启保密模式的配置，请参见 系统参数设置 。

注意事项

配置安全区域时，不允许安全区域的主机或集群和非安全区域的主机或集群使用同一个共享存储。

操作步骤

  1. 单击导航树中[云安全/安全区域]菜单项，进入安全区域页面。

  2. 勾选云资源导航树中的集群节点。

  3. 单击<保存>按钮完成操作。

参数说明

安全区域：安全区域内的虚拟机的密级必须为秘密级（含秘密级）以上的级别，例如秘密、机密、绝密等，该区域内的虚拟机只能在本区域内进行迁移、克隆等操作。该区域内的虚拟机不允许克隆/转换为模板，也不允许导出为OVF模板。与安全区域相对的是非安全区域，非安全区域内的虚拟机的密级为内部公开，且非安全区域内的虚拟机不允许迁移和克隆到安全区域。


保密策略

ARM架构的主机暂不支持“保密策略”功能。

该功能用于控制指定密级级别的虚拟机允许迁移的主机范围及相关设置。

配置前提

当开启保密模式时，系统才显示保密策略功能。关于开启保密模式的配置，请参见 系统参数设置 。

操作步骤

  1. 单击导航树中[云安全/保密策略]菜单项，进入保密策略页面。

  2. 勾选保密范围多选框和可信区域中的主机节点。

  3. 单击<保存>按钮完成操作。

参数说明

  • 保密范围：用于指定受策略控制的虚拟机密级级别。对于策略指定密级级别的虚拟机，不允许克隆、卸载硬盘、删除时强制对磁盘文件进行清零。

  • 可信区域：用于指定受策略控制的密级级别的虚拟机允许迁移的主机范围，即受控虚拟机只能迁移到可信区域内的主机，如果不指定可信区域，则不允许迁移。


访问策略管理

访问策略定义了操作员的访问控制信息。管理员可通过引用访问控制策略来限制操作员是否可以登录CVM。当访问策略被操作员引用后，访问策略限制才会生效。

访问策略根据限制的类型可分为以下几种情况：

  • 只限制操作员访问系统的时间：操作员只能在指定时间访问系统。

  • 只限制操作员登录系统使用的IP：操作员只能使用指定的IP访问系统。

  • 同时限制操作员登录系统使用的IP和访问系统的时间。

在同时限制操作员登录系统使用的IP和访问系统的时间的情况下，操作员是否能够登录系统根据以下情况进行判断：

  • 当操作员登录系统使用的IP与访问策略规则匹配时，即操作员登录系统使用的IP属于访问策略规则中设置的IP范围内：

  • 若规则的访问类型为允许，则在允许访问系统的时间段内，可以登录。

  • 若规则的访问类型为拒绝，则无法登录。

  • 当操作员登录系统使用的IP与访问策略规则未匹配时，使用默认访问类型对其进行处理：

  • 若默认访问类型为允许，则在允许访问系统的时间段内，可以登录。

  • 若默认访问类型为拒绝，则无法登录。

注意事项

  • 默认访问类型和规则中的访问类型不能全部一致。

  • 如果访问策略正在被操作员使用，则不允许删除。

  • 一个访问策略中可包含多条规则。

增加访问策略

  1. 单击导航树中[云安全/访问策略]菜单项，进入访问策略列表页面。

  2. 单击<增加访问策略>按钮，弹出增加访问策略对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  4. 设置完成后，单击<确定>按钮。

修改访问策略

  1. 单击导航树中[云安全/访问策略]菜单项，进入访问策略列表页面。

  2. 选中待修改的策略，单击<修改访问策略>按钮，弹出修改访问策略对话框。

  3. 修改相关参数。关于参数的详细介绍，请参见 参数说明 。

  4. 修改完成后，单击<确定>按钮。

删除访问策略

  1. 单击导航树中[云安全/访问策略]菜单项，进入访问策略列表页面。

  2. 选中待删除的策略，单击<删除访问策略>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮。

查看访问策略详细信息

  1. 单击导航树中[云安全/访问策略]菜单项，进入访问策略列表页面。

  2. 选中待查看的策略，单击<查看访问策略>按钮，弹出查看访问策略对话框。

  3. 查看对应的访问策略信息。

参数说明

  • 默认访问类型：操作员登录系统未匹配上访问策略规则时，则使用默认访问类型对其进行处理，包括允许、拒绝，默认为允许。

  • 访问时间控制：是否控制操作员访问系统的时间，包括不启用、每周、每天，默认为不启用。

  • 起始IP：规则使用的起始IP。

  • 结束IP：规则使用的结束IP。若操作员登录系统所用IP属于设置的IP范围，系统将根据规则定义的访问类型允许或拒绝操作员登录。

  • 访问类型：对匹配规则的操作员的处理动作，包括允许、拒绝，默认为拒绝。


双因子认证

ARM架构的主机暂不支持“双因子认证”功能。

双因子认证通过证书认证、动态口令及验证码的方式登录系统，确保登录更加安全。

启用双因子认证后，系统将采用USBkey/动态口令/验证码结合密码两种条件的认证方式，操作员登录系统时，需要输入PIN码/动态口令/验证码、用户名和密码。

注意事项

  • 启用证书认证登录时，必须确保上传的根证书正确，并且USBkey能够正确登录到系统中，否则将导致无法登录系统。

  • 启用动态口令登录时，必须确保上传的代理配置文件正确，否则将导致无法登录系统。

操作步骤

  1. 单击导航树中[云安全/双因子认证]菜单项，进入双因子认证页面。

  2. 选择开启双因子登录，设置证书参数后，单击<保存>按钮。

参数说明

  • 启用双因子登录：启用双因子登录后，系统将采用USBkey/动态口令/验证码结合密码两种条件的认证方式，登录系统时需要输入PIN码/动态口令/验证码、用户名和密码。

  • 认证方式：支持证书认证、动态口令、验证码。

选择“证书认证”还需设置如下参数：

  • 根证书文件：校验USBkey证书有效性的根证书文件。系统允许上传的根证书文件最大为5MB；已选择的根证书文件会自动上传到系统。

  • 启用CRL定时更新：是否启用CRL定时更新。

  • 链接：查询吊销列表的地址。

  • 频率：定时同步的频率，包括每月、每周、每天，默认为每周。

  • 时间：定时同步时间。

选择“动态口令”还需设置如下参数：

  • 动态口令厂商：支持飞天诚信和安赛。

  • 主机认证代理配置：认证代理配置文件请登录飞天诚信OPT Server管理中心下载。仅动态口令厂商为飞天诚信时需要配置此参数。

  • 认证服务器地址：安塞认证服务器的地址。仅动态口令厂商为安赛时需要配置此参数。


ACL策略管理

ACL（Access Control List，访问控制列表）是一条或多条规则的集合，用于识别报文流。这里的规则是指描述报文匹配条件的判断语句，匹配条件可以是报文的源IP地址、目的IP地址、端口号等。网络设备依据规则识别出特定的报文，并根据预先设定的策略对流量进行处理。

ACL是一种基于包过滤的安全控制技术。通过ACL可以控制虚拟机之间的网络访问能力，进而保障部署在虚拟机上的业务资源的安全性。

ACL策略管理提供了查看、增加、删除和修改ACL策略及其规则的功能。

注意事项

如果ACL策略正在被网络策略模板引用时，则不允许删除。

增加ACL策略

  1. 单击导航树中[云安全/ACL策略]菜单项，进入ACL策略列表页面。

  2. 单击<增加>按钮，弹出增加ACL策略对话框。

  3. 设置策略名称、描述、入方向默认动作、出方向默认动作、ACL类型、所有者、启用时间段。各参数的详细介绍，请参见 参数说明 。

  4. 单击<增加规则>按钮，弹出增加规则对话框。

  5. 设置规则相关参数。关于参数的详细介绍，请参见 参数说明 。

  6. 单击<修改优先级>按钮，弹出修改优先级对话框。

  7. 通过拖动行的方式改变多条规则间的优先级，单击<确定>按钮，返回增加ACL策略对话框。

  8. 单击<确定>按钮。

修改ACL策略

  1. 单击导航树中[云安全/ACL策略]菜单项，进入ACL策略列表页面。

  2. 选中待修改的ACL策略，单击<修改>按钮，弹出修改ACL策略对话框。

  3. 修改ACL策略相关参数并修改策略中各规则间的优先级。关于参数的详细介绍，请参见 参数说明 。

  4. 单击<确定>按钮。

切换为公共策略

  1. 单击导航树中[云安全/ACL策略]菜单项，进入ACL策略列表页面。

  2. 选中待切换的ACL策略，单击<切换为公共策略>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮，将策略切换为公共策略。

复制ACL策略

  1. 单击导航树中[云安全/ACL策略]菜单项，进入ACL策略列表页面。

  2. 选中待复制的ACL策略，单击<复制>按钮，弹出复制ACL策略对话框。

  3. 填写或修改相关参数，单击<确定>按钮。

删除ACL策略

  1. 单击导航树中[云安全/ACL策略]菜单项，进入ACL策略列表页面。

  2. 选中待删除的ACL策略，单击<删除>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮。

过滤ACL策略

  1. 单击导航树中中[云安全/ACL策略]菜单项，进入ACL策略列表页面。

  2. 在“所有者”处，通过选择“全部”，“公共”，或“私有”，根据策略所有者过滤并查看系统中的所有ACL策略。

查看ACL策略详细信息

  1. 单击导航树中[云安全/ACL策略]菜单项，进入ACL策略列表页面。

  2. 选中待查看的ACL策略，单击<查看>按钮，弹出查看ACL策略对话框。

参数说明

  • 入方向默认动作：若虚拟交换机入方向的报文未匹配上ACL策略中的规则，则使用入方向默认动作对报文进行处理，包括允许、拒绝，默认为允许。

  • 出方向默认动作：若虚拟交换机出方向的报文未匹配上ACL策略中的规则，则使用出方向默认动作对报文进行处理，包括允许、拒绝，默认为允许。

  • ACL类型：创建的ACL规则类型，包括IP、二层。

  • IP：表示报文根据ACL规则的源IP地址、目的IP地址、IP承载的协议类型等三、四层信息进行过滤。

  • 二层：表示报文根据ACL规则的源MAC地址、目的MAC地址等链路层协议信息进行过滤。

  • 所有者：选择ACL策略的所有者，公共策略指系统中所有用户都可查看并使用的策略，私有策略只有创建者所属用户组的用户才可以查看并使用。

  • 启用时间段：设置ACL策略中的规则在每天指定时间段内生效。未开启“启用时间段”，则ACL规则将不受时间段限制一直生效。

  • 方向：匹配ACL规则的报文的方向，包括入方向，出方向，入方向和出方向，默认为入方向。

  • 动作：对匹配ACL规则的报文的处理的动作，包括允许、拒绝，默认为允许。

当ACL类型为IPv4时，需配置如下参数：

  • 协议： 匹配ACL规则的报文的协议类型，包括ALL、ICMP、TCP和UDP。

  • IP类型：选择IP地址类型，包括IPv4和IPv6。

  • 源IP地址：匹配ACL规则的报文的源IP地址。

  • 源子网掩码：匹配ACL规则的报文的源子网掩码。

  • 源网络前缀：匹配ACL规则的报文的源网络前缀。

  • 源端口：匹配ACL规则的报文的源端口。

  • 目的IP地址：匹配ACL规则的报文的目的IP地址。

  • 目的子网掩码：匹配ACL规则的报文的目的子网掩码。

  • 目的网络前缀：匹配ACL规则的报文的目的网络前缀。

  • 目的端口：匹配ACL规则的报文的目的端口。

当ACL类型为二层时，需配置如下参数：

  • 协议：匹配ACL规则的报文的协议类型，包括ALL、ARP、RARP、IPv4和IPv6。

  • 源MAC地址：匹配ACL规则的报文的源MAC地址。

  • 源MAC掩码：匹配ACL规则的报文的源MAC掩码。MAC掩码与MAC地址格式一致，均为48位。通过MAC掩码，可以实现一条ACL规则匹配多个MAC地址。

  • 目的MAC地址：匹配ACL规则的报文的目的MAC地址。

  • 目的MAC掩码：匹配ACL规则的报文的目的MAC掩码。MAC掩码与MAC地址格式一致，均为48位。通过MAC掩码，可以实现一条ACL规则匹配多个MAC地址。


虚拟防火墙管理

虚拟防火墙是一组过滤规则的集合，可以对虚拟机进行安全防护，防止虚拟机遭受外部的攻击，提升数据中心虚拟机的安全性和可靠性。

虚拟防火墙使用基于连接状态的检测机制，将通信双方之间交互的属于同一连接的所有报文都作为整体的数据流来对待。对于新建立的应用连接，防火墙会预先检查其关联的规则，放行允许通过的连接，并记录该连接的状态信息，生成状态表；对于该连接的后续数据报文，只要符合状态表，就可以通过。

系统支持两种类型的虚拟防火墙：白名单和黑名单。与白名单防火墙关联的规则匹配的报文允许通过，反之丢弃；与黑名单防火墙关联的规则匹配的报文会被丢弃，反之允许通过。

系统支持配置的规则包括TCP、UDP、ICMP以及一些常用的应用协议如DNS、HTTP、HTTPS、IMAP、IMAPS、LDAP、MS SQL、MYSQL、POP3、POP3S、RDP、SMTP、SMTPS、SSH等。

配置了虚拟防火墙的虚拟机与远端站点通信时，防火墙规则有两种应用方向，包括入口和出口：

  • 入口：远端站点向虚拟机发起连接的方向。

  • 出口：虚拟机向远端站点发起连接的方向。

对于系统支持的DNS、HTTP、HTTPS等常用的应用协议类型的规则，其应用方向默认为入口方向。

注意事项

  • 虚拟防火墙与ACL策略是互斥的。若虚拟机同时配置了虚拟防火墙和ACL策略，只有虚拟防火墙生效。

  • 虚拟防火墙默认放行所有DHCP连接。若要过滤虚拟机的DHCP报文，请为虚拟机配置相应的ACL策略。

  • 虚拟防火墙正在被虚拟机使用时，不允许删除。

增加虚拟防火墙

  1. 单击导航树中[云安全/虚拟防火墙]菜单项，进入虚拟防火墙列表页面。

  2. 单击<增加>按钮，弹出增加虚拟防火墙对话框。

  3. 输入虚拟防火墙的名称和描述信息。

  4. 选择防火墙的类型。

  5. 根据实际情况为虚拟防火墙增加相应规则：单击<增加规则>按钮，弹出增加规则对话框。设置相关参数，单击<确定>按钮，返回增加虚拟防火墙对话框。

  6. 单击<确定>按钮完成操作。

修改虚拟防火墙

  1. 单击导航树中[云安全/虚拟防火墙]菜单项，进入虚拟防火墙列表页面。

  2. 在虚拟防火墙列表中选中待修改的虚拟防火墙，单击 [image] 图标，弹出修改虚拟防火墙对话框。

  3. 输入虚拟防火墙的描述信息。

  4. 修改虚拟防火墙的规则信息：

  • 增加虚拟防火墙的规则：单击<增加规则>按钮，为虚拟防火墙增加规则。

  • 修改虚拟防火墙的规则：单击规则对应操作列的 [image] 图标，修改对应的规则。

  • 删除虚拟防火墙的规则：单击规则对应操作列的 [image] 图标，删除对应的规则。

  5. 单击<确定>按钮完成操作。

删除虚拟防火墙

  1. 单击导航树中[云安全/虚拟防火墙]菜单项，进入虚拟防火墙列表页面。

  2. 在虚拟防火墙列表中选中待删除的虚拟防火墙，单击 [image] 图标，弹出删除虚拟防火墙的确认对话框。

  3. 单击<确定>按钮完成操作。

参数说明

虚拟防火墙：

  • 防火墙类型：包括白名单和黑名单两种类型。与白名单防火墙关联的规则匹配的报文允许通过，反之丢弃；与黑名单防火墙关联的规则匹配的报文会被丢弃，反之允许通过。

  • 增加白名单防火墙时，默认入口方向的规则为空，出口方向已关联两条全匹配规则（系统未启用“虚拟机IPv6地址管理”功能时，默认出口方向只关联一条IPv4的全匹配规则）。当虚拟机配置此防火墙后，默认远端站点向虚拟机发起的入方向连接都会被拒绝，但不会限制虚拟机的出方向连接。对于入方向需要放行的连接，可增加对应的入口方向规则。当需要限制虚拟机的出方向连接时，需要先删除防火墙默认关联的出口方向的全匹配规则，再根据实际业务情况增加相应的出口方向规则。

  • 增加黑名单防火墙时，默认关联的入口方向、出口方向规则都为空。当虚拟机配置此防火墙后，默认放行虚拟机的所有入方向、出方向连接。当需要限制虚拟机的入方向或出方向连接时，可根据实际情况增加相应的入口或出口方向规则，与规则匹配的连接报文会被丢弃。

规则列表：

  • 方向：规则应用的方向，即虚拟机与远端站点通信建立逻辑连接的方向。入口表示从远端站点到虚拟机，出口表示从虚拟机到远端站点。

  • IP协议：虚拟防火墙允许或禁止IP报文通过的协议类型。若此参数设置为“任何”，表示虚拟防火墙允许或者拒绝所有协议类型的IP报文通过。

  • 端口/类型-编码：对于协议类型为TCP或UDP的IP报文，此参数表示虚拟机防火墙允许或禁止IP报文通过的端口号；对于协议类型为ICMP的IP报文，此参数表示虚拟机防火墙允许或禁止IP报文通过的类型-编码。

  • 远端CIDR：虚拟防火墙允许或禁止报文通过的远端站点IP。0.0.0.0/0表示任意的IPv4地址，::/0表示任意的IPv6地址。

增加或修改虚拟防火墙的规则：

  • 方向：虚拟机与远端站点通信建立逻辑连接的方向，包括入口和出口，默认为入口。入口表示从远端站点到虚拟机，出口表示从虚拟机到远端站点。

  • 端口：虚拟机防火墙允许或禁止IP报文通过的端口号。若方向选择为“入口”，则表示远端站点访问虚拟机的端口；若方向选择为“出口”，则表示虚拟机访问远端站点的端口。当选择“定制TCP规则”或“定制UDP规则”时需要设置此参数。白名单防火墙为打开，黑名单防火墙为关闭。

  • 类型：虚拟防火墙允许或禁止ICMP报文通过的type类型。当选择“定制ICMP规则”时需要设置此参数。白名单防火墙为允许，黑名单防火墙为禁止。

  • 编码：虚拟防火墙允许或禁止ICMP报文通过的code编码。当选择“定制ICMP规则”时需要设置此参数。白名单防火墙为允许，黑名单防火墙为禁止。

  • IP协议：虚拟防火墙允许或禁止IP报文通过的协议类型，对应IP报文头部的protocol字段。当选择“其他规则”时，需要设置此参数。白名单防火墙为允许，黑名单防火墙为禁止。

  • IP类型：选择IP报文类型，包括IPv4和IPv6。

  • 远端IP地址：虚拟防火墙允许或禁止报文通过的远端站点的IP地址。当选择“IPv4”类型时，输入远端站点的IPv4地址；当选择“IPv6”类型时，输入远端站点的IPv6地址。设置为空，表示任意的IP地址。白名单防火墙为允许，黑名单防火墙为禁止。

  • 子网掩码：远端站点IPv4地址的子网掩码。

  • 网络前缀：远端站点IPv6地址的网络前缀。


网络限速策略管理

网络限速策略是一条或多条规则的集合。规则用于识别网络报文流，对于识别出的特定网络报文流，限制其平均带宽和突发缓冲。网络限速策略用于虚拟机与特定站点之间网络流量带宽的精确控制。

网络限速策略通过网络策略模板作用到虚拟机上，与网络策略模板中入方向和出方向的流量限制相比，具有更精细的控制粒度。

增加网络限速策略

  1. 单击导航树中[云安全/网络限速策略]菜单项，进入网络限速策略列表页面。

  2. 单击<增加>按钮，弹出增加网络限速策略对话框。

  3. 输入网络限速策略的名称、描述信息、所有者、启用时间段。

  4. 根据实际情况为网络限速策略增加相应规则：单击<增加规则>按钮，弹出增加规则对话框。设置相关参数，单击<完成>按钮，返回增加网络限速策略对话框。

  5. 单击<确定>按钮，完成操作。

修改网络限速策略

  1. 单击导航树中[云安全/网络限速策略]菜单项，进入网络限速策略列表页面。

  2. 选中需要修改的网络限速策略，单击对应操作列的 [image] 图标，弹出修改网络限速策略对话框。

  3. 修改网络限速策略的描述信息。

  4. 修改网络限速策略的规则信息：

  • 增加规则：单击<增加规则>按钮，为网络限速策略增加规则。

  • 修改规则：单击规则对应操作列的 [image] 图标，修改对应的规则。

  • 删除规则：单击规则对应操作列的 [image] 图标，删除对应的规则。

  • 设置规则优先级：单击<修改优先级>按钮，设置规则的优先级。

  5. 单击<确定>按钮，完成操作。

切换为公共策略

  1. 单击导航树中[云安全/网络限速策略]菜单项，进入网络限速策略列表页面。

  2. 选中需要切换所有者的网络限速策略，单击对应操作列 [image] 图标，弹出操作确认对话框。

  3. 单击<确定>按钮，将策略切换为公共策略。

复制网络限速策略

  1. 单击导航树中[云安全/网络限速策略]菜单项，进入网络限速策略列表页面。

  2. 选中需要复制的网络限速策略，单击对应操作列 [image] 图标，弹出复制网络限速策略的对话框。

  3. 填写或修改相关参数，单击<确定>按钮完成操作。

删除网络限速策略

  1. 单击导航树中[云安全/网络限速策略]菜单项，进入网络限速策略列表页面。

  2. 选中需要删除的网络限速策略，单击对应操作列 [image] 图标，弹出删除网络限速策略的确认对话框。

  3. 单击<确定>按钮完成操作。

过滤网络限速策略

  1. 单击导航树中[云安全/网络限速策略]菜单项，进入网络限速策略列表页面。

  2. 在“所有者”处，通过选择“全部”，“公共”，或“私有”，根据策略所有者过滤并查看系统中的所有网络策略。

参数说明

  • 所有者：选择网络限速策略的所有者，公共策略指系统中所有用户都可查看并使用的策略，私有策略只有创建者所属用户组的用户才可以查看并使用。

  • 远端CIDR：网络限速策略限制网络流量的网段。0.0.0.0/0表示任意的IPv4地址，::/0表示任意的IPv6地址。不填表示任意的IP地址。

  • 方向：应用规则的流量的方向，包括上行和下行。

  • 上行：表示虚拟机发送给远端站点的流量。

  • 下行：表示远端站点发送给虚拟机的流量。

  • 平均带宽：允许的流量平均带宽，单位为Kbps或Mbps。

  • 突发缓冲：允许的为突发流量预留的缓冲区大小，单位为KBytes或MBytes。

  • 优先级：网络限速策略匹配规则列表的优先级。当存在同方向的多条规则且高优先级规则限制的远端站点的IP包含低优先级规则限制的站点IP时，低优先级规则失效，系统将按照高优先级规则进行匹配，对相关网络流量进行限速。例如有两条上行方向的规则A和B，规则A限制的远端站点IP范围是192.168.100.0/24，规则B限制的远端站点IP是192.168.100.40/32。当规则A的优先级高于规则B时，由于规则A限制远端站点包含规则B中限制的远端站点，此时规则B失效，网络限速策略只会根据规则A进行匹配。


管理平台备份配置管理

管理平台备份配置管理实现了系统自动定时备份和手动备份CVM数据和配置文件的功能，同时提供了查看备份历史，下载备份历史数据的功能，以及利用历史备份数据对当前的CVM系统进行数据和配置文件的还原。

  • 自动备份CVM是在CVM启动后，自动将CVM当前的数据和配置文件保存到CVM所管理的随机挑选的三台主机上。正常情况下，每天进行一次自动备份，每台主机上保留最近7次的备份文件。CVM版本升级后，老版本的备份文件依旧保留。

  • 定时备份CVM是通过设置备份频率和执行时间，系统周期性对CVM数据和配置文件进行自动备份，配置方法请参见 管理平台备份配置 _Ref493000511 。

  • 手动备份CVM是指手动触发对CVM数据和配置文件进行备份，操作步骤请参见 备份管理平台数据 。

主要功能

  • 管理平台备份配置

  • 备份管理平台数据


管理平台备份配置

该功能用于配置保存CVM备份文件的位置（自动备份文件和手动备份文件的保存位置是相同），设置是否启动自动备份功能及其参数。

注意事项

  • 在执行CVM备份后，如果删除虚拟机及其镜像文件，则CVM备份恢复后该虚拟机不能恢复。

  • 使用远端备份时，请提前在远端服务器上规划好备份路径，创建备份目录。

操作步骤

  1. 单击导航树中[云安全/管理平台备份配置]菜单项，进入管理平台备份配置页面。

  2. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  3. 设置完成后，单击<保存>按钮，保存管理平台备份配置，或单击<立即备份>按钮，并在弹出的对话框中单击<确定>按钮，立即备份CVM数据。

参数说明

  • 备份目的地：CVM备份文件保存到目的地的方式，包括主机本地目录、远端服务器，默认为主机本地目录。

当备份到主机本地目录时，需设置如下参数：

  • 备份位置：CVM所在主机存放CVM备份文件的路径。

当备份到远端服务器时，需设置如下参数：

  • IP地址：远端服务器的IP地址。

  • 用户名：远端服务器的用户帐号。该帐号要求有可读写远端服务器的权限。若连接远端服务器的方式为FTP，则该账号必须为远端服务器FTP Server上创建的帐号；若连接远端服务器的方式为SCP，则该账号必须为远端服务器操作系统上创建的帐号。

  • 密码：用户帐号对应的密码。

  • 连接方式：将CVM备份文件传输到远端服务器所使用的传输协议，包括FTP和SCP，默认为FTP。若选择FTP方式，则仅支持Server-U、VsFTP、IIS类型的FTP服务器。

  • 备份位置：远端服务器上存放CVM备份文件的路径。请确认远端服务器上已存在该路径。

  • 连接测试：对CVM和远端服务器的连通性进行实时检查。

  • 服务器端口：访问远端服务器所用的端口号。当连接方式为FTP时，服务器端口默认为21；当连接方式为SCP时，服务器端口默认为22。

  • 启用定时备份：是否定时备份CVM，默认为否。当设置为是时，需设置如下参数：

  • 频率：执行备份的频率。默认为每周。

  • 时间：执行备份的开始时间。

  • 保留个数：系统保留CVM备份文件的个数，默认值为空。


备份管理平台数据

该功能用于对当前CVM系统数据进行备份，生成CVM备份文件。备份内容包括数据库、HA配置、版本信息等。当CVM管理平台发生故障时，通过CVM备份文件可快速回复CVM管理平台，而不影响虚拟化环境的使用。

备份CVM数据的操作结果说明如下：

  • 失败：表示备份失败，不会生成备份文件。

  • 成功：表示备份成功，会生成包含CVK配置的备份文件。该备份文件可以用于还原操作。

  • 部分成功：表示生成的备份文件中，有部分CVK配置备份失败。该备份文件可以用于还原操作，只是存在部分CVK主机的备份失败，不影响CVM备份的还原操作。

注意事项

CVM数据的备份路径在管理平台备份配置页面进行设置，默认路径为“/vms”。

操作步骤

  1. 单击导航树中[云资源]菜单项，进入云资源概要信息页面。

  2. 单击<备份CVM数据>按钮，弹出备份CVM数据对话框。

  3. 单击<确定>按钮，开始备份CVM数据。


管理平台备份历史管理

每完成一次CVM数据备份，系统将在CVM备份历史列表中展示每一次CVM数据备份的相关信息，包括备份文件名、创建时间、版本号、备份目的地、备份位置等。

注意事项

  • 为了确保CVM数据还原后能够正常使用，需要执行如下操作：在还原CVM数据之前，必须关闭所有集群的HA功能。在还原CVM数据后，先执行“连接所有主机”操作，然后重新启用集群的HA功能。

  • 还原CVM数据时，必须确保当前主机、虚拟机、共享存储等相关资源的数量与备份时没有任何增减，以免发生还原错误。

  • 还原CVM数据时，将不支持其他操作员并发操作，即只能在当前操作员完成CVM数据还原操作后，其他操作员才能进行管理操作。

查看备份历史列表

  1. 单击导航树中[云安全/管理平台备份配置]菜单项，进入管理平台备份配置页面。

  2. 选择“备份历史”页签，进入CVM备份历史页面。

下载备份历史

  1. 单击导航树中[云安全/管理平台备份配置]菜单项，进入管理平台备份配置页面。

  2. 选择“备份历史”页签，进入CVM备份历史页面。

  3. 在CVM备份历史列表中选择待下载的备份，单击 [image] 图标，完成下载操作。

还原CVM数据

  1. 单击导航树中[云安全/管理平台备份配置]菜单项，进入管理平台备份配置页面。

  2. 选择“备份历史”页签，进入CVM备份历史页面。

  3. 在CVM备份历史列表中选择待还原的备份，单击 [image] 图标，弹出还原CVM数据对话框。

  4. 单击<确定>按钮，开始CVM数据还原操作。

上传备份文件

  1. 单击导航树中[云安全/管理平台备份配置]菜单项，进入管理平台备份配置页面。

  2. 选择“备份历史”页签，进入CVM备份历史页面。

  3. 单击<上传>按钮，弹出上传对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 设置完成后，单击<完成>按钮。

导入备份历史

  1. 单击导航树中[云安全/管理平台备份配置]菜单项，进入管理平台备份配置页面。

  2. 选择“备份历史”页签，进入CVM备份历史页面。

  3. 单击<导入>按钮，弹出导入备份历史对话框。

  4. 设置相关参数。关于参数的详细介绍，请参见 参数说明 。

  5. 设置完成后，单击<确定>按钮。

参数说明

  • 文件名：CVM备份文件的名称。

  • 创建时间：CVM备份文件的创建时间。

  • 版本号：自动备份和手动备份时的CVM版本号。

  • 备份目的地：CVM备份文件的存放位置，包括主机本地目录、远端服务器，默认为主机本地。

  • 上传目的地：保存上传的CVM备份文件的位置，包括主机本地目录和远端服务器，默认值为主机本地目录。

当备份目的地或上传目的地为主机本地目录时，需设置如下参数：

  • 备份位置/上传位置：CVM所在主机存放CVM备份文件的路径。

当备份目的地或上传目的地为远端服务器时，需设置如下参数：

  • IP地址：远端服务器的IP地址。

  • 用户名：远端服务器的用户帐号。该帐号要求有可读写远端服务器的权限。若连接远端服务器的方式为FTP，则该账号必须为远端服务器FTP Server上创建的帐号；若连接远端服务器的方式为SCP，则该账号必须为远端服务器操作系统上创建的帐号。

  • 密码：用户帐号对应的密码。

  • 连接方式：将CVM备份文件传输到远端服务器所使用的传输协议，包括FTP和SCP，默认为FTP。若选择FTP方式，则仅支持Server-U、VsFTP、IIS类型的FTP服务器。

  • 备份位置/上传位置：远端服务器上存放CVM备份文件的路径。

  • 服务器端口：访问远端服务器所用的端口号。当连接方式为FTP时，服务器端口默认为21；当连接方式为SCP时，服务器端口默认为22。

  • 连接测试：对CVM和远端服务器的连通性进行实时检查。


防病毒配置

ARM架构的主机暂不支持“防病毒配置”功能。

云资源数据密集度高，为了降低遭受攻击的风险以及遭受攻击后可能面临的损失，CVM提供了防病毒配置功能，加强了云资源的安全防护。

该功能用于防病毒软件的配置、上传和安装。上传的防病毒补丁包要求为“.tar.gz”格式，且解压后直接为安装程序。

注意事项

上传过程中请勿关闭该窗口或浏览器，以免导入防病毒补丁包失败。

操作步骤

  1. 单击导航树中[云安全/防病毒配置]菜单项，进入防病毒配置页面。

  2. 选择防病毒厂商，输入防病毒补丁包保存目录。

  3. 单击虚线框区域，在弹出的对话框中选择需要导入的防病毒补丁包，或者直接将防病毒补丁包拖拽到虚线框中。单击<开始上传>按钮上传防病毒补丁包，上传成功后CVK主机会自动安装防病毒补丁。

  4. 单击<检查>按钮，检测CVK主机安装防病毒补丁的情况。如果CVK主机没有自动安装防病毒补丁，可单击 [image] 图标或单击<一键安装>按钮手动进行安装。

参数说明

  • 防病毒厂商：支持的防病毒软件厂商。

  • 保存目录：用于存放上传的防病毒补丁的目录。

  • 已上传补丁包：最近一次上传的防病毒补丁包的名称。

  • 名称：主机的名称。

  • 状态：主机的状态。

  • IP地址：主机的IP地址。

  • 补丁包安装状态：主机中防病毒补丁是否安装，包括未安装、已安装。

  • 进度：检测操作执行进度，包括未检测、检测中、检测完毕、检测异常、安装中、安装成功、安装失败。

  • 操作：以图标的形式显示操作员可执行的操作。

  • 表示为主机安装防病毒补丁。

  • 表示卸载主机的防病毒补丁。


保密业务电子流管理

ARM架构的主机暂不支持“保密业务电子流”功能。

保密业务电子流管理用于管理电子流信息，包括修改安全区域内虚拟机密级级别、增加虚拟机磁盘、删除虚拟机磁盘、删除异常主机等电子流信息。

保密业务电子流管理提供了查看、审批和删除的功能。

配置前提

当开启保密模式时，系统才显示保密业务电子功能。关于开启保密模式的配置，请参见 系统参数设置 。

注意事项

审批完成的保密业务电子流不允许删除，包括审批通过和审批驳回。

查看保密业务电子流详细信息

  1. 单击导航树中[云安全/保密业务电子流]菜单项，进入保密业务电子流列表页面。

  2. 选择待查看的电子流，单击 [image] 图标，弹出查看保密业务电子流对话框。

审批保密业务电子流

  1. 单击导航树中[云安全/保密业务电子流]菜单项，进入保密业务电子流列表页面。

  2. 选择待审批的电子流，单击 [image] 按钮，弹出查看保密业务电子流审批对话框。

删除保密业务电子流

  1. 单击导航树中[云安全/保密业务电子流]菜单项，进入保密业务电子流列表页面。

  2. 选择待删除的电子流，单击 [image] 按钮，弹出删除保密业务电子流确认对话框。

  3. 单击<确定>按钮。

参数说明

  • 状态：保密业务电子流状态，包括待审批、通过、驳回。

  • 申请人：保密业务电子流申请人名称。

  • 申请时间：保密业务电子流申请时间。

  • 审批人：保密业务电子流审批人名称。

  • 审批时间：保密业务电子流审批时间。

  • 实施结果：保密业务电子流实施结果，如果实施失败，会记录失败原因。

  • 审批意见：保密业务电子流审批意见。

  • 电子流基本信息：显示电子流的基本信息。


监控管理

监控管理功能包括监控报表管理、资源使用统计、自定义监控和审计日志管理。

  • 监控报表记录了主机或虚拟机在指定时间段内的CPU、内存等利用率信息。

  • 资源使用统计记录了集群、主机、虚拟机、IP资源、VLAN资源以及存储资源的使用情况。

  • 自定义监控提供了操作员自定义监控面板的功能。

  • 审计日志记录了所有操作员对CVM所做的操作，并按照操作类型将所有操作记录分为行为审计，物理资源审计，虚拟资源审计三类，为操作员提供了一种直接的审计手段。

主要功能

  • 监控报表

  • 资源使用统计

  • 自定义监控


监控报表

监控报表管理功能用于统计和展示操作员所关心的主机和虚拟机数据，如主机网络流量使用情况、主机性能统计、虚拟机网络流量使用情况、虚拟机性能统计和磁盘读写速率统计等。同时系统提供了将报表保存到本地的功能，操作员可以将查询报表结果保存为图片或者PDF文档。

主要功能

  • 查看主机性能统计信息

  • 查看虚拟机性能统计信息


查看主机性能统计信息

该功能用于统计和查看系统中指定主机在指定时间范围内的CPU利用率、内存利用率等信息。操作员可以根据需要设置查询条件，如指定统计周期，设置查询数据的开始时间和截止时间进行查询，并可以将报表保存到本地。

操作步骤

  1. 单击导航树中[监控管理/监控报表/主机报表]菜单项，进入主机性能统计页面。

  2. 设置查询条件相关参数。关于参数的详细介绍，请参见参数说明。

  3. 单击<查询>按钮，在页面下方报表显示部分，将会显示主机性能的查询结果。

  4. 单击 [image] 图标，可以将报表保存为图片。

  5. 单击<导出>按钮，导出主机性能的查询结果。

参数说明

  • 主机：待查询性能信息的主机。

  • 统计周期：主机性能统计的周期，包括小时、天、周、月、年，默认为天。

  • 开始时间：待查询数据的开始时间，不能大于结束时间，默认为当前日期的前一天。

  • 截止时间：待查询数据的结束时间，不能小于开始时间，默认为当前日期的前一天。

  • 统计类型：主机可供查询的性能统计信息，包括CPU利用率、内存利用率、磁盘利用率、磁盘读速率、磁盘写速率、磁盘I/O吞吐量、网络总流量、网络读流量、网络写流量、网络读速率、网络写速率，默认仅查询CPU利用率和内存利用率。

  • CPU利用率：按统计周期显示自开始时间至截止时间主机CPU使用情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 内存利用率：按统计周期显示自开始时间至截止时间主机内存使用情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 磁盘利用率：按统计周期显示自开始时间至截止时间主机磁盘使用情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 磁盘读速率：按统计周期显示自开始时间至截止时间主机磁盘读速率统计情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 磁盘写速率：按统计周期显示自开始时间至截止时间主机磁盘写速率统计情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 磁盘I/O吞吐量：按统计周期显示自开始时间至截止时间主机磁盘I/O吞吐量统计情况。显示框仅显示统计时间段内有统计数据的时间点。

  • 网络总流量：按统计周期显示自开始时间至截止时间主机网络总流量统计情况。显示框仅显示统计时间段内有统计数据的时间点。

  • 网络读流量：按统计周期显示自开始时间至截止时间主机网络读流量统计情况。显示框仅显示统计时间段内有统计数据的时间点。

  • 网络写流量：按统计周期显示自开始时间至截止时间主机网络写流量统计情况。显示框仅显示统计时间段内有统计数据的时间点。

  • 网络读速率：按统计周期显示自开始时间至截止时间主机网卡读流量统计情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 网络写速率：按统计周期显示自开始时间至截止时间主机网卡写流量统计情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。


查看虚拟机性能统计信息

该功能用于统计和查看系统中指定虚拟机在指定时间段内CPU、内存等利用率信息。操作员可以根据需要设置查询条件，如指定统计周期，设置查询数据的开始时间和截止时间进行查询，并可以将报表保存到本地。

操作步骤

  1. 单击导航树中[监控管理/监控报表/虚拟机报表]菜单项，进入虚拟机性能统计页面。

  2. 设置查询条件相关参数。关于参数的详细介绍，请参见参数说明。

  3. 单击<查询>按钮，在页面下方报表显示部分，将会显示虚拟机性能的查询结果。

  4. 单击 [image] 图标，可以将报表保存为图片。

  5. 单击<导出>按钮，导出虚拟机性能的查询结果。

参数说明

  • 虚拟机：待查询性能信息的虚拟机。

  • 统计周期：虚拟机性能统计的周期，包括小时、天、周、月、年，默认为天。

  • 开始时间：待查询数据的开始时间，不能大于结束时间，默认为当前日期的前一天。

  • 截止时间：待查询数据的结束时间，不能小于开始时间，默认为当前日期的前一天。

  • 统计类型：虚拟机可供查询的性能统计信息，包括CPU利用率、内存利用率、磁盘利用率、磁盘读速率、磁盘写速率、磁盘I/O吞吐量、网络总流量、网络读流量、网络写流量、网络读速率、网络写速率，默认仅查询CPU利用率和内存利用率。

  • CPU利用率：按统计周期显示自开始时间至截止时间虚拟机CPU使用情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 内存利用率：按统计周期显示自开始时间至截止时间虚拟机内存使用情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 磁盘利用率：按统计周期显示自开始时间至截止时间虚拟机磁盘使用情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 磁盘读速率：按统计周期显示自开始时间至截止时间虚拟机磁盘读速率统计情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 磁盘写速率：按统计周期显示自开始时间至截止时间虚拟机磁盘写速率统计情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 磁盘I/O吞吐量：按统计周期显示自开始时间至截止时间虚拟机磁盘I/O吞吐量统计情况。显示框仅显示统计时间段内有统计数据的时间点。

  • 网络总流量：按统计周期显示自开始时间至截止时间虚拟机网络总流量统计情况。显示框仅显示统计时间段内有统计数据的时间点。

  • 网络读流量：按统计周期显示自开始时间至截止时间虚拟机网络读流量统计情况。显示框仅显示统计时间段内有统计数据的时间点。

  • 网络写流量：按统计周期显示自开始时间至截止时间虚拟机网络写流量统计情况。显示框仅显示统计时间段内有统计数据的时间点。

  • 网络读速率：按统计周期显示自开始时间至截止时间虚拟机网卡读流量统计情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。

  • 网络写速率：按统计周期显示自开始时间至截止时间虚拟机网卡写流量统计情况，包括平均值、最大值、最小值。显示框仅显示统计时间段内有统计数据的时间点。


查看性能TopN统计信息

该功能用于统计和查看系统中指定时间段内，CPU、内存等利用率最高的主机或虚拟机信息，操作员可以根据需要设置查询条件，并可以将报表保存到本地。

操作步骤

  1. 单击导航树中[监控管理/监控报表/TopN统计报表]菜单项，单击“主机”页签进入主机性能TopN查询页面，或单击选择“虚拟机”页签进入虚拟机性能TopN查询页面。

  2. 设置查询条件相关参数。关于参数的详细介绍，请参见参数说明。

  3. 单击<查询>按钮，在页面下方报表显示部分，将会显示主机或虚拟机性能TopN的结果。

  4. 鼠标移动到报表图表中，将会浮动显示主机或虚拟机名称和相应统计数值；双击报表中柱形图，可以查看主机或虚拟机性能统计报表页面。

  5. 单击 [image] 图标，可以将报表保存为图片。

  6. 单击<导出>按钮，导出性能TopN的查询结果。

注意事项

TopN统计主机/虚机报表时，当主机/虚机名称过长时只显示前七位字符。

参数说明

  • 主机池：待查看性能信息的主机或虚拟机所在主机池。

  • 集群：待查看性能信息的主机或虚拟机所在集群。可选范围为已选定主机池下的集群，若未选择主机池，该选项无效。

  • 主机：待查询性能信息的虚拟机所在主机。可选范围为已选定集群或主机池下的主机，若未选择主机池，该选项无效。

  • 开始时间：待查询数据的开始时间，不能大于结束时间，默认为当前日期的前一天。

  • 截止时间：待查询数据的结束时间，不能小于开始时间，默认为当前日期的前一天。

  • TopN：CPU、内存等利用率最高的主机或虚拟机的查询个数，包括5、10，默认为5。

  • 统计类型：主机或虚拟机可供查询的性能TopN统计信息，包括CPU利用率、内存利用率、网络总流量、网络读流量、网络写流量、磁盘I/O吞吐量，默认仅查询CPU利用率和内存利用率。

  • CPU利用率：报表为柱形图，横坐标为主机或虚拟机的名称，纵坐标为主机或虚拟机在指定时间段内CPU利用率百分比的平均值，利用率从高到低依次从左到右排列。

  • 内存利用率：报表为柱形图，横坐标为主机或虚拟机的名称，纵坐标为主机或虚拟机在指定时间段内存利用率百分比的平均值，利用率从高到低依次从左到右排列。

  • 网络总流量：报表为柱形图，横坐标为主机或虚拟机的名称，纵坐标为主机或虚拟机在指定时间段网络总流量统计，按统计值从高到低依次从左到右排列。

  • 网络读流量：报表为柱形图，横坐标为主机或虚拟机的名称，纵坐标为主机或虚拟机在指定时间段网络读流量统计，按统计值从高到低依次从左到右排列。

  • 网络写流量：报表为柱形图，横坐标为主机或虚拟机的名称，纵坐标为主机或虚拟机在指定时间段网络写流量统计，按统计值从高到低依次从左到右排列。

  • 磁盘I/O吞吐量：报表为柱形图，横坐标为主机或虚拟机的名称，纵坐标为主机或虚拟机I/O吞吐量统计，按统计值从高到低依次从左到右排列。


资源使用统计

资源使用统计功能主要用于对操作员所关注的系统中集群、主机、虚拟机、IP、VLAN和存储资源分配情况的统计，给操作员提供一个更为详细的资源使用统计。

主要功能

  • 集群资源统计

  • 主机资源统计

  • 虚拟机资源统计

  • IP分配统计

  • VLAN分配统计

  • 存储资源统计


集群资源统计

该功能用于统计和查看集群基本信息和资源的使用情况，例如主机数、虚拟机概要、CPU总核数、CPU分配比、总内存、内存分配比等信息。

操作步骤

  1. 单击导航树中[监控管理/资源使用统计/集群资源统计]，进入集群资源统计页面。

  2. 单击<高级查询>按钮，选择要查询的主机池或集群后单击<确定>按钮，页面将显示集群资源统计的结果。双击集群名称还可跳转到集群的概要信息页面，查看集群的详细信息。

  3. 单击<打印>按钮可打印相应的信息。

  4. 单击<导出>按钮，弹出资源导出对话框，选择导出格式，单击<确定>按钮，导出相应信息。

参数说明

  • 主机数：集群中的主机总数。

  • 虚拟机概要：集群中虚拟机的总数，以及处于“运行”和“关闭”状态的虚拟机数量。

  • 虚拟机密度：集群中平均每个主机中虚拟机的数量。

  • CPU总核数：集群中各主机的CPU核数总和。

  • CPU分配比：集群中分配给虚拟机的CPU核数与主机CPU总核数的比例。

  • 总内存：集群中各主机的内存容量总和。

  • 内存分配比：集群中分配给虚拟机的内存大小与主机内存总和的比例。

  • 共享LUN数量：集群共享存储的LUN数量。


主机资源统计

该功能用于统计和查看主机基本信息和资源使用情况，例如运行时间、主机型号、CPU、型号、CPU利用率、内存利用率、本地磁盘容量等。

操作步骤

  1. 单击导航树中[监控管理/资源使用统计/主机资源统计]，进入主机资源统计页面。

  2. 单击<高级查询>按钮，选择要查询的主机池、集群或主机后单击<确定>按钮，在页面下方报表显示部分，将显示主机资源统计的查询结果。双击主机名称，跳转到主机的概要信息页面，查看主机的详细信息。

  3. 单击<打印>按钮可打印相应的信息。

  4. 单击<导出>按钮，弹出资源导出对话框，选择导出格式，单击<确定>按钮，导出相应信息。

参数说明

  • 状态：主机当前的状态，包括正常、不正常、维护模式、主机不在集群HA内。

  • 运行时间：主机已经连续运行的时间。

  • 主机型号：主机的型号信息。

  • CPU型号：主机物理CPU的型号信息。

  • CPU：主机CPU总核数，即CPU个数与每个CPU核数的乘积。

  • CPU分配数：主机已分配的CPU数量，即主机中所有虚拟机的数量之和。

  • CPU分配比：主机已分配CPU的比例，即CPU分配数/主机CPU总核数。

  • 内存：主机内存的容量。

  • 已分配内存：主机已分配内存的大小，即主机中所有虚拟机内存之和。

  • 内存分配比：主机已分配内存的比例，即已分配内存/主机总内存。

  • 运行中的内存：主机中所有运行状态虚拟机的内存总大小。

  • 虚拟机概要：主机上虚拟机的总数量，以及处于“运行”和“关闭”状态的虚拟机数量。

  • CPU利用率：主机CPU一小时内的平均利用率。

  • 内存利用率：主机内存一小时内的平均利用率。

  • 本地磁盘容量：主机本地磁盘的空间大小。

  • 平台：主机使用的虚拟化平台。目前仅支持CVK。


虚拟机资源统计

该功能用于查看虚拟机的资源使用情况。

操作步骤

  1. 单击导航树中[监控管理/资源使用统计/虚拟机资源统计]，进入虚拟机资源统计页面。

  2. 单击<高级查询>按钮，选择要查询的主机池、集群或主机后单击<确定>按钮，页面将会显示虚拟机资源统计的结果。

  • 双击虚拟机显示名称，跳转到虚拟机的概要信息页面，查看虚拟机的详细信息。

  • 单击虚拟机磁盘名称，弹出虚拟机磁盘对话框，查看磁盘的详细信息。

  3. 单击<打印>按钮可打印相应的信息。

  4. 单击<导出>按钮，弹出资源导出对话框，选择导出格式，单击<确定>按钮，导出相应信息。

参数说明

  • 显示名称：虚拟机的显示名称。

  • 集群名称：虚拟机所在集群的名称。

  • 虚拟机IP地址：虚拟机网卡的IP地址。

  • 描述：虚拟机的描述信息。

  • 主机：虚拟机所在主机名称。

  • 状态：虚拟机当前的状态，包括运行、暂停、关闭、未知、HA异常。

  • CPU利用率：虚拟机CPU一小时内的平均利用率。

  • 内存利用率：虚拟机内存一小时内的平均利用率。

  • CPU：虚拟机当前的CPU总核数，即CPU个数与每个CPU核数的乘积。

  • 内存：虚拟机当前的内存容量。

  • 虚拟机磁盘：虚拟机挂载的所有磁盘。单击虚拟机磁盘名称，可查看虚拟机磁盘的详细信息。

  • 操作系统：虚拟机上的操作系统。


IP分配统计

该功能主要统计系统中IP分配情况，可以快速的查询出每个主机池、集群和主机的虚拟机IP分配情况；支持以IP地址进行过滤查询，可快速查询使用该IP地址的虚拟机信息。在查询结果页面双击虚拟机显示名称可跳转到虚拟机的概要信息页面，查看虚拟机的详细信息。

操作步骤

  1. 单击导航树中[监控管理/资源使用统计/IP分配统计]，进入IP分配统计页面。

  2. 单击<高级查询>按钮，选择要查询的主机池、集群或主机后单击<确定>按钮，在页面下方报表显示部分，将显示IP资源统计的查询结果。

  3. 在IP地址搜索输入框中输入指定的IP地址，单击 [image] 图标可快速查询使用此IP地址的虚拟机信息。双击虚拟机显示名称，跳转到虚拟机的概要信息页面，查看虚拟机的详细信息。

  4. 单击<打印>按钮可打印相应的信息。

  5. 单击<导出>按钮，弹出资源导出对话框，选择导出格式，单击<确定>按钮，导出相应信息。

参数说明

  • MAC地址：虚拟机的MAC地址。

  • IP地址：虚拟机对应网卡的IP地址。

  • 操作系统：虚拟机上的操作系统。

  • CAStools版本：虚拟机CAStools版本信息。


VLAN分配统计

该功能用于统计系统中VLAN分配情况，便于快速查询虚拟机所属VLAN。

操作步骤

  1. 单击导航树中[监控管理/资源使用统计/VLAN分配统计]，进入VLAN分配统计页面。

  2. 在VLAN ID搜索输入框中输入指定的VLAN ID，可快速查询使用此VLAN ID的虚拟机信息。双击虚拟机显示名称，跳转到虚拟机的概要信息页面，查看虚拟机的详细信息。

  3. 单击VLAN ID列的 [image] 图标，展开VLAN ID下的虚拟机列表。

  4. 单击<打印>按钮可打印相应的信息。

  5. 单击<导出>按钮，弹出资源导出对话框，选择导出格式，单击<确定>按钮，导出相应信息。

参数说明

  • VLAN ID：虚拟机对应网卡的VLAN ID。

  • MAC地址：虚拟机的MAC地址。

  • IP地址：虚拟机的IP地址。

  • 操作系统：虚拟机上的操作系统。

  • CAStools版本：虚拟机的CAStools版本信息。


存储资源统计

该功能主要统计系统中存储资源分配情况，能够快速的查询出主机池、集群和主机下存储资源包括虚拟机磁盘、网络存储、共享文件系统的分配情况。

注意事项

网络存储的统计结果是根据添加该存储的主机进行显示，而非使用它的虚拟机。

操作步骤

  1. 单击导航树中[监控管理/资源使用统计/存储资源统计]，进入存储资源统计页面。

  2. 单击<类型>搜索框，可选择虚拟机磁盘、网络存储、共享文件系统，选择查询类型后，在页面下方报表显示部分，将显示相应查询结果。

  3. 单击<高级查询>按钮，弹出高级查询对话框，选择要查询的主机池、集群或主机后单击<确定>按钮，在页面下方报表显示部分，将显示相应的查询结果。

  • 单击虚拟机名称，跳转到虚拟机的概要信息页面，可查看虚拟机的详细信息。

  • 单击主机名称，跳转到主机的概要信息页面，可查看主机的详细信息。

  • 单击 [image] 图标，弹出使用者明细对话框，可查看共享文件系统详细信息。

  4. 单击<打印>按钮可打印相应的信息。

  5. 单击<导出>按钮，弹出资源导出对话框，选择导出格式，单击<确定>按钮，导出相应信息。

参数说明

虚拟机磁盘：

  • 磁盘名称：虚拟机磁盘名称。

  • 源路径：虚拟机磁盘所在路径。

  • 虚拟机显示名称：虚拟机的显示名称。单击虚拟机名称，可跳转到对应虚拟机的概要信息页面。

  • 状态：虚拟机当前状态。

  • 主机名称：主机的名称。单击主机名称，可跳转到对应主机的概要信息页面。

  • 磁盘容量：虚拟机磁盘总容量。

  • 可用容量：虚拟机磁盘可用容量。

  • 磁盘利用率：虚拟机的磁盘利用率。

网络存储：

  • 显示名称：网络存储的显示名称。

  • 类型：网络存储类型。

  • 主机名称：主机的显示名称。单击主机名称，可跳转到对应主机的概要信息页面。

  • 总容量：网络存储的总容量。

  • 已分配容量：对于类型为iSCSI网络存储或FC网络存储的存储池，此参数表示存储池中块设备的总容量。

  • 实际可用容量：网络存储中实际可用容量。

  • 状态：网络存储的状态。

  • 使用者：该网络存储的使用者明细。

共享文件系统：

  • 显示名称：共享文件系统的显示名称。

  • 类型：共享文件系统的类型。

  • 目标路径：共享文件系统的路径。

  • 总容量：共享文件系统的总容量。

  • 已分配容量：共享文件系统中已分配给虚拟机磁盘的虚拟容量总和。

  • 实际可用容量：共享文件系统的实际可用容量。

  • 磁盘利用率：共享文件系统的磁盘利用率。

  • 使用者：使用该共享文件系统的存储卷明细，单击 [image] 图标即可查看。


TopN虚拟机存储资源统计

该功能用于统计和查看主机池、集群和主机下TopN虚拟机的实时存储资源统计信息。操作员可以根据需求设置查询条件，并可以将报表导出到本地。

注意事项

TopN统计主机/虚机报表时，当主机/虚机名称过长时只显示前七位字符。

操作步骤

  1. 单击导航树中[监控管理/资源使用统计/TopN虚拟机存储资源]菜单项，进入TopN虚拟机存储资源信息页面。

  2. 选择主机池、集群、主机、TopN数值，单击<查询>按钮，在页面下方报表显示部分，将会显示虚拟机存储资源TopN的结果。

  3. 鼠标移动到报表图表中，将会浮动虚拟机名称和相应统计数值。

  4. 单击<重置>按钮，可重置查询条件，重新选择查询条件，单击<查询>按钮，查询结果将按当前查询条件重新显示。

  5. 单击<导出>按钮，导出TopN虚拟机存储资源的查询结果。

参数说明

  • 主机池：主机或虚拟机所在的主机池。

  • 集群：主机或虚拟机所在的集群。可选范围为已选定主机池下的集群，若未选择主机池，该选项无效。

  • 主机：虚拟机所在的主机。可选范围为已选定集群或主机池下的主机，若未选择主机池，该选项无效。

  • TopN：磁盘写延迟、磁盘读延迟等数值最高的虚拟机的查询个数（选项包括：5、10，默认值为5）。

  • 统计类型：虚拟机可供查询的存储TopN统计信息（包括：磁盘写延迟、磁盘读延迟、磁盘写请求、磁盘读请求、磁盘I/O吞吐量）。

  • 磁盘写延迟：报表为柱形图，横坐标为虚拟机的名称，纵坐标为虚拟机在最近的一个时间点的磁盘写延迟时间， 按延迟时间从高到低依次从左到右排列。

  • 磁盘读延迟：报表为柱形图，横坐标为虚拟机的名称，纵坐标为虚拟机在最近的一个时间点的磁盘读延迟时间，按延迟时间从高到低依次从左到右排列。

  • 磁盘写请求：报表为柱形图，横坐标为虚拟机的名称，纵坐标为虚拟机在最近的一个时间点的磁盘写请求数，按统计值从高到低依次从左到右排列。

  • 磁盘读请求：报表为柱形图，横坐标为虚拟机的名称，纵坐标为虚拟机在最近的一个时间点的磁盘读请求数，按统计值从高到低依次从左到右排列。

  • 磁盘I/O吞吐量：报表为柱形图，横坐标为虚拟机的名称，纵坐标为虚拟机I/O吞吐量统计，按统计值从高到低依次从左到右排列。


自定义监控

该功能用于操作员自定义监控面板，自定义监控面板可以替换缺省大屏。自定义监控面板以可拖拽控件的形式，向操作员提供了快速自定义监控面板的接口。

注意事项

  • 线性图表中，鼠标沿着线滑动，当鼠标变成 [image] 后，会出现tip提示信息。

  • 线性图表中，当图例名称过长而显示不全时，可以通过在对应颜色的线上，显示tip提示信息查看其全称。

增加自定义监控面板

  1. 单击导航树[监控管理/自定义监控]，进入自定义监控页面。

  2. 单击<增加监控面板>按钮，弹出增加监控面板对话框。

  3. 输入监控面板名称、自定义图标、自定义背景、宽度、高度并选择是否替换缺省大屏后，单击<确定>按钮。关于参数的详细介绍，请参见参数说明。

  4. 在自定义监控页面中，单击新增的监控面板，进入监控面板页面。

  5. 单击<进入设计模式>按钮，设计监控面板。

  6. 在右侧控件区域选中需要添加的面板控件后，用鼠标拖拽到面板视图区中。

  7. 设置面板控件相关参数，并单击<确定>按钮。关于参数的详细介绍，请参见参数说明。若所选面板控件无需设置参数，请忽略此步骤。

  • 需设置相关参数的面板控件包括：自定义虚拟机监控信息、自定义主机监控信息、自定义共享文件系统监控信息、自定义Top5主机监控信息、自定义Top5虚拟机监控信息。

  • 无需设置参数的面板控件包括：系统健康度、主机健康度、CPU分配比、内存分配比、共享存储分配比、系统告警、主机状态统计、虚拟机状态统计。

  8. 面板控件增加完成后，单击<保存>按钮保存设置。

修改自定义监控面板

  1. 单击导航树[监控管理/自定义监控]，进入自定义监控页面。

  2. 单击自定义监控面板上右上角的 [image] 图标，弹出修改监控面板对话框。

  3. 修改面板名称、自定义图标、自定义背景、宽度、高度并选择是否替换缺省大屏后，单击<确定>按钮返回自定义监控页面。关于参数的详细介绍，请参见参数说明。

  4. 单击监控面板，进入监控面板页面。

  5. 单击<进入设计模式>按钮，设计监控面板。

  6. 单击控件右上角的 [image] 图标可删除控件；单击控件右上角的 [image] 图标可修改自定义主机监控控件、自定义虚拟机监控控件、自定义共享文件系统监控控件、自定义Top5主机监控信息和自定义Top5虚拟机监控信息的设置。关于控件相关参数的详细介绍，请参见参数说明。

  7. 面板控件修改完成后，单击<保存>按钮，弹出操作提示对话框。

  8. 单击<确定>按钮，完成自定义监控面板的修改。

  9. 单击<退出设计模式>按钮，并在弹出的对话框中，单击<确定>按钮返回监控面板页面。

克隆自定义监控面板

  1. 单击导航树[监控管理/自定义监控]，进入自定义监控页面。

  2. 单击自定义监控面板右上角的 [image] 图标，弹出克隆监控面板对话框。

  3. 输入克隆后的监控面板名称，单击<确定>按钮。

删除自定义监控面板

  1. 单击导航树[监控管理/自定义监控]，进入自定义监控页面。

  2. 单击自定义监控面板右上角的 [image] 图标，弹出操作确认对话框。

  3. 单击<确定>按钮。

查看自定义监控信息

  1. 单击导航树[监控管理/自定义监控]，进入自定义监控页面。

  2. 单击已创建的监控面板，进入监控面板页面。

  3. 单击<全屏>按钮，可以全屏显示监控图表信息；在浏览器中点击后退按键，可以退出全屏显示。

参数说明

  • 增加/修改自定义监控面板：

  • 监控面板名称：自定义监控面板的名称。

  • 自定义图标：可以上传自定义监控面板的图标。

  • 自定义背景：可以上传自定义监控面板的背景。

  • 宽度：自定义监控的宽度，单位为像素。

  • 高度：自定义监控的高度，单位为像素。

  • 替换缺省大屏：可以选择是否替换缺省大屏，如果选择是，则会将该自定义监控作为概览信息全屏显示页面。

  • 系统健康度：显示CVM健康度，即CVM各主机健康度的平均值。

  • CPU健康度：主机CPU利用率大于80%为0-50分，主机CPU利用率小于80%和大于60%为51-80分，主机CPU利用率小于60%为81-100分。

  • 内存健康度：主机内存利用率大于80%为0-50分，主机内存利用率小于80%和大于60%为51-80分，主机内存利用率小于60%为81-100分。

  • 存储健康度：主机存储利用率大于80%为0-50分，主机存储利用率小于80%和大于60%为51-80分，主机存储利用率小于60%为81-100分。

  • 网络健康度：主机网络吞吐量大于1024Mbps为0-50分，主机网络吞吐量小于1024Mbps和大于500Mbps为51-80分，主机网络吞吐量小于500Mbps为81-100分。

  • 整体健康度：CPU健康度*30%+内存健康度*40%+存储健康度*15%+网络健康度*15%。

  • 主机健康度：显示系统中各个主机的健康度。

  • CPU分配比：

  • 主机CPU总核数：云资源中各主机CPU核数数量总和。

  • 虚拟机CPU总核数：云资源中各虚拟机CPU核数数量总和。

  • CPU分配比例：云资源中主机CPU的利用率，即虚拟机CPU总核数占主机CPU总核数的百分比。

  • 内存分配比：

  • 主机内存总数：云资源中各主机内存容量总和。

  • 虚拟机内存总数：云资源中各虚拟机内存容量总和。

  • 内存分配比例：云资源中主机内存的利用率，即虚拟机内存总数占主机内存总数的百分比。

  • 共享存储分配比：

  • 存储总数：云资源中共享存储容量总和。

  • 可用总数：云资源中共享存储可用容量总和。

  • 存储分配比例：云资源中共享存储使用率，即共享存储使用容量总和占共享存储容量总和的百分比。

  • 系统告警：显示告警管理中每个级别的告警数量。告警级别包括紧急、重要、次要、提示。

  • 主机状态统计：显示当前云资源中主机总数与不同状态的主机数量。主机状态包括正常、异常、维护。

  • 虚拟机状态统计：显示当前云资源中虚拟机总数与不同状态的虚拟机数量。虚拟机状态包括正常、关闭、异常。

  • 自定义主机监控信息：该显示框根据创建面板时设定的指标项显示自定义的主机监控信息。纵轴可以是主机的CPU利用率、内存利用率、I/O吞吐量统计、网络吞吐量统计、磁盘请求、磁盘I/O延迟（趋势图横轴表示时间，以30秒为单位）。

  • 自定义虚拟机监控信息：该显示框根据创建面板时设定的指标项显示自定义的虚拟机监控信息。纵轴可以是虚拟机的CPU利用率、内存利用率、I/O吞吐量统计、网络吞吐量统计、CPU使用情况、磁盘请求、磁盘I/O延迟（趋势图横轴表示时间，以30秒为单位）。

  • 自定义共享文件系统监控信息：该显示框根据创建面板时设定的指标项显示自定义的共享文件系统监控信息。纵轴可以是共享文件系统的I/O吞吐量统计、磁盘请求（趋势图横轴表示时间，以30秒为单位）。

  • 自定义Top5主机监控信息：该显示框根据创建面板时设定的指标项显示自定义的Top5主机监控信息。纵轴可以是主机的CPU利用率、内存利用率。趋势图横轴表示时间，以30秒为单位。

  • 自定义Top5虚拟机监控信息：该显示框根据创建面板时设定的指标项显示自定义的Top5虚拟机监控信息。纵轴可以是虚拟机的CPU利用率、内存利用率。趋势图横轴表示时间，以30秒为单位。


审计日志

审计日志详细记录了所有操作员对CVM的操作，并按照操作类型将所有操作记录分为行为审计，物理资源审计，虚拟资源审计三类，为操作员提供了一种直接的审计手段。

主要功能

  • 行为审计

  • 物理资源审计


行为审计

行为审计用于详细记录所有操作员对CVM所做的包括操作员动作，系统配置和告警管理动作的所有操作，包括操作员登录名、操作员姓名、完成时间、登录的IP地址、操作分类、操作描述、执行结果、失败原因等信息，为操作员提供了一种直接的审计手段。

查看行为审计日志信息

  1. 单击导航树中[监控管理/审计日志/行为审计]菜单项，进入行为审计列表页面。

查询行为审计日志

  1. 单击导航树中[监控管理/审计日志/行为审计]菜单项，进入行为审计列表页面。

  2. 单击<过滤>按钮，弹出过滤查询对话框。

  3. 设置过滤查询参数，单击<确定>按钮。行为审计日志列表中将显示符合过滤条件的日志信息。关于参数的详细介绍，请参见参数说明。

清理行为审计日志

  1. 单击导航树中[监控管理/审计日志/行为审计]菜单项，进入行为审计页面。

  2. 单击<清理>按钮，弹出清理日志对话框。

  3. 单击输入框或者 [image] 图标，在弹出的日历对话框中选择清理操作日志的截止日期。

  4. 单击<确定>按钮。

下载行为审计日志

  1. 单击导航树中[监控管理/审计日志/行为审计]菜单项，进入行为审计列表页面。

  2. 单击<下载>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮，开始下载符合过滤条件的全部行为审计日志信息。

参数说明

  • 时间（从）：查询完成时间在本参数设定日期之后的行为审计日志。操作员可以单击输入框或者 [image] 图标，在弹出的日历对话框中选择查询日期。

  • 时间（至）：查询完成时间在本参数设定日期之前的行为审计日志。操作员可以单击输入框或者 [image] 图标，在弹出的日历对话框中选择查询日期。

  • 登录地址：登录CVM的IP地址。

  • 风险级别：操作执行对应的风险级别，包括高、中、低。

  • 事件类型：操作员所操作事件的类型。

  • 操作分类：操作员所执行操作的分类，包括操作员动作、系统配置、告警管理动作。

  • 清理截止日期：删除截止日期及其之前的所有行为审计日志。不允许清理操作日志保留时长内的日志。关于操作日志保留时长的设置，请参见系统参数设置。


物理资源审计

物理资源审计用于详细记录所有操作员对CVM所做的包括主机池动作，主机动作和数据中心动作等所有操作，包括操作员登录名、操作员姓名、完成时间、登录的IP地址、操作分类、操作描述、执行结果、失败原因等信息，为操作员提供了一种直接的审计手段。

查看物理资源审计日志信息

  1. 单击导航树中[监控管理/审计日志/物理资源审计]菜单项，进入物理资源审计日志列表页面。

查询物理资源审计日志

  1. 单击导航树中[监控管理/审计日志/物理资源审计]菜单项，进入物理资源审计页面。

  2. 单击<过滤>按钮，弹出过滤查询对话框。

  3. 设置过滤查询参数，单击<确定>按钮。物理资源审计日志列表中将显示符合过滤条件的日志信息。关于参数的详细介绍，请参见参数说明。

清理物理资源审计日志

  1. 单击导航树中[监控管理/审计日志/物理资源审计]菜单项，进入物理资源审计日志列表页面。

  2. 单击<清理>按钮，弹出清理日志对话框。

  3. 单击输入框或者 [image] 图标，在弹出的日历对话框中选择清理操作日志的截止日期。

  4. 单击<确定>按钮。

下载物理资源审计日志

  1. 单击导航树中[监控管理/审计日志/物理资源审计]菜单项，进入物理资源审计日志列表页面。

  2. 单击<下载>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮，开始下载符合过滤条件的全部物理资源审计日志信息。

参数说明

  • 完成时间：操作员完成操作的时间。

  • 操作分类：操作员所执行操作的分类，包括数据中心动作、主机池动作、主机动作、存储动作、网络动作、集群动作、虚拟存储动作、存储适配器动作、命令行动作。

  • 操作对象：操作所执行的对象。

  • 失败原因：操作执行失败的原因。

  • 风险级别：操作执行对应的风险级别，包括高、中、低。

  • 事件类型：操作员所操作事件的类型。

  • 登录名：操作员登录CVM使用的帐号。

  • 操作员姓名：操作员的姓名。

  • 时间（从）：查询完成时间在本参数设定日期之后的物理资源审计日志。操作员可以单击输入框或者 [image] 图标，在弹出的日历对话框中选择查询日期。

  • 时间（至）：查询完成时间在本参数设定日期之前的物理资源审计日志。操作员可以单击输入框或者 [image] 图标，在弹出的日历对话框中选择查询日期。

  • 执行结果：操作的执行结果，包括成功、失败、部分成功。

  • 清理截止日期：删除截止日期及其之前的所有物理资源审计日志。不允许清理操作日志保留时长内的日志。关于操作日志保留时长的设置，请参见系统参数设置。


虚拟资源审计

虚拟资源审计用于详细记录所有操作员对CVM所做的包括虚拟机动作，模板动作和云彩红动作等所有操作，包括操作员登录名、操作员姓名、完成时间、登录的IP地址、操作分类、操作描述、执行结果、失败原因等信息，为操作员提供了一种直接的审计手段。

查看虚拟资源审计日志信息

  1. 单击导航树中[监控管理/审计日志/虚拟资源审计]菜单项，进入虚拟资源审计日志列表页面。

查询虚拟资源审计日志

  1. 单击导航树中[监控管理/审计日志/虚拟资源审计]菜单项，进入虚拟资源审计页面。

  2. 单击<过滤>按钮，弹出过滤查询对话框。

  3. 设置过滤查询参数，单击<确定>按钮。虚拟资源审计日志列表中将显示符合过滤条件的日志信息。关于参数的详细介绍，请参见参数说明。

清理虚拟资源审计日志

  1. 单击导航树中[监控管理/审计日志/虚拟资源审计]菜单项，进入虚拟资源审计页面。

  2. 单击<清理>按钮，弹出清理日志对话框。

  3. 单击输入框或者 [image] 图标，在弹出的日历对话框中选择清理操作日志的截止日期。

  4. 单击<确定>按钮。

下载虚拟资源审计日志

  1. 单击导航树中[监控管理/审计日志/虚拟资源审计]菜单项，进入虚拟资源审计页面。

  2. 单击<下载>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮，开始下载符合过滤条件的全部虚拟资源审计日志信息。

参数说明

  • 完成时间：操作员完成操作的时间。

  • 操作分类：操作员所执行操作的分类，包括虚拟机动作、模板动作、备份动作、恢复动作、动态资源业务扩展动作、站点容灾动作、CVM动作、云彩虹动作。

  • 操作对象：操作所执行的对象。

  • 执行结果：操作的执行结果，包括成功、失败、部分成功。

  • 失败原因：操作执行失败的原因。

  • 风险级别：操作执行对应的风险级别，包括高、中、低。

  • 事件类型：操作员所操作事件的类型。

  • 时间（从）：查询完成时间在本参数设定日期之后的虚拟资源审计日志。操作员可以单击输入框或者 [image] 图标，在弹出的日历对话框中选择查询日期。

  • 时间（至）：查询完成时间在本参数设定日期之前的虚拟资源审计日志。操作员可以单击输入框或者 [image] 图标，在弹出的日历对话框中选择查询日期。

  • 清理截止日期：删除截止日期及其之前的所有虚拟资源审计日志。不允许清理操作日志保留时长内的日志。关于操作日志保留时长的设置，请参见系统参数设置。


告警管理

告警管理功能用于统计和查看操作员需要关注的告警信息。目前，CVM统计的告警信息的类型包括主机资源告警、虚拟机资源告警、集群资源告警、故障告警、安全告警、其他异常告警和ONEStor资源告警。

主要功能

  • 实时告警

  • 告警阈值配置

  • 告警屏蔽配置


实时告警

实时告警页面按照告警产生时间展示了系统最近一段时间内产生的告警。

注意事项

默认情况下，实时告警信息的刷新频率为10秒。系统在达到刷新时间间隔所设置的时间后，将自动刷新实时告警信息列表中显示信息。若刷新时间间隔设置较短，操作员将没有充足的时间进行确认操作。例如：当有一条或多条告警信息已选择但未进行确认时，在定时刷新后操作员需要重新选择，才能完成确认操作。因此，为了方便操作员完成告警信息确认操作，可以更改刷新时间间隔。

查询实时告警信息

  1. 单击导航树中[告警管理/实时告警]菜单项，进入实时告警列表页面。

  2. 单击<过滤>，弹出过滤对话框。

  3. 设置过滤查询参数，单击<确定>按钮。实时告警列表中将显示符合过滤条件的告警信息。关于参数的详细介绍，请参见参数说明。

屏蔽实时告警

  1. 单击导航树中[告警管理/实时告警]菜单项，进入实时告警列表页面。

  2. 选择待屏蔽的告警信息，单击<屏蔽>按钮，弹出屏蔽告警对话框。

  3. 输入屏蔽描述，单击<确定>按钮。

查看告警详细信息

  1. 单击导航树中[告警管理/实时告警]菜单项，进入实时告警列表页面。

  2. 选择待查看的告警信息，单击告警信息列，弹出查看告警详细信息对话框。

确认实时告警

该功能用于确认指定的告警信息，从而改变告警的确认状态。告警的确认状态是判断某告警信息是否已经被操作员处理过的一种标识。通过查看告警的确认状态，区分未处理的告警和已处理的告警。

  1. 单击导航树中[告警管理/实时告警]菜单项，进入实时告警列表页面。

  2. 选择待确认的告警信息，单击<确认>按钮完成操作。

删除实时告警

  1. 单击导航树中[告警管理/实时告警]菜单项，进入实时告警列表页面。

  2. 选择待删除的告警信息，单击<删除>按钮，弹出确认对话框。

  3. 单击<确定>按钮。

编辑告警维护经验

  1. 单击导航树中[告警管理/实时告警]菜单项，进入实时告警列表页面。

  2. 选择待编辑维护经验的告警，单击告警信息列，弹出查看告警详细信息对话框。

  3. 单击<编辑维护经验>按钮，弹出编辑维护经验对话框。

  4. 编辑告警问题的维护经验，单击<确定>按钮。

一键清理告警

  1. 单击导航树中[告警管理/实时告警]菜单项，进入实时告警列表页面。

  2. 单击<一键清理>按钮，弹出一键清理对话框。

  3. 选择告警信息的确认状态、告警级别、类型、开始时间和截止时间。

  4. 单击<确定>按钮。

参数说明

  • 刷新时间间隔：实时告警信息列表中显示信息的自动刷新时间间隔，包括：5秒、10秒、30秒、1分钟、5分钟，默认值为10秒。

  • 确认状态：告警的确认状态，用来标识告警是否被处理，包括所有状态、已确认、未确认，默认为所有状态。

  • 告警级别：告警的级别，包括所有级别、紧急、重要、次要、提示，默认为所有级别。

  • 类型：告警的类型，包括所有类型、主机资源告警、虚拟机资源告警、集群资源告警、故障告警、安全告警、其他异常告警和ONEStor资源告警，默认为所有类型。

  • 告警状态：告警的确认状态，包括已确认、未确认。

  • 告警来源：告警的来源设备信息，显示内容为设备类型、设备名称和管理IP地址。

  • 最新告警时间：告警最近一次上报的时间。

  • 首次告警时间：告警第一次上报的时间。

  • 重复次数：告警上报重复次数。

  • 告警原因：告警的产生原因。告警原因是系统预定义的，不可修改，同一类型的告警，此处显示信息相同。

  • 恢复建议：修复告警的建议。恢复建议是系统预定义的，不可修改，同一类型的告警，此处显示信息相同。

  • 维护经验：维护告警的经验，由操作员记录告警问题的解决方法，方便以后处理同类告警问题。同一类型的告警，此处显示信息相同。


告警阈值配置

告警阈值指的是触发告警的最低值，当主机、虚拟机、集群的CPU利用率、内存利用率、磁盘利用率或主机、虚拟机的磁盘吞吐量、网络吞吐量等达到预设值的阈值时，触发相应告警。告警阈值配置提供了查看预定义告警阈值信息、配置告警服务器的IP地址、修改指定告警阈值的配置信息和启用/禁用告警配置等功能。

注意事项

  • 系统默认将当前CVM主机的IP作为告警服务器的IP地址。双机环境（包括Master和Slave状态的CVM主机）下，默认将处于Master状态的CVM主机的IP作为告警的IP地址。

  • 删除告警服务器IP地址时，至少保留一个IP，IP地址列表不能为空。

  • 选中的告警阈值配置项必须配置完成，否则无法启动。

查看告警阈值配置信息

  1. 单击导航树中[告警管理/告警阈值配置]菜单项，进入告警阈值配置列表页面。

告警服务器配置

  1. 单击导航树中[告警管理/告警阈值配置]菜单项，进入告警阈值配置列表页面。

  2. 单击<告警服务器配置>按钮，弹出第三方告警服务器配置对话框。

  3. 输入告警服务器的IP地址，单击 [image] 图标，将该IP地址增加到下方的告警服务器列表。

  4. 单击<确定>按钮，完成告警服务器的配置。

修改告警阈值配置

  1. 单击导航树中[告警管理/告警阈值配置]菜单项，进入告警阈值配置列表页面。

  2. 单击告警指标项对应的操作列 [image] 图标，弹出修改告警阈值对话框。

  3. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  4. 单击<确定>按钮完成操作。

启用/禁用告警阈值

  1. 单击导航树中[告警管理/告警阈值配置]菜单项，进入告警阈值配置列表页面。

  2. 单击告警指标项对应的操作列 [image] 或者 [image] 图标，完成告警阈值的启用或者禁用。

批量启用/禁用告警阈值

  1. 单击导航树中[告警管理/告警阈值配置]菜单项，进入告警阈值配置列表页面。

  2. 选择一个或多个告警阈值指标，单击<批量操作>按钮，选择[批量启动指标]或者[批量禁用指标]菜单项，弹出批量启动或者禁用告警阈值确认对话框。

  3. 单击<确定>按钮完成操作。

参数说明

  • 指标项：告警监测指标名称。

  • 紧急告警：触发紧急告警的最低值。

  • 重要告警：触发重要告警的最低值。

  • 次要告警：触发次要告警的最低值。

  • 提示告警：触发提示告警的最低值。

  • 持续时间：告警指标项持续超过所设置阈值的时间。一旦超过该时间，则触发告警。当告警为主机资源告警、虚拟机资源告警、集群资源告警时，需配置此参数。

  • 告警上报间隔：故障持续发生时，同一对象的同一种告警连续上报的时间间隔，默认为1分钟。当告警为主机资源告警、虚拟机资源告警、集群资源告警、故障告警时，需配置此参数。

  • 状态：告警阈值的状态，包括启用、禁用。

  • 操作：以图标的形式显示操作员可执行的操作。

  • 表示启用告警阈值；

  • 表示禁用告警阈值；

  • 表示修改告警阈值。

  • 告警类别：告警阈值的类别，包括紧急告警、重要告警、次要告警、提示告警。若为主机资源告警、虚拟机资源告警、集群资源告警，选择某一告警类别后，需输入该指标项利用率的百分比。


告警屏蔽配置

告警屏蔽配置管理可以将无需关注的告警加入到屏蔽配置列表中。加入屏蔽配置列表中的告警将不再上报，也不显示在实时告警列表中。

查看告警阈值配置

  1. 单击导航树中[告警管理/告警屏蔽配置]菜单项，进入告警屏蔽配置列表页面。

  2. 在告警屏蔽配置列表中，单击告警屏蔽配置对应的指标项，弹出查看告警阈值对话框。

查询告警屏蔽配置信息

  1. 单击导航树中[告警管理/告警屏蔽配置]菜单项，进入告警屏蔽配置列表页面。

  2. 单击<过滤>按钮，弹出过滤对话框。

  3. 设置过滤查询参数，单击<确定>按钮。告警屏蔽配置列表中将显示符合过滤条件的告警屏蔽配置信息。关于参数的详细介绍，请参见参数说明。

增加告警屏蔽配置

  1. 单击导航树中[告警管理/告警屏蔽配置]菜单项，进入告警屏蔽配置列表页面。

  2. 单击<增加>按钮，弹出增加告警屏蔽配置对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 设置完成后，单击<确定>按钮。

删除告警屏蔽配置

  1. 单击导航树中[告警管理/告警屏蔽配置]菜单项，进入告警屏蔽配置列表页面。

  2. 选择待删除的告警屏蔽配置，单击<删除>按钮或者单击对应操作列的 [image] 图标，弹出操作确认对话框。

  3. 单击<确定>按钮。

参数说明

  • 告警级别：告警的级别，包括紧急告警、重要告警、次要告警、提示告警。当告警类型为故障告警、其他异常告警时，才显示此参数。

  • 紧急告警：触发紧急告警的最低值。当告警类型为主机资源告警、虚拟机资源告警、集群资源告警时，才显示此参数。

  • 重要告警：触发重要告警的最低值。当告警类型为主机资源告警、虚拟机资源告警、集群资源告警时，才显示此参数。

  • 次要告警：触发次要告警的最低值。当告警类型为主机资源告警、虚拟机资源告警、集群资源告警时，才显示此参数。

  • 提示告警：触发提示告警的最低值。当告警类型为主机资源告警、虚拟机资源告警、集群资源告警时，才显示此参数。

  • 持续时间：告警指标项持续超过所设置阈值的时间。一旦超过该时间，则触发告警。当告警类型为主机资源告警、虚拟机资源告警、集群资源告警时，才显示此参数。

  • 告警上报间隔：故障持续发生时，同一对象的同一种告警连续上报的时间间隔，默认为1分钟。当告警为主机资源告警、虚拟机资源告警、集群资源告警、故障告警时，才显示此参数。

  • 状态：告警阈值当前的状态，包括启用、禁用。

  • 告警类型：告警的类型，包括所有类型、主机资源告警、虚拟机资源告警、集群资源告警、故障告警、其他异常告警，默认为所有类型。

  • 告警指标项：告警监测指标名称。

  • 对象名称：告警屏蔽配置作用对象的名称。


告警通知

告警通知管理可设置告警以邮件和短信方式通知用户。

主要功能

  • 告警邮件通知


告警邮件通知

该功能用于配置告警邮件通知。告警邮件通知是指将指定的告警信息以邮件方式发送给用户。

注意事项

要使告警邮件通知生效，还需在邮件服务器设置中完成邮件服务器的相关设置。

操作步骤

  1. 单击导航树中[告警管理/告警通知]菜单项，进入告警邮件通知设置页面。

  2. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  3. 设置完成后，单击<邮件配置>按钮，在弹出的对话框中设置邮件服务器相关参数。关于参数的详细介绍，请参见参数说明。

  4. 邮件服务器设置完成后，单击<保存>按钮返回告警邮件通知页面。

  5. 单击<邮件测试>按钮验证告警邮件通知配置是否正确。

  6. 单击<保存>按钮，完成告警邮件通知配置。

参数说明

  • 通知方式：支持“统一发送”和“分组发送”。

  • 统一发送：将所有告警发送到指定的“目的邮件地址”。

  • 分组发送：将告警信息发送到告警对象所属操作员分组中所有操作员的邮箱。请确保操作员已正确配置“E-mail”，否则不能接收到告警邮件。

  • 目的邮件地址：接收告警通知的邮件地址。通过单击 [image] 图标和 [image] 图标可以对目的邮件地址列表进行新增和删除操作。仅通知方式选择“统一发送”时需要配置此参数。

  • 需关注的告警级别：需要关注的告警级别，包括紧急、重要、次要、提示。

  • 需关注的告警：需要关注的告警，包括所有告警、选定告警。默认为所有告警。

  • 需关注的指标项：需要关注的主机或虚拟机的告警信息。

  • 服务器地址：SMTP邮件服务器的域名或者IP地址。

  • 端口号：连接SMTP邮件服务器的TCP端口号，默认为25。

  • 服务器要求身份验证：设置SMTP服务器是否需要对发件人进行身份验证。默认为不需要身份验证。

  • 用户名：连接SMTP服务器的用户账号。当开启“服务器要求身份验证”设置时，需要输入该参数。

  • 密码：连接SMTP服务器的用户密码。当开启“服务器要求身份验证”设置时，需要输入该参数。

  • 发件人姓名：发送SMTP邮件的用户姓名。

  • 发件人邮箱地址：发送SMTP邮件的用户邮箱地址。


告警短信通知

该功能用于配置告警短信通知。告警短信通知是指将指定的告警信息以短信方式发送给用户。

注意事项

要使告警短信通知生效，还需在短信配置中启用短信通知并完成相关设置。

操作步骤

  1. 单击导航树中[告警管理/告警通知]菜单项，选择“告警短信通知”页签，进入告警短信通知设置页面。

  2. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  3. 设置完成后，单击<短信配置>按钮，在弹出的对话框中启用短信通知，并设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 短信配置完成后，单击<保存>按钮返回告警短信通知页面。

  5. 单击<短信测试>按钮验证告警短信通知配置是否正确。

  6. 单击<保存>按钮，完成告警短信通知的设置操作。

参数说明

  • 通知方式：支持“统一发送”和“分组发送”。

  • 统一发送：将所有告警发送到指定的“接收短信电话”。

  • 分组发送：将告警信息发送到告警对象所属操作员分组中所有操作员的邮箱。请确保操作员已正确配置“电话”，否则不能接收到告警短信。

  • 接收短信电话：接收告警通知短信的电话。通过单击 [image] 图标和 [image] 图标可以对电话列表进行新增和删除操作。仅通知方式选择“统一发送”时需要配置此参数。

  • 需关注的告警级别：需要关注的告警级别，包括紧急、重要、次要、提示。

  • 需关注的告警：需要关注的告警，包括所有告警、选定告警。若选择“选定告警”，则需要通过单击 [image] 图标和 [image] 图标对需关注的告警阈值进行增加和删除。

  • 需关注的指标项：需要关注的主机或虚拟机的告警信息。


虚拟化拓扑

操作员通过虚拟化拓扑管理功能，可以实时掌握计算资源、网络资源、存储资源的分布关系及运行情况信息。虚拟化拓扑包括计算拓扑、网络拓扑、存储拓扑三种拓扑。

主要功能

  • 查看计算拓扑

  • 查看网络拓扑


查看计算拓扑

计算拓扑体现了集群与物理主机、物理主机与虚拟机的隶属关系，可以清晰地查看整个虚拟数据中心的主机、虚拟机的告警信息，以及每个集群的CPU、内存和共享存储容量的利用情况信息。

操作步骤

  1. 单击导航树中[虚拟化拓扑/计算拓扑]菜单项，进入计算拓扑信息页面。

参数说明

  • 顶部工具条：

  • 箭头 [image] ：鼠标默认为该模式，在该模式下，可以选中拓扑中的图例进行拖拽。

  • 放大镜 [image] ：选中该模式可对目标区域进行局部放大。

  • 手 [image] ：当拓扑在窗口范围内显示不完整时，可以通过拖拽移动拓扑的位置来查看无法显示的部分。

  • 图片 [image] ：将拓扑图生成图片，如需保存，可以右键单击图片，选择“图片另存为”进行保存。

  • 图例 [image] ：显示拓扑中图标的名称及其含义。

  • 保存 [image] ：保存拓扑图当前状态。

  • 重置 [image] ：将修改后的拓扑图重置为修改前的状态。

  • 搜索输入框：选中时会在右边显示搜索输入框，可根据节点名称快速定位节点。

  • 鹰眼视图：选中时会在右下角显示整个拓扑图的缩略图。

  • 显示关闭虚拟机：选中时拓扑图中会显示出处于运行和关闭状态的虚拟机，去勾选则只显示处于运行状态的虚拟机。

  • 主机池节点：双击拓扑图中的 [image] 图标可以进入主机池概要信息页面。

  • 集群节点：双击拓扑图中的 [image] 图标可以进入集群概要信息页面。单击该节点图标，会显示集群详细信息面板。

  • HA：集群是否开启了HA功能，包括已启用、已关闭。

  • 计算资源DRS：集群是否开启了计算资源动态资源调度功能，包括已启用、已关闭。

  • 存储资源DRS：集群是否开启了存储资源动态资源调度功能，包括已启用、已关闭。

  • 主机数量：集群中主机的数量。

  • 虚拟机数量：集群中虚拟机的数量，包括处于运行状态虚拟机的数量、处于关闭状态虚拟机的数量。

  • 总CPU核数：集群中主机CPU核数的总和。

  • CPU分配比例：集群中分配给虚拟机的CPU核数与主机CPU总核数的比例。

  • 总内存大小：集群中所有主机内存的总和。

  • 内存分配比例：集群中分配给虚拟机的内存大小与主机内存总和的比例。

  • 本地总存储：集群中主机的本地存储总大小。

  • 本地总可用存储：集群中主机上可用的本地存储总大小。

  • 主机节点：双击拓扑图中的 [image] 图标可以进入主机概要信息页面，单击该节点图标，会显示主机详细信息面板。

  • 主机：主机名称。

  • 型号：主机的型号信息。

  • CPU数量：主机CPU的核数。

  • CPU型号：主机CPU的型号信息。

  • 内存：主机内存大小。

  • 管理IP：主机的管理IP地址。

  • 虚拟机数量：主机上的虚拟机数量，包括处于运行状态虚拟机的数量、处于关闭状态虚拟机的数量。

  • CPU利用率：主机的实时CPU利用率。

  • 内存利用率：主机的实时内存利用率。

  • 版本：主机的Hypervisor版本。

  • 状态：主机当前的状态，包括正常、异常、告警。

  • 告警信息：当主机有告警信息时，显示关于该主机的告警信息。

  • 虚拟机节点：双击该节点可以进入虚拟机管理界面，单击该节点图标，会显示虚拟机详细信息面板。

  • 虚拟机：虚拟机显示的名称。

  • 状态：虚拟机当前运行状态，包括运行、暂停、关闭、未知、HA异常。

  • 操作系统：虚拟机的操作系统。

  • vCPU：虚拟机CPU的总核数（即CPU个数与每个CPU核数的乘积。

  • 内存：虚拟机内存的容量。

  • 磁盘：虚拟机磁盘的容量。

  • CPU利用率：虚拟机一小时内的平均CPU利用率。

  • 内存利用率：虚拟机一小时内的平均内存利用率。

  • 磁盘利用率：虚拟机当前的磁盘利用率。

  • 网络：虚拟机的MAC地址和IP地址。

  • 告警信息：当虚拟机有告警信息时，显示关于该虚拟机的告警信息。


查看网络拓扑

以虚拟交换机为核心，查看虚拟交换机与虚拟机的网络连接关系，以及虚拟机vNIC端口的网络策略与流量监控数据。

操作步骤

  1. 单击导航树中[虚拟化拓扑/网络拓扑]菜单项，进入网络拓扑信息页面。

参数说明

  • 顶部工具条：

  • 箭头 [image] ：鼠标默认为该模式，在该模式下，可以选中拓扑中的图例进行拖拽。

  • 放大镜 [image] ：选中该模式可对目标区域进行局部放大。

  • 手 [image] ：当拓扑在窗口范围内显示不完整时，可以通过拖拽移动拓扑的位置来查看无法显示的部分。

  • 图片 [image] ：将拓扑图生成图片，如需保存，可以右键单击图片，选择“图片另存为”进行保存。

  • 图例 [image] ：显示拓扑中图标的名称及其含义。

  • 保存 [image] ：保存拓扑图当前状态。

  • 重置 [image] ：将修改后的拓扑图重置为修改前的状态。

  • 搜索输入框：选中时会在右边显示搜索输入框，可根据节点名称快速定位节点。

  • 鹰眼视图：选中时会在右下角显示整个拓扑图的缩略图。

  • 虚拟交换机：单击虚拟交换机图标时，会显示虚拟交换机的详细信息；双击虚拟交换机图标，可以跳转至对应主机的虚拟交换机页面。

  • 网卡：双击网卡图标，可以跳转至对应主机“物理网卡”页签。

  • 虚拟机名称：虚拟机显示的名称。

  • 虚拟端口名：虚拟机的虚拟端口名称。

  • MAC：虚拟机的MAC地址。

  • VLAN：虚拟机网卡所在VLAN的ID。

  • IP：虚拟机的IP地址。

  • 接收报文数：虚拟机的虚拟端口接收到的报文数。

  • 接收字节数：虚拟机的虚拟端口接收到的字节数。

  • 发送报文数：虚拟机的虚拟端口发送的报文数。

  • 发送字节数：虚拟机的虚拟端口发送的字节数。


查看存储拓扑

以存储为核心，查看物理主机与存储的连接关系、以及存储与虚拟机的连接关系。

操作步骤

  1. 单击导航树中[虚拟化拓扑/存储拓扑]菜单项，进入存储拓扑信息页面。

参数说明

  • 顶部工具条：

  • 箭头 [image] ：鼠标默认为该模式，在该模式下，可以选中拓扑中的图例进行拖拽。

  • 放大镜 [image] ：选中该模式可对目标区域进行局部放大。

  • 手 [image] ：当拓扑在窗口范围内显示不完整时，可以通过拖拽移动拓扑的位置来查看无法显示的部分。

  • 图片 [image] ：将拓扑图生成图片，如需保存，可以右键单击图片，选择“图片另存为”进行保存。

  • 图例 [image] ：显示拓扑中图标的名称及其含义。

  • 保存 [image] ：保存拓扑图当前状态。

  • 重置 [image] ：将修改后的拓扑图重置为修改前的状态。

  • 搜索输入框：选中时会在右边显示搜索输入框，可根据节点名称快速定位节点。

  • 鹰眼视图：选中时会在右下角显示整个拓扑图的缩略图。

  • 存储节点：单击该节点图标，会显示详细信息面板。

  • 名称：存储名称。

  • 类型：存储的文件系统类型，包括本地文件目录、本地文件目录（高速）、LVM逻辑存储卷、iSCSI网络存储、NFS网络文件系统、共享文件系统、Windows系统共享目录。

  • 目标路径：目的主机上存储池使用的本地目录挂载点，例如：/vms/images。

  • 容量：存储的大小。

  • 已用容量：当前已用的存储容量。

  • 空闲容量：当前可用的存储容量。

  • IP地址：访问共享存储的IP地址。

  • NAA：共享存储的NAA信息。

  • LUN：共享存储的LUN信息。

  • 利用率：共享存储当前的利用率。


系统管理

ARM架构主机暂不支持管理平台联动资源。

系统管理用于管理系统操作员、系统任务、操作日志、系统参数、双机热备管理、管理平台联动资源和License。

  • 操作员及分组管理：用于管理操作员、操作员分组和在线操作员。

  • 任务管理：统一管理系统任务。

  • 操作日志管理：用于快速查询操作日志，收集和下载CVM和CVM所管理的主机的日志文件。

  • 系统参数管理：配置系统全局参数、邮件服务器、认证服务器、短信配置。

  • 双机热备管理：用于搭建CVM管理平台的双机热备环境以及对CVM主机的管理。

  • 管理平台联动资源管理：实现不同管理系统间的配置同步。

  • License管理：提供License的申请和注册。


操作员及分组管理

操作员及分组管理用于管理系统中的操作员、操作员分组和在线操作员。

主要功能

  • 操作员管理

  • 操作员分组管理


操作员管理

操作员是指CVM的管理员。操作员登录CVM时必须通过身份认证。身份认证方式包括密码认证和LDAP认证。认证成功的操作员才能登录CVM，并且只能使用与自身访问权限对应的功能。

操作员管理功能主要包括增加、修改、删除、查询操作员、查看操作员的详细信息，以及查看操作员已授权的资源。

注意事项

  • 默认情况下，对于连续三次登录失败的操作员，系统将锁定该操作员所在客户端的IP地址，锁定时长为一分钟，即一分钟内禁止任何操作员通过该IP地址再次访问系统。操作员可在系统参数设置中，修改登录尝试最大次数和登录失败锁定时长。

  • 操作员的实际权限为所属操作员分组的权限与操作员特有权限的并集。

  • 对于已登录CVM的操作员，如果修改该操作员的属性，将不会影响其在CVM中的操作，直至该操作员重新登录。修改已登录CVM的操作员，将不影响该操作员在CVM中的操作，直至下次登录成功；删除已登录CVM的操作员，将导致该操作员不能继续使用CVM。

  • admin操作员即超级管理员，拥有所有权限。该操作员在安装系统时自动创建，不允许删除。

增加操作员

  1. 单击导航树中[系统管理/操作员管理/操作员]菜单项，进入操作员列表页面。

  2. 单击<增加操作员>按钮，弹出增加操作员对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 参数设置完成后，单击<完成>按钮。

修改操作员

  1. 单击导航树中[系统管理/操作员管理/操作员]菜单项，进入操作员列表页面。

  2. 选中待修改的操作员，单击<修改操作员>按钮，弹出修改操作员对话框。

  3. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  4. 修改完成后，单击<完成>按钮。

删除操作员

  1. 单击导航树中[系统管理/操作员管理/操作员]菜单项，进入操作员列表页面。

  2. 选中待删除的一个或者多个操作员，单击<删除操作员>按钮，弹出删除操作员确认对话框。

  3. 单击<确定>按钮。

查询操作员

  1. 单击导航树中[系统管理/操作员管理/操作员]菜单项，进入操作员列表页面。

  2. 单击<过滤>按钮，弹出过滤查询对话框。

  3. 设置过滤查询参数，单击<确定>按钮。操作员列表中将显示符合过滤条件的操作员信息。

查看操作员详细信息

  1. 单击导航树中[系统管理/操作员管理/操作员]菜单项，进入操作员列表页面。

  2. 选中待查看的操作员，单击<查看操作员信息>按钮，弹出查看操作员信息对话框。

查看已授权资源

当“资源授权类型”为集群、主机或虚拟机时，可通过该页面统一查看操作员已授权的资源。

若需要修改已授权资源，请通过“修改操作员”进行修改。

  1. 单击导航树中[系统管理/操作员管理/操作员]菜单项，进入操作员列表页面。

  2. 选中待查看授权资源的操作员。

  3. 在下方已授权资源列表中，查看操作员的已授权资源。

  • 集群页签，当操作员的“资源授权类型”为“集群”时，此页签展示操作员已授权的集群。

  • 主机页签，当操作员的“资源授权类型”为“主机”时，此页签展示操作员已授权的主机。

  • 虚拟机页签，当操作员的“资源授权类型”为“虚拟机”时，此页签展示操作员已授权的虚拟机。

参数说明

  • 登录名：操作员登录CVM使用的帐号。

  • 认证方式：操作员登录CVM使用的身份认证方式，包括密码认证和LDAP认证，默认为密码认证。

  • 密码认证：根据操作员帐号和密码组合进行本地认证。

  • LDAP认证：根据操作员帐号和密码组合进行LDAP服务器认证。LDAP服务器的配置，请参见认证服务器设置。

  • 密码：操作员通过密码认证方式登录系统时，所使用的密码。填写密码时必须遵守密码策略。

  • 确认密码：必须与登录密码完全一致。

  • 操作员分组：操作员所属的分组，选项包括当前登录操作员可管理的全部操作员分组。

  • 资源授权类型：操作员所具有的数据资源权限。

  • 当资源授权类型为所有资源时，则在权限设置页面选择操作员的操作权限。

  • 当资源授权类型为集群、主机或虚拟机时，则在权限设置页面选择操作员即将拥有管理权限的集群、主机或虚拟机，操作权限由操作员所在分组决定。

  • E-mail：操作员的E-Mail邮箱。E-Mail邮箱地址必须符合标准规范，形如account@domain.com。若需要使用“分组发送”接收告警邮件通知，请确保该E-mail邮箱地址正确，否则不能接收到告警邮件。

  • 电话：操作员的手机号码。手机号码必须符合标准规范。若需要使用“分组发送”接收告警短信通知，请确保该电话正确，否则不能接收到告警短信。

  • 访问策略：操作员访问CVM的策略。对于引用访问策略的操作员，系统将根据访问策略的配置允许或限制该操作员登录系统。

  • 在线数量：系统允许操作员使用此账号同时登录的最大数量，默认为0，表示不作限制。

  • 禁用操作员：禁止操作员登录系统。

  • 操作员权限：操作员特有的操作权限。操作员的实际权限为所属操作员分组的权限与其特有权限的并集。


操作员分组管理

操作员分组是多个操作员的集合，每一个分组又可以配置多级子分组。不同的子分组可以具有不同的访问权限。

不同分组/子分组的操作员登录到CVM之后，默认只能查看和操作本分组/子分组内的资源。

注意事项

  • 系统管理员组和安全审计分组为系统默认分组，不允许被删除，且安全审计员组下不允许增加子分组。

  • 若某个操作员分组存在子分组，则删除该分组前，请先删除其子分组。

增加操作员分组

  1. 单击导航树中[系统管理/操作员管理/操作员分组]菜单项，进入操作员分组列表页面。

  2. 单击<增加分组>按钮，弹出增加分组对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 参数设置完成后，单击<完成>按钮。

增加操作员子分组

  1. 单击导航树中[系统管理/操作员管理/操作员分组]菜单项，进入操作员分组列表页面。

  2. 对于父分组，单击操作员分组对应的操作列 [image] 图标，弹出增加子分组对话框；对于子分组，单击父分组名称前的 [image] 图标展开其子分组，单击操作员子分组对应的操作列 [image] 图标，弹出增加子分组对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 参数设置完成后，单击<完成>按钮。

修改操作员分组/子分组

  1. 单击导航树中[系统管理/操作员管理/操作员分组]菜单项，进入操作员分组列表页面。

  2. 对于父分组，单击操作员分组对应的操作列 [image] 图标，弹出修改分组对话框；对于子分组，单击父分组名称前的 [image] 图标展开其子分组，单击操作员子分组对应的操作列 [image] 图标，弹出修改分组对话框。

  3. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  4. 修改完成后，单击<完成>按钮。

删除操作员分组/子分组

  1. 单击导航树中[系统管理/操作员管理/操作员分组]菜单项，进入操作员分组列表页面。

  2. 对于父分组，单击操作员分组对应的操作列 [image] 图标，弹出删除操作员分组确认对话框；对于子分组，单击父分组名称前的 [image] 图标展开其子分组，单击操作员子分组对应的操作列 [image] 图标，弹出删除分组确认对话框。

  3. 单击<确定>按钮。

查看操作员分组详细信息

  1. 单击导航树中[系统管理/操作员管理/操作员分组]菜单项，进入操作员分组列表页面。

  2. 对于父分组，单击操作员分组对应的操作列 [image] 图标，弹出查看操作员分组对话框；对于子分组，单击父分组名称前的 [image] 图标展开其子分组，单击操作员子分组对应的操作列 [image] 图标，弹出查看分组信息对话框。

参数说明

  • 分组名：操作员分组的名称。

  • 允许管理子分组：是否允许操作员对所属分组的全部子分组数据进行管理。默认为不允许。

  • 分组权限：操作员分组的操作权限。默认操作权限为查看各部分被管理资源。


在线操作员管理

在线操作员管理用于对当前登录CVM的操作员进行快速查询和强制下线。

注意事项

当前操作员具有立即下线的操作权限时，才能执行立即下线在线操作员操作。

查询在线操作员

  1. 单击导航树中[系统管理/操作员管理/在线操作员]菜单项，进入在线操作员列表页面。

  2. 单击<过滤>按钮，弹出过滤查询对话框。

  3. 设置过滤查询参数后，单击<确定>按钮。在线操作员列表中将显示符合过滤条件的在线操作员信息。关于参数的详细介绍，请参见参数说明。

立即下线操作员

  1. 单击导航树中[系统管理/操作员管理/在线操作员]菜单项，进入在线操作员列表页面。

  2. 选中待立即下线的操作员，单击<立即下线>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮。

参数说明

  • 登录名：操作员登录CVM使用的帐号。

  • 操作员姓名：操作员的名称。

  • 操作员分组：操作员所属的操作员分组。

  • 登录时间：操作员登录CVM的开始时间。

  • 登录地址：操作员登录CVM所使用的计算机IP地址。

  • 会话ID：操作员登录CVM的会话编号。


任务管理

任务管理用于管理系统中所有主机自动发现任务。启用主机自动发现任务后，系统将自动搜索可添加的主机并将其添加到任务所属的集群下。默认一个集群只能添加一个主机自动发现任务。通过一个主机自动发现任务可将多个主机自动添加到集群。

注意事项

  • 运行中的主机自动发现任务不允许修改。

  • 出现以下情况时，主机将无法被自动发现：

  • 待发现主机与CVM网络不可达。

  • 待发现主机的CVK版本与CVM版本不一致。

  • CVM所管理的物理CPU个数已达到License中限制的可管理CPU个数。

  • 待发现主机已被CVM管理。

  • 待发现主机与当前主机池中其他主机的系统时间相差大于5分钟。

  • 待发现主机已使用其他CVM所管理主机池的共享文件系统。

增加主机自动发现任务

  1. 单击导航树中[系统管理/任务管理/主机自动发现任务]菜单项，进入主机自动发现任务列表页面。

  2. 单击<增加任务>按钮，弹出增加任务对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 参数设置完成后，单击<确定>按钮。

修改主机自动发现任务

  1. 单击导航树中[系统管理/任务管理/主机自动发现任务]菜单项，进入主机自动发现任务列表页面。

  2. 选择待修改的任务，单击 [image] 图标，弹出修改任务对话框。

  3. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  4. 修改完成后，单击<确定>按钮。

删除主机自动发现任务

  1. 单击导航树中[系统管理/任务管理/主机自动发现任务]菜单项，进入主机自动发现任务列表页面。

  2. 选择待删除的任务，单击 [image] 图标或<删除任务>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮。

查看主机自动发现任务详细信息

  1. 单击导航树中[系统管理/任务管理/主机自动发现任务]菜单项，进入主机自动发现任务列表页面。

  2. 选择待查看的任务，单击 [image] 图标，进入任务详细信息页面。

批量删除主机自动发现任务

  1. 单击导航树中[系统管理/任务管理/主机自动发现任务]菜单项，进入主机自动发现任务列表页面。

  2. 选中多个待删除的任务，单击列表上方的<删除任务>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮。

启动主机自动发现任务

  1. 单击导航树中[系统管理/任务管理/主机自动发现任务]菜单项，进入主机自动发现任务列表页面。

  2. 选择待启动的业务，单击 [image] 图标或<启动任务>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮。

批量启动主机自动发现任务

  1. 单击导航树中[系统管理/任务管理/主机自动发现任务]菜单项，进入主机自动发现任务列表页面。

  2. 选中多个待启动的任务，单击<启动任务>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮。

停止主机自动发现任务

  1. 单击导航树中[系统管理/任务管理/主机自动发现任务]菜单项，进入主机自动发现任务列表页面。

  2. 选择待停止的任务，单击 [image] 图标或<暂停任务>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮。

批量停止主机自动发现任务

  1. 单击导航树中[系统管理/任务管理/主机自动发现任务]菜单项，进入主机自动发现任务列表页面。

  2. 选中多个待停止的任务，单击<暂停任务>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮。

参数说明

  • 主机池：主机自动发现任务所属的主机池。

  • 集群：主机自动发现任务所属的集群。

  • 起始IP：待发现的主机所在IP范围的起始IP地址。起始IP必须小于结束IP。

  • 结束IP：待发现的主机所在IP范围的结束IP地址。结束IP必须大于起始IP。

  • ROOT密码：待发现主机ROOT用户的密码。待发现主机的ROOT密码需一致。

  • 检测间隔：任务启动后，系统进行主机搜索的频率，单位为分钟。

  • 持续时间：自动发现任务启动的持续时间，超时以后会自动停止任务，单位为小时。

  • 立即启动：是否立即启动该主机自动发现任务。


操作日志管理

操作日志详细记录了所有操作员对CVM所做的操作，包括操作员登录名、操作员姓名、完成时间、登录的IP地址、操作分类、操作描述、执行结果、失败原因等信息。操作日志管理用于查询、清理、下载和转储操作日志，以及收集日志文件。

主要功能

  • 查询操作日志

  • 清理操作日志

  • 下载操作日志

  • 转储操作日志


查询操作日志

操作员可以在操作日志列表中通过自定义过滤条件查询日志信息。

注意事项

  • 登录名为$SYSTEM的操作日志，是执行完定时任务（如备份策略、快照策略等）时系统自动生成的。例如系统进行自动备份虚拟机时，将自动记录备份虚拟机的操作日志，登录名为$SYSTEM，用户姓名为$SYSTEM。

  • 登录名为admin@VMC-RS的操作日志，是第三方系统调用当前CVM的REST接口时记录的日志。

操作步骤

  1. 单击导航树中[系统管理/操作日志/操作日志]菜单项，进入操作日志列表页面。

  2. 单击<过滤>按钮，弹出过滤查询对话框。

  3. 设置过滤查询参数后，单击<确定>按钮。操作日志列表中将显示符合过滤条件的日志信息。关于参数的详细介绍，请参见参数说明。

参数说明

  • 登录名：操作员登录CVM使用的帐号。

  • 操作员姓名：操作员的姓名。

  • 时间（从）：查询完成时间在本参数设定日期之后的操作日志。操作员可以单击输入框或者 [image] 图标，在弹出的日历对话框中选择查询日期。

  • 时间（至）：查询完成时间在本参数设定日期之前的操作日志。操作员可以单击输入框或者 [image] 图标，在弹出的日历对话框中选择查询日期。

  • 登录地址：操作员登录CVM所使用的计算机IP地址。

  • 执行结果：操作的执行结果，包括所有、成功、失败、部分成功。

  • 操作对象：操作所执行的对象。

  • 操作分类：操作员所执行操作的分类，包括操作员动作、系统配置、数据中心动作、主机池动作、主机动作、存储动作、网络动作、集群动作、虚拟机动作、模板动作、备份动作、告警管理动作、恢复动作、动态资源扩展业务动作、虚拟存储动作、站点容灾动作、CVM动作、存储适配器动作、云彩虹动作、命令行动作、电子流动作。

  • 事件类型：操作员所执行操作的事件类型，包括所有类型、删除、还原、格式化、转化、迁移、初始化、增加、修改、克隆、备份、部署、进入维护、退出维护、拷贝、导入、导出、分发、配置、管理、升级、执行命令、启动、关闭、重启、暂停、休眠、恢复、登录、注销、连接、断开连接、扫描、刷新、同步。

  • 风险级别：操作执行对应的风险级别，包括所有级别、高、中、低。


清理操作日志

该功能用于清理指定日期及其之前的所有操作日志。

注意事项

不允许清理操作日志保留时长内的日志。关于操作日志保留时长的设置，请参见系统参数设置。

操作步骤

  1. 单击导航树中[系统管理/操作日志/操作日志]菜单项，进入操作日志列表页面。

  2. 单击<清理>按钮，弹出清理日志对话框。

  3. 单击输入框或者 [image] 图标，在弹出的日历对话框中选择清理截止日期。

  4. 单击<确定>按钮。


下载操作日志

该功能用于下载符合过滤条件的全部日志信息。

操作步骤

  1. 单击导航树中[系统管理/操作日志/操作日志]菜单项，进入操作日志列表页面。

  2. 单击<下载>按钮，弹出操作确认对话框。

  3. 单击<确定>按钮，开始下载符合过滤条件的全部日志信息。


转储操作日志

该功能用于对CVM管理平台的操作日志进行备份和转储。

操作步骤

  1. 单击导航树中[系统管理/操作日志/操作日志]菜单项，进入操作日志列表页面。

  2. 单击<转储>按钮，弹出转储日志对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 设置完成后，单击<保存>按钮，完成日志转储配置。

  5. 单击<立即转储>按钮，立即转储操作日志。

参数说明

  • 转储目的地：转储的日志文件保存的目的地，包括远端服务器和主机本地目录，默认为远端服务器。

当转储目的地为远端服务器时，需配置如下参数：

  • IP地址：远端服务器的IP地址。

  • 用户名：远端服务器的用户帐号。该帐号要求有可读写远端服务器的权限。若连接远端服务器的方式为FTP，则该账号必须为远端服务器FTP Server上创建的帐号；若连接远端服务器的方式为SCP，则该账号必须为远端服务器操作系统上创建的帐号。

  • 密码：用户帐号对应的密码。

  • 连接方式：将待转储的日志文件传输到远端服务器所使用的传输协议，包括FTP和SCP，默认为FTP。若选择FTP方式，则仅支持Server-U、VsFTP、IIS类型的FTP服务器。

  • 连接测试：对CVM和远端服务器的连通性进行实时检查。

  • 转储位置：远端服务器上存放转储的日志文件的路径。

  • 服务器端口：访问远端服务器所用的端口号。当连接方式SCP时，服务器端口默认值为22；当连接方式为FTP时，服务器端口默认值为21。

当转储目的地为主机本地目录时，需配置如下参数：

  • 转储位置：CVM所在主机上存放转储的日志文件的路径。

  • 启用定时转储：是否定时转储日志文件，默认为否。若设置为是时，需配置如下参数：

  • 频率：执行转储策略的频率，包括每月、每周、每天，默认为每周。

  • 日期：每月定时转储日志文件的日期。

  • 星期：每周定时转储日志文件的星期。

  • 时间：执行转储的开始时间。

  • 保留个数：远端服务器或CVM所在主机本地上保留转储的日志文件的个数。此参数不允许为空。


收集日志文件

该功能用于收集CVM及其所管理主机的日志信息，并将收集到的日志文件下载到本地。

注意事项

如果收集某个或者某些主机的日志文件失败，下载页面将显示收集日志文件失败的主机名称。

操作步骤

  1. 单击导航树中[系统管理/操作日志/日志文件收集]菜单项，进入收集日志文件页面。

  2. 输入CVK主机日志文件大小，选择CVK主机日志时间范围，并选择一个或多个CVK主机，单击<收集日志文件>按钮，开始收集日志文件。

  3. 收集完成后，单击<单击下载>按钮将日志文件下载到本地保存，或者单击<重新收集>按钮重新收集日志文件。

参数说明

  • CVK主机日志文件大小：在收集CVK主机日志文件的时间范围内，允许收集单个CVK主机日志文件的大小默认为100MB。若某个CVK主机的日志超过CVK主机日志文件大小，则其多余的日志将不会被收集。

  • CVK主机日志时间范围：收集最近一段时间范围内的CVK主机日志文件，默认为收集最近1周的日志。

  • 需收集的CVK主机列表：待收集日志文件的CVK主机，允许收集多个CVK主机的日志文件。


系统参数管理

CVM的系统参数管理功能包括系统参数、邮件服务器、认证服务器、短信、Syslog服务器和中间件的设置。

主要功能

  • 系统参数设置

  • 邮件服务器设置

  • 认证服务器设置

  • 短信配置

  • Syslog服务器配置


系统参数设置

系统参数设置用于配置CVM管理平台的全局参数。系统参数的设置可以分为如下部分：

  • 系统基本参数：用于设置CVM的基本参数。

  • 个性化定制参数：用于设置CVM界面的个性化定制参数。

  • 自定义菜单参数：用于设置在CVM界面访问其它系统。

  • VNC代理服务器参数：用于设置VNC代理服务器的连接参数。VNC是Virtual Network Computing（虚拟网络计算机）的缩写，它的作用是将远端的计算机屏幕通过网络传输到本地，并允许以本地操作的方式对远端计算机进行远程控制。VNC由客户端和服务器两部分组成。系统中的虚拟机控制台为VNC客户端，安装在物理服务器主机上的虚拟机为VNC服务器，操作员可能会通过Internet从外部网络访问数据中心内部的虚拟机，从安全角度考虑，必须为这些虚拟机安装一个VNC代理服务器，该VNC代理服务器成为数据中心暴露给外部网络的唯一节点，操作员首先通过系统访问VNC代理服务器，由该VNC代理服务器统一与数据中心内部的虚拟机进行通信，确保了安装在虚拟机业务应用的安全性。

  • DNS服务器参数：用于设置DNS服务器地址。

  • HA系统参数：用于设置主机心跳周期和存储心跳周期。HA实现了两种心跳：主机心跳和共享存储池文件心跳。通过这两种心跳，CVM节点完成CVK主机的管理和HA资源的监控，实现集群内主机和虚拟机的故障检测并完成虚拟机的故障迁移，保证虚拟机的实时在线。

操作步骤

  1. 单击导航树中[系统管理/参数配置]菜单项，进入参数配置页面。

  2. 选择“系统参数”页签，进入系统参数配置页面。

  3. 设置系统基本参数、个性化定制参数、自定义菜单参数、VNC代理服务器参数、HA系统参数。关于参数的详细介绍，请参见参数说明。

  4. 设置完成后，单击<保存>按钮。

参数说明

系统基本参数：

  • 操作员闲置时长：当前Web界面的闲置超时时间，默认为10分钟。当登录后的操作员闲置时间超过操作员闲置时长时，系统自动注销该操作员。

  • 登录失败锁定时长：当操作员连续登录失败的次数达到登录尝试最大次数时，系统暂时锁定该操作员所在客户端IP地址的时长。默认为1分钟。锁定时长内，任何操作员都不能通过该IP地址再次访问系统。

  • 登录尝试最大次数：系统允许操作员连续登录失败的次数，默认为3次。当连续登录失败的次数达到设定值时，系统暂时锁定该操作员所在客户端IP地址。锁定时长由登录失败锁定时长参数设定。

  • 最大在线操作员数：系统允许同时在线的操作员的最大个数。默认为0，表示不作限制。

  • 管理台日志级别：设置CVM日志输出级别，包括错误、警告、提示，默认为错误。

  • 轮播间隔：云资源概览页面信息自动切换的时间间隔，包括5秒、10秒、30秒、1分钟、5分钟，默认为10秒。

  • 实时监控刷新间隔：设置管理平台中主机和虚拟机性能监控自动刷新时间间隔，包括30秒、1分钟、5分钟、10分钟，默认为30秒。

  • 告警信息保存期：告警信息在系统中保存的天数，默认为7天。

  • 虚拟机回收保存期：设置虚拟机回收站中的虚拟机保存的天数，逾期的虚拟机将被自动删除，默认值为0。0表示不自动删除回收站中的虚拟机。

  • 监控数据保留时长：性能监控数据在系统中的保留的天数，默认为7天。

  • 迁移超时时长：迁移运行状态的虚拟机时，如果在该参数设置时间范围内虚拟机尚未完成迁移，则系统将先暂停该虚拟机，使其可以快速完成迁移。待迁移完成后再将该虚拟机恢复为运行状态。默认为5分钟。

  • 性能监控时间间隔：系统采集主机、虚拟机的CPU、内存、磁盘、网络等性能数据的时间间隔。集群、主机和虚拟机的性能监控页签，会按照该时间间隔显示各项性能监控数据。最小时间间隔为10秒，最大为120秒，默认为30秒。

  • 动画效果：设置导航菜单是否启用动画效果，包括启用、不启用，默认为不启用。

  • 安全增加模式：设置是否启用安全增加模式，包括启用、不启用，默认为不启用。启用后，在主机上部署虚拟机时，虚拟机内存配置总和，不能超过该主机内存的80%。启用安全增加模式后，增加虚拟机，克隆虚拟机，通过模板部署虚拟机时，会进行安全内存的判断。

  • 保密模式：设置是否启用保密模式，包括启用、不启用，默认为不启用。保密模式启用后，有如下使用限制：同一个存储卷不允许给多个虚拟机使用；操作员的登录名不允许修改；同一个操作员账号只允许一个用户登录；只能通过HTTPS方式访问CVM；如果设置了安全区域，禁止将保密模式设置为不启用。保密模式启用后，可以使用云安全的安全区域、保密策略、保密业务电子流功能；保密模式不启用时，以上功能不可用。

  • 主机内存预留：设置主机是否预留内存，默认为是。若设置为“是”，主机内存预留值设定为主机内存的20%和10GB之间的最小值，当主机空闲内存大小与将在该主机上运行的虚拟机内存大小之差小于主机的预留内存值时，则不允许启动或在线迁入该虚拟机到当前主机。若选择为“否”，主机下虚拟机启动或在线迁入操作按正常使用情况处理。

  • CPU绑定超配：设置主机的CPU绑定是否允许超配，包括是、否，默认为是。若设置为“是”，每个NUMA节点下绑定物理CPU的虚拟CPU总数允许大于该节点的物理CPU总数；若设置为“否“，则不允许。

  • 共享存储故障隔离：共享存储发生故障时，是否重启所有使用共享存储的主机，包括重启主机、不重启主机，默认为重启主机。当设置为不重启主机时，必须开启集群高可靠性。

  • 虚拟机IPv6地址管理：设置是否启用虚拟机的IPv6配置和显示功能，包括是、否，默认为否。若设置为“是”，在增加、修改、克隆虚拟机和通过模板部署虚拟机等操作时，可以设置IPv6地址；在查看虚拟机时，系统将显示相应的IPv6地址。

  • 临时文件目录：上传和下载临时文件的目录，默认为/vms/tmp。

  • 操作日志保留时长：限制清理操作日志的时间，只允许清理保留时长之前的日志。默认为六个月。

  • 迁移暂停时长：虚拟机在线迁移完成前，用于迁移剩余脏页内存的虚拟机暂停时间。若无特殊需要，不建议设置。

  • VNC控制台密码：设置连接虚拟机VNC控制台的密码。仅对设置密码之后的新创建的虚拟机生效。若想单独修改某虚拟机的VNC控制台密码，可以在<修改虚拟机>界面进行修改。

  • VNC随机密码：选择虚拟机是否适用随机的VNC密码，开启后，用户已配置的VNC密码将会失效。

  • 客户端最大连接数：允许同一个IP地址的客户端与CVM建立连接的最大数量。默认值为300，最小为20，最大为500。

  • 告警编码：主机上报告警信息给告警服务器所用的编码格式，目前有BASE64、GBK、UTF-8三种。请根据实际情况进行选择。

  • 最大外部快照个数：设置最多允许保留虚拟机的外部快照个数，最多可以保留32个外部快照。

  • Intel RDT防吵闹：设置是否启用Intel RDT防吵闹功能，包括是、否，默认为否。启用该功能后，可以在修改虚拟机的对话框中，为虚拟机开启Intel RDT防吵闹功能。Intel RDT防吵闹功能需要物理主机CPU的支持。

  • 限制共享存储超配：选择是否限制共享存储超配，不开启表示不限制共享存储超配；开启后，可限制共享存储允许超配的倍数。建议重要业务开启超配限制，以防止共享存储资源超配过多，导致空间不足，影响业务。若未限制共享存储超配，请关注共享存储池利用率，当利用率过高时，请及时扩容或删除不必要的文件，避免空间不足，导致读写中断。

  • 共享存储超配比：设置限制共享存储超配的倍数，即允许共享存储分配的总容量超过实际容量的倍数。取值范围为0~N，0表示不允许超配，最大只允许分配和共享存储实际容量一致的卷容量，N表示允许超配的配置，实际可分配容量为实际容量的N+1倍。只有开启“限制共享存储超配”功能后，才可配置此参数。建议不要配置过高的超配比，并请关注共享存储池利用率，当利用率过高时，请及时扩容或删除不必要的文件，避免空间不足，导致读写中断。

个性化定制参数：

  • 系统名称：CAS系统的名称，即窗口标题的名称。

  • 版权信息：登录界面版权信息。

  • 登录页背景：登录界面背景图片。

  • 首页Logo：管理平台首页左上方的Logo。

  • 登录页Logo：登录界面的Logo。

  • 首页小Logo：收缩导航栏后，页面左上方的图标。

  • 网页缩略图标：系统在网页窗口上显示的图标。

  • 版权Logo：版权信息处的Logo。

  • 列表纵向分割线：系统是否开启显示列表的纵向分割线。

自定义菜单参数：

  • 菜单名称：其它系统的名称，该名称将显示在系统左侧导航栏中。

  • 菜单URL：其它系统的URL地址。单击导航栏中的系统名称，系统自动显示URL地址对应的页面。

VNC代理服务器参数：

  • VNC代理服务器IP：VNC代理服务器的IP地址。

  • VNC代理登录名：登录VNC代理服务器的用户帐号。

  • VNC代理登录密码：登录VNC代理服务器的用户账号对应的密码。

DNS服务器参数：

  • DNS服务器：设置DNS服务器的IP地址，最多可以设置3个，每个IP地址之间用“;”分隔。

HA系统参数：

  • 主机心跳周期：CVK主机向CVM发送心跳报文的时间间隔，默认为10秒。当CVK主机故障时，主机心跳将中断。在连续三个主机心跳周期和三个存储心跳周期之后，故障主机上的虚拟机将迁移到集群内的其他主机上。

  • 存储心跳周期：CVK主机向其存储池写入时间戳文件的时间间隔，默认为30秒。当存储网络故障时，存储心跳将中断。在连续三个存储心跳周期之后，受影响的虚拟机将迁移到集群内的其他主机上。


邮件服务器设置

该功能用于设置SMTP邮件服务器参数。

SMTP是建立在FTP文件传输服务上的一种邮件服务，主要用于传输系统之间的邮件信息并提供来信有关的通知。

操作步骤

  1. 单击导航树中[系统管理/参数配置]菜单项，进入参数配置页面。

  2. 选择“邮件服务器”页签，进入邮件服务器配置页面。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 单击<邮箱测试>按钮，测试配置的邮件服务器是否可用。

  5. 待测试成功后，单击<保存>按钮。

参数说明

  • 服务器地址：SMTP邮件服务器的域名或者IP地址。

  • 端口号：连接SMTP邮件服务器的TCP端口号。默认为25。

  • 服务器要求身份验证：设置SMTP服务器是否需要对发件人进行身份验证。默认为不需要身份验证。当设置为需要身份验证时，需配置如下参数：

  • 用户名：连接SMTP服务器的用户帐号。

  • 密码：连接SMTP服务器的用户密码。

  • 编码类型：邮件编码类型，包括UTF-8、GB2312，默认值为UTF-8。

  • 发件人邮箱地址：发送SMTP邮件的用户邮箱地址。

  • 发件人姓名：发送SMTP邮件的用户姓名。


认证服务器设置

企业网通常都包含了办公自动化、财务信息查询系统、电子邮件系统、网络设备和服务器管理等应用，这些应用都需要进行用户身份的认证，并对不同身份所拥有的角色进行授权，因而需要一个唯一的认证服务系统实现用户认证信息的统一管理。对于这种需要统一身份认证的应用场景，CVM提供了对LDAP认证的支持。

该功能用于设置LDAP认证服务器的参数。当操作员使用LDAP认证方式登录CVM时，需要到此服务器上进行身份认证。

操作步骤

  1. 单击导航树中[系统管理/参数配置]菜单项，进入参数配置页面。

  2. 选择“认证服务器”页签，进入认证服务器配置页面。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 单击<连通测试>按钮，检测CVM是否能与LDAP服务器连接成功。

  5. 待连通测试成功后，单击<保存>按钮。

参数说明

  • 服务器地址：提供LDAP服务的服务器IP地址。

  • 端口号：连接LDAP认证服务器的TCP端口号，默认为389。

  • 版本：LDAP服务器支持的版本，包括2、3，默认为3。

  • 类型：LDAP服务器的类型，包括通用LDAP服务器、微软活动目录，默认为通用LDAP服务器。

  • 用户名属性名称：从LDAP获取用户信息时，使用的用户名属性名称。当认证服务器类型为通用LDAP服务器时，默认用户名属性名称为cn；当认证服务器类型为微软活动目录时，默认用户名属性名称为sAMAccountName。

  • 管理员密码：与LDAP服务器通信时使用的管理员密码。

  • 管理员DN：LDAP服务器的管理员所在叶子节点到根的路径。例如：cn=Administrator,cn=users,dc=abc,dc=com。第一个cn是LDAP服务器系统管理员的用户名，第二个cn固定是users，dc的信息根据域名的级数填写。

  • Base DN：基准DN，LDAP搜索的起始DN。同一服务器上配置多个LDAP服务器时，Base DN不能重复。当LDAP服务器的类型为微软活动目录时，若Base DN未配置ou属性，会包含部分微软自带数据，配置时请指定ou。例如：ou=test,dc=abc,dc=com。ou是组织单位的名称，ou里面存在用户时，管理平台才能成功连接LDAP服务器。


短信配置

该功能用于配置短信平台相关参数。当告警产生时，短信平台将告警信息以短消息的方式自动发送到指定短信接收电话上，以便管理员及时了解系统异常现象。与邮件通知方式相比，短信通知的时效性更强，更能提升处理业务环境问题的效率。

注意事项

短信平台自动发送告警信息到指定短信接收电话，需完成如下配置：

  • 启用短信通知，并完成短信平台相关配置。

  • 在告警短信通知页面完成相关告警短信通知配置，具体请参见告警短信通知。

操作步骤

  1. 单击导航树中[系统管理/参数配置]菜单项，进入参数配置页面。

  2. 选择“短信配置”页签，进入短信配置页面。

  3. 设置相关参数。关于参数的具体介绍，请参见参数说明。

  4. 单击<短信测试>按钮，测试短信配置是否正确。

  5. 测试成功后，单击<保存>按钮。

参数说明

  • 启用短信通知：设置管理台是否启用短信通知，包括是、否，默认为否。

  • 短信类型：设置发送短信的平台类型，包括吉信通短信平台、华为短信机、移动代理服务器、瑞成短信平台、通用短信平台和网联平台，默认为吉信通短信平台。吉信通短信平台与瑞成短信平台均为第三方短信发送平台，需单独注册并部署，详情请分别参见吉信通和瑞成官方网站；华为短信机为华为公司的短信发送设备；移动代理服务器即中国移动代理服务器MAS。

当短信类型为吉信通短信平台时，需配置如下参数：

  • 登录名：登录吉信通短信平台的用户名。

  • 登录密码：登录吉信通短信平台的密码。

  • 启用HTTP代理：设置是否通过HTTP代理访问吉信通短信平台。当启用HTTP代理时，需配置代理地址、代理端口、代理用户名、代理密码。

当短信类型为华为短信机时，需配置如下参数：

  • IP地址：华为短信机的IP地址。

  • 数据库用户名：华为短信机数据库的用户名。

  • 密码：华为短信机数据库的密码。

  • 登录名：登录华为短信机的用户名。

  • 登录密码：登录华为短信机的密码。

  • 主叫标识号码：华为短信机的主叫标识号码。

  • 业务代码：华为短信机的业务代码。

当短信类型为移动代理服务器时，需配置如下参数：

  • IP地址：移动代理服务器的IP地址。

  • 接口编码：移动代理服务器的接口编码。

  • 数据库用户名：移动代理服务器的数据库用户名。

  • 密码：移动代理服务器的数据库密码。

当短信类型为瑞成短信平台时，需配置如下参数：

  • IP地址：瑞成短信平台的IP地址。

  • 登录名：登录瑞成短信平台的用户名。

  • 登录密码：登录瑞成短信平台的密码。

  • 启用HTTP代理：设置是否通过HTTP代理访问瑞成短信平台。启用HTTP代理后，还需配置代理地址、代理端口、代理用户名、代理密码。

当短信类型为通用短信平台时，需配置如下参数：

  • 短信编码：告警短信内容的编码类型，包括UTF-8和GBK，默认值为UTF-8。

  • 发送方式：告警短信的发送方式，包括HTTP请求（POST）和命令行。

  • 请求路径：通用短信平台发送短信的请求路径，当发送方式为HTTP请求（POST）时，需要设置该参数。具体路径的地址及语法需通过短信服务提供商来获取。例如，某短信服务提供商的请求路径设置为：http://192.168.0.1:80/sendSms?userName=a&pwd=b&mobile={Mobile}&content={Content}，其中，在发送短信时{Mobile}会替换为接收短信的电话号码、{Content}会替换为告警短信内容。

  • 命令行：通用短信平台发送短信的命令行，当发送方式为命令行时，需设置该参数。命令行所调用的脚本文件、脚本安装路径及命令行的语法，需要通过短信服务提供商来获取。例如，某短信服务提供商的命令行设置为：/vms/sendMsg.sh --mobile {Mobile} --content {Content}。其中，在发送短信时{Mobile}会替换为接收短信的电话号码、{Content}会替换为告警短信内容。


Syslog服务器配置

该功能用于配置Syslog服务器参数，配置完成后系统会将针对于系统的一些操作，发送特定的信息到配置的Syslog服务器中。

操作步骤

  1. 单击导航树中[系统管理/参数配置]菜单项，进入参数配置页面。

  2. 选择“Syslog服务器配置”页签，进入Syslog服务器配置页面。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 设置完成后，单击<保存>按钮。

参数说明

  • Syslog服务器IP：Syslog服务器的IP。需输入多个IP地址时，请使用英文分号（;）分割，例如：192.168.0.27;192.168.0.28，或FC00::1;FC00::2。

  • 协议：发送Syslog信息使用的协议，包括UDP、TCP，默认为TCP。

  • Syslog端口号：Syslog服务器的端口号。


中间件配置

该功能用于配置消息中间件，用于与第三方服务进行通信，修改CVM的中间件配置后需同步修改第三方服务的中间件配置。

操作步骤

  1. 单击导航树中[系统管理/参数配置]菜单项，进入参数配置页面。

  2. 选择“中间件配置”页签，进入中间件配置页面。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 设置完成后，单击<保存>按钮。

  5. 若需恢复初始化设置，单击<重置>按钮。

参数说明

  1. RabbitMQ服务器地址： RabbitMQ服务器地址，默认127.0.0.1。

  2. 端口号：RabbitMQ服务的端口号，默认5672。

  3. 用户名：RabbitMQ服务的用户名。

  4. 密码：RabbitMQ服务的密码。

  5. 虚拟主机名：RabbitMQ服务虚拟主机名。

  6. VM事件交换机名称： RabbitMQ管理平台中对应的用于保存虚拟机事件的交换机名称。


双机热备管理

双机热备功能是对CVM主机进行双机热备配置；当主CVM发生故障时，通过主备CVM的切换，CVM可以对外正常提供服务。双机热备基于数据同步复制的方式实现。数据同步复制是指：主CVM通过管理网实时将数据库文件等数据同步给备CVM。同时主CVM上允许创建一个本地同步分区，用于向备CVM同步除了数据库文件以外的其余数据。

双机热备管理包括双机热备搭建、查看热备配置、双机热备切换、查看热备主机信息等功能。

配置前提

搭建双机热备的两台CVM主机需同时满足以下条件：

  • 全新安装的系统，无纳管的CVK主机，无虚拟机。

  • 主机上的存储池必须保持系统默认配置，即只有isopool和defaultpool两个存储池。

  • CAS软件版本号必须相同。

  • 主机的系统引导方式必须相同。

  • 主机的系统时间相差不能大于5分钟。

  • 主机安装的CAS组件（CVM、CIC、SSV）必须相同。

  • /vms分区需要有足够的存储空间，至少大于20G。

  • 两台主机之间管理网络必须相通。

注意事项

  • 在双机热备搭建过程中和切换过程中，禁止任何操作。

  • 双机热备环境搭建完成后，CVM主机作为CVK主机加入到管理平台时需满足以下条件：

  • 系统全新安装，非以前的双机热备环境升级。

  • 主机上未创建本地同步分区。

  • 备机处于异常、数据正在同步、数据同步异常状态时，禁止执行双机热备切换。

  • 执行双机热备切换操作是系统向主备管理平台发出的热备切换指令，主备管理平台能否切换成功取决于主备机之间的数据是否同步。

  • 双机热备配置过程中的配置页面默认取浏览器的语言。

双机热备搭建

  1. 单击导航树中[系统管理/双机热备配置]菜单项，进入热备主机列表页面。

  2. 单击<热备搭建>按钮，弹出热备搭建对话框。

  3. 设置相关参数，关于参数的详细介绍，请参见参数说明。

  4. 单击<确定>按钮完成操作。

查看热备配置

  1. 单击导航树中[系统管理/双机热备配置]菜单项，进入热备主机列表页面。

  2. 单击<查看热备配置>按钮，弹出热备搭建对话框。

双机热备切换

  1. 单击导航树中[系统管理/双机热备配置]菜单项，进入热备主机列表页面。

  2. 单击<热备切换>按钮，在弹出的对话框中单击<确定>按钮完成操作。

查看热备主机信息

  1. 单击导航树中[系统管理/双机热备配置]菜单项，进入热备主机列表页面。

  2. 当CVM主机未作为CVK主机加入到管理平台时，列表下方将会显示CVM主机的“网络”和“存储适配器”页签。

  3. 在“网络”页签中，可以管理CVM主机上的虚拟交换机，包括增加、修改、删除虚拟交换机。

  4. 在“存储适配器”页签中，可以管理CVM主机上的存储适配器，包括修改主机的iqn标识符、执行设备扫描等。

参数说明

双机热备搭建：

  • 虚IP地址：管理平台对外提供访问的IP地址，必须为空闲IP，建议使用此IP访问CVM。

  • 子网掩码/前缀：虚IP地址对应的子网掩码/前缀。

  • 备机IP地址：备CVM主机的管理IP地址。

  • 备机root密码：备CVM主机root用户的密码。

  • 仲裁方式：双机热备系统的仲裁方式，包括：高级仲裁、简易Ping方式。

  • 高级仲裁：指定一台已安装CVK组件的主机作为仲裁主机，当主备CVM管理平台之间通信异常时，主备节点同时向仲裁主机发送本机状态信息，仲裁主机根据接收到的信息进行仲裁，将重新确定的主备角色信息回送给两节点。仲裁主机安装的CAS软件版本号必须与主备CVM管理平台安装的CAS软件版本号一致。

  • 简易Ping方式：指定两个仲裁IP地址，当主备CVM管理平台之间通信异常时，主备节点同时ping两个仲裁IP地址来判断自身是否网络故障。若节点无法同时ping通两个仲裁IP地址，则认为自身故障，降为备机。

  • 仲裁主机IP地址：仲裁主机的IP地址，仲裁主机必须是已安装CVK组件的主机。

  • 仲裁主机root密码：仲裁主机root用户的密码。

  • 仲裁IP地址：局域网中能够访问的网关或一直可以连通的主机IP地址，用于测试CVM主机网络是否故障。建议使用网关的IP地址。当仲裁方式选择简易Ping方式时，必须设置两个不同的仲裁IP地址。

  • 预估主机个数：预估管理平台中主机的个数，用于计算数据库分区大小。

  • 预估虚拟机个数：预估管理平台中虚拟机的个数，用于计算数据库分区大小。

  • 数据库分区大小：数据库分区是在CVM主机的／vms分区中创建的分区，用于主备CVM间的数据同步。数据库分区大小=（预估主机个数 * 7M + 预估虚拟机个数 * 5M）* 15天 / 1024M；最少20G。为了缩短双机热备的搭建时间，当设置数据库分区大小超过200G时，建议两台CVM之间的管理网使用万兆光纤。

查看热备主机信息-网络：

  • 物理接口：虚拟交换机所使用的主机物理网卡的接口。

  • 网络类型：虚拟交换机的网络类型，默认值为业务网络。

  • 管理网络：此类型的虚拟交换机用于传输CVM与各主机之间控制层数据。

  • 业务网络：此类型的虚拟交换机用于传输虚拟机业务数据。

  • 存储网络：此类型的虚拟交换机用于传输主机到IP SAN存储服务器或者主机到分布式存储之间的报文，且不允许虚拟机连接使用。

  • 备份网络：此类型的虚拟交换机用于传输虚拟机备份到远端服务器时的备份数据，且不允许虚拟机连接使用。一个主机上只允许存在一个此类型虚拟交换机或此类型的子网。

  • 迁移网络：此类型的虚拟交换机用于传输虚拟机迁移时的内存和磁盘镜像数据，且不允许虚拟机连接使用。一个主机上只允许存在一个此类型的虚拟交换机或此类型的子网。

  • 其他网络：此类型的虚拟交换机用于传输上述未提及的其他类型的数据。

  • 转发模式：虚拟交换机的转发模式，包括VEB、VXLAN(SDN)。

  • VEB：Virtual Ethernet Bridge，虚拟以太网桥。在该模式下，虚拟机与虚拟机之间的流量通过纯软件的方式进行转发。

  • VXLAN(SDN)：部署了SDN控制器和云计算管理平台的VXLAN解决方案对应的虚拟交换机转发模式。

  • VLAN ID：虚拟交换机连接主机协议栈端口的VLAN ID。

  • 状态：虚拟交换机的运行状态，包括活动、不活动。

  • IP地址：虚拟交换机的IP地址。

  • 子网掩码/前缀：虚拟交换机使用的子网掩码/前缀。

  • 网关：虚拟交换机使用的网关。

  • DPDK状态：虚拟交换机的DPDK状态。

查看热备主机信息-存储适配器：

  • 名称：存储适配器名称。

  • 型号：存储适配器型号。

  • 类型：存储适配器类型，包括SCSI、iSCSI、FC、FCoE。

  • 状态：存储适配器状态。

  • 标识符：存储适配器iqn标识符。

  • 正常扫描：按照正常规则扫描。

强制扫描：强制执行扫描操作。一些HBA卡在存储分配完成后，需要通过强制扫描（存储链路重置）才能发现新增加设备。这是一种破坏性操作，可能导致IO操作超时。


管理平台联动资源管理

ARM架构的主机暂不支持“管理平台联动资源”功能。

管理平台联动资源管理用于管理与CVM联动的VCF组件。当CVM与VCF组件联动时，CVM与VCFC（VCF Controller，虚拟融合架构控制器）之间通过REST API接口与其进行通信，由VCFC统一管理和下发网络策略到CVM的虚拟交换机上。对于CVM而言，VCFC是一个与其通信联动的外部资源，在两者联动工作前，需要在CVM上定义VCFC资源的访问方式。

增加管理平台联动资源

  1. 单击导航树中[系统管理/管理平台联动资源]菜单项，进入管理平台联动资源列表页面。

  2. 单击<增加联动资源>按钮，弹出增加管理平台联动资源对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 设置完成后，单击<确定>按钮。

修改管理平台联动资源

  1. 单击导航树中[系统管理/管理平台联动资源]菜单项，进入管理平台联动资源列表页面。

  2. 选择待修改的资源，单击 [image] 图标，弹出修改管理平台联动资源对话框。

  3. 修改相关参数。关于参数的详细介绍，请参见参数说明。

  4. 修改完成后，单击<确定>按钮。

删除管理平台联动资源

  1. 单击导航树中[系统管理/管理平台联动资源]菜单项，进入管理平台联动资源列表页面。

  2. 选择待删除的资源，单击 [image] 图标，弹出删除管理平台联动资源确认对话框。

  3. 单击<确定>按钮。

查看管理平台联动资源详细信息

  1. 单击导航树中[系统管理/管理平台联动资源]菜单项，进入管理平台联动资源列表页面。

  2. 选择待查看的资源，单击 [image] 图标，弹出查看管理平台联动资源对话框。

同步管理平台联动资源

  1. 单击导航树中[系统管理/管理平台联动资源]菜单项，进入管理平台联动资源列表页面。

  2. 选择待同步的资源，单击 [image] 图标，弹出与VCF同步分布式虚拟交换机信息对话框。

  3. 单击<确定>按钮。

参数说明

  • IP地址：联动资源的IP地址。

  • 协议：访问联动资源时所使用的协议，包括HTTP、HTTPS。

  • 端口号：访问联动资源时所使用的端口号。

  • 关联类型：联动资源与CVM联动的方式，包括强联动、弱联动。

  • 强联动：CVM负责虚拟网络管理，由CVM与VCF两方交互完成所有系统资源同步，交互过程无第三方软件参与，适用于未部署Cloud OS的场景。

  • 弱联动：Cloud OS负责虚拟网络管理，CVM只同步虚拟交换机的信息给VCFC，虚拟端口的创建和删除等相关操作由Cloud OS触发VCFC完成，适用于部署了Cloud OS的场景。

  • 用户名：登录联动资源所使用的用户名。

  • 密码：登录联动资源所使用的用户名对应的密码。

  • 根路径：CVM通过REST API接口访问VCFC时的URL路径。


License管理

License管理功能，用于对软件进行授权。提供两种授权方式：本地授权或License Server授权，可根据实际情况选择授权方式。如需申请License，请联系授权经销商。

未完成License注册的CVM为试用版。试用版的功能与正式版完全相同，但可用时间仅为180天。用户通过可申请并注册License获取CVM的正式版，解除试用版的时间限制。

注意事项

  • 仅企业增强版支持容灾管理功能，如果要使用容灾管理功能，请申请对应版本的企业增强版License。

  • 异构平台迁移授权需要单独申请，如需使用异构平台迁移功能，请参考异构平台迁移配置指导，申请授权后使用。

  • 当CIC与CVM部署在同一台服务器中时，需注意以下事项：

  • CVM与CIC需要使用相同的注册方式（本地授权方式或License Server授权方式）。

  • CIC与CVM在远程注册时的参数是相同并且共用的，用户在配置参数时只需在CIC或CVM中选择一个进行配置，如果在CIC与CVM中均配置参数，则两处的参数配置会互相影响。

  • CVM企业增强版注册完成后，CIC的虚拟机授权个数依然受限。用户需要在CIC中进行License Server注册操作，当出现“已经是企业增强版，无需再申请，请确认是否切换注册方式。”的提示时，单击<确定>按钮，CIC即可切换至企业增强版，CIC中虚拟机授权个数也不再受到限制。

主要功能

  • 查看授权信息

  • 本地授权方式


查看授权信息

该功能用于查看已注册的授权信息。

操作步骤

  1. 单击导航树中[系统管理/License管理]菜单项，进入License管理页面，查看当前已获得的授权信息。

参数说明

CVM授权：

  • 可管理CPU个数：目前License允许CVM可以管理的物理CPU个数。

  • 已管理CPU个数：CVM已经管理的物理CPU个数。

  • 可保护虚拟机数：目前License授权CVM存储复制站点容灾功能可保护的虚拟机数。

  • 已保护虚拟机数：目前CVM站点容灾功能已经保护的虚拟机数。

  • 授权条码：CVM的授权条码。

  • 版本：CVM的版本，包括标准版、企业版、企业增强版。

  • License有效期：当前License的剩余有效天数。

磁盘备份容灾授权：

  • 容灾节点授权点数：License授权支持磁盘备份容灾功能的主机节点数。

  • 容灾节点已使用点数：目前已使用磁盘备份容灾功能的主机节点数。

  • 总备份授权点数：License授权磁盘备份容灾功能可保护的虚拟机/生产机个数。

  • 已使用备份点数：目前已被磁盘备份容灾功能保护的虚拟机/生产机个数。

  • 未使用授权点数：还可以授权磁盘备份容灾功能保护的虚拟机/生产机个数。

异构平台迁移授权：

  • 总授权点数：License授权支持异构迁移的源设备个数。

  • 已使用授权点数：目前已使用异构迁移功能的源设备个数。

  • 剩余授权点数：还可以进行异构迁移的源设备个数。


本地授权方式

用于通过本地授权方式进行授权。本地授权过程为：

  1. 通过“本地授权”功能，获取安装了CVM的物理主机信息文件，主机信息文件用于标识授权的应用控制范围，将作为以本地授权方式注册授权的重要依据；对于异构平台迁移功能，主机信息文件通过“硬件码下载”功能获取，硬件码文件将作为申请异构平台迁移License的重要依据。

  2. 获取主机信息文件后，请参考《H3C CAS软件注册指导》中的介绍，获取授权激活文件。

  3. 通过“注册License”功能，将获取的License激活文件导入CVM，完成License的注册。

  4. 对于本地授权方式注册的正式授权，还可以通过“导出License”功能，将授权激活文件下载到本地。

本地授权

  1. 单击导航树中[系统管理/License管理]菜单项，进入License管理页面。

  2. 单击<本地授权>按钮，弹出申请正式授权对话框。

  3. 设置相关参数。关于参数的详细介绍，请参见参数说明。

  4. 设置完成后，单击<完成>按钮，将主机信息文件下载到本地计算机保存。主机信息文件默认名称为“host.info”。

注册License

  1. 单击导航树中[系统管理/License管理]菜单项，进入License管理页面。

  2. 单击<注册License>按钮，弹出注册License对话框。

  3. 单击<浏览>按钮，选择需要导入到系统的License文件。

  4. 单击<打开>按钮开始上传License文件。

  5. 单击<确定>按钮，完成操作。

导出License

  1. 单击导航树中[系统管理/License管理]菜单项，进入License管理页面。

  2. 单击<导出License>按钮，将授权激活文件下载到本地计算机保存。授权激活文件默认名称为“casLicense.lic”。

硬件码下载

  1. 选择顶部“管理”页签，单击左侧导航树[License管理]菜单项，进入License管理页面。

  2. 单击[特性授权]页签。

  3. 单击<硬件码下载>按钮，将主机硬件码文件下载到本地计算机保存。硬件码文件默认名称为“HardInfo.dat”。

参数说明

最终用户的信息：

  • 用户姓名：使用CVM的最终客户姓名全称。

  • 国家/地区：最终用户所在的国家或地区，默认值为中国。

  • 省/市：最终用户所在的省或市。

  • 公司/单位名称：最终用户所在公司或单位的全称。

  • 地址：最终用户所属公司或单位的详细通信地址。

  • 邮编：最终用户所属公司或单位所在区域的邮政编码。

  • 电子邮件地址：最终用户的E-Mail邮箱地址。

  • 联系电话：最终用户的电话联系方式。

申请人信息：

  • 姓名：License申请者的姓名全称。

  • 公司/单位名称：License申请者所在公司或单位的全称。

  • 电子邮件地址：License申请者的E-Mail邮箱地址。

  • 联系电话：License申请者的联系电话。


License Server授权方式

用于以License Server方式申请授权。License Server授权，即通过授权服务器申请授权。授权申请后，可以查看详细信息，也可以根据需要进行授权的扩容或释放。

License Server授权

  1. 单击导航树中[系统管理/License管理]菜单项，进入授权信息页面。

  2. 单击<License Server授权>按钮，进入License Server授权对话款，设置相关参数。关于参数的详细介绍，请参见参数说明。

授权扩容/释放

  1. 单击导航树中[系统管理/授权管理]菜单项，进入授权信息页面。

  2. 单击<授权扩容/释放>按钮，弹出License Server授权对话框，设置相关参数。关于参数的详细介绍，请参见参数说明。

授权详细信息

  1. 单击导航树中[系统管理/授权管理]菜单项，进入授权信息页面。

  2. 单击<授权详细信息>按钮，弹出授权详细信息对话框。查看当前软件通过License Server方式授权的详细信息。

参数说明

基本操作：

  • 授权服务IP地址：License Server的IP地址。

  • 授权服务端口：License Server的授权服务端口。

  • 客户端名称：在License Server中为本系统创建的客户端名称。

  • 客户端密码：在License Server中为本系统创建的客户端密码。

授权CPU配置：

  • 当前可管理CPU个数：当前CVM授权可以管理的物理CPU个数。

  • 已管理CPU个数：当前CVM已经管理的物理CPU个数。

  • 版本：授权所对应的版本信息。有无限授权企业版、标准版、企业版、企业增强版授权，以及对应的升级版授权（标准版升企业版、标准版升企业增强版、企业版升企业增强版）。

  • 可申请CPU：License Server上当前申请的授权数量，即可管理CPU个数。

  • 已分配CPU：本CVM中已获取的授权数量，即可管理CPU个数。

  • 操作：指定“申请”或“释放”授权的动作。

  • CPU数量：申请或释放的授权数量，即可管理CPU个数。

授权虚拟机配置：

  • 当前可保护虚拟机数：当前SRM授权的存储复制容灾功能可保护的虚拟机个数。

  • 可申请虚拟机：License Server上当前可申请的SRM授权，即可保护的虚拟机个数。

  • 已分配虚拟机：当前CVM已获取授权，即已授权存储复制容灾功能保护的虚拟机个数。

  • 操作：指定“申请”或“释放”授权的动作。

  • 虚拟机数：申请或释放的可保护虚拟机数。

授权详细信息：

  • 授权条码：授权的序列号。

  • 类型：指明“正式授权”或“临时授权”。

  • 剩余时间：授权剩余可用时间。


运维概述

CAS云计算管理平台运维架构如图1 所示，将系统中的日常运维划分为：基础运维、高级运维、场景化运维、个性化运维四种类型。每种类型涵盖了不同的功能，适用于不同的场景。

CAS云计算管理平台提供完善的运维解决方案，构建与业务相匹配的运维体系，实现标准化、可视化、流程化、精细化的运维管理。CAS云计算管理平台提供运维可视化、六大一键操作、自定义运维等简运维特性，旨在为用户提高运维效率，提升运维质量。

图-1 CAS云计算管理平台运维架构图

  • 基础运维：帮助用户了解如何查看系统中的各种资源使用和分布情况、展示资源与主机、虚拟机的连接关系以及操作任务进展和日志记录。

  • 高级运维：

  • 通过报表查询，可以直观看到虚拟化环境中的资源瓶颈，协助用户对调整架构和更换IT资源等规划做出最佳决策。

  • 通过资源统计数据，协助用户掌握虚拟化系统当前的运行状态，为用户的规划策略提供最佳的决策依据。

  • 通过自动主机发现，帮助用户管理所有集群的主机自动发现任务，自动搜索可添加的同网段的主机，并将其添加到任务所属的集群下。

  • 通过告警机制，让用户能够及时发现并解决影响虚拟化环境健康运行的问题，确保环境能够监控稳定运行。

  • 场景化运维：为用户提供了高效便捷的巡检方式，能快速对系统进行全方位的健康巡检，并且自动生成分析报告给出优化建议。协助用户查看主机、虚拟机资源的使用情况，及时释放空闲存储资源。根据实际需求为虚拟机创建还原点，必要时可进行虚拟机还原。

  • 个性化运维：帮助用户根据实际业务需求和关注重点进行个性化设置，例如可配置多组操作员进行灵活的团队运维，划分目录管理不同业务类型的虚拟机，设计自定义监控面板让关注的数据可随时进行查看。


运维建议

  • 建议操作员日常关注系统的健康状态和资源使用情况。

  • 建议操作员设置告警通知功能来关注系统告警，按照告警详细信息的恢复建议对告警进行处理。CAS云计算管理平台提供告警维护经验记录功能，对于同类型的告警，维护经验将累计记录。

  • 建议操作员定期在CAS云计算管理平台上进行巡检，检测软硬件运行情况以及掌握系统的健康状态。了解CAS云计算管理平台中计算/网络/存储资源的分布情况，监测主机/虚拟机/IP/VLAN/存储维度的资源使用情况。在系统中，主机/虚拟机的各类资源使用趋势会以报表的形式展示。

  • 建议操作员定期查看和分析日志信息，能够及时发现系统中存在的隐患。CAS云计算管理平台提供日志下载功能，遇到疑难问题可以发送日志给技术支持工程师，协助分析解决问题。


基础运维

功能

说明

帮助链接/查看步骤

资源概览

首页资源概览

通过图表展示云资源中主机与虚拟机实时状态信息，帮助用户快速了解系统内资源的使用情况。可查看系统健康度、主机状态统计、虚拟机状态统计、CPU分配比、内存分配比、存储分配比、存储集群容量、系统告警信息、Top5主机的CPU、内存和存储利用率、主机数量与状态、Top5虚拟机的CPU、内存和存储利用率、虚拟机数量与状态。

云资源概览

大屏展示

软硬件资源性能监控

主机硬件监控

监控主机硬件状态。同时CAS云计算管理平台对存储、物理网卡、GPU设备、存储适配器也进行着实时监控。

查看主机硬件监控信息

性能监控

用于监控主机和虚拟机，查看虚拟环境下的资源使用情况。

  • 可查看集群下主机的CPU利用率、内存利用率、I/O吞吐量统计、磁盘请求和共享文件系统占用率。

  • 可查看虚拟机的CPU利用率、内存利用率、I/O吞吐量统计、网络吞吐量统计、磁盘请求、磁盘I/O延迟、磁盘利用率和分区占用率信息。

  • 查看主机性能监控信息

  • 查看虚拟机的性能监控信息

虚拟机进程服务监控

用于查看虚拟机当前正在运行的程序、进程和服务，显示每个进程的用户名、进程ID、进程名、CPU利用率、内存利用率和内存使用量信息。

查看虚拟机进程服务监控信息

虚拟化拓扑展示

计算拓扑

计算拓扑展示了集群与物理主机、物理主机与虚拟机的隶属关系，可查看整个虚拟数据中心的主机、虚拟机的告警信息，以及每个集群的CPU、内存和共享存储容量的利用情况信息。

查看计算拓扑

网络拓扑

网络拓扑展示了以虚拟交换机为核心的虚拟交换机与虚拟机的网络连接关系，可查看虚拟机vNIC端口的网络策略与流量监控数据。

查看网络拓扑

存储拓扑

存储拓扑展示了以存储为核心的存储与物理主机、虚拟机的连接关系，可查看存储节点详细信息。

查看存储拓扑

操作感知与日志记录

操作日志

用于详细记录所有操作员在CAS云计算管理平台中所做的操作。例如，操作员发现系统执行了计划外的任务，可打开操作日志查找近期任务执行的相关信息，联系相关操作员询问任务执行情况，也可以查看任务台了解任务执行的情况。

操作日志管理

日志文件收集

用于收集CAS云计算管理平台及其所管理主机的日志信息，并将收集到的日志文件下载到本地。例如，在日常巡检的过程中，操作员发现主机运行异常无法处理时，可选择对应的主机进行日志文件收集，发给技术支持工程师分析。

收集日志文件

审计日志

用于详细记录所有操作员在CVM中所做的操作，并按照操作类型将所有操作记录分为行为审计，物理资源审计，虚拟资源审计三类，可作为审核操作员操作的参考依据。

审计日志管理

任务台

用于快速查看近期执行的任务的相关信息。例如，操作员对虚拟机进行启动时，系统将自动弹出任务台，显示任务执行情况。若任务执行失败，任务台会显示失败原因，操作员可参考问题原因，及时做出调整方案。

在CAS云计算管理平台界面右上方单击 [image] 图标，打开任务台；查看任务执行情况。


高级运维

功能

说明

帮助链接

监控报表

主机报表

用于统计和查看指定主机在指定时间范围内的资源利用率等信息。

查看主机性能统计信息

虚拟机报表

用于统计和查看指定虚拟机在指定时间段内资源利用率等信息。

查看虚拟机性能统计信息

TopN统计报表

用于统计和查看指定时间段内资源利用率最高的主机或虚拟机信息。

查看性能TopN统计信息

资源统计

集群资源统计

用于统计和查看集群基本信息和资源的使用情况，例如主机数、虚拟机概要、CPU总核数、CPU分配比、总内存、内存分配比等信息。

集群资源统计

主机资源统计

用于统计和查看主机基本信息和资源使用情况，例如运行时间、主机型号、CPU型号、CPU利用率、内存利用率、本地磁盘容量等。

主机资源统计

虚拟机资源统计

用于查看虚拟机的基本信息和资源使用情况，例如主机名、虚拟机状态、CPU利用率、内存利用率、CPU、内存、虚拟机磁盘、操作系统等。

虚拟机资源统计

IP分配统计

用于统计IP分配情况，可以快速的查询出每个、集群和主机的虚拟机IP分配情况。

IP分配统计

VLAN分配统计

用于统计系统中VLAN分配情况，可以快速查询虚拟机所属VLAN。

VLAN分配统计

存储资源统计

用于统计系统中存储资源分配情况，可以快速的查询、集群和主机下存储资源包括虚拟机磁盘、网络存储、共享文件系统的分配情况。

存储资源统计

TopN虚拟机存储资源统计

用于统计和查看主机池、集群和主机下TopN虚拟机的实时存储资源统计信息。

TopN虚拟机存储资源统计

告警管理

实时告警

用于显示系统最近一段时间内产生的告警，支持对告警原因分析和恢复建议。例如，在日常运维中业务虚拟机发生故障影响了部分业务。操作员可以通过实时告警功能去查看这台虚拟机的告警信息，了解告警原因和恢复建议后，再去采取措施处理虚拟机。

实时告警管理

告警阀值配置

用于配置触发告警的最低值，支持自定义告警级别和告警阈值。例如，操作员重视集群的CPU利用率这项告警检测指标，希望在实时告警列表及时发现集群CPU利用率的变化。操作员可以通过告警阈值配置功能，为这指标项配置告警类别、告警阈值、告警持续时间等参数，来获取关注的信息。

告警阈值配置管理

告警屏蔽配置

用于将无需关注的告警进行屏蔽。已屏蔽的告警将不再上报到实时告警列表。例如，在实时告警列表中有多条非关注重点的告警信息上报。操作员可以通过告警屏蔽配置功能，配置需要屏蔽的指标项和对象。

告警屏蔽配置管理

告警通知

用于将系统内告警信息以邮件和短信方式通知用户。例如，在实际的使用中，操作员可能会需要时刻重点监控部主机或虚拟机运行中的一些指标。操作员可以通过配置告警通知功能接受短信或邮件，实时了解系统内资源运行的状态。

  • 告警邮件通知配置

  • 告警短信通知配置

主机自动发现

主机自动发现任务

用于管理所有集群的主机自动发现任务。该功能可以自动搜索可添加的同网段的主机，并将其添加到任务所属的集群下，默认一个集群只能添加一个主机自动发现任务。操作员可以通过配置相关的自动发现任务列表，启用主机自动发现任务，将多个主机自动添加到集群，降低工作量提升效率。

任务管理


场景化运维

功能 | 说明 | 帮助链接
一键健康巡检 | 用于快速检测系统的健康情况，计算检测项总体得分。该功能可提供系统检测、计算资源检测、存储资源检测、网络资源检测、高可靠性服务状态检测，帮助管理员快速了解虚拟机环境的运行状态、性能以及可能存在的隐患。 | 健康巡检
一键资源分析 | 用于查看集群、主机、虚拟机的资源配置与近一个月的CPU、内存的使用情况。分析集群、主机、虚拟机等资源配置与使用情况，为用户提供决策规划依据。 | 资源分析
一键存储清理 | 用于扫描和检测虚拟机和后端存储文件的关联关系，对于未被任何虚拟机挂载的存储文件，同时又不是虚拟机操作系统安装包(ISO)以及虚拟化驱动程序的文件，我们将其视为空闲存储文件，您可以对扫描出的空闲的存储文件进行选择性的清理，以释放存储空间。 | 存储清理
一键资源导出 | 用于查询和导出系统内主机、虚拟机的资源配置信息。该功能支持界面定制、列名定制，可自定义资源展示信息重点。 | 资源导出
一键虚机还原 | 用于还原虚拟机磁盘状态到创建虚拟机还原点时的状态。 | 虚机还原
一键僵尸虚机清理 | 僵尸虚拟机是指长时间未使用且处于关闭状态的虚拟机。该功能用于发现、启动和删除僵尸虚拟机，协助用户进行资源管理。 | 僵尸虚拟机管理


个性化运维

功能 |  | 说明 | 帮助链接
操作员管理 | 操作员管理 | 用于增加、修改、删除操作员，以及查看操作员的详细信息。 | 操作员管理
 | 操作员分组 | 用于为多个操作员统一配置相同权限。 | 操作员分组管理
 | 在线操作员 | 用于管理CVM中当前在线的操作员，可以查看、查询和立即下线在线操作员。 | 在线操作员管理
虚拟机视图 | 增加目录 | 用于操作员自定义目录，并可以在每个目录下创建子目录，根据实际需要将同类型的虚拟机收藏到一个目录中进行统一管理。 该功能可以方便操作员分类管理虚拟机、快速查找虚拟机、快速查看虚拟机的详细信息等。 | 虚拟机视图管理
 | 设置启动规则 | 用于设置虚拟机按照指定的顺序依次启动。例如：3个虚拟机分别安装了数据库、应用和WebService软件，需要设置一定的启动顺序。首先将它们收藏到同一个虚拟机目录下，然后设置相应的启动规则，再执行批量启动操作。
自定义监控 | 自定义监控 | 用于操作员自定义监控面板，设置关注的参数图表，针对性展示用户关注的参数。自定义监控面板控件可拖拽放置，操作方便，监控页面可全屏展示，给用户带来更好的体验。例如，操作员希望把关注的参数集合到一个面板展示并随时查看，可以通过自定义监控功能进行设计，拖拽相应的面板组件，设置关注的参数指标，保存该监控面板后可随时打开查看。 | 自定义监控


系统辅助功能

系统辅助功能是CVM提供的与系统操作相关的配置功能。

系统辅助功能的配置主要包括：

  • 辅助管理：提供与配置界面及后台任务和消息相关的功能。

  • 查看任务台：用于跟踪和记录自操作员登录成功以来的管理操作任务执行状态。


辅助管理

辅助管理功能为操作员提供设置界面风格、注销操作员和修改操作员密码等功能。

主要功能

  • 设置界面风格

该功能用于设置CVM主界面配色风格，支持蓝色（默认值）、黑色、绿色、红色、紫色、墨色六种色调。

操作步骤：

在主界面上，单击界面右上方的 [image] 图标，根据需要选择界面配色风格。

  • 注销操作员

该功能用于注销当前操作员。注销后，操作员需要重新登录。

操作步骤：

在主界面上，单击界面右上方的 [image] 图标，系统将返回登录页面。

  • 修改操作员密码

该功能用于修改当前登录操作员的登录密码。

操作步骤：

在主界面上，单击界面右上方的 [image] 图标，选择[修改密码]菜单项，弹出修改密码对话框。

输入旧密码、新密码和确认密码后，单击<确定>按钮，完成操作。


查看任务台

通过任务台，操作员可以查看登录之前未完成的任务信息和登录之后所有操作员创建的任务信息，以及任务的执行状态。

操作步骤

  1. 单击界面右上方的 [image] 图标，在主界面的下方将会显示任务台窗口。

  2. 如需关闭任务台，单击任务台窗口右上角的 [image] 图标即可。

参数说明

  • 操作对象：任务操作的资源（包括：集群、主机池、主机、虚拟机）。

  • 任务状态：以进度条和百分比数字显示任务操作的进度。

  • 操作员：创建该任务的操作员登录名。

  • 操作员IP：操作员创建该任务时所使用计算机的IP地址。

  • 开始时间：任务开始的时间。

  • 完成时间：任务结束的时间。

  • 执行结果：任务的执行结果。

  • 成功：表示任务执行成功。

  • 部分成功：表示任务执行部分成功。

  • 失败：表示任务执行失败。


常见问题

1. 访问CVM和CIC需要安装客户端吗？

不需要。

CVM和CIC完全基于标准的B/S架构，用户无需安装任何客户端。直接使用网络浏览器在地址栏中输入http://<CVM管理IP地址>:8080/cas或者https://<CVM管理IP地址>:8443/cas，即可访问CVM；在地址栏中输入http://<CIC管理IP地址>:8080/cic或者https://<CIC管理IP地址>:8443/cic，即可访问CIC。

例如：当CVM的管理IP地址为IPv4时，可在浏览器中输入：http:192.168.1.1:8080/cas或者https://192.168.1.1:8443/cas登录CVM。当CVM的管理IP地址为IPv6时，可在浏览器中输入：http://[172:20::2:31]:8080/cas或者https://[172:20::2:31]:8443/cas登录CVM。

2. 使用不同的浏览器访问CVM或CIC时，为什么页面显示效果不一致？

不同的浏览器对网页的解释方法有差异，但这对产品的功能没有影响，用户在使用过程中可以忽略。

3. 迁移虚拟机时，对虚拟机镜像文件所在的存储有什么要求？

  • 以“更改主机”方式迁移

若虚拟机镜像文件保存在共享存储系统下；虚拟机所在源和目的物理主机都挂了该共享存储系统。

  • 以“更改数据存储”或“更改主机和数据存储”方式迁移

  • 需确保源存储池的空闲容量，大于虚拟机存储卷的容量，才能成功迁移数据存储。当迁移后虚拟磁盘格式与源虚拟机不同时，还需确保目的存储池的可用空间至少是源虚拟机存储卷容量的两倍，否则可能导致迁移失败。

  • 虚拟机使用RBD网络存储时，不支持在线迁移数据存储。

  • 虚拟机存在快照时，迁移虚拟机的数据存储，要求源和目的存储池的类型一致，都为文件系统类型（本地文件目录或共享文件系统）或都为RBD网络存储。

4. 虚拟机备份过程中对服务器有什么配置要求？

备份过程中，对服务器有以下特殊配置要求：

  • 若将虚拟机备份到本地磁盘路径，需要该路径存在且可以写入。

  • 若将虚拟机备份到FTP服务器上，则FTP服务器上配置的用户对于在备份时使用的目录具有创建目录和上载的权限，并且配置的目录必须存在。

  • 若将虚拟机备份到SSH服务器上，则SSH服务器上配置的用户对于在备份时使用的目录具有创建目录和写的权限，并且配置的目录必须存在。

  • 若用户在备份过程中，将本地目录、FTP服务器上的目录或SSH服务器上的目录删除掉，会出现备份异常。如FTP方式，可能会将备份后的数据文件放到FTP用户的根目录下。

5. 增量备份文件丢失后，如何保证后续还原成功？

在导航树选中虚拟机，在右侧选择“备份管理”页签，单击虚拟机备份文件对应的还原。如果在选择的时间点之前有增量备份文件被删除或丢失（丢失的备份时间点是不会显示在界面上的），将会出现还原不成功的情况。

原则上备份的文件是不可以删除的，但由于人为原因或其他人力无法抗拒的原因导致备份的某部分文件丢失后，可以先进行一次全量备份，后续再次进行增量备份。

6. 为虚拟机增加多个串口后，为什么有的虚拟机不能显示全部串口信息？

这是由于虚拟机操作系统的类型导致的。

7. 在CVM中导入/还原虚拟机时，为什么导入/还原后的虚拟机只有单级镜像文件？

对于多级镜像文件的虚拟机，导入或还原后的虚拟机的多级镜像文件将会合并为一级，虚拟机镜像则变为单级镜像文件。

8. 如何处理存储池中“使用者”为空，且文件名称后缀为“_base_0”/“_base_1”的存储卷？

导入或还原虚拟机后，原有的多级镜像文件剩下的一级镜像文件“_base_1”和基础镜像文件“_base_0”，若该镜像文件“使用者”为空，则表示此镜像文件将不再被使用。为了清理存储空间，操作员可以在存储池中手动将其删除。

9. 如何更新Virtio硬盘的驱动程序？

当选择Virtio硬盘作为虚拟机的硬盘时，需要更新其驱动程序才能正常使用。

根据不同的情况，以Windows 7操作系统为例，更新驱动程序的方法如下：

  • 当Virtio硬盘作为虚拟机的系统硬盘时，在增加虚拟机操作完成后，还需要为虚拟机增加一个软驱，并挂接/vms/isos路径下名称以“virtio-win7”开头的文件。然后启动虚拟机进行操作系统的安装，在安装过程中，将会提示安装"Red Hat VirtIO SCSI controller"，单击<是>按钮即可。

  • 当Virtio硬盘作为虚拟机的普通硬盘时，在修改虚拟机操作完成后，还需要为虚拟机增加一个软驱，并挂接/vms/isos路径下名称以“virtio-win7”开头的文件。然后启动或重启虚拟机，虚拟机启动或重启后会提示安装设备驱动程序，将安装路径指定为A:\win7\x86。驱动程序安装完成后，在虚拟机的[计算机管理/磁盘管理]中可以发现该磁盘。

10. CVM和CIC对物理服务器有什么要求？

X86架构主机要求CPU支持Intel-VT或AMD-V虚拟化技术。

ARM架构主机要求CPU支持ARM8.1及以上版本，支持虚拟化主机扩展（VHE）技术。

推荐硬件配置：

  • CPU：

  • X86架构主机：支持Intel-VT或AMD-V虚拟化技术

  • ARM架构主机：支持VHE虚拟化技术

  • 内存：

  • X86架构主机：>32GB

  • ARM架构主机：>16GB

  • 硬盘：>300GB

  • 网卡：≥4个千兆以太网卡

  • 光驱：1个CD/DVD

11. 为什么在配置界面中没有找到组织、用户自助服务等云业务管理功能？

如果需要使用组织和用户自助服务功能，请确认已经安装了CIC和SSV组件，并注册了CIC License。

12. CVM和CIC中，是否支持通配符搜索？

在CVM和CIC的大部分查询框、搜索输入框中，支持通配符搜索。在界面右上角的搜索框和存储池对应的存储卷列表的搜索框中，不支持通配符搜索。

在CVM和CIC中“*”和“？”被定义为搜索通配符。

  • “*”可以匹配到任意长度字符。

  • “？”只能匹配到长度为1的字符。


故障处理

本文按以下几类对常见故障的处理方法进行介绍：

  • 访问类

  • 虚拟机相关

  • 集群/主机相关


访问类

1. 访问CVM或CIC时页面出现异常，如何处理？

问题现象：访问CVM或CIC时，页面样式混乱或数据显示异常。

可能原因：

  • 使用多个浏览器窗口访问CVM或CIC。由于不同的浏览器支持的能力有差异，在一台计算机上同时打开两个或以上浏览器窗口或在同一个浏览器中同时使用两个选项卡访问同一个CVM或CIC，可能会造成系统数据异常。

  • 频繁切换浏览器窗口大小。不同浏览器对网页的解释方法存在差异，频繁切换操作可能会出现页面样式混乱的情况。

  • 浏览器存在缓存。访问CVM或CIC时，浏览器显示的是缓存中的内容。

解决方法：

  • 在一台计算机上尽量只打开一个窗口访问CVM或CIC。

  • 定期清除浏览器的缓存，清除缓存后重新登录CVM或CIC。

2. 用户通过LDAP验证登录时，为什么无法登录？

问题现象：通过LDAP验证登录时，提示“用户名不存在或密码错误”。

可能原因：

  • 该用户是通过微软活动目录创建的，并且创建时在账户选项中默认设置了“用户下次登录时需更改密码”，CAS不支持此功能，所以用户无法登录。

  • 服务器设置了密码策略，导致用户登录密码过期。

用户账户在LDAP服务器中被管理员禁用。


虚拟机相关

1. 已经启用HA的集群中，为什么启动虚拟机失败？

可能原因：

  • 虚拟机的磁盘镜像文件不存在。

  • 虚拟机未挂载光驱。

  • 虚拟机网卡接入的交换机不存在。

  • 虚拟机磁盘文件的类型不正确。

  • 物理主机内存已被占满。

解决方法：

1. 检查虚拟机的磁盘镜像文件是否存在？文件大小是否正常？如果磁盘文件不存在或大小为0，请重新创建虚拟机。参考如下步骤：

  1. 展开CVM左侧“云资源”节点，选中虚拟机vm01，在右侧“概要”页签的“存储路径”中可以看到虚拟机的磁盘存放位置，比如/vms/target3/vm01；

  2. 选中虚拟机vm01所在的物理主机节点，右侧菜单中“存储”页签，选中路径为“/vms/target3”的存储，查看该存储下是否有vm01磁盘文件，其大小是否正常（不能为0）。

2. 检查虚拟机是否挂载了光驱，如果其源路径为“/dev/cdrom”，说明挂接了虚拟机所在服务器的物理光驱，请确认该服务器是否有物理光驱，如果没有，请断开虚拟机的光驱连接；如果光驱的源路径为某iso文件，例如为“/vms/isos/winxpsp3.iso”，则请确认该文件是否存在（请参考1中的步骤确认），如果不存在请断开光驱连接。查看虚拟机光驱信息的方法如下：

  1. 单击导航树中该虚拟机菜单项，进入虚拟机概要信息页面。

  2. 单击<修改虚拟机>按钮，进入修改虚拟机配置页面。

  3. 单击左侧导航<光驱>选项，如果右侧有<断开连接>按钮表示该虚拟机已挂接光驱或ISO，若要断开光驱连接，请直接单击<断开连接>即可；如果右侧有<连接>按钮表示该虚拟机没有挂接。

3. 查看虚拟机所有网卡接入的虚拟交换机是否存在，所引用的“网络策略模板”是否存在。如果不存在或不正确，请修改。

4. 请确认虚拟机磁盘文件的类型是否正确，参考如下步骤：

  1. 参考解决方法1中步骤b，记录磁盘文件的类型，比如qcow2；

  2. 参考解决方法2中的步骤a和b，进入修改虚拟机配置页面，选中磁盘，右侧菜单中的“存储格式”即描述了磁盘文件的格式。正常情况下，qcow2对应于“智能”，raw对应于“高速”。

5. 检查服务器内存是否已经已被其他启动的虚拟机占满了，如果是，请考虑增加服务器物理内存，或暂时关闭该服务器上其他的处于“运行”状态的但是暂不使用的虚拟机。

2. 虚拟机在安装操作系统过程中，对宿主机重启，导致无法继续安装操作系统怎么办？

问题现象：虚拟机在安装Windows XP操作系统过程中，虚拟机所在主机关闭。启动主机后，重新进入虚拟机失败，无法继续安装操作系统。

解决方法：

  • 重新启动虚拟机后，立即单击任意键，继续安装操作系统。

  • 重新创建虚拟机并安装操作系统。

3. 为什么虚拟机控制台无法响应键盘消息？

问题现象：虚拟机启动失败的情况下，通过控制台Ctl+Alt+Del重启失败后，虚拟机控制台无法再响应键盘消息。

可能原因：

  • Windows虚拟机磁盘损坏。

  • Windows虚拟机没有安装操作系统。

解决方法：

  • Windows虚拟机磁盘损坏。

在CVM上，为Windows虚拟机挂接上修复镜像ISO，修改虚拟机从光驱引导。重新启动虚拟机，同时打开该虚拟机的控制台，在第一次的时候提示从CD/DVD引导时，选择任意键从光驱引导进行修复，或重新安装即可。

  • Windows虚拟机没有安装操作系统。

为虚拟机挂接上待安装的操作系统ISO，或配置好网络安装。修改虚拟机从光驱引导或从网络引导，重新启动虚拟机，同时打开该虚拟机的控制台，安装对应的操作系统即可。

4. 对集群中的虚拟机执行某些操作时，操作成功，但界面提示失败？

问题现象：在集群启用/禁用HA功能过程中，或者集群启用HA功能后，对集群中的虚拟机进行启动、重启、关闭或休眠操作，有时会出现界面提示失败，但过一段时间后却看到实际操作已经成功。

问题原因：

  • 由于主机或者数据中心网络繁忙，导致上述操作结果返回时间超过1分钟等待阈值，系统因等待超时而认为该操作失败，但实际操作已经成功。

  • 虚拟机的存储或网络等配置错误，也会导致启动虚拟机操作失败。由于HA进程会对启动失败的虚拟机周期的启动该虚拟机，一旦虚拟机的存储或网络等配置恢复正常，虚拟机就会启动成功。

解决办法：

1. 检查网络是否出现拥塞，排查导致拥塞的原因；在主机或数据中心网络十分繁忙时，尽量减少或避免对已启用HA功能的集群进行虚拟机启动、关闭或休眠等操作。

2. 在启动虚拟机之前，请确保虚拟机的存储或网络等配置正确。

5. 在CAS管理平台上执行关闭或重启虚拟机操作失败

问题现象：虚拟机安装某些版本的Linux系统，在管理平台上执行关闭或重启操作，虚拟机内部在关闭过程中有时会打印"Disabling IRQ #10 BUG:Soft lockup -CPU#0 stuck for 67s! [migration/0:5]"类的字样，导致虚拟机无法正常关闭。

问题原因：一些版本的Linux系统对virtio网卡兼容性不好，安装此操作系统的虚机若使用virtio网卡，可能会出现此情况，使用普通网卡则不会出现。

解决办法：出现这种情况时，虚拟机内部系统关闭流程实际已基本结束，此时可以在管理平台上选择关闭电源来强制关闭虚拟机。

6. 对虚拟机进行操作时，提示“集群进程未启动”

问题现象：在已启用HA的集群中，对虚拟机进行启动、关闭、迁移等动作时，任务台会提示操作失败，并显示原因为“集群进程未启动”。

问题原因：虚拟机所在主机上的HA服务未启动。

解决办法：

1. 操作员可以根据实际情况，在以下方法中选择适用的方法。

  • 在系统中，对虚拟机所属的集群先执行禁用HA操作，再执行启动HA操作。待操作成功后，主机上的HA服务将会启动。

  • 以root用户登录虚拟机所在的主机，通过执行service corosync start命令，启动主机上的HA服务。

  • 重新启动虚拟机所在的主机。待主机启动后，HA服务将会启动。

2. 待根据上述方法完成操作后，再对虚拟机进行启动、关闭、迁移等动作即可。

7. 增加存储卷或者克隆虚拟机时报错该如何处理?

问题现象：在增加存储卷或者克隆虚拟机时，出现错误提示信息：“internal error pool iSCSITarget8-lun1 has asynchronous jobs running.”。

问题原因：

操作员执行了如下CVM或CIC不支持的操作：

  • 在一个存储池中同时创建多个存储卷。

  • 对镜像文件保存在同一个存储池中的多个虚拟机，同时执行克隆操作（即在一个存储池中同时刷新并读取多个存储卷）。

  • 同时克隆多个虚拟机，并将其镜像文件保存到同一个存储池中。

解决办法：操作失败后，重复执行相应的操作即可。

8. 在执行某些虚拟机操作时，提示“目的存储卷文件****已经存在”

问题现象：在执行迁移虚拟机、克隆虚拟机、部署虚拟机、将虚拟机克隆为模板、将虚拟机转换为模板操作的过程中，提示“目的存储卷文件****已经存在”。

问题原因：在执行上述操作的过程中，系统检测到目标存储池中已经存在与待拷贝的存储卷（即目的存储卷文件）同名的存储卷文件。

解决办法：

如果管理员不需要保留目标存储池中与待拷贝存储卷重名的存储文件，则删除该存储文件后，重新执行操作即可。如果管理员需要保留目标存储池中与待拷贝存储卷重名的存储文件，则具体操作如下：

  • 对于克隆虚拟机、部署虚拟机、将虚拟机克隆为模板、将虚拟机转换为模板操作：重新执行操作的过程中，更换虚拟机名称/虚拟机模板名称，或者更换目标存储池。

  • 对于迁移虚拟机操作：重新执行操作的过程中，更换目标存储池。

9. 跨CVM进行虚拟机操作后，虚拟机启动时找不到磁盘？

问题现象：跨CVM进行模板部署虚拟机、虚拟机备份、导入虚拟机、导入文件（P2V、V2V方式）操作后，虚拟机启动时，提示找不到磁盘。

问题原因：某些虚拟机（如openSUSE）需要依赖CVM的cid文件（cid是CVM的唯一标识）来识别磁盘分区，跨CVM操作时将导致虚拟机找不到磁盘。

解决办法：对于存在这种问题的虚拟机，不能使用by-id（在Linux操作系统的/dev/disk/by-id目录下依赖磁盘ID生成的标识符）的方式识别磁盘分区，可在/etc/fstab文件中将磁盘分区识别方式修改为by-uuid或by-path方式。

10. 本地导入虚拟机操作被中断，再次导入时提示“存储文件已存在”

问题现象：在CVM中本地目录方式导入虚拟机时，网络中断前台页面报未知异常，待网络恢复之后再次导入虚拟机，提示存储文件已存在。

问题原因：本地目录方式导入虚拟机，网络中断，后台脚本仍然在执行，后台导入成功，前台没有收到消息，故报未知异常；前台程序调用脚本没有获取返回结果“成功”，将不会去执行虚拟机数据入库、存储池刷新等动作，从而出现此问题中的现象。

解决办法：

1. 对虚拟机将要导入的主机执行连接主机操作。

2. 删除导入失败的虚拟机。

3. 进入主机的存储页签，刷新虚拟机镜像导入的存储池。

4. 删除对应的虚拟机镜像文件。

5. 待网络稳定之后再次导入虚拟机即可。

11. 主机上的虚拟机操作失败、运行状态的虚拟机突然暂停或状态变为“未知”？

问题现象：

  • 主机上的虚拟机操作失败。

  • 正在运行的虚拟机突然暂停或者虚拟机状态变为“未知”。

问题原因：主机系统根目录挂接的磁盘空间的可用空间不足，造成虚拟机无法运行。

解决方法：数据中心管理员在该主机上手动释放系统根目录下的空间。建议系统根目录下预留2G以上的空间，才能确保在CVM或CIC中正常管理该主机上的虚拟机。

12. 对虚拟机进行操作时，提示“连接主机失败”

CVM通过Libvirt连接一个主机的连接请求数量有限制，当超过的连接请求限制时，CVM或CIC会提示操作员“连接主机失败”。遇到这种情况时，可以稍后重试连接。

13. 虚拟机启用大页功能后，为什么在线迁移虚拟机失败？

问题现象：虚拟机启用大页功能后，在线迁移虚拟机，迁移失败并提示信息如下：虚拟机的内存大小不是目的主机内存页大小的整数倍，请修改虚拟机内存。

解决办法：关闭虚拟机，将其内存大小修改为目的主机内存页大小的整数倍。如果在虚拟机启用大页功能后，需要在线增加虚拟机内存，请确保增加的内存大小也是目的主机内存页大小的整数倍，否则也可能会导致迁移失败。

14. 虚拟机执行批量操作时，返回CVM/CIC登录界面或显示网络通信异常

问题现象：在主机的虚拟机列表页面中，对若干虚拟机进行批量操作（例如启动、关闭等），返回CVM/CIC登录界面或者显示网络通信异常页面。

问题原因：任务台刷新过于频繁。

解决方法：

  • 返回CVM或CIC登录界面的情况：重新登录CVM或CIC后，减少批量操作虚拟机的数量。

  • 显示网络通信异常页面的情况：刷新页面并重新登录CVM或CIC后，减少批量操作虚拟机的数量。

15. 执行动态资源扩展任务后，为什么虚拟机状态为“未知”？

问题现象：双机热备环境下执行动态资源扩展任务后，虚拟机状态显示为“未知”。

可能原因：虚拟机状态显示为“未知”可能是由于在双机热备环境下，配置动态资源扩展时将虚拟机回收模式配置为删除，当满足回收条件需要删除该虚拟机，后台执行删除完成而前台数据库未同步时发生主备倒换导致该虚拟机状态显示为“未知”并且在动态资源扩展业务中也存在该虚拟机。

解决方法：

1. 找到该虚拟机所在主机。

2. 单击导航树中[云资源/主机池/<主机名>]或者[云资源/主机池/集群/主机]菜单项，进入主机概要信息页面。

3. 单击<更多操作>按钮，选择[连接主机]菜单项，弹出连接主机确认对话框。

4. 单击<确定>按钮完成操作。

5. 重新连接主机后，该虚拟机即可正常删除并在动态资源扩展业务中消失。

16. 为什么通过CAStools设置虚拟机网络信息失败？

问题现象：使用Red Hat Enterprise Linux 7的虚拟机模板部署虚拟机成功后，通过CAStools设置网络信息失败。

问题原因：在Red Hat Enterprise Linux 7中默认使用NetworkManager守护进程来监控和管理网络设置，通过CAStools来修改虚拟机IP信息时，无法建立NetworkManager会话连接，重启虚拟机或服务后，默认自动连接到原会话连接。所以会导致设置失败。

解决办法：在制作RHEL 7操作系统的虚拟机模板之前，为虚拟机安装最新版本的CAStools，然后使用命令“chkconfig NetworkManager off”关闭NetworkManager服务，再制作模板。

17. 当使用同一串口的多台虚拟机同时运行时，为什么虚拟机无法进行通信？

问题原因：当使用同一串口的多台虚拟机同时处于运行状态时，该串口无法确定与哪一台虚拟机进行通信。

解决办法：当多台虚拟机使用同一串口时，每次只启动一台使用该串口的虚拟机。


集群/主机相关

1. 集群HA启用或者增加主机时，主机重启，导致主机不在集群中或者主机增加失败

问题现象：集群HA启用或者向主机池/集群增加主机的过程中，集群中的主机或者增加的主机因断电或者与存储设备连接不通而重启，导致主机不在集群中或者主机增加失败等情况。

解决方法：

  • 对于集群HA启用过程中出现上述情况，请先关闭该集群的HA功能，然后重新启用HA即解决该问题。

  • 对于向主机池/集群增加主机过程中出现上述情况，如果主机池/集群中出现该主机信息，需要先删除该主机，然后重新增加即解决该问题；如果主机池/集群中未出现该主机信息，直接重新增加该主机即可。

2. 当虚拟化管理服务器出现故障，应该如何恢复？

情形一：

当虚拟化管理服务器（即安装CVM或CVK的主机）仅作为管理服务器（仅安装CVM的主机），不作为业务服务器（即仅安装CVK的主机），并且存在HA集群时，如果该管理服务器出现故障，恢复方法如下：

1. 在虚拟化管理服务器上重新安装CVM和CVK，待完成后，登录新安装的虚拟化管理平台。同时，请确保原虚拟化管理平台中的业务服务器运行正常。

2. 创建一个空集群，并启动HA功能。

3. 将原HA集群中的任意一台主机增加到创建的集群中，系统会弹出增加主机确认对话框。通过选择对话框中的选项，对原集群的HA配置或者主机原有的共享文件系统进行恢复。选择完成后单击<确定>按钮，系统将会弹出增加主机对话框。

4. 在增加主机对话框的列表中，依次输入主机的root用户名和密码。输入完成后，单击<确定>按钮，将列表中的全部主机增加到虚拟化管理平台中。

情形二：

当虚拟化管理服务器（即安装CVM和CVK的主机）作为管理服务器的同时，又作为业务服务器（即仅安装CVK的主机），并将其加入HA集群。当该主机出现故障时，恢复方法如下：

1. 在主机上安装完成CVM和CVK后，为其配置与原先管理服务器相同的IP地址和主机名称。同时，请确保其他主机运行正常。

2. 登录新安装的虚拟化管理平台。创建一个空集群，并启动HA功能。

3. 将原HA集群中的任意一台主机（除管理服务器之外）增加到创建的集群中，系统会弹出增加主机确认对话框。通过选择对话框中的选项，对原集群的HA配置或者主机原有的共享文件系统进行恢复。选择完成后单击<确定>按钮，系统将会弹出增加主机对话框。

4. 在增加主机对话框的列表中，依次输入主机的root用户名和密码。输入完成后，单击<确定>按钮，将列表中的全部主机增加到虚拟化管理平台中。

5. 确认管理服务器是否已增加到集群中。如果存在，操作员需要先将管理服务器从集群中删除，然后再次加入集群；如果不存在，操作员需要将管理服务器增加到集群中。

3. 如何解决CVM中集群HA配置与实际HA配置不一致问题？

问题现象：在启用/禁用集群HA功能的过程中，如果集群中某台主机重启、关闭、网络出现故障，将会导致启用/禁用集群HA功能操作失败，此时CVM中集群HA配置会与实际主机上的HA配置不一致。

解决方法：

  • 主机故障可以在短期内恢复，解决方法为：待主机恢复正常后，再次启用/禁用集群HA功能即可。

  • 主机故障不能在短期内恢复，解决方法为：从集群中删除故障主机后，再次启用/禁用集群HA功能即可。

4. 如何处理主机在开机时有异常提示？

提示一：

主机在开机时提示“/dev/sda1: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY. Press F to attempt to fix the errors, I to ignore, S to skip mounting, or M for manual recovery”。

问题原因：文件系统损坏导致系统无法启动，通常是由于异常掉电、硬件损坏或非正常关闭主机系统等原因导致的。

解决办法：

1. 为保证数据安全，推荐使用F键进行自动修复，修复完成后执行reboot命令重启主机。

2. 若自动修复后仍然有上述提示，需要使用M键进行手工修复：输入root用户的密码后执行“fsck -y 出错的磁盘或分区”进行文件系统检查，例如“fsck -y /dev/sda1”，待文件系统检查完成后执行reboot命令重启主机。

提示二：

主机在开机时提示“The disk drive for /opt/mds/disk/1 is not present. Continue to wait, or Press S to skip mounting, or M for manual recovery”。

问题原因：磁盘或者分区无法识别导致的系统无法启动，通常是由于磁盘硬件损坏或磁盘不在位等原因造成的。

解决办法：

先按S键跳过，待主机启动完毕后检查磁盘状态是否正常。

  • 若磁盘状态正常，则无需做其他操作。

  • 若磁盘状态不正常，请自行修复磁盘。

为了避免主机开机时发生类似情况，可以在/etc/fstab中删除不能识别的磁盘或分区信息，或者在挂载选项中增加nobootwait字段，例如“UUID=2f943256-c904-45f7-9ad1-f3a79e7d70f3 /opt/mds/disk/1 ext4 nobootwait,defaults 0 2”。

5. 修改主机存储适配器的iqn标识符时报错

问题现象：在主机上删除共享存储池时，前台显示任务一直处于“执行”状态，刷新浏览器页面后，该存储池被删除。当修改该主机存储适配器的iqn标识符时，弹出提示“iSCSI正在被使用，不允许修改其配置文件（错误码为：5029）”。

可能原因：主机和共享存储之间的链路故障，主机和共享存储之间无法正常通信。当管理员在CVM上执行删除共享存储池的操作后，主机无法正常删除该共享存储池。当刷新浏览器页面后，前台虽然显示存储池已被删除，但是主机和存储池之间的会话连接还存在。

解决方法：

1. SSH登录到对应的物理服务器上。

2. 使用命令iscsiadm -m session查看主机和存储池之间的会话是否存在。

  • 如果会话存在，请执行下面的步骤。

删除 /etc/iscsi/nodes 目录下以对应主机iqn标识符命名的文件夹。

删除 /etc/iscsi/send_targets 目录下以对应存储服务器IP地址命名的文件夹。

  • 如果不存在，请联系技术支持。

6. 修改CVM主机的系统时间后，定时策略任务不生效

问题现象：修改CVM主机的系统时间后，定时策略任务（如快照策略、备份策略、动态资源定时扩展策略等）不生效。

可能原因：修改了CVM主机的系统时间，导致CVM的主机时间与tomcat、casserver程序内部的时间不一致。

解决方法：

1. 使用SSH登录到CVM管理平台所在主机。

2. 执行service tomcat8 restart命令，重启tomcat服务（该操作会导致CVM管理平台不可用，请确保管理平台没有正在执行的任务，同时不要再对管理平台进行操作）。

3. 执行service casserver restart命令，重启casserver服务。

7. 修改网络策略模板时报错

问题现象：修改网络策略模板时，显示如下错误信息：“Domain not found: no domain with matching uuid '06753ef3-7ead-42b1-9b7b-f7b09f53c8ec' ”。

问题原因：引用该网络策略模板的虚拟机在CAS中存在，但是在物理主机上不存在。

解决方法：首先从CAS中删除与该网络策略模板存在引用关系的处于“未知”状态的虚拟机，然后再修改该网络策略模板。


存储相关

1. 创建“iSCSI共享文件系统”类型的存储池时报错

问题现象：创建“iSCSI共享文件系统”类型的存储池时，出现错误信息“internal error Child process (/bin/mount -t ocfs2 /dev/disk/by-path/ip-192.168.10.1:3260-iscsi-iqn.2007-04.com.xxx:storware.target4-lun-0 /vms/target4) status unexpected: exit status 1”。

问题原因：iSCSI存储上配置的物理主机对于Target的权限为只读。修改其权限为非独占式读写时，由于物理主机和iSCSI存储之间的session（会话）已经建立，无法重新赋予物理主机权限。需要使用SSH或其它方式登录到物理主机上，手动断开物理主机和iSCSI存储Target之间的会话。

解决方法：

1. 使用SSH方式登录到对应的物理服务器上。

2. 执行命令iscsiadm -m session查询对应的session会话，如查询出结果如下。

root@vmc-10:/vms/isos# iscsiadm -m session

tcp: [2] 192.168.10.1:3260,1 iqn.2007-04.com.xxx:storware.target4

tcp: [4] 192.168.10.1:3260,1 iqn.2007-04.com.xxx:storware.640f02.target3

3. 选择需要断开的Target会话。如Target iqn.2007-04.com.xxx:storware.target4，则执行如下命令。

root@vmc-10:/vms/isos# iscsiadm -m node -T iqn.2007-04.com.xxx:storware.target4 -u -p 192.168.10.1

Logging out of session [sid: 2, target: iqn.2007-04.com.xxx:storware.target4, portal: 192.168.10.1

4. 在iSCSI存储管理器上，将对应的物理主机从iqn.2007-04.com.xxx:storware.target4上取消关联即可。

2. 删除Target中的逻辑资源，为什么使用该Target的物理主机会重启？

问题现象：在iSCSI存储管理器上删除共享文件系统使用的Target中的逻辑资源时，使用该Target的物理主机会重启。

问题原因：物理主机使用共享文件系统的时候，会定期的向设备上写时间戳，当设备连接不通时，会重启物理主机。

例如物理主机A使用了共享文件系统target3，共享文件系统target3基于iSCSI存储上的target3，其中target3使用SAN-03作为逻辑资源。当主机A正在使用共享文件系统target3时，管理员在iSCSI存储管理器上将SAN-03从target3的逻辑资源中删除，这时候物理主机A上的虚拟机vmc-6在写设备的时候，就会失败，从而检测到设备的异常，物理主机A会重启。

注意事项：在iSCSI存储管理器上删除Target使用的逻辑资源是一项高风险操作。在执行该删除操作前，管理员需要在CVM上确认是否有物理主机使用Target作为共享文件系统，从而预先评估该风险和其它的类似风险。

3. 如何对已经是共享文件系统的磁盘进行格式化处理？

问题现象：对已经是共享文件系统的存储池进行格式化操作时，出现如下错提示信息：“没有主机引用该存储池”或“设备忙，请稍候再试”。

问题原因：

  • 没有主机引用该存储池。

  • 主机已经引用了该共享文件系统存储池，使共享文件系统存储池处于激活状态。

解决办法：

  • 若报“没有主机引用该存储池”错误信息，请执行以下步骤：

  1. 在主机池中选择一个主机，如cvk-1。

  2. 在主机cvk-1的概览页面中选择“存储”页签，单击“增加”按钮，在其存储池中增加该共享文件系统的存储池，并在cvk-1主机上暂停该存储池。

  3. 在主机池上对该共享文件系统进行格式化处理。

  • 若报“设备忙，请稍候再试”错误信息，请执行以下步骤：

  1. 在所有引用该共享文件系统的主机上，在存储条目后，单击<暂停存储池>按钮，将该存储池暂停。

  2. 在主机池上对该共享文件系统进行格式化处理。

4. 共享文件系统的存储硬件扩容后，为什么在CVM中查看存储池容量未增加？

问题现象：在共享文件系统的存储硬件扩容后，在系统中查看使用该共享文件系统的存储池容量，发现其并未增加。

解决办法：

备份共享文件系统中的文件之后，在系统中对扩容后的共享文件系统进行格式化。

推荐操作步骤如下：

1. 对共享文件系统中的文件备份。

2. 在所有使用该共享文件系统的主机对应的存储池列表中，删除该共享文件系统对应的存储池中虚拟机正在使用的全部文件；

3. 删除完成后，暂停该共享文件系统对应的存储池；

4. 在主机所属主机池对应的共享文件系统信息列表中，对该共享文件系统进行格式化；

5. 格式化完成后，将之前备份的文件拷回该共享文件系统中；

6. 在所有使用该共享文件系统的主机对应的存储池列表中，启动该共享文件系统对应的存储池。

7. 完成上述操作后，该共享文件系统对应的存储池可以正常使用。

5. 共享文件系统存储池的格式化过程被中断，后续无法使用存储池怎么办？

问题现象：共享文件系统存储池的格式化过程突然被中断，或格式化中途被终止，如主机突然重启或其他类似异常情况，导致格式化工作没有完整完成，后续无法使用存储池。

解决办法：选择[主机池/共享文件系统]，找到对应的共享文件系统，选择其后的“磁盘分区格式化”按钮，重新对共享文件系统格式化；待格式化完成后，再次使用存储池即可。

6. 为什么在CVM中刷新Windows系统共享目录类型存储池的状态和卷信息时，等待时间较长？

问题现象：Windows系统共享目录类型的存储池在Windows服务器停机、网卡Down或者停止共享后，在CVM中刷新存储池的状态和卷信息时，需要等待较长时间。

问题原因：由于受到底层文件共享协议的限制，Windows系统共享目录服务不通时，第一次查看主机的存储页签时需要等待较长时间（大约3分钟）；查看存储池的状态和卷信息时，可能需要等待较长时间（大约1分钟）。

7. 下载存储卷时，系统提示文件拷贝错误

问题现象：对一个较大的存储卷执行下载操作后，在下载完成之前，重新下载该存储卷，系统提示文件拷贝错误。

问题原因：重新下载同一个存储卷，系统将重新拷贝存储卷文件，并将前一次下载（即拷贝）未完成的文件覆盖，导致两次下载操作都出现错误。系统只会对第二次下载操作提示文件拷贝错误。

解决方法：等待一段时间之后，重新对存储卷执行下载操作。

8. 在存储设备上改变LUN映射关系，为什么对应的存储池无法启动？

可能原因：在存储设备端改变LUN的权限映射关系之前没有在系统中暂停或删除对应的存储池。该操作会导致主机内核中存储设备状态发生变化，系统无法自动处理，导致存储池不能被启动。强行执行该操作可能会导致数据被破坏。

解决方法：

1. 在异常的主机上删除该存储池。

2. 为异常主机重新创建该存储池。

9. 主机上增加FC网络存储失败

问题现象：主机上增加FC网络存储时，弹出错误信息：“An error occurred,but the cause is unknown”。

问题原因：主机无法自动更新FC LUN的信息。

解决办法：

  • 在主机上进行相应的维护操作，然后重新添加FC LUN。维护操作过程：“选择主机→存储适配器→选择相应的HBA卡→正常扫描（强制扫描）”。

  • 重启主机，重新初始化主机并获取FC LUN信息，然后重新为主机添加FC LUN。

10. 为主机增加iSCSI共享文件系统，为什么长时间没有响应？

问题现象：iSCSI存储设备在主机池上配置为共享文件系统，管理员通过SSH或者终端在主机上使用命令行，手工为主机池对应Target的LUN划分PV、VG或LV。然后再通过CVM为主机增加共享文件系统，前台长时间显示处于执行的状态条，没有响应。

产生原因：共享文件系统不支持在OCFS2格式的磁盘上创建PV、VG和LV，会使加载进程阻塞，从而导致无法加载存储池的情况。

解决办法：

1. 在存储设备上依次删除对应的LV、VG、PV。

2. 在主机池共享文件系统部分，对于该Target的LUN磁盘重新进行格式化处理。

3. 再次为主机引用共享文件系统存储池。

11. 为什么CVK主机无法正常启动共享存储？

问题现象：使用FC SAN或iSCSI SAN存储服务器上虚拟磁盘的CVK主机无法正常启动共享存储。

问题原因：FC SAN或iSCSI SAN存储服务器上的主机可访问权限为只读。

解决方法：

1. 在CVM中，将该CVK主机上的虚拟机迁移到其它主机上去，或者进入维护模式。

2. 暂停该CVK主机上的所有共享文件系统。

3. 在FC SAN或者iSCSI SAN存储服务器上，将主机可访问权限设置为可读写。

4. 重启该CVK主机。

5. 启动该CVK主机上的共享文件系统。

6. 将该CVK主机上迁出的虚拟机迁回，或者退出维护模式。

12. 在CVM中增加Windows系统共享目录存储池时报错

问题现象：在CVM中增加Windows系统共享目录存储池时，会出现如下提示信息报错：“Requested operation is not valid: CIFS server maybe not available, please check the configuration”。

问题原因：Windows共享目录所在的源服务器上“Internet协议版本4（TCP/IPv4）”常规选项卡设置的IP与高级选项卡设置的IP不一致。

解决办法：

1. 在Windows共享目录所在的源服务器上打开本地连接属性。

2. 在属性窗口的“网络”选项卡中选择“Internet协议版本4（TCP/IPv4）”后，单击“属性”按钮。

3. 然后在打开的“Internet协议版本4（TCP/IPv4）”常规选项卡窗口中确认选中的选项。

  • 如果选中的是“自动获得IP地址”，则单击“高级”按钮，在“高级TCP/IP设置”窗口中选择“WINS”选项卡，在“NetBIOS设置”区域中选择“启用TCP/IP上的NetBIOS”。

  • 如果选中的是“使用下面的IP地址”，则在“高级TCP/IP设置”窗口中选择“IP设置”选项卡，删除“IP地址”区域中多余的IP地址，只留下“Internet协议版本4（TCP/IPv4）”中常规选项卡设置的IP地址。

13. 在CVM中暂停或者删除存储池时报错

问题现象：在CVM中暂停或者删除存储池时，出现如下提示信息报错：“internal error Child process (/bin/umount /vms/target3) status unexpected: exit status 1”。

问题原因：服务器上某些进程正在使用存储池挂接的目录，导致umount命令执行失败。

问题解决：

1. 采用SSH方式登录到对应的物理服务器上。

2. 假设存储池挂接在/vms/target3目录下，则执行命令lsof +d /vms/target3查询出所有使用该目录的进程。

root@vmc-216:~# lsof +d /vms/target3

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME

bash 11349 root cwd DIR 8,16 3896 513 /vms/target3

vim 12138 root cwd DIR 8,16 3896 513 /vms/target3

vim 12138 root 3u REG 8,16 12288 1412504 /vms/target3/.test.txt.swp

3. 采用“kill -9 进程号”方式结束所有查询出来的进程。

root@vmc-216:~# kill -9 11349

root@vmc-216:~# lsof +d /vms/target3

执行完一次kill -9之后，需要重新执行命令lsof +d /vms/target3进行查询，直到没有进程为止。

4. 此时在CVM中，对应的存储池就可以暂停或删除了。

共享文件系统类型的存储池不能作为NFS或者其他文件系统使用，只能作为本地CVK的镜像存储使用，否则可能也会导致umount失败（执行lsof命令无法查询出哪些进程在使用该存储池）或者其他问题。

14. 在CVM中上传或下载文件时，提示“存储池资源剩余空间不足”时如何处理？

问题原因：由于CVM的/vms目录剩余空间不够导致。

解决方法：查看/vms目录下的剩余空间大小，释放/vms目录下的空间，删除不需要的文件或者将文件转移到其他位置，保证/vms目录剩余空间大小为需要上传或下载文件大小的两倍以上。


常用词

  • 超级管理员

具有系统中所有的操作执行权限和所有的资源访问权限。对于公有云，超级管理员是运营商数据中心管理员；对于私有云，超级管理员是企业或机构的IT管理员。

  • 云资源

CAS云计算管理平台分层管理模型的核心节点之一，用来统一管理数据中心内所有的、复杂的硬件基础设施，不仅包括基本的IT基础设施（如硬件服务器系统），还包括其它与之配套的设备（如网络和存储系统）。

  • 虚拟机

虚拟机是运行在物理服务器上的操作系统和应用程序，多个虚拟机可以同时使用同一个物理服务器提供的底层硬件资源，运行不同的操作系统（如Windows、Linux等）和应用程序，它包含自己的虚拟CPU、内存、硬盘和网络接口卡（NIC）等。

  • 主机

即实体服务器。主机的作用是为虚拟机提供硬件环境，主机有时也可称为“宿主”。

  • 集群

由物理主机和虚拟机组成的计算资源集合，用来提供虚拟化环境下的高可靠性和高可用性。

集群是CAS云计算管理平台基础架构管理中的一个新概念，其目的是使用户可以像管理单个实体一样轻松地管理多个主机和虚拟机，从而降低管理的复杂度，同时定时对集群内的主机和虚拟机状态进行监测，如果一台服务器主机出现故障，运行于这台主机上的所有虚拟机都可以在集群中的其它主机上重新启动，保证了数据中心业务的连续性。

  • 主机池

主机池是一个逻辑概念，用于管理数据中心内的集群与主机。

  • 虚拟机模板

在一台虚拟机的基础上，“转换”或“克隆”出来的复制品。通过虚拟机模板，用户能以复制的形式，快速、批量的创建具有标准化硬件配置和软件功能的虚拟机。

  • 虚拟交换机

内置在虚拟化网络环境中的流量控制软件，通过模拟实体交换机，能够对虚拟机之间的网络流量进行安全隔离、限速、聚合等功能。

  • 网络策略模板

一组网络控制功能的集合，如QoS、VLAN、端口绑定等。一般情况下，同一个部门的虚拟机具有相同的网络策略需求，此时，可以通过定义网络策略模板的方式，在为这些部门创建虚拟机的时候，部署相同的网络策略模板。


图例

  • 集群状态图例

图例 | 含义 | 产生条件 | 解决办法
 | 集群启用了HA功能 | 正常启用集群的HA功能 | －
 | 集群未启用HA功能 | 未启用集群的HA功能 | －

  • 主机状态图例

图例

含义

产生条件

解决办法

主机连接状态正常

主机成功加入到CVM管理平台中，并且运行正常

－

主机连接状态错误

  • 主机电源接触不良

  • 主机处于关闭状态

  • 主机密码被修改

  • 主机管理网络异常

  • CVM管理平台与主机之间的Libvirt连接异常

  • 检查主机电源是否接通

  • 检查主机是否处于启动状态

  • 检查主机密码是否正确

  • 检查主机管理网络是否正常

  • 检查主机Libvirt服务是否处于运行状态，若异常，请联系技术支持工程师

主机处于维护状态

  • 管理员手动将主机进入维护模式

  • HA数据同步使主机进入维护模式

  • 管理员手动将主机退出维护模式

  • 等待HA同步完成后主机会自动退出维护模式，最长不超过10分钟

主机不受集群HA管理

主机加入集群HA时，与集群HA通信失败导致加入失败

选中异常主机，单击右键，选择<加入集群>按钮，重新执行加入集群HA操作

  • 虚拟机状态图例

图例

含义

产生条件

解决办法

虚拟机处于运行状态

虚拟机正常运行中

－

虚拟机处于暂停状态

  • 管理员手动暂停虚拟机

  • 在启用HA的集群中，共享存储故障，系统冻结受影响的虚拟机

  • 虚拟机迁移时，迁移超时时长到期后，系统暂停还未迁移完成的虚拟机

  • 管理员手动恢复虚拟机

  • 共享存储恢复正常后，被冻结的虚拟机将自动恢复为运行状态

  • 虚拟机迁移完成后，系统会自动将虚拟机恢复为运行状态

虚拟机处于关闭状态

  • 管理员手动关闭或休眠虚拟机

  • 动态资源扩展业务生效，业务虚拟机被回收

  • 管理员手动启动虚拟机

  • 动态资源扩展业务满足资源扩展条件时，系统会自动启动被回收的业务虚拟机

虚拟机处于未知状态（连接发生错误）

  • 系统未收到该虚拟机的性能数据

  • 前后台数据不同步，虚拟机实际不在该主机上

  • 查看虚拟机、虚拟机所在主机是否有性能数据；若无，请联系技术支持工程师

  • 确认主机上是否存在该虚拟机，若无，请联系技术支持工程师

虚拟机处于HA异常状态

  • 虚拟机所在主机HA异常，该主机上所有虚拟机均处于HA异常状态

  • 主机HA状态正常，但虚拟机加入集群HA失败

  • 选中异常主机，单击右键，选择<加入集群>按钮，重新执行加入集群HA操作

  • 在虚拟机概要页面，单击虚拟机状态处的 [image] 图标